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法律资讯

警告提示系统

为了您的人身安全以及避免财产损失，必须注意本手册中的提示。人身安全的提示用一个警告三角表示，仅与财产

损失有关的提示不带警告三角。警告提示根据危险等级由高到低如下表示。

危险

表示如果不采取相应的小心措施，将会导致死亡或者严重的人身伤害。

警告

表示如果不采取相应的小心措施，可能导致死亡或者严重的人身伤害。

小心

表示如果不采取相应的小心措施，可能导致轻微的人身伤害。

注意

表示如果不采取相应的小心措施，可能导致财产损失。

当出现多个危险等级的情况下，每次总是使用最高等级的警告提示。如果在某个警告提示中带有警告可能导致人身

伤害的警告三角，则可能在该警告提示中另外还附带有可能导致财产损失的警告。

合格的专业人员

本文件所属的产品/系统只允许由符合各项工作要求的合格人员进行操作。其操作必须遵照各自附带的文件说明，特

别是其中的安全及警告提示。 由于具备相关培训及经验，合格人员可以察觉本产品/系统的风险，并避免可能的危

险。

按规定使用 Siemens 产品

请注意下列说明：

警告

Siemens 产品只允许用于目录和相关技术文件中规定的使用情况。如果要使用其他公司的产品和组件，必须得到 
Siemens 推荐和允许。正确的运输、储存、组装、装配、安装、调试、操作和维护是产品安全、正常运行的前提。

必须保证允许的环境条件。必须注意相关文件中的提示。

商标

所有带有标记符号 ® 的都是西门子股份有限公司的注册商标。本印刷品中的其他符号可能是一些其他商标。若第三

方出于自身目的使用这些商标，将侵害其所有者的权利。

责任免除

我们已对印刷品中所述内容与硬件和软件的一致性作过检查。然而不排除存在偏差的可能性，因此我们不保证印刷

品中所述内容与硬件和软件完全一致。印刷品中的数据都按规定经过检测，必要的修正值包含在下一版本中。

Siemens AG
Division Process Industries and Drives
Postfach 48 48
90026 NÜRNBERG
德国

A5E39221328-AC
Ⓟ 12/2017 本公司保留更改的权利

Copyright © Siemens AG 2017.
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安全性信息 1
Siemens 为其产品及解决方案提供了工业信息安全功能，以支持工厂、系统、机器和网络

的安全运行。

为了防止工厂、系统、机器和网络受到网络攻击，需要实施并持续维护先进且全面的工业

信息安全保护机制。Siemens 的产品和解决方案仅构成此类概念的其中一个要素。

客户负责防止其工厂、系统、机器和网络受到未经授权的访问。只有在必要时并采取适当

安全措施（例如，使用防火墙和网络分段）的情况下，才能将系统、机器和组件连接到企

业网络或 Internet。 

此外，应考虑遵循 Siemens 有关相应信息安全措施的指南。更多有关工业信息安全的信

息，请访问 https://www.siemens.com/industrialsecurity。

Siemens 不断对产品和解决方案进行开发和完善以提高安全性。Siemens 强烈建议您及时

更新产品并始终使用最新产品版本。如果使用的产品版本不再受支持，或者未能应用最新

的更新程序，客户遭受网络攻击的风险会增加。

要及时了解有关产品更新的信息，请订阅 Siemens 工业信息安全 RSS 源，网址为 https://
www.siemens.com/industrialsecurity。
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前言 2
本文档的用途

本文档说明使用 PCS 7 过程控制系统优化工厂组态的方法。通过示例，可以了解各个组态

任务。

其中会学到以下知识：

● 如何得到工厂各阶段过程控制组态的技术结构

● 如何使用不同的视图（组件视图、工厂视图、过程对象视图）

● 组态期间要历经哪些阶段

● 如何构造工厂

● 如何创建过程变量类型和模型

本文档详细介绍了以下主题；这些主题在其它手册中没有介绍：

● 组态过程控制系统

● 使用工厂层级 (PH) 和过程对象视图 (POV)

● 使用导入/导出助手 (IEA)

指导

本文档深入介绍了 PCS 7 的主要功能。还可以将此文档用作参考并阅读所需的具体信

息。 

文中按顺序对组态任务进行了介绍，以便用户学会如何快速而有效的组态。手册还提供了

所有组态任务的重要背景信息和相互关系，以阐明它们在整个系统中的重要性和前后关

系。 

所有工作指令都可通过菜单栏中的菜单命令进行访问。对于其中的许多功能，您还可以选

择使用各对象的快捷菜单中的命令。

工程组态系统 (V9.0 SP1)
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访问 PCS 7 文档的方式

PCS 7 所需的文档包括以下类型：

● PCS 7 自述文件

自述文件提供两个版本：

– PCS 7 自述文件（离线）

该版本通过 PCS 7 安装程序安装。该文件仅包含常规信息以及文档的 Internet 链接。

– PCS 7 自述文件（在线）

该版本包含有关安装和使用 PCS 7 的所有信息，并以您熟悉的格式提供。该文件只

在 Internet 上提供，以便其始终保持最新。 

说明

Internet 上的 PCS 7 自述文件（在线）中提供的信息优先于所有其他 PCS 7 文
档。 
请仔细阅读该 PCS 7 自述文件，因为其中包含有关 PCS 7 的重要信息和修正。

● PUD Manager
“PUD Manager”是一款用于访问文档的创新式工具，随 PCS 7 DVD 一起提供。 
其具备的一些亮点包括：

– 创建您自己的手册汇集。 
– 根据您的需要自定义文档集。 
– 提供用于访问您的信息的高效搜索引擎。

要安装 PUD Manager 并整合文档，请参见 Siemens 工业支持 (https://
support.industry.siemens.com/cs/cn/zh/view/109748882/en?dl=en)。
PUD Manager 位于 SIMATIC 管理器的以下路径中：

“SIMATIC Manager > 帮助> 简介”(SIMATIC Manager > Help > Introduction)
（STEP 7 在线帮助的路径为“SIMATIC Manager > 帮助 > 目录”(SIMATIC Manager > 
Help > Contents)）

● PCS 7 系统文档

系统文档包含了多种产品的信息，如组态手册和入门手册。此文档用作整个系统的指

南，说明了各个硬件和软件组件之间的交互。

有关“PCS 7 文档门户设置”的相关信息，请参见产品概述《过程控制系统 PCS 7；
PCS 7 ‑ 文档》(Process Control System PCS 7; PCS 7 ‑ Documentation)；“访问文

档的方式”部分。

前言
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● PCS 7 产品文档

产品文档包含有关特殊硬件和软件组件的信息。各个文档提供了有关特定组件的详细信

息。

● PCS 7 技术信息和解决方案 
有关重要的技术信息和解决方案，请参见 SIMATIC PCS 7 概述 (https://
support.industry.siemens.com/cs/cn/zh/view/63481413)。

完整版本的文档可在“SIMATIC PCS 7 技术文档”网站找到：

www.siemens.com/pcs7-documentation (www.siemens.com/pcs7-documentation)

更多相关信息，请参见产品概述《过程控制系统 PCS 7；PCS 7 - 文档》(Process Control 
System PCS 7; PCS 7 - Documentation)；“访问文档的方式”部分。

所需基础知识

要理解本文档，需要具备自动化工程领域的常识和 PCS°7 的基础知识。我们还假定读者了

解如何使用安装有 Windows 操作系统的计算机或是与 PC 类似的其它设备（如编程设

备）。 

组态手册和 PCS 7 的《入门指南》文档将向您提供有关使用 PCS 7 的基本信息。

入门指南的第 1 部分和第 2 部分

《PCS 7 入门指南 - 第 1 部分》(PCS 7 Getting Started - Part 1) 专为 PCS 7 新手编写。提

供 PCS 7 过程控制系统的初步概述，从而您能够自行创建一个简单的项目。项目是在现

有 SIMATIC 站上进行组态的。 

《PCS 7 入门指南 - 第 2 部分》(PCS 7 Getting Started - Part 2) 可供已经阅读了《入门指

南 - 第 1 部分》 的用户使用。其中介绍了可用于快速有效地进行工厂组态的 PCS 7 功能。

这些功能尤其适用于大型复杂工厂的组态。 

《PCS 7 入门指南 - 第 1 部分》和《PCS 7 入门指南 - 第 2 部分》使用标准示例项目

“color_gs”介绍功能。同时还指出了正确的组态顺序。 

您可以从 Internet (www.siemens.com/pcs7-documentation) 下载完整的 PCS 7 项目

“color_gs”和文档《入门指南 - 第 1 部分》(Getting Started - Part 1)：

1. 选择相应 PCS 7 版本的手册。

2. 单击《PCS 7 入门指南 - 第 1 部分》(PCS 7 Getting Started - Part 1) 的链接。

3. 单击以下图标，下载项目：

前言
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约定

在本文档中，软件界面元素的名称使用的语言与本文档的语言一致。如果为操作系统安装

了多语言软件包，则在切换语言后某些名称将会以操作系统的基本语言显示，因此，会与

文档中所用的名称不同。

 如果使用 Windows 10 操作系统，则可以在“开始”(Start) 菜单“所有程序 > Siemens 自
动化”(All programs > Siemens Automation) 下找到 Siemens SIMATIC 程序。

相对于先前版本的变更 

以下内容概括说明了其中最重要的更改：

● 自 V9.0 起
基于以下在 PROFINET 上组态分布式 IO 系统：

ET 200SP HA
紧凑型现场单元 (CFU)
帮助按钮作为一项可选设置用于替代报警信息 
PCS 7 工程组态系统的新生命周期商业模型。

参见

组态逻辑运算 (页 483)

组态 PCS 7 消息系统 (页 221)

前言
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使用 PCS 7 文档 3
3.1 PCS 7 工程系统组态手册指南

基本结构

PCS 7 工程组态系统组态手册分为以下三个部分：     

部分 内容

为 PCS 7 设备确定组件和系统

规划工厂的工程组态 此部分包含根据 PCS 7 工厂要求选择正确系统和组件时所需的所

有信息。 

其中完整地概述了 PCS 7 中以下组件的安装选项：

● 自动化系统

● 分布式 I/O
● 总线系统

● 网络

组装组件和系统

PCS 7 工厂结构 该指南部分引导用户了解手册中有关安装硬件组件的说明。此外，

还提供了有关 PCS 7 和 SIMATIC 使用差别方面的信息和规则。 

工程组态

工程组态的基本概念 介绍如何使用 PCS 7 来实现高效工程组态要求（例如类型定义、

复用性、集中编辑）。

PCS 7 工程组态系统

的组态

介绍 PCS 7 工程组态软件的结构和用途

实施 PCS 7 组态 就完成 PCS 7 的组态提供了分步操作说明以及关系和背景信息

有关工厂工程组态的

数据交换

对导入/导出功能进行了逐步说明，并介绍了关系和背景信息

编译和下载 介绍如何编译组态数据并将其下载到 CPU（AS、OS）。

测试 概述了调试前最重要的测试选项

工程组态系统 (V9.0 SP1)
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部分 内容

使用 VXM 比较项目

版本

说明如何使用 Version Cross Manager 比较不同的项目版本

维护和诊断 提供有关诊断、服务支持、数据安全性、版本控制和备份项目数据

方面的信息

使用 PCS 7 文档

3.1 PCS 7 工程系统组态手册指南
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规划工厂的工程组态 4
4.1 系统 ID

“系统 ID”用于提供透明度和最有效的技术支持。

“系统 ID”是根据终端用户、现场、工厂和生产单元标识特定 PCS 7 系统的唯一密钥。

该密钥在整个 PCS 7 系统使用期内保持不变。它与所有报价、订单、服务合同等相关联。

工程组态系统 (V9.0 SP1)
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创建和处理系统 ID

以下步骤描述了系统 ID 的创建和处理：

1. 通过网站 www.siemens.com/SIDregistry (www.siemens.com/SIDregistry) 注册新项目，可
提供唯一的系统 ID。

说明

如果在 SIMATIC 管理器中打开无“系统 ID”的项目，“打开多项目”(Open Multiproject) 
对话框将弹出消息“您是否已经注册 SID（系统标识编号）？如果未注册，请登录 
www.siemens.com/SIDregistry 网站注册！”。此消息为用户提供了接收注册系统 ID 
的选项。

2. 对于多项目情况，可在“系统 ID”(System ID) 字段下输入系统 ID，如下图所示：

说明

多项目的“系统 ID”复制至所有子项目中。

3. 对于 PCS 7 项目，可在“系统 ID”(System ID) 字段下输入系统 ID，如下图所示：

规划工厂的工程组态

4.1 系统 ID
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说明

在 ES 项目中输入系统 ID 后，SIMATIC Management Console 可使用系统 ID 检索项

目清单数据。

说明

“系统 ID”是根据终端用户、现场、工厂和生产单元标识特定 PCS 7 系统的唯一密钥。

该密钥在整个 PCS 7 系统使用期内保持不变。它与所有报价、订单、服务合同等相关

联。

规划工厂的工程组态

4.1 系统 ID
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4.2 工程开始前的注意事项

工厂规划方面的重要问题

建议您仔细研究下表中所列的问题。这将有助于您进行有效的工厂规划。在“本手册中的

附加部分”标题下，可跳转到含有帮助解答这些问题的更多信息和概述的部分。     

注意

安全性概念

作为常规安全措施，Siemens 推荐使用适当的程序保护到工业产品的网络访问。建议根

据白皮书《过程控制系统 PCS 7；PSC 7 安全概念》(Process Control System; Security 
Concept) 组态

环境，以便在受保护的 IT 环境中运行此类产品。 
这尤其适用于在工厂中通过用于维护和/或运行安全相关设备的 PC 组件访问：

● 我们建议仅通过过程控制网络的 PC 组件进行安全相关设备的维护和/或运行。 
● 不建议在企业控制网络内使用 Web 客户端维护和/或运行安全相关设备。

但如果决定在企业控制网络内使用 Web 客户端来维护和/或运行安全相关设备，我们建议：
将使用权限限制为只读访问。

问题 本手册中的相关主题 执行以下任务

需要了解...
本手册中包含更多信息的部分 

需要了解哪些文档？ 需要文档的各个处理阶

段：

● 规划

● 组态

● 调试

快速找到所需的信息 ● PCS 7 工程系统组态手册指

南 (页 21) 

应如何控制工厂以及

工厂应如何对中断情

况做出响应？

● 过程类型：连续或非

连续运行

● 自动化等级

● 可控性（中央/本地）

● 可用性

选择系统并确定组件要求 ● 选择要使用的组件 (页 29) 
● 选择组件时要考虑哪些重要

因素？ (页 34) 

工厂中包含哪些区

域？

● 技术区域

● 系统联系

● 本地因素

● 创建工厂层级

● 确定区域；支持区域，

例如在设备运行期间进

行故障分析

● 在一个项目中可处理多少个

对象？ (页 48) 
● 可集成多少设备、传感器和

执行器？ (页 50) 
● 实现自动化需要多少 CPU？ 

(页 49) 
● 在规划工厂结构时可使用哪

些信息来源？ (页 44) 

规划工厂的工程组态
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问题 本手册中的相关主题 执行以下任务

需要了解...
本手册中包含更多信息的部分 

应使用哪些组件？

（连接路径的距离和

技术）

组态信号路径 确定

● 总线系统和常规布线

● 传输率

● 距离限制

● 可以使用哪些网络/总线系统

进行通信？ (页 62) 
● 有哪些扩展限制？ (页 52) 

应使用哪些组件？

（PC 组件）

PC 组件（操作员控制、

监视、组态系统）

确定

● 数量

● 可用性

● 数据备份

● 更改文档（验证）

● 可以使用哪些 PC 组件？ 
(页 112) 

● 如何防止对工厂进行未经授

权的访问？ (页 37) 
● 如何验证过程管理？ (页 40) 
● 如何将项目和过程数据归

档？ (页 42) 
应使用哪些组件？

（自动化系统、I/O、

传感器和执行器）

自动化系统（性能和应

用领域） 

已规划或现有的 I/O 设
备、传感器和执行器

确定

● AS 的数量

● 可用性

● 故障安全

● Ex 保护

● 使用的模块和软件

● 选择 AS 的标准是什么？ 
(页 115) 

● 哪些设备可作为分布式组件

进行连接？ (页 131) 

要保证高效工程组态

可做哪些准备工

作？ 

● 过程变量的数量

● 用于工程师站数量和

分布

● 规划工程组态环境

● 使用多项目和导入/导出

助手

● 使用适当资源创建列表

（例如，对于过程变量列

表）

● 哪些设备可作为分布式组件

进行连接？ (页 131) 
● 可导入数据和数据格式 

(页 143) 

如何在 PCS 7 工厂

中执行维护和诊断？

● 开始维护准备

● 规划诊断

● 使用诊断工具

● 规划维护支持

● 使用维护站

● SIEMENS 为 PCS 7 提供哪

些服务支持？ (页 46) 
● 使用维护站诊断（资产管

理） (页 689) 
可以使用哪些语言？ ● 组态和过程控制

– 英语

– 德语

– 法语

– 意大利语

– 西班牙语

规划工程组态和过程控制 ● 如何设置默认设置 (页 255) 
● 如何设置显示设备的语言 

(页 320) 

规划工厂的工程组态
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更多信息

《过程控制系统 PCS 7；PCS 7 文档》(Process Control System PCS 7; PCS 7 
Documentation) 为本手册提供了以下补充信息：

● 访问文档的方式

● 规划阶段的文档 

● 实现阶段的文档 

● 调试、操作、诊断和维护的文档 

● 白皮书《过程控制系统 PCS 7；PCS 7 安全性概念》(Process Control System PCS 7; 
PSC 7 Security Concept)

规划工厂的工程组态
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4.3 PCS 7 系统的组件

4.3.1 选择要使用的组件

简介

PCS 7 提供了一系列执行自动化任务的选项。。其范围广泛、种类繁多的组件便于满足以

下需求：           

● 针对特殊要求使用适合的组件

● 选择可精确组态的组件来满足特定要求

下表列出了符合特定过程控制要求的最佳匹配系统、组件和功能。 

选择系统、组件和功能

根据 PCS 7 工厂的要求选择系统、组件和功能： 

提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

过程模式 - OS

操作和监视 在过程模式下操作和监视 装有 WinCC 软件的 
PCS 7 操作站

 

通过 Internet/Intranet 
进行操作员控制和监视

通过 Internet 或 Intranet 在过程

模式下使用操作员控制和监视

功能

PCS 7 Web 服务器

和 PCS 7 Web 客户

端

 

通过 Internet/Intranet 
访问过程数据

通过 OPC 和 OLE DB 与外部系

统进行数据通信

OpenPCS 7  

监视 PCS 7 工厂 监视过程控制 PCS 7 维护站  

设备状态监视 监视终端总线和系统总线上连

接的系统

WinCC 的“设备状

态监视”功能

 

时间同步 终端总线、系统总线和现场总

线上连接的各系统的中央时间

同步

WinCC 的“时间同

步”

 

功能

 

短期归档 过程值和消息的短期归档 WinCC 的归档系统  

规划工厂的工程组态
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提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

长期归档 使用 PC 站来长期归档过程值、

消息和 BATCH 数据

Process Historian 

 

 

控制和操作顺序控制系

统

通过图形方式显示和操作已组

态的顺序控制系统

SFC Visualization  

操作和监视安全矩阵 
(Safety Matrix)

显示并操作组态的安全响应 Safety Matrix Viewer

*)

 

访问保护 集中的用户管理、访问保护和

电子签名

带 Electronic 
Signature 的 
SIMATIC Logon 

 

批生产过程 控制非连续过程 SIMATIC BATCH  

Route Control 控制、监视和诊断管路系统中

的物料输送

SIMATIC Route 
Control

 

已归档的过程数据 分析归档的过程数据 使用 Process 
Historian：
● OS
● Information 

Server

 

不使用 Process 
Historian：
● OS

 

过程模式 – AS 和 I/O

可用性 使用高可用性自动化系统

带分布式 I/O 的
S7-400H （如 
ET 200 等）

 

故障安全 使用故障安全

自动化系统 
带分布式 I/O 的 
S7-400F （如 
ET 200 等）

 

可用性和故障安全 使用高可用性和故障安全自动

化系统 带分布式 I/O 的
S7-400FH（如 
ET 200 等）

 

控制模式 具备控制器功能的模块 S7-400 FM  
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提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

分布式 I/O 根据保护级别、连接和防爆区

来通过 PROFIBUS DP 连接现

场设备

通过 PROFINET I/O 连接分布

式 I/O

通过 PROFINET 连接现场设备

基本 ET 200...  

传感器和执行器 连接执行器和传感器 PROFIBUS PA

PROFINET I/O

基金会现场总线

 

智能现场设备 将智能现场设备与 PROFIBUS 
通信系统相连

PROFIBUS DP/PA

PROFINET（通过 
IE/PB‑Link 或 CFU）

 

将智能现场设备与 HART 通信

系统相连

分布式 IO 系统（通

过 PROFIBUS DP 
或 

PROFINET IO）

 

将智能现场设备连接到 
FOUNDATION Fieldbus

Compact FF Link  

连接 DP/PA PROFIBUS DP 与 
PROFIBUS PA 之间的网关

DP/PA 耦合器，

PA-Link
 

连接 DP/FF PROFIBUS DP 和基金会现场

总线之间的网关

Compact FF Link  

连接 PROFINET/PA PROFINET 与 PROFIBUS PA 
之间的网关 

CFU

IE/PB Link PN IO
（含下游 DP/PA 耦合

器）

 

非冗余 PROFIBUS DP 
设备

将非冗余 PROFIBUS DP 设备

连接到冗余 PROFIBUS DP
Y-Link  

诊断

（对于硬件组件）

对 PROFIBUS DP 线路中通信

错误的简单诊断

更多相关信息，请参见“附加

服务支持和诊断 (页 693)”部分

例如，诊断中继器  
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提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

诊断

（对于软件组件）

使用和激活 PCS 7 诊断功能

更多相关信息，请参见“附加

服务支持和诊断 (页 693)”部分

例如，NCM S7 
PROFIBUS 诊断

 

危险区域 在危险区域（1 区或 2 区）中使

用的专用 I/O 组件

S7-300 Ex I/O 模块，

ET 200iSP
 

设备更换 在运行中更改 AS 组件的组态 CiR/H-CiR  

设备更换 在运行中更改 AS 块的接口 CPU 410-5H（固件

版本 8.1 或更高版本）

 

过程模式 – 通信/连接

通信（网络） 终端总线、系统总线 以太网  

支持通过网络组件（例如 CP、
总线连接器）进行的通信

SIMATIC NET 的网

络组件

 

连接 AS 将自动化系统连接到系统总线 CP 443-1 或 CPU 内
部的 PROFINET 接
口

 

连接 OS/BATCH 将 PCS 7 操作站/BATCH 站连

接到终端总线或系统总线

通信处理器或其它以

太网连接

 

连接 ES 将 PCS 7 工程师站连接到终端

总线或系统总线

通信处理器或其它以

太网连接

 

点对点连接 通过点对点连接器在 AS 与其它

站之间进行通信

S7-400 CP

S7-300 CP
（ET 200M 中）

 

工程组态

可扩展性 用于多个不同过程对象的许可

证

许可证  

基本工程组态 硬件和通信的基本工程组态 带 HW Config 和 
NetPro 的 STEP 7

 

连续自动化功能 自动化功能的图形组态 CFC  

非连续的自动化功能 采用步进允许条件的顺序控制

系统的图形组态

SFC  

重复工艺功能 使用 PCS 7 库实现工艺功能 PCS 7 Advanced 
Process Library

 

规划工厂的工程组态

4.3 PCS 7 系统的组件

工程组态系统 (V9.0 SP1)
32 配置手册, 12/2017, A5E39221328-AC



提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

用户功能块（自定义） 按照 IEC 61131-3 创建

自己的用户功能块

SCL  

批生产过程 组态配方和批生产（生产作业） SIMATIC BATCH  

Route Control 用于组态、控制、监视和诊断

管道系统中物料输送的系统

SIMATIC Route 
Control

 

使用 S7‑400H 时的

可用性

冗余自动化系统的工程组态 S7 H Systems  

使用 S7‑400F 时的

故障安全性

具有 F 功能块的 
F 编程工具

S7 F Systems  

对已定义状态的安全响

应

为该过程中发生的事件指定精

确定义的响应

Safety Matrix  

控制器优化 使用 PCS 7 对控制电路进行系

统辅助优化

PCS 7 PID Tuner  

PCS 7 OS 的
工厂画面

在过程模式下为 OS 创建工厂

画面，并将画面对象与单一控

制单元互连（动态显示）

WinCC 的 Graphics 
Designer 

 

逻辑矩阵的逻辑运算 实施控制信号。为逻辑算子提

供下列功能：许可、保护和互

锁

Logic Matrix  

智能现场设备 现场设备的组态、参数分配和

调试

SIMATC PDM  

高效工程组态 高效工程组态的功能

● 与多位项目工程师合作

● 具有复用性和集中修改功能

的类型定义

多项目、

SFC 类型、过程变量

类型、模型、控制模

块类型、过程对象视

图

 

大量数据处理 创建：

● 过程变量（根据过程变量类

型）

● 模型副本

导入/导出助手

PCS 7 Advanced ES

 

 

比较项目版本 确定项目各种版本之间的差异 Version Cross 
Manager (VXM)

 

版本控制 多项目、项目或库的版本控制 Version Trail  

读回参数 从 AS 自动循环读取参数  
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提示 详细说明 PCS 7 的执行系统、

组件和功能 
选中

√

测试 利用仿真 SIMATIC S7 站对组

态进行功能测试

S7-PLCSIM  

管理 软件管理和生命周期管理 SIMATIC 
Management 
Console

 

工厂文档 根据各标准在 PCS 7 项目中编

制工厂文档

DOCPRO  

更多信息

● 组态 PCS 7 工厂时所用的功能选项 (页 47)

● 选择网络组件 (页 62)

● 选择 PC 组件 (页 112)

● 选择 AS 组件 (页 115)

● 选择 I/O 组件 (页 130)

● 高效工程的准备工作 (页 142)

4.3.2 选择组件时要考虑哪些重要因素？

选择标准

为过程控制系统选择组件时会涉及多种因素。最重要的因素包括：         

● 过程类型（连续或非连续）

● 工厂对中断情况的应对方法（可用性和安全状态）
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过程类型

有两种过程类型：

● 连续过程

即以“固定方式”生产“同一产品”的工厂（例如，水淡化工厂）的过程顺序。此类过

程可通过 PCS 7 使用顺序控制系统 (SFC) 实现自动化。可针对小型工厂单元以及整个

工厂实现自动化。

● 非连续（批生产）过程

即生产“不同产品”（例如，用于生产药片或混合漆的各种配方）的工厂的过程顺序。

此类过程可通过 PCS 7 使用 SIMATIC BATCH 实现自动化。通过使用 SIMATIC BATCH 
中基于配方的控制策略，可使 PCS 7 工厂的过程顺序灵活地适应于变换的产品、物料

特性、工厂条件和生产阶段等。

工厂对中断情况的应对方法（可用性和安全状态）

中断情况所造成的后果常常难以估测。因此，事先规划对故障的应对方法非常重要。这可

以通过以下措施实现：

● 使用高可用性组件

● 使用故障安全组件

● 使用高可用性和故障安全组件

● 采取适当的组态措施，例如：

– 过程变量之间的互锁（依赖关系可确保目标系统响应）

– 用于启动和关闭的顺序控制图（整个系统的自动控制）

– 更高级的计算和管理功能（直接回应事件结果）

– 针对目标控制单元和工厂的控制功能（例如，在已明确状态下使用故障安全系统进

行控制）

更多信息

● “选择高可用性组件和故障安全组件 (页 54)”部分

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)
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4.3.3 PCS 7 可与哪些“第三方系统”进行通信？

与“第三方系统”进行通信

通过 PCS 7 可在“全集成自动化”框架内与多个系统连接（在 PCS 7 中使用 TIA 组件无

需附加的应用程序）：       

● 管理级和远程访问

可使用标准化的数据交换接口，如以太网、OPC 和 OLE DB（OpenPCS 7 站），将 
PCS 7 无缝地集成到公司范围的信息网络中。这使过程数据在公司内部随时随地都可供

使用。

● 与其它通信系统的数据链接

另外，使用适配器可与下列通信系统进行通信： 
– AS 接口

– Modbus 

说明

有关其它通信选项的详细信息，请与 Siemens 代理联系。

组件选择

选择与第三方系统进行数据链接所需的组件： 

提示 详细说明 执行 PCS 7 的系统、

组件和功能

选中

√

过程模式 – 通信/连接

IT 世界 将 PCS 7 集成到 SIMATIC IT SIMATIC IT  

访问 MIS/MES 过程

数据

通过 OpenPCS 7 站（OPC 和 
OLE DB）在公司范围内访问使用 
PCS 7 采集的过程数据

OpenPCS 7  

简单的执行器和传感

器 
在最低的现场级连接简单的（通常

为二进制）执行器和传感器

AS-i 连接器  

Modbus 设备 用于将组件与 Modbus 接口相连 具有 Modbus 驱动程序

的 CP 341
 

工程组态

连接器和耦合器 组态、参数分配和调试 HW Config 或特定组件

软件
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更多信息

● “管理级别和远程访问 (页 106)”部分

● “与其它系统的数据链接 (页 100)”部分

4.3.4 如何防止对工厂进行未经授权的访问？

防止在自动化工厂中未经授权的访问

在现代化的工业工厂中，大量的组件通过网络连接到一起。使用多种总线系统和协议（例

如 TCP/IP 和 COM/DCOM）搭建网络。在联网的自动化工厂中，防止对工厂进行未经授

权的访问（例如，使用“办公网络”进行访问）很重要。这样可保证不会对工厂造成不良

影响。              

PCS 7 中的工厂保护

除了 Windows 提供的标准资源（用户登录）和通常的网络组件（网桥和防火墙）之外，

PCS 7 还提供了各种选件用于防止在工厂中进行未经授权的访问。

选择组件和功能

从 PCS 7 中选择保护访问所需的组件/功能：

提示 详细说明 PCS 7 的系统、组件和

功能

选中

√

PCS 7 OS 中的权限 使用含有操作员权限的智能卡实

现访问保护

智能卡读卡器  

组态操作员权限 WinCC 的操作站功能

“用户管理器”

工程组态系统

“本地操作员权限”功

能

 

无操作员权限时显示的画面内容 “OS 项目编辑器”功能  

对 AS 的访问保护 防止对已加载的 CPU 进行访问 HW Config – CPU 的属

性

 

图表访问保护 文件夹内单个图表或所有图表

的“写保护”属性

SIMATIC Manager - 对
象属性
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PCS 7 中的集中用户管理

通过访问保护控制进行

用户管理

用于工程组态和过程模式下通过

访问保护控制实现的用户管理，

为工程设计以及操作员监控确定

了特定应用的用户角色

SIMATIC Logon  

对项目数据的访问保护 用于工程组态中通过访问控制实

现的集中用户管理

可为多项目的对象（例如，多项

目、项目、库）提供访问保护 

“对项目数据的访问保

护”功能

 

对 AS 的访问保护 对于在自动化系统（用户程序、

HW Config）中更改数据的任

务，使用密码进行访问保护

“受密码保护的 CPU 
访问”功能 

 

电子签名 密码保护的功能执行，例如对于

使用 BATCH 进行的批生产控制

基于 SIMATIC Logon 
的电子签名

 

通过 SIMATIC Logon 进行集中用户管理的原理

PCS 7 中的 SIMATIC Logon 基于 Windows 中的基本用户管理机制：

1. 在 Windows 中定义了用户、用户组（在普遍使用的 Windows 服务器上可用）和密码。

2. SIMATIC Logon 软件定义工程组态系统、操作员站、BATCH 站和 Route Control 工作站的
用户角色，并将这些角色分配给已定义的 Windows 用户组。

3. 对于用户角色和用户权限的附加限制可在此应用程序内定义。对于 SIMATIC BATCH 可定
义以下附加限制：

– 对用户角色中用户权限的限制（全局）

– 每台计算机上允许的用户角色（针对每台特定计算机）

– 每个工厂单元所允许的用户角色（针对每个特定单元）

– 每个工厂单元所允许的用户角色（针对每个项目）
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PCS 7 中所包含的组件可通过集中登录服务获得已登录用户的信息，并得到对登录进行的

任何更改以及其它信息的通知。

说明

工程师站的用户角色

工程师站提供以下用户角色：

● “项目管理员”
允许执行工程师站上的所有功能

● “项目编辑器”
有限制地使用工程功能

– 没有权限更改用户管理 
– 没有权限导出和导入功能

– 没有权限更改归档（删除、移动、导出）

– 对可能的特定工厂区域的其它限制，例如通过 AS 特定的访问控制

电子签名的原理

PCS 7 支持符合 FDA 或 21 CFR 第 11 部分要求的“电子签名”功能。工程组态中包含应

由“电子签名”功能基于用户角色激活的对象操作或对象有条件转移的定义。在发生此类

事件时，会出现一个 Windows 中常见的登录对话框形式的对话框，提示输入一个或多个签

名。

要求： 

SIMATIC Logon Service 软件会验证登录数据。因此，必须在 PC 上安装 SIMATIC Logon 
Service 才能使用“电子签名”功能。

更多信息

● “通过访问保护来保护项目/库 (页 182)”部分

● 手册《SIMATIC Logon；SIMATIC 电子签名》(SIMATIC Logon; SIMATIC Electronic 
Signature)

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

● 白皮书《PCS 7 和 WinCC 的安全性概念》
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4.3.5 如何验证过程管理？

验证过程和过程管理的目的是什么？ 

对于许多工厂来说，法律和商业要求起着决定性作用，尤其是在以下方面：

● 验证质量标准

● 工厂状况的文档编制

● 确保只有经授权人员访问工厂以及验证操作员输入

● 确保只有经授权人员可以对工厂进行更改

对过程控制系统的另外一个要求是，要经常完成自动化工厂中所有关键工厂数据和过程操

作的自动文档。 

食品与药品管理局 (FDA)

美国食品与药品管理局 (FDA) 已对这些方面规定了指导方针。GMP 法规 21 CFR 第 210、
211 和 11 部分就是根据这些指导方针制定而成。21 CFR 第 11 部分汇总了对于自动化工

程（有关验证方面）最重要的、国际有效的要求。

根据 21 CFR 第 11 部分规定使用 PCS 7 进行验证

PCS 7 和 SIMATIC BATCH 支持根据 21 CFR 第 11 部分规定进行验证。

1. 作为美国权威机构，FDA 规定并非全球通用。

2. FDA 规则不是指南，而是法规。

3. FDA 对自动化工程未做要求。其主要涉及电子数据的相关要求。

4. FDA 的第 11 部分未对验证要求做任何说明。您可以在 EU GMP 的附录 11 中找到相关指
南。
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选择组件和功能

从 PCS 7 中选择验证过程控制所需的组件/功能：

要求 详细说明 执行 PCS 7 的系统、

组件和功能

选中

√

记录所做的修改 BATCH：记录以下每种修改：

● 修改配方

● 修改用户权限

BATCH 更改日志  

BATCH：记录配方 BATCH 配方日志  

BATCH：记录批生产期间的任何

更改（包括操作员输入） 
BATCH 日志  

路径控制：记录传输路径的变化 路径日志  

记录受保护的操作 ES：记录以下过程：

● 下载到目标系统（整个程序）

● 下载到目标系统（仅下载更改）

● 激活和禁用测试模式

● 在测试模式下更改值

更改日志  

ES：在 CFC/SFC 中额外记录以下

过程：

● 在 CFC 中
– 组态连接

– 激活和取消激活运行组

● 在 SFC 中
– 各步中的常量组态

– 转移中的常量组态

– 顺控程序属性中的常量组态

ES 日志  

记录删除操作 BATCH：在单独的日志中记录所

有的删除操作

BATCH 日志  

对项目和库进行控制

版本

ES：创建不同版本的项目和库 版本跟踪  

项目和库版本的一致

性

ES：比较项目和库的版本并通过

图形显示差异

版本交叉管理器 (VXM)  

图表版本控制 ES：创建不同版本的 CFC/SFC 修改图表后自动提示  

版本控制 BATCH：对配方、配方操作和公

式进行版本控制

创建新的批生产对象后

自动执行该操作
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要求 详细说明 执行 PCS 7 的系统、

组件和功能

选中

√

系统访问 基于 Windows 的集中用户管理 SIMATIC Logon  

用户标识 更改日志随用户标识自动修改。 在更改日志中自动执行

该操作

 

电子签名 密码保护的功能执行，例如对于使

用 BATCH 进行的批生产控制

基于 SIMATIC Logon 
的电子签名

 

记录电子签名 BATCH：记录已执行的电子签名 在配方/批生产报告和 
BATCH 更改日志中自

动执行该操作

 

记录 AS 访问 记录在 AS 中所做的修改 通过 SIMATIC Logon 
保护访问

通过 ES 日志进行记录

 

检验验证结果 BATCH：日志和归档 - 已完成的批

次可以按照 XML 格式归档

BATCH 中的“归档批

生产”功能

 

更多信息

● “使用 VXM 比较项目版本 (页 681)”部分

● “如何在 ES 日志中记录更改 (页 669)”部分

● “如何在更改日志中记录更改 (页 672)”部分

● 版本交叉管理器的在线帮助

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)

● 手册《过程控制系统 PCS 7；SIMATIC Route Control》(Process Control System PCS 
7; SIMATIC Route Control)

● 手册《SIMATIC Logon；SIMATIC 电子签名》(SIMATIC Logon; SIMATIC Electronic 
Signature)

4.3.6 如何将项目和过程数据归档？

简介

SIMATIC PCS 7 提供了多种功能用于归档项目数据和过程值。
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归档项目数据

为工厂范围组态数据编排的中心数据库包含在工程组态系统中。为避免数据丢失，建议对

项目进行定期备份。归档包含将组态数据以归档文件的压缩格式进行保存的过程。可以在

硬盘或移动式数据介质（例如 CD、DVD）上进行归档。可在 SIMATIC Manager 中选择

所需的归档工具。

说明

使用 Version Cross Manager 确定项目不同版本之间的差异。

归档过程数据

可将过程数据（测量值和消息）保存在以下归档中：

● WinCC 归档

此类归档是容量有限的循环归档。只要达到归档的最大容量，就会将最早的值删除，以

使添加的新值能够得以保存。这符合“先进先出”原理。

通过将这些归档导出到其它存储位置，可防止这些最早的值丢失。

● BATCH 归档

可将已完成批次的批生产数据归档至 Process Historian。获得授权的人员或系统可通

过 Information Server 查看和评估相关信息。

用于归档的组件和功能

归档对象 详细说明 执行 PCS 7 的系统、组件和功

能

选中

√

组态数据 多项目可随所有项目和主数据

库一同归档。

STEP 7 SIMATIC Manager 中
的“归档”功能

 

过程数据（在循

环归档中）

操作站将测量值和消息保存在

归档中，以便这些数据长期可

用。

● 变量记录（归档）

● 报警记录（归档）

 

必须使用 WinCC 中的编辑器

组态和修改 WinCC 归档。

● 变量记录：过程值

● 报警记录：消息

● 报表设计器：打印布局

 

用作外部归档服务器的 
SIMATIC PC 站

● Process Historian
● 变量记录和报警记录

 

批生产数据 可将已完成批次的批生产日志

归档至数据库。 
● SIMATIC BATCH
● Process Historian
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换出归档信息

可将 OS 归档中的信息（变量和报警日志）备份到外部介质中（例如 CD、DVD）。

更多信息

● “归档/版本控制和文档编制简介 (页 694)”部分

● 有关过程和批生产数据归档的信息，请参考有关 SIMATIC Process Historian 的文档

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)

4.3.7 在规划工厂结构时可使用哪些信息来源？

工厂结构

可按照以下思路理解工厂结构：           

● 在何处及如何组态和设计工厂的各区域

● 使用哪些选项来装备工厂的哪些区域

规划工厂结构

说明

不存在可作为通用结构而建议使用的工厂结构。为实现过程自动化而设计工厂时所涉及的

设计方案取决于以下因素：

● 法律、规章和标准

● 过程工程和制造工程的关系

● 当地条件（位置、扩展能力、环境条件等）

● 其它要求（例如使用的传感器和执行器）
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用于规划工厂结构的信息来源

可从以下来源收集重要信息：

信息来源 主题 示例

过程描述 ● 过程工程连续性

● 基于位置的连续性

● 自动化系统的集中式/分布式

组态

● HMI 系统的集中式/分布式组

态

● 依赖于自动化程度的工作站

数量

工厂（例如发电站）：

● 具有单元（例如，具备燃烧器控制功

能的加热单元）的工厂

● 各单元与整个过程的关系（例如，单

元故障会造成工厂故障还是降低质

量/性能）

● 有关危险物（例如，爆炸性气体）的

信息

● 有关单元（例如压力控制单元）和组

件（例如压力传感器、泵、阀）的信

息

过程变量列表 可进行集中式或分布式组态；请

注意以下方面：

● 距离和分布

● 维护

● 环境（例如防爆区、本地操

作员输入、发热和灰尘）

● 组态、操作和监视

● 过程变量类型

● 传感器和执行器的类型及其技术参

数 - 例如：

– 填充液位传感器：0 至 20 l
– 泵：具备电机、温度传感器和过

载保护

– 阀：具备驱动器和位置反馈信号

● 传感器/执行器在工厂中的规划位置

● 来自传感器和执行器的信号：在自动

化系统中采集和处理

● 属于某过程变量类型的过程变量（例

如“填充液位”）

将数据导入工程系统

可将工厂电子信息导入工程系统以在 PCS 7 中显示工厂结构（例如，过程变量、工厂画

面）。

更多信息

● “组态 PCS 7 工厂时所用的功能选项 (页 47)”部分

● “可导入数据和数据格式 (页 143)”部分
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4.3.8 SIEMENS 为 PCS 7 提供哪些服务支持？

服务支持  

有关 Siemens 为 PCS 7 工厂提供的服务支持，请访问 Internet (https://
support.industry.siemens.com/cs) 
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4.4 组态 PCS 7 工厂时所用的功能选项

4.4.1 如何扩展 PCS 7？

可扩展性

SIMATIC PCS 7 可以多种方式灵活适应不同的工厂需求和工厂规模。在工厂升级或发生技

术变革的情况下，可随之扩展或修改组态。     

SIMATIC PCS 7 可应用在任何规模的工厂中。根据具体需求，用户可进行如下选择：

● 在性能容量不同的自动化系统中进行选择 - 从具有少量控制任务的应用程序开始（例

如：从 SIMATIC PCS 7 BOX 开始）-- 直到具有集成过程数据控制功能的超大型生产工

厂的自动化

● 逐步集成分布式或集中式 I/O

● 组态显示和操作组件并确定其规模 - 从约使用 160 个过程变量的小型单工作站系统开始

（例如实验室自动化），到约使用 60,000 个过程变量且采用客户端-服务器架构的分布

式多工作站系统（例如大型生产工厂的自动化）

● 扩展可组态过程对象的数量（有多种 PO 数量选择的软件）

● 定义网络组件并组态通信网络

● 通过系统添加各种硬件和软件组件来完善功能（例如，带 SIMATIC BATCH 的操作站或

独立的归档服务器）

● 集成将 SIMATIC PCS 7 连接到 IT 世界的应用程序

容量选项

以下部分提供有关规划 PCS 7 工厂容量的信息：

● 在一个项目中可处理多少个对象？ (页 48)

● 实现自动化需要多少 CPU？ (页 49)

● 可集成多少设备、传感器和执行器？ (页 50)

● 需要多少操作员站？ (页 50)

● 有哪些扩展限制？ (页 52)
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4.4.2 在一个项目中可处理多少个对象？

工厂规模

PCS 7 工厂规模是可组态和可扩展的。

针对工程师站、操作站、维护工作站、SIMATIC BATCH 站、Route Control 工作站以及 
SIMATIC PDM 的软件产品许可证，我们提供了不同的数量限制供用户选择。用户可通过

增加授权包来扩展这些数量限制。 

过程对象

在 PCS 7 V7.0 SP1 及更高版本中，以下规则适用于过程对象 (PO) 的许可：       

支持操作员监控以及生成消息的所有 SFC 和所有块实例都被视为是 PCS 7 过程对象。这

些是将传送到 OS 并需要许可证的对象。

在 CFC 中，支持操作员监控的块在块属性中分配有属性“S7_m_c”。 

过程对象可以是以下的块和对象之一：

● 用于工厂的操作员监控的块（例如，电机、阀门）

● 用于自动化的对象（例如，液位控制）

● 用于信号采集和信号处理的对象（非通道驱动程序块，例如 MonAnL）

许可证等级

有关过程控制系统各种组件的最新许可证级别和相关许可证所能达到的工厂规模信息，请

参见安装手册《过程控制系统 PCS 7；许可证和数量框架》(Process Control System 
PCS 7; Licenses and Quantity Frameworks)。

参见

PCS 7 许可证信息 (页 499)
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4.4.3 实现自动化需要多少 CPU？

CPU 的需求数量标准

PCS 7 工厂中所需的 CPU 数量取决于以下因素：

● 传感器和执行器的数量

使用的传感器和执行器越多，需要的自动化系统就越多。

相关信息，请参见“可集成多少设备、传感器和执行器？ (页 50)”部分。

● CPU 类型

CPU 越强大，CPU 的所需数量就越少。

相关信息，请参见“自动化系统概述 (页 117)”部分

● 利用率和需要的可扩展性

所需储量越大，CPU 所需数量就越大。

● CPU 限制

相关信息，请参见“PCS 7 项目的 CPU 限制 (页 122)”部分。

● 工厂扩展

相关信息，请参见“有哪些扩展限制？ (页 52)”部分。

● 环境要求

● 为使程序处理更快速，所需 CPU 数量更少而请求的 CPU 优化：

– 优化程序段的处理周期

– 优化处理顺序

PCS 7 不能进行多值计算

说明

在 PCS 7 中，无法使用多值计算（同步操作多个 CPU）。
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4.4.4 可集成多少设备、传感器和执行器？

混合容量  

以下各部分包括了 PCS 7 工厂预组装自动化系统的混合容量示例： 

● “PCS 7 的单一自动化系统 (页 118)”部分

● “PCS 7 的冗余自动化系统 (页 119)”部分

说明

所示值不是各自位置上 AS 的特定最大值。它们是一个示例列表，代表在混合操作结合模

块的所有位置期间，可用 AS 总容量的典型分布。

4.4.5 需要多少操作员站？

PCS 7 OS 的容量

SIMATIC PCS 7 既支持单工作站系统，又支持采用客户端-服务器体系结构的多工作站系

统。下表显示了在多工作站系统中规划操作站的最重要因素。     

参数 值

项目中服务器/服务器对（OS、BATCH、路径控制和归档服

务器）的最大数量

18

每个 OS 服务器/服务器对中自动化系统的最大数量 64

多客户端操作中的 OS 客户端的最大数量（每个多站系统） 40 
注：如果每个 OS 客户端都

能访问所有 OS 服务器/服务

器对.

多通道操作中每个操作员站支持的最多监视器数量 4

系统中过程模式下允许的最多监视器数量 60

OS 区域的最大数目 64

每个监视器的最多窗口数量 1 到  16 （可调）

每个趋势窗口的趋势数量 10

OS 过程画面超时（100 个过程符号） < 2 s

过程对象最大数目：

规划工厂的工程组态

4.4 组态 PCS 7 工厂时所用的功能选项

工程组态系统 (V9.0 SP1)
50 配置手册, 12/2017, A5E39221328-AC



参数 值

● 每个 OS 单工作站系统 8 500 PO
● 每个 OS 服务器 12 000 PO
● 每个 AS 2 600 PO
● 每个项目 216 000 PO

每台服务器/单工作站最多可组态的报警数量 200 000

过程变量数量：

● 每个 OS 单工作站系统 大约 4 500

● 每个 OS 服务器 大约 7 000

● 每个多工作站系统 大约 128 000

集成高性能归档系统（循环缓冲）用于：

● 过程值归档（每台 OS 服务器/单工作站系统） 约 1 500

● 消息归档（每台 OS 服务器/单工作站系统） 连续消息：

约 10/s 

突发消息约 3 000 / 4s
注：如果不足五秒又出现突

发消息情况，则可能导致消

息丢失。

长期归档

使用 SIMATIC Process Historian 归档过程值 有关组态限制的更多信息，

请参见 SIMATIC Process 
Historian 文档。

Process Historian 无需针对

操作员站的归档变量提供单

独的许可证密钥。

PCS 7 Web 客户端的最大数量 100

PCS 7 Web 诊断客户端的最大数量 3

维护站的数量 1 个维护站
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更多信息

● 手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

● 手册《过程控制系统 PCS 7；OS Web 选件》(Process Control System PCS 7; Web 
Option for OS)

● 手册《过程控制系统 PCS 7；维护站》(Process Control System PCS 7; Maintenance 
Station)

4.4.6 有哪些扩展限制？

扩展限制 

工厂所有的扩展潜力依赖于下列因素：       

● 连接 PCS 7 组件的网络类型

● 传感器和执行器间的桥接距离（考虑到可能的传输速率）

因为几乎所有 PCS 7 的传感器和执行器都集成在分布式 I/O 中，所以网络通信距离是一个

关键因素。 

最大扩展 

在 PCS 7 中使用的下列总线系统的最大长度如下： 

总线系统 在 PCS 7 中的应用 最大扩展

工业以太网 用于网络和子网的通信网络，使用针对商

业系统应用而开发的特殊组件

电耦合 1.5 km

光耦合 150 km（全局）

PROFINET 用于单元和现场区域的通信网络 电耦合 5 km

光耦合 150 km

PROFIBUS DP 用于单元和现场区域的通信网络 电耦合 10 km

光耦合 100 km

PROFIBUS PA 用于过程自动化 (PA) 的 PROFIBUS 电耦合 1.9 km

FOUNDATION Fieldbus 用于过程自动化的 FOUNDATION 
Fieldbus

电耦合 1.9 km
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总线系统 在 PCS 7 中的应用 最大扩展

HART 通信 使用 HART 协议进行数据通信的传感器和

执行器可以通过特殊模块与自动化系统进

行通信。

3 km

点对点连接 两个节点间通过特定的协议进行通信 取决于所选的网络

TIA 解决方案   

AS 接口 (ASI) 在自动化的最低层上用以将（通常为二进

制的）执行器和传感器连接到可编程控制

器的通信网络

100 m

Modbus 用于将组件与 Modbus 接口相连 取决于组件

MPI 用于进行测试和诊断的多点接口 15 m

更多信息

● 可以使用哪些网络/总线系统进行通信？ (页 62)

● 网络/总线系统的最大传输率 (页 66)
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4.5 选择高可用性组件和故障安全组件

组件

工厂对故障的反应对于过程控制工程组态来说是一个很重要的方面。由于现有的故障报告

常常不能满足需要，因此以下组件是过程控制工程组态的重要组成部分：   

● 高可用性组件

● 故障安全组件

投资费用

与生产损失相关的费用和损失相比，对高可用性组件和故障安全组件的高额投资显得微不

足道。生产中断可能造成的损失越高，就越应该使用高可用性组件和故障安全组件。

4.5.1 PCS 7 的冗余概念

高可用性组件

在过程控制系统中使用高可用性组件可最大程度地降低生产损失的风险。使用冗余组态可

保证过程控制系统的容错。它意味着过程中涉及的所有组件在连续操作时都有备份。如果

故障发生或其中一个控制系统组件失效，正常运行的冗余组件就会接管该连续控制任务。

冗余概念

PCS 7 高可用性组件可用于满足以下各个自动化层面的高可用性需要：

● 操作站、BATCH 站、Route Control 工作站、维护站、外部归档服务器（控制级）

● 总线系统

● 自动化系统（过程级）

● 分布式 I/O（现场级）

下图显示了基于高可用性组件组态的理论结构。
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图中编号 描述

1 多个客户端（OS 客户端、BATCH 客户端、Route Control 客户端）可访问

服务器（OS 服务器、BATCH 服务器、Route Control 服务器）上的数据。

2 操作员站（客户端和服务器）之间的通信以及与工程师站之间的通信是通过

冗余的高可用性终端总线（工业以太网）进行的。 

客户端和服务器通过交换机连接到终端总线。 

3 必要时，可对服务器（OS 服务器、BATCH 服务器、Route Control 服务器、

维护服务器、外部归档服务器）进行冗余配置。 
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图中编号 描述

4 自动化系统与 OS 服务器/Route Control 服务器、BATCH 服务器（在基于 
AS 运行时）及工程师站之间的通信，以及各自动化系统之间的通信，都是

通过冗余的高可用性系统总线（工业以太网）进行的。 

自动化系统、服务器和工程师站通过交换机连接到系统总线。 

5 冗余高可用性自动化系统 AS 41xH 的每个组成部分都通过以太网连接（CP 
或 CPU 的集成接口）与系统总线相连。 

AS 的每个组成部分都可以连接到多个分布式 I/O 系统。使用内部接口或附加

的通信处理器进行连接（以太网或 PROFIBUS DP）。

6 通过每个 I/O 系统（如 ET 200M）中的两个接口模块（如 IM 153-2）来实现

冗余连接到现场总线。

7 可使用冗余的数字量或模拟量输入/输出模块来评估传感器/执行器信号。如果

两个冗余模块中有一个发生故障，则另一个有效模块将继续评估输入/输出信

号。

8 PROFIBUS PA I/O（或 FF I/O）通过耦合器和两个接口模块连接到冗余现场

总线（如 PROFIBUS DP）。

冗余现场总线通过冗余链接（PA-Link 或 Compact FF Link）实现。现场设

备通过有源现场分配器连接到现场总线：

● 对于环型冗余：AFD; AFDiS  或 AFDiSD
● 对于耦合器冗余：AFS

9 通过 Y Link 可将非冗余 PROFIBUS 分布式 I/O 设备连接到冗余 PROFIBUS 
DP。

更多信息 

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

4.5.2 PCS 7 的运行可靠性概念

故障安全组件

如果故障可能危及人命、损害设备或环境时，可在 PCS 7 中引入故障安全自动化系统。故

障安全自动化系统会同时检测过程中的故障和内部故障，并且在故障发生时，自动将设备

切换到安全状态。         
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运行可靠性概念

PCS 7 的故障安全自动化系统可配置成单通道系统（使用一个 CPU 的 F 系统）或冗余系

统（FH 系统）。 

图中编号 示例描述

1 故障安全 S7-300 信号模块通过 ET 200M 连接到故障安全 S7-400F 自动化

系统。

2 故障安全自动化系统可配置成冗余形式。故障安全和高可用性自动化系统 
S7-400FH 可保证最佳的设备可用性和安全性。

3 故障安全 S7-300 信号模块（F 模块）也可以冗余方式连接，以进一步提高

可用性。
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安全机制

PCS 7 运行可靠性概念包括以下安全机制：

● PROFIsafe 规约用于 F CPU 和分布式 I/O 之间安全相关的 PROFIBUS DP 通信。故障

安全自动化系统和信号模块能够识别错误的用户数据并通过此安全框架触发相应的错误

响应。

● 在程序设计（F 程序）之后，组态的安全功能将在 CPU 的不同处理器区域接受两次处

理。将通过随后的结果比较来发现可能存在的错误。

● 程序设计错误（如除数为零或数值溢出）将由专用的故障安全 CFC 块（F 块）中途截

取。

● 以下功能提高了安全等级：

– 比较 F 程序

– 按校验和检测修改过的 F 程序

– 访问权限受密码保护

说明

在 F 程序中检测到错误不会导致 CPU 切换到停止状态，而是触发一个可组态的响

应。这种情况出现时，会使得相应的 F 程序组或是整个 F 程序进入安全状态。

使用标准组件

除故障安全信号模块，在故障安全自动化系统中也可使用标准模块。

用户程序可能同时包含了 F 程序和标准程序。这些程序将与特殊转换块分离。

S7-400F/FH 的认证

以下认证适合于 PCS 7 使用的故障安全 S7-400F/FH 自动化系统：

● 德国技术监测组织（TUEV）认证，符合 IEC 61508 的安全等级 SIL1 到 SIL3。

● 符合 DIN V 19250/DIN V VDE 0801 的要求等级 AK1 到 AK6

● 符合 EN 954-1 类别 2 到 4

更多信息 

● 产品概述《过程控制系统 PCS 7；已发布模块》(Process Control System PCS 7; 
Released modules)

● SIMATIC PCS 7 过程控制系统的附加目录（目录 ST PCS 7 AO）

在此目录中，您可以找到可集成进故障安全自动化系统的组件。
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● 手册《SIMATIC 可编程控制器 S7 F/FH》(SIMATIC Programmable Controllers S7 F/
FH)

● 手册《S7-300 故障安全信号模块》(S7-300 Fail-safe Signal Modules)

● 手册《SIMATIC ET 200S 分布式 I/O 系统》(SIMATIC ET 200S Distributed I/O 
System)

● 手册《SIMATIC 分布式 I/O 系统 ET 200pro》

● 手册《SIMATIC 分布式 I/O ET 200iSP 分布式 I/O 设备 - 故障安全模块》(SIMATIC 
Distributed I/O ET 200iSP Distributed I/O Device - Fail-safe Modules)

4.5.3 建议使用的组件

组件选择

安全性和可用性要求均是选择设备高可用性组件和故障安全组件的决定性因素。下表根据

系统要求列出了建议选择的组件。 

要求： 低或无 中 高/大型

AS

可用性 默认值 部分：

SIMATIC H 系统 (页 124)

SIMATIC H 系统 (页 124)

安全性方面 默认值 部分：

SIMATIC F 系统 (页 127)

SIMATIC F 系统 (页 127)

可用性和安全性方面 默认值 部分：

SIMATIC FH 系统 (页 127)

SIMATIC FH 系统 (页 127)

分布式 I/O
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要求： 低或无 中 高/大型

可用性 

 

● ET 200M
● ET 200iSP
● ET 200SP HA

● 在 ET 200M 中使用两个 
IM 153

● 在 ET 200iSP 中使用两

个 IM 152-1
● 在 ET 200SP HA 中使用

两个 IM 155-6

● 在 ET 200M 中使用两个 
IM 153
在 ET 200M 中使用冗余 
IO 模块。 

● 在 ET 200iSP 使用两个 
IM 152-1
在 ET 200iSP 中使用冗

余 IO 模块。 
● 在 ET 200SP HA 中使用

两个的 IM 155-6
在 ET 200SP HA 中使用

冗余 IO 模块。 
● PA Link
● Compact FF Link

● 在 PA Link 中使用两个 
IM 153-2 和两个 DP/PA 
耦合器

● 两个 Compact FF Link

● 在 PA Link 中使用两个 IM 
153-2 和两个 DP/PA 耦合

器

● 两个 Compact FF Link
安全性方面 

 

● ET 200M
● ET 200iSP 

● 在 ET 200M 中使用故障

安全 IO 模块 
● 在 ET 200iSP 中使用故障

安全 IO 模块

● 在 ET 200M 中使用故障安

全 IO 模块

● 在 ET 200iSP 中使用故障

安全 IO 模块 
● ET 200S ● 故障安全 IO 模块和电源

模块

● 故障安全 IO 模块和电源模

块

可用性和安全性方面 ● ET 200M
● ET 200iSP

● 在 ET 200M F 中使用两

个 IM 153
在 ET 200M 中使用故障

安全 IO 模块。

● 在 ET 200iSP 中使用两

个 IM 152-1
在 ET 200iSP 中使用故障

安全 IO 模块（仅固件 
V2.0 支持故障安全型。）

● 在 ET 200M 中使用两个 
IM 153
在 ET 200M 中使用冗余故

障安全 IO 模块。

● 在 ET 200iSP 中使用两

个 IM 152-1
在 ET 200iSP 中使用冗余

故障安全 IO 模块（仅固

件 V2.0 支持故障安全

型。）

总线系统

可以使用的终端总线

和工厂总线

工业以太网：标准环型

结构

工业以太网：标准环型结构 工业以太网：冗余环形组态
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要求： 低或无 中 高/大型

可以使用的

现场总线 
PROFIBUS DP/PA 冗余 PROFIBUS DP/PA 冗余 PROFIBUS DP/PA

PROFINET 冗余 PROFINET 冗余 PROFINET

基金会现场总线 使用两个 Compact FF Link 
和有源现场分路器 (AFS) 的
冗余

使用两个 Compact FF Link 
和有源现场分配器 (AFD) 的
环型冗余。 

HMI 系统

可用性 – 数据安全 PCS 7 OS、
SIMATIC BATCH 和 
SIMATIC Route 
Control

用于 PCS 7 OS、
SIMATIC BATCH、

SIMATIC Route Control、维

护站和中央归档服务器的冗

余服务器

用于 PCS 7 OS、
SIMATIC BATCH、

SIMATIC Route Control、维

护站和中央归档服务器的冗余

服务器
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4.6 选择网络组件

4.6.1 PCS 7 内的通信

简介

PCS 7 内的通信基于 SIMATIC NET 网络组件，这些组件符合在全球范围内建立的标准。

SIMATIC NET 包括专为工业用途而开发的功能强大而稳定的组件。这些组件具有以下特

点：

● 这些组件为在 PCS 7 工厂的所有级别和组件之间进行可靠的数据交换做好了准备。

● 可使用标准组件来增强和扩展这些组件。

SIMATIC NET

SIMATIC NET 包含以下组件：

● 通信网络，由传输介质、相应的连接和传输组件以及相应的传输方法组成。

● 协议和服务，用于组件之间的数据通信。

● 自动化系统的通信模块，用来与通信网络建立连接（例如，通信处理器 CP）。

4.6.2 可以使用哪些网络/总线系统进行通信？

用于通信的网络/总线系统 

下表显示了用于 PCS 7 工厂中组件之间通信的网络/总线系统。         

通信双方 操作站和 
Route 
Control 
工作站

BATCH 
站 

工程师站 AS 分布式 I/O 智能现场设备、

传感器和执行

器

操作站和，

Route Control 工
作站

以太网 以太网 以太网 以太网 无 无

BATCH 站 以太网 以太网 以太网 以太网

*1)

无 无
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通信双方 操作站和 
Route 
Control 
工作站

BATCH 
站 

工程师站 AS 分布式 I/O 智能现场设备、

传感器和执行

器

工程师站 以太网 以太网 以太网 以太网 通过 AS 的以太

网

通过 AS 的以太

网 

AS 以太网 以太网

*1)

以太网 以太网 PROFIBUS DP 
或 PROFINET

PROFIBUS 
DP；

PROFIBUS 
PA；

基金会现场总

线；

HART、AS-i、
Modbus 

分布式 I/O 无 无 通过 AS 的
以太网

PROFIBUS 
DP 或 
PROFINET

PROFIBUS DP 
或 PROFINET
（通过 AS）

通过 AS

智能现场设备、

传感器和执行器

无 无 通过 AS 的
以太网

PROFIBUS 
DP；

PROFIBUS 
PA；

基金会现场总

线；

HART、AS-i、
Modbus 

通过 AS 无

*1) BATCH 站和 AS 之间的通信路径取决于 BATCH 站的运行模式：

● 基于 PC 运行时：通过终端总线（以太网）和 OS 到 AS

● 基于 AS 运行时：通过工厂总线（以太网）到 AS

4.6.3 网络/总线系统的应用领域和参数

网络/总线系统的应用领域/参数

下表概要列出了最重要的网络/总线系统选用决定标准：
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终端总线和系统总线

应用领域/参数 信息和组态限制

应用领域 终端总线和系统总线

标准 IEEE 802.3

传输速率 (页 66) 100 Mbps，最高 10 Gbps

网络规模（最大）：

● 电气 5 km*
● 光纤 150 km*
● 无线 1000 m*
● 全局 使用 TCP/IP 的 WAN

拓扑 环型、线型、星型、树型、冗余型 

节点数：

● 典型 每段 1023 个

● 最大 （没有限制）

具体参数分配 地址和协议；无总线参数

特殊应用区域 -

*) 最大网络扩展能力取决于所用的网络组件

现场总线

参数 信息和组态限制

应用领域 PROFIBUS DP PROFINET PROFIBUS 
PA***

或 
FOUNDATION 
Fieldbus

HART AS-i

标准 IEC 61158-2

EN 50170-1-2

IEC 
61158/61784

IEC 61158-2

EN 50170-1-2

ISA S50.2

符合 Bell 202 标
准

IEC 62026

EN 50295

传输速率 (页 66) 最高 12 Mbps
（视距离而定）

最高 100 Mbps

 

31.25 Kbps 1.2 Kbps (PTP)

19.2 Kbps（总

线）

最长周期时间： 

5 ms（对于 31 
个 AS-i 从站）
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参数 信息和组态限制

网络规模（最大）：

● 电气 9.6 km**
（使用中继器） 

5 km* 1.9 km 3 km (PTP)
100  m（总线）

最长 100 m

● 光纤 90 km 150 km* - - -
● 无线 15 m（带 ILM） 1000 m* - - -

拓扑 环型、线型、星

型、树型、冗余

型

 

环型、线型、星

型、树型、冗余

型 

线型、星型、树

型

线型 — 直接连接

到特殊输入模块

线型、星型、树

型

节点数：

● 典型 每段 32 个 每段 1023 个 每段 32 个 

每个 PA Link 64 
个

1 个节点 15

● 最大 125 （没有限制） 125 1 个节点 32（31 个从站，

最多有 124 个二

进制元件）

具体参数分配 数据吞吐量和连

接参数

地址和协议；无

总线参数

数据吞吐量和连

接参数

使用 SIMATIC 
PDM 的设备组态

使用 S7 组态的

连接

特殊应用区域 - - 危险区域 - 模拟传感器从站

规约 7.3/7.4

*) 最大网络扩展能力取决于所用的网络组件

**) 具有中继器的 PROFIBUS DP 段：相关信息，可参考“电气传输介质 (页 81)”部分。

***) 与应用到 FOUNDATION Fieldbus 的参数类似。相关信息可参见文档《SIMATIC 过程

控制系统 PCS 7，FOUNDATION Fieldbus》(SIMATIC Process Control System PCS 7, 
FOUNDATION Fieldbus)。
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4.6.4 网络/总线系统的最大传输率

最大传输率

下表列出了网络/总线系统的最大传输率。传输率取决于网络物理成分：        

● 电气网络：使用电气导电连接（铜缆）安装的网络

● 光纤网络：使用光纤电缆 (FO) 安装的网络

网络/总线系统 电气网络 光纤网络 建议

工业以太网 100 Mbps，最高 10 
Gbps

100 Mbps，最高 10 
Gbps

始终使用支持传输率为 100 Mbps 
或 1 Gbps 的组件

PROFINET 最高 100 Mbps  最高 100 Mbps 可为传输路径配备工业以太网组件。

PROFIBUS DP 最大段长度的传输率：

● 12 Mbps，最长 60 m
● 6 Mbps，最长 60 m
● 3 Mbps，最长 100 m
● 1.5 Mbps，最长 200 

m
● 500 Kbps，最长 400 

m
● 187.5 Kbps，最长 

700 m
● 93.75 Kbps，最长 

900 m
● 45.45 Kbps，最长 

900 m
● 19.2 Kbps，最长 

900 m
● 9.6 Kbps，最长 900 

m

最大 12 Mbps
● 使用塑料 FO，最长 

400 m
● 使用玻璃光纤 FO，最

长 10 m

如果看重的是抗干扰能力和控制到

负载的隔离，建议使用光纤网络。

有关电气网络的传输率和传输距离

之间的相互关系的信息，可参考

“电气传输介质 (页 81)”部分

PROFIBUS PA 31.25 Kbps - 通过 PROFIBUS DP 进行通信。

相关信息，可参考“将 PROFIBUS 
DP 连接到 PROFIBUS PA 
(页 87)”部分
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网络/总线系统 电气网络 光纤网络 建议

FOUNDATION 
Fieldbus

31.25 Kbps - 通过 PROFIBUS DP 进行通信。

更多信息请参见文档《SIMATIC 过
程控制系统 PCS 7，
FOUNDATION Fieldbus》
(SIMATIC Process Control 
System PCS 7, FOUNDATION 
Fieldbus)。

HART 1.2 Kbps (PTP)

19.2 Kbps（总线）

- -

AS-i 最长周期时间：

5 ms（对于 31 个 AS-i 
从站）

- 通过 PROFIBUS DP 进行通信。

相关信息，可参考“将 ASI 接口连

接到 PROFIBUS DP (页 104)”部

分

*) SCALANCE X-400 交换机适用于 10/100/1000 Mbps 网络（电气网络或光纤网络）。

（DTE 连接到 10/100 Mbps 端口。）

4.6.5 光传输介质

4.6.5.1 工业以太网使用的光纤和电气传输介质

光传输介质     

建议使用玻璃光纤作为光传输介质。PCS 7 提供了适用于室内和室外接地安装的标准电

缆。 

可提供固定长度的、预安装过的标准电缆， 

● 带 2 x 2 BFOC 连接器（FO 标准电缆）

● 带 2 x 2 SC 连接器（FO 标准电缆）：

千兆位范围的光纤网络需要使用带 2 x 2 SC 连接器的 FO 标准电缆。

电气传输介质

终端使用工业双绞线 (ITP) 来连接。提供了采用各种设计的预制电缆或传输制品（ITP 标准

电缆），这些电缆配有小 D 形接口，通过这种接口可将节点与网络组件直接相连。
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也可选择使用所谓的 TP 线电缆通过双绞线 (TP) 来连接终端。

SCALANCE X100 介质转换器

使用 SCALANCE X100 介质转换器可配置光网络和组合（电气/光）网络：

● SCALANCE X101-1
最大传输范围（段长度）为 3 km

● SCALANCE X101-1 LD
最大传输范围（段长度）为 26 km

更多信息

● 请参见“可以使用哪些网络/总线系统进行通信？ (页 62)”部分

● 手册《SIMATIC Net 双绞线和光纤网络》(SIMATIC Net Twisted Pair and Fiber-Optic 
Networks)

4.6.5.2 PROFIBUS 中的光传输介质

建议       

说明

建议：光传输类型用于较长距离或建筑物间的连接。

玻璃光纤电缆或塑料光纤电缆用作光 PROFIBUS 网络的传输介质。 

玻璃光纤电缆

PCS 7 提供了具有适用于室内和室外电缆安装的兼容连接器组（20 个 BFOC 连接器）的

玻璃光纤电缆标准电缆。

塑料光纤电缆

PCS 7 提供了具有适用于室内电缆安装的兼容插接适配器的塑料光纤电缆标准电缆：
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光链路模块 (OLM)

通过使用 OLM，可配置光网络和组合（电气/光）网络：

● OLM 配有一个 RS 485 接口和 2 个光纤电缆接口。

光总线端子 (OBT)

通过使用 OBT，可将具有集成光接口的 PROFIBUS DP 节点连接到 RS 485 段或没有集成

光接口的 PROFIBUS DP 节点。

为 S7-400F/FH 使用光纤电缆和 OBT

建议为故障安全自动化系统（仅包含 F 模块）使用光纤电缆和 OBT，以满足安全级 SIL 3 
的要求。通过使用光纤电缆的 OBT 将 ET 200M 连接到 PROFIBUS DP 的电气总线电

缆。 

所需安全等级 SIL 3 的优点是：建立直接电气连接时无需使用安全保护器来隔离 IM 153-2 
与 F 模块之间的信号。 
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更多信息

● 请参见“网络/总线系统的最大传输率 (页 66)”部分

● 手册《SIMATIC NET；PROFIBUS 网络》(SIMATIC NET; PROFIBUS Networks)

● 手册《SIMATIC NET；双绞线和光纤网络》(SIMATIC NET; Twisted Pair and Fiber-
Optic Networks)

4.6.5.3 PROFINET IO 使用的光纤和电气传输介质

光传输介质     

建议使用玻璃光纤作为光传输介质。PCS 7 提供了适用于室内和室外接地安装的标准电

缆。 

可提供长度固定的预装标准电缆（请查看系统以了解可用电缆）， 

● 带 2 x 2 BFOC 连接器（FO 标准电缆）

● 带有 2 x 2 SC 连接器（FO 标准电缆） 

● 带有用于 ET 200SP HA 和 CFU 的 2 x 2 FC LC 插头（IE FC FO 电缆）

电气传输介质

PROFINET IO 中的组件通过工业双绞线 (ITP) 进行连接。采用各种设计的预制电缆或传输

制品（ITP 标准电缆），可将节点与网络组件直接相连。

更多信息

● 请参见“可以使用哪些网络/总线系统进行通信？ (页 62)”部分

● 手册《SIMATIC Net 双绞线和光纤网络》(SIMATIC Net Twisted Pair and Fiber-Optic 
Networks)
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4.6.6 以太网终端总线和工厂总线

4.6.6.1 使用以太网规划管理级

将系统总线与终端总线隔离          

说明

建议将系统总线与终端总线隔离。但对于较小的组态，则不一定要如此。

MES 级应始终通过路由器进行连接。这样可以防止未经授权访问过程控制系统。

以太网/千兆位以太网

用于 PCS 7 的网络组件为工业以太网组件。这具有以下意义：

● 通信速度为 100 Mbps 或 1 Gbps 

● 采用交换技术

● 使用光学/电气环实现冗余

用于 PCS 7 的组件

网络节点通过网络电缆连接到 SCALANCE X 交换机。用于数据传输：

● 双绞线电缆（ITP 或 TP）

● 光纤电缆 (FO)

● 同轴和三轴电缆

更多信息

● “通过终端总线和工厂总线的数据路径 (页 164)”部分

● Internet (http://support.industry.siemens.com/cs/cn/zh/view/60119725/en) 上提供了更

多有关 PCS 7 安全性概念的信息。白皮书《PCS 7 和 WinCC 的安全性概念》

● “网络/总线系统的最大传输率 (页 66)”部分
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4.6.6.2 使用采用了 SCALANCE X 的交换技术

SCALANCE X

SCALANCE X 属于 SIMATIC NET 工业以太网交换机中的交换机产品系列。交换机是将数

据分发给目标地址的主动网络组件。 

● 用于 PCS 7 的 SCALANCE X 交换机

有关适合的交换机的信息，请参见产品概述《过程控制系统 PCS 7；已发布模块》

(Process Control System PCS 7; Released Modules)。

● 用于 PCS 7 的 SCALANCE X 介质转换器

可通过介质转换器实现光连接路径和电气连接路径的互连。

如 SCALANCE‑X101‑1 和 SCALANCE X101‑1LD 即可用于此目的。

具有冗余管理器的环

可将交换机用作冗余管理器来构建环网结构。在 PCS 7 中，可构建具有光学或电气连接路

径的网络。在网络的线性拓扑中最多可组态 50 个交换机。 

选择 SCALANCE X 变型

交换机 端口类型和编号 冗余管理器 备用管理

器千兆位以太网

10/100/1000 
Mbps
 

以太网

(10/100 Mbps)
Sub D 
(ITP)

RJ45 (TP) 多模 FO 单模 FO

X414-3E4) 2 x TP 或

2 x 1 Gbps FO

- 12/201) 42)/121) 43)/121) 有 有

X408-24) 4 x TP 或

4 x 1 Gbps FO

- 4 4 4 有 有

X310 3 x TP - 7 - - 有 有

X308-2 3 x TP 或

2 x 1 Gbps FO

- 7 2 - 有 有

X308-2LD 3 x TP 或

2 x 1 Gbps FO

- 7 - 2 有 有

X204IRT - - 4 - - 有 5) 有 5)
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交换机 端口类型和编号 冗余管理器 备用管理

器千兆位以太网

10/100/1000 
Mbps
 

以太网

(10/100 Mbps)
Sub D 
(ITP)

RJ45 (TP) 多模 FO 单模 FO

X202-2IR
T

- - 2 2 - 有 5) 有 5)

XC200 - - 8 - - 无 6) 无

XP208 - - 8 - - 支持 不支持

XC206-2 - - 6 2 - 支持 无

X101-1 - - 1 1 - 无 无

X101-1LD - - 1 - 1 无 无

1) 包括扩展模块

2) 可用 2 个多模介质模块堆叠

3) 可用 2 个单模介质模块堆叠

4) 光学连接用的光纤模块

 100 Mbps：MM491-2 高速以太网光纤模块 (100Base FX)
 1000 Mbps：MM492-2 千兆介质模块 (1000Base-FX) 

5) 冗余管理器和备用管理器不能同时运行
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采用 SCALANCE X 的交换技术示例

更多信息

● “终端总线和系统总线上的数据路径 (页 164)”部分

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

● 操作说明《工业通信；工业以太网交换机 SCALANCE X‑400》(Industrial 
Communication; Industrial Ethernet Switches SCALANCE X‑400)

● 组态手册《工业通信；工业以太网交换机 SCALANCE X-300 SCALANCE X-400》
(Industrial Communication; Industrial Ethernet Switches SCALANCE X-300 
SCALANCE X-400)

● 操作说明《工业通信；工业以太网交换机 SCALANCE X‑200》(Industrial 
Communication; Industrial Ethernet Switches SCALANCE X‑200)
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● 操作说明《工业通信；工业以太网交换机 SCALANCE X‑300》(Industrial 
Communication; Industrial Ethernet Switches SCALANCE X‑300)

● 操作说明《工业通信；工业以太网 SCALANCE X-100 和 SCALANCE X-200 产品线》

(Industrial Communication; Industrial Ethernet SCALANCE X-100 and 
SCALANCE X-200 product line)

4.6.6.3 将网络节点连接到以太网

AS 和 PC 站的总线连接

AS 的连接

AS 与工业以太网之间的连接协议为 TCP/IP 或 ISO。AS 中的以下接口适用于该连接：

● 通信处理器 CP 443-1

● CPU 的板载以太网接口（如果有）
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连接 PC 站

说明

PC 组件包

遵守 PC 组件的要求。相关信息，请参见 PCS 7 自述文件。 

与终端总线连接

用于连接终端总线： 

● 已发布的 PC 站通信模块（例如，Intel® Gigabit CT Desktop Adapter；板载以太网接

口）

● PC 站与终端总线的冗余连接版本：

- 并行冗余协议

相关信息，请参见功能手册《过程控制系统 PCS 7；高可用性过程控制系统》。 

在实施上述功能时，请参考产品文档来确认通信模块是否适合终端总线。

连接到系统总线

可以使用以下网络适配器连接到系统总线：

● 标准通信模块：

– 每个 PC 站最多连接 8 个通信伙伴（自动化系统或服务器）时。

– 高可用性自动化系统与 CPU（固件版本 V6.0 及以上或 CPU 410 过程自动化 V8）
一起使用时。

– 需要通过 2 个网络适配器连接 PC 站与高可用性自动化系统时（2 路冗余）。

● 在下列情况下需要带板载处理器 (CP 16xx) 的通信模块： 
– 每个 PC 站连接 9 个到 64 个（最多）通信伙伴（自动化系统或服务器）时。

– 高可用性自动化系统与 CPU（固件版本低于 V6.0 或 CPU 410 过程自动化 V8）一

起使用时。

– 需要通过 2 个网络适配器连接 PC 站与高可用性自动化系统时（2 路冗余和 4 路冗

余）。

更多信息

● 功能手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 
7; PCS 7 - PC Configuration)

● “终端总线和系统总线上的数据路径 (页 164)”部分
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● 有关高可用性自动化系统的信息，请参见功能手册《过程控制系统 PCS 7；高可用性过

程控制系统》(Process Control System PCS 7; High Availability Process Control 
Systems)。 

● 更多关于认可网络适配器和通信处理器的信息，请参见产品概述《过程控制系统 PCS 
7；已发布模块》(Process Control System PCS 7; Released Modules)。

● 有关时间同步的更多信息，请参见功能手册《过程控制系统 PCS 7；时间同步》(Process 
Control System PCS 7; Time Synchronization)。

4.6.6.4 组态冗余以太网

冗余系统总线/终端总线

以下通信解决方案通过消除单个错误来提高可用性：

● 冗余电气网络

● 冗余光网络

● 组合的冗余网络

环型结构的应用

也可通过环型结构组态实现冗余：

● 单环（参见高可用性系统总线实例）

● 双环（参见冗余高可用性系统总线实例）

增加一个具有 SCALANCE X 和两个接口卡（用于各个连接的组件，如 AS、OS）的环

型结构可提高可用性级别。
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高可用性系统总线实例

下图显示了环型结构的高可用性系统总线示例。除系统总线外，所有组件都进行了冗余组

态。 

冗余高可用性系统总线实例

下图显示了双环型结构的冗余高可用性系统总线示例。所有组件都进行了冗余组态。 
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交换机

所有交换机 (SCALANCE X‑400/‑300/‑200) 都有 2 个环端口以实现与两个以太网环结构相

连接。

更多信息

● “使用采用了 SCALANCE X 的交换技术 (页 72)”部分

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

4.6.6.5 在以太网上规划诊断

SCALANCE X 交换机的诊断功能

使用 SCALANCE X 时，以下诊断功能可用：

● 对以太网网络进行分段分析

● 通信错误诊断

● 向其它 SIMATIC NET 网络组件发送错误信号，或将自身 LED 设置为“故障”。

附加诊断工具和信息

可使用附加工具进行网络诊断。请参考组态手册《过程控制系统 PCS 7；操作员站》

(Process Control System PCS 7; Operator Station)以及手册《过程控制系统 PCS 7；服务

支持和诊断》(Process Control System PCS 7; Service Support and Diagnostics)，以了解

可用于在过程模式下进行调试的其它诊断工具。
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4.6.7 使用 PROFIBUS 的现场总线

4.6.7.1 使用 PROFIBUS 规划现场级

PCS 7 工厂中的 PROFIBUS

PROFIBUS 用于 PCS 7 的现场级。将使用以下 PROFIBUS 配置文件：     

● PROFIBUS DP — 用于 AS 和分布式 I/O 之间的通信

● PROFIBUS PA（依照 IEC 61158）— 用于直接连接具有总线能力的智能现场设备

● PROFIBUS DP，作为 FOUNDATION Fieldbus 的网关 

用于 PCS 7 的组件 

在多种应用下，均可采用下列传输介质组合来配合 PROFIBUS 的工作：

● 屏蔽双线电缆 — 用于电气数据传输

● 光纤电缆 (FO)— 用于光数据传输

视所使用的传输介质和将要连接的设备，可使用以下组件来组态 PROFIBUS 网络：

● 光学连接：光链路模块 (OLM)/光总线端子 (OBT)

● PROFIBUS DP 与 PROFIBUS PA 之间的链接：PA-Link 或 DP/PA 耦合器

● PROFIBUS DP 与基金会现场总线之间的链接：紧凑型 FF Link

● 冗余 PROFIBUS DP 和单 PROFIBUS DP 间的链接：Y-Link
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● 中继器：诊断中继器/RS 485 中继器

● 总线端接：RS 485 端接元件

FOUNDATION Fieldbus

有关将 FOUNDATION Fieldbus 集成进 PCS 7 系统的信息，请参见调试手册《过程控制

系统 PCS 7；PCS 7 - 基金会现场总线》(Process Control System PCS 7; PCS 7 - 
FOUNDATION Fieldbus)。

4.6.7.2 电气传输介质

简介      

屏蔽双绞线电缆用作电气 PROFIBUS 网络的传输介质。PROFIBUS 节点通过具有支线或

总线电缆连接器的总线端子连接到总线电缆。 
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PROFIBUS 段

PROFIBUS 段是由两端连接了浪涌阻抗的总线电缆组成。各 PROFIBUS 段通过中继器彼

此连接。段电缆最大长度取决于以下因素：

● 传输速率

● 使用的电缆类型

PROFIBUS 段的最大电缆长度受到限制。有关此主题的更多信息，请参见“网络/总线系

统的最大传输速率 (页 66)”部分。 

RS 485 中继器

RS 485 中继器是一种信号放大器。通过它可增加电缆长度。最多可串联 9 个 RS 485 中继

器。使用 RS 485 中继器时两节点之间的最大电缆长度如下：

传输

速率

2 节点间的最大电缆长度

（串联 9 个 RS 485 中继器时）

9.6 至 187.5 Kbps 10,000 m

500 Kbps 4000 m

1.5 Mbps 2000 m

3 至 12 Mbps 1000 m

有源 RS 485 终端元件

无论传输速率如何，所有 PROFIBUS 段必须在两端连接终端元件。RS 485 终端元件用作

终止 PROFIBUS 段的永久性线路终端。

RS 485-iS 耦合器

RS 485-iS 耦合器是用于在危险区域中实现 PROFIBUS DP 本质安全传送的隔离变送

器。 

将本质安全 PROFIBUS DP 节点（例如，ET 200iSP 或具有 Ex i DP 接口的第三方设备）

连接到 PROFIBUS DP 时需要使用 RS 485-iS 耦合器。RS 485-iS 耦合器也可在危险区域

中用作中继器。
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更多信息

● 手册《SIMATIC NET；PROFIBUS 网络》(SIMATIC NET; PROFIBUS Networks)

● 手册《SIMATIC，分布式 I/O 设备 ET 200iSP》(SIMATIC, Distributed I/O Device ET 
200iSP)

4.6.7.3 连接 PROFIBUS DP 节点

AS、ET 200M、ET 200S、ET 200iSP 及 ET 200pro 的总线连接

AS 的连接

自动化系统通过以下组件连接到 PROFIBUS DP： 

● CP 443-5 Extended

● CPU 的内部 PROFIBUS DP 接口

PROFIBUS DP 线路最多可连接到每个自动化系统（视 CPU 而定，可能具有附加件模块）

的 4 个内部 PROFIBUS DP 接口，最多可再连接 10 个额外的 CP 443-5 Extended。如果

有可用于 PROFIBUS DP 接口的 964-DP 接口模块，则可将它们安装在 CPU 的开放式模

块插槽中。
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ET 200M、ET 200S、ET 200iSP 和 ET 200pro 的连接

可使用各种设计形式的总线连接器将 ET 200M、ET 200S、ET 200iSP 和 ET 200pro 连接

到 PROFIBUS DP。匹配连接器可与 ET 200 组件一并订购。

4.6.7.4 信号整合（单通道或双通道） 

单通道 IO（也用于开关 IO）

输入或输出信号通过单 IO 模块（单通道）与系统相连。 

双通道 IO（冗余 I/O 的一部分） 

输入或输出信号通过两 IO 模块（双通道）与系统相连。控制器发送并获取两个独立值。如

果数值通过一个或两个源生成，或发送至一个或两个接收器，该功能不相关。 

● 一个对应于执行设备的传感器通过 MTA 与一个工作站中的两个 IO 模块相连。两条通道

的值必须由 REDLib 处理。 

● 一个对应于执行设备的传感器通过 MTA 与两个不同工作站中的两个 IO 模块相连。两条

通道的值必须由 REDLib 处理。 

● 一个对应于执行设备的传感器通过 IO 设备的冗余终端块连接工作站中的两个 IO 模块

（硬件支持的冗余）。要使用基于 ET 200SP HA 的分布式 IO 站，需要使用 PCS 7 Basis 
Library（不低于 V9.0）处理两条通道的值。

● 对应于两个执行设备的两个传感器连接到位于同一工作站中的两个 IO 模块。两条通道

的值可由 REDLib 处理。 

● 对应于两个执行设备的两个传感器连接到两个不同工作站中的两个 IO 模块。两条通道

的值可由 REDLib 处理。

4.6.7.5 冗余 PROFIBUS DP 网络的布局

冗余 PROFIBUS DP

S7-400H 高可用性自动化系统在每个 CPU 上都具有一个 DP 主站接口用于连接 PROFIBUS 
DP。借助连接的分布式 I/O，通过两个 IM 153-2 类型接口模块将 PROFIBUS DP 连接到 
I/O 设备。
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布局选项：为 PROFIBUS DP 提供了以下高可用性通信解决方案：

● 作为电气网络的冗余 PROFIBUS DP

● 线型、环型或星型布局中具有 OLM 的冗余光网络

冗余 PROFIBUS DP 示例

下图显示了一个带有冗余 PROFIBUS DP 的电气网络：

有效 PROFIBUS DP 总线连接失败时，冗余总线连接将接管从编码器到高可用性系统的通

信。

更多信息

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

4.6.7.6 将非冗余 PROFIBUS DP 设备连接到冗余 PROFIBUS DP

Y-Link            

首选 Y-Link 总线连接器作为冗余 PROFIBUS 主站系统到单通道 PROFIBUS 主站系统的

网关。 
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Y-Link 的结构

Y-Link 由两个 IM 153‑2 接口模块和一个 Y 耦合器组成。Y 耦合器是 Y-Link 的一个组件，

用于将较低等级的 PROFIBUS DP 连接到 IM 153‑2 中的 DP 主站。 

说明

组态 Y-Link 时，请仅使用有源背板总线模块。

Y-Link 的属性

● 发生故障时，Y-Link 会将整个 I/O 线路无扰动地切换到冗余 H 系统的有效 PROFIBUS 
DP。

● 从可编程控制器视角来看，Y-Link 是一个 DP 从站，而从下层 DP 主站系统视角来看，

它是一个 DP 主站。

● 传输速率：

– 对于与 H 系统的连接：从 9.6 Kbps 到 12 Mbps
– 对于切换的 PROFIBUS DP：从 187.5 Kbps 到 1.5 Mbps

● 容量：

– S7-400H 上 Y-Links 的数量只受最大总线节点数 126 的限制。

– 每个底层 DP 主站系统中的节点数不能超过 64。

● 支持运行中修改组态 (CiR)

● 采用模块化设计，通过有源背板总线安装在 S7-300 导轨上
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● 通过 RS-485 中继器在底层 DP 主站系统和电源之间实现隔离

● 防护等级为 IP 20（防护等级 (页 716)）

更多信息

● 手册《DP/PA Link 和 Y-Link 总线耦合器》

4.6.7.7 将现场设备连接到 PROFIBUS DP

PA Link        

PA-Link 是 PROFIBUS DP 与 PROFIBUS PA 之间的首选网关。 

PA Link 的结构

PA Link  由一个 IM 153-2  接口模块和最多 5 个 DP/PA 耦合器组成。PA Link  可通过两

个 IM 153-2  连接到冗余 PROFIBUS DP。

DP/PA 耦合器

DP/PA 耦合器是 PROFIBUS DP 与 PROFIBUS PA 之间的物理链路器。DP/PA 耦合器

在 Ex 和非 Ex 系列中均可使用。

如果设备数量较少，实时要求不高，而且不使用冗余 PROFIBUS DP，则 DP/PA 耦合器也

可在“单机”模式（无 IM 153-2）下运行。 
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通过 PROFIBUS PA 通信

PROFIBUS PA 使用与 PROFIBUS DP 相同的通信协议；其通信服务和帧完全相同。 

每个 PROFIBUS PA 段都必须通过 SpliTConnect 端接器来终止。

PA Link 的属性

● 发生故障时，PA Link  会无波动切换到冗余 H 系统的激活 PROFIBUS DP。

● 使用特殊总线模块时，可于在线运行期间对模块进行“热交换”。

● 容量：

– 最多可将 5 个 DP/PA 耦合器连接到一个 PA Link  上。

– 每个底层 PROFIBUS PA 中的节点数不能超过 64 个。

● 支持运行中修改组态 (CiR)

● 隔离较高级别的 DP 主站系统

● 适用于在有爆炸危险的区域（危险区）中连接传感器/执行器

● 通过 ES 中集成的 SIMATIC PDM 工具组态、调试和诊断 PA Link 及连接的现场设备
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PA Link  或 DP/PA 耦合器

PA Link  或 DP/PA 耦合器的使用取决于以下因素：

● 工厂规模

● 所需性能

● 所使用的自动化系统

组件 PA Link DP/PA 耦合器

结构 PA Link  由以下元件组合构建而

成：

● 接口模块 IM 153-2 以及

● DP/PA 耦合器

（标准情况时最多 2 个；对于危

险区最多 5 个）

● 单机操作，无可附加的组

件

● 集成的 PROFIBUS PA 电
源和总线端子

使用和性能 适用于需进行大量寻址和对周期时

间要求高的情况

适用于设备数量少、实时要求

低的情况

传输

速率

● 在 DP 端：从 9.6 Kbps 到 12 
Mbps（最大值）

● 在 PA 端：31.25 Kbps

● 在 DP 端：45.45 Kbps
● 在 PA 端：31.25 Kbps

功能 自动化系统通过 PA Link （DP 从
站）对现场设备间接寻址。

使用 DP/PA 耦合器时，自动

化系统对现场设备直接寻址；

换言之，DP/PA 耦合器是透

明的。

外壳安全级别 可以使用针对危险区的设计。 

危险区中只能使用传感器和执行

器！

可以使用针对危险区的设计。

危险区中只能使用传感器和执

行器！

冗余 具有两个 IM 153-2 模块的组态可

在 H 系统中使用。

-

诊断 通过诊断帧和 LED 通过 LED

连接 HART 设备

有关如何连接 HART 设备的信息，请参见“连接 HART 设备 (页 101)”部分。
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更多信息

● 请参见操作指南《DP/PA 耦合器、有源现场分配器、PA Link 和 Y Link》(DP/PA coupler, 
Active Field Distributor, PA Link and Y Link)

4.6.7.8 冗余 PROFIBUS PA 网络的组态

冗余 PROFIBUS PA    

可将 PROFIBUS PA 组态为冗余，以补充 PROFIBUS DP。

将冗余 PROFIBUS PA 连接到冗余 DP/PA 耦合器。如果某个通信路径出现故障，则该通

信路径中到现场设备的支线将得以保全。

高可用性通信解决方案

提供以下通信解决方案以提高系统可用性：

● 使用有源 AFD (Active Field Distributor) 的环形冗余

● 使用 AFS (Active Field Splitter) 的耦合器冗余

FDC 157-0 DP/PA 耦合器可独立使用，也可在 PA Link 中使用。

每个 PA Link 最多可连接 2 个冗余 PROFIBUS PA。

将高可用性 PROFIBUS PA 连接到 PROFIBUS DP

可按照以下方式将高可用性 PROFIBUS PA 连接到 PROFIBUS DP： 

● 使用两个 IM 153-2 实现到冗余 PROFIBUS DP 的冗余连接

● 使用一个 IM 153-2 实现与 PROFIBUS DP 的单通道连接

使用 AFD 或 AFS 连接 PA 设备时，建议在 PCS 7 中设置以下组态限制：

● 在一个冗余 DP/PA 耦合器上最多使用 8 个 AFD，每个 AFD 最多连接 4 个现场设备（每

条支线一个现场设备）

● 在一个冗余 DP/PA 耦合器上最多使用 4 个 AFDIS 或 AFDiSD，每个 AFD 最多连接 6 
个现场设备（每条支线一个现场设备）

● 与冗余 DP/PA 耦合器连接的 1 个 AFS 

● 每个 PROFIBUS PA 最多可连接 31 个现场设备。
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高可用性 PROFIBUS PA 实例

下图显示了通过 AFD 和 AFS 进行的现场设备连接。与 PROFIBUS DP 的连接显示为冗余

链接。

更多信息

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

4.6.7.9 在 PROFIBUS 上规划诊断

诊断中继器

建议使用诊断中继器为 PROFIBUS DP 段（铜缆）提供详细诊断。如果出现故障，它将

向 DP 主站发送诊断报警并给出有关故障类型和位置方面的详细信息。

准则：为能够定位网络中的故障，诊断中继器必须能识别所连 PROFIBUS 子网的拓扑结

构。通过“准备线路诊断”功能，诊断中继器可得出到所有节点的距离，并将数据保存在
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一个内部表中。中继器随后可通过计算与线路故障的距离，并依据该表来查明故障发生在

哪两个节点之间。

诊断中继器的属性

诊断中继器具有以下特点：

● 诊断两个 PROFIBUS 段的功能

该诊断功能既能定位电缆故障位置，又能定位故障原因，如电缆破裂或缺少端接电阻

器。 

● 三个 PROFIBUS 段的中继器功能

诊断中继器可放大总线电缆的数字信号和连接各个 RS 485 段。

● 传输速率：从 9.6 Kbps 到 12 Mbps 
还可在“网络/总线系统的最高传输速率 (页 66)”部分找到相关信息。

● 电缆长度

若使用标准电缆，诊断中继器可监视每个 PROFIBUS 段中的 100 米电缆。

说明

请仅使用主动背板总线模块。
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更多信息

● 手册《PROFIBUS-DP 的 SIMATIC 诊断中继器》(SIMATIC Diagnostic Repeater for 
PROFIBUS-DP)

● 手册《过程控制系统 PCS 7；服务支持和诊断》

4.6.8 使用 PROFINET 的现场总线 

4.6.8.1 使用 PROFINET 规划现场级

概述

PROFINET 是 PROFIBUS 用户组织 (PNO) 的开放标准，它完全符合 IEEE 标准并与以太

网兼容。以下是 PROFINET 数据通信的最低要求：   

● 通过铜缆或光缆传输的 100 Mbps 数据通信（100 Base TX 和 100 Base FX）

● 全双工传输

● 交换式以太网

● 自动协商（传输参数协商）

● 自动跨接（交换机中发送和接收线路相互跨接）

● 无线通信 

现场总线集成

PROFINET 允许轻松连接基于 PROFIBUS PA 的现有现场总线系统，而无需对现有 PA 现
场设备进行更改。   

分布式现场设备

同样地，PROFINET 允许将分布式现场设备连接到现场总线。   

可用的模块或设备（例如，具有 DP 功能的智能现场设备）可与具有 PROFINET 功能的连

接接口或 Link 模块配合使用。

有关 PROFINET 的更多信息，请参见《SIMATIC PROFINET 系统描述》(SIMATIC 
PROFINET system description) 手册。

运行中组态 (CiR)

对于某些因自动化过程较为复杂或重启成本较高而在操作期间不能关闭的过程单元，在运

行期间对其进行组态很有必要。
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更多 CiR 相关信息，请参见手册《过程控制系统 PCS 7；CPU 410 过程自动化》(Process 
Control System PCS 7; CPU 410 Process Automation)。  

PROFINET 用作 PCS 7 中的现场总线

PCS 7 允许安装具有以下组件的 PROFINET 网络：   

● 分布式 I/O 设备，例如：

– 带 IM 155-6PN HA 的 ET 200SP HA 
– 带 IM 153-4PN HF 的 ET 200M 
– 带 IM 155-6PN HF 的 ET 200SP
– PN-Field 设备

● IE/PB Link PN IO ，用于连接智能 DP 现场设备

● IE/PB Link PN IO ，带下游 DP/PA 耦合器，用于连接 PA 现场设备

● Compact Field Unit PA，用于连接 8 个 PA 现场设备和 8 个空闲的可组态通道

有关将 SIMATIC PCS 7 于 PROFINET 结合使用的更多信息，请参见 SIMATIC PCS 7 
与 PROFINET 结合使用 (https://support.industry.siemens.com/cs/ww/en/view/72887082)

更多相关信息，请参见产品概述《过程控制系统 PCS 7；已发布模块》(Process Control 
System PCS 7; Released Modules)。
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4.6.8.2 PROFINET 组态

PROFINET 拓扑

拓扑符号

以下符号表示在 PROFINET 架构中使用的特殊机制，用于标识 PN 设备中的可用性和/或
冗余性：

符号 定义

Line

单线型表示无可用性。只有冗余 PROFINET 
总线型拓扑能够提升可用性。冗余 
PROFINET 总线型拓扑需要使用特殊 PN 设
备工作模式 (R1)。

MRP
环型表示高可用性拓扑。PROFINET 使用 
MRP（介质冗余协议）。PROFINET IO 环
型拓扑可通过具有 MRP 功能的 PN 设备或/
和交换机构建。必须组态 MRP 环型拓扑，

否则会创建一个回路，这会导致网络故障。

PROFINET IO：要拆分 PROFINET 总线型

拓扑，仅需使用一部多通道交换机（支持 
PROFINET）。星型拓扑表示可用性的提

升，但不表示高可用性。冗余 PROFINET 
星型拓扑需要使用特殊 PN 设备工作模式 
(R1)。 
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外设组件

单外设组件

符号 定义

S1

外设或工作站仅通过一个接口模块（设备/工
作站的 IM）与控制器相连。此外，对应于

工作站的设备仅与组态中的一个控制器相连

（单个系统或高可用性系统内的一侧组态）。

在 PROFINET IO 环境中，此类连接称

为“单 PROFINET (S1)”。

冗余外设组件（使用 H 系统）

符号 定义

R 1

要实现外设的系统连接，使用两个接口模

块。接口模块连接至其高可用性系统的相应

控制器。

在 PROFINET IO 环境中，此类连接称

为“冗余 PROFINET (R1)”。

S2

此外，还可通过一个接口模块连接高可用性

系统。在这种情况下，接口模块通过两路逻

辑连接与高可用性系统的每个控制器相

连。 

在 PROFINET IO 环境中，此类连接称

为“系统冗余 (S2)”。

可用性变型

● 高可用性

高可用性将通过所有类型的机制提高可用性。可通过冗余或单个环型拓扑提高可用性。

设置为环型拓扑的总线系统属于高可用性系统。在环型结构中，即使环中任何位置的传

输电缆断开连接（例如，由于出现断线），信号路径仍保持完好无损。

● 冗余 I/O（分布式 I/O）

传感器/执行器的整个信号路径均采用冗余组态。
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● 切换 I/O（分布式 I/O）

I/O（站）的通信路径是冗余的。仅有一个输入/输出模块 (SM) 处理过程信号。 

● 系统冗余（使用 H 系统）

系统冗余仅可用于高可用性系统。PN 设备必须支持“系统冗余”功能 (S2)。两路逻辑

有效连接将独立于物理连接使用。物理层可以冗余、高可用性或独立！

● 冗余

冗余组件、软件或技术解决方案介绍了存在两种组件、软件或技术解决方案的情况。

PROFINET IO 特性

特征

PCS 7 支持 PROFINET IO 的以下功能：

特征 定义

CiR
需要通过 CiR（运行中组态）在系统运行过

程中更改设备对应工作站或控制器自身参

数。 

如果不支持该功能，则无法更改外设/工作

站。这将在一定程度上导致信号故障（基

于 PROFINET IO）。设备缺少 CiR 功能可

能影响网络中工作站的组态变更。

SoE 基于现场总线的时间同步。 

ready

PROFINET IO：按照相关标准，如果 PN 设
备可以实现下列三种功能，则适用于过程自

动化：

● 支持系统冗余 (S2)
● MRP 功能

● 支持 CiR
其他有效功能（可选）：支持高可用性系统

冗余 (R1) 或 SoE 功能
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建议使用的外设与拓扑组合

连接名称 符号 拓扑 外设接口

单 PROFINET 总线型拓

扑
S1

单总线型拓扑

Line

单 IM (S1)

S1

高可用性 PROFINET 
(MRP)

S1
单环型 (MRP)

MRP

单 IM (S1)

S1

系统冗余 (S2)
S2

单总线型或单星型/层级

Line

单 IM (S2)

S2

高可用性系统冗余 (MRP/
S2) 

S2

单环型 (MRP)

MRP

单 IM (S2)

S2

系统冗余 (S2)
CiR

S2 Line
MRP

S2 ready

冗余 PROFINET (R1)
R 1

CiR

双总线型或双星型

LineLine

双 IM (R1)

readyR 1

冗余高可用性 
PROFINET (MRP/R1) 

R 1

CiR

双环型 (MRP)

MRP MRP

双 IM (R1)

readyR 1

4.6.8.3 使用 PROFINET 组态 IO 设备

下图所示示例介绍了几种通过 PROFINET 现场总线将 IO 设备集成到 AS 的最佳结构。

● 使用 MRP 将（非冗余）单独 PROFINET 现场总线连接到 AS

● 将单独 IO 设备连接到冗余 AS（S2 冗余）

● 将冗余 IO 设备连接到冗余 AS（R1 冗余）

● 使用 MRP 通过环形拓扑将冗余 IO 设备连接到冗余 AS（R1 冗余）
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使用 MRP 通过环形拓扑将（非冗余）单独 PROFINET 现场总线连接到 AS

MRP

S1

将单独 IO 设备连接到冗余 AS（S2 冗余）

S2

将冗余 IO 设备连接到冗余 AS（R1 冗余）

R 1

Line

使用 MRP 通过环形拓扑将冗余 IO 设备连接到冗余 AS

R 1

MRP MRP
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更多信息

有关使用冗余设备的更多信息，请参阅功能手册《过程控制系统 PCS 7；高可用性过程控

制系统》(Process Control System PCS 7; HighAvailability Process Control Systems)。

4.6.8.4 将现场设备连接到 PROFINET IO

IE/PB-Link and CFU        

IE/PB Link  是 PROFINET IO 和 PROFIBUS DP 之间的网关。要连接现场设备，您还需要

添加 PA 耦合器连接器。

对于现场设备而言，CFU PA 是 PROFINET IO 与 PROFIBUS PA 之间的网关。

4.6.9 与其它系统的数据链接

4.6.9.1 与其它系统的数据链接简介

简介

在 PCS 7 环境中，全集成自动化(TIA)提供了用于组态多种通信任务的解决方案。   
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潜在通信伙伴

TIA 解决方案可用于通过以下协议进行通信的设备和工厂：

● HART 设备 (页 101)

● MODBUS (页 103)

● AS 接口 (页 104)

4.6.9.2 连接 HART 设备

什么是 HART？ 

HART（Highway Addressable Remote Transducer，可寻址远程传感器高速通道）是一种

串行传输方法，用于在 4 - 20 mA 电流环路上向所连接的测量传感器和执行器传输附加参

数数据（如测量范围或阻尼）。 

PCS 7 中使用的 HART 设备

HART 设备可以和以下 ET 200 系列在 PCS 7 中共同使用：

● ET 200M 

● ET 200iSP 

● ET 200SP

● ET 200SP HA

对于所有这些设备，以下内容适用：

● HART 设备可以连接到特殊模拟 HART 电子模块。 

● 可通过 HART 电子模块连接经认证可以使用 HART 协议进行数字通信的所有传感器或 
HART 执行器。

对于 ET 200M 系列，以下内容适用：

● 通过支持 HART 的特殊 S7-300-Ex IO 模块，可连接到经认证可以在危险区域中使用

的 HART 设备。

带 HART 的 S7-300-EX 模块具有诊断能力（具有通道和模块诊断功能）。

● 在标准环境以及危险区域中，HART 设备均可连接到特殊的 IO 模块。
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组态示例

在危险区域中使用

● 在危险区域 2 区中的 ET 200M 上

● 在危险区域 1 区和 2 区中的 ET 200iSP 上

HART 现场设备的组态

可使用 SIMATIC PDM 为 PCS 7 组态 HART 现场设备。
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4.6.9.3 连接 Modbus

Modbus

Modbus 是一种开放式串行通信协议。Modbus 协议用于将第三方系统联网。由于 Modbus 
的最大传输速率为 38.4 Kbps，因此推荐在总线节点数很少并且对实时性要求不高的情况

下使用。        

连接 Modbus

Modbus 通过分布式 I/O 站 ET 200M 中插入的 CP 341 连接到 PCS 7。CP 341 可以使用

点对点连接协议以及 Modbus 协议进行更快速的数据通信。

CP 341

CP 341 有以下 3 种型号（接口物理特性）：

● RS 232C (V.24)

● 20 mA (TTY)

● RS 422/RS 485 (X.27)

Modbus 主站和 Modbus 从站需要使用特殊的驱动程序才能实现 Modbus 连接。这些驱动

程序必须单独订购。

更多信息

● 手册《SIMATIC CP 341 点对点连接；安装和参数分配》(SIMATIC CP 341 Point-to-
Point Connection; Installation and Parameter Assignment)

● 手册《用于 PtP CP 的 SIMATIC 可加载驱动程序；Modbus 协议 RTU 格式；S7 是主

站》(SIMATIC Loadable Drivers for PtP CPs; Modbus Protocol RTU Format; S7 is 
Master)

● 手册《用于 PtP CP 的 SIMATIC 可加载驱动程序；Modbus 协议 RTU 格式，S7 是从

站》(SIMATIC Loadable Drivers for PtP CPs; Modbus Protocol RTU Format, S7 is 
Slave)
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4.6.9.4 连接 AS 接口

AS 接口 (AS-i) 

执行器传感器接口（AS 接口）是一种多供应商网络系统，用于简单的且通常是最低现场级

的二进制执行器和传感器。AS 接口是一种基于 EN 50 295 的国际标准接口。

通过 AS 接口，可寻址常见的 2 线电缆上所有的传感器和执行器，同时为它们提供所需的

电源电压。 

将 AS 接口连接到 PROFINET IO 或 PROFIBUS DP

在 PCS 7 工厂中，您可以选择以下方法通过 AS 接口连接现场设备。

● 通过 PROFINET IO 连接 AS 接口：

– 使用带有 AS 接口主模块 CP 343‑2 的 ET 200M

● 通过 PROFIBUS DP 连接 AS 接口：

– 使用带有 AS 接口主模块 CP 343‑2 的 ET 200M
– 使用 DP/AS 接口连接器 

将 AS 接口连接到 PROFIBUS DP

AS 接口通过连接到 PROFIBUS DP 的 DP/AS 接口连接到 PCS 7。 

AS 接口作为底层总线通过 DP/AS 接口连接器集成到 PCS 7 中。这种做法的结果就是无法

使用 PCS 7 的全部功能（例如，无法使用诊断功能）。
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AS 接口依照主站从站原则运行。通过 AS 接口线路连接的传感器/执行器会被主站 DP/AS 
接口连接器控制为从站。

从 PROFIBUS DP 主站系统角度来看，DP/AS 接口连接器是一个 DP 从站。 

PROFIBUS DP 与 AS 接口是电气隔离的。

DP/AS 接口连接器

可使用以下 DP/AS 接口连接器：

● 防护等级为 IP20 的 DP/AS 接口连接器 Advanced

● 防护等级为 IP20 的 DP/AS 接口连接器 20E

所有 DP/AS 接口连接器都可以在最大传输速率为 12,000 Kbps 的 PROFIBUS DP 上运

行。 

以下为组态时的必备项： 

● 电源

● PROFIBUS 连接器插头

● AS 接口连接插座

更多信息

● 手册《SIMATIC NET；CP 343-2 / CP 343-2 P AS 接口主模块》(SIMATIC NET ; CP 
343-2 / CP 343-2 P AS-Interface master) 

● 手册《SIMATIC NET；DP/AS 接口连接器 Advanced》(SIMATIC NET; DP/AS 
INTERFACE LINK Advanced)

● 手册《SIMATIC NET；DP/AS 接口连接器 20E》(SIMATIC NET; DP/AS-Interface Link 
20E)
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4.6.10 管理级别和远程访问

4.6.10.1 连接到 MIS/MES

到 MIS/MES 的连接选项   

可通过以下选项将 MIS/MES 系统连接到 SIMATIC PCS 7：

● 连接到 IT 世界 - SIMATIC IT (页 106) 

● 通过 OPC 连接 HMI 系统 (页 109) 

● 通过 OpenPCS 7 连接到 IT 世界 (页 108) 

● 通过 PCS 7 Web 客户端访问 PCS 7 OS (页 109) 

更多信息

说明

将 MIS/MES 系统连接到 SIMATIC PCS 7 时，还应遵守白皮书《PCS 7 和 WinCC 的安全

性概念》(Security Concept PCS 7 and WinCC) 中的信息。

4.6.10.2 连接到 IT 世界 - SIMATIC IT

SIMATIC IT

SIMATIC IT 是一个用于 MES（Manufacturing Execution Systems，制造执行系统）的技

术平台，它以 ISA 95 标准为基础。根据此标准，明确的业务和生产规则对功能加以协调，

以实现最佳工作流。      

SIMATIC IT 具有以下主要部分：

● SIMATIC IT 建模器

● SIMATIC IT 组件
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SIMATIC IT 建模器

SIMATIC IT 建模器连接自动化级与 ERP（Enterprise Resource Planning，企业资源计划）

级：

● 工厂控制和生产控制等级

● 公司和设计等级

SIMATIC IT 建模器是一个跨行业的集成和协作平台，用于操作各种过程、数据和功能。除

了一些用于内部程序控制、用户管理等的基本功能外，还具有用于工厂和生产建模的功能。

SIMATIC IT 组件

SIMATIC IT 生产建模器和 SIMATIC IT 组件的功能和体系结构符合 ISA-95 标准。每个 
SIMATIC IT 组件都专门用来完成某一特定任务，该任务符合 ISA-95 标准的某一项功能。

这些组件一起实现 ISA-95 标准的所有标准生产功能。在 SIMATIC IT 软件中使用 ISA-95 
术语，例如“物料清单”(Material list)。

SIMATIC IT 组件：

● SIMATIC IT Production Suite（基本 MES 功能，如物料管理、产品订单管理等）

● SIMATIC IT Historian（工厂性能分析和归档）

● SIMATIC IT Unilab（实验室信息管理系统）

● SIMATIC IT Interspec（产品规格管理系统）

● 详细的生产调度程序

● SIMATIC IT 库

PCS 7 的连接

SIMATIC PCS 7 过程控制系统通过 CP 443-1 集成到 SIMATIC IT。

更多信息

● 手册《SIMATIC PCS 7/SIMATIC IT 集成手册》

● 在 Internet (https://support.industry.siemens.com/cs/cn/zh/view/26639558) 上 
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4.6.10.3 通过 OpenPCS 7 连接到 IT 世界

OpenPCS 7

使用装有 OpenPCS 7 的 PC 站（OpenPCS 7 站），无需具有拓扑或 PCS 7 OS 安装相关

的知识即可与外部系统交换数据。 

可以使用 OpenPCS 7 与下列等级进行数据交换： 

● 自动化等级

● 工厂控制和生产控制等级

● MES 等级（制造执行系统）

● ERP 等级（企业资源规划）

标准接口格式

OpenPCS 7 使用下列标准接口格式进行数据交换：

● OPC UA（统一架构）

● OPC DA（数据访问）

● OPC A&E（报警和事件以及历史报警和事件）

● OPC HDA（历史数据访问）

● OLE DB（在具有 OLE 功能的应用程序（例如 MS Office）中的数据集成）

更多信息

● “OpenPCS 7 站的组态 (页 161)”部分

● 手册《过程控制系统 PCS 7；OpenPCS 7》(Process Control System PCS 7; 
OpenPCS 7)

● “如何插入 OpenPCS 7 站 (页 281)”部分

● “如何组态 OpenPCS 7 以访问 PCS 7 数据 (页 613)”部分
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4.6.10.4 通过 OPC 连接 HMI 系统

OPC      

“用于过程控制的 OLE”(OPC, OLE for Process Control) 提供了用于和大量数据源进行通

信的标准机制。这些数据源是工厂中的机器还是控制室中的数据库并不重要。OPC 基于 
Microsoft 的 OLE/COM 技术。

有关 OPC 的详细信息，可参考 OPC Foundation 出版的文档《用于过程控制的 OLE 数据

访问标准 V2.0》(OLE for Process Control Data Access Standard, Version 2.0)。 

连接 HMI 系统

PCS 7 的 OPC 接口符合 OPC Foundation 的规范。可在 PCS 7 中使用过程变量来执行数

据通信（数据访问）。 

具有 OPC 数据访问服务器的 PCS 7 OS 服务器

OPC 接口的应用程序基于客户端-服务器模型。 

OPC 数据访问服务器随 PCS 7 软件一同安装。PCS 7 OS 服务器将行业数据访问通信功

能作为一个接口提供给系统。每个 OPC 客户端应用程序都可访问此 OPC 服务器的过程数

据（标签管理）。

PCS 7 OS 服务器可用于以下功能：

● OPC 数据访问服务器

● OPC 数据访问客户端

OPC 用于将一个或多个操作员站连接到 PCS 7 OS 服务器。可通过网络（例如，本地数据

网络）连接到操作员站。

更多信息

● 文档《用于过程控制的 OLE 数据访问标准 V2.0》(OLE for Process Control Data Access 
Standard, Version 2.0)

● 可以在 Internet (http://www.opcfoundation.org) 上找到 OPC 基金会地址。 

4.6.10.5 通过 PCS 7 Web 客户端访问 PCS 7 OS

PCS 7 提供的 OS Web 选件可实现通过 Internet 或 Intranet 在过程模式下使用 PCS 7 OS
（单工作站系统或多工作站系统）的操作员监控功能。       
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OS Web 选件

使用 OS Web 选件需要以下组件： 

● PCS 7 Web 服务器

使用独立的 PCS 7 Web 服务器为 PCS 7 Web 客户端提供所有必需的 OS 画面。PCS 
7 Web 服务器是具有 PCS 7 Web 服务器功能的 OS 客户端。

– OS 多工作站系统：对于 OS 多工作站系统，已组态为 PCS 7 Web 服务器的 OS 客
户端在 PCS 7 工厂中不能再用作操作站（OS 客户端）。

– OS 单工作站系统：已组态为 PCS 7 Web 服务器的 OS 单工作站系统在 PCS 7 工
厂中仍可用作 PCS 7 OS。

● PCS 7 Web 客户端

PCS 7 Web 客户端是 Intranet/Internet 中安装有 Internet Explorer 的计算机。用户在 
Internet Explorer 中通过 Web 页面登录到 PCS 7 Web 服务器。PCS 7 Web 服务器控

制具体用户对项目数据的访问。可对此访问过程进行操作和监视。

PCS 7 Web 客户端工作原理

用户通过 PCS 7 Web 客户端的 Internet Explorer 登录对话框登录到 PCS 7 Web 服务器，

然后即可访问与其用户权限（在“用户管理器”WinCC 编辑器中设置）相对应的所有功能。

PCS 7 Web 客户端上执行的所有操作都将以工厂操作员的名义自动记录下来。 

举例来说，PCS 7 Web 客户端提供了以下功能： 

● 操作员监控功能，OS 上也使用这些功能。

● 基于具体用户启动的消息列表，启动方式与在 OS 客户端上的方式相同。也可确认消

息，但这取决于用户。

● 根据工厂层级显示画面层级

● 包括“报警循环”功能在内的批处理消息功能

● 声音报警指示

● 扩展状态显示

说明

并非所有功能均可用。有关可用功能的信息，请参见手册《过程控制系统 PCS 7；OS 
Web 选件》(Process Control System PCS 7; Web Option for OS)。
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更多信息

● 手册《过程控制系统 PCS 7；OS Web 选件》(Process Control System PCS 7; Web 
Option for OS)

● 手册《过程控制系统 PCS 7：SIMATIC BATCH》Process Control System PCS 
7:SIMATIC BATCH
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4.7 选择 PC 组件

4.7.1 可以使用哪些 PC 组件？

简介

公司提供有各种各样的基本设备可用作工程师站 (ES)、操作员站 (OS)、维护站 (MS)、
BATCH 站 (BATCH) 和 Route Control 工作站，并且可用于将 SIMATIC PCS 7 连接到 IT 
世界。基本设备由以下组件组成：

● 基本硬件（PC 基础单元）

● 彩色监视器

有关推荐设备和最低基本硬件的最新信息

有关每个 PCS 7 新版本的推荐设备和最低基本硬件的最新信息，请参见 PCS 7 自述文件

（在线）。

本版本包含 PCS 7 安装和使用的所有信息。该文件只在 Internet 上提供，以便我们使其保

持更新。 

网络

必须使用交换机、路由器或网关隔离 PCS 7 系统的网络，以防止办公网络对 PCS 7 网络

的干扰。

更多信息 

● “AUTOHOTSPOT”

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

● 白皮书《PCS 7 和 WinCC 的安全性概念》

● 目录 ST PCS 7 AO（SIMATIC PCS 7 的附件）
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4.7.2 PCS 7（包）的预组态系统

基本硬件 

特殊版本的基本硬件（包）可用于工程师站 (ES)、操作员站 (OS)、BATCH 站 (BATCH)、
Route Control 工作站，并且可用于将 SIMATIC PCS 7 连接到 IT 世界。这些包针对特殊

应用进行了优化。  

SIMATIC PCS 7 BOX 基本硬件

SIMATIC PCS 7 BOX 是工业 PC。在小型工厂采用 SIMATIC PCS 7 BOX。 

我们提供了多种可在 PCS 7 中使用的 SIMATIC PCS 7 BOX PC（PC 包）：

有关该设备的信息，请参见手册《过程控制系统 PCS 7；SIMATIC PCS 7 BOX》(Process 
Control System PCS 7; SIMATIC PCS 7 BOX)。

彩色监视器

Siemens 提供一系列工业监视器作为过程监视器使用。这些监视器是根据工厂的环境温度

来选择的。

通过多监视器 PC 安装最多可为工作站（OS 客户端）连接 4 台监视器。可通过 1 个键盘

和 1 个鼠标对以这种方式拆分的工厂区域进行管理。

更多信息 

● 目录 ST PCS 7

● 目录 ST PCS 7 AO（SIMATIC PCS 7 的附件）

4.7.3 连接 PC 组件

有关连接 PC 组件的信息，请参见“将网络节点连接到以太网 (页 75)”部分。  
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4.7.4 用于发送声学和光学信号的附加组件

信号模块

可以用信号模块扩展 OS 单工作站系统和 OS 客户端。这些信号模块可以控制代表各种消

息类别的报警器以及最多 3 个不同的灯或蜂鸣音。      

使用硬件定时器（看门狗）时，信号模块可以检测操作员站故障并发出相关信号。还可以

连接硬件确认按钮。 

信号模块安装在操作员站的 PCI 插槽中。

声卡

也可以使用操作员站中已安装的标准声卡。 

更多信息 

● 有关信号模块的功能及安装的信息，请参见《WinCC 信息系统》(WinCC Information 
System) 中“选项 > 过程控制选项”(Options > Options for Process Control) 下的内容。

● 有关组态有声信号设备的更多信息，请参见组态手册《过程控制系统 PCS 7；操作员

站》(Process Control System PCS 7; Operator Station)。
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4.8 选择 AS 组件

4.8.1 选择 AS 的标准是什么？

PCS 7 中的自动化系统

PCS 7 过程控制系统采用从 SIMATIC AS-41x 产品系列中挑选的组件为基础。可根据工厂

需求选择自动化系统：

● 标准自动化系统

● 高可用性自动化系统（H 系统）

● 如果自动化系统采用了 CPU 41xH，则可以组态故障安全自动化系统。

使用 PCS 7 CPU 410 过程自动化在运行时进行更改

可在运行中使用以下功能：

● 运行期间扩展 CPU 410 组态限制

自动化系统 在线升级最大数量的 CPU 410-5H 过程对象

具有 CPU 410‑5H（固件

版本 8.1 或更高版本）的 
AS 410H 的功能

AS 可加载过程对象的最大数目由 AS 系统扩展卡 (SEC) 
上的特定存储容量指定。

特定容量必须包含不少于为 AS 组态的过程对象的数量。

系统扩展卡的特定容量可以通过 CPU 410 扩展包进行扩

展，在运行时最多可扩展至 PO 2600（等同于 PO 
2000+）。 

● 更改 AS 块的接口

自动化系统 运行中更改接口

具有 CPU 410‑5H（固件

版本 8.1 或更高版本）的 
AS 410H 的功能

下列操作可用：

● 为 AS 块下载接口更改

● 从其它库中向 AS 下载块

● 逐步更新 AS 库 

● 更改参数分配
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● 更改程序

● 更改 AS 组件的组态

自动化系统 运行中更改组态 (CiR/HCiR)

所有自动化系统支持的功

能

下列操作可用：

● 添加/删除新从站

● 添加/删除新模块

● 为插入的模块设置新参数。

● 对于 CPU 410 V8.2，可以在 PROFINET 上使用 CiR/
H-CiR。

高可用性自动化系统的附

加功能

下列操作可用：

● 更改存储器容量

● 更改 CPU 参数（在 HW Config 中标记为蓝色：例如：

CPU 属性 > 保护 > 密码保护 (CPU Properties > 
Protection > Password Protection)）

● 添加/删除 S7-400 模块

带集成 AS 的 SIMATIC PCS 7 BOX PC，适合小型工厂的 CPU

SIMATIC PCS 7 BOX 提供了可在其中集成 PCS 7 AS/ES/OS/RC/BATCH 组件的各种工

业 PC。SIMATIC PCS 7 BOX 用于可集成在 PCS 7 网络中的自治小型工厂或组合的 AS/
OS 站。如果自动化系统集成到 SIMATIC PCS 7 BOX，则该系统将始终是一种标准自动化

系统。 

在 PCS 7 中，可使用以下 SIMATIC PCS 7 BOX PC（PC 包）：

● SIMATIC PCS 7 BOX RTX：安装有 PLC WinLC RTX 软件的 BOX PC

● SIMATIC PCS 7 AS mEC RTX：采用 S7-300 设计安装有 PLC WinLC RTX 软件的 AS

● SIMATIC PCS 7 AS RTX：安装有 PLC WinLC RTX 软件的 MICROBOX PC

有关使用 SIMATIC PCS 7 BOX 所需的所有信息，请参见手册《过程控制系统 PCS 7；
SIMATIC PCS 7 BOX》(Process Control System PCS 7; SIMATIC PCS 7 BOX)。

选择自动化系统的标准 

由于对自动化系统的需求非常广泛，所以很难对该系统下一个精确的定义。下面概述了选

择自动化系统时要注意的最重要信息：

● “实现自动化需要多少 CPU？ (页 49)”部分

● “可集成多少设备、传感器和执行器？ (页 50)”部分
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● “PCS 7 的冗余概念 (页 54)”部分

● “PCS 7 的运行可靠性概念 (页 56)”部分

以下几个部分包含有关实际选择自动化系统和要连接的 I/O 组件的更多信息。

更多信息

● “如何将其它库中的对象复制到主数据库 (页 313)”部分

● “针对 RUN 模式下的组态更改 (CiR) 在 PROFIBUS DP 上组态分布式 I/O 设备 
(页 401)”部分

● 可用组件列表

产品概述《过程控制系统 PCS 7 - 已发布模块》(Process Control System PCS 7; 
Released Modules) 中介绍了可用于 PCS 7 版本的所有模块的列表。

● 有关传送和更新许可证密钥的详细信息，请参见以下文档：

– 功能手册《过程控制系统 PCS 7；服务支持和诊断》(Process Control System PCS 
7; Service Support and Diagnostics)

– 在线帮助《SIMATIC；自动化许可证管理器》(SIMATIC; Automation License 
Manager)

4.8.2 自动化系统概述 (AS 41x)

4.8.2.1 自动化系统简介

PCS 7 自动化系统的组件 (AS 41x)

自动化系统可作为已预装配的完整系统使用。自动化系统基本上由以下组件组成：

● 带有 4 个、9 个或 18 个插槽的模块机架

● 电源

● S7-400-CPU
取决于 CPU 类型：

– 工业以太网接口：

CPU 和/或接口模块的集成连接

– PROFIBUS 接口：

CPU 和/或接口模块的集成连接

– 工作存储器：

CPU 或存储卡的集成存储器
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4.8.2.2 PCS 7 的单一自动化系统

概述

提供以下预组装的完整系统，以用作标准自动化系统：     

● 下表是几个精选完整系统的技术规范。

● 有关可能的设备变型的更多信息，请参见目录 ST PCS 7 和/或 CA 01。 

● 有关组态限制的相关信息，请参见文档《过程控制系统 PCS 7；许可证和组态限制》

(Process Control System PCS 7; Licenses and Configuration Limits)。

带 APL 的
自动化系统

AS 410 *) AS
RTX

AS
mECAS

410E
AS
414‑3

AS
414-3IE

AS
416-2

AS
416-3

AS
416-3IE

AS
417-4

模拟值测量 50 50 100 200 400 400 500 300 300

数字值测量 150 160 250 450 800 800 1 000 600 600

PID 控制器 30 35 50 75 150 150 180 200 200

电机 40 40 75 100 200 200 350 150 150

阀 40 40 75 100 200 200 350 250 250

SFC 15 15 15 40 100 100 200 100 100

步 150 150 150 400 1 000 1 000 2 000 800 800

定量给料 3 3 3 15 25 25 50 50 50

数字量输入 DI 200 200 350 600 1 200 1 200 1 700 1 200 1 200

数字量输出 DO 50 60 100 200 400 400 550 400 400

模拟量输入 AI 100 100 175 300 600 600 800 600 600

模拟量输出 AO 25 30 75 100 200 200 250 200 200

过程对象 (PO) 200 200 350 600 1 200 1 200 1 800 1 200 1 200

接口

● MPI/DP 1 1 1 1 1 1 1 1 1
● DP 1 1 1 1 1  1 1 1
● DP 模块（选装）  1   1 1 2   
● PN/IE（2 端口） 1  1   1    
● TCP/IP        2 1

*) 请参见备注“AS 410”
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说明

AS 410 
AS 410 是使用 SIMATIC PCS 7 的新工厂的首选系统。它包括 CPU 410 过程自动化。

CPU 410 的接口数取决于固件版本。

● 一个固件版本为 V8.0 的 PN 接口。

● 自固件版本 V8.1 起，支持两个 PN 接口。

有关此自动化系统的更多详细信息，请参见手册《过程控制系统 PCS 7；CPU 410 过程自

动化》(Process Control System PCS 7; CPU 410 Process Automation)。

4.8.2.3 PCS 7 的冗余自动化系统

概述

按以下方式配备高可用性自动化系统：     

● 有两个 CPU = ...-2H
冗余子系统放置在机架内。

● 只有一个 CPU = ...-1H
如果由于安全等原因而必须在空间上隔离冗余子系统，则采用此类自动化系统。

详细信息

提供以下预组装的完整系统，以用作高可用性自动化系统：   

● 下表是几个精选完整系统的技术规范。

● 有关可能的设备变型的更多信息，请参见目录 ST PCS 7 和/或 CA 01。 

● 有关组态限制的相关信息，请参见文档《过程控制系统 PCS 7；许可证和组态限制》

(Process Control System PCS 7; Licenses and Configuration Limits)。

带 APL 的
自动化系统

AS 410H *)

AS 410E AS 
412H

AS 
414H

AS 
416H

AS 
417H

模拟值测量 10 10 100 400 600

数字值测量 20 20 250 800 1 000

PID 控制器 5 5 50 150 200

电机 7 7 75 200 400

规划工厂的工程组态

4.8 选择 AS 组件

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 119



阀 7 7 75 200 400

SFC 0 0 15 100 200

步 0 0 150 1 000 2 000

定量给料 0 0 3 25 50

数字量输入 DI 20 30 300 1 200 1 800

数字量输出 DO 10 10 110 400 650

模拟量输入 AI 15 15 150 600 900

模拟量输出 AO 5 5 50 200 350

过程对象 (PO) 200 30 350 1 200 2 000

接口

MPI/DP 1 1 1 1 1

DP 1 1 1 1 1

PN/IE（2 端口） 1 1 1 1 1

*) 请参见备注“AS 410”

说明

AS 410
AS 410 是使用 SIMATIC PCS 7 的新工厂的首选系统：

● CPU 410‑5H Process Automation（1 x 或 2 x）
● 通用 CPU 的性能可以用过程对象的数量来衡量。

● AS 410H 中的接口数取决于固件版本。

有关此自动化系统的更多详细信息，请参见手册《过程控制系统 PCS 7；CPU 410 过程自

动化》(Process Control System PCS 7; CPU 410 Process Automation)。

机架 UR2-H

UR2-H 是紧凑的专用机架，由于配备有分开的背板总线，所以适于组态整个高可用性自动

化系统。
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AS 410H 分离机架配置示例 

如果使用的 AS 位于不同机架上，可以设计一种空间分离的自动化系统。

同步模块

同步模块连接两个 CPU。它们安装在 CPU 中，并通过光纤电缆互连。每个 CPU 中安装

两个同步模块。 

4.8.2.4 PCS 7 的故障安全自动化系统

概述

高可用性自动化系统用作故障安全自动化系统 AS 41xF 和 AS 41xFH 的硬件。 

根据故障安全自动化系统的类型和组态，可使用以下完整系统：

● 对于故障安全系统（F 系统 AS 41xF）：每个系统一个 AS 41x-x-1H

● 对于故障安全和高可用性自动化系统（FH 系统 AS 41xFH）：

– 两个子系统都在一个机架上：每个系统一个 AS 41x-x-2H
– 两个子系统分别在单独的机架上：每个系统两个 AS 41x‑x‑1H

通过故障安全用户程序（F 程序）的 F 运行系统许可证和编程工具/块库，您可实现以下安

全功能。 

更多信息

上表简要概述了各个完整系统。

有关可能的设备变型的详细信息，请参见目录 ST PCS 7 和/或 CA 01。 
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4.8.3 PCS 7 项目的 CPU 限制

有关 PCS 7 项目中 CPU 的一些最重要性能规范的限制信息，请参见安装手册《过程控制

系统 PCS 7；许可证和组态限制》(Process Control System PCS 7; Licenses and 
Configuration Limits)。 

4.8.4 PCS 7 项目 CPU 的默认性能参数

下表显示了有关 PCS 7 项目的 CPU 性能的默认参数。这些值在使用 PCS 7 软件组态 CPU 
时将设置为默认值。     

这些值显示在 HW Config 中的 CPU 属性中。

它们完全可以满足典型应用程序的需要，但可根据组态的需要在限制范围内进行更改。

AS 400 - PCS 7 中 CPU 的默认值

有关某个 CPU 型号的默认参数信息，可在 HW Config 中新插入的 CPU 的属性中找到。

参数 CPU 412-3H CPU 414-3 CPU 416-2
CPU 416-3

CPU 417-4

来自通信的循环加载 [%] 20

在发生 I/O 访问错误时调用 OB 
85

仅限进入和离开错误

循环监视时间 [ms] 6 000

最小周期时间 [ms] 0

过程映像（每个 I + O） 768 字节 416-2: 2 048 字节

416-3: 3 072 字节

3 072 字节

时钟存储器 无

本地数据（优先级）： (1-2, 9-12, 16, 24-28) : 758

本地数据（优先级）： (3-6, 17-19, 29) : 256 (3-8, 13-15, 17-23, 29) : 256

用户本地数据区 16 384 字节 16 384 字节 32 768 字节

最大通信作业数 600 600 2 400

针对来自模块的已完成消息的监

视时间 [100 ms]
650

针对向模块传递参数的监视时

间 [100 ms]
600
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参数 CPU 412-3H CPU 414-3 CPU 416-2
CPU 416-3

CPU 417-4

在 POWER ON 时启动 暖启动

报告 STOP 原因 开

确认触发的消息发送（QTM；

SFB 33-35） 
关

诊断缓冲区中的消息数 3 200

时间同步 无

AS 41xH - PCS 7 中 CPU 的默认值（AS 410H 除外）

参数 CPU 412-5H CPU 414-5H CPU 416-5H CPU 417-5H

循环监视时间 [ms] 6 000

最小周期时间 [ms] 0

来自通信的循环加载 [%] 20

过程映像（每个 I + O） 768 字节 3 072 字节

在发生 I/O 访问错误时调用 OB 
85

仅限进入和离开错误

时钟存储器 无

本地数据（优先级）： (1-2, 9-12, 16, 24-28) : 1024 (1-2, 7-16, 24-28) : 1024

(3-6, 17-19, 29) : 256 (3-6, 17-19, 29) : 256

(7,8, 13-15, 20-23) : 0

用户本地数据区 16 384 字节 32 768 字节

最大通信作业数 600 2 400

针对来自模块的已完成消息的监

视时间 [100 ms]
650

针对向模块传递参数的监视时间 
[100 ms]

600

在 POWER ON 时启动 暖启动

报告 STOP 原因 开

确认触发的消息发送（QTM；

SFB 33-35） 
关

诊断缓冲区中的消息数 3 200

规划工厂的工程组态

4.8 选择 AS 组件

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 123



参数 CPU 412-5H CPU 414-5H CPU 416-5H CPU 417-5H

时钟：同步 在 AS 中：作为从站 

测试周期时间 90 分钟

钝化响应 基于通道

PCS 7 中 CPU 的 AS 410H - 默认值

参数 CPU 410

循环监视时间 [ms] 6 000

最小周期时间 [ms] 0

来自通信的循环加载 [%] 20

过程映像（每个 I + O） 16 384 字节

在发生 I/O 访问错误时调用 OB 85 仅限进入和离开错误

时钟存储器 无

本地数据（优先级）： (1-29) : 2048

用户本地数据区 65 536 字节

最大通信作业数 10 000

针对来自模块的已完成消息的监视时间 [100 ms] 650

针对向模块传递参数的监视时间 [100 ms] 600

在 POWER ON 时启动 暖启动

报告 STOP 原因 开

确认触发的消息发送（QTM；SFB 33-35） 关

诊断缓冲区中的消息数 3 200

时钟：同步 在 AS 中：作为从站 

测试周期时间 90 分钟

钝化响应 基于通道

4.8.5 高可用性自动化系统的组件

H 系统的工作原理

自动化系统由两个冗余组态的子系统组成，它们通过光纤电缆同步。两个子系统构成了按

照活动冗余原则运行的高可用性自动化系统。           
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当前冗余是指所有冗余设备都一直在运行，并且也参与过程数据的采集。当前冗余伙伴负

责执行控制任务。装载在两个 CPU 中的用户程序完全相同，并且由两个 CPU 同步运行。

如果活动 CPU 失败，自动化系统会自动切换到冗余 CPU。该切换对于正在进行的过程无

影响，因其进行的是平稳切换。

H 系统的组态实例
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H 系统的基本组态组件

可使用以下组件通过已连接的 I/O 对完整的高可用性自动化系统进行组态：

● 高可用性自动化系统 (AS 41x-x-2H) ，配有用于连接工业以太网工厂总线和基于 
PROFINET 或 PROFIBUS DP 的现场总线的接口模块。

– AS 选择：

相关信息，请参见“自动化系统概述 (页 117)”部分。

– 连接到系统总线：

相关信息，请参见“将网络节点连接到以太网 (页 75)”部分。

– 连接到现场总线：

相关信息，请参见“连接 PROFIBUS DP 节点 (页 83)”部分。

相关信息，请参见“将现场设备连接到 PROFINET IO (页 100)”部分。

● 适用于连接分布式 I/O 的冗余现场总线：

– 相关信息，请参见“冗余 PROFIBUS DP 网络的布局 (页 84)”部分。

– 相关信息，请参见“使用 PROFINET 组态 IO 设备 (页 98)”部分。

● 具有 I/O 模块的分布式 I/O：

– 例如具有 IO 模块（以及具有冗余 IO 模块）的 ET 200M
相关信息，请参见“可用分布式 I/O 系统 ET 200 概述 (页 136)”部分。 

连接附加组件

● 可组态为非冗余的 PROFIBUS DP 设备：

相关信息，请参见“将非冗余 PROFIBUS DP 设备连接到冗余 PROFIBUS DP (页 85)”
部分。

● 智能现场设备到 PROFIBUS PA：
可以在以下部分中找到更多有关此内容的信息

– 将现场设备连接到 PROFINET IO (页 100)
– 将现场设备连接到 PROFIBUS DP (页 87)
– 冗余 PROFIBUS PA 网络的组态 (页 90)

● 智能现场设备到基金会现场总线：

可参考手册《过程控制系统 PCS 7；基金会现场总线》(Process Control System PCS 
7; FOUNDATION Fieldbus) 获取相关信息。

混合操作

说明

可将高可用性和标准自动化系统用于混合操作。
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更多信息

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

4.8.6 故障安全自动化系统的组件

F 系统的工作原理

故障安全自动化系统使用各种安全功能既检测过程错误又检测自身的内部错误。如果发生

错误，则故障安全自动化系统会自动将工厂受影响的部分切换到安全状态。       

基于 AS 41x-H 自动化系统的故障安全自动化系统将标准生产自动化和安全技术组合到一

个系统中。它们经德国技术监督组织（TUEV）认证合格，并且符合 IEC 61508 的类别 SIL 
1 至 SIL 3、DIN V 19250/DIN V VDE 0801 的类别 AK 1 至 AK 6 和 EN 954-1 的类别 2 
至 4 的安全要求。

F 系统的安全机制

相关信息，可参考“PCS 7 的操作安全性 (页 56)”部分。

FH 系统

可将故障安全自动化系统组态为单个通道（使用一个 CPU 的 F 系统）或组态为冗余（FH 
系统）。FH 系统的冗余与故障安全无关。冗余不用于检测错误，而是用于提高故障安全自

动化系统的可用性。
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F/FH 系统的组态示例

F 系统的基本组态组件

可使用以下组件通过已连接的 I/O 对完整的故障安全自动化系统进行组态：

● 用于编辑故障安全用户程序的 F 运行系统许可证

● S7 F 系统附加软件包，用于对 H 系统进行组态和编程
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● 高可用性自动化系统 (AS 41x-x-1H) ，配有用于连接到工业以太网工厂总线和现场总线

的接口模块

– AS 选择：相关信息，可参考“自动化系统概述 (页 117)”部分

– 连接到系统总线：相关信息，可参考“将网络节点连接到以太网 (页 75)”部分。

– 连接到现场总线：相关信息，可参考“连接 PROFIBUS DP 节点 (页 83)”部分。

● 具有故障安全组件的分布式 I/O：

– 具有故障安全 I/O 模块（F 模块）的 ET 200M
– 防止 ET 200M 中标准 S7-300 IO 模块与故障安全 S7-300 IO 模块之间发生过压的隔

离模块。

– 带故障安全 IO 模块和故障安全电源模块的 ET 200S
– 具有故障安全 I/O 模块（F 模块）的 ET 200iSP
– 具有故障安全 I/O 模块（F 模块）的 ET 200pro
相关信息，可参考“可用分布式 I/O 系统 ET 200 概述 (页 136)”部分

FH 系统的组件

根据 FH 系统的类型、要求和组态，可使用以下高可用性自动化系统：

● 两个子系统都在一个机架上：

AS 41x-x-2H 

● 两个子系统分别在单独的机架上：

AS 41x-x-1H (2x)

除了 F 系统的组态，H 系统的所有可能组态也都可以组合使用：相关信息，可参考“高可

用性自动化系统的组件 (页 124)”部分

除附加软件包 S7 F 系统 外，还必须在工程师站中安装 S7 H 系统 许可证。

更多信息

● 手册《SIMATIC 可编程控制器 S7 F/FH》(SIMATIC Programmable Controllers S7 F/
FH)

● 手册《S7-300 故障安全信号模块》(S7-300 Fail-safe Signal Modules)
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4.9 选择 I/O 组件

I/O 组件

PCS 7 提供了用于连接 I/O 设备以及通过传感器和执行器记录和输出过程信号的各种选

项：           

● 集成了 S7-400 自动化系统的中央模块、模拟信号模块和数字信号模块

● 集成了通过 PROFIBUS DP 或 PROFINET 连接到自动化系统的分布式 I/O。以下产品

系列构成了各种信号和功能模块的基础：

– ET 200SP HA
– ET 200M
– ET 200S
– ET 200SP
– ET 200iSP
– ET 200pro
– Compact Field Unit (CFU)

● 集成了通过现场总线实现的智能现场设备： 
– PROFIBUS DP 或 PROFINET

直接集成智能、分布式现场和过程设备

– 通过 PROFIBUS PA 或基金会现场总线（如 IE/PB-Link / Compact FF Link）。

- 冗余 
- 0、1 或 2 区的危险区域

– 通过 PROFIBUS DP 或 PROFINET 集成 HART 设备

PCS 7 的信号及功能模块

说明

PCS 7 仅支持针对产品概述《过程控制系统 PCS 7；已发布模块》(Process Control System 
PCS 7; Released Modules) 中所列出的信号及功能模块进行诊断。

也可以使用当前 S7-400 和 S7-300 模块系列中的信号模块。 
● 如使用这些模块，用户需自行负责。 
● PCS 7 不提供针对这些模块的诊断支持。 
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4.9.1 使用分布式还是集中式 I/O？

使用集中式 I/O

集中式 I/O 主要用于 PCS 7 中具有小型分布式结构的小型应用或工厂。

说明

以下 PCS 7 功能不能通过集中式 S7-400 I/O 模块来使用：

● 运行中修改组态

● I/O 模块冗余

● 故障安全 I/O 模块

使用分布式 I/O

PCS 7 工厂大多都组态有分布式 I/O。主要优点包括：

● 模块化和一致性

● 电缆敷设及调试成本低

● 空间要求小

● 无需接线板、子配电板和危险区域缓冲级

● 使用信号模块的冗余组态可以提高可用性

● 使用故障安全信号模块可达到安全状态

● 可在 CPU RUN 模式下进行扩展和参数分配

● 使用自诊断时提供的详细信息可以轻松排除故障

4.9.2 哪些设备可作为分布式组件进行连接？

将现场系统连接到 PCS 7

已针对过程控制系统中分布式现场系统的集成对 PCS 7 进行了优化，这是采用 PROFIBUS 
技术实现的。或者，也可以使用 PROFINET。 
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可作为分布式组件进行连接的设备

下表显示了以下信息：

● 可在 PCS 7 工厂中作为分布式组件连接的现场设备、传感器和执行器

● 用于同上述现场设备、传感器和执行器进行通信的组件

设备 I/O 更多信息 

传感器和执行器 直接连接分布式 I/O 设备

● ET 200SP HA
● ET 200M
● ET 200iSP
● ET 200SP
● ET 200S
● ET 200pro
● Compact Field Unit (CFU)

可用分布式 I/O 系统 ET 200 概述 
(页 136) 

使用 PROFINET 的现场总线  (页 93) 

智能 PROFIBUS DP 现场

设备 
直接连接到 PROFIBUS DP（DP 主站系

统）

 

智能 PROFIBUS PA 现场

设备 

 

直接连接到 PROFIBUS PA 并将 
PROFIBUS PA 同步连接到 PROFIBUS 
DP（DP 主站系统）。用于连接的组件如

下：

● PA Link
● DP/PA 耦合器

将现场设备连接到 PROFIBUS DP 
(页 87) 

直接连接到 PROFIBUS PA，并将 
PROFIBUS PA 同步连接到 PROFINET 
IO（PROFINET IO 系统）组件。用于连

接的组件如下：

● Compact Field Unit

将现场设备连接到 PROFINET IO 
(页 100)

智能 FF 现场设备 直接连接到 FOUNDATION Fieldbus 并
将 FOUNDATION Fieldbus 同步连接到 
PROFIBUS DP（DP 主站系统）。

用于连接的组件如下：

● Compact FF Link
● FDC 157 耦合器

调试手册《过程控制系统 PCS 7；
PCS 7 ‑ 基金会现场总线》(Process 
Control System PCS 7; 
PCS 7 ‑ FOUNDATION Fieldbus)
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设备 I/O 更多信息 

HART 现场设备 直接连接到分布式 I/O 设备的专用 I/O 组
件

● ET 200SP HA
● ET 200M
● ET 200iSP
● ET 200SP

连接 HART 设备 (页 101) 

非冗余 PROFIBUS DP 设
备

将设备间接连接到冗余 PROFIBUS DP 将非冗余 PROFIBUS DP 设备连接到

冗余 PROFIBUS DP (页 85) 

使用 PROFINET 集成的示例

下图说明使用 PROFINET 在非冗余系统中集成的一个示例。
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使用 PROFIBUS 集成的示例

下图说明使用 PROFIBUS 在非冗余系统中集成的一个示例。

Ex

更多信息

● 有关冗余系统的信息，请参见《过程控制系统 PCS 7；高可用性过程控制系统》(Process 
Control System PCS 7; High Availability Process Control Systems) 手册。

● 有关将 FOUNDATION Fieldbus 集成进 PCS 7 系统的信息，请参见调试手册《过程控

制系统 PCS 7；PCS 7 - 基金会现场总线》(Process Control System PCS 7; PCS 7 - 
FOUNDATION Fieldbus)。
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4.9.3 在高可用性自动化系统中使用还是在故障安全自动化系统中使用？

概述

下表显示了可在其中根据所选 ET 200 产品线连接分布式 I/O 的自动化系统 (AS)。 

AS 类型 
具有 ET 200... 

标准 (AS 400) 高可用性 (AS 400H) 故障安全 (AS 400F) 故障安全和高可用

性 (AS 400FH)

ET 200M X X X X

ET 200S X X

（通过 Y-Link）

X X

（通过 Y-Link）

ET 200iSP X X X X

ET 200pro X X 

（通过 Y-Link）

X X 

(via Y-Link)

ET 200SP X DP：不支持 X 1) DP：不支持

ET 200SP HA X X X 1) X 1) 

X = 支持组态

1)  =  故障安全 I/O 模块未获准应用于 PCS 7 中的这种组态详细信息，请参见《过程控制系统 PCS 7；已发布的模

块》(Process Control System PCS 7; Released Modules)

激活分布式 IO 系统的系统冗余 Typ R1 

要激活分布式 IO 系统的系统冗余 Typ R1，请使用许可证密钥。许可证密钥必须传送到 
CPU 的 SEC 才能使用。可以在不交换 SEC 的情况下执行激活。 

激活分布式 IO 系统的系统冗余 Typ R1，作为 CPU 410-5H 系统扩展卡的升级。

更多信息，请参见以下文档：

《过程控制系统 PCS 7；服务支持和诊断》(Process Control System PCS 7; Service 
Support and Diagnostics)。

更多信息

● “可用分布式 I/O 系统 ET 200 概述 (页 136)”部分
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4.9.4 可用分布式 I/O 系统 ET 200 概述

分布式 I/O 站 ET 200 的属性

下表概要列出了 PCS 7 中所用 ET 200 中分布式 I/O 系统最重要的属性。 

属性 ET 200M ET 200iSP ET 200S ET 200pro ET 200SP 
HA

ET 200SP

保护级别 IP20 IP30 IP20 IP65、
IP66、IP67

IP20 IP20

数字模块 x x

（具有计数器/
频率

测量功能）

x x x x

模拟模块 x x x x x x

电机启动器模块 - - x - - -

控制器及计数器模块 x - - - - -

Ex 数字/模拟模块 x

（也支持 
HART 的
模拟模块

）

x - - - -

故障安全模块 x

（+ 隔离模块）

x x

（+ ET 200S 
SIGUARD）

x - -

冗余 IO 模块 x （仅 
PROFIBUS 
DP）

- - - x （共享端

点）

-

模块的诊断能力得到

了增强

x x x x x x

可以连接 HART 现场

设备

x

（通过

PDM 组态）

x

（通过

PDM 组态）

- - x

（通过

PDM 组态）

x

（通过

PDM 组态）

运行时的“热插拔”

功能

x

（+ 有源总线

模块）

x x x x x
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属性 ET 200M ET 200iSP ET 200S ET 200pro ET 200SP 
HA

ET 200SP

组态和参数分配 HW Config HW Config 
和 PDM

HW Config HW Config HW Config HW Config

在 RUN 模式下更改

组态

 (CiR)

更多相关信息，请参见“是否可以在运行期间修改组态？ (页 138)”部分

可在危险区域（Ex 
区 (页 712)）使用 

x

ET 200M：

2 区（+ 防爆

隔板）

执行器/传感

器/

HART：1 区

x

ET 200iSP /
HART：1 
区、2 区

RS485-iS 耦
合器：

2 区

执行器/传感

器：

0 区

x

2 区（电机启

动器除外）

- x

ET 
200SP HA
：2 区

x

ET 200SP：
2 区

 

每站最多 n 个模块

（不包括接口模块）

n = 12 n = 32 n = 63 n = 16 n = 56 n = 64

电气总线连接

（HF = 高性能；

PN = PROFINET）

x

（IM 153‑2 
HF 适用于 
PROFIBUS 
连接；

IM 153‑4 PN 
适用于 
PROFINET 
连接）

x

(IM 152)

x

(IM 151-1 
HF)

x

(IM154‑2)

x

（IM 155‑6 
PN HA 适用

于 
PROFINET
 连接）

x

（IM 156‑6 
PN HF 适用

于 
PROFINET 
连接）

光纤总线链接

（HF = 高性能；

FO 和 FC = 光纤）

x

(IM 153-2 
FO HF)

- - - x

(see 
released 
bus 
adapters) 

x

(see 
released 
bus 
adapters) 

通过连接模块连接的

总线

x x x x x x
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属性 ET 200M ET 200iSP ET 200S ET 200pro ET 200SP 
HA

ET 200SP

最大传输速率 (Mbps) DP：12

PN：100

1.5 12 12 100 DP：12

PN：100

将非冗余 
PROFIBUS DP 设备

连接到冗余 
PROFIBUS DP

Y‑Link - - - - -

在 FOUNDATION 
Fieldbus  上集成 FF 
设备

Compact 
FF Link

- - - - -

4.9.5 是否可以在运行期间修改组态？

运行中组态

下表概述了允许在操作进行期间 (CPU RUN) 对分布式 I/O 所做的组态更改。

允许的组态更改

表格 4-1 如果需要使用或已在现场总线系统中使用组件，允许执行以下组态变更（取决于工厂状态）。

组件 允许的组态更改

添加和删除 分配参数 通过 SIMATIC PDM 组态

PROFINET IO *) ● PROFINET IO
● IO 设备

  

PROFIBUS DP；

PROFIBUS PA

● PROFIBUS DP 节点

● PA Link
● DP/PA 现场设备

 ● DP 现场设备

● PA 现场设备

PROFIBUS DP； 

基金会现场总线

● PROFIBUS DP 节点

● Compact FF link
● FF 现场设备

 ● DP 现场设备

● FF 现场设备

ET 200SP HA ● ET 200SP HA 站
● 输入/输出模块

输入/输出模块 已连接的 HART 现场设备 
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组件 允许的组态更改

添加和删除 分配参数 通过 SIMATIC PDM 组态

ET 200M (on 
PROFIBUS DP 
only)

要求：接口模块型

号：

● IM 152-2 HF
● IM 153-2 HF-FO

● ET 200M 站
● 输入/输出模块

输入/输出模块 已连接的 HART 现场设备 

ET 200iSP ● ET 200iSP 站
● 输入/输出模块

输入/输出模块 已连接至 HART 模块的 HART 
现场设备

ET 200pro ● ET 200pro 站 - -

ET 200S ● ET 200S 站 - -

ET 200SP （仅在  
PROFIBUS DP  上）

● ET 200SP 站
● 输入/输出模块

输入/输出模块 已连接的 HART 现场设备 

Compact Field Unit ● PA 现场设备

● Compact Field Unit
● 空闲可组态通道上的组

件

空闲的可组态通道 ● PA 现场设备

*) 需要 CPU 410 固件版本 V8.2 或更高版本才能使用此硬件。

更多信息

● “运行中修改组态 (CiR) 的规则 (页 176)”部分
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4.9.6 如何在危险区域中集成分布式 I/O？

在危险区域中集成 I/O

下图概要说明了在危险区域中集成分布式 I/O 的各种选项：     
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图例

组件 在危险区域中使用

ET 200M ET 200M 可以在危险区 2 中运行。如果使用适当的危险区 I/O 模
块，则执行器/传感器可位于危险区 1 中。 

在具有适当许可（例如消防证书）时，还允许在危险区 2 中热插

拔 I/O 模块。

ET 200iSP ET 200iSP 可直接安装在危险区 1 或 2 (EEx de ib [ia/ib] IIC T4) 
中。

传感器/执行器也可安装在区域 0 中。

可在危险条件下对各个模块进行热插拔。

ET 200SP HA ET 200SP HA 可以在危险区 2 中运行。执行器/传感器不会在危险

区 1 或 0 中释放。 

在具有适当许可（例如消防证书）时，还允许在危险区 2 中热插

拔 I/O 模块。

Compact Field Unit PROFIBUS PA 中的紧凑型现场单元和现场设备可以在危险区 2 中
运行。

现场设备 通过 PROFIBUS PA 可向危险区 1 或 2 中直接集成适当的现场设

备和过程设备。

传感器/执行器也可安装在区域 0 中。

本质安全操作面板

如有需要，可在危险区 1 或 2 中使用本质安全 PC 操作面板（PCS 7 附加件）。可将面板

连接到距离 750 m 内的操作站。
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4.10 高效工程的准备工作

4.10.1 为高效率的工程规划对象/功能

高效工程组态的功能

下表概述了用于确保高效工程组态的对象/功能。建议在使用 PCS 7 规划工厂工程组态时

将这些功能考虑在内。

功能 简要说明 工具 本手册中包含更多

信息的部分

过程控制库 PCS 7 为自动化解决方案的图形组态提供了一个

库，包括范围广泛的预组态和已测试块、面板及

符号。

这些库元素非常有助于将工程组态需求和项目成

本降至最低。

块范围很宽，包括简单的逻辑和驱动程序块、带

有内部操作和信号响应的工艺块（如 PID 控制

器、电机或阀）以及用于现场设备集成的块。 

标准 PCS 7 软
件

如何支持重复工艺

功能？ (页 145) 

多项目工程组态 多项目工程组态可根据工艺因素将一个大规模的

工厂项目分成多个子项目。这样就可由几个项目

工程师同时操作这些子项目。

优点：

● 可随时在多项目中添加或删除单个项目。

● 多项目中的子项目存储在中央服务器上，并移

动到本地工程师站进行编辑。

● 子项目组合回多项目后，即可对整个工厂执行

项目间功能（比如编译和下载）。

PCS 7 的标准

功能

在多项目中组态 
(页 188) 

主数据

库

可为项目创建一个自定义库以提高效率。 PCS 7 的标准

功能

主数据库的对象 
(页 308) 

分支和合并项目 分支和合并是多项目工程组态的一项功能，可根

据工艺因素分离并重新组合项目的各个部分。可

以将图表或工厂单元复制到另一个要在其中对它

们进行修改的项目中。

PCS 7 的标准

功能

分支和合并项目图

表 (页 192) 
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功能 简要说明 工具 本手册中包含更多

信息的部分

导入已组态的工厂

数据 
可以将来自更高级别 CAD/CAE 领域的已组态工

厂数据（比如过程变量列表或图表）导入到工程

组态系统，并用于几乎完全自动地生成过程变量。

导入/导出助手 可导入数据和数据

格式 (页 143) 

从工厂工程组态中

传送数据 (页 621) 

自动生成过程变量 基于导入的过程变量列表和自定义的过程变量类

型，可自动生成大量的过程变量（PCS 7 中的 
CFC），并将其存储在工厂层级的正确位置。

导入/导出助手 使用过程变量和模

型 (页 625) 

使用过程变量类型 
(页 201) 

导出组态数据 在组态和调试期间，由 PCS 7 优化的参数可导回

到 CAD/CAE 领域。

导入/导出助手 使用过程变量和模

型 (页 625) 

硬件配置的自动扩

展/修改

站组态可从 HW Config 导出，在项目外进行修改

和调整，然后再导回。也可以导出或导入输入和

输出的符号名。

此功能可供具有重复使用的硬件结构的工厂用来

实现高效工程组态。

HW Config 导入/导出硬件配置 
(页 645) 

创建和优化逻辑功

能 
逻辑矩阵编辑器用于高效组态工厂。 逻辑矩阵编辑

器

组态逻辑运算 
(页 483)

有关工厂工程组态

的数据交换

PCS 7 与 COMOS 之间的数据交换 高级工程组态

系统 (AdvES)
数据交换概述 
(页 621)

4.10.2 可导入数据和数据格式

数据导入

下表提供了以下信息：     

● 可以向其中导入数据的任务

● 可导入的数据格式

● 可生成数据的应用程序
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工程组态中的工作阶段 潜在导入格式 用于生成的应用程序

创建过程变量

（PCS 7 中的 CFC） 

列表格式：

● csv
可以 CSV 格式（例如 MS 
Excel 或 Access）导出列

表的应用程序

创建硬件组态 ● cfg HW Config
（标准 PCS 7）

创建 OS 画面

（非动态画面元素）

导入图形的格式：

● emf
● wmf
导入图形对象的格式：

● emf
● wmf
● dib
● gif
● jpg
● jpeg
● ico

任何图形应用程序

创建外国语文本 ● txt
● csv

文本编辑器（例如 MS 
Excel 或 Wordpad）

创建项目数据 ● xml SIMATIC Manager

Version Cross Manager

更多信息

● “导入及重用工厂数据 (页 208)”部分

● “数据交换概述 (页 621)”部分
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4.10.3 如何支持重复工艺功能？

PCS 7 的以下功能支持重复工艺功能：       

● 模板

模板（标准类型、标准解决方案）用于协助用户对 PCS 7 工厂进行组态。它们包含在 
PCS 7 高级过程库中。

● 类型概念

我们还推荐您将相似的功能分组，以提高工厂工程组态的效率。通过使用可重用的对象

（如过程变量类型和模型）来组态相似的功能。

模板

PCS 7 库“PCS 7 高级过程库”包含用于实现以下工艺功能的模板：

● 测量值显示的控制

● 具有监视功能的二进制值采集

● 具有监视功能的模拟值采集

● 手动调整

● 固定设定值控制

● 层叠控制

● 比率控制

● 拆分范围控制

● 定量给料

● 手动/自动电机控制

● 电机控制（变速）

● 手动/自动阀门控制

● 连续阀门控制

● 顺序控制系统

有关各种块及其操作的信息，请参见以下文档： 

功能手册《SIMATIC；过程控制系统 PCS 7；高级过程库》(SIMATIC; Process Control 
System PCS 7; Advanced Process Library)
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有关组态大量过程变量的建议

创建包含所有过程变量的过程变量列表。考虑哪些过程变量可以分配到一种过程变量类型。

在工程组态期间，使用此列表通过导入/导出助手基于过程变量类型生成带有相应过程变量

的 CFC。

导入文件必须有特定的结构。有关此结构的精确组态，请参见部分“使用 IEA 文件编辑器

创建/编辑导入文件 (页 639)”。

例如，在准备阶段，应该创建包含以下信息的过程变量列表：

组件 测量 测量 电机 ....

块 1 2 1  

工厂区域 工厂区域 1 工厂区域 2 工厂区域 1 工厂区域 1

子区域 定量给料工厂 油加热 搅拌器 气加热

类型 3（PT 100 – 温度

测量）

3（测量方法，例

如平方根）

10 ...

属性 1 测量范围起点

（例如 263°K）

测量范围起点

（例如 0 mA）

开 ...

属性 2 测量范围终点

（例如 473°K）

测量范围终点

（例如 100 mA）

关 ...

属性 3 限值 1：300 K  反馈输入 ...

属性 4 限值 2：320 K  反馈输出 ...

属性 5 限值 3：390 K  温度传感器（类

型 1 - PT 100）
 

属性 6 限值 4：400 K    

属性 7 ...    

属性 ... ...    

更多信息

● “数据交换概述 (页 621)”部分
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介绍使用 PCS 7 进行工厂的工程组态 5
PCS 7 - 实现全集成自动化的过程控制系统

作为应用于企业范围自动化网络“全集成自动化”中的过程控制系统，SIMATIC PCS 7 使
用在 TIA 模块化系统中选定的标准组件。它所具有的统一数据管理、通信和组态为加工工

业、生产工业和混合工业（连续/批生产过程与分散生产相结合，例如玻璃工业或制药工

业）的各个部门提供了一个开放平台，以实现面向现代及未来同时又经济节约的自动化解

决方案。

在 TIA 网络内，SIMATIC PCS 7 不仅能够处理标准过程工程组态任务，还能实现生产场地

辅助过程（如装填、包装）或输入/输出物流（如物料周转、仓储）的自动化。

通过将该自动化等级与 IT 世界联系起来，能够在整个公司范围内使用过程数据对操作顺

序、生产过程和商业过程进行评估、规划、协调和优化。
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PCS 7 工厂的基本结构

SIMATIC PCS 7 的模块化体系结构基于从 SIMATIC 程序的标准范围内选择的硬件和软件

组件。可使用基于国际工业数据交换标准（如 Ethernet、TCP/IP、OPC 或 OLE DB 通信）

的接口，将 PCS 7 工厂接入公司范围的信息网络。

图 5-1 PCS 7 工厂中用于 HMI 和工程组态的系统基本结构
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图 5-2 自动化区域基本结构 - 基于 PROFINET 的现场总线

图 5-3 自动化区域基本结构 - 基于 PROFIBUS DP 的现场总线
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PCS 7 的系统/组件

编

号

系统/
组件

描述 本手册中包含更多信息的部分

1 OpenPCS 7 站 用来与外部系统进行数据通信的 PC 站，无需具备拓扑

方面的知识。 

数据是通过 OPC/OLE DB 以事件驱动方式或循环方式

来访问的。

● 通过 OpenPCS 7 连接到 
IT 世界 (页 108) 

PCS 7 Web 服
务器

可用来在世界各地通过 intranet 或 Internet 以在线方式

对过程进行监视的 PC 站。

● 通过 PCS 7 Web 客户端

访问 PCS 7 OS (页 109) 

2 SIMATIC IT 通过 SIMATIC IT 可将 SIMATIC PCS 7 集成到公司范

围的信息网络中。

● 连接到 IT 世界 - SIMATIC 
IT (页 106) 

3 工程师站 用于集中执行工厂范围工程组态的 PC 站：

● 硬件组态

● 通信网络组态

● 使用标准工具组态连续的和顺序的过程顺序

● 使用 SIMATIC BATCH 组态非连续的过程顺序（批

生产过程）

● 使用 SIMATIC Route Control 来组态路径控制

● 操作员监控策略

● 编译所有组态数据并将其下载到所有目标自动化系

统 (AS)、操作员站 (OS)、BATCH 站 (BATCH) 和 
Route Control 工作站

● 工程师站的组态 (页 155) 
● PCS 7（包）的预组态系

统 (页 113) 
● 为高效率的工程规划对象/

功能 (页 142) 

维护站 用于诊断所有 PCS 7 组件的 PC 站。诊断状态通过按

层级结构排列的诊断画面表示，并以诊断消息的形式传

达给用户。 

维护站可设计成单工作站系统或多工作站系统。维护站

（在单工作站中）或 MS 客户端（多工作站系统）最好

放在工程师站上运行。 

● 使用维护站诊断（资产管

理） (页 689) 
● 附加服务支持和诊断 

(页 693) 
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编

号

系统/
组件

描述 本手册中包含更多信息的部分

4 操作站 带有用于在过程模式下操作和监视 PCS 7 工厂的人机

界面的 PC 站

操作员站可设计成单工作站系统或多工作站系统。

● 操作员站的组态 (页 156)
● PCS 7（包）的预组态系

统 (页 113) 

Route Control 
工作站

用于操作和监视路径控制以传输物料的 PC 站

Route Control 工作站可设计成单工作站系统或多工作

站系统。

● 组态路径控制工作站 
(页 160) 

Process 
Historian（归档

服务器）

长期归档 PC 站（外部归档服务器）。Process 
Historian 是终端总线上的一个节点。Information 
Server 为中央报表系统。 

● 操作员站的组态 (页 156)

(3
 + 
4)

PCS 7 Box 与分布式 I/O 结合使用时具有 PCS 7 过程控制系统功

能（工程组态、自动化、操作员监控）的工业 PC。

PCS 7 BOX 用于可集成到 PCS 7 网络中的小型独立系

统或组合的 AS/OS 站。 

它允许集中进行工程组态。

● 工程师站的组态 (页 155) 
● 操作员站的组态 (页 156)
● PCS 7（包）的预组态系

统 (页 113) 

5 BATCH 站 用于操作和监视非连续过程顺序（批生产过程）的 PC 
站。

可将 BATCH 站设计成单工作站或具有 BATCH 客户

端/BATCH 服务器体系结构的多工作站系统。

● BATCH 站的组态 (页 158) 

6 终端总线 以下组件通过终端总线进行通信： 
● 服务器/客户端（OS、BATCH、Route Control）和

工程师站

注：所有系统中的单工作站系统（ES、OS、BATCH、

Route Control）都可以连接到终端总线。 

● PCS 7 内的通信 (页 62) 
● 使用以太网规划管理级 

(页 71) 

7 工厂总线 以下组件通过工厂总线进行通信： 
● 服务器（OS、Route Control）和自动化系统 (AS)
● 可互换的自动化系统（SIMATIC 连接）

● PCS 7 内的通信 (页 62) 
● 使用以太网规划管理级 

(页 71) 
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编

号

系统/
组件

描述 本手册中包含更多信息的部分

8 自动化

系统

自动化系统可执行以下任务：

● 获取过程变量

● 按照用户程序中的指令处理数据

● 将控制指令和设定值输出至过程

● 向操作员站提供数据以供显示

● 检测操作员站上的操作员命令及其向过程的返回值

● 直接访问 Route Control 工作站

● 选择 AS 的标准是什么？ 
(页 115) 

9 I/O
现场总线

连接典型及智能现场设备。智能现场设备是通过 
PROFINET、PROFIBUS DP、PROFIBUS PA、
HART 或基金会现场总线进行通信连接的。 

另外，还可集成以下组件：

● 通过 ASI 接口连接的简单执行器和传感器

● 通过 instabus EIB 实现的楼宇自动化的组件

● 带有 Modbus 接口的组件

● 使用 PROFIBUS 规划现场

级 (页 80) 
● 使用 PROFINET 的现场总

线  (页 93) 
● 哪些设备可作为分布式组

件进行连接？ (页 131) 
● 与其它系统的数据链接简

介 (页 100) 

更多信息 - PCS 7 小册子

如果希望了解更多有关 PCS 7 的介绍性信息，请阅读 PCS 7 过程控制系统小册子。您可

以找到有关 SIMATIC PCS 7 中的通信原理和系列功能，以及可能的技术应用和适合实现

您的自动化任务的功能方面的必要信息。

本手册中的以下各节是以这些 PCS 7 小册子中的信息为基础的。 
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PCS 7 工厂的结构 6
6.1 PCS 7 工厂的基本组态

基本组件

下图显示了 PCS 7 工厂的基本组件。     
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图例

站 图中编号 功能

工程师站 1 所有 PCS 7 系统组件的中央工程均在工程师站中执行： 
● 操作员站

● 维护站

● BATCH 站
● Route Control 工作站

● 自动化系统

● 集中式 I/O
● 分布式 I/O
工程组态完毕后，组态数据将下载到 PCS 7 系统组件。 
只能在工程师站上进行更改。 每次更改后都会再次进行下

载。

操作员站 2 在操作员站上，可以在过程模式下操作并观察 PCS 7 工
厂。 

可通过维护站全面诊断 PCS 7 系统。 

外部归档服务器用于归档重要的过程和工厂数据

BATCH 站 3 在 BATCH 站上，可以在过程模式下操作并观察不连续过

程顺序（批生产过程）。

Route Control 工
作站

4 在 Route Control 工作站上，可以在过程模式下控制并监

视物料输送（路径控制）。

OpenPCS 7 站 5 使用 OpenPCS 7 站可以在 IT 世界中访问 PCS 7 数据。

自动化

系统

6 自动化系统执行以下任务：

● 它注册并处理来自所连接的中央 I/O 和分布式 I/O 的过

程变量，并将控制信息和设定值输出给过程。

● 它向操作员站提供可视化数据。

● 它在操作员站注册各个操作并将其发送到过程。

更多信息

● “将网络节点连接到以太网 (页 75)”部分

● “连接 PROFIBUS DP 节点 (页 83)”部分

PCS 7 工厂的结构

6.1 PCS 7 工厂的基本组态

工程组态系统 (V9.0 SP1)
154 配置手册, 12/2017, A5E39221328-AC



6.2 组态 PC 站

6.2.1 工程师站的组态

概述

工程师站是指其上安装了用于组态 PCS 7 项目的 PCS 7 工程组态软件的 PC。        

将工程师站连接到工厂和终端总线以将组态数据下载到 PLC（OS、BATCH、Route Control 
或 AS），并在过程模式下进行测试。

工程师站的 PC 组态选项

PCS 7 工厂中的工程师站可采用以下 PC 组态： 

● 在单个 PC 上实现一个 PCS 7 项目的工程组态

● 针对小型工厂：

– 在单个 PC 上组合工程师站和操作员站

– 在单个 PC 上实现工程师站、操作员站和自动化系统的组合。本解决方案通过 
SIMATIC PCS 7 BOX 来提供。

● 针对大型工厂 - 带有多个工程师站的 PCS 7 项目工程组态：

PCS 7 工厂的结构

6.2 组态 PC 站
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组态 方法 注

有公共服务器（标

准办公网络）

各项目编辑员的工程师站通过 PC 网络处理

多项目。

项目编辑员在本地工程师

站处理单个项目。

无公共服务器 ● 在中央工程师站上保存多项目并创建项

目间连接。

● 单个项目会移动到分布式 PC 上进行工

程组态。

● 完成项目后，将其复制回中央工程师站

并在多项目中执行项目间功能。

通过这种方式可以实现分

布式工程组态（例如，在

多个位置）。

更多信息

● “将网络节点连接到以太网 (页 75)”部分

● 有关组态工程师站和安装操作系统及 PCS 7 工程软件的详细信息，请参见手册《过程

控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 7 - PC 
Configuration)。

● 手册《过程控制系统 PCS 7；SIMATIC PCS 7 BOX》(Process Control System PCS 
7; SIMATIC PCS 7 BOX)。

6.2.2 操作员站的组态

概述

操作站是指安装了 PCS 7 OS 软件的 PC。操作站连接到系统总线以允许和自动化系统进

行数据通信。       

操作站的架构变化多样，可灵活地适应各种工厂规模和客户要求。操作站可组态为单工作

站系统或采用客户端-服务器体系结构的多工作站系统。

OS 服务器包含操作和监视系统以及中断和测量值归档的所有数据。它与自动化系统建立

通信连接。OS 服务器向 OS 客户端提供过程数据。OS 客户端用于操作和监视过程模式。

它们访问一个或多个 OS 服务器的数据。

在多工作站系统中，建议为 OS 客户端和 OS 服务器之间的数据通信设置终端总线（与系

统总线分开）。可以将过程值归档存储在单独的归档服务器上，以提高性能。

为了提高可用性，可对操作站进行冗余设置。

PCS 7 工厂的结构

6.2 组态 PC 站
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操作站可采用的 PC 组态

可在 PCS 7 工厂中为操作站创建以下 PC 组态： 

● 单个 PC 上作为单工作站系统的 OS：
在一个工作站上放置 PCS 7 项目（工厂/单元）的全部操作员监控功能。系统总线上的 
OS 单工作站系统可与其它的单工作站或多工作站系统并行使用。 
通过 WinCC/Redundancy 软件包，两个 OS 单工作站系统也可冗余地运行。

操作站也可与单个 PC 上的工程师站和自动化系统组合使用。本解决方案通过 SIMATIC 
PCS 7 BOX 来提供。

● 作为采用客户端-服务器体系结构的多工作站系统的 OS：
OS 多工作站系统由多个 OS 客户端（操作站）组成，这些客户端由一个或多个 OS 服
务器通过终端总线来提供数据（项目数据、过程值、归档、报警和消息）。 
OS 客户端可同时访问数个 OS 服务器上的数据（多客户端操作）。OS 服务器也具有

客户端功能，可以访问其它 OS 服务器上的数据（归档、消息、变量、参数变量）。这

样，一个 OS 服务器上的过程画面就可以与其它 OS 服务器上的变量互连（服务器间通

信）。 
通过 PCS 7 Server Redundancy 软件包，可实现 OS 服务器的冗余操作。

通过 multi-VGA 卡最多可为工作站（OS 客户端）连接 4 台显示器。可通过 1 个键盘

和 1 个鼠标对以这种方式拆分的工厂区域进行管理。

● PCS 7 可实现通过 Internet 或 intranet 在过程模式下使用 PCS 7 OS（单工作站系统或

多工作站系统）的操作员监控功能。有关详细信息，请参见“通过 PCS 7 Web 客户端

访问 PCS 7 OS (页 109)”部分和手册《过程控制系统 PCS 7；OS Web 选件》(Process 
Control System PCS 7; Web Option for OS)。

维护站（资产管理）

操作站（OS 区域）也可组态成维护站使用。通过维护站，可以在层级结构的诊断画面中

调用与所有 PCS 7 组件的状态有关的信息。   

PCS 7 工厂的结构

6.2 组态 PC 站
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维护站可设计成单工作站系统或多工作站系统。维护站（在单工作站中）或 MS 客户端（多

工作站系统）最好放在工程师站上运行。

要提高可用性，也可以对维护站进行冗余组态。

更多信息，请参见“使用维护站诊断（资产管理） (页 689)”部分和手册《过程控制系统 
PCS 7；维护站》(Process Control System PCS 7; Maintenance Station)。

长期归档 PC 站 (SIMATIC Process Historian)

SIMATIC Process Historian 可另外作为外部归档服务器在 PCS 7 中执行长期归档。

外部归档服务器是独立的 PC 站，即终端总线上一个未连接到系统总线的节点。 

有关于此的详细信息，请参见：

● “组态 SIMATIC 和 PC 站 (页 270)”部分

● 系统手册《SIMATIC；Process Historian 管理》(SIMATIC; Process Historian 
Administration)

● 系统手册《SIMATIC; SIMATIC Information Server》

更多信息

● “将网络节点连接到以太网 (页 75)”部分

● “需要多少操作站？ (页 50)”部分

● 有关组态操作站和安装操作系统及 PCS 7 OS 软件的详细信息，请参见手册《过程控制

系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 7 - PC 
Configuration)。

● 手册《过程控制系统 PCS 7；PCS 7 BOX》( Process Control System PCS 7; PCS 7 
BOX)

6.2.3 BATCH 站的组态

概述

BATCH 站是安装了 SIMATIC BATCH 的 PC。      

BATCH 站的体系结构变化多样，可灵活地适应各种工厂规模和客户要求。BATCH 站可组

态为单工作站系统或采用客户端/服务器体系结构的多工作站系统。

PCS 7 工厂的结构

6.2 组态 PC 站
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典型批生产过程自动化具有一个 BATCH 服务器和几个 BATCH 客户端，它们共同处理工

厂项目。BATCH 服务器可冗余组态以提高可用性。

BATCH 服务器和 OS 服务器应始终在单独的 PC 上运行。BATCH 客户端和 OS 客户端可

在公共的 PC 上运行。

BATCH 站与 OS 和 AS 的通信取决于运行的类型：

● 基于 AS 运行：

BATCH 站通过终端总线与操作站通信，通过工厂总线与自动化系统通信。BATCH 站
具有与各个终端总线和工厂总线的连接。

● 基于 PC 运行：

BATCH 站通过终端总线与操作站通信。BATCH 站仅可通过操作站与自动化系统通信。

BATCH 站与终端总线之间仅需要一个连接。

下图显示具有 BATCH 多工作站系统的组态。BATCH 服务器基于 AS 运行，并具有一个与

工厂总线的连接。

PCS 7 工厂的结构

6.2 组态 PC 站
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用于 BATCH 站的 PC 组态选项

可为 PCS 7 工厂中的 BATCH 站创建以下 PC 组态： 

● 针对小型工厂：

– BATCH 站和操作站作为单个公共 PC 上的单工作站系统

– BATCH 站作为单个 PC 上的单工作站系统与操作站分开

● 针对大型工厂：

– BATCH 站作为采用客户端/服务器体系结构的多工作站系统：

它由一个 BATCH 服务器和多个 BATCH 客户端（操作站）组成

BATCH 客户端和 OS 客户端可在单独的 PC 或公共的 PC 上运行。 
BATCH 服务器也可冗余运行。

通过 multi-VGA 卡最多可为工作站（BATCH 客户端）连接 4 台显示器。可使用键盘

和/或鼠标控制分布在这 4 台显示器上的所有工厂区域。 

更多信息

● 有关 BATCH 站组态和 SIMATIC BATCH 软件安装的详细信息，请参见手册《过程控制

系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 7 - PC 
Configuration)。

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)

6.2.4 组态路径控制工作站

概述

Route Control 工作站是安装了 SIMATIC Route Control 的 PC。Route Control 服务器和 
Route Control 客户端都连接到终端总线。另外，Route Control 服务器还连接到系统总

线。   

Route Control 工作站的体系结构变化多样，可灵活地适应各种工厂规模和客户要求。Route 
Control 工作站可组态为单工作站系统或采用客户端/服务器体系结构的多工作站系统。

典型的路径控制具有一个 Route Control 工作站服务器和多个 Route Control 客户端，它们

共同操作工厂项目。Route Control 服务器可冗余组态以提高可用性。

PCS 7 工厂的结构

6.2 组态 PC 站
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用于 Route Control 工作站的 PC 组态选项

以下 PC 组态可用于 PCS 7 工厂中的 Route Control 工作站： 

● 针对小型工厂：

– Route Control 工作站和操作员站作为单个公共 PC 上的单工作站系统

– Route Control 工作站作为单个 PC 上的单工作站系统与操作员站分开

● 针对大型工厂：

– Route Control 工作站作为使用客户端/服务器体系结构的多工作站系统：

它由一个 Route Control 服务器和多个 Route Control 客户端（操作员站）组成。

Route Control 客户端和 OS 客户端可在单独的 PC 或共享的 PC 上运行。 
Route Control 服务器也可冗余运行。

更多信息

● 有关组态 Route Control 工作站和安装操作系统及 SIMATIC Route Control 软件（包括

所需的许可证密钥）的详细信息，请参考手册《过程控制系统 PCS 7；PCS 7 - PC 组
态》(Process Control System PCS 7; PCS 7 - PC Configuration)。

● 手册《过程控制系统 PCS 7；SIMATIC Route Control》(Process Control System PCS 
7; SIMATIC Route Control)

6.2.5 OpenPCS 7 站的组态

OpenPCS 7 站是安装了 OPC 服务器或 OLE DB 服务器的 PC。OpenPCS 7 站的体系结

构变化多样，可灵活地适应各种工厂规模和要求。     
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OpenPCS 7 站可执行以下任务：

● 通过 OPC 或 OLE DB 接口为自动化过程提供 PCS 7 数据。

● 允许客户端应用程序（OPC 或 OLE DB）访问它提供的 PCS 7 数据。

用于 OpenPCS 7 站的 PC 组态选项

以下 PC 组态可用于 PCS 7 工厂中的 OpenPCS 7 站：

PCS 7 工厂的结构
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编

号

组态 应用领域

1 OpenPCS 7 站、OS 客户端和客户端应用程序（OPC 
或 OLE DB）位于同一台 PC 上

单工作站系统：

建议用于小型工厂

2 OpenPCS 7 站与客户端应用程序（OPC 或 OLE DB）分

别在不同的 PC 上，通过附加网络（图中的 Internet/
Intranet）相连接。

对于此组态，OpenPCS 7 站也可安装在以下 PC 站上：

● OS 客户端

● OS 服务器

● OS 单工作站系统

采用客户端-服务器架构的

多工作站系统：

建议大中型工厂使用

3 OpenPCS 7 站与客户端应用程序（OPC 或 OLE DB）分

别位于通过另一种网络（图中的 Internet/Intranet）连接

的不同 PC 上，可访问有防火墙保护的 PCS 7 工厂的终

端总线。

采用客户端-服务器架构的

多工作站系统：

建议大中型工厂使用

更多信息

● “通过 OpenPCS 7 连接到 IT 世界 (页 108)”部分

● 有关安装操作系统的更多信息，请参见手册《过程控制系统 PCS 7；PCS 7 - PC 组态》

(Process Control System PCS 7; PCS 7 ‑ PC Configuration)。

● 手册《过程控制系统 PCS 7；OpenPCS 7》(Process Control System PCS 7; 
OpenPCS 7)

PCS 7 工厂的结构

6.2 组态 PC 站

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 163



6.3 终端总线和工厂总线的组态

6.3.1 通过终端总线和工厂总线的数据路径

通信路径

下图用一个实例来说明通信路径和系统总线。         

PCS 7 工厂的结构

6.3 终端总线和工厂总线的组态

工程组态系统 (V9.0 SP1)
164 配置手册, 12/2017, A5E39221328-AC



图例 

总线 以下过程的数据传递或通

信

通信双方

终端总线 组态数据的下载 工程师站和以下站：

● 操作站（OS 服务器或 OS 客户端）

● BATCH 站（BATCH 服务器或 BATCH 客
户端）

● Route Control 工作站（Route Control 服
务器或 Route Control 客户端）

服务器之间的通信 ● OS 服务器

● BATCH 服务器（基于 PC 运行时）和 
BATCH 相关的 OS 服务器

服务器处理的数据向操作

员控制和监视站（客户端）

进行传输

● OS 服务器和 OS 客户端

● BATCH 服务器和 BATCH 客户端

● Route Control 服务器和 Route Control 客
户端

工厂总线 组态数据的下载 工程师站和自动化系统

过程的操作和监视 ● 自动化系统和 OS 服务器、Route Control 
服务器

（CPU -> CP -> 总线 -> 网络适配器 (CP) 
-> O /RCS）

● 可选：

自动化系统和 BATCH 服务器 
（基于 AS 运行时使用 BATCH 服务器）

自动化系统间的通信

（SIMATIC 通信）

自动化系统

（CPU -> CP -> 总线 -> CP -> CPU）

6.3.2 终端总线和工厂总线的组态

拓扑选项    

系统总线和终端总线可按如下方式组态：

● 作为工业以太网（10/100 Mbps 和 GB）

● 总线型、树型、环型、星型或冗余环型结构

有关工业以太网属性的信息，可参考“网络/总线系统的应用领域和参数 (页 63)”部分。

PCS 7 工厂的结构
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可用的 SIMATIC NET 组件

 用途 SIMATIC NET 
的组件

其它参考部分

PC（OS、
BATCH、Route 
Control 和 ES）

以太网的连接组件 ● CP 1613
● CP 1623
● CP 1628

将网络节点连接到以

太网 (页 75) 

● 带集成以太网卡的 
BCE

 

● 带桌面

适配器网卡的 BCE
 

AS 以太网的连接组件 ● CP 443-1  
● 带集成以太网接口

的 CPU
 

连接路径 光纤传输路径 ● 玻璃光纤 FO 电缆  

电气传输路径 ● ITP 电缆（工业双

绞线）

使用以太网规划管理

级 (页 71) 

● TP 电缆（双绞线） 工业以太网使用的光

纤和电气传输介质 
(页 67) 

● 同轴电缆  

网络耦合器 光纤和/或电气传输路

径

● SCALANCE X 网络/总线系统的最大

传输速率 (页 66)

电气传输路径 ● SCALANCE X 使用以太网规划管理

级 (页 71) 

● 星型耦合器 使用采用了 
SCALANCE X 的交换

技术 (页 72)  

光纤传输路径 ● 介质转换器 工业以太网使用的光

纤和电气传输介质 
(页 67) 

组态冗余总线

有关冗余总线组态的信息，可参考“组态冗余以太网 (页 77)”部分。
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更多信息

有关网络体系结构、网络组态、网络组件和安装说明的更多信息，请参考以下文档：

● 产品概述《过程控制系统 PCS 7；已发布模块》(Process Control System PCS 7; 
Released modules)
包含可用于某个 PCS 7 版本的 SIMATIC NET 组件

● 手册《用于工业以太网的 SIMATIC NET NCM S7》(SIMATIC NET NCM S7 for 
Industrial Ethernet)

● 手册《SIMATIC NET；三轴网络》(SIMATIC NET; Triaxial Networks)

● 手册《SIMATIC Net 双绞线和光纤网络》(SIMATIC Net Twisted Pair and Fiber-Optic 
Networks)

● 操作说明《SIMATIC NET；工业以太网交换机 SCALANCE X-400》(SIMATIC NET; 
Industrial Ethernet Switches SCALANCE X-400)

● 组态手册《SIMATIC NET；工业以太网交换机 SCALANCE X-400》(SIMATIC NET; 
Industrial Ethernet Switches SCALANCE X-400)

● 操作说明《SIMATIC NET；工业以太网交换机 SCALANCE X-200》(SIMATIC NET; 
Industrial Ethernet Switches SCALANCE X-200)

PCS 7 工厂的结构
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6.4 安装自动化系统和连接的 I/O

6.4.1 自动化系统的组态

自动化系统

以下自动化系统可通过选择硬件和适当的软件进行组态：   

自动化系统 其它参考部分

● 标准自动化系统  
● 高可用性自动化系统

（H 系统）
PCS 7 的冗余概念 (页 54)

建议使用的组件 (页 59)

● 故障安全自动化系统

（F 系统）
PCS 7 的运行可靠性 (页 56)

建议使用的组件 (页 59)

● 故障安全和高可用性自动化系统

（FH 系统）
PCS 7 的冗余概念 (页 54)和

PCS 7 的运行可靠性 (页 56)

可用的 S7-400 组件 

用途 组件 其它参考部分

自动化系统 ● AS 400H/F/FH 自动化系统概述 (页 117)

PCS 7 项目的 CPU 限制 (页 122)

PCS 7 项目 CPU 的默认性能参数 (页 122)

高可用性自动化系统 ● AS 400H 高可用性自动化系统的组件 (页 124)

故障安全自动化系统 ● AS 400F/FH 故障安全自动化系统的组件 (页 127)

以太网的连接组件 ● CP 443-1
或

● CPU 的以太网接口

将网络节点连接到以太网 (页 75)

PROFINET IO 的连接设

备

● CPU 410-5H 连接 PROFINET IO 节点 (页 386)

PROFIBUS 的连接设备 ● 扩展型 CP 443-5
或

● PROFIBUS DP 接口

连接 PROFIBUS DP 节点 (页 83)
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SIMATIC PCS 7 Box PC

在 PCS 7 中，可使用以下集成了 AS 的 SIMATIC PCS 7 Box PC（PC 包）：

● SIMATIC PCS 7 BOX RTX：安装有 PLC WinLC RTX 软件的 BOX IPC

● SIMATIC PCS 7 AS RTX：安装有 PLC WinLC RTX 软件的 MICROBOX IPC

集成到 SIMATIC PCS 7 IPC 中的自动化系统是标准自动化系统。

更多信息

● 产品概述《过程控制系统 PCS 7；已发布模块》(Process Control System PCS 7; 
Released modules)

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

● 手册《SIMATIC 可编程控制器 S7 F/FH》(SIMATIC Programmable Controllers S7 F/
FH)

● 手册《S7-300 故障安全信号模块》(S7-300 Fail-safe Signal Modules)

● 手册《过程控制系统 PCS 7；SIMATIC PCS 7 BOX》(Process Control System PCS 
7; SIMATIC PCS 7 BOX)

6.4.2 产品的安装说明指南

简介

本部分针对的是各个产品文档中的安装说明。       

说明

使用 PCS 7 时，SIMATIC 组件的项目文档手册中与安装相关的信息也都有效。在“PCS 
7 产品安装说明的补充 (页 175)”部分介绍了与安装相关的几种例外情况。

使用 PCS 7 时，SIMATIC 组件的项目文档手册中与编程和参数分配相关的信息的有效性

受到限制。PCS 7 提供了许多附加工具和功能。对 SIMATIC 组件的参数进行编程和设置

时，应执行本手册“创建 PCS 7 组态”部分中介绍的过程。

PCS 7 工厂的结构
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安装说明指南 

组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

通信

工业以太网 手册《SIMATIC NET；用于工业以太网的 NCM S7》
(SIMATIC NET; NCM S7 for Industrial Ethernet)
手册《SIMATIC NET；三轴网络》(SIMATIC NET; Triaxial 
Networks)

手册《SIMATIC Net 双绞线和光纤网络》(SIMATIC Net 
Twisted Pair and Fiber-Optic Networks)

PROFINET IO 手册《SIMATIC NET；工业以太网/PROFINET 工业以太网》

(SIMATIC NET Industrial Ethernet/PROFINET Industrial 
Ethernet)

PROFIBUS 手册《SIMATIC Net PROFIBUS 网络》(SIMATIC Net 
PROFIBUS Networks)

AS 接口 手册《SIMATIC NET；ASI 接口 – 简介和基本信息》

(SIMATIC NET; AS Interface – Introduction and Basic 
Information)

SCALANCE X 手册《SIMATIC NET；工业以太网交换机 SCALANCE X》
(SIMATIC NET; Industrial Ethernet Switches SCALANCE X)

CP 443-1 设备手册《SIMATIC NET；用于工业以太网的 S7-CP》
(SIMATIC NET; S7-CPs for Industrial Ethernet)
B4 部分；CP 443‑1：
● 安装和调试（步骤 1 到 3）

扩展型 CP 443-5 设备手册《SIMATIC NET；PROFIBUS/B4 部分的 S7 CP；
扩展型 CP 443‑5》(SIMATIC NET; S7 CPs for PROFIBUS / 
Part B4; CP 443-5 Extended)：
● 安装和调试（步骤 1 到 2）

CP 1613 / CP 1623 安装说明《SIMATIC NET；CP 1613》
操作说明（精简版）《SIMATIC NET，CP 1623》
手册《SIMATIC NET；CP 1613 的日时钟功能》(SIMATIC 
NET; Time-of-day Functions of the CP 1613)

CP 1612 安装说明《SIMATIC NET；CP 1612》

CP 1512 安装说明《SIMATIC NET；CP 1512》
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组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

RS 485 中继器 手册《SIMATIC；PROFIBUS DP 的诊断中继器》(SIMATIC; 
Diagnostic Repeater for PROFIBUS DP)
● RS 485 中继器

PC 站

PC 站（ES、OS、
BATCH、Route Control、
归档服务器、OpenPCS 7、
PCS 7 BOX）

手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process 
Control System PCS 7; PCS 7 - PC Configuration)：
● 组态

● 组态

● 安装

自动化系统

S7-400 
（例如 AS 41x）

 

手册《SIMATIC；S7‑400 自动化系统；组态》(SIMATIC; 
S7‑400 Automation Systems; Configuration)：
● 安装 S7-400
● 对 S7-400 进行布线

● 调试

手册《可编程控制器 S7-400；CPU 数据》(Programmable 
Controller S7-400; CPU Data)：
● CPU 41x 的安装

● 技术规范

S7-400H 
(AS 41x-xH)

 

手册《过程控制系统 PCS 7；高可用性过程控制系统》

(Process Control System PCS 7; High Availability Process 
Control Systems)：
● PCS 7 中的高可用性解决方案

手册《SIMATIC S7-400H 高可用性系统》(SIMATIC 
S7-400H High Availability Systems)：
● S7-400H 安装选项

● 入门指南

● CPU 41x-H 的安装

● 使用 S7-400H 上的 I/O
● 运行中更换设备
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组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

S7-400F/FH 
(AS 41x-xH)

 

系统描述《SIMATIC S7 中的安全工程组态》(Safety 
Engineering in SIMATIC S7)：
● 故障安全系统的概述

● 带选择的组态和帮助

手册《SIMATIC；S7-400 自动化系统；安装：工业软件 S7 
F/FH 系统；组态和编程》(SIMATIC;  S7-400 Automation 
Systems; Installation:Industrial Software S7 F/FH Systems; 
Configuring and Programming.)。
● 安全机制

手册《SIMATIC S7-400H 高可用性系统》(SIMATIC 
S7-400H High Availability Systems)：
● S7-400H 安装选项

● 入门指南

● CPU 41x-H 的安装

● 使用 S7-400H 上的 I/O

PCS 7 AS RTX 功能手册《过程控制系统 PCS 7；SIMATIC PCS 7 BOX》
(Process Control System PCS 7; SIMATIC PCS 7 BOX)
● 安装 PCS 7 AS RTX
● 调试和组态 PCS 7 AS RTX

SIMATIC S7-mEC 功能手册《过程控制系统 PCS 7；SIMATIC PCS 7 BOX》
(Process Control System PCS 7; SIMATIC PCS 7 BOX)
● 安装 PCS 7 AS RTX
● 调试和组态 PCS 7 AS RTX
● SIMATIC S7-mEC 与 SIMATIC PCS 7 AS RTX 之间的差

异

S7-400 信号模块 手册《S7-400 自动化系统；模块数据》(S7-400 Automation 
System; Module Data)：
● 技术规范

分布式 I/O

ET 200SP HA 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System ET 200SP HA)
● 组态选项

● 安装

● 布线
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组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

ET 200M 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System ET 200M)
● 组态选项

● 安装

● 布线

用于过程自动化的 S7-300 
信号模块

手册《SIMATIC；分布式 I/O 系统 ET 200M；用于过程自动

化的信号模块》(SIMATIC; Distributed I/O System ET 200M; 
Signal Modules for Process Automation)：
● 关于组件的硬件配置和参数分配的手册

● 技术规范

S7-300 故障安全

信号模块

手册《SIMATIC；自动化系统 S7-300；ET 200M 分布式 I/O 
设备的故障安全信号模块》(SIMATIC; Automation System 
S7-300; ET 200M Distributed I/O Device Fail-safe Signal 
Modules)
● 关于组件的硬件配置和参数分配的手册

● 技术规范

带本质安全信号的

S7-300 信号模块

手册《SIMATIC；S7-300，ET 200M Ex I/O 模块》

(SIMATIC; S7-300, ET 200M Ex I/O Modules)：
● 关于组件的硬件配置和参数分配的手册

● 技术规范

FM 355 S

FM 355 C

手册《FM 355 和 FM 355-2 控制器模块》(FM 355 and FM 
355-2 Controller Modules)：
● 控制器设置

● 安装和删除

● 布线

CP 341 手册《SIMATIC；CP 341；安装和参数分配》(SIMATIC; 
CP 341; Installation and Parameter Assignment)：
● 串行数据传输的基本原理

● 安装

● 布线

ET 200iSP 手册《SIMATIC；分布式 I/O 设备 ET 200M》(SIMATIC; 
Distributed I/O DeviceET 200iSP)
● 组态选项

● 安装

● 布线和安装
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组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

ET 200S 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System ET 200S)
● 组态选项

● 安装

● 布线和安装

ET 200SP 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System ET 200SP)
● 组态选项

● 安装

● 布线和安装

ET 200pro 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System ET 200pro)
● 组态选项

● 安装

● 布线和安装

Compact Field Unit PA 手册《SIMATIC；分布式 I/O 系统》(SIMATIC; Distributed I/
O System Compact Field Unit) 
● 组件描述

● 安装

● 布线

PA-Link 和
DP/PA 耦合器

手册《SIMATIC；总线耦合器 DP/PA-Link 和 Y-Link》
(SIMATIC; Bus Couplers DP/PA-Link and Y‑Link)
● 组件描述

● 安装

● 布线

Compact FF Link 操作说明《SIMATIC；总线耦合器；紧凑型 FF Link》
(SIMATIC; Bus Couplers; Bus Link Compact FF Link)
● 组件描述

● 安装

● 布线

Y-Link 手册《SIMATIC；总线耦合器 DP/PA-Link 和 Y-Link》
(SIMATIC; Bus Couplers DP/PA-Link and Y‑Link) 
● 组件描述

● 安装

● 布线
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组件 在以下产品文档（•  章节……）中可找到与安装相关的信息

诊断中继器 手册《PROFIBUS DP 的诊断中继器》(Diagnostic Repeater 
for PROFIBUS DP)：
● 组态选项

● 安装

● 布线

DP/AS-i Link 20 E
DP/AS-i LINK Advanced

手册《SIMATIC NET; DP/AS I Link 20E》
手册《SIMATIC NET; DP/AS-INTERFACE LINK Advanced》
● 组件描述

● 安装

● 布线

6.4.3 PCS 7 产品安装说明的补充

ET 200S 对负载电压故障的诊断

说明

在出现负载电压故障时，ET 200S 的数字输入/输出模块不具有诊断功能。这意味着负载电

压故障时，通道驱动器上不报告任何 QBAD。 
无负载电压时，输出将不再通过用户程序进行切换，输入处显示的最后有效值。 

以下安装版本提供了一个补救措施：

● 使用带有电源模块 PM-E DC 24 V 的 24 V DC 数字量输入/输出模块：

由于整个站（IM151 和电源模块）通过共享的 24 V DC 电源供电，因此电压的故障会

导致站故障。这会在 PCS 7 中进行报告并导致所有相关模块的钝化。所有通道驱动器

都将设置为 QBAD。

● 使用带有电源模块 PM-E AC 120/230 V 的 120/230 V AC 数字输入/输出模块：

监视用户程序中的负载电压
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6.4.4 运行中修改组态（CiR）的规则

DP 和 PA 从站的规则       

使用 CiR 组态分布式 I/O 时，请遵守以下规则：

● 组态 DP 主站系统时，需规划数量充足的支线交叉点或间隙。不允许支线的传输率为 
12 Mbps。

● 即使更改组态时，也应使用活动的总线终端元件在两端终止 PROFIBUS DP 和 
PROFIBUS PA 总线线路，以保证总线终端正确。

● 为了防止分割线路，建议使用 SpliTConnect 产品系列的组件安装 PROFIBUS PA 总线

系统。

● ET 200M 站和 PA 链接必须始终与主动背板总线一同安装。应尽可能安装所需的所有总

线模块，因为操作期间无法安装和删除总线模块。

● 在 ET 200M 站，只能在最后安装的模块后直接插入模块或删除最后的模块。应始终避

免模块之间有间隙。

● 使用终端模块和终止模块完全组装 ET 200iSP 站。从一开始就为 IM 152 的 ET 200iSP 
配备所需的电子模块。在其余适合终止模块的插槽中安装预留模块。仅在高可用性 AS 
中可能存在模块间间隙。

IO 设备和 PA 从站的规则

使用 CiR or HCir 组态分布式 I/O 时，请遵守以下规则：

● 组态 PROFINET IO 系统时，需规划数量充足的支线交叉点或间隙。不允许支线的传输

率为 100 Mbps。

● 为了防止分割线路，建议使用 SpliTConnect 产品系列的组件安装 PROFIBUS PA 总线

系统。

● 在 IO 设备站，建议在最后安装的模块后直接插入模块或删除最后的模块。 

更多信息

有关 CiR 与 HCir 的区别，请参见手册《过程控制系统 PCS 7；CPU 410 过程自动化》

(Process Control System PCS 7; CPU 410 Process Automation)。
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工程组态的基本概念 7
概述

下面介绍了使用 PCS 7 进行工程组态的基本机制。提供高效的组态的 PCS 7 功能位于最

前端：

● 中央、工厂范围的工程组态 (页 178)

● 使用 PCS 7 向导的项目设置 (页 180)

● 分布式工程 (页 185)

● 工程数据的类型定义、复用性和集中编辑 (页 197)

● 导入及重用工厂数据 (页 208)

● 硬件与软件之间的自由分配 (页 211)

● 从 PH 获得画面层级和 OS 区域 (页 212)

● 生成块图标 (页 214)

● 生成操作员文本 (页 214)

● PCS 7 消息系统的基本概念 (页 216)
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7.1 中央、工厂范围的工程组态

使用 SIMATIC Manager 集中进行工程组态

SIMATIC Manager 是所有工程组态任务的中央起始点。      

PCS 7 项目的管理、归档和记录都在这里进行。 

可通过 SIMATIC Manager 访问工程组态系统的所有应用程序。 

如果 ES、OS、BATCH、Route Control 与 AS 之间存在连接，则可从 SIMATIC Manager 
将组态数据传送到目标系统，然后进行在线测试。 

工程组态系统

工程组态系统基于协同的应用程序构建，这样便于在 PCS 7 工厂中实现所有组件集中式

的、项目级的工程组态：

● 组态硬件和现场设备（HW Config、SIMATIC PDM）

● 通信网络组态 (NetPro)

● 组态连贯有序的过程顺序（CFC、SFC）

● 组态不连续的过程顺序 - 批生产过程 (SIMATIC BATCH)

● 组态路径控制（SIMATIC Route Control）

● 设计操作员控制和监视策略（WinCC 图形编辑器）

工程组态的基本概念
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● 组态报警系统（组态 PCS 7 消息系统、OS 项目编辑器、报警记录）

● 编译所有组态数据并将其下载到目标自动化系统 (AS)、操作员站 (OS)、维护站 (MS)、
BATCH 站 (BATCH) 和 Route Control 工作站

集成的数据库

由于有了工程组态系统的集成数据库，数据只要输入一次便可用于整个系统。

更多信息

● “PCS 7 应用程序及其使用方法 (页 245)”部分
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7.2 创建项目和访问保护

7.2.1 使用 PCS 7“新建项目”向导设置项目

PCS 7“新建项目”向导

利用 PCS 7 的“新建项目”(New Project) 向导，可创建新的 PCS 7 项目。可通过对话框自

动创建所有必需对象。      

在 SIMATIC Manager 中启动 PCS 7“新建项目”(New Project) 向导。

工程组态的基本概念
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接下来您会了解到 PCS 7 向导可提供的优点。

PCS 7“新建项目”向导选项

可通过对话框选择下列对象：

● 要使用的 CPU

● 要创建的 AS 对象（CFC、SFC）和 OS 对象（PCS 7 OS、SIMATIC BATCH、

SIMATIC 路径控制、OpenPCS 7）

● PCS 7 OS、SIMATIC BATCH、SIMATIC 路径控制或 OpenPCS 7 应为单工作站系统、

多工作站系统还是冗余多工作站系统

● 新项目的名称

● 项目的存储位置（项目路径）

预先在预览中检查项目的结构。然后开始完成项目。

结果

按照预览，在 SIMATIC Manager 中创建了在多项目工程中包含从属项目的多项目（参见

上图）。预览会根据所选的设置进行调整，并向您展示 PCS 7 向导所创建的结构。

还创建了包含以下内容的主数据：

● 在工厂层次结构中：

分别针对过程变量类型、模型和共享声明的文件夹

● 在组件视图中：

有一个 S7 程序，其中包含分别放置源文件、块和图表的几个文件夹以及

一个放置共享声明的文件夹

更多信息

● “如何使用 PCS 7 向导创建新的多项目 (页 256)”部分。

7.2.2 使用 PCS 7“扩展项目”向导扩展项目

PCS 7“扩展项目”向导 

利用 PCS 7“扩展项目”(Expand Project) 向导可扩展现有的 PCS 7 项目，以包含更多的预

组态 SIMATIC 400 站或 SIMATIC PC 站。可通过对话框自动创建所有必需对象。    
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在 SIMATIC Manager 中启动 PCS 7“扩展项目”(Expand Project) 向导。

用于插入预组态工作站的选项

可通过对话框选择下列对象：

● 是否要创建 SIMATIC 站和/或 PC 站（未集成硬件）

● 要使用的 CPU

● 要创建的 AS 对象（CFC、SFC）和 OS 对象（PCS 7 OS、SIMATIC BATCH、

SIMATIC 路径控制、OpenPCS 7）

● PCS 7 OS、SIMATIC BATCH、SIMATIC 路径控制或 OpenPCS 7 应为单工作站系统、

多工作站系统还是冗余多工作站系统

● 项目的存储位置（项目路径）

可以预先在预览中检查项目的结构。 

结果

为所选项目中的 OS/BATCH/Route Control/OpenPCS 7 创建了一个新的 SIMATIC 400 站
或 SIMATIC PC 站（与预览一样）。 

更多信息

● “如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部分。

7.2.3 通过访问保护来保护项目/库

简介    

建议保护您的项目和库免受未经授权的访问并记录所有访问操作。

说明

要使用此功能，需要安装 SIMATIC Logon。
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通过保护密码进行访问

从 PCS 7 V7.0 开始，可指定保护密码来为项目和库提供访问保护。这些项目和库以后仅

能由具有以下用户角色之一的 Windows 用户来打开和编辑：

● 项目管理员

● 项目编辑人员

● 使用保护密码验证自身的用户

设置授权

项目管理员定义项目编辑人员与项目密码。管理员有权激活和禁用访问保护。 

项目管理员可为 Windows 用户分配两种用户角色之一。

用于设置访问保护的功能

在 SIMATIC Manager 中，可为每个项目或库做出以下访问保护设置。可在整个多项目间

同步访问保护。

功能 描述 执行操作所需的用户

角色

激活访问保护（包

括定义项目密码）

● 为特定项目或库激活访问保护

此项目或库只能由分配了项目编辑人员或项

目管理员角色的 Windows 用户来打开和编

辑。

● 指定项目密码

可为每个项目或库指定项目密码

项目管理员

禁用访问保护 为特定项目或库禁用访问保护 项目管理员

管理用户 指定项目管理员和项目编辑人员 项目管理员

同步多项目中的访

问保护

为多项目中的所有项目和库全局指定项目管理

员和项目编辑人员。

项目管理员

显示更改日志 打开更改日志 项目管理员

项目编辑人员

删除访问保护和更

改日志

删除访问保护和受密码保护的项目或库的更改

日志。

项目管理员
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更改日志

如果激活了访问保护，则可以在更改日志中记录以下事件，例如：

● 激活/禁用/组态访问保护和更改日志

● 打开/关闭项目和库

● 下载到目标系统（系统数据）

● 用于下载和复制块的操作

● 在测试模式下更改参数

● 更改 CPU 模式的活动（例如，停止 CPU）

● CPU 存储器复位

可以显示更改日志、为其添加注释并将其导出。

用于设置更改日志的功能

在 SIMATIC Manager 中，执行以下更改日志功能。

功能 描述 执行操作所需的用户

角色

激活更改日志 为带访问保护的项目或库激活更改日志。 项目管理员

禁用更改日志 为带访问保护的项目或库禁用更改日志。 项目管理员

显示更改日志 显示更改日志的内容。可添加注释。 项目管理员

项目编辑人员

更多信息

● “如何提供带有访问保护的项目/库 (页 263)”部分

● “如何在更改日志中记录更改 (页 672)”部分

● “如何在 ES 日志中记录更改 (页 669)”部分

● 手册《SIMATIC Logon；SIMATIC 电子签名》(SIMATIC Logon; SIMATIC Electronic 
Signature)

● 更改日志的在线帮助
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7.3 分布式工程

PCS 7 提供以下选项，可供多个项目工程师使用：

● 在多项目中组态 (页 188) 

● 分支和合并项目图表 (页 192) 

如果项目数据位于中央服务器，则可以通过网络在工程师站之间交换这些数据（例如，项

目特定的块库）：

● 在网络中组态 (页 194) 

7.3.1 工程组态的工作方法

多项目工程组态

如果要使若干项目小组并行处理复杂项目，可使用多项目工程组态。可以使用多项目工程

组态快速灵活地对工厂进行组态。   

● 进行组态时，整个自动化项目（多项目）分成多个工艺项目。在中央工程师站上创建多

项目中的各个项目。并使所有共享对象可在主数据库中使用。在中央工程师站上管理这

些项目和主数据库。

● 工程师可以将这些项目移动到其它工程师站，进行分布式组态。

● 处理完多项目中的各个项目并返回到多项目后，可在系统的支持下同步跨项目数据。

说明

使用分布式工程师站

● 只应将实际需要分别编辑的项目组件（AS、OS）移动到分布式工程师站上。这样可确
保多项目的其它对象保持可用。

● 只能将整个用户项目移动到分布式 ES。

更多相关信息，请参见“在多项目中组态 (页 188)”部分。
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分支和合并项目图表

如果有必要让多个项目工程师处理 AS 或 OS，则可拆分项目。

● 应按照工艺特点在项目内分布（例如，应将单元与相关图表一起复制到其它项目）。

会自动以文本互连替换跨图表互连。

● 合并每个项目时，会在编辑完成后将各部分复制回原始项目中。同名图表会在提示用户

确认后被替换。然后重新建立文本互连。

说明

在多项目工程组态中使用

此拆分选项可独立于多项目工程组态或在多项目工程组态基础上使用。在这种情况下，

特定项目可仍保留在其存储位置。通过网络，多个工程师站可以打开该项目并对其进行

编辑。

在多项目工程组态的情况下，主数据库构成了单独处理项目图表的基础。

更多相关信息，请参见“分支和合并项目图表 (页 192)”部分。

在网络中组态（多用户工程组态）

如果多个项目工程师从其各自的工程师站处理中央服务器上或带有共享驱动器的 PC 上的

某个项目，他们还可同时处理该项目的特定部分。   

更多相关信息，请参见“在网络中组态 (页 194)”部分。

说明

中央网络服务器是工程师站。如果该工程师站仅用于存储项目，而不用于组态操作，则不

需要使用工程师站的许可证密钥。

7.3.2 指定组态的项目结构

为了尽可能有效地编辑自动化项目，您需要考虑该项目的各种情况以及现有的工程组态环

境。

指定工程组态项目的设计

从根本上说，您可以创建具有项目特定设计或站特定设计的工程组态项目。而实践中创建

两者的组合通常是最佳选择。

工程组态的基本概念

7.3 分布式工程

工程组态系统 (V9.0 SP1)
186 配置手册, 12/2017, A5E39221328-AC



请记住为工程组态项目的设计定义工厂特定条件。相关示例有：

● 项目工程师人数

● 可用工程师站数量（符合 PCS 7 ES 系统要求）

● 工程师站联网

● 项目复杂程度

● 组态持续时间/费用

项目特定的设计

在此情况下，每个特定的项目都包含项目工程师要编辑的一个 AS 和一个 OS，或所有 AS 
和 OS。

这就是项目工厂视图为何既包含 AS 对象（如 CFC 和 SFC）又包含 OS 对象（如画面和

报表）的原因。

优点

● 可通过项目中的 AS 和 OS 对设计进行全面组态和测试。

● 组态和调试过程中的运行模式是相同的。

● 可以复制整个工厂单元，包括 OS 对象的更新。

● 工厂层级中具有统一视图，其中包含单项目中的 AS 和 OS。

说明

注意事项

● 要在以后实现分布式编排（从单项目中删除特定的 AS 或 OS），必须详细了解各个顺序
步骤。

● 从一开始就应尽可能具体地组织项目。

站特定的设计

与项目特定的设计相反，在这种情况下，所有 AS 和 OS 均独立（分布式）存储在各个项

目中。

因此，AS 项目中不存在 OS 对象，OS 项目中也不存在 AS 对象。
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优点

● 这种分布式结构可确保能够以最灵活的方式将各个项目分配给项目工程师，还可以在编

辑速度方面实现最佳性能。

● 可以在调试过程中添加或删除工程师站，从而能快速应对人员可用性的变化。

说明

注意事项

● 在单独的计算机上对组态期间的 AS 和 OS 进行测试（在分布式站可用的情况下）。

● 必须在编辑之后再次更新已保持冗余的各项目的部分工厂层级。

● 不可以复制整个工厂单元，包括 OS 对象的更新。

7.3.3 在多项目中组态

简介

SIMATIC PCS 7 的多项目功能以所有包含的项目永久可用为基础。如果不存在永久可用的

网络连接，则应将单项目从多项目网络中删除，以进行分布式编辑。其原因是：并不是所

有的 PC 站都在网络中永久可用，或特意在网络外编辑项目（例如与工程组态部门/系统集

成商签订的合同）。   

通过以下系统功能删除或重新集成各项目：

● 删除以进行编辑

● 编辑后重新应用

优点

● 不会由于缺少项目而出现意外的延迟或等待时间。

● 在执行分布式编辑期间，不会意外访问项目（例如执行跨项目的功能时）。

注意事项：

● 使用 NetPro 时，已组态的连接会因为缺少通信伙伴而生成警告消息。在项目拆分期间，

只能通过引用创建未指定的新连接。

● 如果无法访问所包含的某个组件（例如，在打开多项目的过程中或在使用 NetPro 时），

则可能需要长时间等待。

● 如果要编译 OS 服务器，则必须在中央位置组合所有相关项目（AS 项目和相应的 OS 
项目）。
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● 必须将主数据库作为本地备份进行管理。

● 必须在本地对各项目进行归档。

多项目的结构

在 SIMATIC Manager 中，多项目是一种级别高于项目的结构。它包括自动化解决方案的

所有项目、主数据库以及从属对象（AS、OS、程序、图表等）。  

项目分布规则

以如下方式对自动化解决方案进行拆分：任何一位项目工程师所必须编辑的全部自动化系

统和操作站都应该包含在单个项目中。以下规则适用：

● 在任意时刻，只能由一位项目工程师来编辑多项目中的某个项目。

● 项目的最小可能单元为 AS 或 OS。

● 仅可将整个项目移动到分布式工程师站。

● 仅将形式上实际需要编辑的对象（AS、OS）移动到分布式工程师站上。这意味着多项

目中的所有其它对象均可在中央分布式工程师站上进行编辑。

● OS 服务器必须包括分配给它的自动化系统的所有工厂层次。
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● 相应的通信伙伴均可供跨项目的功能操作使用。相关示例包括组态 SIMATIC 连接或编

译 OS。

● 如果与各个项目工程师相关的项目部分在分布式工程师站本地可用，则系统可实现最佳

性能。

使用 SIMATIC BATCH 进行多项目工程的规则

注意

在分布式工程师站上进行分布式工程组态的规则

对于使用 SIMATIC BATCH 的多项目工程，只有在满足了某些条件及采取了附加步骤的

情况下，才能在分布式工程师站上进行分布式工程组态（包括测试在内）。  
有关此主题的更多信息，可访问 Internet (https://support.industry.siemens.com/cs/cn/zh/
view/23785345)。

多项目中外部归档服务器的规则

说明

在一个多项目中仅可组态一个外部归档服务器 (Process Historian)。   
当使用冗余归档服务器时，在多项目中只能有一个 PC 站充当归档服务器，另一个 PC 站
充当该归档服务器的冗余 PC 站。

在将一个多项目的多个分布式项目合并后，在该多项目中只能存在一个外部归档服务器。

操作系统要求 

说明

请注意以下事项：

● 在对大型项目进行分布式工程设计时，为能在网络中工作，中央工程师站上必须安装一个准
许用于现有版本 PCS 7 的服务器操作员系统。

● 分布式工程师站可使用准许用于现有版本 PCS 7 的操作系统之一。
有关准许的操作系统的更多信息，请参见文档《PCS 7 过程控制系统；PCS 7 自述文件》
(PCS 7 Process Control System; PCS 7 Readme)。
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建议步骤总览 

为了能够成功使用多项目，请熟悉 STEP 7 在线帮助中“使用多项目中的项目”部分中的

多项目。使用 PCS 7 时，建议采用以下步骤。 

步骤 描述

1 在中央工程师站上创建包含一个项目的多项目及主数据库（使用 PCS 7“新建

项目”(New Project) 向导）。

2 在中央工程师站上插入更多项目，并存储多项目主数据。

3 将多项目中包含的项目和主数据库移动到分布式工程师站。

4 分散编辑项目

5 将分布式项目移回到中央工程师站

6 在中央工程师站上执行交互项目功能

说明

执行交互项目功能时，涉及的所有项目必须物理存在于中央工程师站上的多项目中，并且

它们未处于工作状态。

依照以上步骤，在“实施 PCS 7 组态”部分中也对组态过程进行了描述。

关于步骤 3 - 移动项目以进行分散编辑的建议时间

对于何时应将项目移动到分布式工程师站，并没有特别的时间要求。建议预先在中央工程

师站上至少执行以下步骤：

● 创建具有单独项目的多项目

● 在各项目下，为 OS、BATCH、Route Control 和 OpenPCS 7 创建 AS 和 PC 站

● 创建工厂层级的结构

● 对主数据库和那些必须在项目中联合使用的对象进行编译

依照以上步骤，在“实施 PCS 7 组态”部分中也对组态过程进行了描述。

关于步骤 6 - 跨项目的功能 

跨项目的功能用来确保在 SIMATIC Manager 中可像处理单项目一样来处理多项目。例如，

这样可将多项目连同所有项目和主数据库一起进行归档，或者将其保存在另一个位置。 
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此外，还有一些交互项目功能，分散编辑后最终需要在中央工程师站上的多项目中执行这

此功能。这些功能包括：

● 合并项目间子网以及到文本引用的连接

● 在 AS 和 OS 之间组态新的跨项目 (S7) 连接 

● 编译 PCS 7 工厂中包含的所有组件（AS、OS、BATCH、Route Control 等）并按正确

顺序自动将其下载到 CPU

● 对于每个 OS 客户端：从所有相应的 OS 服务器上下载服务器数据

服务器数据下载只执行一次。之后，每次在过程模式下启动 OS 客户端时，会自动更新

服务器数据。

● 生成/更新块图标

● 创建/更新诊断画面

说明

执行交互项目功能时，涉及的所有项目必须物理存在于中央工程师站上的多项目中，并

且它们未处于工作状态。

更多信息

● “如何通过添加新（空）项目扩展多项目 (页 258)”部分

● “如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部分

● “分散多项目（多项目工程组态）简介 (页 334)”部分

● “在分散编辑后合并项目（多项目工程组态） (页 615)”部分

● “多项目中的附加 PH 功能 (页 300)”部分

● STEP 7 的在线帮助

7.3.4 分支和合并项目图表

分支项目图表

还可于图表级别（S7 程序）在涉及多个项目工程师的项目中进行分支与合并操作。应按照

工艺特点在项目内分布（例如，应将单元与相关图表一起复制到其它项目）。会自动以文

本互连替换跨图表互连。      

编辑完成后，将各部分复制回原始项目中。同名图表会在提示用户确认后被替换。然后重

新建立文本互连。
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在多项目工程组态中使用

说明

此拆分选项可独立于多项目工程组态或在多项目工程组态基础上使用。 
在多项目工程组态的情况下，主数据库构成了单独处理项目图表的基础。

建议步骤总览

步骤 描述

1 将项目的工艺部分（单个图表、多个图表）复制到其它项目。

结果：副本中包含与未包含在复制部分的所有源的文本互连。

2 单独编辑复制的部分（添加、删除、修改块和图表）。

3 将此经过编辑的工艺部分复制回原始项目。

结果：系统首先会删除原始项目中同名的图表。所有这些图表中都存在等待从

删除的图表获取数据的文本互连。随后，系统会从其它项目复制图表。

4 闭合所有文本互连。

结果：在另一项目内已编辑并复制回原始项目的图表中，以及在因删除图表而

在其中生成文本互连的图表中，都会关闭互连。

说明

必须在组件视图中复制图表。

如果在工厂视图中复制图表，将创建目标文件夹中图表的副本，而不是进行替换。

在分布式工程师站上进行编辑的规则

● 在网络永久可用的情况下，可以将项目各部分移动到分布式工程师站上进行编辑，而且

仍能在多项目中保持同步。

● 在项目端，必须确保项目工程师始终能够访问多项目的各部分。

以下是所需功能组件的示例：

– 网络连接（例如，考虑由操作系统产生的限制）

– 网络组件（例如交换机、路由器）

– PC（包括必需的许可和权限）
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优点

● 可随时使用其它项目中自动化系统的数据对 OS 服务器进行编译。

● 所有用到的项目部分均包含在主数据库中，并且可通过网络访问主数据库。

● 可以在工程组态服务器上轻松归档整个项目（包括所有分散的单个项目）。

● 在网络永久可用的情况下，大型分布式站项目结构及其分布式编排是能够实现最佳性能

的组态选项。

注意事项

● 如果出现与预期相反情况，即项目在网络中不可用，将导致长时间的延迟或等待。

● 在执行跨项目的功能时，项目工程师必须相互协调，以确保此时没有对所包含的某个项

目进行操作。否则会出现冲突。

更多信息

● “由多位用户进行组态（文本互连） (页 461)”部分

7.3.5 在网络中组态

应用

如果多个项目工程师从其各自的工程师站处理中央服务器上或带有共享驱动器的 PC 上的

某个项目，他们还可同时处理该项目的特定部分。     
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在多用户工程组态中，可能出现下列情况：   

●  多位项目工程师同时处理同一个 AS 的 CFC 或 SFC：

– 编辑不同图表文件夹中不同的图表。

– 编辑同一图表文件夹中不同的图表。

– 编辑同一图表。

说明

中央网络服务器是工程师站。该工程师站可以有如下用途：

● 仅用于存储项目，在此情况下，该工程师站不需要许可证密钥。

● 用于组态项目。在此情况下，该工程师站需要许可证密钥。

●  多位项目工程师同时处理同一个操作站的以下对象：

– 对一个 OS 的各种过程画面进行编辑。

– 对一个 OS 的各种报告进行编辑。

– 对一个 OS 的各种脚本进行编辑。 

编辑不同图表文件夹中不同的图表

不同图表文件夹中的不同图表可由多位项目工程师分别在不同工程师站上进行编辑。在此

情况下，各个工程师所执行的工作通常不会与其他人的工作相冲突。

编辑同一图表文件夹中不同的图表

同一图表文件夹中的不同图表可由多位项目工程师分别在不同工程师站上进行编辑。某个

工程师所执行的工作不太可能与其他人的工作相冲突。但是，却无法完全排除冲突的可能

性，因为所有图表会访问同一资源，如符号表、运行顺序等。

可能发生以下冲突情况： 

● 如果某个项目工程师进行了离线更改而其他项目工程师正在测试模式下工作，那么他们

下次进入测试模式时，将收到消息，指出必须重新编译图表并将其装载到目标系统。项

目工程师此时应负责决定是否激活测试模式。这样做的意义大小取决于离线更改；项目

工程师应在这一点上达成一致。

● 出现另一个应用程序正在使用该数据的消息后，如果在测试模式中记录或删除监视值，

会话日志中不会存储此操作。因此下次启动测试模式时，必须重新记录或删除。

● 如果由于离线更改（例如，因为块已被删除）而使得测试模式中的监视值不再更新，系

统会在相应的连接处以红色背景显示“#”字符，而不显示这些监视值。

● 当某位项目工程师在测试模式下编辑参数时，系统将拒绝由另一位工程师启动的所有编

译操作，同时显示一条消息，说明数据当前正由其它应用程序使用（访问冲突）。
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编辑同一图表

多位项目工程师编辑同一图表时会产生相互干扰。因此，不建议这样做。如果图表已由一

位项目工程师打开，则其他各位项目工程师在打开该图表时都将接到相关通知。

不同操作的行为

基本的规则是：发生访问冲突时，将总是执行具有最高优先级的操作。在这种情况下，优

先级较低的操作会被取消。短读取操作具有低优先级，所有其它操作具有较高的优先级。

操作类型 读/写操作 响应

短读取操作（不带有

资源分配）包括：

● 打开图表

● 打开运行顺序

● 打开对话框

并行执行其它短读取操作时，应不会产

生冲突。

同时执行短写入操作或长写入操作时，

会导致存取冲突。即，将取消短读取操

作。

短写入操作（不带有

资源分配）包括：

● 实例化、参数化、互连

等。

● 单击“确定”(OK) 关闭对

话框

并行执行短写入操作或长写入操作时，

无论哪个操作较晚启动，都会产生访问

冲突。

长读取操作（带有资

源分配）包括：

● AS-OS 数据传输（OS 
编译）

如果触发长读取操作时未立即产生存取

冲突（例如，由于已并行执行了写入操

作），则执行此操作时将不会产生存取

冲突。

长写入操作（带有资

源分配）包括：

● 优化运行顺序

● 编译

● 下载

如果触发长写入操作时未立即产生访问

冲突（例如，由于已在同时执行写入操

作），则执行此操作时将不会产生访问

冲突。

更多信息

● “由多位用户进行的组态（文本互连） (页 461)”部分

● CFC 在线帮助
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7.4 工程数据的类型定义、复用性和集中编辑

简介

在工厂工程组态中，一些工厂部件、功能或程序部分彼此之间仅在几个方面存在差

异。       

为了提高工作效率，可创建一些可重复使用且仅需提供当前参数的基本元件（单元、程序

部分等）。 

可重复使用的基本元素

基本元素 描述

块类型 (页 198) 块类型是可插入到 CFC 的程序段。可通过块类型创建块实

例。块类型位于 PCS 7 高级过程库中。例如，其中包含用于

激活电机或阀门的块。

还可以创建自己的块类型或根据工厂需求修改 PCS 7 高级过

程库中的块类型。

SFC 类型 (页 200) SFC 类型是一种顺序控制器，它可在 SFC 编辑器中组态并

可插入到 CFC 中。将创建可执行的 SFC 实例。

过程变量类型 (页 201) 过程变量类型是一个 CFC（它也可能包含 SFC 类型）用于

为过程工程工厂在基本自动化方面组态特定的过程控制功能。

过程变量可通过导入/导出助手 (IEA) 从过程变量类型中创建，

也可在 CFC 编辑器中创建。

控制模块类型 (页 506) 

 

控制模块类型是一种 CFC（其中还可能包含 SFC 类型），

它为实现过程工程工厂的基本自动化针对特定过程控制功能

而组态。 

使用高级工程系统或 CFC 编辑器，可从控制模型类型创建实

例（即控制模块）。

与过程变量类型相比，控制模块类型具有以下优势： 
● 对实例（即控制模块）进行的实例特定的更改在类型和实

例同步期间不会丢失。

● 控制模块类型可包括可选块。当创建实例（控制模块）时，

可决定应向各个实例中插入哪些可选块。

模型 (页 203) 模型可以包含更大的单元，例如子工厂。它由包含 CFC/
SFC、画面、报表及附加文档的层级文件夹组成。可使用导

入/导出助手 (IEA, Import/Export Assistant) 创建副本。
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项目特定的目录规约

可以使用所提供的硬件目录（位置为 HW Config：PCS 7_Vx.y）创建项目特定的目录配置

文件。 

使用经修改满足用户需要的目录配置文件可高效配置硬件。更多相关信息，请参见“定义

项目特定的目录配置文件 (页 344)”部分。

7.4.1 使用块类型、面板和块图标

块类型

块类型是程序的预编译部分，这些程序用于处理可插入到 CFC 中的重复功能。块类型创建

块实例，随后可为块实例分配参数并进行互连。块类型确定了此类型的所有实例的特

性。             

可根据项目需要修改块类型，例如，修改操作员文本或使参数可见/隐藏。为确保在整个项

目中只使用块类型的一个版本，请将所有块类型集中存储在主数据库 (页 204)中，而且在

实例化之前对其进行修改。 

说明

在主数据库中存储块类型。这意味着可确保整个项目中只使用特定块类型（带有类型名称）

的一个版本。

如果由一个 OS 来监控程序，则不同程序的不同版本会导致冲突。相同的块类型变量（相

同的类型名称）具有相同的结构时，将发生这一情况。

可能的块类型

以下块类型可存储在主数据库中：

● 过程系统库中的块类型

● 供应商库中的块类型

● CFC 中用户创建的块类型

集中组态

如果块类型的接口描述和/或系统属性发生更改，将该块类型导入到 CFC 数据存储系统时，

它将覆盖（更新）同名的现有块类型。此类型的所有块实例也随之更改，以符合新的块类

型。 
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集中的类型可修改性与 FB 和 FC 相关。 

执行集中更改之前，会出现一条关于后果的警告，其中包含新旧块类型的相关信息，例如，

名称、上一次接口更改的日期。

集中更改类型可能会对块实例产生负面影响。互连和参数分配可能会丢失。在这种情况下，

必须自行修改相应的块实例。

将记录集中类型修改，更新后将自动显示此日志。也可以在后来通过菜单命令“选项 > 日
志：块类型...”(Options > Logs: Block Types...) 调用此日志。如果需要调整块实例，使用

此日志可将工作量和出错风险降到最低。

类型/实例概念 - 集中组态

类型/实例概念的优点在于能够集中进行修改。这样就能对块类型、SFC 类型、过程变量类

型和模型集中进行后继更改，并随后将这些更改应用到所有实例和副本。

说明

请参见 CFC、SFC 和 IEA 的在线帮助，以找出实例和副本所支持的类型更改。

面板和块图标

在 OS 上，在过程模式下监控块实例需要相应的面板。面板包含专门用于操作员监控的工

艺块的所有元件的图形表示。面板在 OS 的单独窗口中进行描述，并通过块图标（通常位

于 OS 总览显示中）来打开。

PCS 7 高级过程库中的每种工艺块类型都有对应的面板。块图标可通过菜单命令自动生

成。也可自行创建和修改面板与块图标。 

更多信息

● “如何根据特定项目调整块 (页 316)”部分

● 手册《过程控制系统 PCS 7；高级过程库》(Process Control System PCS 7; Advanced 
Process Library)

● 手册《过程控制系统 PCS 7；块编程指导》(Process Control System PCS 7; 
Programming Instructions for Blocks)

● CFC 在线帮助
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7.4.2 使用 SFC 类型

SFC 类型

SFC 类型允许将顺序控制系统定义为可重用模板。SFC 类型是一种顺序控制系统，它可

在 SFC 编辑器中组态并可插入到 CFC 中。将创建可执行的 SFC 实例。SFC 实例在 CFC 
中显示为块，并带有一个与块实例相对应的接口。

要运行 SFC 实例，必须对 SFC 类型和 SFC 实例进行编译，并将它们下载到自动化系统。

为确保在整个项目中只使用 SFC 类型的一个版本，请将所有 SFC 类型集中存储在主数据

库 (页 204)中，而且在安装之前对其进行修改。

可定义能够在顺控程序中使用的 SFC 类型特征（控制策略、设定值、参数、注释文本、位

置文本等）。控制策略由操作或更高级别的控制器（例如，SIMATIC BATCH）来指定。

说明

无法将 SFC 类型分配给工厂视图中的层级文件夹，因为它们与执行无关。

可能的 SFC 类型

例如，也可以在库/主数据库中存储以下 SFC 类型：

● 用户创建的 SFC 类型

● SFC 库中的 SFC 类型

集中组态

对 SFC 类型接口的修改将传送到 SFC 实例。

编译并下载 AS 后，以下更改将自动在 SFC 实例中生效。

● 对拓扑的更改（步/转移顺序、更改的跳转目标）

● 对步组态的更改

● 对转移组态的更改

SFC 可视化仅在编译并下载了 OS 后才执行更新。
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更多信息

● “如何创建 SFC 类型 (页 543)”部分

● 手册《S7 的 SFC；顺序功能图》(SFC for S7; Sequential Function Chart)

7.4.3 使用过程变量类型

过程变量类型

过程变量类型是一种 CFC（它还可包含 SFC 类型），它针对 PCS 7 工厂中重复发生的特

定基本自动化过程控制功能（如填充液位控制）进行组态。借助导入/导出助手，可基于导

入文件通过一次操作从过程变量类型复制大量过程变量。随后可根据必需的、特定的自动

化任务对过程变量进行修改，并相应地进行互连。     

将过程变量类型集中存储在主数据库 (页 204)中。在派生过程变量之前修改过程变量类

型。 

过程变量类型源

以下过程变量类型可存储在主数据库中：

● PCS 7 高级过程库 中的模板

● 控制系统库中的标准化过程变量类型，例如，针对电机、阀、PID 控制器的变量类型

● CFC 中用户创建的过程变量类型

生成过程变量

在使用导入/导出助手导入期间，可通过过程变量类型创建过程变量。导入文件中的每一行

均会在目标项目中创建一个过程变量。过程变量会保留到过程变量类型的分配。

集中组态 

通过“创建/修改过程变量类型”(Create/modify process tag type) 向导对过程变量类型进行

更改。在该向导中对过程变量进行的更改将自动同步到项目中现有的此类型的过程变

量。     
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可使用此向导对过程变量类型进行以下更改：

● 从过程变量中删除过程变量类型中不存在的参数、信号连接点和消息。重置相应属性。

● 将过程变量类型中新定义的参数、信号连接点和消息添加到过程变量。设置相应属性。

● 在过程变量中更正过程变量类型中已更改的类别。

如果更改无法自动同步（例如，由于自动同步时，项目的过程变量并非全部都可用），则

可使用“更新过程变量”(Update Process Tags) 向导中的菜单命令再次启动同步。

无法自动同步的过程变量类型与过程变量之间的不一致性会显示在日志中。

说明

如果使用“创建/修改过程变量类型”(Create/Modify Process Tag Type) 向导直接在过程变

量类型的 CFC 中进行任何更改，则这些更改不会应用到现有的此类型过程变量！ 
其中包括以下更改： 
● 添加/删除块

● 互连更改

● 参数更改

此时，必须先删除受影响的 CFC，然后再使用导入/导出助手重新导入已更改的过程变量类

型。 
不能再对现有过程变量类型或者通过其派生的过程变量的块名称进行更改。否则，将不能

再进行导入/导出。

说明

确保多项目中的所有项目都可用，以便同步过程变量。

使用过程变量类型

以“填充液位控制”过程变量为基础创建过程变量类型： 

在下例中，过程变量是一个 CFC（包含附加属性），用于“填充液位控制”系统功能的信

号采集、信号预处理、自动化以及操作员监控。

该 CFC 有以下特征：

● 有一个固定在锅炉上的填充液位传感器。该传感器将 0 到 1500 l 的填充液位转换为 4 
- 20 mA 的电流值。

● 信号电缆连接到模拟量输入模块的通道上。信号名称列出在工厂的信号列表中。自动化

块通过信号的名称访问此无条件信号。

● 实现模拟值输入的驱动程序块 (CH_AI) 将无条件信号转换为预处理信号（0 l 到 1500 
l）。
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● 控制器块 (CTRL_PID) 根据设定值和填充液位传感器提供的实际值来确定范围在 0 到 
100 % 之间的调节值。

● 实现模拟值输出的驱动程序块 (CH_AO) 将该信号转换为无条件信号，并传递给模拟量

输出模块。

● 在模拟量输出模块上，通过电流为 4 - 20 mA 的电线来连接控制。阀在 4 mA 时关闭，

在 20 mA 时完全打开。电流为中间值时阀部分打开。

● 控制器块在 OS 中具有以下元件：

– 一个面板

– 设定值和实际值的归档变量

– 超出填充液位上限或下限时发出报警

测试完成后，可使用导入/导出助手基于以上述方式定义的过程变量创建过程变量类型。

更多信息

● “通过过程变量类型创建过程变量（多项目） (页 509)”部分

7.4.4 使用模型

模型

模型用于定义比过程变量类型（直到工厂部分）更复杂的功能，并将这些功能存储为可重

复使用的模板。模型由包含 CFC/SFC、画面、报表及附加文档的层级文件夹组成。借助导

入/导出助手，可在单个事务中基于导入文件从模型复制大量过程变量。随后，可对副本进

行修改，以符合必需的、特定的自动化任务需要。    

说明

只能在多项目中创建模型。

将模型集中存储在主数据库 (页 204)中。创建副本前对模型进行调整。

创建副本

用于导入/导出参数描述、互连描述和消息的块在模型的图表中已准备好。将模型链接到导

入文件后，便可使用导入/导出助手导入该模型。将会为所生成的副本分配模型的参数、互

连和消息。

导入文件中的每一行均会在目标项目中创建一个副本。副本将保留到模型的分配。 
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集中组态

可使用“创建/更改模型”(Create/Change Model) 向导对模型进行更改。

如果对已具有副本的模型或模型的 I/O 点进行修改，由于导入数据不再与模型数据相匹配，

因此会显示一条消息，指出此情况。

使用“创建/更改模型”(Create/Change Model) 向导，检查模型与已分配的导入文件、以及

在 IEA 标识中更改的副本的一致性。 

说明

不可再修改现有模型或模型副本的块名称。否则，将不能再进行导入/导出。

更多信息

● “如何创建模型 (页 555)”部分

● IEA 的在线帮助

7.4.5 使用主数据库

主数据库

使用 PCS 7 向导创建多项目时，会自动创建主数据库。主数据库用于存储多项目的所有项

目的项目主数据。将项目从多项目移动到分布式工程师站以进行编辑时，还必须传送主数

据库，以便向所有项目工程师提供一个相同的数据库。       

主数据库有助于确保重复使用所定义的类型版本。主数据库与多项目一起自动归档。

主数据库内容

项目中使用的对象或为项目进行过专门修改的对象都存储在主数据库中。举例来说，这包

括下列元素：

● 块类型

● SFC 类型

● 过程变量类型

● 模型

● OS 画面
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● OS 报表

● 共享声明（枚举、测量单位、设备属性）

此外，主数据库中还可包括下列对象。

● PCS 7 高级过程库 中的对象

● 来自供应商库的对象

● 用户创建的对象

下图给出了示例。
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更多信息

● “如何创建主数据库 (页 311)”部分。

7.4.6 使用项目特定的目录配置文件

项目特定的目录规约

根据在主数据库中为特定项目存储的过程变量类型、模型等，可为硬件配置创建项目特定

的目录规约。这意味着所有项目编辑器都使用相同的硬件组件。如果将那些存在于多项目

中的项目移动到分布式工程师站以进行编辑，则还必须移动项目特定的目录规约。    
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“PCS 7_Vx.y”硬件目录

每个项目特定的目录规约的基础是 HW Config 中的硬件目录“PCS 7_Vx.y”，其中包括已

准许用于 PCS 7 的所有模块和组件的最新版本。

说明

有关准许在 PCS 7 中使用的模块及其版本的更多信息，请参见产品概述《过程控制系统 
PCS 7；已发布模块》(Process Control System PCS 7; Released Modules)。

在 HW Config 中创建一个新的目录规约，然后通过拖放的方式将所需组件从“PCS 7_Vx.y”
硬件目录移动到新的目录规约中。可以为该目录规约指定任意名称。

更多信息

● “定义项目特定的目录规约 (页 344)”部分。
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7.5 导入及重用工厂数据

导入/导出接口

所有的 PCS 7 工程组态系统的基本应用程序都有导入/导出接口。使用导入/导出接口具有

以下优势：             

● 工厂规划数据可以与控制系统工程组态数据同步。这就是控制系统工程组态和工厂工程

组态可以同时独立编辑的方法。

● 来自工程组态系统的数据可作为模板导出，在外部程序（例如 MS Excel）中有效地复

制和修改，然后导回工程组态系统中。这样就可以优化重复或类似工厂信息的组态。

说明

有关 PCS 7 与 COMOS 之间数据交换的信息，请参见“数据交换概述 (页 621)”部分。

导入/导出工厂数据

内容 导入/导出 位置 其它参考部分 

过程变量列表或图表 例如，可将来自更高级别 CAD/CAE 领域的已组

态工厂数据（如过程变量列表或图表）导入到工

程组态系统，并用于几乎全自动地生成过程变

量。

可将通过 PCS 7 进行优化的参数导回到 CAD/
CAE 领域。

导入/导出助

手 (IEA, 
Import/
Export 
Assistant)

如何使用 MS Excel/
Access 交换数据 
(页 641) 

硬件配置 可从 HW Config 导出硬件配置，在外部根据现

有的工厂信息继续对其进行编辑。然后将它们导

回到 HW Config 中。 

也可以导出/导入输入和输出的符号名。 

HW Config 导入/导出硬件配置 
(页 645) 

工厂画面 可将现有的工厂画面导入图形编辑器，用以创

建 OS 画面（例如，作为背景画面）。

这适用于那些不包含任何动态画面元素的画面。

图形编辑器 组态手册《过程控制

系统 PCS 7；操作站》

项目数据 可将已组态的控制系统项目数据从工程组态系统

中导出，以与 CAD/CAE 领域中的规划数据同

步。 

导出文件的格式：*.xml

SIMATIC 
Manager

为高效率的工程规划

对象/功能 (页 142) 
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用于导入/导出工厂数据的数据格式

有关导入和导出工厂数据的更多信息，请参见“可导入数据和数据格式 (页 143)”部分。

更多导入/导出功能

内容 导入/导出 位置 其它参考部分 

过程变量类型（过

程变量）

借助导入/导出助手，可基于一个过程变量类型以

及一个包含过程变量信息的外部可调整导入文件

来创建/更新大量过程变量。

导入/导出助

手 (IEA, 
Import/
Export 
Assistant)

通过过程变量类型创

建过程变量（多项

目） (页 509) 

模型（副本） 借助导入/导出助手，可基于模型及包含参数和互

连信息的外部可调整导入文件创建/更新大量的模

型副本。

导入/导出助

手 (IEA, 
Import/
Export 
Assistant)

如何创建模型副本 
(页 559) 

I/O 和消息 与操作员相关、在 PCS 7 中创建的文本可在 
PCS 7 外部进行编译（例如，针对工厂操作员，

并以他们的母语进行显示的那些文本）。将与操

作员相关的文本导出到文本文件。在 ASCII 编辑

器或 MS Excel 中编译这些文本，然后再将其导

回 PCS 7。

格式：*.tx" 或 *.csv

更改语言时，可选择在导入到项目期间所指定的

任意语言。 
● 更改“标题和注释”(Title and Comments) 的语

言 - > 仅针对选定对象

● 更改“显示文本”(Display texts) 的语言 - > 针
对整个项目。

SIMATIC 
Manager

如何导入/导出块、I/
O 和消息 (页 322) 
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内容 导入/导出 位置 其它参考部分 

导入/导出整个表格

内容

可导出过程对象视图中参数、信号和消息的所有

可编辑字段。之后，可在外部编辑它们（例如，

更改参数和互连），然后再次将其导入。

格式：*.csv

这意味着可在外部为现有工厂部件或复制的单元

提供更改的参数值和互连，而无需使用导入/导出

助手。

SIMATIC 
Manager

如何导入/导出块、I/
O 和消息 (页 322) 

导入/导出画面对象 在 OS 组态期间，可将 OS 画面对象的相关信息

（例如，对象类型或互连信息）导出到 CSV 文件

中。 

之后，可在 MS Excel 中外部编辑此信息（例如，

更改变量互连），然后将其导回 WinCC 中。

WinCC 项目

管理器：图

形对象更新

向导

组态手册《过程控制

系统 PCS 7；操作站》
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7.6 硬件与软件之间的自由分配

分离硬件和软件组态

可基于信号的符号名在硬件和软件组态之间建立连接。  

● 在规划阶段，于 HW Config 中组态硬件结构并且为模块的输入输出和现场设备集分配

符号名称。

● 在软件组态期间为过程变量创建 CFC/SFC。通过这些符号名称实现过程与输入和输出

之间的互连。    

编译期间，根据相同的符号名进行硬件和软件分配。各项目工程师不必担心系统的内部地

址（绝对地址，如 O 4.0、I 1.1）。 

这样，就分离了硬件和软件的组态。可在定义硬件之前创建软件，反之亦然。只需在编译

和下载之前的时刻，将 CFC/SFC 分配给正确的自动化系统即可。

符号表

如果已将符号名分配给了绝对地址，则 PCS 7 可以将符号名编译成必需的绝对地址。此过

程在 PCS 7 的硬件配置期间或导入硬件配置时执行。

示例

例如，可以将符号名 MOTOR_751_ON 分配给符号表中的操作数 A 4.0 并使用 
MOTOR_751_ON 作为源语句中的地址。 

有关 PCS 7 的建议

在 PCS 7 项目中使用符号名。利用符号名可以获得比绝对地址更为直观的描述。通过组合

使用简短的符号名和详细注释，不仅可以创建一个有效的程序，还可以提供良好的程序文

档。 

符号名还可以方便您指出程序的元素是否与 PCS 7 工厂的组件匹配。

更多信息

● “如何给输入及输出地址分配符号 (页 353)”部分。
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7.7 从工厂层级获得画面层级和 OS 区域

从工厂层级获得画面层级

OS 上供操作员使用的 OS 画面层级完全可从工厂层级的组态数据中获得。

这涉及到根据 PCS 7 工厂的组态将画面（其目的是为操作员显示过程）插入到工厂层级 
(PH) 中。可在 PH 中的每个层级文件夹的每个 OS 中均插入一个画面。 

在工厂层次结构中插入画面用于创建画面层级。编译 OS 后，画面树管理器就具有了相同

的层级，以用于进行进一步编辑。 

建议：创建 PH 时，考虑所需的画面层级。

要求

说明

使用“OS 编译”功能时，如果在 SIMATIC Manager 中的常规 PH 设置中激活了选项“从

工厂层级中获得画面层级”(Derive picture hierarchy from the plant hierarchy)，则仅将工厂

层级的结构复制到画面树管理器中。

在画面树管理器中修改了画面层级后，如果不希望在下次编译 OS 时覆盖此画面层级，则

禁用此选项。

从 PH 获得 OS 区域

可对 OS 区域进行定义，以反映在工厂层级 (PH) 中所创建的工厂结构。例如，对于大型工

厂，这意味着可将操作员分配到工厂的特定部分。在这种情况下，工厂操作员只能在对其

具有用户权限的过程模式下查看和操作区域。仅显示与此区域相关的消息。

通常，PH 中的单元与 OS 区域相对应。 

在常规 PH 设置中，可以决定应将哪个 PH 层级看作 OS 区域。为此级别中的每个层级文

件夹定义一个区域标识符。区域标识符的默认设置与 PH 中的层级文件夹名称相对应。

如果将某个区域标识符分配给层级文件夹，则此区域标识符也适用于所有较低级别的层级

文件夹和对象。

编译 OS 时，OS 区域被传送到画面树管理器中以进行进一步编辑。层级会始终显示在画

面树管理器中，并以定义为 OS 区域的层级开始。

建议：构建 PH 时考虑所需的 OS 区域，并指定区域标识符。
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更多信息

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

● PH、IEA 和 PO 的在线帮助
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7.8 生成块图标和操作员文本

7.8.1 生成块图标

生成块图标

在过程模式下，块图标用于对工厂或单元进行操作员监控。对于 CFC 中可监控的块实例而

言，块图标是必需的。     

可以指定是否为 PCS 7 OS 上的每个过程画面创建块图标，以及是否在此过程画面中存储

块图标。

在编译 OS 之前可以在工厂视图中或过程对象视图中定义以下设置：

● 为每个过程画面选择“从工厂层级获得块图标”(Derive block icons from the plant 
hierarchy) 选项。

● 如果选择“多项目”、“项目”或“层级文件夹”对象，然后执行“创建/更新块图标”
(Create/Update Block Icons) 功能，则块图标会依据工厂层级自动插入到过程画面中并

链接到对应的过程变量。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》

7.8.2 生成操作员文本

生成单位和操作员文本

显示以下块信息的面板用于在过程模式中向操作员显示过程。   

● 测量值

● 操作限制

● 单位

● 操作员文本

这些文本已包括在用于 CFC 的块类型中。

单位和操作员文本只采用为块类型存储的语言进行显示，而与当前的语言选择无关。
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所提供的库（例如，PCS 7 高级过程库）中的块类型的单位和操作员文本只存在英语版

本。 

可以在 CFC 的块类型或块实例的属性中更改单位和操作员文本（例如，将它们翻译成另一

种语言）。 

更多信息

● “如何导入/导出 I/O 和消息 (页 322)”部分

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

工程组态的基本概念

7.8 生成块图标和操作员文本

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 215



7.9 PCS 7 消息系统

7.9.1 消息系统的基本概念

PCS 7 消息系统

PCS 7 消息系统通知操作员在过程和控制工艺中发生的事件。在 PCS 7 OS（OS 客户端）

上以信号列表的形式和通过组显示分别将事件显示给操作员。操作员操作包含在另一个列

表中。   

消息类别

下表介绍了过程控制系统中的消息类别：

消息类别 描述

过程消息 过程消息指示自动化过程中发生的过程事件，例如测量值超出

限值事件和操作消息。

● 过程消息是为各块预定义的，因此无需组态。不过，必要时

可通过以下方法更改消息文本和消息优先级：在 CFC 块的

对象属性中更改、集中在过程对象列表中更改或通过导入和

导出进行更改。

● 操作消息是过程消息的一个子集。它们指示用于评估工艺变

量的过程变量，例如耗用时间计数器。

注：

在使用“用户可组态消息类别”功能时，请遵循

“用户可组态消息类别 (页 221)”部分中的信息。

过程控制消息 I&C 系统消息在 SIMATIC PCS 7 于自身的组件中（AS、OS 
等）检测到错误并发出信号时生成。此类错误包括组件故障直

至所连接 I/O 模块的断线信号。 

过程控制消息由 PCS 7 中的驱动程序块生成，且无需组态。

运行消息 运行消息在操作员控制过程变量（例如更改控制器的运行模式）

时生成。在使用 PCS 7 库提供的面板时，会自动生成操作消

息。 

如果按照手册《过程控制系统 PCS 7；块编程指导》(Process 
Control System PCS 7; Programming Instructions for Blocks) 
中的说明对面板进行组态，则符合 PCS 7 标准的操作消息同样

可用于您的那些块。
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消息来源

根据组态的不同，消息可来源于控制系统中的不同位置。消息的时间戳受消息来源的影响。

下图举例说明了一个分布式的 I/O (ET 200M)。

图片说明

来自 AS (2) 或 ET 200...(3) 中的事件...作为单个的消息通过系统总线传送到 OS。该消息

与相应的时间戳一起传送。消息按时间顺序连同其发生的时间在 OS 的信号列表中显示。 

下表显示了消息来源位置和时间戳的分配。

来源位置 消息文本的组态 时间戳的分配 消息

操作站 (OS, 
Operator 
station)

WinCC 项目管理器

的“报警记录”编辑器

中

操作站中 过程控制消息来自链接

非 S7 系统的 OS

自动化

系统 (AS)
项目库的块类型中或 
CFC 的块类型中

自动化

系统中

过程和控制工艺消息来

自 SIMATIC 站

分布式 I/O
（如 ET 200M）

CFC 中的驱动程序块

的块实例中

在分布式 I/O 中，通过

接口模块（如果

激活了高精度时间戳）

工厂出现故障时，用于

初始值采集的选定事

件 

“报警循环”功能

来自在 OS 上可视化的工艺块中的过程和控制工艺消息具有“报警循环”功能。可使用此

功能直接从消息列表中为此过程变量选择面板。 
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帮助按钮

也可以为来自工艺块的消息组态帮助按钮。这可通过如下方式激活：

1. 打开 WinCC 项目管理器

2. 在快捷菜单中，选择“属性”(Properties)。将打开“项目属性”(Project Properties) 对话框。

3. 选择“选项”(Options) 选项卡。

4. 选择“运行时帮助可用”(Help available in Runtime) 

5. 单击“确定”(OK)

结果

在系统运行时，当单击“进入报警列表”(incoming alarm list) 按钮即可以看到帮助图标可

用。

7.9.2 组态消息

组态操作员站 (OS)

可以在“报警记录”（WinCC 项目管理器）中为操作员站组态新消息以及相应的消息文

本。还可以在其中指定触发该消息的事件（二进制值、整数值中的位等）。

自动化系统 (AS) 和分布式 I/O 的组态

在创建 CFC 时或在过程对象视图中为自动化系统 (AS) 和分布式 I/O 组态消息。 

在 CFC 中使用具有消息响应的块时，可通过默认设置预设具有关联消息级别的具体消息文

本。这些消息在发生相应的事件时进行传送。可按如下方式根据特定需要修改这些消息文

本及其属性：

● 块类型中的消息：

首先将所需的块复制到项目库中，然后在其中更改消息。

● 各个块实例中的消息：

在过程对象视图中或直接在 CFC 的块实例中更改消息。

建议：请在组态开始时创建主数据库。在组态开始时更改块类型的消息。如果已在项目中

创建了 CFC，请导入块类型。随后在所有实例（例外：已手动更改过的实例）中修改操作

员文本。
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更多信息

组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station) 中通过逐步说明详细介绍了消息组态。下面部分的内容概述了 PCS 7 提供的用于

组态便捷消息系统的各项功能。

7.9.3 消息组态的重要方面

消息组态的重要方面

在使用“用户可组态消息类别”功能时，请参见“用户可组态消息类别”部分中的信息。

下表概述了组态消息的最重要方面。       

方面 描述 可能的组态

消息文本 如果在 CFC 中使用了具有消息功能的块（例如，“定量给料 
[FB63]”块），则具有相关消息类别的特定消息文本会被预设为默认

设置。 

用户可根据具体需要修改这些消息文本及其属性：

● 显示设备的语言

● 修改块类型和块实

例的消息文本

辅助值 可以使用当前过程信息更新消息，例如，通过在消息文本的某些位

置插入关联值。消息块将分析该关联值并在消息文本的指定位置插

入相应的过程值。这需要将具有以下信息的块插入消息文本：@<关
联值的编号>[<element_type>]<Format_information>@

有关各个块实例的可能关联值，可参见 PCS 7 库的块在线帮助。

将关联值添加到块类型

和块实例的消息文本

中 

扩展的事件文

本

工厂操作员无法根据标准消息，例如“过高”，立即理解“过高”

的确切含义。

因此，用户可以向事件文本添加补充信息，例如“反应釜填充液

位”。块注释即用于此目的。 

通过给事件文本加前缀关键字 ($$BlockComment$$)，可将块注释复

制到消息的事件文本中。 

PCS 7 高级过程库的块中已准备了此类事件文本。只需为每个块实

例分别调整块注释。

● 扩展事件文本，以

在块类型和块实例

中包括块

注释

消息编号 编译 PCS 7 OS 期间，将在报警记录中自动给 ES 中组态的每条消

息分配一个唯一的消息号。

这些消息号中预留了 8 位范围用于创建对相应 AS 的唯一交叉引用。

这是为了确保可以通过一个 OS 监视多个 AS，以及将消息分配给正

确的 AS。 

● 不需要组态
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方面 描述 可能的组态

分配消息号 使用 PCS 7 向导创建项目时，将定义消息号范围（随后可以更改）。

可选择下列过程：

● 分配在整个 CPU 中唯一的消息号（分配消息优先级的必要条件）

● 分配在整个项目中唯一的消息号

使用选项“分配在整个 CPU 中唯一的消息号”(Assigning message 
numbers which are unique for the entire CPU)，可按原样复制程序，

而无需更改消息号。

指定消息号

概念 

消息优先级 默认情况下，最新消息总是显示在消息列表的第一行。可更改该设

置。 

可为每条消息分配优先级（0 = 最低，16 = 最高）。该分配的目的是

为了确保总览区中的消息行总是显示满足下列条件的消息：

● 尚未确认

● 最高优先级

此外，工厂操作员可在过程模式下根据优先级按升序或降序对消息

列表排序。 

注：仅在将消息号范围定义为“面向 CPU 唯一”(CPU-oriented 
unique) 时，才能指定消息优先级。

指定块类型和块实例的

消息优先级

消息文本中的

错误位置

出现错误时，分布式 I/O 的驱动程序块会向 OS 发送一条消息，其中

包含下列有关错误发生位置的信息：

● 模块所连接的 DP 主站系统的编号

● 安装模块的机架或站号

● 机架上的模块插槽号

● 文本库 MOD_D1_TXT 或 MOD_D2_TXT 中的消息文本

通过分配插槽和通道号可指定触发消息的模块的通道。

消息文本组态：

直接将消息文本输入放在 CFC 中的 IM_DRV 块中。 

有关 HART 和 PA 现场设备诊断事件的消息文本（来源）被预组态

为“现场设备”。建议您根据组态要求修改预组态的消息文本。 

● 驱动程序块的概念

更多信息

● “如何在 SFC 中组态消息 (页 542)”部分

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

工程组态的基本概念

7.9 PCS 7 消息系统

工程组态系统 (V9.0 SP1)
220 配置手册, 12/2017, A5E39221328-AC



7.9.4 组态 PCS 7 消息系统

7.9.4.1 用户可组态消息类别

消息系统

从 PCS 7 V8.0 SP1 起，可以影响过程控制期间块上越限消息在组显示和消息列表中的显

示。可使用“用户可组态消息类别”功能实现此目的。 

该功能取消了块中越限的固定分配以及其在组显示和消息列表中的外观。 

此外，为每个消息类别分配其自身的重要性。通过重要性指定在组显示和消息列表中显示

消息的顺序。

对于多项目和其中包含的全部项目，可使用经典消息系统或具有“用户可组态消息类别”

功能的消息系统。

使用此功能要求为所有自动化系统设置 CPU 范围内唯一的消息号分配。

与经典消息系统相比，其不同之处是在 SIMATIC Manager 中组态消息类别。所有其它与

消息系统相关的组态仍保持不变。

说明

在使用“用户可组态消息类别”功能时，需用文档记录消息类别组态，

并让操作员可使用此文档。

消息类别

使用“用户可组态消息类别”功能时，最多可组态 6 个消息类别。

下表列出了二者之间的差异： 

经典消息系统 使用“用户可组态消息类别” 
功能的消息系统

消息类别 消息类型 消息类别

报警

 

报警上限 报警上限

报警下限 报警下限

警告

 

警告上限 警告上限

警告下限 警告下限
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经典消息系统 使用“用户可组态消息类别” 
功能的消息系统

消息类别 消息类型 消息类别

容差

 

容差上限 容差上限

容差下限 容差下限

过程控制期间组显示中的外观

只能给每个消息类别分配一个按钮。仅限分配前四个按钮。

下表通过示例给出了组显示外观：

经典消息系统 使用“用户可组态消息类别”功能的消息系

统

过程控制期间扩展状态显示中的外观

扩展状态显示使用在“组态消息类别”(Configure message classes) 选项卡中设置的重要

性。

扩展过程控制模拟显示中的外观

扩展模拟显示使用在“组态消息类别”(Configure message classes) 选项卡中设置的颜色和

重要性来显示模拟值。

过程控制期间块图标和面板中的外观

有关此主题的详细信息，请参见《过程控制系统 PCS 7；高级过程库》手册。
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过程控制期间消息列表中的外观

下表给出了有关消息列表中外观的不同之处：

消息列表

 
经典消息系统 使用“用户可组态消息类别”

功能的消息系统

进入消息列表 消息列表中消息的顺序取决

于消息产生的时间（日期/时
间）。

最新消息可显示在顶部或底

部，具体取决于 OS 项目编

辑器中 WinCC 项目的“消息

显示”(Message display) 选
项卡的“消息页面的排序”
(Sorting of the message 
pages) 区域中的设置。

消息列表中消息的顺序首先取

决于消息的重要性，其次取决

于消息产生的时间（日期/时
间）。

最重要的消息和最新消息可显

示在顶部或底部，具体取决

于 OS 项目编辑器中 WinCC 
项目的“消息显示”(Message 
display) 选项卡的“消息页面

的排序”(Sorting of the 
message pages) 区域中的设

置。

已确认消息列表

离开消息列表

待隐藏消息列表

隐藏消息列表

使用“用户可组态消息类别”功能时，在消息系统的消息列表中不显示“优先级”(Priority) 
列。

过程控制总览区单行消息行中的外观

下表给出了外观的不同之处：

经典消息系统 使用“用户可组态消息类别”功能的消息系

统

基于消息的优先级显示消息。 基于消息的重要性显示消息。

报警器组态

要从使用使用“经典消息系统”的 PCS 7 项目转为使用“用户可组态消息类别”功能的消

息系统，必须再次组态报警器。

使用“用户已组态消息类别”功能时组态消息系统 

可在“组态 PCS 7 消息系统”(Configure PCS 7 message system) 对话框中激活此功能。
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要打开此对话框，可在 SIMATIC Manager 中选择菜单命令“选项 > PCS 7 消息系统 > 组
态...”(Options > PCS 7 message system > Configure...)。

仅可在此对话框中组态消息类别。

步骤 说明 位置

1 组态消息类别 “组态 PCS 7 消息系统”(Configure PCS 7 
message system) 对话框

有关更多信息，请参见下一小节。
2 将消息类别分配给组显示中的

按钮

3 将所需消息类别分配给块类型

或块实例的消息

在块类型或块实例上

在块类型上，在该块类型的消息对话框中分

配消息类别。

可在 CFC 中块的消息对话框中进行实例特

定的分配。

更多关于组态的信息，可参见相关对话框的在线帮助。

导入/导出 PCS 7 消息系统的组态数据

可以在“组态 PCS 7 消息系统”(Configure PCS 7 message system) 对话框中导入或导出

所做设置。  

为此，请在 SIMATIC Manager 的“选项 > PCS 7 消息系统”(Options > PCS 7 Message 
system) 中使用菜单命令“导入...”(Import...) 和“导出...”(Export...)。 

7.9.4.2 指定各列的消息颜色

消息窗口中列的外观

在过程控制消息列表中，可指定仅为某列显示的消息颜色。

在以下章节“如何组态 PCS 7 消息系统”中介绍了相关的组态信息。

 

7.9.4.3 如何组态 PCS 7 消息系统

简介

在“组态 PCS 7 消息系统”(Configure PCS 7 message system) 对话框中执行组态操作。

该组态适用于多项目中的全部项目。
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可以在“组态 PCS 7 消息系统”(Configure PCS 7 message system) 对话框中导入或导出

所做设置。有关此主题的更多信息，请参见“用户可组态消息类别 (页 221)”部分。 

要求

分配的消息号在整个 CPU 中唯一。

步骤

1. 打开 SIMATIC Manager。

2. 打开多项目/项目。

3. 选择多项目。

4. 选择菜单命令“选项 > 组态 PCS 7 消息系统 > 组态...”(Options > PCS 7 message system 
> Configure...)。
将显示“组态 PCS 7 消息系统”(Configure PCS 7 message system)。

5. 在以下选项卡中组态消息类别、组显示、显示颜色、消息块和消息列表：

– “组态消息类别”(Configure message classes)
– “组显示分配”(Group display assignment)
– “在消息窗口中显示列”(Display of the columns in the message windows)
– “显示消息块”(Display of the message blocks)
– “组态消息列表”(Configure message lists)

6. 编译 OS。

7. 下载所有 OS 服务器和 OS 客户端。

说明

请勿在报警记录编辑器中更改 WinCC 项目。

根据块图标不同数量，启用基于优先级的报警可能影响在 OS 客户端上更改过程画面的性

能。

更多信息

更多关于组态的信息，可参见相关对话框的在线帮助。
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7.9.5 在过程模式下自动显示和隐藏消息

简介

可在过程模式下针对以下选项使用“自动显示和隐藏消息”功能：       

● 针对过程状态，例如启动、关闭。

在 CFC 中组态“STRep”块时发生。 
具体组态将在下文介绍。 

● 针对系统图表中具有消息功能的块的消息：

在将数字系统图表连接到工厂层级时发生。

更多相关信息，请参见“如何组态系统图表中消息的自动显示和隐藏 (页 304)”部分。

在过程模式下自动显示/隐藏消息

在以下情况下（过程状态）使用“自动显示和隐藏消息”功能，例如：

● 希望在启动部分工厂时抑制消息（消息混乱）。

● 希望自动隐藏在关闭部分工厂时生成的消息。

● 希望自动隐藏来自未运行的部分工厂的消息。

“STRep”块的组态

使用 PCS 7 高级过程库中的“STRep”块来实现此功能。“STRep”块用于隐藏/显示过程状

态（例如启动、关闭等）的消息。请将“STRep”块的状态输入互连到确定过程状态的逻

辑。由此“STRep”控制的所有块都组合在指定了标识符的组中。这意味着可以在需要时使

用多个“STRep”块。

过程状态传送到 OS 后，通过对过程状态消息的预组态分配，在 OS 中受到抑制。 

过程模式中的自动显示和隐藏不会影响自动化系统中消息的生成。

组态步骤概述

步骤 内容

1 ● 将“STRep”块插入到 CFC 中
● 将过程状态（例如，工厂部分启动）的控制信号互连到“STRep”块的状态输入（state1 到 

state32）
状态输入表示用于显示和隐藏消息的状态。

更多相关信息，请参见“如何在过程模式下组态消息的自动显示和隐藏 (页 497)”部分。

2 创建共享声明
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步骤 内容

3 在过程对象视图中为组分配块。

4 将来自组中块的消息（要隐藏的消息）分配给过程对象视图中的状态。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》

7.9.6 确认概念和确认触发报告 (ATR)

确认概念

PCS 7 使用集中确认概念。在 OS 上确认一条消息时，该确认会传送到 AS 中的报告块。

之后再从报告块中将其作为一条确认消息集中转发给即将获得该消息的所有操作员站。

确认触发报告 (ATR)

如果触发消息的事件连续快速地改变其状态，则可能引发消息蜂拥而至。这就不再能够完

全确保设备状态的总览。

通过组态“确认触发报告 (ATR)”功能，可以抑制重复报告“波动”信号，直到工厂操作

员确认它们为止。当未经确认的消息保留在 OS 中时，在 AS 中会抑制重新发送此消息的

信号变化。

使用 ATR 可达到以下目的：

● 未决消息仍可进行管理。

● 通信负载减少。

组态确认触发报告 (ATR)

可在 CPU 的对象属性中激活指定 AS 的确认触发报告 (ATR)。

说明

对多项目的所有自动化系统均组态同一个消息方法（标准消息过程或确认触发报告）。 
请勿在多项目中混合使用这两种方法。否则，操作员将无法识别生成消息的消息过程。这

可能导致得出错误的结论。
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更多信息

● “如何激活确认触发报告 (ATR) (页 368)”部分

7.9.7 高精度时间戳

简介

在工厂局部出现故障并随后出现消息混乱后进行初始值采集期间，常常必须读入高精度计

时的事件：

即使存在大量消息，也必须要明确识别导致单元故障的消息（初始值）。  

高精度时间戳

高精度时间戳可使进入事件的时间戳非常精确：如果不同 PROFINET IO 或 PROFIBUS-
DP 链上两个站中的两个传感器分别连接到不同的自动化系统并同时被激活，则这两个信

号变化的时间戳相差不会超过 1 ms、10 ms 或 30 ms（取决于所用硬件）。前提是假定连

接到工厂总线的所有设备实现了时间同步。

更多信息

● “组态高精度时间戳硬件  (页 367)”部分

● 功能手册《过程控制系统 PCS 7；高精度时间戳》(Process Control System PCS 7; 
High-Precision Time Stamping)

● 功能手册《过程控制系统 PCS 7；使用 ET 200SP HA 添加高精度时间戳》(Process 
Control System PCS 7; High-Precision Time Stamping by use of ET 200SP HA)
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7.9.8 发送声学/光学信号

“报警器”功能

除可视化显示消息和报警之外，对于某些消息而言，可能还需要发送声学或光学信令。在 
PCS 7 OS 中，提供了“报警器”功能来达到此目的，您会有如下选择：

● 可以在 OS 站中将信号模块连接到 PCI 接口。对于不同的消息类别，最多可以控制四个

不同的外部传感器，如四个报警器或四个不同的指示灯。使用确认输入可以禁用一个设

备（例如报警器）。只要应用了分配的控制信号（例如，激活了消息类别的信号），其

它三个设备就会仍保持激活。连接一个信号模块还允许使用附加的设备状态监视（监视

狗功能）。

● 可使用安装在 OS 中的标准声卡。声音信号由 WAV 文件产生，该文件会持续播放到消

息被确认为止。如果同时出现多个未决报警，则将同时播放所有 WAV 文件。声卡不能

用于执行设备状态监视。

可一起操作信号模块和声卡。 

更多信息 

● 有关信号模块的功能和安装的详细信息，可参考手册《过程控制系统 PCS 7；WinCC 
基本过程控制》(Process Control System PCS 7; WinCC Basic Process Control)。

● 有关组态报警器的详细信息，可参考组态手册《过程控制系统 PCS 7 操作员站》(Process 
Control System PCS 7 Operator Station)。
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PCS 7 工程组态系统的组态 8
8.1 中央起始点 - SIMATIC Manager

SIMATIC Manager

SIMATIC Manager 是所有工程任务的中央起始点。PCS 7 项目的管理、归档和记录都在

这里进行。工程系统的所有应用都可通过 SIMATIC Manager 进行访问。如果 ES、OS、
BATCH、Route Control 与 AS 之间存在连接，则可从 SIMATIC Manager 将组态数据传送

到目标系统，然后进行在线测试。   

SIMATIC Manager 中的视图

SIMATIC Manager 提供以下三种视图，可视当前任务的具体情况对其进行优化编辑。 

说明

这些视图的一个主要特性是它们所包含的对象只存在一次。

视图 用途

组件视图 (页 234) 在组件视图中，可组织多项目中的项目、创建硬件组件以及启动自动

化系统、总线组件、过程 I/O 和 PC 站的硬件配置。

工厂视图 (页 237) 工厂视图功能用于根据工艺特点安排和描绘工厂。在工厂视图中可按

层级安排自动化功能和操作员监控功能等。过程模式下 PCS 7 OS 的
结构即源自此工厂层级（例如，OS 区域、画面层级）。

过程对象视图 
(页 239) 

过程对象视图提供了过程变量的通用视图。它显示了与过程变量/对象

（例如，参数、信号和消息）各方面的表格视图相结合的工厂层级。

在过程对象视图中，整个项目的所有基本控制数据均可显示在面向过

程控制的视图中。多项目会收集所有项目中包含的数据。

从一个视图切换到另一个视图

使用 SIMATIC Manager 菜单命令“视图”(View) >“[视图名称]”([Name of view]) 在这些视图

之间切换。
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PCS 7 项目的结构

与带有文件夹和文件显示的 Windows 资源管理器的目录结构类似，PCS 7 多项目也是组

织成项目、文件夹和对象的形式。多项目位于对象层级的顶层，表示自动化解决方案的所

有数据和程序。文件夹可包含对象，而对象又可包含其它文件夹和对象。 

下图中的示例在组件和工厂视图中显示多项目最重要的文件夹：
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面向对象的工作

在 SIMATIC Manager 中，不同对象类型直接链接到处理它们所需要使用的应用程序。关

联的应用程序也会在打开对象时启动。 
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8.2 组件视图

组件视图

组件视图用于管理多项目和它包含的项目。此外，还可将其用于执行以下功能：               

● 创建硬件组件

● 设置硬件配置

● 设置和测试 AS 组态

● 开始组态 OS 或维护站

● 设置 BATCH 组态

● 启动 Route Control 组态

● 运行项目间功能

多项目工程组态

使用组件视图可在多项目中执行以下功能：

● 对多项目进行工艺性拆分，以进行分散编辑

● 完成分散编辑后将项目合并回多项目

● 完成项目同步后运行项目间功能

硬件配置

在组件视图中工作时，可组态自动化系统硬件、总线组件和过程 I/O。在组件视图中，在项

目下创建以下对象：

● SIMATIC S7-400 站 (AS)

● SIMATIC PC 站，例如工程师站 (ES)。

选择站，然后双击“硬件”(Hardware) 以访问 HW Config 应用程序。使用 HW Config 将附

加硬件组件（例如 CP、ET 200M）或软件应用程序（服务器或客户端）添加到站中，并

设置硬件组件参数。 

说明

完成硬件配置后，将主要在工厂视图和过程对象视图中工作。
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AS 组态

组件视图中的对象根据其重要性识别为不同的组件（例如，S7 程序、站、OS、PLC/AS 
(CPU)、图表文件夹）。

在组件视图中，通过将块类型和 SFC 类型从主数据库复制到使用它们的 AS 的图表文件夹

来对它们进行组织。之后才可在目录中使用它们来进行 CFC/SFC 组态。

操作站组态

启动组件视图后，就可以开始针对过程模式组态操作站。使用上下文菜单命令“打开对象”
(Open object) 选择 OS 后，将启动 WinCC 项目管理器。 

有关详细信息，请参考组态手册《过程控制系统 PCS 7；操作站》(Process Control System 
PCS 7; Operator station)。

维护站组态

从组件视图开始组态维护站，这与操作站的组态类似。

更多信息，请参见《过程控制系统 PCS 7；维护站》(Process Control System PCS 7; 
Maintenance Station) 手册。

BATCH 组态

从组件视图中启动批生产控制组态。通过菜单命令“选项”(Options) > SIMATIC BATCH 打
开 BATCH 组态对话框。

有关详细信息，请参见组态手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process 
Control System PCS 7; SIMATIC BATCH)。

Route Control 组态

从组件视图启动 Route Control 的组态。使用选项 > SIMATIC Route Control (Options > 
SIMATIC Route Control) 菜单命令打开 Route Control 组态对话框。

有关此主题的更多信息，可参见组态手册《过程控制系统 PCS 7；SIMATIC Route 
Control》(Process Control System PCS 7; SIMATIC Route Control)。
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其它可用功能

组件视图 重要功能选项

● 使用 PCS 7 向导创建新的多项目 (页 256)
● 通过添加新（空）项目扩展多项目 (页 258)
● 使用 PCS 7 向导通过预组态工作站扩展项目 

(页 261)
● 插入 SIMATIC 站 (页 270)
● 插入操作站或维护站 (页 274)
● 插入 BATCH 站 (页 277)
● 插入 Route Control 工作站 (页 279)
● 插入工程师站 (页 273)
● 分配多项目进行分散编辑（多项目工程组

态） (页 334)
● 在分散编辑后合并项目（多项目工程组态） 

(页 615)
● 运行项目间功能

● 编译 - 下载

离线或在线？

可在以下两种状态间切换组件视图：

组件视图 > 离线 (Component 
View > Offline)

此项目结构视图显示工程师站上的项目数据。创建新项目时离线视图被设

置为默认视图。在离线视图中，将为 S7 程序（离线）显示工程师站上的

完整数据。

组件视图 > 在线(Component 
View > Online)

此项目结构视图显示目标系统 (CPU) 上的项目数据。在在线视图中，将

为 S7 程序（在线）显示目标系统上的数据。可使用此视图访问目标系统。
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8.3 工厂视图

工厂层级

在工厂视图中，可以工艺视角建立项目结构。在此过程中，可以按层级结构将自动化、操

作员控制和监视功能组织到工厂、单元或功能等层级中。根据相关层级文件夹的工艺意义

为其命名。将以下内容组织成层级文件夹：     

● AS 的 CFC 和 SFC

● OS 的画面和报表

● 附加文档，如单元描述、过程变量表或规划文档等（采用 Word 或 Excel 等格式）

所得到的项目结构即为工厂层级。

其它方面

请注意工厂视图的以下几个方面：

● 工艺对象（工厂、单元、功能……）可作为单一实体（例如，复制时）进行处理。

● 工艺对象可用于在独立于固定硬件分配的情况下工作。

● OS 区域和 OS 的画面层级源自工厂层级。

● 工厂层级是面向工厂的过程对象识别的基础。层级路径构成了工厂代号（高层代号 
HID）。可使用它来指定组成命名方案的文件夹。

● 可在工厂视图中插入和定位过程画面。过程画面中所用块的块图标可以从工厂层级自动

生成。

主数据库

主数据库包含为在多项目的单个项目中使用而创建的项目主数据，例如： 

● 块类型

● SFC 类型

● 过程变量类型

● 模型

● OS 画面

● OS 报表

● 附加文档
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其它可用功能

工厂视图 重要功能选项

工厂层级

● PH 的设置和属性 (页 288) 
● 插入附加层级文件夹 (页 292) 
● 在层级文件夹中插入对象 (页 293) 
● 在 PH 中的复制和移动规则 (页 294) 
● 检查 PH 的一致性 (页 299) 
● 多项目中的附加 PH 功能 (页 300) 
● 指定 AS/OS 分配 (页 295) 
主数据库：

● 创建主数据库 (页 311) 
● 将库对象复制到主数据库 (页 313) 
● 使用过程变量类型 (页 327) 
● 使用模型 (页 329) 

AS-OS 分配

在每个层级文件夹的工厂视图中，必须为每个 OS 分配一个 AS。这种 AS-OS 分配会在组

件视图中产生以下结果：

● 工厂视图中插入的所有 CFC 和 SFC 均存储在已分配 AS 的图表文件夹中。

● 工厂视图中插入的所有画面和报表都存储在已分配 OS 的文件夹中。
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8.4 过程对象视图

过程对象视图

需要过程变量和 CFC 的详细信息，并想要编辑它们的属性及各个方面时，可使用过程对象

视图。在要为大量对象分配相同的参数、注释或互连时，使用过程对象视图较为理想。         

过程对象视图的优点

与工厂视图相比，过程对象视图的优点在于可编辑对象的所有可修改属性。可编辑的所有

方面均一致，并以实用的表单呈现给用户。 

而对于在过程对象视图中不能直接编辑的内容（如模块参数分配和画面内容），可在跳转

到 CFC、SFC、HW Config 或 WinCC 项目管理器后进行编辑。

过程对象视图的上下文菜单包含可用于撤消或重复所做更改的功能。

组态

过程对象视图的左侧显示工厂层级（树形结构）。其右侧显示列有底层对象及其属性的表

（内容窗口）。 

树形结构显示与工厂视图中相同的对象。此外，过程对象视图的树形结构还显示 CFC、

SFC、OS 画面、OS 报表以及附加文档。 

过程对象视图 重要功能选项： 

 “编辑大量数据 (页 563)”部分
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显示的过程对象的属性

内容窗口中显示按以下方面组织的对象的属性。

选项卡 用途

常规 (General) 其中显示树形结构中当前所选工厂单元的所有底层过程对象（过程变量、CFC、SFC、

OS 画面、OS 报表或附加文档）以及这些对象的常规信息。

图表 在此处，可以看见多项目中包含的所有图表，包括没有 PH 分配的图表和超出项目边

界的图表在内。除 CFC 图表外，该列表还包含 SFC 图表和 SFC 类型。表格中不会

显示 SFC 类型的 PH 分配。当选择多项目、项目或 PH 文件夹时，可以选择“图表”
(Charts) 选项卡。

块 (Blocks) 其中显示树形结构中当前所选工厂单元的所有从属 CFC 中块的块属性。在此处，SFC 
实例也会被标识为块。

参数 其中显示“常规”(General) 选项卡中显示的过程变量和 CFC 的所有 I/O 点，这些过

程变量和 CFC 已明确选定为要在过程对象视图中进行编辑 (S7_edit = para)。

信号 (Signals) 其中显示“常规”(General) 选项卡中显示的过程变量和 CFC 的所有 I/O 点，这些过

程变量和 CFC 已明确选定为要在过程对象视图中进行编辑 (S7_edit = signal)。

消息 (Messages) 其中显示“常规”(General) 选项卡中显示的所有过程变量、CFC 和 SFC 的相应消息。

画面对象 (Picture 
objects)

其中显示 WinCC 中与“常规”(General) 选项卡中显示的过程变量和 CFC 对应的所有

画面链接。

归档变量 (Archive 
tags)

其中显示与“常规”(General) 选项卡上显示的所有过程变量、CFC 和 SFC 对应的现

有已互连 WinCC 归档变量及其属性。 

将显示与 PCS 7 相关的属性（变量记录中定义的所有属性的子集）。

层级文件夹 
(Hierarchy folder)

其中显示树形结构中当前所选工厂单元的 PH 的层级文件夹（每个层级文件夹占一

行）。

设备属性 
(Equipment 
properties)

其中显示树形结构中所选项目的设备属性。

这些设备属性是在共享声明中已组态的设备属性类型的实例（每个设备属性占一

行）。类型发生改变时，在该实例中输入属性。

共享声明 (Shared 
declarations)

在此，可以编辑类型属性、枚举、测量单位以及多项目中包含的设备属性。
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创建附加工艺对象

在过程对象视图中，可以创建以下工艺对象并编辑这些对象的属性：

对象 用途

层级文件夹 
(Hierarchy folder)

通过在项目中添加对象（如工厂、单元和功能）来扩展工厂层级。

CFC/SFC 创建可随后通过相应的编辑器做进一步编辑的空 CFC 和 SFC。

附加文档 (Additional 
document)

创建空的附加文档或导入可用附加文档，例如 MS Excel 或 MS Word 格式文档（如

果安装了相关应用程序）。

画面 (Picture) 创建可随后通过图形编辑器做进一步编辑的空画面。

报告 (Report) 创建可随后通过页面布局编辑器做进一步编辑的空报表。

设备属性 
(Equipment 
properties)

创建单元的设备属性并更改它们的属性。

过程变量（来自库）

(Process tag (from 
library))

插入主数据库中过程变量类型目录中的过程变量。可将过程变量类型拖动到过程对象

视图或工厂视图的层级文件夹中。此操作会在该层级文件夹中创建过程变量。

访问保护 (Access 
protection)

激活访问保护功能以限制某些用户对所选项目的访问。

离线或在线？

可在以下两种状态间切换过程对象视图：

过程对象视图 > 离线 (Process 
object view > Offline)

此视图显示工程师站上的项目数据。创建新项目时离线视图被设置为默认

视图。在离线视图中，将为 S7 程序（离线）显示工程师站上的完整数据。

过程对象视图 > 在线 (Process 
object view > Online)

在测试模式（在线）下，“常规”(General)、“参数”(Parameters) 和“信

号”(Signals) 选项卡中会显示附加列，通过它们可在线测试和调试 CPU（目

标系统）上的过程变量和 CFC。 

更多信息

● “编辑大量数据 (页 563)”部分

● PH、IEA 和 PO 的在线帮助
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8.5 视图间的关系

视图间的关系

由于组件视图和工厂视图/过程对象视图代表相同对象的不同方面，因此某些功能将影响所

有视图中的对象：   

● “删除对象”(Deleting objects) 会将对象从这三个视图中删除。

● 在工厂视图/过程对象视图中创建新对象时，同时会在分配给组件视图中层级文件夹的 
AS/OS 中创建这些对象。

● 在组件视图中创建新对象对工厂视图/过程对象视图没有影响。

提示：如果存在工厂层级，则只应在工厂视图或过程对象视图中编辑对象。组件视图随后

只用于创建和编辑自动化系统和 PC 站（例如操作员站）。
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8.6 交叉视图功能及其使用方法

使用单元（工厂视图）

涉及工厂范围的工程期间可执行以下功能：

● 复制整个单元，包括 AS 的图表和 OS 的画面。

● 删除单元以及归属该单元的所有对象。

● 将单元移至其它设备（AS 和 OS）。

跨设备关系（PH、OS 和 AS）由 ES 进行管理。

在项目（组件视图）中复制 SIMATIC 站 (CPU)

复制 SIMATIC 站时，站的硬件属性将按原样进行复制。关联程序文件夹中的以下内容将得

到保留：

● 全局地址之间的所有互连

● 运行组之间的所有互连

● 图表之间的所有互连

工厂层级 (PH) 将得到保留。现在 PH 中将存在两份复制功能所涉及的全部图表（原始图表

及其另名副本）。

将 SIMATIC 站 (CPU) 从项目复制到项目（组件视图）

如果将 SIMATIC 站从一个项目复制到另一个项目，该站的硬件属性将按原样进行复制。关

联程序文件夹中的以下内容将得到保留：

● 全局地址之间的所有互连

● 运行组之间的所有互连

● 图表之间的所有互连

将为该站分配新名称。

如果也复制了站之间的相关子网，则跨项目边界复制的站之间的连接将得到保留并保持一

致。

与复制的站关联的工厂层级在目标项目中进行设置。如果源项目中的站有与 PH 的连接，

则目标项目中也会建立这些连接。请在组态 PH 时或在同名的目标项目中应用现有 PH 期
间使用这些功能。
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复制 S7 程序（组件视图）

在 SIMATIC Manager 中，可在复制某个项目内的整个 S7 程序或将该程序复制到另一项

目。复制程序文件夹时以下内容将得到保留：

● 全局地址之间的所有互连

● 运行组之间的所有互连

● 图表之间的所有互连
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8.7 PCS 7 应用程序及其使用方法

概述

PCS 7 包括以下应用程序和选件，可使用它们来组态 PCS 7 工厂：     

应用 用途

HW Config 组态硬件

硬件配置显示站或 PC 站的硬件结构。使用 HW Config，可根据站的

实际结构指定机架及其插槽分配；可组态各种模块并为模块分配参数，

以及组态分布式 I/O。

NetPro 组态网络和连接

使用 NetPro，可以极其简单、明晰的方式为工厂执行组态、分配参数

以及记录网络组态。

CFC 组态连续过程

CFC（Continuous Function Chart，连续功能图）是一个可与 STEP 
7 软件包结合使用的图形编辑器。它用于通过现成的块创建 CPU 的整

个软件结构。使用该编辑器时，可将块放置在功能图上、为它们分配

参数并将它们互连起来。

SFC 组态顺序控制系统

SFC（Sequential Function Chart，顺序功能图）是一种用于创建顺序

控制系统的工具。使用该应用程序，可创建和调试工艺顺序控制系统。

SCL 块编程

SCL（Structured Control Language，结构化控制语言）是一种用于可

编程控制器的高级编程语言。除高级语言元件外，它还包含作为语言

元件的典型 AS 元件：

● 输入

● 输出

● 定时器

● 位存储器

● 块调用

SCL 补充并扩展了 STEP 7 编程软件的 LAD、FBD 和 STL 编程语言。
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应用 用途

图形编辑器

(WinCC)
编辑过程画面

在图形编辑器中，编辑要在操作站上显示给操作员并用于过程控制的

仿真图形。PCS 7 提供了一个可在创建过程画面时使用的功能，该功

能可向过程画面中自动插入所有块图标（过程变量的清晰图形表示）。

也可插入其它图形对象并定义这些对象的动态属性。例如，可显示某

个阀的当前状态，这样操作员便可立即确定该阀的状态是“打开”还

是“关闭”。

变量记录

(WinCC)
归档过程值

变量记录用于归档过程值，其包括以下功能：

● 创建归档

● 将过程值分配给归档

报警记录

(WinCC)
归档消息和报警

在处理消息和报警过程中使用报警记录来实现以下功能：

● 接收来自过程的消息

● 准备消息并在过程模式下显示消息

● 操作员确认

● 归档

报表设计器

(WinCC)
设计过程值或消息的打印输出布局。 

报表设计器提供了用于创建和输出报表的功能。可分别调整所提供的

标准布局。报表设计器提供了所需的编辑器。 

OpenPCS 7 连接到工厂管理级

生产过程中会不断产生对工厂管理级和企业管理级而言非常重要的新 
PCS 7 数据。通过 OPC/OLE DB 可以访问这些数据。通过该软件包，

可使用较高控制级的数据，并可创建自己的统计信息和评估。

SIMATIC 
BATCH

批生产过程（不连续过程）自动化

通过使用 SIMATIC BATCH 软件包，可为过程单元组态具有严格要求

的面向配方的控制策略。这样便可编辑具有备选过程顺序的复杂任务。

SIMATIC Route 
Control

自动化路径控制 

通过使用 SIMATIC Route Control 软件包，可以在过程模式下控制并

监视物料输送（路径控制）。

SIMATIC PDM SIMATIC PDM 是一个用于对设备（例如，传感器）进行组态、参数分

配、调试和维护以及用于组态网络的软件包。 

可通过 SIMATIC PDM 对设备的过程值、报警和状态信息进行简单的

监视。
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应用 用途

Version Cross 
Manager

比较项目版本

Version Cross Manager 用于执行以下比较操作：

● 比较项目和库的版本并通过图形显示差异

● 比较两个 S7 程序版本之间有关编程方面的差异

● 比较两个 CFC/SFC 的版本

● 以 XML 格式导出项目数据

版本跟踪 创建版本

版本跟踪用于创建多项目、项目和库的版本。版本跟踪的附加功能是

自动归档和自动回读。

S7 F 系统 为组态 S7-400F/S7-400FH 提供支持。

“S7 F 系统”附加软件包支持： 
● 使用 HW Config 组态 F I/O。

● 通过为 F 模块提供 F 库创建安全程序，以及在安全程序中集成故障

检测功能。

导入/导出助手 对大量数据进行快速工程组态的工具（例如，导入过程变量类型和模

型）。

PCS 7 高级过程

库

PCS 7 库包括供在 PCS 7 工厂中使用的块和功能。

硬件目录 硬件目录“PCS7_Vx.y”包含所有经许可的设备和模块（在任何情况下

均为最新版本）。

DOCPRO 使用 DOCPRO，可创建和管理工厂文档。

SFC 可视化 操作员系统的 SFC 可视化使得通过 SFC 编辑器组态的顺序控制系统

以与在工程组态系统上相同的方式表示和运行。不需要对此进行任何

额外的组态。
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实施 PCS 7 组态 9
9.1 组态任务概述

简介

以下介绍的基本活动是按照实际顺序进行的，按此顺序可在组态期间完成合理的工作流。     

根据项目的要求，组态中的某些步骤必须执行，而其它步骤为可选步骤。通过下表可了解

哪些组态任务是必需的，而哪些又是可选的。

组态任务概述

组态任务 强制 可选

设置 PC 站
（请参见手册《过程控制系统 PCS 7；PCS 
7 - PC 组态》(Process Control System 
PCS 7; PCS 7 - PC Configuration)）

X -

创建 PCS 7 项目（多项目） X -

创建 SIMATIC 站 (AS 41x) X -

创建 SIMATIC PC 站 X

对于工程师站

和操作站

X

如果站用作： 
● 维护站

● SIMATIC BATCH
● SIMATIC Route Control
● OpenPCS 7
● Process Historian

创建工厂层级 X -

创建主数据库 X -

分配多项目进行分散编辑（多项目工程组

态）

 X

由多个项目工程师进行分散

编辑

配置硬件（AS 和 I/O） X -

创建网络连接 X -
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组态任务 强制 可选

创建 SIMATIC 连接 X -

组态以下 AS 功能： X -
● 创建 CFC X -
● 组态 SIMATIC 连接 - X
● 组态 I/O 的链接（驱动程序块） X -
● 通过过程变量类型创建过程变量 - X

在多项目中编辑大量数据

时 

● 创建顺序控制系统 (SFC) - X
● 创建模型 - X

在多项目中编辑大量数据时

组态 OS 功能

在组态手册《过程控制系统 PCS 7；操作

站》中介绍

X -

组态维护站

在组态手册《过程控制系统 PCS 7；维护

站》中介绍

- X

使用维护站时 

组态 BATCH 功能

在组态手册《过程控制系统 PCS 7；
SIMATIC BATCH》(Process Control 
System PCS 7; SIMATIC BATCH) 中进行

了描述

- X

使用 SIMATIC BATCH 时

组态 Route Control 功能

请参见手册

《过程控制系统 PCS 7；SIMATIC Route 
Control》(Process Control System PCS 7; 
SIMATIC Route Control)

- X

在用于与 SIMATIC Route 
Control 结合使用时

组态外部归档服务器上的归档功能 

在《过程控制系统 PCS 7；操作站》

(Process Control System PCS 7; Operator 
Station) 手册中介绍：

 X

使用 SIMATIC Process 
Historian 时

实施 PCS 7 组态
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组态任务 强制 可选

组态与车间管理级的连接（OpenPCS 7 和 
SIMATIC IT）

- X

将 PCS 7 通过接口连接到

管理级时

在分散编辑后合并项目（多项目工程） - X

由多个项目工程师进行分散

编辑

执行项目间功能（多项目工程组态） - X

由多个项目工程师进行分散

编辑

编译并下载到目标系统 X -

描述的步骤

以下部分中介绍的组态创建过程是在此步骤的基础上构成的。作为讨论所有主题的前提条

件，必须按多项目工程组态来创建 PCS 7 项目。PCS 7 项目细分为若干项目，逐一进行分

散编辑，最后合并到多项目中，以实现跨项目功能。

说明

遵循此处介绍的步骤可获得全部系统支持。当然也可采用不同的步骤，但您将失去 PCS 7 
提供的某些或全部支持。

实施 PCS 7 组态
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9.2 需要完整下载 AS 或 OS 数据的更改的概述

简介

完成组态或项目的某些更改/更新后，需要完整下载 AS 或 OS。   

但是，完整下载将显著干预 PCS 7 的过程运行，因为需要执行 CPU STOP，例如完整下

载 AS 时。 

此处的说明旨在帮助您决定当工厂中无法执行完整的 AS 或 OS 下载时进行特定的更改是

否可行。

适合更改的情况

● 没有软件更新的项目和工程组态更改

以下内容概要介绍了这些更改。

● 不使用新功能的软件更新

更多相关信息，请参考《过程控制系统 PCS 7；不使用新功能的软件更新》手册中的

“不使用新功能的软件更新的重要说明”部分。

● 使用新功能的软件更新

有关更多信息，请参考《过程控制系统 PCS 7；使用新功能的软件更新》手册中的

“新 PCS 7 功能的要求”部分。

完整 AS 下载概述

以下更改会导致失去下载更改功能，并强制您在 CPU STOP 模式下执行完整的 AS 下
载。   

● 块结构更改，例如接口更改、添加消息。

说明

CPU RUN 模式中 TCiR 的更改

要在 CPU RUN 模式下执行块结构和接口的 TCiR 更改，需要固件版本为 V8.1 的 CPU 
410。

● HW Config 中的更改

– CPU 参数

– 中央机架中的 HW 更改

– 对于不允许“在运行时更改”(CiR) 的 PROFIBUS DP 的更改。

– 启用/禁用 CiR 功能

实施 PCS 7 组态
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● 编译期间通过菜单命令“工具 > 设置 > 编译/下载... > 选项：‘压缩’”(Tools > Settings 
> Compile/Download... > Option:"Compress") 压缩了 DB 和 FC 编号。

● 下载更改前，已修改的程序下载到另一个 CPU 中，例如，用于调试目的。在这种情况

下，时间戳不再与原始 CPU 的时间戳匹配。

例外： 
如果使用“S7 下载”(S7 Download) 对话框的“下载到测试 CPU”(Download to test CPU) 
选项，将保留下载标识符和比较时间戳。因此仍可通过下载更改将程序传输到原始 
CPU。

● 依靠不是源自于最近下载（时间戳比较）的归档程序。

完整 OS 下载概述

以下更改需要完整的 OS 下载

进行以下更改后，不能再使用“下载更改”功能。执行完整下载后，不能再使用“下载更

改”功能。

● 重命名了 OS

● 执行了完整的 OS 编译

● 更改了目标计算机的路径

● 更改了主站 OS 到备用站 OS 的分配

● 更改了冗余 OS 服务器的组态

● 更改了 OS 的项目属性

● 更改了 OS 中的热键

● 将新增 OS 服务器的数据下载到了现有的 OS 服务器中

实施 PCS 7 组态
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9.3 设置 PC 站

所有 PC 站上的设置 

为了能够从中央工程师站 (ES, Engineering station) 组态、下载和测试 PCS 7 项目中的所

有自动化系统 (AS, Automation System) 和 PC 站（例如 OS 和 BATCH），则必须在所

有 PC 站上进行以下设置：

● 指定通过终端总线和工厂总线通信的通信模块

● 为工厂总线上的通信模块设置/检查访问点和操作模式

首先在中央工程师站上进行这些设置。 

更多信息

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

实施 PCS 7 组态

9.3 设置 PC 站

工程组态系统 (V9.0 SP1)
254 配置手册, 12/2017, A5E39221328-AC



9.4 创建 PCS 7 项目

9.4.1 默认设置和各个步骤概述

组态任务概述 

本部分内容介绍了创建及设置 PCS 7 项目的各个步骤：

内容 位置

对 PCS 7 项目进行默认设置 (页 255) SIMATIC Manager

使用 PCS 7 向导创建新的多项目 (页 256) PCS 7“新建项目”向导 

（在 SIMATIC Manager 中）

通过添加新（空）项目扩展多项目 (页 258) SIMATIC Manager

通过添加预组态工作站扩展项目 (页 261) PCS 7“扩展项目”向导 

（在 SIMATIC Manager 中）

通过添加附加对象扩展项目 (页 262) SIMATIC Manager

组态项目/库的访问保护 (页 263) SIMATIC Manager 

（带 SIMATIC Logon）

9.4.2 如何设置默认设置

步骤

1. 打开 SIMATIC Manager 并选择菜单命令“选项 > 自定义...”(Options > Customize...)。
将打开“自定义”(Customize) 对话框。    

2. 检查“常规”(General) 选项卡的“项目/多项目的存储位置”(Storage location for projects/
multiprojects) 和“库的存储位置”(Storage location for libraries) 下的路径信息。      
如果要使用专门组态的项目驱动器来代替默认路径（即“项目/多项目的存储位置”(Storage 
location for projects/multiprojects) 下的“SIEMENS\STEP7\S7Proj”），则指定新的路径。

3. 确保加载了备份（镜像）。

4. 在“语言”(Language) 选项卡上，设置要使用的语言和助记符。

5. 在“日期和时间”(Date and Time) 选项卡中，设置所需的格式并指定模块是否应显示编程设
备/PC 的当地时间（对于 UTC 系统时间 -> 转换为当地时间）。

6. 在“向导”(Wizards) 选项卡上，检查是否设置了“PCS 7”选项。
必须进行此设置，以后才能启动“新建项目”(New Project) 和“扩展项目”(Expand Project) 
PCS 7 向导。

实施 PCS 7 组态
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7. 在“消息号”(Message Numbers) 选项卡中，保留默认设置“始终提示设置”(Always prompt 
for setting)，或选择“整个 CPU 消息号总是唯一”(Always assign unique message numbers 
CPU-wide)。

8. 在“归档”(Archive) 选项卡中，可以选择要使用的归档程序（如 PKZip）和用于归档/重新获
取的路径。

9. 单击“确定”(OK)。
对话框将关闭。

在使用 PCS 7“新建 SIMATIC Manager 项目”(New SIMATIC Manager Project) 向导首次创

建 PCS 7 项目时输入所有其它设置。稍后可以在“设置”(Settings) 对话框中更改这些设

置。

说明

为使某些设置生效（例如，更改语言时），必须重启 SIMATIC Manager。

更多信息

● “Settings（设置）”对话框的在线帮助

9.4.3 如何使用 PCS 7 向导创建新的多项目

PCS 7“新建项目”向导 

使用 PCS 7“新建项目”(New Project) 向导将新的 PCS 7 项目创建为多项目。多项目包含以

下组件：     

● 一个项目

● 主数据库

您将在 PCS 7 向导的引导下完成各个组态步骤。使用该向导可指定 CPU，选择要创建的

工厂层级的层级数和 AS 对象 (CFC/SFC) 以及选择 OS 对象（PCS 7 OS、SIMATIC 
BATCH 和 SIMATIC 路径控制）。期间还可指定工艺名称（如工厂、单元和功能），并可

在以后根据工厂的具体要求进行修改。 

步骤 

1. 在 SIMATIC Manager 中选择菜单命令“文件”(File) >“新建项目”(New Project) 向导。

2. 可使用“预览”(Preview) 按钮检查多项目的结构。

实施 PCS 7 组态
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3. 单击“继续”(Continue)。

4. 根据需要选择所需 CPU（包）和所需的通信模块 (CP 443-5) 数。

5. 单击“继续”(Continue)。

6. 在下一个对话框中定义需要的项目结构：

– AS 对象：CFC/SFC
– OS 对象：PCS 7 OS、SIMATIC BATCH、SIMATIC Route Control、OpenPCS 7
– 组态：单工作站系统、多工作站系统或冗余多工作站系统。

7. 单击“继续”(Continue)。

实施 PCS 7 组态
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8. 指定多项目的目录名（项目名称）和存储位置（路径）。

说明

PCS 7 中的项目名称

允许在 PCS 7 的多项目名称或项目名称中使用以下字符：

● 字母表中的大小写字母（A 到 Z；a 到 z）
● 数字（0 到 9）
● 下划线 ( _ )
● 连字符 ( - )

9. 单击“完成”(Finish) 开始创建该多项目。

10.选择“消息号分配选择”(Message number assignment selection) 对话框中的“分配 CPU 
范围内唯一的消息号”(Assign unique message numbers CPU-wide) 选项。

11.单击“确定”(OK)。

结果

创建了一个多项目，其中包含一个项目，如预览所示。在组件视图和工厂视图中分别创建

了相关的对象。还创建了包含以下内容的主数据：

● 在组件视图中：

有一个 S7 程序，其中包含分别放置源文件、块和图表的几个文件夹以及

一个放置共享声明的文件夹

● 在工厂视图中：

有几个分别用于放置过程变量类型、模型和共享声明的独立文件夹

打开多项目

使用 PCS 7 向导创建多项目后，该多项目会在 SIMATIC Manager 中自动打开。

以后再打开该多项目时，务必要使用菜单命令“文件”(File) >“打开”(Open) >“多项目”
(Multiprojects) 选项卡 >“<多项目的名称>”>“确定”(OK) 按钮来打开。

9.4.4 如何通过添加新（空）项目扩展多项目

步骤

1. 在 SIMATIC Manager 中选择多项目。

2. 选择菜单命令“文件 > 多项目 > 在多项目中创建...”(File > Multiproject > Create in 
Multiproject...)。
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3. 输入新项目的名称并指定存储位置。

4. 单击“确定”(OK)。

结果

在多项目中创建新项目，用户可通过 PCS 7“扩展项目”向导添加预组态的工作站以进一步

组态（例如，使用 HW Config、工厂层级进行组态）或扩展该多项目。

更多信息

● 对于多项目工程，请阅读“在多项目中组态 (页 188)”部分中关于将自动化系统、操作

员站和 SIMATIC PC 站分布给多项目的单个项目的规则。

● “如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部分。

9.4.5 如何将现有项目插入到多项目中

简介

如果要继续使用现有项目（未更改或修改的单项目），可以在多项目中集成该项目。   

如果该项目已属于另一多项目，则会显示一条消息。如果要在多项目中包括这样的项目，

则需将其从其它多项目中删除。

步骤

1. 打开多项目。

2. 在 SIMATIC Manager 中选择菜单命令“文件 > 多项目 > 在多项目中插入...”(File > 
Multiproject > Insert in Multiproject...)。

3. 选择要插入的项目。

4. 单击“确定”(OK)。

说明

如果此项目源于早期 PCS 7 版本，请按照手册《过程控制系统 PCS 7；SW 更新 ...》
(Process Control System PCS 7; SW Update ...) 中所述的步骤进行。
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多项目中外部归档服务器的规则

说明

在一个多项目中仅可组态一个外部归档服务器 (Process Historian)。   
当使用冗余归档服务器时，在多项目中只能有一个 PC 站充当归档服务器，另一个 PC 站
充当该归档服务器的冗余 PC 站。

如果多项目中已提供一个外部归档服务器，则在向已存在的项目中插入之前，请先检查其

是否未在任何其它归档服务器中组态。

 

9.4.6 如何从多项目中删除项目

简介

可从多项目中删除不再需要的项目。

步骤

1. 打开多项目。

2. 选择要从多项目中删除的项目。

3. 在 SIMATIC Manager 中选择菜单命令“文件 > 多项目 > 从多项目中删除...”(File > 
Multiproject > Remove from Multiproject...)。

结果

该项目不再属于多项目。但是，该项目并未被删除；只是删除了面向多项目的分配。使用

菜单命令“文件 > 删除 > 用户项目”(File > Delete > User projects) 删除项目。
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9.4.7 如何使用 PCS 7 向导用预组态工作站扩展项目

PCS 7“扩展项目”向导

借助 PCS 7“扩展项目”(Expand Project) 向导，可使用预组态工作站（例如，AS 或用于 
OS、BATCH、Route Control 或 OpenPCS 7 等未集成任何硬件的 PC 站）扩展项

目。       

说明

要使用向导插入维护站，请按插入 OS 站的步骤操作。然后在工厂层级中指明将 OS 作为

维护站。

对于 AS，这涉及组合的组态（产品包），可在 PCS 7 目录中找到并已通过 PCS 7“新建项

目”(New project) 向导进行了解。如果在工厂中使用此类包，在插入预组态工作站时会创建

所有需要的对象。因此，您不必单独集成该包的组件。

插入 AS

1. 在 SIMATIC Manager 中选择要扩展的项目。

2. 选择菜单命令“插入 > 预组态工作站...”(Insert > Pre-configured station…)。

3. 从“CPU：”下拉列表中选择所需的 CPU。

4. 从“包”(Bundle) 列表中选择所需包。
您可以在“说明”(Description) 列中找到该包的各组件。

5. 从“通信模块 (CP 443-5) 的数量”(Number of communication modules (CP 443-5)) 下拉列
表中选择要设置的通信模块（分布式 I/O）的数量。

6. 单击“继续”(Continue)。

7. 如果还想插入 PC 站，则选择所需的站类型（OS 对象）。

8. 单击“继续”(Continue)。

9. 将在下一个对话框中显示项目名称和存储位置。

10.单击“完成”(Finish)。

结果

将创建相应的自动化系统，其中包括所选包的所有组件的硬件配置。 

插入 PC 站

1. 在 SIMATIC Manager 中选择要扩展的项目。

2. 选择菜单命令“插入 > 预组态工作站...”(Insert > Pre-configured station…)。
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3. 在“CPU：”下拉列表中选择“（未集成硬件）”(without integrating hardware) 项。

4. 单击“继续”(Continue)。

5. 从“OS 对象”(OS objects) 下选择以下对象之一：

– PCS 7 OS
另外在此选择 OS 站作为维护站。

– SIMATIC BATCH
– SIMATIC Route Control
– OpenPCS 7

6. 然后选择以下项之一：

– 单工作站系统

– 多工作站系统

– 冗余多工作站系统

7. 单击“继续”(Continue)。
将在下一个对话框中显示项目名称和存储位置。

8. 单击“完成”(Finish)。

结果

将创建包括硬件配置的相应的 SIMATIC PC 站。 

9.4.8 如何通过添加对象扩展项目

简介

基本组态通过 PCS 7 向导创建，可以通过添加适用于工厂的对象来扩展此基本组态。

步骤

此处介绍的步骤对任何选定视图都有效。可以根据所选对象及所选视图插入对象选择。

1. 在 SIMATIC Manager 中选择文件夹/对象。

2. 选择“插入”(Insert) 菜单。
“插入”(Insert) 菜单提供了所有能在文件夹下插入的对象。
选择内容取决于是否在过程对象视图、工厂视图或组件视图中选择了对象。

3. 使用菜单命令选择所需对象并指定对象名称。

更多信息

● SIMATIC Manager 在线帮助
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9.4.9 如何提供带有访问保护的项目/库

简介    

从 PCS 7 V7.0 开始，可指定保护密码来为项目和库提供访问保护。 

组态访问保护后，可在更改日志中记录在线操作。

要求

● 已安装 SIMATIC Logon。

● 在 PCS 7 安装期间，在 SIMATIC Logon 中自动创建“项目管理员”和“项目编辑员”

角色。

● 在 SIMATIC Logon 中为您分配了“项目管理员”角色。

● 您以项目管理员或项目编辑员的身份登录。

规则

● 当前登录的用户（项目管理员、项目编辑员）显示在 SIMATIC Manager 的状态栏中。

● 首次激活访问保护时，会改变项目格式。系统将通知您，不能再使用较早版本的 PCS 7 
编辑已修改的项目。

● 使用删除访问保护和更改日志功能，您将丢失对此项目或库具有访问权限的用户的相关

信息以及所有更改日志。

激活访问保护和分配密码

1. 在 SIMATIC Manager 中选择项目/库。

2. 选择菜单命令“选项 > 访问保护 > 激活”(Options > Access Protection > Activate)。

3. 在“激活访问保护”(Activate Access Protection) 对话框中输入密码并确认密码。

4. 单击“确定”(OK)。
相应的项目/库现已受密码保护，只有经过授权的用户才能打开它们进行编辑。

禁用访问保护

1. 在 SIMATIC Manager 中选择项目/库。

2. 选择菜单命令“选项 > 访问保护 > 禁用”(Options > Access Protection > Deactivate)。

3. 在“禁用访问保护”(Deactivate Access Protection) 对话框中输入密码并确认密码。

4. 单击“确定”(OK)。
相应的项目/库不再受密码保护，任何用户都可以打开它们进行编辑。
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激活/禁用更改日志

1. 在 SIMATIC Manager 中选择项目/库。

2. 选择菜单命令“选项 > 更改日志 > 激活”(Options > Change log > Activate ) 或“禁用”
(Deactivate)。
还将记录特定的在线更改。

显示更改日志

1. 在 SIMATIC Manager 的树形视图中，选择所需部分（项目、SIMATIC 站或操作员站）。

2. 选择菜单命令“选项 > 更改日志 > 显示”(Options > Change Log > Display)。
将打开更改日志，并且可向其添加注释。

访问保护的其它方面

菜单命令 用途

“选项 > 访问保护 > 管理”
(Options > Access Protection 
> 
Manage)

编辑用户管理（在“SIMATIC Logon 角色管理”(SIMATIC 
Logon Role Management) 对话框中）

作为项目管理员，您有权：

● 激活或禁用访问保护

● 管理和同步用户

● 更改项目密码

● 激活、禁用及显示更改日志

● 删除访问保护和更改日志

作为项目编辑员，您有权：

● 打开和编辑带有访问保护的项目/库
● 显示更改日志

“选项 > 访问保护 > 在多项目

中同步”(Options > Access 
Protection > Synchronize in 
multiproject)

打开多项目时，此命令为多项目中的所有项目和库全局指

定项目管理员和项目编辑员。 

为选定对象（如项目或库）指定的属性将分配给多项目中

的所有其它对象。

“选项 > 访问保护 > 删除访问

保护和更改日志”(Options > 
Access Protection > Remove 
Access Protection and 
Change Log)

为受密码保护的项目/库删除访问保护并删除更改日志（因

为已不再需要访问保护）
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更多信息

● “通过访问保护来保护项目/库 (页 182)”部分

● “如何在 ES 日志中记录更改 (页 669)”部分

● SIMATIC Manager 在线帮助

● 手册《SIMATIC Logon；SIMATIC 电子签名》(SIMATIC Logon; SIMATIC Electronic 
Signature)

9.4.10 如何打开受访问保护的项目/库

简介      

下面将介绍如何打开受保护的项目/库。这通常取决于是否安装了 SIMATIC Logon 
Service。

说明

如果在没有登录 SIMATIC Logon Service 的情况下打开包含受保护项目/库的多项目，则受

保护的项目/库将变灰并且不可编辑。

要查看涉及的项目/库（包括路径），请将鼠标光标置于灰显的项目或库上（工具提示），

或访问详细视图。

如果尝试打开受保护的项目/库，但未以项目管理员或项目编辑员的身份注册，或者不知道

项目密码，该项目/库将不会打开。

实施 PCS 7 组态

9.4 创建 PCS 7 项目

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 265



步骤

如果…… 则

● 已安装 SIMATIC Logon 
Service

● 以项目管理员或项目编辑员的

身份注册

● 已经使用 SIMATIC Logon 
Service 登录

● 未打开项目/库

1.在 SIMATIC Manager 中，选择菜单命令

“文件 > 打开...”(File > Open...)。

2.选择所需的项目/多项目/
库。

3.单击“确定”(OK)。

● 已安装 SIMATIC Logon 
Service

● 以项目管理员或项目编辑员的

身份注册

● 未打开项目/库

1.在 SIMATIC Manager 中，选择菜单命令

“文件 > 打开...”(File > Open...)。

2.选择所需的项目/多项目/
库。

3.单击“确定”(OK)。

4.在“SIMATIC Logon Service”对话框中输入用户名和

密码。

5.单击“确定”(OK)。

● 未安装 SIMATIC Logon 
Service

● 未打开项目/库

1.在 SIMATIC Manager 中，选择菜单命令

“文件 > 打开...”(File > Open...)。

2.选择所需的项目/多项目/
库。

3.单击“确定”(OK)。

4.在“输入项目密码”(Enter project password) 
对话框中输入项目密码。

5.单击“确定”(OK)。

结果

将打开受保护的项目/库，并且可对其进行编辑。 
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9.4.11 如何管理多语言文本

简介

要显示操作员站上的过程，请使用面板，例如，它会向工厂操作员显示测量值、操作限制、

单位和块操作员文本。   

PCS 7 允许您导出项目中以某种语言存储的文本，对其进行翻译后重新导入，然后以翻译

后的语言显示这些文本。

说明

如果与要更新的系统中块的 PCS 7 版本相比，操作员文本或显示文本已更改，而如果要使

用新的 PCS 7 V7.1 面板，则应备份“旧”操作员文本。

要求

已在项目中安装了所需的语言。

（在 SIMATIC Manager 中选择菜单命令选项 > 显示设备的语言 (Options > Language for 
Display Devices)，以显示可用语言的列表）。

规则

● 新文本的长度不得超过默认文本。如果必须使用较长的文本，应查看是否仍能够正确显

示该文本。

● 导出：

对位于所选对象之下的所有块和符号表执行导出。将为每个文本类型创建一个导出文

件。其中包含一个源语言列和一个目标语言列。 
源语言列中的文本不可更改。

● 导入：

对位于所选对象之下的所有块和符号表执行导入。导入时，将目标语言列（右侧列）中

的内容导入所选对象。仅导入在源语言列中存在现有文本对应项的那些文本。

导出

1. 在 SIMATIC Manager 中打开要更新的项目。

2. 在组件视图中，选择主数据库文件夹（如果不存在，则选择项目文件夹）。

3. 选择菜单命令选项 > 管理多语言文本 > 导出 (Options > Manage Multilingual Texts > Export)。
将打开“导出用户文本”(Export User Texts) 对话框。
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4. 进行以下设置：

– 在“文本表”(Text tables) 组中，选择导出文件的存储位置和格式（*.xls 或 *.csv）。

– 在“语言”(Language) 组中，依照显示语言选择目标语言和源语言。

– 在“文本类型”(Text types) 组中，选择要导出的文本类型。

– 如果适用，可激活“输入导出文件中使用的文本磅值”(Enter points of use of texts in 
the export file) 复选框。

5. 单击“确定”(OK)。
将在目标目录中为每个文本类型创建一个导出文件。

如果管理多个特定项目的语言，可重复第 3 步和第 4 步。请注意，随后必须设置不同的导

出文件名或目标目录。

导入

1. 在 SIMATIC Manager 中打开要更新的项目。

2. 在组件视图中，选择主数据库文件夹（如果不存在，则选择项目文件夹）。

3. 选择菜单命令选项 > 管理多语言文本 > 导入 (Options > Manage Multilingual Texts > Import)。
将打开“导入用户文本”(Import User Texts) 对话框。

4. 在“源”(Source) 组中，选择导出文件的存储位置和格式（*.xls 或 *.csv）。

5. 单击“确定”(OK)。
将导入文本，并且输出一个导入日志文件。

多语言项目中的显示语言

● 对于多语言项目，在首次编译 OS 之前，必须在 SIMATIC Manager 中添加以后要用到

的所有显示语言（有关此主题的更多信息，请参见“如何设置显示设备的语言 
(页 320)”部分）。

● 必须使用更改组态时所用的同种语言执行编译和下载操作。

例如，如果导入西班牙语文本（显示设备的语言：西班牙语），则还必须使用该语言执

行编译和下载操作。否则更改的文本不会添加到 WinCC 文本库中。

● 为了在 WinCC 中使用 PCS7 库中的文本，在 SIMATIC Manager 的“显示设备的语言”
(Language for display devices) 下只能选择以下 S7 语言：

– “德语（德国）”(German (Germany))
– “英语（美国）”(English (USA))
– “法语（法国）”(French (France))
– “意大利语（意大利）”(Italian (Italy))
– “西班牙语（国际分类法）”(Spanish (international sorting))
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● 在编译 OS 时，“西班牙语（国际）”文本将转换为“西班牙语（传统）”文本。如果

想要使用菜单命令选项 > 管理多语言文本 (Options > Manage multilingual texts) 将您自

己的文本翻译成这 5 种主要语言之一并将它们导入您的项目中，则以上说明同样适用。

关于其它语言，请参见 WinCC 中提供的语言。

● 对于 WinCC，不能同时使用同种语言的不同变型或分类法，即，不能同时使用“英语

（美国）”和“英语（英国）”，或同时使用“西班牙语（国际分类法）”和“西班牙

语（传统分类法）”，或者同时使用“荷兰语（荷兰）”和“荷兰语（比利时）”。

更多信息

● SIMATIC Manager 在线帮助

● 手册《SIMATIC；使用 STEP 7 编程》(SIMATIC; Programming with STEP 7)

● 手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)
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9.5 组态 SIMATIC 和 PC 站

概述

在 SIMATIC Manager 中多项目的项目中创建下列对象：       

● 每个自动化系统一个“SIMATIC 400 站”

● 为工程师站创建一个“SIMATIC PC 站”

● 每个操作员站的“SIMATIC PC 站”（单工作站系统或多工作站系统）

● 用作维护站的“SIMATIC PC 站”（单工作站系统或多工作站系统）

● 每个 BATCH 站的“SIMATIC PC 站”（单工作站系统或多工作站系统）

● 每个 Route Control 工作站的“SIMATIC PC 站”（单工作站系统或多工作站系统）

● 每个 OpenPCS 7 站一个“SIMATIC PC 站”

● 为外部归档服务器 (Process Historian) 创建一个“SIMATIC PC 站”

使用 HW Config 应用程序组态自动化系统和 PC 站（例如 ES、OS）的硬件。

说明

如果需要分散编辑多项目的项目，请阅读“在多项目中组态 (页 188)”部分中关于将自动

化系统、操作员站和 SIMATIC PC 站分配给多项目的单个项目的信息。

9.5.1 如何将 SIMATIC 400 站添加到多项目的项目

简介

如果使用 PCS 7 向导创建了多项目，则默认插入一个自动化系统。通过以下方法，可插入

附加的自动化系统：

● 使用 PCS 7“扩展项目”向导

相关信息，可参考“如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部分。

● 手动（将在下面介绍）
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步骤

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 SIMATIC 站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC 400 站”(Insert > station > SIMATIC 400 station)。
插入一个新站（“SIMATIC 400 Station(1)”；可根据需要修改名称）。

3. 重复此步骤以添加更多的 SIMATIC 站。

更多信息

● “如何创建 SIMATIC 400 站 (页 349)”部分。

● SIMATIC Manager 在线帮助

9.5.2 如何启动组态 SIMATIC 400 站

简介

本节介绍如何启动自动化系统的基本组态。对于多项目，建议遵循以下工作流程：

● 在中央工程师站上，自动化系统将在单个项目中创建，并对通信处理器进行组态以实现

与数据网络的连接。这将在下文进行介绍。

● 仅在移动项目以进行分散编辑之后，才可在分布式工程师站上组态带有连接 I/O 的完整

硬件。全部硬件组态在“组态硬件”部分中介绍。

说明

如果已经使用 PCS 7“扩展项目”(Expand Project) 向导创建 SIMATIC 400 站，则相应包

中的所有硬件组件已经可用。 

步骤

要启动自动化系统的基本组态，请执行以下步骤：

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细视图中双击“硬件”(Hardware) 对象
打开 HW Config。
将打开自动化系统的硬件配置。

2. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。 

3. 在“SIMATIC 400 > 机架 400”(SIMATIC 400 > Rack-400) 硬件目录中，选择所需的机架并通
过鼠标拖动的方式将其插入。
确保所选的排列与物理硬件的排列相匹配。

4. 在“SIMATIC 400 > PS-400”硬件目录中，选择所需的电源并通过鼠标拖动的方式进行添
加。
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5. 在“SIMATIC 400 > CPU-400”硬件目录中，选择所需的 CPU 并通过鼠标拖动的方式将其
插入。 

6. 根据所选 CPU，可以确定以下现场总线系统的属性：

– PROFINET 
– PROFIBUS
单击“确定”(OK) 以确认打开的“属性 - ...”(Properties - ...) 对话框。

7. 重复此步骤以添加附加组件。

8. 在 HW Config 中选择菜单命令“站 > 保存并编译”(Station > Save and Compile)。

更多信息

● “配置硬件”部分

9.5.3 如何将 CP 插入到 SIMATIC 站中并将它们分配给网络

简介

在 SIMATIC 400 站中插入的通信处理器 (CP) 必须在 HW Config 中进行网络连接组态并分

配给通信网络。在多项目工程组态中，建议在中央工程师站上对所有项目执行此组态工作。

例如，这样可以确保节点地址在总线上是唯一的。

说明

如果已经使用 PCS 7“扩展项目”(Expand Project) 向导创建 SIMATIC 400 站，则相应包（包

括 CP）中的所有硬件组件都已可用。换言之，稍后需要通过下述步骤来添加附加 CP。

步骤

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细视图中双击“硬件”(Hardware) 对象
打开 HW Config。
将打开自动化系统的硬件配置。

2. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

3. 在“SIMATIC 400 > CP-400”硬件目录中，选择所用网络所需的 CP (CP 443-1)，然后通过
拖放操作将其插入。
插入该 CP 后，将打开“属性 - 接口”(Properties - Interface) 对话框。

4. 在“属性 - 接口”(Properties - Interface) 对话框中，在设置总线上所需的 CP 地址。

5. 从“子网”(Subnet) 组中选择子网：

– 如果尚未建立子网，请单击“新建”(New)，然后定义一个新的网络。

– 如果已经建立子网，请在“子网”(Subnet) 组中选择所需的网络。
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6. 单击“确定”(OK)。
将关闭“属性”(Properties) 对话框。

7. 从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

更多信息

● “配置硬件”部分

9.5.4 如何插入工程师站

简介               

工程师站在 SIMATIC Manager 中进行组态。在此过程中将执行下列步骤：

● 插入 SIMATIC PC 站

● 在 HW Config 中配置硬件

● 在 NetPro 中组态通信连接

然后，针对 PC 站建立的通信连接可用“站组态编缉器”的诊断功能进行检查。

步骤

1. 在 SIMATIC Manager 的组件视图中选择要插入工程师站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入了一个新的 SIMATIC PC 站。

3. 选择该 SIMATIC PC 站，然后选择菜单命令编辑 > 对象属性... (Edit > Object Properties...) 
并输入所需名称。

4. 从组件视图中选择 SIMATIC 站，然后在详请视图中双击“组态”(Configuration) 对象以打
开 HW Config。
将打开 SIMATIC PC 站的硬件配置。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

6. 在硬件目录中的“SIMATIC PC 站 > HMI ...”(SIMATIC PC station > HMI ...) 下，选择所需
的“WinCC 应用程序”并将其拖到组态表中：

7. 在“SIMATIC PC 站 > CP 工业以太网”(SIMATIC PC Station > CP Industrial Ethernet) 下的
硬件目录中，选择安装在 SIMATIC PC 站中的通信处理器，然后将其拖动到 PC 站。
如果使用标准网卡，请选择“IE 常规”(IE General) 处理器。
将打开“属性 - 以太网接口”(Properties - Ethernet Interface) 对话框。
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8. 在总线上为 CP 设置所需的地址：

– 如果网络适配器已连接到终端总线，请激活“IP 协议正在使用”(IP protocol is being 
used) 复选框。

– 如果网络适配器已连接到工厂总线，请激活“设置 MAC 地址/使用 ISO 协议”(Set 
MAC address / Use ISO protocol) 复选框。

– 对于通过 BCE 连接到工厂总线的网卡，在

“常规”(General) 选项卡中输入名称并

将

“选项”(Options) 选项卡的“连接的发送保持激活状态”(Send keep alive for 
connections) 组中的“间隔”(Interval) 设置为“30”。

9. 从“子网”(Subnet) 组中选择子网：

– 如果尚未建立子网，请单击“新建”(New)，然后定义一个新的网络。

– 如果已经建立子网，请在“子网”(Subnet) 组中选择所需的网络。

10.单击“确定”(OK)。
将关闭“属性”(Properties) 对话框。

11.从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

更多信息

● “设置 PC 站 (页 254)”部分

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

9.5.5 如何插入操作员站或维护站

简介

SIMATIC Manager 将 PCS 7 OS 的每个服务器、冗余服务器、客户端或单工作站系统都

视为 SIMATIC PC 站。SIMATIC PC 站始终包含下列对象：

● WinCC 应用程序

● 不是通过向导插入的通信处理器

● OS
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如果用 PCS 7 向导创建了多项目，则会在选择相应的选项时已插入 PCS 7 OS。通过以下

方法，可插入附加操作员站：

● 使用 PCS 7“扩展项目”向导

有关更多信息，请参见“如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部

分。

● 手动（将在下面介绍）

说明

可组态操作员站并将其用作维护站 (MS)。因此，以下说明也适用于插入维护站。

步骤

1. 在 SIMATIC Manager 的组件视图中选择要插入操作员站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入一个新的 SIMATIC PC 站。

3. 选择该 SIMATIC PC 站，然后选择菜单命令编辑 (Edit) > 对象属性 (Object Properties)，并
输入所需名称。

4. 从组件视图中选择 SIMATIC 站，然后在详请视图中双击“组态”(Configuration) 对象以打
开 HW Config。
将打开 SIMATIC PC 站的硬件配置。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

6. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC station > HMI) 下，选择所需的 WinCC 
应用程序并将其拖到组态表中：

– SPOSA 应用程序（用于 OpenPCS 7 站）

– WinCC 应用程序（用于 OS 服务器或 OS 单工作站系统）

– WinCC 应用程序（备用）（对于冗余 OS 服务器）

– WinCC 应用程序客户端（对于 OS 客户端）

– WinCC 应用程序客户端引用（用于引用 OS 客户端）

– WinCC 应用程序引用（用于引用 OS 单工作站系统）

7. 在硬件目录中的“SIMATIC PC 站 > CP 工业以太网”(SIMATIC PC Station > CP Industrial 
Ethernet) 下，选择要在 SIMATIC PC 站中安装的通信处理器，并将其拖入该 PC 站中。
如果使用的是标准网络适配器，请选择“IE 常规”(IE General) 处理器。
将打开“属性 - 以太网接口”(Properties - Ethernet Interface) 对话框。
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8. 在总线上为 CP 设置所需的地址：

– 如果网络适配器已连接到终端总线，请激活“IP 协议正在使用”(IP protocol is being 
used) 复选框。

– 如果网络适配器已连接到工厂总线，请激活“设置 MAC 地址/使用 ISO 协议”(Set 
MAC address / Use ISO protocol) 复选框。

– 对于通过 BCE 连接到工厂总线的网络适配器，在“常规”(General) 选项卡中输入名

称并将“选项”(Options) 选项卡的“连接的发送保持激活状态”(Send keep alive for 
connections) 组中的“间隔”(Interval) 设置为“30”。

9. 从“子网”(Subnet) 组中选择子网：

– 如果尚未建立子网，请单击“新建”(New)，然后定义一个新的网络。

– 如果已经建立子网，请在“子网”(Subnet) 组中选择所需的网络。

10.单击“确定”(OK)。

11.从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

12.如果要安装附加操作员站，请执行相同的步骤。

指定目标 OS 和备用 OS 

在 SIMATIC Manager 中创建了所有必要的操作员站，并且已为所有操作员站组态了网络

连接后，必须将目标 OS 或备用 OS 的计算机路径分配给每个操作员站。 

● 如果只有一个 OS，则只需指定目标 OS。 

● 如果具有冗余 OS，则必须指定目标 OS（主机）和备用 OS。

在组件视图中的 OS 的对象属性中输入此设置。选择 SIMATIC PC 站下的“OS”对象，然

后选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)（目标 OS 和备用 OS 的路

径）。

指定基本 OS 和用于参考 OS 单工作站系统的交换文件范围

对于参考 OS 单工作站系统，请在 SIMATIC Manager 中执行以下步骤： 

1. 选择参考 OS 单工作站系统 SIMATIC PC 站下的对象“OS”。

2. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

3. 选择选项卡“OS 参考：用于 OS 参考对象的选项”(OS Ref: options for OS Reference 
objects)。
– 输入目标 OS 计算机的路径。

– 选择基本 OS。
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4. 单击“确定”(OK)。

5. 如果选择冗余 OS 单工作站系统作为基本 OS，则可以指定数据交换文件的归档范围：

– 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 
将在“属性”(Properties) 对话框中显示“交换文件范围”(Swap file scope) 选项卡。

– 选择“交换文件范围”(Swap file scope) 选项卡。 
指定需要换出的归档数据。

– 如果要将当前设置应用到已使用“WinCC 应用程序参考”(WinCC Application Ref) 创
建的全部 OS 单工作站系统，请单击“传播”(Propagate) 按钮。随即会打开接受设置

的提示。选择所需按钮“是/否”(Yes/No)。 
– 单击“确定”(OK)。 

更多信息

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

● 手册《过程控制系统 PCS 7；维护站》(Process Control System PCS 7; Maintenance 
Station)

参见

使用维护站诊断（资产管理） (页 689)

9.5.6 如何插入 BATCH 站

简介 

在 SIMATIC Manager 中，BATCH 站的每个服务器、客户端或单工作站系统都作为一个 
SIMATIC PC 站进行管理。此过程始终包含下列对象：      

● BATCH 应用程序（标准、备用、客户端）
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如果使用 PCS 7 向导创建了多项目，则会在选择相应的选项时已插入 BATCH 站。可按以

下方式插入附加 SIMATIC BATCH 站：

● 使用 PCS 7“扩展项目”向导

有关更多信息，请参见“如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部

分。

● 手动（将在下面介绍）

警告

在各个“SIMATIC PC 站”对象上组态应用程序（WinCC、SIMATIC BATCH 等），随

后通过将同一计算机名称分配给“SIMATIC PC 站”对象对它们进行合并以创建一个 
PC 站是不允许的！

要求

已在工程师站上安装相关 SIMATIC BATCH 附加软件包并获得许可。

步骤

1. 在 SIMATIC Manager 的组件视图中选择要插入 BATCH 站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入一个新的 SIMATIC PC 站。

3. 设置 SIMATIC PC 站的计算机名称：

– 为此，选择 PC 站。

– 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。
– 在“计算机名称”(Computer name) 组中输入计算机名称，或者激活“与 PC 站名称

相同的计算机名称”(Computer name identical to PC station name) 复选框。

4. 从组件视图中选择 SIMATIC 站，然后在详请视图中双击“组态”(Configuration) 对象以打
开 HW Config。
将打开 SIMATIC PC 站的硬件配置。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

6. 在硬件目录中的“SIMATIC PC 站 > BATCH”(SIMATIC PC station > BATCH) 下，选择所需
的 BATCH 应用程序并将其拖到组态表中：

– BATCH 应用程序（用于 BATCH 服务器）

– BATCH 应用程序（备用）（用于冗余 BATCH 服务器）

– BATCH 应用程序客户端（用于 BATCH 客户端）

7. 在“SIMATIC PC 站 > CP 工业以太网”(SIMATIC PC Station > CP Industrial Ethernet) 下的
硬件目录中，选择安装在 SIMATIC PC 站中的通信处理器，然后将其拖动到 PC 站。
如果使用标准网卡，请选择“IE 常规”(IE General) 处理器。
将打开“属性 - 以太网接口”(Properties - Ethernet Interface) 对话框。
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8. 在总线上为 CP 设置所需的地址：

– 如果网络适配器已连接到终端总线，请激活“IP 协议正在使用”(IP protocol is being 
used) 复选框。

9. 从“子网”(Subnet) 组中选择子网：

– 如果尚未建立子网，请单击“新建”(New)，然后定义一个新的网络。

– 如果已经建立子网，请在“子网”(Subnet) 组中选择所需的网络。

10.单击“确定”(OK)。 
将关闭“属性”(Properties) 对话框。

11.从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

12.如果要安装附加 BATCH 站，请执行相同的步骤。

更多信息

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

9.5.7 如何插入 Route Control 工作站

简介

在 SIMATIC Manager 中，Route Control 工作站的服务器、客户端或单工作站系统都作为

一个 SIMATIC PC 站进行管理。此过程始终包含下列对象：          

● Route Control 应用程序（标准、备用、客户端）

如果用 PCS 7 向导创建多项目，则会在选择相应的选项时已插入 Route Control 工作站。

可按以下方式插入附加 SIMATIC Route Control 工作站：

● 使用 PCS 7“扩展项目”向导

有关更多信息，请参见“如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部

分。

● 手动（将在下面介绍）

要求

已安装 SIMATIC Route Control 附加软件包并在工程师站上获得许可。
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步骤

1. 在 SIMATIC Manager 的组件视图中，选择要插入 Route Control 工作站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入了一个新的 SIMATIC PC 站。

3. 设置 SIMATIC PC 站的计算机名称：

– 为此，选择 PC 站。

– 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。
– 在“计算机名称”(Computer name) 组中输入计算机名称，或者激活“与 PC 站名称

相同的计算机名称”(Computer name identical to PC station name) 复选框。

4. 从组件视图中选择 SIMATIC 站，然后在详请视图中双击“组态”(Configuration) 对象以打
开 HW Config。
将打开 SIMATIC PC 站的硬件配置。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

6. 在硬件目录中的“SIMATIC PC 站 > 路径控制”(SIMATIC PC station > Route Control) 下，选
择所需的 Route Control 应用程序并将其拖到组态表中：

– RC 应用程序（用于 Route Control 服务器）

– RC 应用程序（备用）（用于冗余 Route Control 服务器）

– RC 应用程序客户端（用于 Route Control 客户端）

7. 在“SIMATIC PC 站 > CP 工业以太网”(SIMATIC PC Station > CP Industrial Ethernet) 硬件
目录中，选择安装在 SIMATIC PC 站中的通信处理器，然后将其拖动到 PC 站。
如果使用标准网卡，请选择“IE 常规”(IE General) 处理器。
将打开“属性 － 以太网接口”(Properties - Ethernet Interface) 对话框。

8. 在总线上为 CP 设置所需的地址：

– 如果网络适配器已连接到终端总线，请激活“IP 协议正在使用”(IP protocol is being 
used) 复选框。

– 如果网络适配器已连接到工厂总线，请激活“设置 MAC 地址/使用 ISO 协议”(Set 
MAC address / Use ISO protocol) 复选框。

– 对于通过 BCE 连接到工厂总线的网络适配器，在“常规”(General) 选项卡中输入名

称并将“选项”(Options) 选项卡的“连接的发送保持激活状态”(Send keep alive for 
connections) 组中的“间隔”(Interval) 设置为“30”。

9. 从“子网”(Subnet) 组中选择子网：

– 如果尚未建立子网，请单击“新建”(New)，然后定义一个新的网络。

– 如果已经建立子网，请在“子网”(Subnet) 组中选择所需的网络。

10.单击“确定”(OK)。
将关闭“属性”(Properties) 对话框。

11.从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

12.如果要安装附加 Route Control 工作站，请执行相同的步骤。
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更多信息

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

● 手册《过程控制系统 PCS 7；SIMATIC Route Control》(Process Control System PCS 
7; SIMATIC Route Control)

9.5.8 如何插入 OpenPCS 7 站

简介 

在 SIMATIC Manager 中，将 OpenPCS 7 站组态为 SIMATIC PC 站。它始终包含“SPOSA 
应用程序”(SPOSA Application) 对象。          

在此过程中将执行下列步骤：

● 插入 SIMATIC PC 站

● 在 HW Config 中配置硬件

然后，针对 PC 站建立的通信连接可用“站组态编缉器”的诊断功能进行检查。

如果用 PCS 7 向导创建了多项目，则会在选择相应的选项时就已插入 OpenPCS 7 站。也

可按照以下方法插入 OpenPCS 7 站：

● 使用 PCS 7“扩展项目”向导

有关更多信息，请参见“如何通过 PCS 7 向导用预组态工作站扩展项目 (页 261)”部

分。

● 手动（将在下面介绍）

步骤

1. 在 SIMATIC Manager 的组件视图中，选择要插入 OpenPCS 7 站的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入了一个新的 SIMATIC PC 站。

3. 选择该 SIMATIC PC 站，然后选择菜单命令编辑 (Edit) > 对象属性 (Object Properties)，并
输入所需名称。

4. 从组件视图中选择 SIMATIC 站，然后在详请视图中双击“组态”(Configuration) 对象以打
开 HW Config。
将打开 SIMATIC PC 站的硬件配置。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。
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6. 在硬件目录的“SIMATIC PC 站 > HMI ...”(SIMATIC PC station > HMI ...) 下，选择所需的 
SPOSA 应用程序并将其拖到组态表中：

7. 从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

更多信息

● “如何组态 OpenPCS 7 以访问 PCS 7 数据 (页 613)”部分

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

9.5.9 如何设置外部归档服务器

简介

在 PCS 7 中进行长期归档是可能的，例如，归档消息和过程值。可以在 PCS 7 工厂中将 
Process Historian 用作外部归档服务器。下面介绍了将 Process Historian 集成到 PCS 7 
项目中的步骤。 

说明

多项目中有一个 Process Historian
多项目中只能组态一个 Process Historian。 
在冗余组态中，另一个 PC 站会作为 Process Historian 的伙伴服务器。

步骤

1. 在 SIMATIC Manager 的组件视图中选择要插入外部归档服务器的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > station > SIMATIC PC station)。
在所选项目中插入一个新的 SIMATIC PC 站。

3. 选择该 SIMATIC PC 站，然后选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)，
并输入所需的 Process Historian 名称。如果该 PC 站名称与操作系统中的计算机名称不同，
则必须另外在“计算机名称”(Computer name) 下输入计算机名称。

4. 在组件视图中选择 SIMATIC PC 站，然后在详细信息视图中双击“组态”(Configuration) 对
象打开 HW Config。
将打开 SIMATIC PC 站的硬件组态。

5. 如果硬件目录不可见，请选择菜单命令“视图 > 目录”(View > Catalog)。

6. 在硬件目录中，导航至“SIMATIC PC 站 > 归档”(SIMATIC PC Station > Archive) 文件夹。
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7. 选择所需应用程序并将其拖放到组态表中：

所需的外部归档服务器 硬件目录中的应用程序

Process Historian ● “Process Historian 应用程序”适用于归档服务器

的 PC 站
● “Process Historian 应用程序（备用）”适用于 

Process Historian 的冗余 PC 站

8. 单击“确定”(OK)。
将关闭“属性”(Properties) 对话框。

9. 从菜单中选择“站 > 保存并编译”(Station > Save and Compile)。

10.继续以相同的方式插入其它 PC 站，例如用作冗余归档服务器的 PC 站。

更多信息

● 有关外部归档服务器的信息，可参考手册《过程控制系统 PCS 7；PCS7 - PC 组态》

(Process Control System PCS 7; PCS7 - PC Configuration)

● 有关 Process Historian 的信息，请参考 SIMATIC Process Historian 的文档

● 有关安装 Process Historian 的相关信息，请参见《SIMATIC；Process Historian 安装

说明；Process Historian 2013 - 安装说明》文档中的“安装 Process Historian Ready 
组件”部分

9.5.10 如何组态和下载 PC 站

简介       

通信模块（以太网）的项目特定网络设置由工程师站直接下载到 PC 站。

要求

● 已在每个 PC 站上安装以下项：

– 操作系统

– PC 站的特定软件（例如 PCS 7 工程组态系统，OS 服务器）

● 所有要下载的 PC 站都至少通过一个网络链接到工程师站。

● 操作系统网络已组态。

● PC 站的网络地址已组态。

● 终端总线上的通信协议已设置为 TCP/IP。
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● 下列设置已在每个 PC 站上完成：

– PC 站和终端总线之间用于通信的通信卡已选择。

– 工厂总线的网络地址已设置。

– PC 站的访问点已设置为“S7ONLINE：= PC 内部（本地）”(S7ONLINE: = PC internal 
(local))。

● 已创建 PCS 7 项目。

步骤

说明

请注意以下几点：

● 组态和下载附加 PC 站之前，请首先对工程师站执行以下任务。

● 组态本地 PC 站时，必须禁用“使用已组态的目标计算机”(Use configured target computer) 
复选框（见步骤 6）。

1. 在 SIMATIC Manager 中，打开 PCS 7 项目。

2. 在组件视图中，选择目标计算机。

3. 选择菜单命令“目标系统 > 组态...”(Target System > Configure...)。
将打开“组态”(Configure) 对话框。项目中选定的 PC 站输入“目标计算机”(Target Computer) 
组中。

4. 从“本地网络连接”(Local Network Connection) 下拉列表中，选择用于访问目标计算机的网
络连接。

5. 单击“更新”(Update)。
更新可访问的计算机列表。

6. 在可用计算机列表中选择所需的目标计算机（PC 站）。

说明

如果所选的 PC 站未出现在列表中，则表明有网络问题或项目组态中出现错误。

请确保选中了复选框“使用已组态的目标计算机”(Use configured target computer)（与

本地 PC 站恰好相反）。

7. 单击“组态”(Configure)。
将打开“组态：<选定的站>”(Configure: <selected station>) 对话框。

8. 在“组态：目标计算机”(Configure: Target Computer) 对话框中，单击“确定”(OK)。
将打开“信息”(Information) 对话框。

9. 单击“确定”(OK)。
组态数据传送到 PC 站。
完成的“组态”(Configuration) 步骤显示在对话框消息行中。
要激活网络连接，还必须将网络设置下载到此 PC 站。

10.单击“关闭”(Close)。
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11.对于步骤 2 中选定的计算机，选择菜单命令“目标系统 > 下载”(Target system > Download)。
将打开“下载到当前项目中的目标系统”(Download to target system in current project) 对话
框。

说明

PC 站中以太网接口的已组态网络地址必须匹配目标系统中的预设地址。

12.如果对话框给出组态数据将被覆盖的警告，请按如下所述内容进行操作：

– 初始调试期间，单击“是”(Yes)。
– 如果 PC 站处于过程模式，只可在允许通信中断时单击“是”(Yes)。
将打开“停止目标模块”(Stop target module) 对话框。

13.在“停止目标模块”(Stop target module) 对话框中，单击“确定”(OK) 进行确认。
将打开“下载”(Download) 对话框。

14.单击“确定”(OK) 进行确认。
将执行下载。
应用组态后，即可运行 PC 站。

15.对所有 PC 站重复步骤 2 至 14。

在总线（工业以太网）上切换日志

说明

操作期间不得禁用 TCP/IP 协议或 ISO 协议。因为组态的操作模式需要这些协议。

如果必须将系统中的总线切换为其它协议（例如，从 TCP 协议切换为 ISO 协议），则必

须在工程师站上临时设置一个混合协议（TCP 和 ISO）。现在，将组态数据加载到 AS 和
操作员监视系统中。

更多信息

● 《SIMATIC NET；调试 PC 站 - 手册和入门指南》(SIMATIC NET; Commissioning PC 
Stations - Manual and Getting Started) 手册
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9.6 创建工厂层级 (PH)

简介

在工厂视图中，可以工艺视角建立项目结构。在此过程中，可以按层级结构将自动化、操

作员控制和监视功能组织到工厂、单元或功能等层级中。根据相关层级文件夹的工艺意义

为其命名。      

将以下内容组织成层级文件夹：

● AS 的 CFC 和 SFC

● OS 的画面和报表

● 附加文档，如单元描述、过程变量表单和规划文档等（采用 Word 或 Excel 等格式）

所得到的项目结构即为工厂层级。

读者注意事项

下面的描述基于以下各点：

● 在中央工程师站上创建工厂层级，并根据需要，填充附加文档。这将在下文进行介绍。

● 然后，将在分布式工程师站上创建的 CFC/SFC 或 OS 画面/OS 报表分配给层级文件

夹。

组态任务概述

本概述将向您介绍创建工厂层级的步骤：

内容 位置

创建工厂层级 (页 290) SIMATIC Manager

将附加的层级文件夹插入工厂层级 (页 292) 工厂层级

指定 AS/OS 分配 (页 295) 工厂层级中的层级文件夹

分配工厂层级的对象 (页 297) 组件视图

检查工厂层级的一致性 (页 299) SIMATIC Manager
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9.6.1 组态 PH

使用 PCS 7“新建项目”向导创建 PH

使用“新建项目”(New Project) PCS 7 向导，可创建带有包含相应工厂层级 (PH) 的项目和

主数据库的 PCS 7 多项目。       

在工厂视图或过程对象视图中创建以下层级对象：

● 多项目（在 s7_Pro4_MP 中）

● 项目（在实例 s7_Pro4_Prj 中）

● 共享声明

● 工厂（在该实例中：plant(1)）

● 单元（在该实例中：Unit(1))

● 工艺功能（在该实例中：function(1))

● 主数据库（在该实例中：s7_Pro4_Lib）
在组件视图中： 
一个 S7 程序，其中包含用于以下各项的文件夹

– 源文件

– 块 (Blocks)
– 图表

– 一个用于共享声明的文件夹

在工厂视图中： 
用于以下各项的文件夹 
– 过程变量类型

– 模型

– 共享声明
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选择工厂视图

如果工厂视图不可见，则选择菜单命令“视图”(View) >“工厂视图”(Plant View)。

9.6.2 PH 设置和属性

简介

使用 PCS 7 向导创建多项目时，在 PCS 7 向导的各个步骤中所进行的默认设置或指定参

数设置将被使用（例如，层级数和 AS 分配）。可在以后更改这些设置，也可针对稍后将

要添加的层级文件夹对其进行调整。       

高层（工厂）代号 (HID) 的定义

高层代号或工厂代号 (HID) 用来依据工厂各部分的唯一功能对其进行识别。HID 根据工厂

组态按层级构建。

对工厂层级进行设置时，可指定 HID 中将自动包括哪些层级，以及名称的每个部分将拥有

多少个字符。因此，HID 包括各种层级文件夹的名称。

实例：

[NameHierarchyfolderLevel1]\[NameHierarchyfolderLevel2]
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对于各层级的每个层级文件夹，还可以指定其名称是包含在 HID 中还是从 HID 中删除。包

含在 HID 中的层级文件夹也称为“包含在代号中的层级文件夹”。

说明

为确保在整个项目中命名的一致性，要确保在组态期间为工厂视图中的层级文件夹选择适

当的命名方案。 
层级文件夹名称中的字符数不得超出为 HID 指定的字符数。

工厂层级的设置概述

设置 描述

层级数 (Number of 
hierarchy levels)

指定允许的最大层级数，最多八层。可在每层插入所需的层级文

件夹数。

画面层级以工厂层级

为基础

使用该选项，OS 画面层级就完全来自于工厂层级的组态数据。以

后编译 OS 时，此画面层级将被传送到画面树管理器。

从工厂层级获得诊断

画面 (Derive 
diagnostics screens 
from the plant 
hierarchy)

使用此选项，在维护工作站的工厂层级中生成诊断画面。 

还可以指定将要生成的诊断画面的名称是来自层级文件夹的名称

还是来自硬件组件的注释。

只能在同时设置了“从工厂层级获得画面层级”(Derive picture 
hierarchy from the plant hierarchy) 选项时才能选择此选项。

移植诊断设置 为诊断区域选择 OS 之后，将在此 OS（以及多项目中所有其它 
OS）中自动修改属性，包括启动列表的扩展部分。这些设置必须

在 PCS 7 版本的升级期间移植。

层级设置

最大字符数 (Max. 
number of 
characters)

指定此层上的层级文件夹名称允许的最多字符数（1 到 24）。
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设置 描述

包含在 HID 中 
(Included in HID)

可以选择自哪些层起的层级文件夹名称（如果已经选择包含在内）

将包含在 HID 中。不用于命名方案的层级文件夹可用于创建其

它“抽屉”（例如，用于工厂描述或过程变量表等参考文档）。

命名方案意味着，组成 HID 的名称会在消息来源 (OS) 中和 OS 
的变量名称中输入（过程变量）。

注：请记住，分配名称和编译 OS 时，变量名称不能超过 128 个
字符。名称由以下元素组成：

● 层级路径中的文件夹名称（包含服务器前缀）

● 图表名称

● 块名称

● 分隔符

● I/O 名称

带分隔符 (With 
separator)

使用此选项，分隔符可包含在 HID 中，且位于该层的层级文件夹

名称之后。 

在层级路径的文本表示中使用分隔符以在层级文件夹的名称之间

加以区分。“\”字符用作分隔符。

OS 区域 (OS area) 使用此选项，可以决定应将哪个层级看作 OS 区域。默认为第 1 
层。

过程模式中的区域特定消息需要 OS 区域定义。

9.6.3 如何针对 PH 进行设置

步骤         

1. 使用菜单命令“视图”(View) >“工厂视图”(Plant View)，在 SIMATIC Manager 中打开工厂层
级。

2. 选择层级文件夹，然后选择菜单命令“选项”(Options) >“工厂层级”(Plant Hierarchy) >“自定
义...”(Customize...)。 
如果在多项目中选择了多个项目，则可首先看到带有所选项目列表的对话框。只能在选择项
目后，才能进行以下对话框中显示的设置。

说明

这些设置起到模板的作用，会被传递给所选项中包含的所有其它项目。未选择的项目仍

保留其各自的设置。 
如果明确选择了多项目，则它所包含的所有项目都将采用您在模板项目中所做的设置。
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3. 单击“确定”(OK)。 
将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。

4. 对项目工厂层级进行设置。
（有关此主题的更多信息，请参见“PH 设置和属性 (页 288)”部分）。

5. 单击“确定”(OK)。

更多信息

● 手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

● “工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框的在线帮助
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9.6.4 PH 的命名约定

扩展基本结构      

使用 PCS 7 向导最多可创建 8 个层级（不包括层级文件夹的附加嵌套）。可在组态期间进

一步扩展此基本结构，方法是进一步添加层级文件夹和/或工艺对象。

这样操作时，请记住命名工厂层级中的文件夹/对象时存在下列规则。

文件夹/对象的命名约定

● 层级文件夹名称中不能使用以下特殊字符：[ . ] [ % ] [ / ] [ \ ] [ " ]

说明

编译 OS 时，名称中的字符 [ ' ] [ . ] [ % ] [ \ ] [ * ] [ ? ] [ : ] [ 空格 ] 将转换为替代符 $。 
ES 分隔符 [\] 将转换为 [/] 字符。 
例如，如果为 CFC 分配了名称“TICA:1”（此名称在 OS 上将变成“TICA$1”），同时

为另一个 CFC 分配了名称“TICA*1”（也将变成“TICA$1”），您将会在传送第二张图

表时收到一条错误消息，原因是该图表名称已经存在。 

● 变量名称的最大长度是 128 个字符。不过，请记住，OS 上的许多编辑窗口都不能完整

显示这 128 个字符。因此，应对 HID 的长度加以限制。

● 请记住，与某些种国家语言有关的特殊字符占用两个字符位置，因此会相应地减少名称

的最大长度。

● 请记住，所传送的文本长度取决于 OS 中的目标块的最大文本长度（变量记录，例如，

事件为 50 个字符；来源为 32 个字符）。编译 OS 时，传送的文本最长可达 255 个字

符。

补救措施：

增加用户文本字段的最大字符长度，或者选择较短的 HID。

● 传送消息的消息文本由层级路径、图表名称和块名称组成（如果您已决定将这些名称包

含在 HID 中）。

9.6.5 如何插入附加层级文件夹

简介

使用 PCS 7 向导最多可创建 8 个层级（不包括层级文件夹的附加嵌套）。可通过附加层级

文件夹和/或工艺对象来扩展由 PCS 7 向导创建的这一结构。

实施 PCS 7 组态

9.6 创建工厂层级 (PH)

工程组态系统 (V9.0 SP1)
292 配置手册, 12/2017, A5E39221328-AC



层级文件夹

层级文件夹用于在层次结构中构建工厂。它可以包含附加层级文件夹和对象：

● CFC

● SFC

● OS 画面

● OS 报表

● 设备属性

● 附加文档（例如：Excel、Word）

对象的高级标识 (HID) 来源于层级文件夹（路径）名称和对象名称（如果已决定将这些名

称包含在 HID 中）。

步骤

1. 使用菜单命令“视图 > 工厂视图”(View > Plant View)，在 SIMATIC Manager 中打开工厂层
级。

2. 选择要在其下插入附加层级文件夹的层级文件夹。

3. 选择菜单命令“插入 > 工艺对象 > 层级文件夹”(Insert > Technological Objects > Hierarchy 
Folder)。

4. 输入层级文件夹的工艺名称。

指定工艺名称

层级文件夹在插入后会显示在右侧窗口区域中。并且已为更改名称做好准备：选择带有系

统分配的名称的名称字段，并将光标置于文件夹名称的最后一个字符之后。此时，您就可

以直接使用键盘输入所需的工艺名（删除和编辑）。

9.6.6 如何在层级文件夹中插入对象

简介

在工厂视图和过程对象视图中，工艺对象 CFC、SFC、OS 画面、OS 报表及设备属性均

可插入到工厂层级中。插入对象的方法几乎是相同的。您将在下面找到有关如何在工厂视

图中插入工艺对象的说明。
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插入对象

可插入下列对象：CFC/SFC、OS 画面/OS 报表以及设备属性。 

1. 使用菜单命令“视图 > 工厂视图”(View > Plant View)，在 SIMATIC Manager 中打开工厂视
图。

2. 选择要在其下插入对象的层级文件夹。

3. 选择菜单命令“插入 > 工艺对象 >‘<所需的对象>’”(Insert > Technology Objects > "<Required 
Object>")。

插入附加文档

除自动化和工厂操作员监视所需的对象外，还可以在层级文件夹中插入附加文档（例如，

单元描述、过程变量表单及工程文档）。 

1. 选择要在其下插入对象的层级文件夹。

2. 选择菜单命令“插入 > 工艺对象 > 附加文档”(Insert > Technology Objects > Additional 
Document)。
将打开“插入附加文档”(Insert additional Documents) 对话框。将显示所有可用的应用程序。

说明

也可以创建新附加文档，方法是在“已注册的应用程序”(Registered Applications) 框中

选择类型，输入名称，然后单击“确定”(OK)。
在 PH 中即会创建附加文档。双击文档将其打开并进行编辑。

3. 单击“导入”(Import)。

4. 选择所需的附加文档。

5. 单击“确定”(OK)。
随即输入所选项。

9.6.7 在 PH 中的复制和移动规则

复制/移动/删除层级文件夹的规则

● 如果要复制或删除层级文件夹，则其所包含的所有对象也将被复制或删除。例如，在复

制时，可以一步复制整个单元。之后只需对所复制的单元执行修改（例如，到过程信号

的链接）。

● 如果要向其中复制或移动对象的目标层级文件夹不具有 AS（图表文件夹）和/或 OS 分
配，系统将会自动创建此分配（相关信息，可参考“如何指定 AS/OS 分配 (页 295)”
部分）

这表示在项目中，将在所复制的层级文件夹上输入与源文件文件夹中相同的分配。如果

多级别层级分支具有不同的分配，将保留该不同的分配。
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● 包含多个项目时，需要对目标环境中的所有 AS 和 OS 进行识别。如果无法建立唯一的

分配（没有或仅有一个 AS 或 OS），将显示可能的选项列表以供选择。再次提醒您，

如果层级分支具有不同的分配，则正如源层级分支中所指定的那样，这些任务在目标中

也是不同的。

● 如果要向其中复制/移动对象的目标层级文件夹具有 AS 和/或 OS 分配，则此分配将传

递给所有复制的对象。

● 也可以复制和移动包含带有不同分配的对象的层级文件夹。屏幕将显示警告，询问您是

否确实要复制或移动该文件夹。如果回答“是”(Yes)，则所有对象都被复制到分配给目

标层级文件夹的 AS（或 OS）。如果回答“否”(No)，则不执行任何操作。

● 如果要复制/移动的层级文件夹是模型或模型副本，请记住适用于它们的特殊规则（相关

信息，可参考“如何在 SIMATIC Manager 中处理模型 (页 560)”部分）。

更多信息

● “视图之间的关系 (页 242)”部分

● “交叉视图功能及其使用方法 (页 243)”部分

9.6.8 如何指定 AS-OS 分配

简介

必须为工厂层级中的层级文件夹分配 OS 和至少一个 AS。AS/OS 分配会在组件视图中产

生以下结果：

● 工厂层级中插入的所有 CFC 和 SFC 都存储在所分配 AS 的图表文件夹中。

● 工厂层级中插入的所有 OS 画面和 OS 报表都存储在已分配 OS 的文件夹中。

不同库版本 AS 块的块图标 

自 PCS 7 V8.1 起，在 OS 的过程画面中可以显示来自不同库版本的 AS 块的相同块图标。

如果将一个 OS 分配给多个 AS，则只可以为每个 AS 组态以下高级过程库版本的 AS 块：

● PCS 7 V7.1 SP3 的 AS 块

● 从 PCS 7  V8.1 开始的 AS 块

块图标会在 OS 编译完之后插入到过程画面中。标准画面“@PCS7TypicalsAPLV8.pld”用

作创建/更新过程画面中所有 AS 块图标的模板。 
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步骤

1. 选择要在工厂视图中为其进行 AS-OS 分配的层级文件夹。

2. 选择菜单命令“编辑”(Edit) >“对象属性”(Object Properties) 并转到“AS-OS 分配”(AS-OS 
Assignment) 选项卡。

3. 从“分配的 AS（图表文件夹）”(Assigned AS (Chart Folder)) 下拉列表中，选择要分配给所
选层级文件夹的 S7 程序。

4. 如果下级对象具有不同的分配，但是您希望所有下级对象都具有相同的分配，则选中“将所
选分配传递给所有下级对象”(Pass on selected assignment to all lower-level objects) 复选
框。

说明

“将所选分配传递给所有下级对象”(Pass on selected assignment to all lower-level 
objects)复选框仅在下级对象具有其它分配或没有任何分配时才会激活。

5. 从“分配的 OS”(Assigned OS)表中，选择要分配给所选层级文件夹的操作站。

6. 如果下级对象具有不同的分配，但是您希望所有下级对象都具有相同的分配，则选中“将所
选分配传递给所有下级对象”(Pass on selected assignment to all lower-level objects) 复选
框。

说明

如果激活“面向区域”(area-oriented) 编译模式，则只能针对 OS 区域层的 PH 文件夹更

改 OS 分配。

7. 单击“确定”(OK)。

结果

AS/OS 分配被选中，并根据您的设置确定是否将该分配传递给下级对象。

说明

如果您已经分配了项目，使项目中仅有一个 OS 或一个 AS，则不必进行 AS/OS 分配。

更多信息

● PH、IEA 和 PO 的在线帮助

● “AS-OS 分配”(AS-OS Assignment) 选项卡的在线帮助
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9.6.9 如何将对象分配给 PH

简介

也可在稍后从组件视图中将对象（例如，CFC 或 SFC）分配给工厂层级。例如，无论何时

都可先将图表直接插入组件视图，然后再创建工厂层级。如果始终在工厂视图或过程对象

视图中创建图表和画面，图表和画面会自动分配给工厂层级。 

要求

层级文件夹具有与已分配对象相同的 AS 或 OS 分配。如果目标层级文件夹具有不同的 AS-
OS 分配，则已分配对象也会移至组件视图中的此 AS/OS。

说明

如果已在工厂层级的设置中选择了“从工厂层级获得画面层级”(Derive picture hierarchy 
from the plant hierarchy) 设置，则只允许使用对应每个层级文件夹的一个相同的 OS 画面。

步骤

1. 在组件视图中选择所需的对象。

2. 按住 <Shift> 键（移动），同时将对象拖动到 PH 的所需层级文件夹中。

如果直接在 OS 中创建了 OS 画面/OS 报表，并想要在稍后将这些对象分配给工厂层级，

请执行以下步骤：

1. 在项目的组件视图中选择 OS。

2. 选择菜单命令“选项 > OS > 导入 WinCC 对象”(Options > OS > Import WinCC Objects)。

3. 在组件视图中选择所需的对象。

4. 按住 <Shift> 键（移动）的同时通过拖放，将对象从组件视图拖动到 PH 的所需层级文件夹
中。
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复制/移动后的分配

● 将层级文件夹复制/移动到已分配给不同 AS 或 OS 的层级文件夹时，所复制/移动的层

级文件夹还会接收目标文件夹的分配。

● 将对象（如 CFC、OS 画面/OS 报表）复制/移动到已分配给另一个 AS/OS 的层级文件

夹时，这些对象同样也被复制/移动到其它 AS 或 OS。

● 复制/移动带有 CFC 和 OS 画面的层级文件夹时，从这些 OS 画面到 CFC 块中对动态

对象的引用将在目标层级文件夹中得以自动更新。

说明

WinCC 中的 C 脚本引用的过程变量必须在“#define section”中定义。

复制/移动后的互连

复制/移动 CFC 时，将自动复制或删除与共享操作数的互连。 

可在 CFC 中使用菜单命令“选项 > 设置 >“复制/移动...”(Options > Settings > Copy/Move...) 
进行设置，也可在 SIMATIC Manager 中使用菜单命令“选项 > 图表 > 复制/移动的设置...”
(Options > Charts > Settings for Copying/Moving....) 进行设置。默认设置是选项“复制互

连以及操作数”(Copy interconnections with operands)。

取消 PH 分配

如果要在没有 PH 的项目中使用图表、OS 画面和 OS 报表，或者在不丢失图表、画面或

报表的情况下删除当前项目中的 PH，可通过菜单命令“选项 > 工厂层级 > 取消分配...”
(Options >Plant Hierarchy > Cancel Assignment...) 来取消给 PH 的分配。

可以在组件视图和工厂视图中使用此功能。

图表和 OS 画面之间的互连

复制/移动含有已互连画面和图表的层级文件夹时，始终需要更新画面互连。并非必须进行

明确的更新。

编译 OS 时，对 ES 变量有影响的所有更改都将更新。

实施 PCS 7 组态

9.6 创建工厂层级 (PH)

工程组态系统 (V9.0 SP1)
298 配置手册, 12/2017, A5E39221328-AC



9.6.10 如何检查 PH 的一致性

简介

可使用 PCS 7 确定组态数据是否与项目或多项目中所作的设置一致。

一致性检查

在一致性检查中将评估以下属性：

● S7 程序、CFC 和 SFC 的不唯一名称

● 层级文件夹名称中的括号

● 层级文件夹名称的长度

● 层级文件夹的层级数

● OS 区域分配的唯一性和完整性

如果选中复选框“从工厂层级获得画面层级”(Derive picture hierarchy from the plant 
hierarchy)，则将检查以下方面：

● 每个层级文件夹中的 OS 画面数量

● OS 画面名称的唯一性

将在单个选项卡中显示上述结果。 

有关选项卡中所显示测试结果的更多信息，可通过单击“帮助”(Help) 获得。

所选多项目的附加测试

说明

如果选择多项目，还要进行以下检查：

● 检查 S7 程序的名称的唯一性。检查 CFC 和 SFC 的名称在整个多项目中是否唯一。

● 检查每个类型（S7 程序、OS）是否只有一个对象在主数据库中可用。

● 当多项目中的区域文件夹具有相同名称时，将检查 OS 分配的一致性

● 在多项目的所有项目中，检查 OS 编译模式（“面向 AS”(AS oriented) 或“面向区域”(Area 
oriented)）的一致性

● 检查多项目中 PH 设置的一致性（OS 区域的级别、画面层级和诊断的起源以及 HID 相关
性）

如果选择项目或层级文件夹，则这些测试仅与该项目/层级文件夹有关。
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步骤

1. 在工厂层级中选择多项目或某个项目。

2. 选择菜单命令“选项 > 工厂层级 > 检查一致性”(Options > Plant Hierarchy > Check 
Consistency)。
将打开“一致性检查 － 日志”(Consistency Check - Log) 对话框，其中包含检查到的错误。

3. 消除这些错误，然后再次运行一致性检查。

显示检查日志

检查完成后会显示一条消息，但如果发生错误，就会输出检查日志。

也可稍后使用菜单命令“选项 > 工厂层级 > 显示检查日志”(Options > Plant Hierarchy > 
Display Check Log) 以显示日志，而不再运行检查。当最后的一致性检查显示组态数据与

所作的设置一致时，不会显示检查日志。

说明

可能会出现违反命名方案的现象，例如，在以后更改设置或将文件夹复制/移动到不同层的

情况下。系统会容许这些违例，以免在您工作时出现不必要的错误消息。

更多信息

有关检查日志的详细信息，请参考在线帮助。

9.6.11 多项目中的附加 PH 功能

特定于多项目的 PH 功能

工厂层级的功能应根据多项目工程组态的需要进行调整。这种支持始于通过 PCS 7 向导创

建多项目之时。     
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以下功能对多项目而言非常重要：

功能 描述

创建多项目 在 SIMATIC Manager 中，PCS 7 向导自动创建多项目。 
● 通过在 PCS 7 向导中选择的内容（PH、AS、OS）创建项目。

● 在 PH 的主数据库中创建三个层级文件夹，这三个文件夹用于存储过程变量

类型、模型和共享声明。

项目间一致性检查 ● 通过一致性检查可以较早地识别单一控制单元名称的多重分配。这可防止因

这些错误而取消至 OS 的数据传送过程（编译 OS 功能期间）。

● 可在所有多项目中检查 S7 程序的唯一性。S7 程序的唯一性是导入/导出向导

和诊断功能正常工作的必要条件。

● 在主数据库内，执行检查以确保只存在一个 S7 程序和一个 OS。
将 PH 设置传递给多项目

的其它项目

多项目中项目的 PH 设置可通过使用菜单命令选项 > 工厂层级 > 自定义... 
(Options > Plant Hierarchy > Customize...) 进行更改：

● 单个项目的设置

如果在多项目中选择某一个项目，可定义专用于该项目的 PH 设置。

● 多个/所有项目的相同设置

如果选择多项目中的多个项目或者选择多项目本身以显示设置对话框，则将

先显示一个附加对话框。使用此对话框选择项目模板，然后在下一个对话框

中输入 TM 设置。此模板的设置将传递给选择列表中包含的所有项目。

在多项目的所有项目中创

建/更新块图标

菜单命令选项 > 工厂层级 > 创建/更新块图标... (Options > Plant Hierarchy > 
Create/Update Block Icons...) 用于将块图标以 PH 为基础的所有画面考虑在内，

并且从选中的对象（多项目、项目、层级文件夹）开始。

在多项目中，PH 中的路径对在其它项目中进行搜索十分重要。会在多项目的所

有项目中搜索具有相同名称的 PH 结构。在其中找到的 CFC 将包含在编辑过程

中。

设置/更新块图标的大小 自 PCS 7 V8.1 起，可以为 OS 的过程画面定义高级过程库（自 V8.1 起）的块

图标大小。要设置大小，请选择菜单命令“选项 > 工厂层级 > 创建/更新块图标...”
(Options > Plant Hierarchy > Create/update block icons...)。

在“缩放块图标”(Zoom block icons) 区域输入所需的百分比值。 

实施 PCS 7 组态

9.6 创建工厂层级 (PH)

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 301



功能 描述

使多项目中的层级文件夹

保持同步

处理多项目时，某些情况下需要在多项目的所有项目或单个项目中的工厂层级部

分创建冗余文件夹。 

有以下两方面应用：

● 在 SIMATIC BATCH 中，所有项目的第一层级都需要标识为“过程单元”
(Process cell) 的文件夹。

● 通过在多项目的各个项目的工厂层级中使用相同的名称，当执行“创建/更新

块图标”（Create/Update Block Icons）和“创建/更新诊断画面”（Create/
Update Diagnostic Screens）功能时，将检测到属于一体的 AS 和 OS 部分。

多项目中的工厂层级同步功能允许您保存多组态。这也可保护项目发生（意外）

更改，而导致名称不一致。选择菜单命令选项 > 工厂层级 > 在多项目中同步... 
(Options > Plant Hierarchy > Synchronize in the Multiproject...)，可在过程对象

视图或工厂视图中启动同步功能。

重命名或修改层级文件夹

的属性

重命名或修改某个层级文件夹的属性后，将执行检查以确定源于该层级文件夹的

层级文件夹是否在多项目的其它项目中也存在。如果存在，也将重命名这些层级

文件夹并相应设置其属性。

创建/更新诊断画面 菜单命令选项 > 工厂层级 > 创建/更新块图标 (Options > Plant Hierarchy > Create/
Update Block Icons) 用于为项目或多项目中的项目创建或更新诊断画面。要求：

必须已在项目中建立诊断结构。

更多信息

● PH、IEA 和 PO 的在线帮助

9.6.12 根据 ISA-88 在层级文件夹中定义类型

简介      

可根据 ISA-88.01 标准将属性分配给 PH 中的层级文件夹。例如，在工厂管理级 (MES)，
BATCH 工厂和应用需要该“ISA-88 类型定义”。

可使用对象属性将层级文件夹的对象类型从“中性”(Neutral) 更改为“过程单元”(Process 
cell)、“单元”(Unit) 或“设备模块”(Equipment module)。 

步骤

1. 选择要在 PH 中更改其设置的对象。

2. 选择菜单命令编辑 > 对象属性 (Edit > Object Properties)
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3. 打开“ISA-88 类型定义”(ISA-88 Type Definition) 选项卡。

4. 更改对象类型，例如，从“<中性>”(<Neutral>) 更改为“过程单元”(Process cell)。

5. 单击“确定”(OK)。

结果

创建更多的文件夹时，恰好位于下面两层中的文件夹将依据各自的层级被分配“单元”(Unit) 
和“设备模块”(Equipment module) 属性。

工厂层级

下图显示了采用 ISA-88 类型定义的 3 个层级文件夹。

PH 的工艺意义

层级文件夹 符号 含义

工厂 在项目中，当前仅能创建一个过程单元。 

单元 在一个过程单元中可以定义多个单元。 

设备模块

（阶段）

在一个单元中可以定义多个设备模块，如定量给料

或装瓶机。

中性文件夹

可通过添加中性文件夹扩展 3 层层级，从而改进项目的结构，例如将单元划分为组。中性

文件夹可在任一层上创建。允许的层级（ISA-88 层级、包含中性文件夹的层）总数不得超

过八。

例如，中性文件夹可插到“单元”(Unit) 层之上。然后可将此层用作区域层。可将另一层插

在“设备模块”(Equipment Module) 层之下。然后可将此层用作控制模块层。
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“单元”(Unit) 对象类型的后继项

后继项是指在由另一单元（前导）启动的生产过程中执行操作的单元。

对于“单元”(Unit) 对象类型，可以选择来自同一项目或其它项目的不同的单元作为此单元

的“后继项”。如果后继项位于另一项目中，则它将在当前项目中以带有链接的层级文件

夹的形式插入。这在“ISA-88 类型定义”(ISA-88 Type Definition) 选项卡上通过“后继项/前
导项”(Successor/Predecessor) 按钮进行设置。

更多信息

● PH、IEA 和 PO 的在线帮助

9.6.13 如何组态系统图表中消息的自动显示和隐藏

简介

此功能的作用是使操作站/维护站能在过程模式下自动显示/隐藏来自系统图表中具有消息功

能的块的消息。         

数字系统图表

为此，所有数字系统图表都必须从组件视图移动到工厂层级中。 

对于数字系统图表，文件名称以字符“@”以及紧跟的数字开头，例如“@1....”。

有关在启动、关闭等特定过程状态下自动显示/隐藏消息的信息，请参见“在过程模式下自

动显示和隐藏消息 (页 226)”部分。

要求

AS 已在启用“生成模块驱动程序”功能的情况下编译。

步骤

1. 将项目/多项目工厂层级中的层级文件夹置于“诊断”范围之外。

2. 选择该层级文件夹。

3. 从快捷菜单中选择“对象属性...”(Object Properties...) 命令。

4. 选择“AS-OS 分配”(AS-OS Assignment) 选项卡。

5. 在“分配的 AS（图表文件夹）：”(Assigned AS (chart folder):) 区域中，从下拉列表中选择
相应的 AS。
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6. 在“分配的 OS：”(Assigned OS:) 区域中的下拉列表中选择所需的 OS/MS。
– 对于单工作站系统，OS/MS 的 PC 站
– 对于多工作站系统，OS/MS 服务器的 PC 站
– 对于 SIMATIC MS PDM，SIMATIC MS PDM 的 PC 站

7. 在组件视图中，选择例如“@1......”这样“@”字符后面跟有数字的所有数字系统图表。

8. 从快捷菜单中选择命令“剪切”(Cut)。

9. 在工厂视图中，选择第 1 步中创建的层级文件夹。

10.在快捷菜单中，选择菜单命令“粘贴”(Paste)。

结果

为了自动显示/隐藏来自系统图表中具有消息功能的块的消息，这些系统图表已从组件视图

移动到工厂层级中。
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9.7 创建主数据库

库的优点

组态期间，将项目中使用的所有对象（块、图表、源文件、过程变量类型、模型、SFC 类
型）组合在对象自己的库中是有帮助的。例如，这意味着可确保整个项目中只使用特定块

类型的一个版本。          

说明

通过一个 OS 操作不同的库版本

自 PCS 7 V8.1 起，可以通过一个 OS 对不同版本的 AS 块的块图标进行操作和监视。如

果使用主数据库，请注意只能对一个版本的 AS 块进行组态并将其下载到 AS 中。

主数据库

使用 PCS 7 向导创建多项目时，会自动创建主数据库。主数据库用于存储多项目的所有项

目的项目主数据。将项目从多项目移动到分布式工程师站以进行编辑时，还必须传送主数

据库，以便向所有组态工程师提供一个相同的数据库。 

主数据库有助于确保重复使用所定义的类型版本。主数据库与多项目一起自动归档。

项目中使用的对象和为项目进行了专门修改的对象都存储在主数据库中。举例来说，这包

括下列元素：

● 块类型

● SFC 类型

● 过程变量类型

● 模型

● 共享声明

● OS 画面

● OS 报表

此外，主数据库中还可包括下列对象。

● PCS 7 高级过程库 中的对象

● 来自供应商库的对象

● 用户创建的对象
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维护主数据库 

请仔细规划主数据库维护策略。建议在将自己创建的块类型加入到主数据库中之前，对它

们进行彻底测试或进行修改以适应项目需要。系统支持后继项更改（在生成块实例之后），

但由于块类型的集中修改或 OS 的重新编译，更改的工作量会增大。

说明

如果已经在主数据库中使用了来自 PCS 7 库的块或 SFC 类型，而且 PCS 7 库的版本已经

更改，则需要执行更新。 
“更新块类型”功能可用于同步块类型和 SFC 类型。相关信息，请参见“如何更新块类型

和 SFC 类型 (页 315)”部分。

说明

PCS 7 安装期间始终会复制所提供的库。如果编辑了所提供的库，则再次安装时所更改的

库会被原始库覆盖。 

组态任务概述

内容 位置

创建主数据库 (页 311) SIMATIC Manager

将对象复制到主数据库 (页 313) SIMATIC Manager

如何根据特定项目调整块 (页 316) SIMATIC Manager（组件视图）

创建过程变量类型 (页 510) SIMATIC Manager（工厂视图）

创建模型 (页 555) SIMATIC Manager（工厂视图）

测试库对象 (页 333) CFC 或 SFC 编辑器

建立库对象文档 (页 333) 在相关编辑器中

隐藏库 (页 312) SIMATIC Manager
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9.7.1 主数据库的对象

主数据库组态

视所使用的视图，主数据库可能包含不同的文件夹：     
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在组件视图中

在组件视图中，主数据库包含以下各项：

● 一个 S7 程序，其中包括单独的块、源和图表文件夹

● 一个共享声明文件夹

● 在详细信息窗口中的对象符号（符号表）

将多项目所需的所有块类型（工艺块、驱动程序块、通信块）复制到主数据库的块文件

夹。 

这可能是来自 PCS 7 库、供应商库或者您自己编写的块的集合。

PCS 7 库中的块适合在组态期间遇到的大部分情况下使用。如果需要为满足特殊要求而修

改块，应尽早修改；换句话说，要在将块用于项目之前修改。 

SFC 类型存储在主数据库的图表文件夹中。 

说明

SFC 类型也可以是过程变量类型或模型的一部分。

在项目中测试过要作为模板使用的 OS 画面和 OS 报表之后，会将它们复制到主数据库的

一个层级文件夹。此时，将在主数据库中创建一个 OS。可在组件视图中看到它。 

说明

此 OS 不是自动化解决方案的一部分。
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在工厂视图和过程对象视图中

在工厂层级（工厂视图或过程对象视图）中，主数据库包含分别用于过程变量类型和模型

的文件夹。这两个层级文件夹每个都有一个对 S7 程序的 AS 分配以及将它们标识为主数

据库层级文件夹的标识符。

● 共享声明

可将以下元素定义为可在各种应用程序中使用的共享声明：

– 枚举

– 单位

– 设备属性

● 过程变量类型

过程变量类型是一个 CFC，用于帮助过程工程工厂在基本自动化方面实现特定的过程

控制功能，例如液位填充控制。可以此过程变量类型为基础制作副本，然后根据特定自

动化任务进行修改并加以利用。过程变量类型的副本是过程变量。

● 模型

模型由包含以下元素的层级文件夹组成：

– CFC/SFC
– OS 画面

– OS 报表

– 附加文档

使用“导入导出助手”(Import Export Assistant) 可通过这些元素创建任意数量的副本。

● 模板

PCS 7 库“高级过程库”包含工艺功能模板。

层级文件夹的功能

可通过下列方法区分主数据库的层级文件夹和项目的层级文件夹：

● 如果复制目标不是主数据库或其中已有相同的层级文件夹，则文件夹层级会在复制/移动

过程中失去其标识符，标识符的作用是将其标识为主数据库的文件夹层级。

如果层级文件夹丢失其标识符，则以普通层级文件夹图标替换其图标。

● 不能在主数据库中显式地插入具有此标识符的任何新层级文件夹。如果创建模型和过程

变量类型时相应的文件夹已不再可用，将会在主数据库中自动创建该文件夹。

● 失去其标识符的层级文件夹在返回主数据库之后将无法再进行标识。

更多信息

● PH、IEA 和 PO 的在线帮助
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9.7.2 如何创建主数据库

简介

如果已使用 PCS 7 向导创建了多项目，则它已经包含了主数据库。如果多项目中还没有主

数据库，可以下列方式使用 SIMATIC Manager 来定义主数据库：     

● 创建一个新库并将它定义为主数据库。

● 将一个现有库定义为主数据库。

说明

每个多项目只能包含一个主数据库。该主数据库只能包含一个 S7 程序。

步骤

要求：没有将任何库定义为多项目中的主数据库。不过，如果定义了主数据库，则必须撤

消对现有主数据库的定义。可通过执行“步骤”中的第 4 步来实现此目的。

要创建一个新库作为多项目中的主数据库，请执行以下操作： 

1. 在 SIMATIC Manager 中，选择菜单命令“文件”(File) >“新建”(New)

2. 打开“库”(Libraries) 选项卡，然后输入库的名称（最好为多项目的名称）。

3. 必要时，输入存储位置（路径）。
该库即创建完成且已打开。

4. 在多项目的组件视图中选择该库，然后选择菜单命令“文件 > 多项目 > 定义为主数据库”
(File > Multiproject > Define as master data library)。
该库即被定义为主数据库。

5. 选择该库，然后选择菜单命令“插入”(Insert) >“程序”(Program) >“S7 程序”(S7 Program)。
即创建了其中包含块和源文件夹的 S7 程序。

6. 使用“插入”(Insert) >“S7 软件”(S7 Software) >“图表文件夹”(Chart Folder) 菜单命令在 S7 
程序下添加一个图表文件夹。

结果

多项目拥有了一个新的主数据库。不需要在工厂层级中显式地建立模型或过程变量类型文

件夹。创建模型或过程变量类型时会自动建立这些文件夹。 
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命名

说明

SIMATIC Manager 支持长度超过 8 个字符的名称。不过，库目录的名称不能超过 8 个字

符。因此，各库名称的前 8 个字符必须有差异。名称不区分大小写。 
请确保文件名始终与最初建立的库名称相符。在 SIMATIC Manager 中，名称更改在文件

级不起作用。

9.7.3 如何使用库

简介

此部分说明处理库时的最重要功能。请在将其它库中的对象添加到主数据库之前逐渐熟悉

这些功能。

库功能

在 SIMATIC Manager 中可以使用库的以下功能：

● 使用“库”(Libraries) 选项卡中的菜单命令“文件 > 打开 >”(File > Open >) 打开库。

● 可以使用菜单命令“文件 > 另存为”(File > Save As) 复制库，并为库指定另一名称。 

● 可以使用“库”(Libraries) 选项卡中的菜单命令“文件 > 删除”(File > Delete) 删除

库。 

● 可使用菜单命令“编辑 > 删除”(Edit > Delete) 删除库的组成部分，如图表、块和源文

件。 

● 可隐藏不使用的库，并可通过下列方式再次显示：

– 在“库”(Libraries) 选项卡中，选择菜单命令“文件 > 管理”(File > Manage)。
– 选择所需的库，然后单击“隐藏”(Hide)。 
使用“显示”(Display) 按钮可使库再次显示。

说明

建议隐藏除主数据库之外的所有库，因为主数据库包含项目中使用的所有对象。
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创建新库

1. 在 SIMATIC Manager 中，选择菜单命令“文件 > 新建”(File > New)。

2. 转到“库”(Libraries) 选项卡，必要时输入库的名称和位置。

3. 单击“确定”(OK)。 

结果

在多项目中建立了一个新库。

命名

说明

SIMATIC Manager 支持长度超过 8 个字符的名称。不过，库目录的名称不能超过 8 个字

符。因此，各库名称的前 8 个字符必须有差异。名称不区分大小写。 
请确保文件名始终与最初创建库时的名称相符。在 SIMATIC Manager 中，名称更改在文

件级不起作用。

9.7.4 如何将其它库中的对象复制到主数据库

简介

以下部分介绍如何将对象从所提供的 PCS 7 库（PCS 7 高级过程库）或从其它供应商库输

入主数据库。     

说明

AS 41x 中的块类型（在 RUN 模式下向 AS 410H 下载块类型）

每次仅将一个 PCS 7 库版本的块类型加载到 AS 上。

PCS 7 V8.1 或更高版本，可使用“CPU 410-5H 支持的类型更新”在 RUN 模式下将修改了

接口的块类型加载到 AS 中。

要求：

在 AS 中的 CPU 410-5H 的固件版本为 8.1 或更高版本。

更多相关信息，请参见 CFC 在线帮助。
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步骤

如果要复制库的一部分（例如：软件、块、画面等），请按如下所述进行操作：

1. 在 SIMATIC Manager 中，选择菜单命令文件 > 打开 (File > Open)。

2. 打开“库”(Libraries) 选项卡。

3. 选择所需的库，然后单击“确定”(OK)。
将打开库。

4. 在打开的库（源）中选择要复制的对象（例如，过程变量类型、块），然后选择菜单命令
“编辑 > 复制”(Edit > Copy)。

5. 在主数据库（目标）中选择要存储复制的对象的文件夹。

6. 从菜单中选择编辑 > 粘贴 (Edit  > Paste)。

结果

复制的对象将存储在主数据库中。

复制规则

● 如果要将提供的过程变量类型从 PCS 7 高级过程库复制到主数据库，请在“模板”
(Templates) 文件夹内仅选择所需的过程变量类型，复制它们，然后将它们粘贴到主数

据库的“图表”(Charts) 文件夹。

● 当将模板复制到主数据库时，需要注意的是：它们可能会覆盖为特定项目自定义的任何

现有块。

● 如果从不同的库复制块，块的名称（和功能）可能不同，但块编号相同。在这种情况

下，将打开一个对话框，可通过它重命名块或同步属性。

说明

同时使用库“标准库”(STEP 7)、“CFC 库”(ES/CFC)、“PCS 7 高级过程库”：

STEP 7、ES/CFC 和 PCS 7 的库中包含名称相同（但功能不同）的块以及编号相同

（但功能不同）的块。

● 相同的块名称 — CONT_C/CONT_S/PULSGEN/CTU/CTD/CTUD
对于这些块，请使用 CFC 库中的块，因为它们适宜于在 PCS 7 环境下使用。

● 相同的块号
解决方案：在块文件夹中必须为这些块分配空闲的 FB/FC 号。

– 例如：库“标准库 - S5-S7 转换块”、“标准库 - TI-S7 转换块”及“CFC 库元件”中
的 FC 61 ...125

– 例如：库“标准库 - 通信块”、“标准库 - IEC 功能块”及 CFC 中预留的 FC 清单中
的 FC 1 ... FC 40。
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● 从库复制块时符号名也会被复制。

● 如果系统检测到要插入图表中的来自某个库的块的系统属性与现有块的属性不同，则在

复制到块文件夹中时，将打开“插入功能块”(Insert Function Block) 对话框。可在此处

执行属性更新（另请参见 STEP 7 的在线帮助）。

多重背景块规则

● 如果块包含用于访问其它块（多重背景块）的代码，则还必须复制这些较低级别块的适

用版本。缺少的较低级别 FB 可在以后通过工程组态来确定。不过，无法在编译或下载

期间检测缺少的 FC。

● 请记住，用于访问块的块号存储在多重背景块的代码中。使用菜单命令选项 > 重新链

接... (Options > Rewire....) 可更改这些编号（进而更改代码），通过该菜单命令可访

问 SIMATIC Manager 中重新链接功能。例外：对于受保护的块。

9.7.5 如何更新块类型和 SFC 类型

简介

在主数据库中加入新版本的块类型或 SFC 类型后，或者在主数据库中修改块类型后，可使

用“更新块类型”功能列出仍然使用已修改块类型或 SFC 类型老版本的所有组件。也可选

择整个多项目中其修改过的块类型或 SFC 类型应进行更新的组件。         

模板的块（过程变量类型、模型）也将会更新。

如果发现 SFC 类型存在差异并且已安装 VXM 可选软件包，则可在执行更新前通过“显示

差异”(Display differences) 命令按钮调用 Version Cross Manager (VXM)。VXM 将显示所

比较的 SFC 类型之间的详细差异。

说明

AS 41x 中的块类型（在 RUN 模式下向 AS 410H 下载块类型）

每次仅将一个 PCS 7 库版本的块类型加载到 AS 上。

自 PCS 7 V8.1 起，可使用“CPU 410-5H 支持的类型更新”在 RUN 模式下将修改了接口

的块类型加载到 AS 中。

要求：

在 AS 中的 CPU 410-5H 的固件版本不低于 8.1。
更多相关信息，请参见 CFC 在线帮助。
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步骤

1. 选择主数据库块文件夹中的一个或多个块或者在图表文件夹中的一个或多个 SFC 类型或者
图表文件夹。

2. 选择菜单命令“选项”(Options) >“图表”(Charts) >“更新块类型...”(Update Block Types...)。
将打开“更新块类型”(Update Block Types) 对话框。

3. 选择要进行检查，以比较其与在主数据库中选择的块/SFC 类型的差异的 S7 程序。

4. 单击“继续”(Continue)。
将检查所有选定的 S7 程序，并会打开用于选择块/SFC 类型的另一个对话框。此处可获得
有关更新块/SFC 类型的可能结果的信息。

5. 指定要为各个 S7 程序更新的块类型/SFC 类型：将选择所有要更新的块/SFC 类型。必要
时，可取消选择全部不需要更新的类型。
如果不存在要更新的块/SFC 类型，将不会显示块/SFC 类型。在此情况下，请关闭对话框。

6. 单击“完成”(Finish)。

结果

将在所有选定的 S7 程序中更新块/SFC 类型并显示一个日志。

说明

更改块后，需进行更新。请仅在主数据库中更改块。

更多信息

● 有关对话框的在线帮助

9.7.6 修改块

9.7.6.1 修改块以适应项目要求

简介

PCS 7 库中的块适合在组态期间遇到的大部分情况下使用。如果必须为特定项目和满足特

殊要求而修改块，请先修改块，再在项目中使用它们，然后将它们存储在主数据库

中。       
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组态任务概述

可修改下列块特性和属性：

内容 位置

更改块 I/O 的属性 (页 317) LAD/CSF/STL 编辑器

锁定消息属性以免其在块实例中发生更改 
(页 318)

PCS 7 消息组态

翻译消息文本 (页 319) SIMATIC Manager

设置显示设备的语言 (页 320) SIMATIC Manager

导出/导入操作员文本和显示文本 (页 322) SIMATIC Manager

说明

只能在库中按项目要求修改块。并且假定您是在主数据库中修改块。

9.7.6.2 如何更改块 I/O 的属性

简介

块类型的块 I/O 具有可按项目要求进行修改的属性。

步骤

1. 在主数据库的块文件夹中选择要修改的块。

2. 选择菜单命令“编辑 > 打开对象”(Edit > Open Object)。
将启动 LAD/STL/FBD 编辑器（如果块受到保护，屏幕会显示一条消息）。在界面的树形视
图中选择对象时，将会显示其内容。

3. 在右侧窗口中，选择所需的 I/O，然后选择菜单命令“编辑 > 对象属性”(Edit > Object 
Properties)。
将打开“属性”(Properties) 对话框。

4. 选择“属性”(Attributes) 选项卡
属性将以表格形式显示。

5. 在此表中修改属性及其值，或者重新输入。
如果单击“属性”(Attribute) 列，将在下拉列表中显示此 I/O 可能的属性选项。

修改属性并不难，因为输入属性时会进行语法检查，出现错误或缺少信息时会发出通知。

说明

有关属性的使用和它们的描述的信息，可参考 LAD/STL/FBD 编辑器在线帮助。

实施 PCS 7 组态

9.7 创建主数据库

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 317



请注意下列特殊情况

● 以 OS 上的操作员将会使用的语言组态属性“S7_string_0”、“S7_string_1”、“S7_unit”
和“S7_shortcut”的文本。如果想在 OS 上以更多语言提供这些文本，必须在 WinCC 
词典中将它们翻译过来。

● “S7_enum”属性可用于为块参数分配枚举。此外，在 ES 中建立了具有用户选择名称

的“枚举”数据类型。此外，将为使用枚举的块参数创建数据类型参数“BOOL”、

“BYTE”、“INT”、“DINT”、“WORD”或“DWORD”。此参数将被赋予“S7_enum”

系统属性。ES 定义的“枚举”名称作为值使用。可以几种不同的语言组态“枚举”名

称。

● 修改与 OS 上的面板或块结构同步的属性（例如，S7_m_c）时，互连面板或编译 OS 
时可能会发生错误。

● 可以下列方式区分属性：

– 带有“类型字符”的属性

该属性指块类型。对这些属性（例如，S7_link）进行的更改也将应用于所有的现有

块实例。

– 带有“实例字符”的属性

该属性指各个实例。对这些属性（例如，S7_visible）进行的更改不会追溯性地影响

现有块实例。它们只会起默认选项的作用。

例外：在属性“S7_string_0”，“S7_string_1”，“S7_unit”及 “S7_shortcut”中，如

果用户未更改块实例中的值，CFC 将应用这些修改。

● 从 CPU 中回读参数

在回读对话框中，可设置要回读的参数：

– 所有（S7_read_back = true；默认设置）

– 可受监控的参数 (S7_m_c := 'true')
– 标记的参数 (S7_read_back := 'true')
– 无

该块被完全排除在回读内容之外

(S7_read_back = false)。

更多信息，请参见“如何下载到所有目标系统 (页 660)”部分。 

9.7.6.3 锁定消息属性以免其在块实例中发生更改

消息文本和消息属性

在使用“用户可组态消息类别”功能时，请参见“用户可组态消息类别”部分中的信息。
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控制过程时消息对操作员很重要。 在消息的协助下，可监视和评估过程。 PCS 7 库的块

类型中预设了消息文本和消息类别。 举例来说，消息有“实际值过高”、“外部错误”

和“给料过量”。 发生相应事件时，自动化系统便会发送这些消息。     

用户可根据具体需要修改这些消息文本及其属性： 可在块类型中或还在块实例中修改消息

文本及其属性。 如果要避免消息属性在块实例中被修改，可锁定实例。

步骤 

1. 在主数据库的块文件夹中选择要修改的块。

2. 在快捷菜单中选择菜单命令“特殊对象属性 > 消息...”(Special Object Properties > 
Message...)。
将打开“消息组态”(Message Configuration) 对话框。 这会显示为此块组态的所有消息。

3. 在要锁定的文本后的列  中放置复选标记。

4. 单击“确定”(OK) 来应用更改。

结果

文本被锁定。

说明

如果块实例已存在，可通过重复块导入将消息属性的锁定传递给实例。

更多信息

● 有关修改操作员和消息文本的更详细信息，请参见组态手册《过程控制系统 PCS 7；操

作员站》(Process Control System PCS 7; Operator Station)。

9.7.6.4 如何翻译消息文本

多语言消息文本

可输入多种语言的消息文本。PCS 7 库中的块预备有德语、英语、法语、意大利语和西班

牙语的消息文本。

如果需要当前未提供的块消息文本的语言，可设置该语言并翻译文本。
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用于块类型实例的过程

1. 在 SIMATIC Manager 中，选择菜单命令“选项 > 显示设备的语言...”(Options > Language 
for Display Devices...)。

2. 在“可用语言”(Available Languages) 列表中，选择要在 OS 上显示的语言。单击“ -> ”将
所选语言传送到“项目中已安装的语言”(Languages Installed in the Project) 列表。

3. 在“项目中已安装的语言”(Languages Installed in the Project) 组中选择要设置为标准语言
的语言，然后单击“作为标准”(As standard)。

4. 单击“确定”(OK)。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

9.7.6.5 如何设置显示设备的语言

显示设备的语言

显示设备的语言与从 ES 到 OS（编译 OS）的传送消息有关。如果未选择所需的语言，消

息文本将传送到文本库中错误的列并且不会在过程模式中出现。

步骤

1. 在 SIMATIC Manager 中，选择菜单命令“选项 > 显示设备的语言...”(Options > Language 
for Display Devices...)。

2. 例如，将 PCS 7 块的语言设置为“德语（德国）”。

3. 在“Languages installed in the project（项目中已安装语言）”列表中选择要定义为标准的
语言，然后单击“Standard（标准）”。

4. 单击“确定”(OK)。

对于您的项目，可在可用语言列表中选择若干种语言并将其中一种定义为标准。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

● 对话框的在线帮助
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9.7.6.6 如何创建自己的主数据库块

创建自己的块

可以创建自己的 PCS 7 兼容的 AS 块或面板，并将它们存储在主数据库中。

有关创建自己的面板的信息，请参见手册《过程控制系统 PCS 7；块编程指令》(Process 
Control System PCS 7; Programming Instructions Blocks)。

本文还介绍了如何在库中存储自己的块，以及如何使用要传送到主数据库的安装程序将这

些块安装在目标计算机上。

9.7.6.7 使用 OS 画面的面板和块图标

面板和块图标

在 OS 上在过程模式下监控块实例需要相应的面板。面板包含专门用于操作员监控的工艺

块的所有元件的图形表示。面板在 OS 的单独窗口中进行描述，并通过块图标（通常位于 
OS 总览显示中）来打开。         

对于 PCS 7 库的每个工艺块类型，都已有相应的面板。块图标将在执行菜单命令后自动生

成。也可自行创建或修改面板与块图标。 

可在过程画面中为每个块类型创建若干个块图标，以描述某个类型的各种具体实例。

说明

在 CFC 中，可在块的对象属性中将块图标分配给特定实例。

PCS 7“高级过程库”的块类型面板

PCS 7 库块类型面板的显示和操作员输入选项在《PCS 7 过程控制系统；高级过程库》

(PCS 7 Process Control System; Advanced Process Library) 手册中有介绍。

创建自己的面板

有关创建自定义模板的逐步操作说明，请参见《PCS 7 过程控制系统；APL 设计指南》

(Process Control System PCS 7; APL Style guide) 编程手册。
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创建自己的块图标

有关生成和修改块图标的信息，可参见组态手册《过程控制系统 PCS 7；操作员站》

(Process Control System PCS 7; Operator Station)。

更多信息

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

9.7.6.8 如何导入/导出块、I/O 和消息

简介

可从过程对象视图中导出整个表的内容，以将修改过的参数值和互连外部分配给复制的单

元。随后可再次导入修改过的数据。此方法可用作导入/导出助手的替代。                 

参数、信号和消息的导入/导出

要在过程模式下显示过程，请使用为工厂操作员显示测量值、操作限制、测量单位和块操

作员文本的面板。 

对面板的参数、信号和消息进行集中更改时，请在过程对象视图中按以下步骤操作：

● 将表的内容导出到一个文件。

● 使用标准应用程序（MS Excel、MS Access）编辑文本。

● 导入修改过的文本。

过程对象视图中的参数、信号和消息的所有可编辑字段都将导入/导出。所选层级文件夹及

其所有下级层级文件夹中的 CFC 都将包含在内（视在过程对象视图中的选择）。

导出后会收到一条消息，指示 CSV 文件和存储数据的路径。其中的单元格内容显示在双引

号中并以分号分隔，以便可使用 MS Excel 或 MS Access 进行编辑。

说明

实例在上述导入/导出过程中被编辑，因此失去了进行集中更改的能力。

导出当前视图

从过程对象视图中，还可以导出包含过滤器和显示设置的任何组合视图。随后，可在其它

工具中对导出内容进行进一步处理以用于其它目的，例如编制文档。
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导出文件包含当前视图中的所有列和可见字段，包括相应的列标题。

语言

可使用 PCS 7 以任何语言存储所有操作和显示文本。唯一的要求是该语言已安装在项目

中。

在 SIMATIC Manager 中，使用菜单命令选项 > 显示设备的语言 (Options > Language for 
Display Devices) 可以显示可用的语言。所提供语言的数目是在安装 Windows 时指定的

（系统特性）。 

块导出和导入文件的结构

块的导出文件和导入文件包含以下 10 列：

列 列标题 含义

1 - 3 层级 (Hierarchy)；图表 (Chart)；块 (Block)； 块的标识

4 - 9 块注释 (Block comment)；创建块符号 (Create 
block symbol)；块符号 (Block symbol)；操作和

监视属性 (Operating and monitoring property)；
允许的回读 (Reading back allowed)；块组 (Block 
group)

导出/导入的属性

10 块类型 有关块的信息

I/O 导出和导入文件的结构

I/O 的导出文件和导入文件包含以下 18 列：

列 列标题 含义

1 - 4 层级 (Hierarchy)；图表 (Chart)；块 (Block)；I/
O；

I/O 的标识

5 - 14 I/O 注释 (I/O comment)；值 (Value)；单元 
(Unit)；互连 (Interconnection)；信号 (Signal)；
标识符 (Identifier)；文本 0 (Text 0)；文本 1 (Text 
1)；用于测试 (For test)；枚举 (Enumeration)

导出/导入的属性

15 - 18 数据类型 (Data type)；I/O；块类型 (Block 
type)；I/O 类型 (I/O type)。

有关 I/O 的信息
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I/O 导出和导入文件的规则

● 用于导入 I/O 的 CSV 文件必须至少包括用于标识 I/O 的前 4 列。其余列是可选列，可

按任意顺序使用。

● 导入时将忽略包含 I/O 相关信息的列。

● 导入时将忽略空文本字段（单元格）。因此在导入过程中只能创建或修改文本，而不能

将它们删除。

● 如果为某个块列出了若干个 I/O，导致该块有若干个行，则块注释也将显示相应的次数。

如果修改注释，则导入过程中将只导入块注释的最后一行。

消息导出和导入文件的结构

消息的导出文件和导入文件包含下列 20 列：

列 列标题 含义

1 - 5 层级 (Hierarchy)；图表 (Chart)；图表注释 (Chart 
comment)；块 (Block)；I/O；子号码 
(Subnumber)；

I/O 的标识

6 - 19 块注释 (Block comment)；类别 (Class)；优先级 
(Priority)；来源 (Origin)；OS 区域 (OS area)；
事件 (Event)；批次 ID (Batch ID)；操作员输入 
(Operator input)；自由文本 1 (Free text 1)；自由

文本 2 (Free text 2)；自由文本 3 (Free text 3)；
自由文本 4 (Free text 4)；自由文本 5 (Free text 
5)；信息文本 6 (Info text 6)；反应时间 7 
(Reaction time 7)；描述 8 (Description 8)；原因 
9 (Cause 9)；操作员操作 11 (Operator action 
11)；结果 12 (Consequence12)

导出/导入的属性

20 块类型 (Block type) 有关 I/O 的信息

消息导出和导入文件的规则

● 用于导入消息文本的 CSV 文件必须至少包括用于标识 I/O 的前 5 列。其余列是可选列，

可按任意顺序使用。

● 导入时将忽略空文本字段（单元格）。因此在导入过程中只能创建或修改文本，而不能

将它们删除。
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导出当前视图

1. 设置所需的视图（选择相应的选项卡，然后选择“过滤器”(Filter) 和“显示”(Display)）。

2. 选择菜单命令选项 > 过程对象 > 导出当前视图... (Options > Process Objects > Export 
Current View...)。

将生成导出文件（CSV 文件）；其中包含有关树中所选对象（项目、层级文件夹或 CFC）

的所有选定信息。

导出块

1. 选择菜单命令选项 > 过程对象 > 导出块 (Options > Process Objects > Export Blocks)

将创建导出文件（CSV 文件），其中包含有关树窗口中所选对象（项目、层级文件夹或 
CFC）的块的所有属性和信息。 

导出 I/O

1. 选择菜单命令选项 > 过程对象 > 导出 I/O... (Options > Process Objects > Export I/Os...)。

将生成导出文件（CSV 文件），其中包含选定 I/O 的所有属性，以及树中所选对象（项

目、层级文件夹或 CFC）的 I/O 的相关信息。

将写入过程对象视图中的信息（不使用过滤器的“参数”(Parameters) 和“信号”
(Signals)），包括标题。 

导出所有 I/O

1. 选择菜单命令选项 > 过程对象 > 导出所有 I/O...(Options > Process Objects > Export All I/
Os...)。

将生成导出文件（CSV 文件），其中包含有关树中所选对象（项目、层级文件夹或 CFC）

的所有 I/O 的全部属性和信息。

所有 I/O 是指也包括过程对象视图中未选定的 I/O。

将写入过程对象视图中的信息（不使用过滤器的“参数”(Parameters) 和“信号”
(Signals)），包括标题。 

导出消息

1. 选择菜单命令选项 > 过程对象 > 导出消息... (Options > Process Objects > Export 
Messages...)。

将生成导出文件（CSV 文件），其中包含有关树中所选对象（项目、层级文件夹或 CFC）

的所有消息文本（和块信息）。
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附加编辑

说明

编辑导出文本时切勿覆盖管理信息（语言标识或路径指定）。

只能编辑以“T-ID=”开头的行。

说明

始终在程序内部打开文件，例如，在使用 MS Excel 时，通过菜单命令文件 > 打开 (File > 
Open) 打开文件，而不要通过双击打开文件。

切勿使用电子表格编辑工具编辑第一列或第一行，并且不要删除任何分号。

开始导入之前备份导出

导入前会显示一个对话框，可在其中检查导入文件（名称和内容）。也可在其中设置“执

行备份导出”(Execute backup export) 选项。

使用选项“执行备份导出”(Execute backup export) 可在开始导入之前备份当前项目数据

（属性）。

导入块

1. 选择菜单命令选项 > 过程对象 > 导入块... (Options > Process Objects > Import Blocks...)。

2. 选择所需的导入文件（CSV 文件）。

所选导入文件中块的属性和信息将导入到所需项目中。它们被分配给块。

导入块文本

1. 选择菜单命令选项 > 过程对象 > 导入块文本...(Options > Process Objects > Import Block 
Texts...)。

2. 选择所需的导入文件（CSV 文件）。

所选导入文件中所有 CFC 的块文本将导入到所需项目中。这样，您便将文本分配给了指定

过程变量（层级、图表、块、I/O）的块。

导入 I/O

1. 选择菜单命令选项 > 过程对象 > 导入 I/O... (Options > Process Objects > Import I/Os...)。

2. 选择所需的导入文件（CSV 文件）。

所选导入文件的 I/O 属性和信息将导入到所需项目中。它们将分配给指定过程变量（层级、

图表、块、I/O）的 I/O。
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导入 I/O 文本

1. 选择菜单命令选项 > 过程对象 > 导入 I/O 文本...(Options > Process Objects > Import I/O 
Texts...)。

2. 选择所需的导入文件（CSV 文件）。

所选导入文件中所有 CFC 的全部 I/O 的文本将导入到所需项目中。这样，您便将文本分配

给了指定过程变量（层级、图表、块、I/O）的 I/O。

导入消息

1. 选择菜单命令选项 > 过程对象 > 导入消息... (Options > Process Objects > Import 
Messages...)。

2. 选择所需的导入文件（CSV 文件）。

所选导入文件的消息文本将导入到所需项目中。它们将分配给指定过程变量（层级、图表、

块）的块。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》

● 有关对话框的在线帮助

9.7.7 使用过程变量类型

简介

通过 CFC 生成新的过程变量类型之后，即会将过程变量类型自动保存到主数据库的“过程

变量类型”(Process tag types) 文件夹中。过程变量类型将在此主数据库中进行管理。可使

用以下功能：     

功能概述

下面是对使用过程变量/过程变量类型时的一些重要功能的概述。
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在选择图表或过程变量类型之后，可通过在 SIMATIC Manager 中选择“选项 > 过程变量”
(Options > Process tags) 菜单命令使用这些功能。

功能 用途

创建/更改过程变量

类型

● 从 CFC 创建过程变量类型：

– 选择要为其分配参数描述和信号的块和图表的 I/O。

– 选择包含消息的、要分配消息文本的块。

● 更改现有过程变量类型

● 检查现有过程变量与过程变量类型之间的不一致性，并同步任何

可能的不同之处。

同步 修改过程变量类型时，项目中的过程变量将自动同步。 

如果在过程变量类型和过程变量之间发现不一致（例如，由于自动同

步期间无法访问项目的所有过程变量），可以显式运行同步操作。

分配/创建导入文件 为创建过程变量，必须将导入文件分配给相应的过程变量类型。使

用“将导入文件分配给过程变量类型”(Assign an import file to a 
process tag type) 向导执行以下任务： 
● 分配现有导入文件

● 打开并检查已分配的导入文件

● 创建和分配新导入文件

导入 导入过程变量类型的数据

将过程变量类型作为过程变量从主数据库复制到指定的目标项目。然

后，导入数据。生成的过程变量数量取决于导入文件中的条目数。

导入结果是，根据指定的层级路径，在目标项目中为导入文件的每一

行生成此过程变量类型的过程变量。

导出 导出过程变量类型的过程变量数据

可使用以下选项： 
● 选择要用于单个导出的过程变量。

● 选择较高级别的层级文件夹或项目节点，以便选择所有较低级别

的过程变量进行导出。

导出结果是，在相关导出文件中为找到的过程变量类型的每个过程变

量创建一行。

更多信息

● “如何从 CFC 创建过程变量类型 (页 510)”部分

● “如何更改过程变量类型 (页 511)”部分
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● “如何将过程变量与过程变量类型同步 (页 519)”部分

● “导入期间发生了什么？ (页 631)”部分

● “导出期间发生了什么？ (页 635)”部分

● PH、IEA 和 PO 的在线帮助

9.7.8 使用模型

简介    

模型是通过主数据库中包含所需 CFC 的层级文件夹来创建的。在主数据库中存储和管理新

模型。可使用以下功能：

功能概述

下面是对使用模型/副本时的一些重要功能的概述。
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在 SIMATIC Manager 中使用菜单命令“选项 > 模型”(Options > Models) 可访问这些功能。

功能 用途

创建/修改模型 可通过导入/导出助手 (IEA) 按如下所述创建模型：

● 选择要为其分配参数和信号描述以及要导入的块和图表的 I/O。

● 选择包含消息的、要分配消息文本的块。

● 将导入文件的数据分配给模型数据。

如果得到一个模型，其中每个选定 I/O 和消息都分配给导入文件的一

列。

则修改现有模型和更改列结构或列标题时，对当前 IEA 文件结构的分

配将不再正确。在这种情况下，必须选择合适的 IEA 文件或修改文

件。

如果存在已修改模型的副本，也可对副本进行修改。

导入 导入模型数据

从主数据库中将模型作为副本复制到指定的目标项目。然后，导入数

据。将根据导入文件中的条目数生成同样数量的副本。 

导入结果是，根据层级路径中的信息在目标项目中为导入文件的每一

行创建此模型的一个副本。

导出 导出模型的副本数据

可使用以下选项： 
● 选择一个模型以将其单独导出。

● 选择上级层级文件夹或项目节点以选择所有下级副本进行导出。

导出结果是，在相关导出文件中为模型的每个副本创建一行。

更多信息

● “如何创建模型 (页 555)”部分

● “导入期间发生了什么？ (页 631)”部分

● “导出期间发生了什么？ (页 635)”部分

● PH、IEA 和 PO 的在线帮助
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9.7.9 如何保存共享声明

简介

如果已使用 PCS 7 向导创建了多项目，则主数据库已经包含了“共享声明”(Shared 
Declarations) 文件夹。然后用此文件夹存储可用于各种应用程序的共享声明。如果该文件

夹尚不存在，则可明确创建“共享声明”(Shared Declarations) 文件夹。   

“共享声明”(Shared Declarations) 文件夹包含以下子文件夹：

● 枚举

● 单位

● 设备属性

共享声明

可将以下元素定义为共享声明：

● 枚举 (Enumerations)
可以使用枚举为数据类型为“BOOL”、“BYTE”、“INT”、“DINT”、“WORD”

和“DWORD”的块或图表 I/O 参数值定义文本表示。枚举变量中的各个值被赋予适当的

文本，并且这些文本在 I/O 上显示。每个枚举变量中可以分配多个值。

● 单位

测量单位（例如 mbar、l/h、kg）是最多包含 16 个字符的文本。可以在块或图表 I/O 的
参数和互连描述中输入。例如，在过程画面中显示块 I/O 的值时会使用单位。默认情况

下可以使用 CFC 基本设置中包含的所有测量单位。

● 设备属性 (Equipment properties)
设备属性是单元的参数，如，外壳材质、体积等。设备属性的类型定义为“共享声

明”。此类型的实例在 SIMATIC BATCH 中使用，并且可单独修改其属性。

步骤

1. 选择多项目的主数据库。

2. 选择菜单命令插入 > 共享声明 > 共享声明 (Insert > Shared Declarations > Shared 
Declarations)。
将创建“共享声明”(Shared Declarations) 文件夹，且其中包含“枚举”(Enumerations)、“单
位”(Units) 和“设备属性”(Equipment properties) 子文件夹。

3. 声明枚举变量时，选择“枚举”(Enumerations) 文件夹，然后选择菜单命令插入 > 共享声明 
> 枚举 (Insert > Shared declarations > Enumeration)，接下来选择菜单命令插入 > 共享声
明 > 值 (Insert > Shared declarations > Value)。
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4. 声明单位时，选择“单位”(Units) 文件夹，然后选择菜单命令插入 > 共享声明 > 单位 (Insert > 
Shared Declarations > Unit)。

5. 如果要声明设备属性，则选中“设备属性”(Equipment Properties) 文件夹，然后选择菜单命
令插入 > 共享声明 > 设备属性 (Insert > Shared Declarations > Equipment Property)。

多项目中的附加功能

共享声明功能是针对多项目的需要而定制的。以下更新功能对多项目而言非常重要：

菜单命令 用途

选项 (Options) > 共享声明 
(Shared Declarations) > 在多

项目中更新 (Update in 
Multiproject)

可在此处选择以下更新方法：

● 合并多项目中所有项目的共享声明

● 将某个项目的共享声明导出到其它项目中

“选项 > 共享声明 > 显示完整

日志”(Options > Shared 
Declarations > Display Full 
log)

将打开一个完整日志，其中列出最近一次同步多项目中的

共享声明时发生的所有错误。

如果最近一次更新所有项目时并未发生错误，将不生成日

志。

选项 (Options) > 共享声明 
(Shared Declarations) > 检查

似然性 (Check Plausibility)

检查枚举值是否唯一。

“选项 > 共享声明 > 显示似然

性检查的完整日志”(Options > 
Shared Declarations > 
Display Full log Plausibility 
Check)

将打开共享声明似然性检查的完整日志。如果在多项目的

某些项目中检测到错误或警告，则可在此看到这些项目的

列表。为每个列出的项目创建了一个日志。可通过先选择

项目然后再选择菜单命令“共享声明 > 日志...”(Shared 
Declarations > logs...) 来打开日志文件。

更多信息

● SIMATIC Manager 在线帮助
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9.7.10 如何测试库对象

测试库对象

建议在将对象存储在主数据库中之前对其进行彻底测试。使用您用来创建各个待测试对象

的工具的编译、下载和测试功能。       

● 成功地测试对象之后将它们存储在主数据库中。 

● 测试后，将过程变量和模型声明为过程变量类型或模型。这些对象随后将自动存储在主

数据库中。

要求 

由于测试始终在 AS 中执行，因此必须可从工程师站访问 AS。如果模型包含 OS 画面，请

在 OS 中测试相应的 OS 画面。

更多信息

● 相关工具（例如 CFC 编辑器）的在线帮助

9.7.11 如何建立库对象文档

建立库对象文档        

如果要建立库对象文档，请使用用于创建库对象的工具的文档建立功能和打印功能（例如，

CFC 编辑器功能或 LAD/STL/FBD 编辑器中的功能）。 

更多信息

● 相关工具（例如 CFC 编辑器）的在线帮助
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9.8 分配多项目进行分散编辑（多项目工程组态）

读者注意事项

如果现在就想在分布式工作站上并且用多个编辑器同时编辑多项目（包括主数据库），请

注意以下部分。      

如果不想对多项目进行分散编辑，可跳过以下部分，继续阅读“配置硬件”部分。 

简介

可以在分布式工作站上编辑多项目中的各个项目，这样便可通过多个编辑器同时处理较小、

较得心应手的项目。

与其它方法相比，先对项目进行分散编辑，而后在中央工程师站服务器上对项目间功能进

行合并，这种方法最为有效。

尽管项目分布在多个工程师站上，但可以随时读取其它项目。例如，可以采用这种方法来

复制功能和访问库。

说明

即使多项目仅包含一个项目，也应始终使用多项目。这种情况下，不需要对其进行分散编

辑。
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要求

如果要将项目分布在网络内的不同计算机上，则务必始终满足以下条件： 

● 这些项目位于可以进行读写访问的共享文件夹中。

– 建立多项目之前，必须将要在其中定位多项目或各个项目的文件夹设置为共享文件

夹。

– 在网络内，共享名称必须是唯一的。

– 切勿更改多项目中包含的资源（文件夹）共享及共享名称。

原因：在多项目中插入项目时，PCS 7 会生成对此项目位置的引用。该引用依赖于

所包含资源的共享及共享名称。

– 只有使用项目在多项目中所属的共享名称才能找到该项目。

– 为安全起见，不应将整个驱动器共享。

– 只能在一个层级上共享文件夹。

● 必须将 PCS 7 安装在包含项目的文件夹所在的计算机上。PCS 7 提供了访问项目所必

需的数据库服务器功能。

● 如果已为加入到多项目中的项目组态了消息，则在使用面向项目的消息号分配时，应确

保 CPU 的消息号范围不重叠。如果使用面向 CPU 的消息号分配，则不会发生这样的

重叠。

如果执行项目间功能，建议将所有项目合并到一台编程设备/个人计算机上。

当项目分布在不同计算机上时，如果要执行项目间功能，则应遵守以下条件： 

● 在整个编辑过程中，能够通过网络访问项目和多项目所在的所有计算机。

● 切勿在执行项目间功能时进行编辑。

建议

以下建议适用于处理多项目的情况：

● 由一位工程师对多项目进行集中管理。由这位工程师创建项目的结构。此人还需分布要

进行分散编辑的项目，然后将这些项目重新返回到多项目（包括同步项目间数据以及执

行项目间功能）。

以下活动应仅在中央工程师站上进行：

– 移动、复制以及删除多项目中的项目

– 将项目移出多项目以进行分散编辑

– 完成分散编辑后将项目合并到多项目中

● 对于一个项目应有多少个站，无法给出一般性建议。建议分布式工程师站上的项目只有

一个 AS 或 OS。
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● 只将实际需要编辑的 PCS 7 对象移动到分布式工程师站上。这意味着多项目中的其它

所有对象均可在其它分布式工程师站上进行编辑。

● 在分布项目时，谨记可用的项目编辑器数量。

说明

如果项目中仅有一个 OS，务必要在中央工程师站上重新编译此 OS。这样可确保与自

动化系统的项目间连接结构的正确性。

使用 SIMATIC BATCH 进行多项目工程组态的规则

注意

对于使用 SIMATIC BATCH 的多项目工程组态，只有在满足了某些条件及采取了附加步

骤的情况下，才能在分布式工程师站上进行分布式工程组态（包括测试在内）。 
有关此主题的更多信息，可访问 Internet (https://support.industry.siemens.com/cs/cn/zh/
view/23785345)。

更多信息

● “在网络和多项目中工作的限制 (页 336)”部分。

9.8.1 在网络和多项目中工作的限制

限制    

在多项目中工作时须注意以下条件：

● 允许用于 PCS 7 的操作系统必须安装在中央工程师站，以便在网络中运行。相关信息，

请参见《PCS 7 自述文件》（Internet 版本；请参见“AUTOHOTSPOT”）。这同样适

用于分布式工程师站。

● 必须采用 UNC 表示法指定项目在网络内的存储位置：\\计算机名称\共享名称\存储路径

，不带驱动器盘符（即，不是“d:\Projects\Storage path...”）。

● 含有项目的文件夹必须已与相关 PC 上的其它项目编辑器进行了共享。共享名称必须是

唯一的。

● 存储了项目之后不能修改存储路径！

● 在多项目内，所有项目和 S7 程序都必须具有唯一名称。
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● 在对包含 OS 的项目进行分散编辑后，必须在中央工程师站上重新编译每个 OS。为加

快编译速度，可在“编译和下载对象”(Compile and Download Objects) 对话框中禁用未

经修改的对象（使用 SIMATIC Manager 中的菜单命令 PLC >“编译和下载对象”(Compile 
and Download Objects)）。

● 不能将先前面向项目的消息号概念与新的面向 CPU 的消息号概念相混淆。

注意

关于在网络中组态的安全信息

在网络中执行组态时，确保只有获得授权的人员可访问中央服务器或共享驱动器。 
这不应仅通过操作系统和 PC 网络层面的措施加以保证。

有关 PCS 7 访问保护的信息，请参见“通过访问保护来保护项目/库 (页 182)”部分。

使用 SIMATIC BATCH 进行多项目工程的规则

说明

对于使用 SIMATIC BATCH 的多项目工程，只有在满足了某些条件及采取了附加步骤的情

况下，才能在分布式工程师站上进行分布式工程组态（包括测试在内）。 
有关此主题的更多信息，可访问 Internet (https://support.industry.siemens.com/cs/cn/zh/
view/23785345)。

更多信息

● “在分散编辑后合并项目（多项目工程） (页 615)”部分

● “编译和下载 (页 657)”部分

● STEP 7 在线帮助

9.8.2 处理步骤概述

分布前

不存在有关何时将项目移动到工程师站的绑定规范。下表说明了“强制/可选”(Mandatory/
Optional) 列中必须或可以在分布前执行的步骤。 
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下文中，在结构上按照此步骤序列对执行组态进行了说明。 

活动 信息所在部分： 强制 可选

创建具有（所有）

项目（结构）的多

项目

创建 PCS 7 项目 X  

组态 SIMATIC 和 PC 站  X

创建工厂层级 X  

创建主数据库 X  

为多项目中的所有

项目创建基本组态

组态硬件  X

创建网络连接  X

创建 SIMATIC 连接  X

分布 -> 分布式处理 -> 合并

下面列出的处理步骤也反映了建议的处理顺序。

活动 信息所在部分： 位置

将分布式处理的项

目移动到分布式工

程师站

如何将项目移动到分布式工程师站 
(页 339)

集中式工程师站

SIMATIC Manager

项目的分散编辑 如何在分布式工作站上继续编辑项目 
(页 341)

分布式工程师站

再次在集中式工程

师站上合并项目

如何将分布式工作站上编辑过的项目移动

到中央工程师站 (页 616)
集中式工程师站

SIMATIC Manager

分布前或合并后

“强制/可选”(Mandatory/Optional) 等级有助于确定在分布后必须执行还是可以执行此活

动。

活动 信息所在部分： 强制 可选

执行交互项目功能 如何将不同项目的子网合并到多项目中 
(页 617)

多项目中的交互项目连接 (页 456)

X

X

 

组态数据的编译/下
载

编译和下载 (页 657) X  
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9.8.3 如何存储多项目中的项目

要求

● 多项目位于其它所有工程师站都有权访问的中央工程师站上。

● 多项目包含库（尤其是含有模型和过程变量类型的主数据库）。

存储项目

可用以下方式创建将要插入到多项目中的项目：     

● 在中央工程师站上创建项目，然后将其移动到分布式工程师站中进行编辑。

相关信息，请参见“如何将项目移动到分布式工程师站 (页 339)”部分。

● 在分布式工程师站上创建项目（包含 HW 组态），稍后将它们插入到多项目中。

相关信息，请参见“如何将分布式工作站上编辑过的项目移动到中央工程师站 
(页 616)”部分。

步骤

1. 指定项目的存储位置。使用 Windows 资源管理器创建所需的文件夹结构。 
请遵守以下部分中的信息：

– 分配多项目进行分散编辑（多项目工程组态） (页 334) 
– 在网络和多项目中工作的限制 (页 336) 

2. 在 SIMATIC Manager 中，选择菜单命令“选项”(Options) >“自定义”(Customize)，然后设
置项目、多项目和库的存储位置。遵守 DOS 命名约定。

更多信息

● SIMATIC Manager 在线帮助

9.8.4 如何将项目移动到分布式工程师站

要求

● 项目的物理位置位于中央工程师站，且包含在多项目中。

● 可通过网络访问分布式工程师站。

● 当工程师站上安装了 SIMATIC PDM 时：

PdmAssetService 已停止。
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步骤

1. 在 SIMATIC Manager 的组件视图中，选择要移动到分布式工程师站的多项目中的项目。

2. 选择菜单命令“文件 >另存为...”(File > Save as ...)。

3. 进行以下设置：

– 选中“添加到多项目”(Add to multiproject) 复选框。

– 从相应的下拉列表中选择“当前多项目”(Current multiproject) 条目。

– 启用“替换当前项目”(Replace current project)选项。

– 输入分布式工程师站上所需的存储位置（路径）（采用 UNC 表示法）。

4. 单击“确定”(OK)。

结果

● 将会在分布式工程师站上创建与中央工程师站的项目完全相同的副本。该副本会自动插

入到多项目中并替换原始项目。

● 现有的原始项目将从多项目中删除，但它仍然在中央工程师站上。可将原始项目保留为

备份，也可以将其删除。

说明

必须先删除此备份，才能将所复制的项目复制回其原来位置（同一文件夹名称）。

说明

同样，也可将项目保存在数据介质上，然后传递此介质进行分散编辑，也可使用“归

档”(Archive) 功能将项目归档，然后传递数据介质上的归档。

在项目中应用 SIMATIC PDM

当工程师站上安装了 SIMATIC PDM 时：

可以再次启动 PdmAssetService。
建议：使用“允许自动启动/停止”(Allow automatic start/stop) 选项启动 SIMATIC PDM 
Asset 服务。
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从多项目中删除项目（备选）

说明

也可按如下所述将项目移动到分布式工程师站：

1. 在 SIMATIC Manager 的组件视图中，选择要从多项目中删除的项目。

2. 选择菜单命令“文件 > 多项目 > 删除以进行编辑...”(File > Multiproject > Remove for Editing...)
将打开“选择目录”(Select Directory) 对话框。

3. 选择一个目录，然后单击“确定”(OK)。
结果

该项目将被标记为“删除项目以进行编辑”(project removed for editing)，并呈灰色显示。

与上述步骤相反，在删除了某个项目后，将无法使用“归档”(Archive)、“另存为”(Save 
As) 或“编译 OS”(Compile OS) 功能。

更多信息

● “在分散编辑后合并项目（多项目工程组态） (页 615)”部分

● “如何将分布式工作站上编辑过的项目移动到中央工程师站 (页 616)”部分

9.8.5 如何在分布式工作站上继续编辑项目

要求    

在分布式工程师站上安装了编辑所需的所有 PCS 7 软件组件。

项目的分散编辑

对项目进行分散编辑时，可执行以下不受限制的功能：

● 所有非交互项目功能

● 以下部分功能可以照常执行：

– 单纯的编辑工作

– AS 的编译

– 通过预选模块下载 AS（不使用“PC 内部（本地）”(PC internal (local)) 选项）

在分布式 ES 上执行以下任务时，还需执行一些特殊操作：

● 通过分布式工程师站的接口模块直接下载 AS

● 在过程模式下测试 OS（OS 模拟）
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通过分布式 ES 的接口模块下载 AS

如果出于测试目的想要下载 AS，请在项目中执行以下操作：

1. 使用合适的 CP 模块在项目中插入一个本地 SIMATIC PC 站。

2. 组态从此 OS 到 AS 的 S7 连接（组态连接）。

如果要在过程模式下在工程师站上测试 OS（“启动 OS 仿真”(Start OS Simulation) 快捷

菜单），则无论编程设备/PC 接口如何设置，都需要执行上述两个步骤。另外，还需要执

行以下步骤： 

1. 在 WinCC 项目管理器中自定义计算机名称。

说明

在将项目复制或移回到中央工程师站之前，必须先恢复到更改前的状态。

更多信息

● “如何将分布式工作站上编辑过的项目移动到中央工程师站 (页 616)”部分

实施 PCS 7 组态

9.8 分配多项目进行分散编辑（多项目工程组态）

工程组态系统 (V9.0 SP1)
342 配置手册, 12/2017, A5E39221328-AC



9.9 组态自动化系统硬件（SIMATIC 站）

概述

硬件配置涉及以下主题：     

● 定义项目特定的目录配置文件 (页 344) 

● 导出/导入硬件配置 (页 345) 

● 组态步骤概述 (页 348) 

● 时间同步原理 (页 364) 

● 在 PROFIBUS DP 中组态分布式 I/O（标准） (页 369) 

● 针对 RUN 模式下的组态更改 (CiR) 在 PROFIBUS DP 上组态分布式 I/O 设备 (页 401)

● 在 PROFINET IO 中组态分布式 I/O（标准） (页 379)

● 针对 RUN 模式下的组态更改 (CiR) 在 PROFINET IO 中组态分布式 I/O 设备 (页 420)

● 组态高精度时间戳硬件  (页 367) 

● 如何激活确认触发报告 (ATR) (页 368) 

● 如何在 CPU-STOP 模式下下载组态 (页 595) 

9.9.1 硬件组态概述

简介

硬件配置包括在 SIMATIC Manager 和 HW Config 中组态相应自动化级别（AS、OS、
BATCH、路径控制、OpenPCS 7）的工厂。可以创建分布在各个项目中的 SIMATIC 400 
站，并组态所需的 I/O 和通信硬件。   

用户可根据工厂的结构在 PCS 7 OS 中组态各种项目类型。例如，可组态具有一个或多

个 OS 服务器或 OS 客户端的过程单元。通常，使用多工作站项目并创建多个 OS 服务器

和 OS 客户端。

此外，可以在硬件配置中创建和组态冗余组件（例如，冗余 OS，使用 H 站）。
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组态任务概述

本概述将介绍执行各个组态步骤的建议顺序，以及进行组态工作时所要使用的工具：

内容 位置

将所有 SIMATIC 400 站添加到项目。

将工程师站、操作站、BATCH 站、Route Control 工作站、外

部归档服务器和 OpenPCS 7 站作为 PC 站插入项目中。

SIMATIC Manager

将硬件组件添加到 SIMATIC 400 站。

插入硬件组件以及属于特定 PC 站的应用程序。

HW Config

读者注意事项

对于多项目工程，项目中通常已经存在 SIMATIC 400 站和 PC 站。以下部分介绍如何通过

将硬件组件添加到 SIMATIC 400 站而继续操作。

如果尚未组态 PC 站，请先通读“组态 SIMATIC 和 PC 站 (页 270)”一章中的以下部分，

然后再继续。

更多信息

有关为操作站配置硬件的信息，另请参考组态手册《过程控制系统 PCS 7；操作站》

(Process Control System PCS 7; Operator Station)。

9.9.2 定义项目特定的目录配置文件

项目特定的目录配置文件的优点

可在每个多项目中为硬件存储特定的目录配置文件。这样可以确保多项目中各个项目上的

每位工作人员都使用相同的硬件。此项目特定的目录配置文件可以集中使用（通过网络访

问），也可与其它分散编辑数据一起存储在分布式工作站上。     
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设置项目特定的目录配置文件

1. 在 HW Config 中选择菜单命令选项 > 编辑目录配置文件 (Options > Edit Catalog 
Profiles)。 
将打开两个目录配置文件：“标准”配置文件以及尚未包含任何组件的“空”配置文件。

2. 将所需的文件夹和模块从标准配置文件窗口拖动到“空”配置文件窗口。也可使用菜单命令
插入 > 文件夹 (Insert > Folder)，根据需要调整结构。

3. 使用菜单命令配置文件 > 另存为 (Profile > Save As) 保存新的目录配置文件。

将创建新的目录配置文件。该文件随即出现在“硬件目录”(Hardware Catalog) 窗口的“配

置文件”(Profile) 选择列表中，可在该列表中将其选定。

导出项目特定的目录配置文件

为使目录配置文件可在其它工作站上使用，可按如下步骤导出目录配置文件：

1. 在 HW Config 中选择菜单命令选项 > 编辑目录配置文件 (Options > Edit Catalog Profiles)。

2. 选择菜单命令配置文件 > 导出 (Profile > Export)。

3. 选择要导出的目录配置文件并设置目标导出路径。

目录配置文件以 *.dat 格式复制至已组态目标。还可以将文件保存到磁盘上，以此来转发文

件。

导入项目特定的目录配置文件

1. 在要使用目录配置文件的工作站上，在 HW Config 中选择菜单命令选项 > 编辑目录配置文
件 (Options > Edit Catalog Profiles)。

2. 选择菜单命令配置文件 > 导入 (Profile > Import)。

3. 设置源路径，然后选择要导入的目录配置文件。

目录配置文件随即被导入，并出现在硬件目录的“配置文件”(Profile) 选择列表中。

说明

可以使用菜单命令配置文件 > 删除 (Profile > Delete) 删除不需要的目录配置文件。

9.9.3 导出/导入硬件配置

简介

不仅可以在项目中编辑站组态（例如通过保存或打开），还可以将其导出到文本文件（ASCII 
文件、CFG 文件），对其进行编辑（修改），然后再独立于项目将其重新导入。还可以导

出和导入输入和输出的符号名。
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应用

可按如下所述使用导出/导入功能，例如：

● 从硬件工程组态工具导入数据

● 可以使用电子介质（例如电子邮件）分布站组态

● 导出文件可以使用字处理系统打印出来，也可进行编辑以形成文档。

在何处对此进行了介绍？

有关导入和导出硬件配置的详细描述，可参考“导入/导出硬件配置 (页 645)”部分。

9.9.4 组态 SIMATIC 400 站（CPU、CP 和集中式 I/O）

9.9.4.1 树立地址分配的概念

简介

在开始硬件配置之前，首先要建立分配地址的概念。各网络彼此独立，具有各自的地址数

值范围。 

分配期间，我们对以下地址进行区分：

● 节点地址

● 输入/输出地址（I/O 地址）

节点地址

节点地址是可编程模块的地址（PROFIBUS、PROFINET IO、工业以太网地址）。需要这

些地址以便对子网的各个节点进行寻址，例如，在通过工厂总线（工业以太网）将用户程

序下载到 CPU 时。有关在子网中分配节点地址的详细信息，可参考关于工作站联网的部

分。 

输入/输出地址（I/O 地址） 

需要输入/输出地址（I/O 地址）以便在用户程序中读取输入或设置输出。

准则：当在 HW Config 中将模块置于 SIMATIC 400 站时，PCS 7 会分配输入及输出地址。

这意味着每个模块都有自己的起始地址，也就是第一个通道的地址。由此开始地址可得出

其它通道的地址。为了便于使用，可为地址分配符号名（符号表）。
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工厂组态选项 

通过下图可大体了解插入了节点地址和 I/O 的一些工厂组态。

1) PROFINET IO 系统：最大 100 Mbps；最多 255 个节点 

2) DP 主站系统：最大 12 Mbps；最多 126 个节点；配置文件：PROFIBUS DP

说明

对于高精度时间戳

● PROFINET IO 必须连接到固件版本最高为 V8.2 的 SIMATIC 410 站。

● 必须通过 CP 443-5 Extended 或内部 PROFIBUS DP 接口将 PROFIBUS DP 连接到 
SIMATIC 400 站。
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9.9.4.2 组态步骤概述

概述

下表提供了各种组态步骤及相关工具的总览。     

内容 位置

创建 SIMATIC 400 站 (页 349) SIMATIC Manager

在 SIMATIC 400 站中插入模块 (页 350) HW Config

插入通信处理器 (CP, Communication Processor) 
(页 351) 

HW Config

设置 CPU 属性 (页 354) HW Config

设置过程映像 (页 357) HW Config 

组态容错系统（H 系统） (页 362) 

有关详细信息，请参见手册《过程控制系统 PCS 7；
容错过程控制系统》(Process Control System PCS 7; 
Fault-tolerant Process Control Systems)。

HW Config

组态故障安全系统（F 系统） (页 363) 

有关详细信息，请参见手册《自动化系统 S7-400F/
S7-400FH，故障安全系统》(Automation Systems 
S7-400F/S7-400FH, Fail-safe Systems)。

HW Config 

设置时间同步 (页 366) HW Config

组态标准的分布式 I/O (页 369) HW Config

针对 RUN 模式下的组态更改 (CiR) 组态分布式 I/O 
(页 406) 

HW Config

为输入和输出地址分配图标 (页 353) HW Config（符号表）

组态 PA 设备 (页 426) PDM

组态诊断中继器 (页 423) SIMATIC Manager + HW Config

组态智能现场设备 (页 430) PDM

组态 HART 设备 (页 428) PDM

组态 Y 连接器和 Y 耦合器 (页 425) HW Config

组态高精度时间戳硬件 (页 367) HW Config

激活确认触发报告 (ATR) (页 368) HW Config

将组态下载到 CPU (页 595) HW Config

实施 PCS 7 组态

9.9 组态自动化系统硬件（SIMATIC 站）

工程组态系统 (V9.0 SP1)
348 配置手册, 12/2017, A5E39221328-AC



建议的任务顺序 

最好按下面所示的顺序执行组态过程单元和为其分配参数时所涉及的任务：

任务顺序

创建工作站

如何创建 SIMATIC 站 (页 349) 

调用用于组态 HW 的应用程序

布置中央机架

在机架中布置模块

如何在 SIMATIC 站中插入模块 (页 350) 
插入和组态分布式 I/O
分配图标

指定模块/接口的属性

设置 CPU 属性 (页 354) 
设置过程映像 (页 357) 

保存组态和一致性检查

将组态下载到目标系统

如何将组态下载到 CPU (页 595) 

从目标系统上传到编程设备（例如，出于维修目的而重新加载）。

更多信息

● HW Config 在线帮助

9.9.4.3 如何创建 SIMATIC 400 站

简介               

在多项目工程中，可能已在项目中创建了自动化系统。通过以下方法，可插入附加的自动

化系统： 

● 使用 PCS 7“扩展项目”向导

相关信息，可参考“如何使用预组态工作站扩展项目 (页 261)”部分。

● 如果不使用任何提供的包，则需要手动插入（在后面说明）
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SIMATIC 400 站

在创建自动化系统时，需要一个配有电源、CPU 和以太网通信处理器（使用集成以太网接

口的 CPU 时可省去）的 SIMATIC 400 站。然后组态集中式和分布式 I/O 以及所需的任何

其它模块。以下部分将说明如何在项目中插入各个组件并设置其属性。

步骤

在开始组态和分配参数之前，项目中需要有一个可在项目的直接下级插入的 SIMATIC 400 
站。然后可以设置 SIMATIC 400 站的属性。 

1. 在 SIMATIC Manager 组件视图中选择要添加到其它自动化系统的项目。

2. 选择菜单命令“插入 > 站 > SIMATIC 400 站”(Insert > Station > SIMATIC 400 station)。
在所选项目中将插入一个新的 SIMATIC 400 站。

3. 重复此步骤以添加更多的自动化系统。

可以根据需要，从 SIMATIC 400 站快捷菜单中选择“对象属性”(Object Properties) 菜单命

令来更改名称。

更多信息

● “如何将模块插入到 SIMATIC 400 站中 (页 350)”部分

9.9.4.4 如何将模块插入到 SIMATIC 400 站中

简介

创建了 SIMATIC 400 站之后，需从硬件目录向该站添加硬件组件。     
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硬件目录

打开 HW Config 时通常会显示硬件目录。如果不是这样，请使用菜单命令“视图 > 目录”
(View > Catalog) 在 HW Config 中将其打开。

在该目录的下方位置，可以看到当前所选组件的部件编号和简要说明。请将此部件编号与

现有组件的部件编号进行比较。这样便可确保选择了正确的组件。

说明

在硬件目录中，可从不同规约（标准、PCS 7 等）中进行选择。所有规约都是基于“标

准”规约的，是此规约的子集。 
第一次开始进行硬件配置时，默认情况下会显示“PCS 7_Vx.y”规约。此规约显示了针对 
PCS 7 Vx.y 发布的所有模块和设备的当前版本。 
如果不能在此规约中找到所需模块（例如，发布用于 PCS 7 的旧型号 CPU），请选择“标

准”(Standard) 规约，然后从中选择所需模块。请注意，模块的默认设置可能因模块而异。

有关获准使用的模块的信息，请参见产品概述《过程控制系统 PCS 7；已发布模块》

(Process Control System PCS 7; Released Modules)。 
可创建单独的规约，使其包含常用的模块和设备：相关信息，请参见“定义项目特定的目

录配置文件 (页 344)”部分。

过程

有关使用 IO 模块连接工作站的信息，请参见以下各部分：

● “如何在基于 PROFIBUS DP 现场总线的分布式 I/O 中组态模块 (页 374)”部分

● “如何在基于 PROFINET IO 现场总线的分布式 I/O 中组态模块 (页 384)”部分

9.9.4.5 如何插入通信处理器

用于连接到工厂总线的 CP 443-1

通过工厂总线（工业以太网）在自动化系统、工程师站或操作员站以及路径控制工作站之

间建立连接时，可使用 CP 443-1 通信处理器。 

说明

如果使用带集成以太网接口的 CPU，则可以使用该接口连接到工厂总线。这样便无需 CP 
443-1 通信处理器。
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插入 CP 443-1

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 在硬件目录中选择“SIMATIC 400 > CP-400 > 工业以太网...”(SIMATIC 400 > CP-400 > 
Industrial Ethernet ...)，然后拖动所需 CP。
确保在此选择的排列与实际硬件的排列匹配。
插入 CP 后，将打开“属性 － 以太网接口 CP 443-1”(Properties - Ethernet Interface 
CP 443-1) 对话框。

3. 选中复选框“设置 MAC 地址/使用 ISO 协议”(Set MAC address/Use ISO protocol)，然后分
配所需的 MAC 地址（例如 08.00.06.01.00.12 或所用 CP 的预设地址）或接受默认地址。
确保该地址在总线上唯一。

4. 输入 IP 地址和子网掩码，或禁用“IP 协议正在使用”(IP protocol is being used) 复选框。

5. 单击“新建”(New)，稍后使用更有意义的名称替换名称“Ethernet(1)”。

6. 然后单击“确定”(OK) 两次。
将关闭“属性”(Properties) 对话框。

用于与分布式 I/O 连接的 CP 443-5 Extended

除了 CPU 中集成的 PROFIBUS DP 接口（或作为替代接口），还可以使用 CP 443-5 
Extended 作为连接分布式 I/O 的接口。每增加一个 CP 443-5 Extended，都可以插入额外

的 DP 链，并且在理论上可对 126 个额外的 DP 从站进行寻址。 

说明

高精度时间戳与 IM 153-2 结合使用，或是在通过集成的 PROFIBUS DP 接口或 CP 443-5 
Extended 进行路由（通过 ES 和工厂总线为 DP/PA 从站分配参数）时使用。

添加 CP 443-5 Extended

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 在硬件目录中选择“SIMATIC 400 > CP-400 > PROFIBUS ...”，然后拖动所需的 CP 并将其
添加到 SIMATIC 400 站中。
插入 CP 后，将打开“属性 － PROFIBUS 接口 CP 443-5 Ext”(Properties - PROFIBUS 
Interface CP 443-5 Ext) 对话框。

3. 为 DP 主站分配所需的 PROFIBUS 地址
（“参数”(Parameter) 选项卡；“地址：”(Address:) 列表框）。

说明

地址 1 和 126 是 DP 从站的默认地址。不要在项目中使用默认地址。
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4. 单击“新建”(New)，稍后使用更有意义的名称替换名称“PROFIBUS(1)”。

5. 选择“网络设置”(Network Settings) 选项卡，然后将传输速率设置为“1.5 Mbps”并设置
“DP”配置文件。

6. 然后单击“确定”(OK) 两次。
将关闭 PROFIBUS 接口的“属性”(Properties) 对话框。

更多信息

● HW Config 在线帮助

9.9.4.6 如何向输入及输出地址分配符号

简介            

组态模块时，无需在 SIMATIC Manager 中启动符号表（符号编辑器），便可向输入及输

出地址分配符号。 

相关信息，可参考“硬件与软件之间的自由分配 (页 211)”部分

说明

当使用菜单命令“目标系统 >下载到模块...”(Target system > Download to Module...) 下载

到站时，并不会下载所分配的符号。 
结果：使用菜单命令“目标系统 > 上传到 PG”(Target system > Upload to PG) 上传到站组

态，将不会显示任何符号。

步骤 

1. 选择要向其地址分配符号的数字/模拟模块。

2. 选择菜单命令“编辑 > 符号...”(Edit > Symbols...)。
将打开符号表。

3. 为所列地址输入所需的符号。

4. 单击“确定”(OK)。

提示：

单击对话框中的“添加符号”(Add Symbol) 按钮时，需要以符号形式输入地址的名称。

更多信息

● HW Config 在线帮助
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9.9.4.7 设置 CPU 属性

概述

在 HW Config 中，会自动为 PCS 7 输入 CPU 属性。它们适合大多数应用场合。相关信

息，可参考“CPU 的默认参数值 (页 363)”部分。 

下表包含 PCS 7 最重要的 CP 属性设置。     

内容 位置

设置 CPU 启动模式（见下文） HW Config（对象属性）

设置 OB 85（I/O 访问错误）（见下文） HW Config（对象属性）

设置过程映像 (页 357) HW Config（对象属性）

调整本地数据（参见下文） HW Config（对象属性）

设置 CPU 启动模式

S7-400 CPU 能够采用以下启动类型：

● 暖启动

● 冷启动

● 热启动

暖启动 

在暖启动时，将使用系统数据和用户地址区域的“基本设置”从头重新开始执行程序。非

保持性定时器、计数器和存储器位都将被复位。所有数据块及其内容都将被保留。

重启动（暖启动）S7-400 时（例如，通过将模式选择器从 STOP 更改为 RUN 或接通电

源），将在循环程序执行开始 (OB 32 － OB 38) 前对组织块 OB100 进行处理。默认情况

下，所有具有特殊启动行为的 PCS 7 块都安装在 OB100 中。

暖启动 = PCS 7 和普通应用的默认设置
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冷启动

冷启动仅在需要以下某一功能时的异常情况下使用：

● 在冷启动期间，将从 OB1 中的第一个命令开始读取过程映像输入表并执行用户程序。

● SFC 在 RAM 中所创建的数据块将被删除，而其它数据块具有来自加载存储器的默认

值。

● 过程映像和所有的定时器、计数器和存储器位都将被复位，无论它们是否被设置为具有

保持性。

说明

在 PCS 7 过程控制系统和 PCS 7 库的块中使用 S7-400 CPU 时，不允许进行冷启动。

热启动 

在热启动时，将在程序中断时指针所指的位置恢复程序执行（定时器、计数器和存储器位

不会被复位）。

说明

在 PCS 7 过程控制系统中使用 S7-400 CPU 时，不允许进行热启动。

设置启动模式

1. 在 HW Config 中选择 CPU。

2. 选择“编辑”(Edit) >“对象属性”(Object Properties)。
将打开“属性 – CPU...”(Properties - CPU...) 对话框。

3. 打开“启动”(Startup) 选项卡。
建议：应用默认设置。

4. 在“通电后启动”(Startup after Power On) 下设置所需的启动类型。

5. 单击“确定”(OK)。

设置 OB 85（I/O 访问错误） 

如果更新过程映像时出错（模块不存在或有缺陷）且在组态期间未制止 OB 调用，则 CPU 
的操作系统会调用 OB 85。 

如果希望针对 I/O 访问错误 (I/O AAE) 激活 OB 85 调用，则建议激活“仅限进入和离开错

误”(Only for incoming and outgoing errors) 选项。这样便不会因为重复调用 OB 85 而增

加 CPU 的周期时间，可是如果激活“对于每次访问”(For each individual access) 选项则

会发生这种情况。
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“仅限进入和离开错误”(Only for incoming and outgoing errors) 选项是 PCS 7 的默认设置

除了已组态的反应“仅限进入和离开错误”(Only for incoming and outgoing errors) 之外，

模块的地址空间也会影响 OB85 的启动频率：

● 对于地址空间达到双字的模块（例如，具有多达 32 个输入或输出的数字模块，或具有

两个通道的模拟模块），OB85 只启动一次。

● 对于具有更大地址空间的模块，OB85 的启动频率与访问它时所需的双字命令数相同，

例如，对于 4 通道模拟模块为两次。

组态针对 I/O 访问错误作出的响应

1. 在 HW Config 中选择 CPU。

2. 选择菜单命令“编辑”(Edit) >“对象属性”(Object Properties)。
将打开“属性 – CPU...”(Properties - CPU...) 对话框。

3. 选择“周期/时钟存储器”(Cycle/Clock Memory) 选项卡。

4. 从“I/O 访问区域的 OB 85 调用”(OB 85 call for I/O access areas) 下拉列表中选择“仅限进
入和离开错误”(Only for incoming and outgoing errors) 设置。

5. 单击“确定”(OK)。

修改本地数据

CPU 中只有有限的内存用于存放当前所执行块的临时变量（本地数据）。此本地内存（即

本地数据堆栈）的大小取决于具体的 CPU。本地数据堆栈用于存储以下元素： 

● 块的本地数据中的临时变量

● 组织块中的启动信息

● 有关参数传送的信息

● 梯形图程序的中间逻辑结果

创建组织块时，可声明仅在块运行时可用的临时变量 (TEMP)。它们随后将被覆盖。首次

访问前，必须对本地数据进行初始化。每个组织块的启动信息还需要 20 个字节的本地数

据。

按优先级分配本地数据

本地数据要求是按照优先级进行分配的。

默认情况下，在各优先级间均分本地数据堆栈。这意味着每个优先级都有各自的本地数据

区域。这样可确保高优先级及其 OB 都有用于存放其自身本地数据的空间。 

各优先级在本地数据堆栈中的存储器大小不必完全相同。通过为 S7-400 CPU 设置合适的

参数，可以为各优先级设置大小不同的本地数据区域。可取消选择不需要的优先级。这样
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就扩展了可供其它优先级使用的 S7-400 CPU 存储区域。程序执行期间将忽略已取消选择

的 OB，从而节省了计算时间。 

在 Web 上的 FAQ 中对本地数据的计算进行了介绍。

修改本地数据

1. 在 HW Config 中选择 CPU

2. 选择菜单命令“编辑”(Edit) >“对象属性”(Object Properties)。
将打开“属性 – CPU...”(Properties - CPU...) 对话框。

3. 选择“存储器”(Memory) 选项卡，然后根据需要调整本地数据。
更多相关信息，可参考在线帮助。

4. 单击“确定”(OK)。

说明

确保还要将已为 CiR（运行中修改组态）组态的任何预留考虑在内。

设置过程映像

相关信息，可参考“设置过程映像 (页 357)”部分。

更多信息

● “CPU 的默认性能参数 (页 363)”部分

● HW Config 在线帮助

9.9.4.8 设置过程映像

简介    

PCS 7 库中各模块的驱动程序块在查询当前信号状态时并不直接访问 I/O，而是访问 CPU 
系统存储器中的内存区域以及分布式 I/O：过程输入映像 (PII) 和过程输出映像 (PIQ)。此

过程映像既包括数字输入和输出，又包括模拟输入和输出。 

过程映像从 I/O 地址 0 开始，到 HW Config 中设置的上限结束。 
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更新过程映像

过程映像由操作系统自动定期更新。

编辑 CPU 的过程映像 

开始当前循环处理 开始下一循环处理

← OB 1 的当前循环时间 →  

输出 PIQ 更新 PII 编辑

OB 1 或周期性中

断

输出

PIQ
更新 PII 编辑

OB 1 或周期性中

断 

等等 →

过程映像的优点

与直接访问 I/O 模块相比，直接访问过程映像时，CPU 在一个程序周期内的过程信号映像

是一致的。如果输入模块上的信号状态在程序执行期间发生变化，则在下一周期中更新该

过程映像之前，将会一直维持该过程映像中的信号状态。

过程映像的大小

对于 PCS 7，过程映像的大小必须大于或等于所使用的输入及输出数。默认情况下，第一

个模拟输出模块在过程映像中的基地址为 512。建议：将输入及输出过程映像的大小设置

为较高的值。这样便为以后的模拟模块预先保留空间。 

设置过程映像的大小

1. 在 HW Config 中选择 CPU。

2. 选择菜单命令“编辑”(Edit) >“对象属性...”(Object Properties...)。
将打开“属性 – CPU...”(Properties - CPU...) 对话框。
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3. 选择“周期/时钟存储器”(Cycle/Clock Memory) 选项卡，然后设置过程映像的大小。

4. 单击“确定”(OK)。

说明

过程映像的默认大小取决于 CPU。

相关信息，可参考“CPU 的默认参数值 (页 363)”部分

过程映像分区

除了过程映像（PII 和 PIQ）之外，还可以为 S7-400 CPU 指定多达 15 个过程映像区（特

定于 CPU，从 1 号最高到 15 号）。 

说明

请注意以下事项：

● 必须将每个输入/输出地址都分配给过程映像区。

● 分配给过程映像区的每个输入/输出地址将不再属于 OB1 过程输入/输出映像。

● 输入/输出地址在 OB 1 过程映像以及所有过程映像区中均只能分配一次。

● 确保信号和信号处理（模块及相应的驱动程序）在同一 OB 中执行。
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在 I/O 模块的硬件配置期间分配给过程映像（见下图）。 

设置过程映像区

1. 在 HW Config 中，选择要分配给过程映像区的 I/O 模块。

2. 选择菜单命令“编辑”(Edit) >“对象属性...”(Object Properties...)。
“属性 - ...”(Properties - ...)。

3. 转到“地址”(Addresses) 选项卡，然后根据需要分配给过程映像区（PIPx；x=1 到 15）。

4. 单击“确定”(OK)。

由系统更新过程映像区

如果将对某个过程映像区的更新链接至某个 OB，则在调用此 OB 时，操作系统会自动更

新该分区。此策略类似于（总）过程映像的更新，后者是以循环方式或是在执行完 OB1 之
后进行更新的。 

随后会按如下方式，在操作期间自动更新所分配的过程映像区： 

● 在执行 OB 之前 — 输入过程映像区（部分 PII）

● 在执行 OB 之后 — 输出过程映像区（部分 PIQ）
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在链接到 OB 时处理过程映像区

开始当前周期性中断 (OB) 处理 开始下一周期性中断 (OB) 处理

← OB 的当前循环时间 →  

更新部分 PII 执行周期性中断 输出部分 PIQ 更新部分 PII 执行周期性中断 输出部分 PIQ 等
等 →

为 OB 分配过程映像区

在为 CPU 分配参数和指定 OB 的优先级时，可以指定将哪个过程映像区分配给特定 OB
（见下图）。 

为 OB 分配过程映像区

1. 在 HW Config 中选择 CPU。

2. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。
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3. 选择“周期性中断”(Cyclic Interrupts) 选项卡并进行所需设置。

4. 单击“确定”(OK)。

说明

在 CPU 的 RUN 模式下更改周期性中断时间

每次更改 CPU 周期性中断时间都需要编译程序。否则，CPU_RT 块仍然使用以前的值

工作。

更多信息

● HW Config 在线帮助

9.9.4.9 组态高可用性系统（H 系统）

SIMATIC H 站 

对于高可用性自动化系统，会在 SIMATIC Manager 中将 SIMATIC H 站作为一种单独的站

类型添加到项目。如果要组态各装有一个 H CPU 的两个中央机架，从而组态具有冗余能

力的过程控制系统，就需要使用此站类型。
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分步操作说明

有关组态高可用性过程控制系统的完整分步说明，请参考手册《过程控制系统 PCS 7；高

可用性过程控制系统》(Process Control System PCS 7; High Availability Process Control 
Systems)。

9.9.4.10 组态故障安全系统（F 系统）

SIMATIC F/FH 站

对于故障安全及高可用性自动化系统（FH 系统），会在 SIMATIC Manager 中将 SIMATIC 
H 站作为一种单独的站类型添加到项目。

对于故障安全自动化系统（F 系统），会在 SIMATIC Manager 中将 SIMATIC 400 站作为

一种单独的站类型添加到项目。

分步操作说明

● 手册《S7-400F/S7-400FH 自动化系统，故障安全系统》(S7-400F/S7-400FH 
Automation systems, Fail-safe Systems)

● 有关组态高可用性过程控制系统的完整分步说明，请参考手册《过程控制系统 PCS 7；
高可用性过程控制系统》(Process Control System PCS 7; High Availability Process 
Control Systems)。

9.9.4.11 CPU 的默认参数值

修改参数    

在处理新项目时，PCS 7 会为自动化系统设置默认值。 

“CPU 的默认性能参数 (页 122)”部分中的表格给出了 PCS 7 项目中各种典型 CPU 性能

的默认参数。这些值在使用 PCS 7 软件组态 CPU 时被设置为默认值。 

默认参数完全可以满足典型应用的需要，但可根据组态的需要在限制范围内进行更改。 

使用菜单命令“编辑”(Edit) >“对象属性”(Object Properties)，可在 CPU“属性”(Properties) 
对话框的选项卡上修改这些参数。

说明

调整参数后，需要在 CPU 处于 STOP 模式下执行下载操作。
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更多信息

● “CPU 的默认性能参数 (页 122)”部分

9.9.5 设置时间同步

9.9.5.1 时间同步原理

系统范围的时间同步      

为了能够对过程数据进行分析，过程控制系统的所有组件必须使用完全相同的时间。只有

这样，才能以正确的时间顺序分配消息，而不管时区如何。例如，某个 OS 服务器必须承

担时间主站的功能，以使工厂总线上的其它所有操作员站和自动化系统便都从此主站接收

时间。这样，它们就都具有相同的时间。

PCS 7 工厂中的时间同步

站 同步选项 更多信息

操作站

和

维护站

● 在整个终端总线上同步日时钟

● 在整个工厂总线上同步日时钟

组态手册《过程控制系统 PCS 7；
操作员站》(Process Control 
System PCS 7; Operator Station)
1.)

BATCH 站 ● 在整个操作系统中同步日时钟  1.)

Route Control 工
作站

● 在整个操作系统中同步日时钟 1.)

SIMATIC PCS 7 
BOX

● 在 PCS 7 系统集成期间同步日

时钟
功能手册《过程控制系统 PCS 7；
SIMATIC PCS 7 BOX》(Process 
Control System PCS 7; SIMATIC 
PCS 7 BOX)
1.)

AS ● 使用作为时间从站的 AS 同步

日时钟
“如何在 AS 上设置时间同步 
(页 366)”部分

1.)
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站 同步选项 更多信息

域控制器 ● 同步日时钟

域控制器作为终端总线上的时

间主站

手册《过程控制系统 PCS 7；操

作员站》(
Process Control System PCS 7; 
Operator Station)
1.)

时间主站 ● 日时钟主站集成到 PC 中或作

为总线组件连接到以太网。
手册《过程控制系统 PCS 7；操

作员站》(
Process Control System PCS 7; 
Operator Station)
1.)

● 日时钟主站可以是任何可通过

以太网发送时间信号的设备

（例如 PC）。

手册

《SIMATIC NET；SICLOCK TM，

SICLOCK TC 400》
1.)

1.)功能手册《过程控制系统 PCS 7；时间同步》(Process Control System PCS 7; Time 
Synchronization)

使用 CPU 时钟

可以设置和评估自动化系统和操作员站的时间/日期。

表示时区 

整个工厂中仅存在一个连续的无中断日时钟 — UTC。 

在 OS 本地还有另外一种不同于 UTC 的当地时间，可以计算出该时间并用于显示。该当地

时间是通过在 UTC 上加上或减去时差而计算得出的。 

当地时间还考虑到了标准时间和夏令时时间。

说明

在 PCS 7 中，系统内部总是使用 UTC 时间。

在过程模式下（OS 运行系统）显示给工厂操作员的时间信息可以是 UTC 时间，也可以是

当地时间。这样就可以跨越时区界限来组态系统。

例如，可以使用与操作员站的时区不同的自动化系统来组态系统。在操作期间，必要时，

操作员还可在 UTC 显示方式和当地时间显示方式之间进行切换。
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时间戳

诊断缓冲区、消息和 OB 开始信息中的时间戳是使用 UTC 生成的。

设置时间同步的说明

为使时间同步在整个系统中起作用，必须在所涉及的节点上进行某些设置。

涉及的组件 步骤信息可参考

AS：CPU、CP 443-1、

CP 443-5 Extended

“如何在 AS 上设置时间同步 (页 366)”部分

手册《过程控制系统 PCS 7；高精度时间戳》(Process Control 
System PCS 7; High-precision Time Stamps)

OS 手册《过程控制系统 PCS 7；操作员站》(Process Control 
System PCS 7; Operator Station)

PC 站 白皮书《PCS 7 和 WinCC 的安全性概念》

更多信息

● 功能手册《过程控制系统 PCS 7；时间同步》(Process Control System PCS 7; Time 
Synchronization)

● 组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

9.9.5.2 如何在 AS 上设置时间同步

设置 CPU                

1. 打开所需站的硬件配置。

2. 选择要借以执行 AS 时间同步的对象：

– CPU
– CP

3. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
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更多信息

● 功能手册《过程控制系统 PCS 7；时间同步》(Process Control System PCS 7; Time 
Synchronization)

● 手册《过程控制系统 PCS 7；高精度时间戳》(Process Control System PCS 7; High-
precision Time Stamps)

9.9.6 组态高精度时间戳硬件 

二进制信号的高精确度检测 

如果需要对所选区域的过程信号进行高精确度分析，可以与下列分布式 IO 设备系列一起使

用高精度时间戳。

   

● ET 200SP HA

● ET 200M

● ET 200iSP

高精度时间戳的可能使用范围：

● 精确检测与过程相关的设备发生故障的时间。利用时间戳可明确识别指出过程单元故障

原因的信号。

● 分析系统范围的相互关系

● 检测和报告时间要求严格的信号变化顺序

说明

时间戳只应当用于对过程非常重要的选定信号。绝对不可将其用于所有要读取的二进制

信号：

另一方面，可能会同时报告大量信号（例如，在出现故障时）。这会增加因缓冲区溢出

而丢失消息的风险。

时间戳要求

对时间戳的要求是属于该系统的所有设备上的时间必须同步。这需要与某个时间主站相连

接。
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分步操作说明

● 有关组态高精度时间戳的详细分步操作说明，请参见功能手册《过程控制系统 PCS 7；
高精度时间戳》(Process Control System PCS 7; High-precision Time Stamps)。

● 有关将 OS 服务器组态为时钟主站的完整描述和分步操作说明，请参见组态手册《过程

控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator station)。

9.9.7 确认触发报告

9.9.7.1 如何激活确认触发报告 (ATR)

简介    

如果触发消息的事件连续快速地改变其状态，则可能引发消息蜂拥而至。这就不再能够完

全确保设备状态的总览。 

通过组态“确认触发报告 (ATR)”功能，可以在收到确认之前移植重复发送状态“波动”

的信号。

步骤

1. 在组件视图中选择所需的站。

2. 双击详细信息窗口中的“硬件”(Hardware) 对象。
将打开 HW Config 和硬件目录。

3. 选择 CPU。

4. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
将打开“属性 - ("CPU-xxx")”(Properties - ("CPU-xxx")) 对话框。

5. 在“诊断/时钟”(Diagnostics/Clock) 选项卡上，激活“系统诊断”(System Diagnostics) 组中
的复选框“SFB 33-35 的确认触发报告”(Acknowledgment-triggered reporting of SFB 33-35)。

结果

此时，仅当已确认了上一个信号变化（上一个进入消息）时，SFB 33 到 35 才会报告信号

变化。 
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9.10 组态连接的 I/O（标准）

9.10.1 在 PROFIBUS DP 中组态分布式 I/O（标准）

9.10.1.1 如何在 PROFIBUS DP 上组态分布式 I/O

简介

在以下组态操作说明中，首先介绍一个含有以下组件的分布式 I/O 的组态实

例：                                     

● ET 200M（通过 PROFIBUS DP 通信）

● 插接到 ET 200M 中的 S7-300 I/O 模块

要组态分布式 I/O，请逐步执行以下组态步骤：

1. 添加 DP 从站

2. 添加 I/O 模块

3. 为通道添加符号名

添加 DP 从站 － 关于 ET 200M

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 在硬件目录中选择“PROFIBUS DP > ET 200M > IM 153-...”，然后将此模块拖动到 DP 
master system(1)。DP master system(1) 是 RACK 窗口右侧的某一行。
将打开“属性 － PROFIBUS 接口 IM 153-...”(Properties - PROFIBUS Interface IM 153-...) 
对话框。

说明

在硬件目录中，选择与所用背板总线（被动或主动背板总线）匹配的 IM 153 以及要使

用的实际 IM 153 模块上标明的产品版本。在 PCS 7 中使用了主动背板总线。

3. 对于“PROFIBUS 地址”(PROFIBUS Address)，请为 DP 从站选择一个在 DP 网络中唯一的
地址（例如 7）。必须使用 DIL 开关（硬件开关）在 IM 153-... 上设置所选地址。

实施 PCS 7 组态

9.10 组态连接的 I/O（标准）

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 369



4. 单击“确定”(OK)。

5. 选择 ET 200M，然后选择菜单命令“编辑”(Edit) >“对象属性...”(Object Properties...)。

6. 打开“工作参数”(Operating Parameters) 选项卡。
选中“运行期间更换模块”(Replace modules during operation) 复选框（默认设置）。

7. 单击“确定”(OK)。

说明

如果未选中此复选框而某个模块发生故障，则 AS 会将模块故障解释为 ET 200M 的故

障。
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添加输入和输出模块

1. 在硬件目录中选择“PROFIBUS DP > ET 200M > IM 153-... > ...”，然后拖动并插入所需模
块（底部的硬件配置窗口）。

2. 选择第一个模块，然后选择菜单命令“编辑”(Edit) >“对象属性...”(Object Properties...)。

3. 在“地址”(Address) 选项卡中设置地址和过程映像分区。
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4. 按照组态要求设置模块的任何其它属性，例如诊断报警或测量范围。

5. 对其它模块重复此步骤。

说明

对于 ET 200M 分布式 I/O 站中的模块（例如具有 4 个通道的模拟量输出模块），其通

道特定的设置“对 CPU 停止的反应”(Reaction to CPU-STOP)（OCV、KLV、SV）对

于所有通道必须完全相同。

说明

确保也在模拟输入模块自身上使用编码键设置了模块的测量范围。在“编码键设置”
(Coding Key Setting) 右侧的“输入”(Inputs) 选项卡上，可在模块的对象属性中找到用

于设置编码键的代码字母。

如果使用 ET 200M (IM 153-x)，必须在 ET 200M 或 CiR 对象中至少安装一个输入/输出

模块，以免在保存和编译硬件配置时出现一致性错误。

HART 现场设备

关于 HART 现场设备的更多信息，请参见“如何组态分布式 I/O 上的 HART 设备 
(页 427)”部分。
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为通道分配符号名

使用符号表中列出的符号名为模块上的通道分配驱动程序块。在硬件配置中声明符号名。

按照下面概括的步骤进行操作：

1. 选择 ET 200M 中的第一个模块，然后选择“编辑”(Edit) >“符号...”(Symbols...) 菜单命令。

2. 在“符号”(Symbol) 列中输入符号名以反映所读入值的工艺含义。

3. 对其它模块执行相同的步骤，并为所需的其它所有过程值输入符号名。使用工厂描述的过程
变量列表作为基础。

更多信息

● HW Config 在线帮助

● 手册《SIMATIC；分布式 I/O 设备 ET 200M》(SIMATIC; Distributed I/O Device ET 
200M)

● 手册《SIMATIC；分布式 I/O 系统 ET 200S》(SIMATIC; Distributed I/O System ET 
200S)

● 手册《SIMATIC；分布式 I/O 设备 ET200iSP》(SIMATIC; Distributed I/O Device 
ET200iSP)

● 手册《SIMATIC；分布式 I/O 设备 ET 200pro》(SIMATIC; Distributed I/O Device ET 
200pro)
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9.10.1.2 如何在基于 PROFIBUS DP 现场总线的分布式 I/O 中组态模块

步骤

1. 在组件视图中，选择相关站，然后在详细信息窗口中双击“硬件”(Hardware) 对象。
将打开 HW Config 和硬件目录。

说明

如果要向使用 PCS 7 向导创建的 SIMATIC 400 站中添加附加模块，请从第 6 步开始操

作。

2. 在“SIMATIC 400 > 机架 400”(SIMATIC 400 > Rack-400) 硬件目录中，选择所需的机架并通
过鼠标拖动的方式将其插入。
确保所选的排列与物理硬件的排列相匹配。

3. 在“SIMATIC 400 > PS-400”硬件目录中，选择所需的电源并通过鼠标拖动的方式进行添
加。

4. 在 SIMATIC 400 > CPU-400 硬件目录中，选择所需的 CPU 并通过鼠标拖动的方式将其插
入。

5. 单击“确定”(OK) 以确认打开的“属性 - PROFIBUS 接口”(Properties - PROFIBUS Interface) 
对话框。
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6. 以相同的方式添加任何其它需要的组件，例如：

– “SM 400”：数字量及模拟量信号模块 (CPU)
– “CP 400”：通信模块：相关信息，请参见“如何插入通信处理器 (页 351)”部分。

7. 在 HW Config 中选择菜单命令“站 > 保存”(Station > Save)。

设置集成 PROFIBUS DP 接口的属性

添加 CPU 时，必须设置该 CPU 的集成 PROFIBUS DP 接口的属性。 

按照下面的步骤进行操作：

1. 选择 CPU 的 PROFIBUS DP 接口。

2. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。

3. 在“常规”(General) 选项卡上，单击该接口的“属性”(Properties) 按钮。

4. 选择一个 PROFIBUS 网络并分配所需的地址，将该 PROFIBUS DP 接口与该 PROFIBUS 
网络进行联网。
如果尚未创建 PROFIBUS 网络，可使用“新建”(New) 按钮创建一个新网络。

5. 然后单击“确定”(OK) 两次。
将关闭“属性”(Properties) 对话框。

说明

如果要将 PROFIBUS DP 连接到 CP 443-5 Extended，则无需设置上述属性。

请注意，集成 PROFIBUS DP 接口执行的功能范围与 CP 443-5 Extended 不同（如 
PROFIBUS 节点数）。

添加和设置附加的 IF 接口模块

1. 选择 CPU 的模块插槽 (IF1/IF2)。

2. 选择菜单命令“插入 > 插入对象 (Insert > Insert Object)。

3. 在随即打开的对话框中，选择：

– CPU
– 固件版本

– 接口模块

4. 单击“参数”(Parameters) 选项卡中的接口“属性”(Properties) 按钮。

5. 选择一个 PROFIBUS 网络并分配所需的地址，将该 PROFIBUS DP 接口与该 PROFIBUS 
网络进行联网。
如果尚未创建 PROFIBUS 网络，可使用“新建”(New) 按钮创建一个新网络。

6. 然后单击“确定”(OK) 两次。
将关闭“属性”(Properties) 对话框。
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更多信息

● “如何在 PROFIBUS DP 上组态分布式 I/O (页 369)”部分

● “如何插入通信处理器 (页 351)”部分

9.10.1.3 如何使用 ET 200M 组态“冗余 IO”？

简介  

使用 HW Config 组态冗余 I/O 模块。

说明

只能通过 ET 200M 的某些 S7-300 I/O 模块实现冗余操作。有关更多信息，请参见下列文

档：

● 文档《PCS 7 - 已发布的模块》(PCS 7 - Released Modules)
● 手册《自动化系统 S7-400H；高可用性系统》(Automation System S7-400H; High 

Availability Systems)

说明

只能使用同一部件编号和同一产品版本的模拟或数字版本的输入/输出模块。 

分配冗余模块

可按以下方式为 ET 200M 彼此分配冗余模块：

● 模块位于同一冗余 PROFIBUS DP 上的两个不同 ET 200M 站中（请参见示例组态）。

● 模块位于不同冗余 PROFIBUS DP 上的两个不同 ET 200M 站中。

● 模块位于同一 ET 200M 站中。
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使用 ET 200M 在 PROFIBUS DP 进行组态的示例

下图显示了切换的分布式组态中的冗余输入模块设置。

实例组态中的操作方法

“信号模块 1”组态为“冗余信号模块 1”的冗余模块。结果是，信号 E1.1 和 E10.1 彼此

互为冗余。

如果在“信号模块 1”中检测到错误，用户程序将继续使用地址 I1.1，但此时信号来自地

址 I10.1。由于信号状态仍然正常，因此用户程序没有检查到错误。该事件将生成诊断消

息，提供有关钝化信号的信息。 

要求

● 必须已在 SIMATIC Manager 中创建并打开包含 H CPU 的 PCS 7 项目。

● 在 HW Config 中，为 SIMATIC H 站组态冗余 DP 主站系统。

● 已在 HW Config 中组态冗余 PROFIBUS DP 上的 ET 200M 的接口模块 (IM 153-2)。

步骤

1. 在组件视图中，选择 SIMATIC H 站，然后在详细信息窗口中双击“硬件”(Hardware) 对象。
将打开 HW Config。

2. 如果硬件目录不可见，请选择菜单命令“视图”>“目录”(View > Catalog)。
将打开硬件目录。

3. 选择要在其中组态冗余模块的 IM 153-2 (ET 200M)。
模块总览将显示在下部窗格中。
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4. 在硬件目录中选择支持冗余的信号模块。
通过拖放操作，将该信号模块移动到 IM 153-2（下方窗格）中的空闲插槽中。

5. 对第二个信号模块重复步骤 3 和 4。
将插入要为其组态冗余的模块。

6. 再次选择第一个 IM 153-2。

7. 在模块总览中双击插入的信号模块。
将打开此模块的“属性...”(Properties ...) 对话框。

8. 打开“地址”(Addresses) 选项卡。

9. 从“过程映像”(Process image) 下拉列表中选择过程映象分区。

10.选择“冗余”(Redundancy) 选项卡。

11.选择“冗余”(Redundancy) 下拉列表中的条目“2 个模块”(2 modules)。

12.单击“查找”(Find)。
将打开“查找冗余模块”(Find Redundant Module) 对话框。

13.在“子系统”(Subsystem) 列表中，选择在其中组态冗余信号模块的 DP 主站系统。
将在“PROFIBUS 地址”(PROFIBUS address) 框中显示此 DP 主站系统中所有可用的 
PROFIBUS 地址。

14.在“PROFIBUS 地址”(PROFIBUS address) 框中，选择在其中组态冗余信号模块的 IM 153-2。
将在“冗余模块”(Redundant module) 列表中显示此 IM 153-2 中具有冗余能力且尚未对其
进行组态的信号模块。
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15.在“冗余模块”(Redundant module) 列表中，选择要用作冗余信号模块的信号模块。

16.单击“确定”(OK) 关闭对话框。

17.在“附加参数”(Additional parameters) 区域中，进行输入模块所需的任何附加设置。

18.单击“确定”(OK)。

更多信息

● 文档《过程控制系统 PCS 7；PCS 7 高可用性过程控制系统》(Process Control System 
PCS 7; PCS 7 High Availability Process Control Systems)

● 文档《过程控制系统 PCS 7；PCS 7 - 已发布的模块》(Process Control System PCS 
7; PCS 7 - Released Modules)

● STEP 7 的在线帮助

● 手册《自动化系统 S7-400H；高可用性系统》(Automation System S7-400H; High 
Availability Systems)

9.10.2 在 PROFINET IO 中组态分布式 I/O（标准）

9.10.2.1 应用于 PROFINET IO 的网络节点组态规则

IO 设备必须具有设备名称，从而使 IO 控制器可以与其通信。之所以对 PROFINET 执行这

一步骤，是因为名称比复杂的 IP 地址更方便理解。 

在 PROFINET IO 子网中，设备名称必须易于识别。

为实际 IO 设备分配设备名称等同于在 DP 从站中设置过程。

IO 设备交付状态

在交付状态下，IO 设备不具备设备名称。 

只有借助 PG/PC 分配了设备名称后，IO 控制器才能对 IO 设备进行寻址。
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设备名称规范的要求（符合标准 IEC 61158-6-10）

● 如果将设备组态为 PROFINET IO 设备，则可以在此处分配 PROFINET IO 设备名称。

但是，请记住，理想情况下应在“属性”(Properties) 对话框中设置设备名称，从而将其

存储在项目工程组态数据中。

● 当使用设备名称从 DHCP 服务器获取 IP 地址时，同样要求具备设备名称。

● 设备名称必须根据 DNS 约定进行指定。换句话说：

– 总字符数不得超过 240 个（字母、数字、破折号或点）

– 设备名称中的名称部分（换句话说，两个点之间的字符串）最多不得超过 63 个字

符。

– 不可使用特殊字符，例如元音变音符号（ä、ö 等）、括号、下划线、斜线、空格等。

破折号是唯一允许的特殊字符。

– 设备名称不得以“-”字符开始或结尾。

– 设备名称不得以数字开始。

– 设备名称的结构不能为 n.n.n.n (n = 0...999)。
– 设备名称不能以字符串“port-xyz-”(x , y, z = 0...9) 开始。 

示例：[来自短 ID 的名称] [IO 系统的名称] 

在以太网子网（PROFINET IO 系统）中，设备名称必须是唯一的。 

单击“分配名称”(Assign Name) 按钮将设备名称传送给设备。 

说明

CP 作为 PROFINET IO 控制器

当 CP 作为 PROFINET IO 控制器时，在组态期间设备名称将由短 ID 派生得到。通过 
STEP 7 可以自动将 IO 系统添加到设备名称（参见上面的示例）。

复位为出厂设置

使用“复位”(Reset) 按钮，可以将设备复位为出厂设置。然后删除 IP 地址。

注意

复位

根据设备类型，在寻址设备运行时更改设备名称或复位可能会导致操作故障。请检查设备

文档中的信息。

说明

复位为出厂设置后，模块上的设备名称将被删除。
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更多信息

“如何组态网络节点以在 PROFINET IO 上使用 (页 386)”部分

9.10.2.2 如何在 PROFINET IO 上组态分布式 I/O

简介

在以下组态操作说明中，首先介绍一个含有以下组件的分布式 I/O 的组态实例：  

● ET 200SP HA；ET 200M 或 ET 200SP（通过 PROFINET IO 进行通信）

要组态分布式 I/O，请逐步执行以下组态步骤：

1. 添加 IO 设备和总线适配器

2. 添加 I/O 模块

3. 为通道添加符号名

要求

识别用于连接 ET 200SP HA 和 PROFINET IO 的网线类型。从而识别所需类型的总线适

配器。

添加 IO 设备 - 关于 ET 200SP HA

1. 从组件视图中选择所需的 SIMATIC 400 站与 CPU 410-5H，然后在详细信息窗口中双击“硬
件”(Hardware) 对象。
将打开自动化系统的硬件配置。

2. 如果硬件配置中的硬件目录未打开，请选择“视图 > 目录”(View > Catalog)。
将打开硬件目录。

3. 在此目录中的当前 PCS 7 配置文件中，选择路径 PROFINET IO > IO > ET 200SP HA。

4. 双击要连接的外围设备：IM 155-...。
接口模块将直接连接到 PROFINET IO 系统。

5. 选择路径 “PROFINET IO > IO > ET 200SP HA > IM 155-... > 子模块 > 总线适配器”
(PROFINET IO > IO > ET 200SP HA > IM 155-... > Submodule > Busadapter)。

6. 双击 <所需总线适配器类型>。
总线适配器将直接连接到接口模块。
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添加输入和输出模块

说明

使用 IO 冗余

IO 冗余外围模块必须在 HW Config 中组态到载体模块的插槽上。必须从奇数插槽号开始。

伙伴模块必须插入到其后的插槽中。

1. 在硬件目录中选择“PROFINET IO > ET 200SP HA > IM 155-...”，然后拖动并插入所需模
块（硬件组态窗口底部）。

HART 现场设备

关于 HART 现场设备的更多信息，请参见“如何组态分布式 I/O 上的 HART 设备 
(页 427)”部分。
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为通道分配符号名

使用符号表中列出的符号名为模块上的通道分配驱动程序块。在硬件配置中声明符号名。

按照下面概括的步骤进行操作：

1. 选择 ET 200SP HA 中的第一个模块，然后选择“Edit  > Symbols...”(编辑 > 符号...) 菜单命
令。

2. 在“符号”(Symbol) 列中输入符号名以反映所读入值的工艺含义。

3. 对其它模块执行相同的步骤，并为所需的其它所有过程值输入符号名。使用工厂描述的过程
变量列表作为基础。

更多信息

● HW Config 在线帮助

● 手册《SIMATIC；分布式 I/O 设备 ET 200SP HA》(SIMATIC; Distributed I/O Device 
ET 200SP HA)

● 手册《SIMATIC；分布式 I/O 系统 ET 200M》(SIMATIC; Distributed I/O System ET 
200M)

● 手册《SIMATIC；分布式 I/O 系统 ET 200SP》(SIMATIC; Distributed I/O System ET 
200SP)
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9.10.2.3 如何在基于 PROFINET IO 现场总线的分布式 I/O 中组态模块

步骤

1. 在组件视图中，选择相关站，然后在详细信息窗口中双击“硬件”(Hardware) 对象。
将打开 HW Config 和硬件目录。

说明

如果要向使用 PCS 7 向导创建的 SIMATIC 400 站中添加附加模块，请从第 6 步开始操

作。

2. 在“SIMATIC 400 > 机架 400”(SIMATIC 400 > Rack-400) 硬件目录中，选择所需的机架并通
过鼠标拖动的方式将其插入。
确保所选的排列与物理硬件的排列相匹配。

3. 在 SIMATIC 400 > PS-400 硬件目录中，选择所需的电源并通过鼠标拖动的方式进行添加。

4. 在 SIMATIC 400 > CPU-400 硬件目录中，选择所需的 CPU 并通过鼠标拖动的方式将其插
入。

5. 单击“确定”(OK) 以确认打开的“属性 - PROFINET 接口”(Properties - PROFINET Interface) 
对话框。
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6. 以相同的方式添加任何其它需要的组件，例如：

– “SM 400”：数字量及模拟量信号模块 (CPU)
– “CP 400”：通信模块：相关信息，请参见“如何插入通信处理器 (页 351)”部分。

7. 在 HW Config 中选择菜单命令“站 > 保存”(Station > Save)。

更多信息

● “设置集成 PROFINET IO 接口的属性 (页 385)”部分

● “添加和设置附加的 IF 接口模块 (页 386)”部分

● “如何在 PROFINET IO 上组态分布式 I/O (页 381)”部分

● “如何插入通信处理器 (页 351)”部分

9.10.2.4 设置集成 PROFINET IO 接口的属性

添加 CPU 时，必须设置该 CPU 的集成 PROFINET IO 接口的属性。 

步骤

1. 选择 CPU 的 PROFINET IO 接口。

2. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。

3. 在“常规”(General) 选项卡上，单击该接口的“属性”(Properties) 按钮。

4. 选择一个 PROFINET 网络并分配所需的地址，将该 PROFINET IO 接口与该 PROFINET 网
络进行联网。
如果尚未创建 PROFINET 网络，可使用“新建”(New) 按钮创建一个新网络。

5. 然后单击“确定”(OK) 两次。
将关闭“属性”(Properties) 对话框。

说明

如果要将 PROFINET 连接到 CP443-1 Extended，则无需设置上述属性。

请注意，集成 PROFINET 接口执行的功能范围与 CP443-1 Extended 不同（如 PROFINET 
节点数）。
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9.10.2.5 添加和设置附加的 IF 接口模块

步骤

1. 选择 CPU 的模块插槽 (IF1/IF2)。

2. 选择菜单命令“插入 > 插入对象”(Insert > Insert Object)。

3. 在随即打开的对话框中，选择：

– CPU
– 固件版本

– 接口模块

4. 单击“参数”(Parameters) 选项卡中的接口“属性”(Properties) 按钮。

5. 选择一个 PROFINET 网络并分配所需的地址，将该 PROFINET IO 接口与该 PROFINET 网
络进行联网。
如果尚未创建 PROFINET 网络，可使用“新建”(New) 按钮创建一个新网络。

6. 然后单击“确定”(OK) 两次。
将关闭“属性”(Properties) 对话框。

9.10.2.6 如何组态网络节点以在 PROFINET IO 上使用

IO 设备名称

有关 IO 设备命名规则的信息，请参见“应用于 PROFINET IO 的网络节点组态规则 
(页 379)”部分。

在 HW Config 的既有项目计划中创建设备名称 

PROFINET IO 子网中的设备名称必须清楚。

要求 

● PG 接口必须直接连接到 PROFINET IO 子网。

● 设备名称存储于 HW Config 中 IO 设备的质量对话框中。 

● IO 设备的 MAC 地址已知。

要求

1. 在 HW Config 中，选择 IO 设备。

2. 选择菜单“PLC > 以太网 > 分配设备名称”(PLC > Ethernet > Assign Device Name)。

3. 在“分配名称”(Assign Name) 区域中，单击按钮“分配名称”(Assign Name)。
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4. 确保在首次分配设备名称时激活以下选项框：
在“可用设备”(available equipment) 列表中， 
– 只显示相同类型的设备

– 只显示无名称的设备

5. 如果要检查是否已选择所需的 IO 设备。单击“闪烁开”(flash on) 按钮。
在突出显示的设备上闪烁 LED。 

6. 单击“分配名称”(Assign Name) 按钮。
设备名称直接分配给设备。

图 9-1 示例：组态 PROFINET 节点

无项目计划的设备名称

如需在 HW Config 中将设备名称分配至无计划设备名称的 IO 设备，请执行以下步骤。

要求

● PG 接口必须直接连接到 PN-IO 子网。 

● IO 设备的 MAC 地址已知。
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步骤

1. 使用“浏览”(Browse) 按钮查找可用设备的 MAC 地址或输入 MAC 地址（假设已知）。 
– 如果是这种情况，请在浏览网络后从对话框显示的列表中选择具有已知 MAC 地址的

模块。 
– 在工厂内，您可以通过单击按钮“闪烁”(Flash) 选择所需的设备。

所选设备上的 LED 开始闪烁。

2. 设置 IP 组态
从以下选项中选择： 
– 使用 IP 参数 

如果基于所选模块打开对话框，则已经为模块组态了 IP 地址值。否则，必须输入 IP 
地址、子网掩码和网关（如果适用）。 
有关值的范围和特殊 IP 地址的更多信息，请参见：

IP 地址、子网掩码和网关地址值的范围 - 
– 从 DHCP 服务器获取 IP 地址 

如果选择此选项，则从 DHCP 服务器获取 IP 地址。 
根据所选的选项，将通知 DHCP 服务器有关 CP 的 MAC 地址、设备名称或您在此

处输入的客户端 ID。 
客户端 ID 是一串最多由 63 个字符组成的字符串。只能使用下列字符： 
a-z、A-Z、0-9 和 - （破折号） 
如果在此处指定 DHCP 服务器应通过设备名称获取 IP 地址，则必须首先为设备分配

设备名称。 

3. 单击“分配 IP 组态”(Assign IP Configuration) 按钮。
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图 9-2 示例：无项目规划条件下组态 PROFINET 节点

组态 IO 设备连接

建议使用“拓扑编辑器”与 IO 设备建立连接
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复位为出厂设置

使用“复位”(Reset) 按钮，可以将设备复位为出厂设置。然后删除 IP 地址。

注意

复位

在寻址设备运行时更改设备名称或复位可能会导致操作故障，具体取决于设备类型。请检

查设备文档中的信息。

说明

复位为出厂设置后，模块上的设备名称将被删除。

9.10.2.7 如何使用“拓扑编辑器”？

在 HW Config 中组态拓扑

1. 选择 PROFINET IO 上的任一成员 

2. 在 HW Config 中，选择菜单“编辑 > PROFINET IO > 拓扑...”(Edit > PROFINET IO > 
Topology...)。打开“拓扑编辑器”。
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根据需要执行的操作选择相应的选项卡。

“表格视图”选项卡

“表格视图”(Table view) 选项卡提供以下选项：

● “站名称”(Station name) - 如果启用了该选项，则在“伙伴端口”(Partner port) 下的端

口名称前将附加站名称。

● 非互连和连接端口 - 可以使用“选择范围”(Selection range) 部分提供的过滤器进行选

择。

● 编辑或断开现有互连：

– 可以通过双击表中相应的端口条目编辑现有互连的参数。

– 要断开现有连接：

选择表中的互连端口

打开快捷菜单，并选择“断开端口互连”(Disconnect Port Interconnection)。
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● “选项”(Options) - 提供以下内容：

– 电缆长度的测量

– 是否需要自动更新在线视图

– 选择搜索方法

– 需要在“表格视图”(Table view) 中显示的列

● “在线”(Online) - 可以进行检查，从而确定组态的设备是否连接。这将提供连接系统中

的可用互连，并支持检查其当前状态。

● “对象属性...”(Object Properties...) - 选择此选项时，将打开“属性 - PN-IO-X5-Port1 
(R1/S3/X5 P1R)”(Properties - PN-IO-X5-Port1 (R1/S3/X5 P1R)) 对话框，可以组态相

应的参数，如名称、地址等。

● “导出”(Export) - 使用此选项，该组态可以以 .CSV 文件的形式保存在本地驱动器上。

“图形视图”选项卡

使用“图形视图”(Graphic View) 选项卡，可以执行以下功能：

● 创建、更改或删除端口互连

● 编辑设备、模块和端口互连的属性

● 添加或删除被动注释

● 修改视图

在“图形视图”(Graphic view) 的在线视图中，可以看到已检测到并分配给项目设备的连接

工厂的设备。单击“在线”(Online) 激活在线模式。

“离线/在线比较”(Offline/online comparison) 选项卡

在离线模式下组态的拓扑可以和在线模式下检测到的拓扑进行比较，其报告可以以 .csv 文
件的形式保存在本地驱动器上。
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9.10.2.8 如何组态“介质冗余”？

组态的快速概述

说明

使用介质冗余协议

请注意以下说明：

● 每个节点连接到环网组态中的两个其它节点。

● 当在 H 系统中对网络使用介质冗余协议时，必须在两个 IO 控制器之间实现附加连接。

组态

组态对象 介质冗余 H 系统的介质冗余

1 个子网环网 系统冗余 + 子网环网 系统冗余（2 个子网环网）

主要硬件组态

MRP

S1

S2

MRP

R 1

MRP MRP

示例（网络连

接）：

● 网络 1：
CPU (0) X5 端口 1 +
CPU (0) X5 端口 2

● 网络 1：
CPU (0) X5 端口 1 +
CPU (1) X5 端口 1

● 需要介质冗余的单独连

接：

CPU (0) X5 端口 2 +
CPU (1) X5 端口 2

● 网络 1：
CPU (0) X5 端口 1 +
CPU (0) X5 端口 2

● 网络 2：
CPU (1) X5 端口 1 +
CPU (1) X5 端口 2

网络地址 所有节点地址都位于子网中。

使用“拓扑编辑器”在建立网络连接时进行组态

有关使用“拓扑编辑器”的信息，请参见“如何使用“拓扑编辑器”？ (页 390)”部分。
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在 HW Config 中组态域管理

说明

介质冗余

一个 PROFINET 接口上只能运行一个 MRP 环。

如果在具有多个 PROFINET 接口的 CPU 上运行多个 MRP 环，不得将 MRP 环彼此相连。

如果要运行多个 MRP 环，则必须组态 MRP 管理器。大多数情况下，将 CPU 组态为 MRP 
管理器。

1. 选择 PROFINET IO 上的任一成员 

2. 在 HW Config 中，选择菜单“编辑 > PROFINET IO > 域管理...”(Edit > PROFINET IO > 
Domain Management...)。

3. 选择选项卡“MRP 域”(MRP-Domain)。 

4. 在“MRP 域”(MRP Domain) 区域中选择 MRP 域（如果可用域多于一个，在标签“MRP 域”
(MRP Domain) 中标记已使用的域）。

5. 在 PROFINET IO 上选择应组态为 MRP 管理器的成员。 
– 单击“编辑”(Edit)。

将打开“编辑介质冗余”(Edit Media Redundancy) 对话框。 
– 在“角色”(Role) 下拉框中选择条目“管理器”(Manager)。

检查设置并单击“确定”(OK)。

6. 在 PROFINET IO 上选择应组态为 MRP 客户端的成员。（可选择不只一个）。

– 单击“编辑”(Edit)。
将打开“编辑介质冗余”(Edit Media Redundancy) 对话框。 

– 在“角色”(Role) 下拉框中选择条目“客户端”(Client)。
检查设置并单击“确定”(OK)。
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9.10.2.9 如何组态“系统冗余”？

组态的快速概述

说明

使用系统冗余 
必须注意以下说明：

● IO 控制器是冗余的。

● 每个 IO 设备连接到两个 IO 控制器中的每一个。

组态

组态对象 系统冗余（1 个子网环网） 系统冗余 + 介质冗余（子网环

网）

系统冗余（2 个子网线）

 

S2

S2

MRP

R 1

Line

示例（网络连

接）：

● 网络 1：
CPU (0) X5 端口 1 +
CPU (1) X5 端口 1

● 不需要单独的介质冗余

连接

 

● 网络 1：
 CPU (0) X5 端口 1 +
 CPU (1) X5 端口 1

● 需要介质冗余的单独连接：

CPU (0) X5 端口 2 +
CPU (1) X5 端口 2

● 网络 1：
CPU (0) X5 端口 1

● 网络 2：
CPU (1) X5 端口 1

网络地址  每个 IO 设备连接到两个 IO 控制器中的每一个。 

硬件配置：
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HW Config 中 IO 设备的选择和表示。

MRP 的使用  

有关信息，可参考“如何组态“介质冗余”？ (页 393)”部分。

使用“拓扑编辑器”在建立网络连接时进行组态

有关使用“拓扑编辑器”的信息，请参见“如何使用“拓扑编辑器”？ (页 390)”部分。

9.10.2.10 如何使用 ET 200SP HA 组态“冗余 IO”？

简介

说明

使用冗余 IO
必须注意以下说明：

● 使用 ET 200SP HA 的合适模块

● 对于 ET 200SP HA，冗余 IO 的接线盒 (TB45R...) 不得插在两个相邻的载体模块上。

● 只有用于单独 I/O 模块或冗余 IO 的接线盒才可插入电位组中。
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分配冗余模块

硬件规则 

● I/O 模块必须获准用于冗余运行。可在相应模块手册中找到该信息。 

● 冗余部署的 I/O 模块必须完全相同，即 I/O 模块必须具有同一部件编号、硬件版本以及

固件版本。 

安装规则 

● 同类 I/O 模块以并排方式成对插入同一 IO 设备。 

● 冗余 IO： 
– 两插槽均位于同一适配器模块中。

– 两个插槽均位于同一终端块 (TB45R) 中。

更多信息，请参见系统手册《SIMATIC；分布式 IO；ET 200SP HA》(SIMATIC; 
Distributed IO; ET 200SP HA)。

使用 ET 200SP HA 在 PROFINET IO 中进行组态

组态对象 步骤 PCS 7 中的参数

I/O 模块 选择冗余模块

“HW Config > I/O 模块属性 > 冗余”
(HW Config > Properties of the I/O 
module > Redundancy) 选项

卡；“冗余，常规”(Redundancy, 
general) 区域

“冗余”(Redundancy) 下拉

列表：2 个模块

（请参见下图）
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9.10.2.11 如何组态紧凑型现场单元？

步骤

紧凑型现场单元 (CFU) 是 PROFINET IO 上的设备。

说明

CFU 工程组态

要针对 CFU 进行工程组态，必须使用以下通道块：

● 对于可自由组态的通道：

– Pcs7Di...（数字 <输入/输出> 通道块）

● 对于现场总线中的设备：

– Fb... （...现场设备的通道块）
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更多信息

● “如何利用通过 PROFINET IO 上的 IE/PB Link 进行的通信组态 PROFIBUS DP 
(页 426)”部分

● 有关使用紧凑型现场单元的更多信息，请参考《分布式 I/O 设备；紧凑型现场单元 PA》
(Distributed I/O devices; Compact Field Unit PA) 手册。 
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9.11 针对 RUN 模式下的组态更改 (CiR) 组态连接的 I/O

9.11.1 针对 RUN 模式下的组态更改 (CiR) 在 PROFIBUS DP 上组态分布式 I/O 设备

9.11.1.1 RUN 模式下的组态更改原理

简介            

有一些过程单元不能在操作期间关闭。这可能是由于自动化过程的复杂性或重新启动的高

昂代价所致。尽管如此，可能还是会需要扩展或修改工厂。 

使用 CiR（Configuration in Run，运行中组态），可对 RUN 模式下的组态进行某些更改。

原理

为了能够使用 CiR 在操作期间对过程单元进行更改，必须在原始组态中为随后扩展专用于

主站系统的自动化系统的硬件做好准备。需要定义合适的 CiR 对象，以后可在 RUN 操作

状态下用真正的对象（从站和/或模块）替换这些对象。随后可在过程运行期间将以此方式

修改的组态下载到 CPU。

有效性

可在操作期间使用具有分布式 I/O 的工厂各部分中的 CiR 对工厂进行修改。

CiR 要求下图所示的组态。为清楚起见，图中只显示了 DP 和 PA 主站系统。 

该组态由以下组件组成：

● CPU（自固件版本 V3.1 起）

● CP 443-5 Extended（固件版本 5.0 或更高）

● ET 200M：IM 153（自 6ES7153-2BA70-0XA00 起）
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● ET 200iSP：IM 152（自 6ES7152-1AA00-0AB0 起）

● PA Link：IM 153（自 6ES7153-2BA70-0XA00 起）

涉及的步骤

下面阐述了程序及组态更改所需的步骤以及相关的过程单元状态。

步骤 含义 CPU 运行模式 工厂状态

1 组态工厂的实际（真正）组态 STOP 离线组态

2 适当预留（CiR 元素）以供今后扩展工

厂的初始组态

STOP 离线组态

3 下载组态 STOP 调试

4 根据需要将 CiR 对象转换为真正对

象。 

工厂修改只能在具有 CiR 对象的主站系

统或具有 CiR 模块的 ET 200M/
ET 200iSP 站中进行。

RUN 永久操作

如有必要，可接连多次重复执行该 CiR 步骤（上表中的第 4 步）。此时，唯一需要考虑到

的是有足够预留的从站数和 I/O 量，以便能够实现所有的工厂扩展。
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对于 CiR 的建议

下面提供了关于在 RUN 模式下进行组态修改的几点提示： 

● 每次对组态进行修改后，均要创建当前工厂组态的备份副本。只有使用此备份版本才能

在不丧失任何 CiR 功能的情况下继续处理项目。

● 只要有可能，应分多个步骤进行组态修改，且在每个步骤中只做少量更改。这意味着您

随时都可以对情况有清楚的了解。

● 为了最大程度地减少 CiR 同步时间（在 RUN 模式下下载组态后的 CPU 响应），建议

在每个重新组态步骤中只更改一个 DP 主站系统。

● 在定义过程映像（地址区域）时应考虑 CiR 对象的数量。

● 请记住，CiR 对象的数量会影响 CiR 同步时间。因此，应尽可能少地仅组态所需数量

的 CiR 对象。

● 确保还可以在 RUN 模式下连接另外的 DP 从站。

9.11.1.2 CiR 对象的类型

术语

术语 含义

CiR 元素 对 CiR 对象和 CiR 模块的通称

CiR 对象 用于以后向 DP 或 PA 主站系统添加从站的占位符

CiR 模块 以后要添加到 ET 200M/ET 200iSP 站的模块的占位符

CiR 元素

组件 CiR 元素

可用的模块化 DP 从站类型 ET 200M/
ET 200iSP

CiR 模块

其中包含额外的 I/O 量，用户可以对此进行编辑。

现有的 DP 主站系统 CiR 对象

其中包含额外的 DP 从站数量，用户可以对此进行

编辑。

现有的 PA 主站系统 CiR 对象

其中包含额外的 PA 从站数量，用户可以对此进行

编辑。
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说明

计算总线参数时，PCS 7 会将已组态从站和 CiR 元素均考虑在内。 因此，在 RUN 模式下

通过 CPU 将 CiR 元素转换为真实从站和/或模块时，无需更改总线参数。

CiR 对象

为 CiR 对象指定以下属性：

● 保证可以添加的从站数

（默认值： DP 主站系统上为 15；PA 主站系统上为 6）

● 供将来使用的输入和输出字节数 
它们与将来的用户数据地址有关。 诊断地址与其分开组态。

默认值： DP 主站系统上为 1220；PA 主站系统上为 80）。 

CiR 模块

对于模块化 I/O 设备 ET 200M/ET 200iSP，使用 CiR 模块定义附加 I/O 量，方式为指定附

加输入和输出字节总数。 此信息与将来的用户数据地址有关。 组态诊断地址时可以忽略此

信息。

您不必完全利用附加的用户数据量。 但是，绝不能超过当前可用的用户数据量。 PCS 7 
可以确保这一点。

9.11.1.3 允许的组态更改概述

支持的组态更改概述

下表列出了所有支持和不支持的组态更改：

组态更改 支持

是 否

向模块化 DP 从站 ET 200M 添加模块，前提是不将其作为 DPV0 从站加入

进来（使用 GSD 文件）

X  

修改 ET 200M 模块的参数，例如，选择其它报警限制或使用以前未曾使用的

通道

X  

用 ET 200iSP 的电子模块替换预留的模块 X  

更改 ET 200iSP 模块的参数设置 X  

实施 PCS 7 组态

9.11 针对 RUN 模式下的组态更改 (CiR) 组态连接的 I/O

工程组态系统 (V9.0 SP1)
404 配置手册, 12/2017, A5E39221328-AC



组态更改 支持

是 否

向现有 DP 主站系统添加 DP 从站，但不添加 I 从站 X  

向现有 PA 主站系统添加 PA 从站（现场设备） X  

在 IM 153-2 之后添加 DP/PA 耦合器 X  

向现有 DP 主站系统添加 PA 连接器（包括 PA 主站系统） X  

向过程映像分区分配已添加的模块 X  

更改现有模块或微型从站的过程映像分区布置 X  

更改 ET 200M 站中现有模块的参数设置

（标准模式下的标准模块和故障安全信号模块）

X  

恢复更改：将再次删除已添加的模块、DP 从站和 PA 从站（现场设备）。 X  

更改 CPU 属性  X

更改中央 I/O 模块的属性  X

添加和删除 DP 主站系统  X

更改现有 DP 主站系统的属性，包括与恒定总线周期时间相关的总线参数、

设置

 X

在安全模式下更改故障安全信号模块的参数设置  X

更改 DP 从站的以下参数： 
● 总线参数

● DP 主站的分配

● 参数分配数据

● 诊断地址

 X

从模块化 DP 从站删除任何模块

（只能删除最后插入的模块。）

 X

从现有 DP 主站系统删除任何 DP 从站

（只能删除具有最高地址的从站。）

 X

更改 I 从站接口的组态  X

说明

如果要添加或删除从站或模块，或是对现有过程映像分区分配进行更改，则最多可对四个 
DP 主站系统进行操作。
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9.11.1.4 如何为将来的工厂扩展定义 CiR 元素 (CPU-STOP)

定义 CiR 元素         

对于 DP 主站系统，“激活 CiR 功能”的功能可用。使用此功能时，会在所选 DP 主站系

统和具有 CiR 功能的每个较低级别 PA 主站系统中生成一个 CiR 对象。在所选 DP 主站系

统的每个类型为 ET 200M/ET 200iSP 且具有 CiR 功能的模块化从站中，均会插入一个 CiR 
模块。 

可以自动或逐个添加 CiR 元素。

激活 CiR 功能

必须先准备项目使其具备 CiR 功能，之后才能在工厂中只于 RUN 模式下下载组态数据。

此准备工作可借助系统向导来完成。该向导会自动为每个 DP 链路创建一个 CiR 对象，为

每个具有 CiR 功能的已组态站（ET 200M、ET 200iSP、DP/PA）创建一个 CiR 模块。 

该向导将为以后的 CiR 活动设置以下 I/O 区域。 

列出的值是针对 CPU410-5H 的示例，不同的 CPU 类型，值可能不同：

● 3660 字节 I 和 Q，每个具有 CiR 功能的 DP 链路一个

● 每个具有 CiR 功能的 DP 链路 15 个从站

● 每个 ET 200M 行 180 字节

● 每个 ET 200iSP 行 180 字节

● 等电位联结行上每个 CiR 对象有 6 个具有 CiR 功能的从站（地址空间总量最大为 80 字
节）
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已选择了默认设置，这样它们就足以用于典型应用，而不需要进行调整。检查这些默认值

是否满足应用要求，如有必要，可在首次下载前，在各个站上或在某个链上对其进行修改。

说明

针对预留的经验法则如下：尽可能少 — 只要够用即可，因为 CiR 同步时间将取决于预留

的大小。

如果激活了“运行中修改组态”功能，则操作将与 CiR 同步时间有关。此时间达到最大值

时，CiR 操作会中断 AS 上的操作。系统中此时间的上限设置为 1 秒，系统将对此进行监

视。在此期间，过程输出和过程输入将保留最后的有效值。

应确保不超过 CiR 同步时间 1 秒。 
SFC 104 不得用于设置与 PCS 7 的 CiR 同步时间（因其会导致 CPU 进入 STOP 模式）。

● 建议在启动 CiR 时使用小步骤，一次只在一个 DP 链路上进行更改。这样将更易于监视 RUN 
模式下的更改。

● 如果在 RUN 模式下所做的更改仅与某个 DP 链路有关，则在选择 CiR 对象时，会显示最大
的 CiR 同步时间。

● 如果要同时对多个链路进行更改，请将各个链路的时间加起来。

● 在将组态数据下载到 CPU 时，系统会再次通知您 CiR 同步时间是否对所做的设置可行。

说明

H-CiR 
为确保 H 系统的 H-CIR 功能，需要在 STEP7 Netpro 中启用“下载前保存连接”(Save 
connections before download) 选项。

有关 H-CIR 的更多信息，请参见文档《过程控制系统 PCS 7；高可用性过程控制系统》

(Process Control System PCS 7; High Availability Process Control Systems)。
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自动插入 CiR 元素

1. 在 HW Config 中，在站窗口的上部选择所需的 DP 主站系统。

2. 选择菜单命令“编辑 > 主站系统 >启用 CiR 功能”(Edit > Master System > Activate CiR 
capability)。
PCS 7 会将以下 CiR 元素添加到所选的 DP 主站系统中：

– （假定仍然还有空闲插槽）在每个具有 CiR 功能的 ET 200M/ET 200iSP 类型的模块

化从站上添加一个 CiR 模块

此 CiR 对象可根据需要包含足够数量的输入和输出字节，以确保在模块化从站上有

相当数量的输入和输出字节供以后使用。

– 在每个具有 CiR 功能的较低级别 PA 主站系统上添加一个 CiR 模块

此 CiR 对象可根据需要包含足够数量的输入和输出字节，以确保在 PA 主站系统上

占用最大的输入和输出字节数（最大各为 80 字节）。

– 在所选的 DP 主站系统上添加一个 CiR 模块

PCS 7 会尝试为 CiR 对象保证 15 个从站并备好 1220 个输入字节和 1220 个输出字节。

如果此主站系统中先前的最高地址大于 111，则可以保证的从站数将相应减少。如

果可用的输入字节和输出字节均少于 1220 个字节，则该数目也将相应地减少。

说明

请注意以下事项：

● 如果所选 DP 主站系统中尚无 CiR 对象，则只能自动添加 CiR 元素。

● 无法将 CiR 元素自动添加到 IM 153-2 下游的 DP 主站系统。

● 如果激活了 CiR 功能，则会以橙色指示包含 CiR 模块和 CiR 对象的从站（例如 DP/
PA 连接器）。

3. CiR 对象的默认值对于所有 CPU 都相同。因此，激活某个主站系统的 CiR 功能后，必须对
每个相应的 CiR 对象进行以下检查：
在 CiR 对象的属性窗口中指定的主站系统的 CiR 同步时间是否与在 CPU 上设置的 CPU 的 CiR 
同步时间的上限相匹配？
如有必要，必须减少一个或多个 CiR 对象中所保证的从站数。

向 DP 或 PA 主站系统插入 CiR 对象

1. 在 HW Config 中，在站窗口的上部选择所需的主站系统。

2. 使用菜单命令“视图”(View) >“目录”(Catalog) 打开硬件目录。
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3. 将关联的 CiR 对象从硬件目录拖动到主站系统。
该 CiR 对象随即作为占位符从站出现在站窗口的顶部。将为该 CiR 对象设置以下默认值：

– 保证的额外 DP 从站数：在 DP 主站系统上为 15；在 PA 主站系统上为 6
– 最大额外从站数：45 个 DP 从站，36 个 PA 从站

– 输入字节数：对于 DP 为 1220，对于 PA 主站系统为 80
– 输出字节数：对于 DP 为 1220，对于 PA 主站系统为 80

4. CiR 对象的默认值对于所有 CPU 都相同。因此，定义 CiR 对象后，应进行以下检查：
在 CiR 对象的属性窗口中指定的主站系统的 CiR 同步时间是否与在 CPU 上设置的 CPU 的 CiR 
同步时间的上限相匹配？
如有必要，必须减少 CiR 对象中所保证的从站数。

说明

如果主站系统上不再有足够的可用资源，则上述各值将相应减少。最后得到的总线参

数“目标轮转时间”(Target Rotation Time)、“典型目标轮转时间”(Target Rotation Time 
Typical) 和“监视狗”(Watchdog) 显示在 CiR 对象的属性窗口中。

更改额外从站数和/或输入及输出字节数

1. 在 HW Config 中，选择所需的 CiR 对象。

2. 选择菜单命令“编辑”(Edit) >“对象属性...”(Object Properties...)
将打开“属性”(Properties) 对话框。

3. 可根据需要更改保证的额外从站数。
最后得到的总线参数“目标轮转时间”(Target Rotation Time)、“典型目标轮转时间”(Target 
Rotation Time Typical) 和“看门狗”(Watchdog) 显示在站窗口的底部。

4. 根据需要更改输入及输出字节数。
为此，请选中“高级设置”(Advanced Settings) 复选框（默认设置）。不要增加该数目，因
为这样会增加 CiR 同步时间。
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在模块化 ET 200M/ET 200iSP 从站中插入 CiR 模块

1. 在 HW Config 中，在站窗口的上部选择所需的 DP 从站。

2. 使用菜单命令“视图”(View) >“目录”(Catalog) 打开硬件目录。

3. 将 CiR 模块从硬件目录拖动到站窗口底部上次组态的 DP 从站模块紧后面的插槽。
该 CiR 模块将作为占位模块出现在站窗口的底部。
输入和输出字节数将出现在该 CiR 模块的属性窗口中。
对于 ET 200M 站，这些值如下：

– 输入字节数 = 空闲插槽数 * 16
– 输出字节数 = 空闲插槽数 * 16
在只包含一个 CiR 模块的 ET 200M 站中，这些值为 8 x 16 = 128（如果 DP 主站系统中的 
CiR 对象仍有足够的空闲输入及输出字节）。

说明

对于 ET 200iSP，可提供的最大输入和输出字节数为 244。更多相关信息，可参考手册

《SIMATIC；分布式 I/O 设备 ET 200iSP》(SIMATIC; Distributed I/O Device 
ET 200iSP)。

在 STOP 模式下下载组态

定义完 CiR 元素后，即可在 CPU 处于 STOP 模式时下载组态。

可在 S7-400 自动化系统中使用大量模块。为确保已使用的所有模块均不妨碍以后的 CiR 
活动，请遵循以下步骤： 

在 STOP 模式下将组态下载到 CPU 后，立即再次下载组态，这次 CPU 要处于 RUN 模式下。

在此期间，PCS 7 和 CPU 都会检查 CiR 功能。对于较早的模块或其他供应商的模块，尚

无法离线进行此检查。

9.11.1.5 如何删除 CiR 元素 (CPU-STOP)

简介 

在 STOP 模式下，可以删除 DP 和 PA 主站系统中的 CiR 对象，或早先定义的类型为 ET 
200M/ET 200iSP 的模块化从站中的 CiR 模块。 

组态更改不依赖于操作状态。但只能在 STOP 模式下进行下载。 
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删除 DP 主站系统的所有 CiR 元素

1. 在 HW Config 中，在站窗口的上部选择所需的 DP 主站系统。

2. 选择菜单命令“编辑”(Edit) >“主站系统”(Master System) >“禁用 CiR 功能”(Deactivate CiR 
Capability)。
以下 CiR 对象将被删除：

– 删除低级 PA 主站系统中的所有 CiR 对象。

– 删除模块化从站中的所有 CiR 模块。

– 删除所选 DP 主站系统中的 CiR 对象。

说明

请注意以下事项：

● 仅当所选 DP 主站系统中存在一个 CiR 对象时，才能删除 CiR 元素。

● 无法删除 IM 153-2（DP/PA 连接器）下 DP 主站系统中的所有 CiR 元素。

删除单个 CiR 元素

如果要删除 PA 主站系统或者类型为 ET 200M/ET 200iSP 的模块化 DP 从站中的 CiR 模
块，请执行以下操作：

1. 在 HW Config 中，选择要删除的 CiR 元素。

2. 选择菜单命令“编辑”(Edit) >“删除”(Delete)。

如果 DP 主站系统中除了该 CiR 对象外再无其它 CiR 元素，则可使用相同的步骤删除该 
CiR 对象。

9.11.1.6 如何将 CiR 元素转换为真正对象 (CPU-RUN)

新站的默认设置    

向链中添加新站时，默认情况下会为此站设置以下 I/O 区域：

● 80 字节 I 和 Q，每个 CiR 模块的 ET 200M 一个

● 80 字节 I 和 Q，对于 DP/PA 链中每个 CiR 对象的 DP/PA 站。
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已选择了上述默认设置，这样它们就足以用于典型应用，而不需要进行调整。首次下载前，

先要检查这些站特定的 I/O 设置是否满足具体应用。可在首次下载前对这些值进行修改，

而不会丧失项目的 CiR 功能。

说明

如果在向组态添加真实从站或模块时进行了非法操作，则在下载组态时系统只会通过一条

错误消息来告知此事。

对过程单元进行了任何更改后，应使用菜单命令“站”(Station) >“检查 CiR 功能”(Check 
CiR Capability) 检查是否仍有 CiR 功能。

规则

添加组件时，应遵循以下规则：

● 在类型为 ET 200M/ET 200iSP 的模块化 DP 从站内，只能在紧邻上次组态的模块的右

侧插槽中插入 CiR 模块。

自动添加 CiR 元素时会自动运用此规则。

● 在主站系统内，为所添加从站分配的 PROFIBUS 地址必须高于目前所使用的最高地址。

● 对于 ET 200iSP，每个站仅能插入或移除一个模块，然后下载。

添加 DP 或 PA 从站

1. 使用菜单命令“视图”(View) >“目录”(Catalog) 打开硬件目录。

2. 将所要添加的从站从硬件目录拖动到站窗口上方的相关 CiR 对象上。

所添加的从站将出现在站窗口的上方。该从站的名称以橙色背景显示，用以表明该从站是

从 CiR 对象创建的。

说明

添加新从站时，PCS 7 会更新从站的保证数目和最大数目以及该 CiR 对象的输入及输出字

节数。

建议按如下方式选择已添加 DP 从站的站号：

站号 = 
所有先前组态 DP 从站的最高站号 + 1
如果添加类型为 ET 200M/ET 200iSP 的兼容 CiR 的模块化 DP 从站，则此从站一开始就

具有一个 CiR 模块。
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在模块化 ET 200M/ET 200iSP 从站中插入模块

1. 使用菜单命令“视图”(View) >“目录”(Catalog) 打开硬件目录。

2. 将所要添加的模块从硬件目录拖动到站窗口下方的相关 CiR 模块上。

已添加的模块将出现在站窗口下方先前被 CiR 模块占据的位置。该 CiR 模块将被向下移动

一个插槽。

说明

向 ET 200M-/ET 200iSP 站添加模块时，PCS 7 会更新相应 CiR 模块的输入及输出字节

数。
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结果

在下图中，可以在 HW Config 视图中看到在 CiR 模块上放置一个模块后的组态。
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在 RUN 模式中下载组态

以下步骤用于在 RUN 模式下下载修改后的组态： 

1. 使用菜单命令“站”(Station) >“检查 CiR 功能”(Check CiR Capability) 检查是否可以下载当
前的组态。

2. 使用菜单命令 PLC >“下载到模块...”(Download to Module...) 将组态下载到 CPU。

说明

在将组态下载到 CPU 时，INTF LED 亮起后又随即熄灭，而 EXTF LED 保持常亮。只

有 INTF LED 再次熄灭后才能开始添加实际站或模块。EXTF LED 随即也会再次熄灭。

3. 每次从 HW Config 下载站组态时都要备份当前组态（无论 CPU 是何操作状态）。
只有这样才能确保在发生错误（数据丢失）时仍可继续工作而不会丧失 CiR 功能。

9.11.1.7 如何撤消已使用的 CiR 元素 (CPU-RUN)

简介        

通过删除所添加的从站或模块，可以恢复已下载到 CPU 的先前组态更改。

规则

删除模块和从站时适用以下规则：

● 至多从最多 4 个主站系统中删除从站或模块。

● 在 DP 或 PA 主站系统内，开始时最先删除具有最高 PROFIBUS 地址的从站。

接着继续删除具有次高 PROFIBUS 地址的从站。

● 在类型为 ET 200M/ET 200iSP 的模块化 DP 从站内，开始时最先删除具有最高插槽号

的模块。在 HW Config 中，这是最低的模块。

PCS 7 提供了以下诊断功能：在站窗口的下部以标准字体输入接下来要删除的模块，所

有其它模块均为斜体。

接着继续删除具有次高插槽号的模块。

步骤

1. 在站窗口的上部选择要删除的对象。

2. 选择菜单命令“编辑”(Edit) >“删除”(Delete)。

3. 如有必要，对每个要删除的其它对象重复第 1 步和第 2 步。
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4. 选择菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility)。

5. 将修改后的组态下载到 CPU。

说明

请注意以下事项：

● 删除从站时，PCS 7 会更新从站的保证数目和最大数目以及相关的 CiR 对象的输入及输
出字节数。

● 在类型为 ET 200M/ET 200iSP 的模块化从站中删除模块时，PCS 7 会更新相应 CiR 模
块的输入及输出字节数。

9.11.1.8 更改分布式 IO 系统中现有模块的参数设置 (CPU RUN)

对于具有以下分布式 IO 系统系列的站，可以使用 CiR 功能：

分布式 IO 系统系列 DP 主站系统上的站 

ET 200M 是

ET 200iSP 是

ET 200SP 是

在 RUN 模式下更改模块参数分配     

PCS 7 允许在操作期间，在 CPU 不处于 STOP 模式时更改模块参数，例如：

● 启用预留通道

● 更改运行模式

● 更改测量模式

根据模块的性能等级，可在 RUN 模式下更改模块参数而不影响其它模块，在某些限制下，

甚至不会影响即将进行参数更改的模块的通道。 

使用 HW Config 向 PCS 7 项目添加模块时，记住要激活常规面向模块的诊断报警。

说明

不能使用 CiR  更改现有模块的地址。

对 DP 主站系统上站的要求 

● CiR 对象位于要组态的 DP 主站系统中。

● 要修改的模块数少于 100。
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有关可在 CPU 处于 RUN 模式时进行参数更改的 ET 200 模块的详细信息，请参考硬件目

录中的信息文本（文本：在线组态）

参数更改时的模块响应

参数更改时输入及输出模块会作出如下响应：

● 对于输入模块，更改参数设置时可能有以下三种反应：

– 不受影响的通道继续返回当前的过程值。

– 不受影响的通道返回参数设置更改前最后的有效过程值。

– 所有通道返回值“0”（在数字模块和 FM 上）或 W#16#7FFF（在模拟模块上）。

● 更改参数设置时输出模块会作出如下反应：

– 不受影响的通道输出参数设置更改前最后的有效输出值。

参数更改时的 CPU 响应

在 PCS 7 中更改完参数并在 RUN 模式下将其下载到 CPU 后，即会有如下的响应：

1. CPU 执行“在 CPU RUN 模式下下载组态更改后 CPU 的响应 (页 597)”部分中所述的检
查。

2. CPU 伴随事件 W#16#350A 启动 OB 80。

3. CPU 伴随启动事件 W#16#335A 启动 OB 83。
这表明若有直接影响，则有关模块的输入或输出数据可能不再正确。
不能再调用其它任何通过触发新作业来向受影响模块发送数据记录的 SFC（例如 
SFC57“PARM_MOD”），否则在系统发送的数据记录与用户发送的数据记录之间可能会产
生冲突。

说明

在 PCS 7 中，输入及输出值在此 OB 83 启动后的状态为“BAD”（坏）。

4. 一旦 CPU 结束了 OB 83，它即会发送参数数据记录。无论有多少数据记录受所做更改影
响，每个受影响的模块均会收到其所有的数据记录。

5. 然后 OB 83 会再次启动（如果发送成功，则启动事件 W#16#325A，否则启动事件 
W#16#395B）。运行此 OB 83 不会中断任何其它优先级。

说明

在 PCS 7 中，输入和输出值在 OB 83 启动（启动事件为 W#16#325A）后的状态为“正

常”(OK)。

您只能访问属于当前正在执行的 OB 的过程映像分区的过程映像中的值。
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6. 如果数据记录传送成功，DP 主站会在模块状态数据中将这些模块标识为可用。
如果数据记录未传送成功，则 DP 主站会在模块状态数据中将这些模块标识为不可用。在第
二种情况下，访问模块时会出现 I/O 访问错误（在更新过程输入映像或向模块传送过程输出
映像或者直接访问模块时。这将启动 OB85。）

7. 模块的输入或输出数据会像发生插入报警后一样做出响应：当前这些数据并不正确，因为模
块可能尚未分析其数据记录。但是，不得再为模块激活数据记录 SFC 的限制将不再适用。

说明

例如，即使在更改模块参数分配的过程中需要禁用诊断报警，该模块可能仍然可以发送

已准备好的报警。

更改参数分配时可能出现的错误

通过 SFC 传送数据记录时可能发生相同的错误：

● 模块会收到参数数据记录，但无法对其进行评估。

● 对于 PROFIBUS DP：
严重错误（尤其是 PROFIBUS DP 上的协议错误）可导致 DP 主站完全挂起相关的 DP 
从站。随后，此站的所有模块都将失灵。

CPU 操作状态如何影响参数分配的更改 

在 RUN 模式下，在 SDB 评估之后更改参数设置。参数更改期间，INTF LED 将亮起。

如果 HALT 状态发生变化，则参数更改会中断。如果 CPU 切换到 STOP 或 RUN 模式，

则更改会继续。在 STOP 模式下，只有 OB83 调用会被忽略。

如果发生网络故障，将会中止参数更改。网络恢复后，所有现有 DP 站/IO 设备的参数将重

新分配。

主站系统之间的协调

在某些情况下，以下序列可能会在受影响的主站系统中并行运行。

● OB83 启动（启动事件 W#16#335A）

● 数据记录传送

● OB83 启动（启动事件 W#16#325A 或 W#16#395B）
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9.11.1.9 如何更改通道的参数分配 (CPU-RUN)

步骤 - 使用未曾使用的通道    

1. 更改硬件配置并通过菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility) 
来检查 CiR 兼容性。

2. 在 RUN 模式下将硬件配置下载到 CPU。

3. 更改布线。

4. 修改用户程序并将其下载到 CPU。

步骤 - 重新编程已使用的通道

该步骤取决于是否有必要根据更改后的参数更改用户程序和相应的硬件。下面对各种情况

进行了介绍。

不必更改用户程序：

例如，在更改报警限制或禁用诊断中断时便属于这种情况。

1. 更改硬件配置并通过菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility) 
来检查 CiR 兼容性。

2. 在 RUN 模式下将硬件配置下载到 CPU。

必须更改用户程序：

例如，如果要更改模拟输入模块通道的测量范围，而且要将相应的模拟值与程序中的某个

常数进行比较，便属于这种情况。在此情况下，必须对该常数进行修改。

1. 将要修改其参数的通道的各个值设为仿真（在相应的驱动程序上）。

2. 更改硬件配置并通过菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility) 
来检查 CiR 兼容性。

3. 在 RUN 模式下将硬件配置下载到 CPU。

4. 调整用户程序使其适合更改后的模块，然后将其下载到 CPU。
再次取消更改了参数分配的通道的仿真（在相应的驱动程序上）。

必须更改用户程序和硬件

例如，在将输入通道的参数从“0 mA 到 20 mA”(0 mA to 20 mA) 更改为“0 V 到 10 V”(0 V 
to 10 V) 时，便会出现这种情况。

1. 将要修改其参数的通道的各个值设为仿真（在相应的驱动程序上）。

2. 更改硬件配置并通过菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility) 
来检查 CiR 兼容性。

3. 在 RUN 模式下将硬件配置下载到 CPU。

4. 调整用户程序使其适合更改后的模块，然后将其下载到 CPU。
再次取消更改了参数分配的通道的仿真（在相应的驱动程序上）。
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更改电子模块的地址范围 (ET 200iSP)
例如，当使用某个 HART 电子模块的 IEEE 值时，便属于这种情况。

1. 将要修改其参数的通道的各个值设为仿真（在相应的驱动程序上）。

2. 在硬件配置中删除该模块，然后将其下载到 CPU。

3. 再次插入该模块，然后根据需要分配参数。

说明

切勿在此时保存硬件配置，否则会失去 CiR 下载功能。

4. 在 RUN 模式下将硬件配置下载到 CPU。

5. 调整用户程序使其适合更改后的模块，然后将其下载到 CPU。
再次取消更改了参数分配的模块的仿真（在相应的驱动程序上）。

步骤 - 删除已使用的通道

如果不再需要到目前为止所使用的通道，则不必更改硬件配置。在此情况下，可按照下面

的步骤进行操作：

1. 更改用户程序，以便不再对要删除的通道进行评估，然后将其下载到 CPU。

2. 更改硬件配置并通过菜单命令“站”(Station) >“检查 CiR 兼容性”(Check CiR Compatibility) 
来检查 CiR 兼容性。

3. 在 RUN 模式下将硬件配置下载到 CPU。

4. 修改关联的硬件（例如，删除传感器或执行器）

9.11.2 针对 RUN 模式下的组态更改 (CiR) 在 PROFINET IO 中组态分布式 I/O 设备

9.11.2.1 更改分布式 IO 系统中现有模块的参数设置 (CPU RUN)

有一些过程单元不能在操作期间关闭。这可能是由于自动化过程的复杂性或重新启动的高

昂代价所致。尽管如此，可能还是会需要扩展或修改工厂。 

使用 CiR（Configuration in Run，运行中组态），可对 RUN 模式下的组态进行某些更改。

更多相关信息，请参见系统手册《过程控制系统 PCS 7；CPU 410 过程自动化》(Process 
Control System PCS 7; CPU 410 Process Automation)。

实施 PCS 7 组态

9.11 针对 RUN 模式下的组态更改 (CiR) 组态连接的 I/O

工程组态系统 (V9.0 SP1)
420 配置手册, 12/2017, A5E39221328-AC



概述

对于具有以下分布式 IO 系统系列的站，可以使用 CiR 功能：

分布式 IO 系统系列 PROFINET IO 系统上的站

ET 200M 否

ET 200iSP 否

ET 200SP 否

ET 200SP HA 是

CiR 具体规则（单个 AS） 

● 支持类型 S1 和 S2 的 IO 设备（S2 带有支持设备内部更改的 CiR）

● ET 200SP HA 的 IO 数据针对 CiR 限制 1000 字节输入和 1000 字节输出。

● 如果可能，请使用 STOP 下载，以提供网络参数优化

● 请勿更改 LLDP Modus（如果需要，请通过特定选项固定 LLDP Modus）

● 请勿更改 IO 控制器的参数

● 请勿插入或移除 IO 控制器

● 所需最短更新时间为 1 ms

H-CiR 具体规则（冗余 AS） 

● 支持类型 S2 和 R1 的 IO 设备

● 插入和删除 IO 控制器（将 CPU 内部接口更改为 PROFINET）

● 最多 64 个 R1 设备（由于测试工作受限）

参考

关于带 CiR/HCir 和 ET 200SP HA 的 PROFINET IO 的更多信息，请参见手册《过程控制

系统 PCS 7；CPU 410 过程自动化》(Process Control System PCS 7; CPU 410 Process 
Automation )。 
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9.11.2.2 针对 RUN 模式下的组态更改 (CiR) 在 PROFINET IO 中组态分布式 I/O 设备

概述

有一些过程单元不能在操作期间关闭。这可能是由于自动化过程的复杂性或重新启动的高

昂代价所致。尽管如此，可能还是会需要扩展或修改工厂。 

使用 CiR（Configuration in Run，运行中组态），可对 RUN 模式下的组态进行某些更改。

更多相关信息，请参见系统手册《过程控制系统 PCS 7；CPU 410 过程自动化》(Process 
Control System PCS 7; CPU 410 Process Automation)。

CiR 具体规则（单个 AS） 

● 支持类型 S1 和 S2 的 IO 设备（S2 带有支持设备内部更改的 CiR）

● ET 200SP HA 的 IO 数据针对 CiR 限制 1000 字节输入和 1000 字节输出。

● 如果可能，请使用 STOP 下载，以提供网络参数优化

● 请勿更改 LLDP Modus（如果需要，请通过特定选项固定 LLDP Modus）

● 请勿更改 IO 控制器的参数

● 请勿插入或移除 IO 控制器

● 所需最短更新时间为 1 ms

H-CiR 具体规则（冗余 AS） 

● 支持类型 S2 和 R1 的 IO 设备

● 插入和删除 IO 控制器（将 CPU 内部接口更改为 PROFINET）

● 最多 64 个 R1 设备（由于测试工作受限）

参考

关于带 CiR/HCir 和 ET 200SP HA 的 PROFINET IO 的更多信息，请参见手册《过程控制

系统 PCS 7；CPU 410 过程自动化》(Process Control System PCS 7; CPU 410 Process 
Automation )。 
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9.12 组态现场设备

9.12.1 如何组态诊断中继器

简介                   

诊断中继器用于通过 DPVx 协议对 PROFIBUS DP 链中的通信错误进行简单诊断。

要求

● 已安装并接上了诊断中继器。

● 已设置了 PROFIBUS 地址。

● 已对诊断中继器进行了组态（组态和参数分配）。

● 已将盖板后的 DR 开关设置为 ON（开启）（出厂设置）。

● 已接通 DP 主站的电源。

组态硬件

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 将诊断中继器从“PROFIBUS DP > 网络组件”(PROFIBUS DP > Network Components) 硬件
目录拖动到 CPU 的 DP 主站系统。
将打开“属性 - PROFIBUS 接口诊断中继器”(Properties - PROFIBUS Interface Diagnostic 
Repeater) 对话框。

3. 设置地址和属性（总线参数），然后单击“确定”(OK)。

4. 双击诊断中继器。
将打开“属性 - DP 从站”(Properties – DP Slave) 对话框。

5. 在“参数分配”(Parameter Assignment) 选项卡上，将 DP 报警模式设置为 DPV0（将为诊
断事件调用 OB 82）。
要求：必须将 DP 主站上的模式设置为 DPV1。

6. 选择菜单命令“站 > 保存并编译”(Station > Save and Compile)。

7. 选择菜单命令“CPU > 下载到模块...”(CPU > Download to Module...)。
将加载当前组态。

这样就完成了诊断中继器的硬件配置。接着要进行拓扑标识。
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拓扑标识的要求

● 要识别其拓扑的编程设备/PC 必须与 PROFIBUS DP 相连。

● 必须要有已组态的 PROFIBUS DP 模块。

确定拓扑

1. 将编程设备/PC 连接到相关网络诊断中继器的编程设备接口。

2. 切换到 SIMATIC Manager，然后从组件视图中选择要标识拓扑的项目。

3. 选择诊断中继器所处的 DP 主站系统。

4. 选择菜单命令“选项 > 设置编程设备/PC 接口...”(Options > Set Programming Device/PC 
Interface...)，然后像在组态中那样选择“已使用的接口参数分配”(Interface parameter 
assignment used)（例如 CP 5611 (PROFIBUS)）。

5. 单击“属性”(Properties)，然后在“属性”(Properties) 对话框中设置所需的属性。
确保地址设置为“0”。

6. 单击“确定”(OK)，然后确认随即出现的警告消息。

7. 选择菜单命令“目标系统 > PROFIBUS > 准备线路诊断”(Target system > PROFIBUS > 
Prepare Line Diagnostics)。
将打开“准备线路诊断”(Prepare Line Diagnostics) 对话框。

8. 单击“重新启动”(Restart)。
将确定系统数据。

9. 标识完成后单击“关闭”(Close)。

10.选择菜单命令“选项 > 设置编程设备/PC 接口...”(Options > Set Programming Device/PC 
Interface...)，然后将接口参数分配重置为“PC 内部（本地）”(PC internal (local))。

11.单击“确定”(OK)，然后确认随即出现的警告消息。

12.使用菜单命令“目标系统 > 诊断/设置 > ...”(Target system > Diagnostics/Settings > ...)，选
择所需的诊断功能。

说明

如果存在多个 PROFIBUS 网络，则必须为每个网络分别标识拓扑。

更多信息

● 手册《SIMATIC；PROFIBUS DP 的诊断中继器》(SIMATIC; Diagnostic Repeater for 
PROFIBUS DP)
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9.12.2 如何组态 Y 连接器和 Y 耦合器

简介

要实现从 PROFIBUS 主站系统到单通道 PROFIBUS 主站系统的切换，首选使用 Y 
Link。 

从可编程控制器视角来看，Y Link 是一个 DP 从站，而从下层 DP 主站系统视角来看，它

是一个 DP 主站。

步骤

1. 从组件视图中选择所需的 SIMATIC H 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 将 IM 153-2 从“PROFIBUS DP”>“DP/PA 连接器”(DP/PA Link) 硬件目录拖动到 CPU 的冗
余 DP 主站系统。
将打开“属性 - PROFIBUS 接口 IM 153-2”(Properties - PROFIBUS Interface IM 153-2) 对
话框。

3. 如有必要，可在较高级别的 DP 主站系统中为 IM 153-2 更改建议的地址，然后单击“确定”
(OK)。
将打开用于选择较低级别主站系统的对话框。

4. 选择“PROFIBUS DP 的接口模块”(Interface module for PROFIBUS DP)，然后单击“确定”
(OK)。
Y Link 将被插入冗余 DP 主站系统中。较低级别 DP 主站系统的传输速率默认设置为 1.5 
Mbps。

5. 如果要更改较低级别 DP 主站系统的传输速率，请双击该 DP 主站系统。
将打开含有较低级别主站系统属性的对话框。

6. 单击“属性”(Properties)。将显示“PROFIBUS 属性”(PROFIBUS properties) 对话框。

7. 输入较低级别 DP 主站系统的名称，然后选择“网络设置”(Network Settings) 选项卡。

8. 选择从 45.45 Kbps 到 12 Mbps 的传输速度并单击“确定”(OK)。

9. 然后为较低级别主站系统组态 DP 从站。

更多信息

● 手册《SIMATIC；DP/PA Link 和 Y Link 总线耦合器》(SIMATIC; DP/PA Link and Y 
Link Bus Couplers)
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9.12.3 如何利用通过 PROFINET IO 上的 IE/PB Link 进行的通信组态 PROFIBUS DP

简介 IE/PB Link

PCS 7 支持 PROFIBUS DP 通过 IE/PB Link 连接到 PROFINET IO 系统。

步骤

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件组态。

2. 在 HW Config 中组态 PROFINET IO 系统。

3. 将 IE/PB Link 从硬件目录拖到 PROFINET IO 系统。
将打开“属性 - PROFIBUS 接口 PROFIBUS DP”(Properties - PROFIBUS Interface 
PROFIBUS DP) 对话框。

4. 选择表“子网：”(Subnet:) 或将其添加到 PROFIBUS DP 系统。
如果需要，请更改参数。

更多信息

● “如何组态紧凑型现场单元？ (页 399)”部分

● HW Config 在线帮助

● 手册《SIMATIC；DP/PA Link 和 Y Link 总线耦合器》(SIMATIC; DP/PA Link and Y 
Link Bus Couplers)

9.12.4 如何利用通过 PROFIBUS DP 进行的通信组态 PA 设备

简介

PCS 7 通过 DP/PA 适配器或 PA Link 与 PA 现场设备进行通信。下面将对 PA Link 进行组

态，并使用 SIMATIC PDM 为 PA 设备的进一步组态做准备。

要求

● 必须安装 SIMATIC PDM（Process Device Manager，过程设备管理器）附加件软件

包。

实施 PCS 7 组态

9.12 组态现场设备

工程组态系统 (V9.0 SP1)
426 配置手册, 12/2017, A5E39221328-AC



步骤

1. 从组件视图中选择所需的 SIMATIC 400 站，然后在详细信息窗口中双击“硬件”(Hardware) 
对象。
将打开自动化系统的硬件配置。

2. 在 HW Config 中组态 DP 主站系统。

3. 将 PA Link (IM 153-2) 从硬件目录拖到 DP 主站系统。
将打开“属性 - PROFIBUS 接口”(Properties - PROFIBUS Interface) 对话框。

4. 设置 PROFIBUS 接口参数。
将打开用于定义主站系统的对话框。

5. 定义主站系统（DP 或 PA），然后单击“确定”(OK)。

6. 选择 PA Link，这样便可在站窗口底部查看 DP 从站结构。
“插槽 2”(Slot 2) 代表 PA 设备的“主站”。

7. 双击“插槽 2”(Slot 2)以组态 PA 子网。

8. 在“常规”(General) 选项卡上的“接口”(Interface) 组中，单击“属性”(Properties)，然后选
择传输速率为 45.45 Kbps 的子网。然后单击“确定”(OK)。

9. 组态 PA 设备。
可在“硬件目录”的“PROFIBUS PA”（标准规约）下找到这些 PA 设备。

说明

仅当安装了 SIMATIC PDM 时“PROFIBUS PA”条目才可见。

必须在 PROFIBUS PA 中至少组态一个 PA 设备。否则，在编译或一致性检查期间将会

发生错误。

PA 设备组态的其余工作在 SIMATIC PDM 中进行（双击该设备）。

更多信息

● HW Config 在线帮助

● 手册《SIMATIC；DP/PA Link 和 Y Link 总线耦合器》(SIMATIC; DP/PA Link and Y 
Link Bus Couplers)

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

● “组态 SIMATIC 400 站（CPU、CP 和中央 I/O）”部分

9.12.5 如何组态分布式 I/O 上的 HART 设备

HART 现场设备可以在基于 PROFINET IO 或 PROFIBUS DP 的分布式 IO 上连接。
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通过外围模块识别 HART 现场设备

如果要组态支持 HART 的外围模块，则必须考虑以下事项：

1. 组态适用于所使用现场设备类型的支持 HART 的外围模块。

2. 将 HART 现场设备插入组态表中外围模块的插槽中。

HART 现场设备的参数化

在 PCS 7 中，请使用 SIMATIC PDM 参数化 HART 现场设备。更多相关信息，请参见 
SIMATIC PDM 的帮助文档。

9.12.6 如何使用 SIMATIC PDM 组态 HART 设备

简介

HART 设备专用于分布式 IO 站 中的分布式操作：

● IM 155-6 (ET 200SP HA)  

● IM 153-2 (ET 200M)  

● IM 152 (ET 200iSP)

下图针对使用 ET 200M 组态进行了说明。

启动 SIMATIC PDM 以便为与 HART 设备相连的 HART 测量信号生成器分配参数。 

表示 HART 传感器 

HART 模块的信号生成器在组态表中的显示方式与接口模块类似。

要求

● 已经在 HW Config 中打开了分布式 IO 站。

● 在 HW Config 中，组态一个在分布式 IO 站的空闲插槽。
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步骤 - 以 ET 200M 为例

1. 将 HART 模块（例如 AI HART）从硬件目录添加到分布式 IO 站的空闲插槽中。
可通过以下路径找到硬件目录中的 HART 模块：
“<总线系统>\<分布式 IO 站>\<分布式 IO 站\<所选接口模块>”

2. 将“HART 现场设备”(HART field device) 从硬件目录拖动到模拟输入模块的通道中。
可通过以下路径找到硬件目录中的“HART 现场设备”(HART field device)：
“<现场总线系统>\<分布式 IO 站>\<分布式 IO 站>\<所选接口模块>\AI”

3. 选择菜单命令“站 > 保存”(Station > Save)。
将保存硬件配置。

4. 双击现场设备。
打开“设备目录”(Device Catalog)。

5. 选择所需 HART 设备。

6. 将打开 SIMATIC PDM。

7. 在 SIMATIC PDM 中组态 HART 设备。

基本步骤 - 冗余 HART AI/AO 模块上的 HART 现场设备

执行以下基本组态步骤：

1. 打开 HW Config 并组态 2 个相同的 HART 模块。

2. 在 HW Config 中，为模块冗余进行所需的设置。

3. 用 HART 现场设备组态模块的通道。
在彼此冗余的两个模块通道的每个通道上，都需要组态现场设备。

4. 打开 SIMATIC PDM。
打开 SIMATIC PDM 可以定义要使用哪个设备。因而，这也会隐式地在冗余通道上安装相关
设备。
为对于支持冗余互连的现场设备，还会显示“冗余”(Redundancy) 区域。  

SHC 模式

在 SHC 模式下，多个 HART 现场设备可帮助快速实现 HART 通信。这样可缩短 HART 现
场设备参数数据的读写时间。 

为保持组态一致性，必须在 HW Config 和 SIMATIC PDM 中启用 SHC 模式。

如果激活“启用 SHC 模式”(SHC mode enabled) 选项，SIMATIC PDM 将对 HART 远程 
I/O 的模拟量通道将执行以下检查：

SHC 功能是否支持符合“PROFIBUS 和 PROFINET 国际 (PI)”现场总线组织的规范“基

于 HART on PROFIBUS”规定的 SHC 功能（无中断 HART 命令序列）。

● 如果远程 I/O 的 HART 模块支持 SHC 模式，则 SIMATIC PDM 就可使用此模式。

● 如果远程 I/O 的 HART 模块不支持 SHC 模式，则使用传统的通信方法。
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说明

与第三方 HART 现场设备通信

如果使用该选项时与个别 HART 现场设备的通信屡次中断，则应禁用该选项。

更多信息

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

9.12.7 如何使用 SIMATIC PDM 组态智能现场设备

SIMATIC PDM

SIMATIC PDM 是一个功能齐全的工具，用于同智能过程设备一起进行组态、参数分配、

调试和诊断。可在项目的各个阶段（工程组态、调试以及运行时）使用 SIMATIC PDM。

SIMATIC PDM 允许使用标准化用户界面通过单个软件包对多个过程设备进行组态。       

在 SIMATIC Manager 和 HW Config 中，SIMATIC PDM 是作为集成工具而使用的。

通过在 HW Config 中集成，可以编辑与现场总线相连的设备。其它所有设备都是在 SIMATIC 
PDM 的过程设备网络和工厂视图中进行编辑的。

设备参数和功能的显示方式对于所有支持的过程设备都是一致的，而与其通信连接无关，

例如，不管它们使用的是分布式 IO 系统还是 HART 协议，都是如此。

以下关键功能对于测试和调试过程设备数据尤为有用：

● 创建过程设备数据

● 更改过程设备数据

● 验证过程设备数据

● 管理过程设备数据

● 仿真过程设备数据

还可以在屏幕上显示为设备选择的值、报警和状态信号，进而对过程进行监视。也可通过

仿真或使用处于手动模式的设备来操纵与过程相关的值。 
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SIMATIC PDM 的用户界面

SIMATIC PDM 的用户界面支持多个视图：

● HW Config 内的视图

● SIMATIC Manager 内的过程设备网络视图

（使用“视图 > 过程设备网络视图”(View > Process Devices Network View) 菜单命令来

打开）

● SIMATIC Manager 内的过程设备工厂视图

（使用“视图 > 过程设备工厂视图”(View > Process Devices Plant View) 菜单命令来打

开）

● 组态、调试及运行视图

（请参见 SIMATIC PDM。在 Windows“开始”(Start) 菜单中通过“搜索”(Search) 打开调

用：SIMATIC PDM 和菜单命令 LifeList）

实施 PCS 7 组态

9.12 组态现场设备

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 431



通信

SIMATIC PDM 支持多种用于同以下设备进行通信的通信协议和组件：

● 采用 PROFIBUS DP 通信的设备

● 采用 PROFIBUS PA 通信的设备

● 基金会现场总线通信设备

● HART 设备

这些设备可以各种方式连接。就其基本形式而言，我们进行了如下区分：

– 分布式 IO 上的 HART 设备

– 连接到 HART 多路复用器或 HART 接口的 HART 设备

系统要求 

● 已在 HW Config 中创建了使用 SIMATIC PDM 进行组态的设备。

● 使用 SIMATIC PDM 在线工作：查看手册 SIMATIC PDM。

HW Config 中的步骤

1. 在 HW Config 中双击要用 SIMATIC PDM 进行组态的设备。
将打开“用户”(User) 对话框。

2. 选择所需的用户角色。

3. 单击“确定”(OK)。

将打开 SIMATIC PDM。

过程设备工厂视图中的步骤

1. 在 SIMATIC Manager 中，选择菜单命令视图 > 过程设备工厂视图 (View > Process Devices 
Plant View)。
将打开过程设备工厂视图。

2. 选择所需的站和“设备”(Devices) 对象。
将显示现有的所有设备。

3. 选择所需的对象，然后选择菜单命令编辑 > 打开对象 (Edit > Open Object)。

将打开 SIMATIC PDM。
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更多信息

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

● STEP 7 在线帮助

9.12.8 如何使用 SIMATIC PDM 诊断

组态支持 

除了维护工作站所提供的诊断选项外，还可以使用 SIMATIC PDM 为了支持您进行组态而

提供的诊断选项。

“SIMATIC PDM - LifeList”用于测试可以在网络上访问哪些 DP 设备和 HART 设备。 

有关连接错误起因方面的信息，可参考 SIMATIC PDM 的在线帮助。

说明

对于具有诊断能力的设备，SIMATIC PDM 要求设备特定的信息。安装 SIMATIC PDM 后，

可通过“管理设备目录”(Manage Device Catalog) 工具补充此信息。

更多信息

● STEP 7 在线帮助

● SIMATIC PDM 在线帮助

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

● 手册《过程控制系统 PCS 7；服务支持和诊断》
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9.13 创建网络连接

简介

网络（在 PCS 7 中称为子网）一方面用于自动化系统和 SIMATIC PC 站之间的通信（工

业以太网），另一方面用于自动化系统和分布式 I/O 之间的通信。   

概述

在 PCS 7 中创建网络连接涉及以下主题：

● 如何显示联网/非联网站 (页 434) 

● 如何为新子网创建和分配参数 (页 435) 

● 如何创建站的网络连接并为其分配参数 (页 436) 

● 如何更改节点地址 (页 437) 

● 如何更改 PC 网络中的传输率和运行模式 (页 438) 

● 如何保存网络组态 (页 439) 

● 如何检查网络一致性 (页 440) 

● 交互项目网络 (页 442) 

● 冗余网络的网络组态 (页 442) 

● 关于编辑网络组态的提示 (页 443) 

说明

跨网络边界的 S7 连接

如果通过路由器建立 S7 连接（对于 PCS 7，是与 AS 的默认连接），则不允许在路由器

上激活 NAT。如果 NAT 处于激活状态，则无法建立跨网络边界的 S7 连接。

9.13.1 如何显示联网/非联网站

在 NetPro 中显示项目

NetPro 以图形方式显示项目的所有组态站和网络。这样，可根据连接线立即识别某个子网

是否连接到特定站。     

在站的硬件组态期间指定能够通信的组件的网络分配。可随后在 NetPro 中更改此分配。
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步骤

1. 在 SIMATIC Manager 的组件视图中，选择要为其显示网络的项目。

2. 在详细信息窗口中选择所需网络。

3. 从菜单中选择“编辑) > 打开对象” (Edit > Open Object)。

结果

将打开 NetPro，并且项目的所有站及其网络分配均以图形方式显示。

更多信息

● “如何创建站的网络连接并为其分配参数 (页 436)”部分

● NetPro 在线帮助

9.13.2 如何为新子网创建和分配参数

在何处以及如何创建子网

下表概述了有关创建子网的各种选项：

位置 步骤 应用

HW Config 插入通信处理器时 

相关信息，请参见“如何插入通信处理器 (页 351)”部

分。

标准工厂

NetPro “插入”(Insert) >“网络对象”(Network Objects) 菜单命

令

复杂联网工厂

SIMATIC Manager “插入”(Insert) >“子网”(Subnet) 菜单命令 复杂联网工厂

读者注意事项

组态站时可创建子网，并将模块（更确切地说：模块接口）连接到子网。您已熟悉此选项。

对于复杂联网的工厂，最好使用网络视图 (NetPro)。这将在下文进行介绍。
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步骤

1. 在 SIMATIC Manager 的组件视图中选择站。

2. 选择菜单命令“选项”(Options) >“组态网络”(Configure Network)。
NetPro 打开并显示所选项目的网络组态。

3. 单击“目录”(Catalog) 窗口中的“子网”(Subnets)。
如果没有看到此项，则使用菜单命令“视图”(View) >“目录”(Catalog) 打开“目录”(Catalog) 
窗口。

4. 将所需子网拖动到图形网络视图的窗口中。
当鼠标指针呈“禁止”符号的形状时，表明无法在所在位置连接子网。
子网显示为水平线。

5. 双击子网符号。
将打开该子网的“属性”(Properties) 对话框。

6. 设置子网参数（例如，分配唯一名称）。

提示 

如果将鼠标光标置于子网图标上，则会显示包含子网属性的工具提示。

9.13.3 如何创建站的网络连接并为其分配参数

要求

● NetPro 处于打开状态。

● 显示已组态的站。

步骤

1. 利用鼠标为节点选择接口图标（其颜色与对应网络类型相同的小框），并将其朝子网方向拖
动，以建立连接。
呈现“禁止”(Forbidden) 符号形状的鼠标指针将指示不允许的网络连接（例如，将 PROFIBUS 
PA 接口连接到类型为以太网的子网）。
网络连接会显示为分布式 IO 系统的站和子网之间的一条垂直线。

2. 选择网络连接，然后选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。

3. 设置节点属性（例如，节点名称和地址）。

提示 

如果将鼠标光标置于接口图标上，则会显示含接口属性（模块名称、子网类型，若已联网，

还包括节点地址）的工具提示。
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9.13.4 如何更改节点地址

节点地址    

在以太网节点（例如，CP 或 CPU 410）的对象属性 (properties of the ethernet node (e.g. 
CP or CPU 410). ) 中指定节点地址，并定义以下属性：

● MAC 地址

● 此外，对于 IP 协议：

IP 地址/子网掩码/网关地址

MAC 地址

每个以太网节点均分配有 (ethernet node is assigned) 一个唯一的 MAC 地址。可在许多外

部打印模块上找到 MAC 地址。 

● 请注意，当使用具有固定 MAC 地址的 PC 模块时，必须接受此 MAC 地址。 

● 系统最初建议的可任意使用的 MAC 地址可能不同于该模块的地址。 

对于最新的以太网节点，可通过一个复选框来决定是否设置 MAC 地址并使用 ISO 协议。

仅当要使用 ISO 协议时，才需输入 MAC 地址。否则，该域仍为禁用状态；在下载组态数

据时，在工厂中分配给以太网节点的地址便不会被覆盖。 

IP 协议

仅在当前模块支持 TCP/IP 协议时，才显示 IP 参数。

PCS 7 根据子网掩码和子网的网关为节点接口分配“IP 地址”、“子网掩码”和“网关地

址”的默认设置。

如果不想使用默认设置，可输入新的 IP 地址/子网掩码/网关地址。

要求 

● NetPro 处于打开状态。

● 显示已组态的站。

步骤

1. 选择要更改的 ethernet node 地址。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
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3. 选择“属性”(Properties) 对话框中的“常规”(General) 选项卡，然后单击“属性”
(Properties)。

4. 在随后显示的对话框中输入 MAC、IP 地址以及子网掩码地址（如有必要）。

5. 单击“确定”(OK)。

更多信息

● NetPro（或 HW Config）在线帮助

9.13.5 如何更改 PC 网络中的传输率和运行模式

简介

为保证在网络中进行通信，必须确保以下参数在所有网络节点上的设置保持一致：         

● 传输速率

● 运行模式

说明

按照西门子设备的出厂设置，传输率和操作模式的参数会自动加以识别（自协商）。

仅当必须与网络中无权访问“自协商”设置的节点进行通信时，才需要更改此设置。

自动识别传输率和操作模式

确保以太网 CP、CPU、交换机以及网络适配器在数据传输率和总线访问程序的设置/属性

上保持一致。

建议使用默认的自协商设置（自协商两个直接相连的网络接口间最佳传输模式的过程）。

术语自协商表示自动识别和协商传输速率和操作模式（全双工/半双工）。

● 全双工是一种双向数据通信操作模式，在此模式下，通信伙伴可在传输链路上相互独立

地发送数据。

● 半双工也是一种双向数据交换运行模式，在此模式下，一次只能有一个通信伙伴在传输

链路上发送数据。

要求

如果必须与网络中无权访问“自协商”设置的节点进行通信，则需要更改该设置。
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组态网络节点

使用位

置

网络节点 打开组态对话框窗口 参数设置

PC 通信模块

例如，CP 16xx
对网络参数的自协商进行组态

（自协商）。

激活双工模式和传输速率的

选项按钮。

PC 设置 INTEL 网络适

配器（或类似的标

准网络适配器）

1. 使用开始菜单中的搜索框打

开“设备管理器”(Device 
Manager)。

2. 选择网络适配器。

3. “文件 > 属性”(File > 
Properties)

4. “高级”(Advanced) 选项卡

设置属性的值。

典型属性名称（取决于所用

的网络适配器）：

● 速度和双工模式 
(Speed and duplex 
mode)

● 连接速度和双工 (Link 
speed & duplex)

交换机 SCALANCE X ...
例如： 

SCALANCE 
X‑400

● 通过 Telnet 或 Web Based 
Management (WBM) 组态

● 通过 Internet Explorer 打开

交换机的组态对话框：

http: \\<TCP-IP 地址>

端口组态

AS 通信模块  

例如 CP 443-1  

HW Config：
CP 443‑1 属性 >“选项”
(Options) 选项卡 >“单个网络

设置”(Individual Network 
Settings) 组

在“传输介质/双工”
(Transmission medium/
Duplex) 下拉列表框中（默

认设置：“自动设置”
(Automatic setting)）

AS 以太网网络适配器

例如：

CPU 410‑5H 的 
PROFINET 连接  

1. HW Config
2. 选择端口

3. 对象属性

4. “选项”(Options) 选项卡

默认设置：“自动设置”

（自协商）

有关已认可的硬件的信息，请参见产品概述《过程控制系统 PCS 7；已发布模块》。

9.13.6 如何保存网络组态

简介     

要保存网络组态和连接表，可使用“网络 > 从站”(Network > Slave) 和“网络 > 保存并编

译...”(Network > Save and Compile...) 菜单命令。 
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保存 

如果在 NetPro 中创建了网络对象或在 NetPro 中更改了其属性，则 NetPro 将保存以下内

容：

● 节点地址

● 子网属性（例如，传输率）

● 连接

● 修改后的模块参数（例如，CPU 的参数）

保存并编译 

调用菜单命令“网络 > 保存并编译...”(Network > Save and Compile...) 后，可以在下一个

对话框中选择是编译全部内容还是仅编译更改的内容。无论选择哪个选项，NetPro 都会在

整个项目中检查组态数据的一致性，并在独立窗口中显示消息。 

选项 内容

编译并检查全部内容 
(Compile and check 
everything)

生成完整网络组态的可装载系统数据块 (SDB)；其中含有所有

连接、节点地址、子网属性、输入/输出地址和模块参数分配。

仅编译更改内容 
(Compile changes only)

创建已修改的连接、节点地址、子网属性、输入/输出地址或模

块参数分配的可装载系统数据块 (SDB)。

9.13.7 如何检查网络一致性

简介    

建议在保存之前检查网络一致性。

以下是一致性检查期间显示的状态的实例： 

● 未连接到子网的节点

（例外：非联网 MPI 节点）

● 仅有一个节点的子网

● 连接不一致
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其它步骤

在以下操作过程中将进行一致性检查： 

● “网络 > 检查一致性”(Network > Check consistency) 菜单命令

● “网络 > 检查项目范围一致性”(Network > Check consistency project-wide) 菜单命令

● “网络 > 保存并编译...”(Network > Save and Compile...) 菜单命令（在下一对话框中，

选择选项“编译并检查全部内容”(Compile and check everything)）

● 下载到目标系统（对要下载的站和连接进行一致性检查）

步骤

1. 在 NetPro 中，选择菜单命令“网络 > 检查一致性”(Network > Check Consistency)。

结果

将执行一致性检查。 

之后，将打开“<路径 + 项目名称> 一致性检查的输出”(Outputs for consistency check for 
<path + project name>) 窗口。必要时会在此框中显示错误和警告，例如关于硬件配置、网

络或连接组态的错误和警告。

“一致性检查的输出”(Outputs for Consistency Check) 窗口中的消息

如果通过保存并编译或预先下载到目标系统无法生成系统数据 (SDB)，则显示错误消息。

如果未生成系统数据，则无法将硬件/网络和连接组态下载到目标系统上。

如果报告问题后仍然能生成系统数据 (SDB)，则显示警告消息。

要获得错误或警告的帮助，请选择相应错误或警告并按 <F1> 键。 

提示

使用菜单命令“视图 > 输出”(View > Outputs) 可随时打开含有上次一致性检查结果的窗

口。 

交互项目子网的一致性 

在多项目中合并子网后（请参见“交互项目网络 (页 442)”部分）和下载前，应使用 NetPro 
中的菜单命令“网络 > 交互项目一致性检查”(Network > Check Cross-project 
Consistency) 确保整个多项目的一致性。在此检查中，将逐个对多项目的所有项目执行“完

全一致性检查”。这要考虑到多项目中的所有对象。 
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“网络 > 检查一致性”(Network > Check Consistency) 和“网络 > 交互项目一致性检查”
(Network > Check Cross-project Consistency) 这两个菜单命令一致性检查的结果相同。在

这两种情况下，将在合并的子网中搜索重复的节点地址。检查连接的一致性时，在这两种

情况下也将考虑交互项目连接。 

9.13.8 交互项目网络

交互项目网络

可以使用 PCS 7 组态交互项目以太网网络，然后使用这些网络来组态连接。在多个项目中

运行的网络并非一步创建。在各个项目中组态的子网合并到多项目中，并分配给逻辑上

的“整个网络”。“整个网络”表示所有已分配子网的共享属性。继续保留合并网络的各

个子网。 

由于进行了合并，交互项目网络便具有一个相同的子网类型和相同的 S7 子网 ID。在 NetPro 
中，它们由扩展名“属于：以太网交互项目”表示。 

交互项目网络视图

为获得更好的总览，可以在 NetPro 中使用菜单命令“视图 > 交互项目网络视图”(View > 
Cross-Project Network View)，激活“交互项目网络视图”(Cross-project network view)。
此功能在多项目中十分有用。

更多信息

● “如何将不同项目的子网合并到多项目中 (页 617)”部分

● NetPro 在线帮助 

9.13.9 冗余网络的网络组态

冗余网络

在 PCS 7 中，两个现场总线系统都可以冗余组态

请参见组态示例：

● “冗余 PROFIBUS DP 网络的布局 (页 84)”部分

● “使用 PROFINET 组态 IO 设备 (页 98)”部分
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基本操作步骤

1. 使用 PCS 7 向导创建一个包含 CPU（例如，CPU 410-5H 或 CPU 417H）的项目。

2. 可根据选择的组态进行手动或自动连接现场总线：

– 使用以下接口手动创建新的现场总线系统：

- SIMATIC H 站上 CPU 的 PROFINET 接口

- SIMATIC H 站上 CP 443-1 的 PROFINET 接口

- SIMATIC H 站上 CP 443-5 ext 的 PROFIBUS DP 接口：

– 在 SIMATIC H 站中使用 CPU 的 PROFIBUS DP 接口时，会在 CPU 的相应 
PROFIBUS DP 接口内自动创建两个现场总线系统。

继续组态时，确保将其它冗余组件（例如，冗余 OS 服务器）分配给正确的工厂总线。 

结果

创建了冗余现场总线和冗余工厂总线。

更多信息

● 功能手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System 
PCS 7; High Availability Process Control Systems)

9.13.10 关于编辑网络组态的提示

简介      

以下是有关如何编辑现有网络组态的提示。 

突出显示模块的通信伙伴 

组态连接之后，继续执行以下步骤： 

1. 在网络视图中选择可编程模块（CPU，FM）。

2. 选择菜单命令“视图 > 突出显示 > 连接伙伴”(View > Highlight > Connection Partner)。

说明

仅可突出显示可编程模块的通信伙伴。

实施 PCS 7 组态

9.13 创建网络连接

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 443



显示/修改组件属性 

要显示或修改站或者模块的属性，请按下面步骤操作： 

1. 选择组件（站图标或模块）

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。

复制子网和站

1. 选择要复制的网络对象。使用键盘/鼠标组合 <Shift> + 鼠标左按钮选择要同时复制的多个网
络对象。

2. 选择菜单命令“编辑 > 复制”(Edit > Copy)。

3. 单击网络视图中要放置副本的位置，然后选择菜单命令“编辑 > 插入”(Edit > Insert)。

说明

可复制单个网络对象或整个子网以及网络连接、站和 DP 从站。复制时，切记子网的所

有节点必须具有不同的节点地址。因此有必要更改节点地址。

删除网络连接、站和子网

1. 选择网络连接或子网的符号。

2. 选择菜单命令“编辑 > 删除”(Edit > Delete)。删除子网时，仍会保留先前连接到子网的站，
并可连接到另一子网。
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9.14 创建 SIMATIC 连接

概述

组态大中型工厂时，会将多个自动化系统插入同一个工厂单元中。这些自动化系统共享自

动化任务，因此必须能够交换数据。还必须能够在自动化系统和 PC 站之间进行数据通

信。   

以下部分对如何定义这些通信连接以及必须考虑哪些特殊功能进行了解释。

9.14.1 连接类型和连接伙伴

简介 

在使用通信块的用户程序中需要在自动化系统间或自动化系统和 PC 站（例如，OS 站）

之间进行数据交换时，必须始终组态通信连接（简称为连接）。           

连接

连接是为实现通信服务（例如交换过程值）而对两个通信伙伴的逻辑分配。连接指定以下

内容： 

● 所涉及的通信伙伴（例如，两个 SIMATIC 400 站）

● 连接类型（S7 连接、S7 容错连接）

● 特殊属性，例如：

– 连接是否始终保持已组态状态

– 哪个伙伴初始化连接组态

– 是否应传送操作状态消息

连接组态

连接组态期间，每个连接均被分配一个唯一的本地标识符，即“本地 ID”。本地 ID 也可

是符号名（命名的连接）。为通信块分配参数时，需要此本地 ID。 

对于可作为连接端点的每个可编程模块，都有一个单独的连接表。

更多相关信息，请参见“创建网络连接 (页 434)”部分。
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特性

如果两个通信伙伴均为 S7-400 站或其中一个通信伙伴为 S7-400 站，另一个为 SIMATIC 
PC 站，则 PCS 7 将为连接的两个端点自动分配本地 ID。

仅需在一个伙伴的连接表中组态连接，之后另一通信伙伴在其自己的连接表中会自动具有

匹配的条目。

选择连接类型

连接类型取决于子网和建立连接所用的传输协议。所使用的通信块取决于连接类型。 

在 PCS 7 中，使用以下连接类型：

● S7 连接

● S7 容错连接

9.14.2 如何组态两个 SIMATIC 400 站之间的连接

要求    

已创建两个 SIMATIC 400 站。 

说明

确保项目中没有重复节点地址（如果不确定，使用 NetPro 检查）。
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步骤

1. 在 SIMATIC Manager 的组件视图中选择所需项目。

2. 选择菜单命令“选项”(Options) >“组态网络”(Configure Network)。
将打开网络视图。项目中存在的 SIMATIC 400 站、相应的 ET 200M I/O 设备、操作员站以
及网络均将显示在网络视图中。

3. 在网络视图中选择要为其创建连接的模块，例如，SIMATIC 400(1) 的 CPU。
所选模块的连接表将显示在网络视图的下部。

4. 在连接表中选择一个空行，然后选择菜单命令“插入”(Insert) >“新连接...”(New 
Connection...)。
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5. 在“插入新连接”(Insert New Connection) 对话框中选择所需的连接伙伴。此处选择 
SIMATIC 400(2) 的 CPU。

说明

如果创建了到多项目的另一项目中某个伙伴的连接，则必须输入连接名称（引用）。基

于连接名称，可随后合并交互项目连接。 
组态相应的 PC 站 (OS) 时，在连接的“属性”(Properties) 对话框中输入连接名称（组：

“连接标识”(Connection Identification)；域：“本地 ID”(Local ID)）。

6. 从“类型”(Type) 下拉列表中选择“S7 连接”(S7 connection) 条目。

7. 如果要在执行“确定”(OK) 或“添加”(Add) 操作后查看或更改连接的属性，请选择“插入前
显示属性”(Show properties before inserting)。
“属性...”(Properties...) 对话框中显示的内容取决于所选的连接。
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结果

PCS 7 在本地（所选）伙伴的连接表中输入连接，并为此连接分配本地 ID（可更改），并

可在必要时，分配用于编程通信功能块所需的伙伴 ID。伙伴 ID 是块参数“ID”的值。

下载连接

在组态新连接之后，将连接下载到相应站的 CPU 中。 

1. 选择菜单命令“网络”(Network) >“保存并编译...”(Save and Compile...)。
将打开“保存并编译”(Save and Compile) 对话框。

2. 选择选项“编译并检查全部内容”(Compile and check everything) 或
“仅编译更改内容”(Compile changes only)。

3. 在从中组态连接的一个站中选择 CPU。

4. 选择菜单命令 PLC >“在当前项目中下载”(Download in the current project) >“连接和网关”
(Connections and Gateways)。
将下载所有的连接和网关。

说明

还必须下载伙伴站的组态数据。 

更多信息

● “多项目中的交互项目连接 (页 456)”部分

● 对话框的在线帮助
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9.14.3 如何组态 PC 与 SIMATIC 400 站之间的连接（命名的连接）

连接符号名称（命名的连接）               

可为 OS 和 AS 之间的连接分配符号名称而不是连接 ID。此步骤也称为“命名的连接”。

我们建议分配 AS 的名称。编译 OS 后，此名称将出现在“SIMATIC S7 Protocol Suite”中。

更多相关信息，请参见组态手册《过程控制系统 PCS 7；操作员站》(Process Control 
System PCS 7; Operator Station)。

说明

如果在 PC 站与一个 AS 之间组态多个连接，则这些连接必须都具有相同的名称。

步骤

1. 在 SIMATIC Manager 的组件视图中选择所需项目。

2. 选择菜单命令“选项 > 组态网络”(Options > Configure Network)。
将打开网络视图。项目中存在的 SIMATIC 400 站、相应的 ET 200M I/O 设备、操作员站以
及网络均将显示在网络视图中。
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3. 在“SIMATIC PC 站”的符号中，选择“WinCC 应用程序”(WinCC Application)。
该连接表将显示在 NetPro 窗口的下部。
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4. 要插入新连接，请选择菜单命令“插入 > 新连接...”(Insert > New Connection...)。
将打开“新连接”(New Connection) 对话框。

5. 在“连接伙伴”(Connection Partner) 域中选择应与 OS 连接的 CPU。

说明

如果要在多项目中操作，则使用多项目文件夹选择目标项目以及在目标项目中找到的所

需 CPU。

6. 选中“Display properties before inserting（插入前显示属性）”复选框。
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7. 单击“确定”(OK)。
将打开“属性 - S7 连接”(Properties - S7 connection) 对话框。

说明

在“本地 ID：”(Local ID:) 中，默认将输入一个连接名 (S7 connection_1)。

8. 调整本地 ID 名称以符合项目要求（例如，AS 的名称）。这有助于避免错误并维护总览。
在连接表中可再次找到此连接名（命名的连接）。
现在，可以在编译 OS 时使用此路径将相应的 S7 程序传送至 OS（取决于编译 OS 的设
置）。

9. 单击“确定”(OK)。

说明

为避免出错以及更清楚明了，应更改默认的连接名称 (S7 connection_1) 以满足项目要

求（例如，AS 的名称）。
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10.选择菜单命令“网络 > 保存并编译...”(Network > Save and Compile...)。
将关闭连接组态。

11.选择 PC 站，然后选择菜单命令“目标系统 > 在当前项目中下载 > 所选站”(Target system > 
Download in Current Project > Selected Stations)。
将下载组态。

说明

在 HW Config (CPU-STOP) 硬件配置初始下载后，仅使用“编译和下载对象”(Compile 
and Download Objects) 功能或从 NetPro 内便可下载组态更改。 

仅更改本地 ID

本地 ID 可直接在连接表的“本地 ID”(Local ID) 列中进行更改。 

转到伙伴站

要求： 

● 连接伙伴所位于的项目已打开。

● 参与项目的子网已合并。

在连接表中进行编辑时，请按以下说明直接转到连接伙伴的连接表： 

1. 在连接表中选择连接。

2. 选择菜单命令“编辑 > 转到连接伙伴”(Edit > Go to Connection Partner)。

此功能也可用于多项目中的交互项目连接。 

说明

在工程师站上的 OS 模拟启动或终止时，为避免 AS 在运行期间生成消息，工程师站的连

接 ID 应大于 0xc00。

更多信息

● “多项目中的交互项目连接 (页 456)”部分
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9.14.4 如何使用连接表

要求  

● NetPro 处于打开状态。

● 已选择 CPU 或 WinCC 应用程序。

显示和隐藏列 

1. 从连接表快捷菜单中，选择菜单命令“显示/隐藏列”(Display/Hide Columns) > ...，然后从下
一快捷菜单中选择要显示或隐藏的列名。

可见列的名称由复选标记加以指示。如果选择可见列，则复选标记将消失并且此列将隐

藏。 

优化列宽 

要根据列中的内容调整列宽（所有文本均可识别），请按以下步骤操作： 

1. 将鼠标指针定位于连接表标题行中要进行优化的列右侧，直至鼠标指针变为两条平行线（正
如要通过拖动鼠标指针改变列宽那样）。

2. 双击此位置。

提示：如果列设置得过窄，在鼠标指针短暂停留于某个域上时，各个域的全部内容都会显

示出来。

说明

项目关闭后，会按照特定的项目存储列宽和对所显示列的选择。即使在其它计算机上打开

此项目时，项目设置也仍然有效。 

排序连接表 

要根据特定列按升序排序此连接表，则单击列标题。 

再次单击列标题将按相反顺序排序此连接表。 

更改连接属性 

如果要更改已组态的连接，例如设置不同的连接路径（接口），请按以下步骤操作： 

1. 选择要更改的连接。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
可在打开的对话框中更改那些允许编辑的连接属性。
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转到连接伙伴

要求：

连接伙伴所在的项目已在 NetPro 中打开。

如果正在连接表中进行操作，可直接转到连接伙伴的连接表中： 

1. 在连接表中选择连接。

2. 选择菜单命令“编辑 > 转到连接伙伴”(Edit > Go to Connection Partner)。

此功能也可用于多项目中的交互项目连接。

突出显示连接伙伴

要求：

已创建连接。

如果还想让连接伙伴显示在图形网络视图中，可使用以下视图选项：

1. 选择可编程模块（CPU，FM）。

2. 选择菜单命令“视图 > 突出显示 > 连接伙伴”(View > Highlight > Connection Partner)。

更多信息 

● 连接表的在线帮助。

9.14.5 多项目中的交互项目连接

简介

如果项目间子网已组态，则也可在所有子网上组态连接。这些连接的端点可位于不同的项

目中。    

在创建多项目中内的跨项目连接时，以及同步在没有多项目环境的情况下组态的连接时，

PCS 7 都能提供支持。 

连接到指定伙伴的交互项目连接 

创建与指定伙伴（例如 CPU）的项目间连接与在创建项目中的连接类似。用于选择连接伙

伴的对话框不仅允许选择端点（例如模块），还允许选择多项目中端点所在的项目。 

为实现这一点，项目必须是多项目的一部分，并且子网必须已经合并（例如，使用 SIMATIC 
Manager 的“同步项目”向导）。 

实施 PCS 7 组态

9.14 创建 SIMATIC 连接

工程组态系统 (V9.0 SP1)
456 配置手册, 12/2017, A5E39221328-AC



交互项目连接的属性 

操作多项目中的项目时，会保持跨项目连接的一致性。即使具有连接伙伴的项目已从多项

目中删除，多项目内的跨项目连接仍起作用并可进行编译。 

S7 连接的规则：

在打开“属性”(Properties) 对话框之前，PCS 7 只会询问是否应仅在显示连接的属性后断

开连接。仅在回答“是”(Yes) 后方可更改连接的属性。如果修改属性，则必须确保亲自同

步连接属性。 

说明

仅连接的本地 ID 可在不断开连接的情况下进行更改（在表中直接进行更改）。 
不能断开 S7 容错连接。

如果已断开两端的连接，可以通过菜单命令编辑 > 合并连接... (Edit > Merge Connections...) 
再次合并该连接。

有关此主题的更多信息，请参见该对话框的在线帮助。

连接到不可用伙伴的交互项目连接

如果因为相关项目正在别处进行创建或因为正在对其进行编辑导致锁定，致使多项目中的

连接伙伴“不可用”，则选择“在未知项目中”(in unknown project) 作为连接伙伴。在伙伴

项目中，也将选择“未知项目中的伙伴”(Partner in unknown project) 作为连接伙伴。 

此步骤预留了两项目中的连接，这两个项目可在伙伴项目随后包含在多项目中时，通过系

统支持进行同步。 

为实现这一点，必须在两项目的连接属性中组态相同的连接名称（引用）。基于连接名称，

可使用菜单命令编辑 > 合并连接... (Edit > Merge Connections...) 来分配连接伙伴和同步连

接属性。 

有关此主题的更多信息，请参见“如何合并交互项目连接 (页 618)”部分。

下载时的注意事项 

如果已组态了跨项目子网和连接，则必须将网络组态下载到所涉及的所有模块。这些模块

包括连接的端点和所需路由器。 

上传（上传到编程设备）时，已组态的网络组态和连接会假设满足要求而自动合并（例如，

两端点均上传）。 
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NetPro 中的下载功能不是跨项目操作，仅在单个项目中有效。这会影响以下功能：

● 在当前项目中下载 > 选定的站 (Download to Current Project > Selected Stations)

● 在当前项目中下载 > 所选站和伙伴站 (Download to Current Project > Selected and 
Partner Stations)

● 在当前项目中下载 > 子网中的站 (Download to Current Project > Stations on the Subnet)

● 在当前项目中下载 > 选定的连接 (Download to Current Project > Selected Connections)

● 在当前项目中下载 > 连接和网关 (Download to Current Project > Connections and 
Gateways)

● 保存并编译 (Save and Compile) 也仅限于当前激活的项目。

例如，如果 S7 连接是跨项目连接，则必须编译所涉及的两个项目的网络组态。 

更多信息

● “如何合并交互项目连接 (页 458)”部分

9.14.6 如何合并交互项目连接

要求

要在多项目中合并连接必须满足以下条件：   

● 对于相应的连接，在项目中使用完全相同的连接名。此名称也可用作引用。

● 只可以在 NetPro 中将未指定通信伙伴的 S7 连接合并到项目间 S7 连接。在 SIMATIC 
Manager 中会忽略此类连接。

步骤

1. 在 SIMATIC Manager 中选择所需多项目

2. 选择菜单命令文件 > 多项目 > 同步项目 (File > Multiproject > Synchronize Projects)。
将打开“同步多项目 <多项目名称> 中的项目”(Synchronize Projects in the 
Multiproject<name of the multiproject>) 对话框。

3. 在左侧窗口中选择“合并连接”(Merge connections) 条目。

4. 单击“执行”(Execute)。

5. 如果“结果”(Result) 对话框中未指示错误，则单击“保存”(Save)。
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结果

在多项目中会合并和同步这些连接。

9.14.7 冗余连接的组态连接

冗余连接    

高可用性连接是一种单独的连接类型。以下伙伴可以通过高可用性连接进行通信：

● SIMATIC H 站（两个 H-CPU）与 SIMATIC H 站（两个 H-CPU）通信

● SIMATIC PC 站与 SIMATIC H 站（两个 H-CPU）通信

高可用性连接的属性与 S7 连接的属性相对应；不过，仅限于 SIMATIC PC 站的 H-CPU 
和 OPC 服务器。

使用 S7 高可用性连接，通常可以在连接端点之间建立两个连接路径。

要求

● 高可用性系统中两个子系统的硬件组态相同。

● 参与的通信伙伴为 H-CPU 或适当组态的 SIMATIC PC 站。

● 在 SIMATIC PC 站上安装 S7-REDCONNECT 软件包，以便在 SIMATIC PC 站和高可

用性自动化系统之间使用高可用性 S7 连接。

步骤

1. 选择要从中组态新连接的 H 站的 CPU（H-CPU）。

2. 选择菜单命令“插入 > 新连接...”(Insert > New Connection...)。

3. 在打开的“插入新连接”(Insert New Connection) 对话框中选择所需的连接伙伴。

4. 从“类型”(Type) 下拉列表中选择“容错 S7 连接”(Fault-tolerant S7 connection) 条目。

5. 其余步骤与组态 S7 连接时的步骤相同。

更多信息

● 手册《过程控制系统 PCS 7；高可用性过程控制系统》(Process Control System PCS 7, 
High Availability Process Control Systems)
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9.15 组态 AS 功能

9.15.1 编程步骤概述

概述

在组件视图中创建了包括图表文件夹的 S7 程序之后，通过插入 CFC/SFC 并进行编程，

可以在工厂层次结构定义 AS 功能。下表概括了基本的编程步骤，下文将会对其进行更为

详细地介绍。     

内容 强制 可选

创建 CFC（简介） (页 464) X  

组态 I/O 的接口（通道块和诊断块） (页 503) X  

通过过程变量类型创建过程变量（多项目） (页 509)  X 
适用于大量数据处理 

创建顺序控制系统 (SFC) (页 521)  X

创建模型（多项目） (页 555)  X 
适用于大量数据处理 

另请参见有关以下主题的信息：

● 由多位用户进行的组态（文本互连） (页 461) 

● 编辑大量数据 (页 563) 

● 数据交换概述 (页 621) 

更多信息

● 有关 CFC 和 SFC 访问保护的信息，请参见“如何防止对工厂进行未经授权的访问？ 
(页 37)”部分。

● 有关 CFC 和 SFC 的版本控制信息，请参见“CFC 及 SFC 版本控制 (页 701)”部分。
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9.15.2 由多位用户进行的组态（文本互连）

基本操作步骤    

在编程设计 CFC 及 SFC 之前，应决定是否将会由多位工程师对项目进行编辑。为实现这

一点，可在图表级（S7 程序）进行分支与合并。

应按照工艺特点在项目内分布（例如，应将单元与相关图表一起复制到其它项目）。会自

动以文本互连替换现有跨图表互连。

编辑完成后，将各部分复制回原始项目中。在提示进行确认后，将会替换任何同名的图表。

然后重新建立文本互连。

在日志中会指出因块被删除而无法关闭的文本互连。这时可手工对互连进行系统地编辑。

分布和合并项目数据

1. 将项目的工艺部分（例如，图表文件夹或图表）复制到另一项目中。
副本将包含与所有未复制的源的文本互连。

2. 单独编辑所复制的部分（添加、删除、修改块和图表）。

3. 将此已编辑的工艺部分复制回原始项目中。
将图表复制到组件视图的图表文件夹时，确认提示后会覆盖已处理的图表。现在，与所复制
图表相连的图表存在着文本互连。

4. 在 CFC 编辑器中，选择菜单命令“选项 > 关闭文本互连”(Options > Close Textual 
Interconnections)。
将关闭所有“开放”的互连。
在另一项目内经过编辑的图表中和追溯到原始项目的图表中以及在因删除图表而引起了文本
互连的图表中，互连都会被关闭。

说明

必须在组件视图中复制图表。

如果在工厂视图中复制图表，将创建图表的副本而不是进行替换。

文本互连规则

● 图表要通过复制来插入到其它项目中。这样，在返回经过编辑的图表之前，将会一直保

持原始项目的完整功能。

● 当互连中断时，互连伙伴双方都不能进行重新命名，否则，便无法再次关闭文本互连。

● 当同名的图表从临时项目中返回到原始项目时，将会放弃对原始项目中的图表所做的更

改。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 461



● 原始项目中可能会产生不必要的互连，例如，如果在临时项目中修改了跨图表互连而只

将所涉及的其中一个图表返回到原始项目，便会出现这种情况。

示例：图表 CFC_A 包含一个与 CFC_B 图表中的块连接的互连。这两个图表均被复制

到一个临时项目中，并进一步对它们进行编辑。编辑期间，删除了图表间的互连。只

将 CFC_A 返回到原始项目。在原始项目的 CFC_B 中创建一个文本互连；该互连也可

以是闭合的。

结果：在临时项目中删除的互连会重新出现在原始项目中。

● 目标项目（临时项目）中包括复制/移动之前所创建的文本互连。这可能是具体的路径引

用（可能已关闭），也可能是字符串（仅会在目标项目中组态的所需连接）。

将多个 S7 程序合并成一个 S7 程序 

要在未联网的工作站上合并 S7 程序，必须将各个块或源分别复制并插入到目标中。必须

手动编辑项目的全局数据（如变量表的符号表）。 

按照下面概括的步骤进行操作：

1. 在 SIMATIC Manager 中，将块和源复制到 S7 程序的相应文件夹。

2. 以 ASCII 格式导出各个 S7 程序的符号表，然后将它们导入到合并后的 S7 程序的符号表
中。

3. 检查是否有任何符号使用了两次。
提示：还可使用剪贴板（复制和粘贴）整合符号较少的符号表。 

4. 将所要使用的变量表复制到新变量表中，或使用剪贴板将各种变量表整合（复制和剪贴）到
新变量表中。

复制含有消息属性的 S7 程序 

如果已提供了含有消息属性的块，则在复制 S7 程序时应注意以下限制（它们与消息号分

配步骤无关）： 

项目范围的消息号分配

消息号可能发生重叠。为了避免冲突，请注意以下事项： 

● 在 SIMATIC Manager 中，使用菜单命令“编辑”(Edit) >“特殊对象属性”(Special Object 
Properties) >“消息号...”(Message Numbers...)，为每个 S7 程序分配一个固定的消息号

范围。

● 在复制 S7 程序时，确保不覆盖 S7 程序。

● 只有消息类型 (FB) 可与 S7 程序分开进行编程。
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CPU 范围的消息号分配

● 可在项目内以及从其它项目中复制程序，而无需更改消息号。

● 复制各个块时，消息号会发生变化，必须对块进行重新编译以便将修改后的消息号链接

到程序中。

将采用项目范围消息号分配的程序复制到采用 CPU 范围消息号分配的项目中 

● 如果要将在项目范围分配消息号的程序复制到另一个在 CPU 范围分配消息号的项目，

请在 SIMATIC Manager 中选择所需程序，然后选择菜单命令“文件”(File) >“另存为...”
(Save As...) 并激活“重新组织”(With Reorganization) 复选框。这同样也适用于项目包

含多个程序（多个 AS）的情况。

● 复制程序时，将会为消息属性建立默认条目。

将采用 CPU 范围消息号分配的程序复制到采用项目范围消息号分配的项目中 

只能复制各个含有消息的 FB。 

说明

程序中消息号的分配在项目内必须统一！

如果将引用某个文本库的含有消息的块复制到另一个程序，则还必须要复制相应的文本库，

或创建另一个同名的文本库，或更改消息文本中的引用。

在 CPU 范围消息号分配与项目范围消息号分配之间进行更改

如果在 CPU 范围的消息号分配与项目范围的消息号分配之间进行更改，则需要为每个 AS 
更新 CFC 中的块。

1. 从在其中更改了库块的 S7 程序中打开 CFC。

2. 选择菜单命令“选项 > 块类型...”(Options > Block Types...)。
将打开“块类型”(Block Types) 对话框。

3. 在“图表文件夹”(Chart folder) 列表中，选择所有要导入新版本的块。

4. 单击“新版本...”(New Version...)。
将显示一条警告消息，其中包括有关新旧版本的信息并询问您是否确实要更新块类型。如果
单击“是”(Yes)，则执行集中类型更改。图表文件夹中所有块类型的实例也会随之更改。

5. 关闭对话框。

6. 对项目/多项目中的所有工作站重复第 1 步至第 5 步。
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将 S7 连接插入到未指定的连接伙伴中

如果将与未指定伙伴具有 S7 连接的现有项目插入到多项目中，很容易即可将这些 S7 连接

转换为跨项目 S7 连接： 

1. 合并 S7 连接经过的子网：
有关此主题的更多信息，请参见“如何将不同项目的子网合并到多项目中 (页 617)”部分。

2. 在 SIMATIC Manager 中，选择菜单命令“选项 > 组态网络”(Options > Configure Network)。
将打开 NetPro。

3. 选择菜单命令“编辑”(Edit) >“合并连接...”(Merge Connections...)。

PCS 7 会自动合并匹配的 S7 连接。

更多信息

● STEP 7 在线帮助

9.15.3 创建 CFC（常规）

CFC 和 CFC 编辑器

要组态工厂中的连续过程，需要使用通过 CFC 编辑器创建和编辑的 CFC。将主数据库或 
PCS 7 高级过程库中的块插入到这些 CFC 中。     

例如，PCS 7 高级过程库包含用于控制过程或监视测量值的块。这些块的输入和输出直接

在 CFC 编辑器中进行互连及指定参数值。在此过程中，CFC 编辑器图形用户界面会提供

支持。 

在工厂层级中存储 CFC 它们始终位于其具有工艺意义的层级文件夹中。 

PCS 7 高级过程库还提供过程变量类型。它们代表了用于各种过程变量（如电机和阀）的

完整 CFC。 

说明

建议将项目中使用的所有块、图表、过程变量类型等存储在主数据库中，然后在组态期间

只访问主数据库。这尤其适用于从库中复制然后针对项目进行了修改的对象。

有关 CFC 编辑器的详细信息，请参见在线帮助及相应手册。
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块形式的功能

在 CFC 中，可使用具有特定功能的现成块。可将这些功能块放置在 CFC 中，将它们互连

及为它们分配参数。

块类型

对于每个功能块，都存在指定以下内容的类型定义：

● 算法

● 类型名称

● 数据接口（这些是输入和输出参数）

类型定义还指定输入和输出参数的数据类型。这些输入和输出参数称作块输入和块输出，

因为它们在块的图形显示中就是这样出现的。

块实例

块实例是在将块类型放置在 CFC 中后使用块类型创建的。 

从一个特殊的块类型可创建任意数目的块实例。视其具体用途，可为不同的块实例命名、

将它们互连及为它们分配参数，而不必更改特定类型功能的工作方式。

例如，此类型实例概念的一个有用之处是，以后在对块类型进行集中更改后，可自动在所

有块实例中进行这些更改。

复合块（多实例块）

功能可由不同的部分功能组成。可一并添加用于执行部分功能的块，以形成执行整个功能

的多实例块。例如，这样可能会形成一个控制块，它起内部块的作用并且包含消息和操作

员控制块。

通过将不同的块（功能）互连并为它们分配参数，可在 CFC 中创建多实例块。随后该图表

将编译为块类型。

主数据库

在多项目工程组态中，可使用主数据库。它包含该多项目所有项目的项目主数据（块类型、

过程变量类型等）。更多信息，请参见“主数据库简介 (页 306)”部分。
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更多信息

● 通过过程变量类型创建过程变量（多项目） (页 509) 

● 手册《S7 的 CFC；连续功能图》(CFC for S7; Continuous Function Chart) 及在线帮

助。

9.15.3.1 组态步骤概述

要求

在 SIMATIC Manager 中创建可组态 CFC/SFC 的项目结构（工厂视图）。

组态任务概述

下表包含组态过程中必须执行的步骤。

说明

输入单元时，确保未使用以下特殊字符：[ ' ] [ $ ]。 

步骤 内容 描述

 1 创建项目结构 必须在 SIMATIC Manager 中程序文件夹的层级下创建 CFC 的图表文件夹。

CFC 存储在图表文件夹中。

创建块（可选） CFC 可使用现成块。这些现成块可来自库、其它程序，或您创建的块类型。

 2 导入块

（如果通过插入块未

能隐式地导入这些

块）

插入项目所需的块类型，必要时可根据 CPU 以不同方式导入。导入块后，

CFC 即可识别它们。块类型应存储在主数据库中。

 3 创建、导入或打开 
CFC

要执行自动化功能，创建 CFC 或将其从现有项目导入。在 CFC 编辑器中打

开现有图表。

注意：

即使一个图表已经打开进行组态，该图表也可以由其它用户打开进行编辑。

其它用户会接收到以下信息：

“图表 x 已由 <工程师站名称> 上的 <登录名称> 打开”(Chart x opened by 
<logon name> on <name of engineering station>)
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步骤 内容 描述

 4 插入块

（到 CFC 中）

可采用从主数据库或块目录中拖动块的方式将块插入 CFC 中。此操作会创

建一个块实例，其名称在整个图表中都是唯一的。可使用每个块类型创建任

意数量的块实例。

 5 分配参数并将块互

连 
可分配参数并将块输入和输出互连到其它块、嵌套图表或共享地址。 

可在其互连目标尚未出现在图表文件夹中的块/图表输入处指定文本互连。这

些互连将保持打开状态，直到引用的互连伙伴出现，随后可使用菜单命令关

闭这些互连。 

互连表示在块之间或其它对象之间进行通信时，值从一个输出传送到一个或

多个输入。

 6 修改运行属性 块的运行属性决定如何将块包括在 CPU 的整个结构处理中。这些属性对目

标系统响应能力具有决定性作用，而其响应能力反映在反应时间、停滞时

间、依赖时间的结构（例如，闭合回路）。 

插入块时，会为每个块分配默认运行属性。为此，将块安装在 OB 任务中您

确定的位置。必要时，可在以后更改块的安装位置及其它属性。

 7 编译 CFC 在编译为程序时，激活的 CPU 的所有图表都将转换为机器代码（编译器）。

如果编译为块类型，将只编译个别图表。

 8 加载 CFC 程序 编译后，可将 CFC 程序下载到目标系统（自动化系统）。

CFC 与 SIMATIC Manager 之间的交互规则

使用 SIMATIC Manager 时，请记住以下几点：

● 仅当 CFC 中当前没有编辑特定图表文件夹或项目中的图表时，才能在 SIMATIC Manager 
中删除图表、图表文件夹和项目。

● 对于使用 CFC 的项目，使用菜单命令“新建项目”(New Project) 或“项目另存为”(Save 
Project As...) 均无法将可移动数据介质组态为存储位置。

更多信息

● CFC 在线帮助

● 手册《S7 的 CFC；连续功能图》(CFC for S7; Continuous Function Chart)

● 入门指南《S7 的 CFC；连续功能图》(CFC for S7; Continuous Function Chart)

● 相关信息，请参见“CFC 及 SFC 版本控制 (页 701)”部分。

● 有关访问保护的信息，请参见“如何防止对工厂进行未经授权的访问？ (页 37)”部分。
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9.15.3.2 如何创建新的 CFC

简介

项目结构是在创建工厂层次结构时指定。可以在此找到所有 CFC。可在工厂视图中指定对

各工厂部分的分配。

要求

已在 SIMATIC Manager 中创建了包含 S7 程序的项目。

步骤

1. 在 SIMATIC Manager 的工厂视图中选择所需的层级文件夹。

2. 选择菜单命令“插入 > 工艺对象 > CFC”(Insert > Technological Objects > CFC)。
将创建一个具有默认名称的空白 CFC。新的 CFC 包括一个带有 6 张表单的图表分区，没有
其它图表分区。

3. 根据需要更改名称。

说明

图表名称不能超过 22 个字符。名称中不能包含下列字符：\ / . " %

图表中的图表方法

可提供带有图表 I/O 的 CFC，这样便可将其插入到其它图表并可与任何块或 CFC 互连。

通过使用图表中的图表方法，创建嵌套图表。

也可将不带图表 I/O 的图表插入到其它 CFC 中。例如，如果愿意以后再创建图表 I/O，便

属于这种情况。

更多信息

● “如何定义 CFC I/O (页 480)”部分

● CFC 在线帮助

● 图表中的图表方法：手册《过程控制系统 PCS 7，入门指南 - 第 2 部分》(Process 
Control System PCS 7, Getting Started - Part 2)

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
468 配置手册, 12/2017, A5E39221328-AC



9.15.3.3 如何将额外的块插入到 CFC 中

简介

插入块时，在主数据库或块目录中选择一种块类型，并将其置于 CFC 中。然后将为块分配

一个在图表内唯一的名称。插入的块是块类型的实例。可使用每个块类型创建任意数量的

块实例。 

说明

块类型的注释未包括在块实例中。注释字段不接受空值。

步骤

1. 在 SIMATIC Manager 中选择 CFC。

2. 选择菜单命令“编辑 > 打开对象”(Edit > Open Object)。
CFC 会在 CFC 编辑器中打开。新的 CFC 包括一个带有 6 张表单的图表分区，没有其它图
表分区。

3. 在块目录中选择“库”(Libraries) 选项卡。
还可在此处看到主数据库。

4. 从主数据库中选择要插入的块类型，然后将其拖入图表中。
即会在 CFC 中创建该块类型的实例。

5. 以相同方式在 CFC 中插入更多块。

块的运行属性已进行了预定义。必要时可更改运行属性：更多相关信息，请参见“运行组

和运行属性 (页 472)”部分。

搜索块

可通过以下方法搜索块：在块目录的输入域中指定块名称，然后使用“查找”(Find) 按钮

（双筒望远镜图标）来搜索块。如果未找到与所输入文本匹配的块名称，CFC 将会搜索具

有相应注释的块。查找到时将会打开包含块的文件夹并选择块。

使用复选框“搜索起始字母”(Search for initial letter) 可在两种不同搜索模式间进行选择：

● 自由搜索（默认）

程序将搜索名称或注释的特定部分。

● 受限搜索

搜索始于起始字母。
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CFC 编辑器中的块目录

如果块目录尚未打开，请使用菜单命令“视图”(View) >“目录”(Catalog) 打开它。

可以在块目录中看到以下三个选项卡：

选项卡 描述

块 其中，块按块系列分类。还可在 S7 程序名称下找到使用中的块。

图表 在此，您可找到在 S7 程序的图表文件夹中创建的所有图表。一个

小的且打开的文件夹图标用来表示 CFC 编辑器中打开的图表。

库 (Libraries) 通常可在此处找到 PCS 7 提供的所有库以及主数据库。使用“隐

藏”功能可隐藏项目工程不需要的所有库（请参见“使用库 
(页 312)”部分）。将始终显示主数据库。

更多信息

● CFC 在线帮助

9.15.3.4 如何为块分配参数并进行互连

块 I/O              

每个块都有若干个不同的 I/O。 

块 I/O 可为“可见”和“不可见”两种状态： 仅可在块的属性中看到“不可见”参数，不

可在 CFC 的表示中看到这些参数。 

使用块的属性来指定 CFC 中始终处于可见或隐藏状态的 I/O。如果将与块互连的连接切换

为不可见，则在块标题中用一个小三角形指示。 

步骤

1. 在 CFC 中选择块，然后选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
将打开“属性 - 块”(Properties - Block) 对话框，并且“常规”(General) 选项卡处于活动状
态。

2. 在“名称”(Name) 框中，为块实例输入一个唯一的名称。块实例的名称在 CFC 中必须唯一。

说明

块名称的最大长度是 16 个字符（如果是嵌套图表，则为 22 个字符）。名称中不能包

含下列字符：\ / . " %

3. 打开“输入/输出”(Inputs/Outputs) 选项卡。
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4. 可在此处设置针对块的所有 I/O 的参数（I/O 的值、可见/隐藏、测试发布、归档相关等）。
“名称”(Name) 列列出了所有输入和输出的名称。
单击表格的列标题可方便快捷地查找 I/O：列将按升序或降序排序。

说明

如果更改了单元或操作员文本，进行块类型导入时将不再考虑它们。

5. 分配完所有的参数后单击“确定”(OK)。
名称将显示在 CFC 的块标题中；参数也分配给了块。

6. 按相同步骤在 CFC 中组态其它块。

7. 要进行互连，请单击所需的块输出。

8. 单击要与输出互连的块输入。
CFC 编辑器会自动创建一条指示互连的线。

说明

可颠倒第 7 步和第 8 步的执行顺序。 
如果选择了 I/O，可在快捷菜单中创建更多互连：

● 互连到地址...
● 互连到运行组...（仅适用于 BOOL 数据类型）

9. 进行其它参数设置并以相同方式创建互连。

说明

选择连接线以便于跟踪。该线在图表和图表总览中均以不同的颜色闪烁。

单击图表以停止闪烁。

组态归档变量

可将用于操作员监控的块 I/O 标记为在 WinCC 中归档。可在“输入/输出”(Inputs/Outputs) 
选项卡的“归档”(Archive) 列中进行设置。

可能的标识符有：

● 不归档 (No archiving)
连接值将（不再）归档。

● 归档

将在 OS 上归档连接值。 
此项设置还适用于归档到归档服务器。

● 长期归档

例如，在 OS 上归档的值将作为长期归档存储于归档服务器上。

编译 OS 时，标记为归档相关的互连将创建为归档变量，如果过程值归档尚不存在，将创

建名为“Process value archive”的过程值归档。该过程值归档用来存储归档变量。
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与过程画面互连

在创建过程画面时，可以将 CFC 的块 I/O 与过程画面中的对象互连。变量名称由工厂层

级、CFC 名称和块名称构成。您会再次发现该名称是变量名称的一部分。输入/输出值将被

输入。

编译后，可在 WinCC 变量管理中找到变量名称。编译时（选项处于激活状态），将在画

面中创建块图标，块实例将与模拟图互连。

更多信息

● CFC 在线帮助

● 与过程画面互连：手册《过程控制系统 PCS 7，入门指南 - 第 2 部分》(Process Control 
System PCS 7, Getting Started - Part 2)

● 归档变量：组态手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 
7; Operator Station)

9.15.3.5 运行组和运行属性

创建运行组 

会为每个 CFC 自动创建一个单独的运行组。图表的所有块将插入相应的运行组中。这将在

编译 CFC 更改时减少所需时间。 

运行顺序可通过 PCS 7 进行优化。仅可在特殊情况下，对以此方式优化的运行顺序进行更

改。

顺序模型能够在组态运行顺序和多用户时提供最佳支持，从而实现分布式工程组态。

更多相关信息，请参见“如何修改运行顺序 (页 478)”部分。

优化运行顺序 

“优化运行顺序”功能用于根据数据流优化程序运行顺序，以便在程序运行期间将 CPU 
的死机次数降到最小。OB/执行级（任务）和运行组将分别进行优化。

更多相关信息，请参见“如何优化运行顺序 (页 476)”部分。
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9.15.3.6 块的运行属性

简介

本部分介绍理解块的运行属性所需掌握的一些基本知识。

运行属性 

块的运行属性决定了在 CPU 整个结构中如何按照运行顺序执行块。这些属性对目标系统

响应能力具有决定性作用，而其响应能力反映在反应时间、停滞时间、依赖时间的结构（例

如，闭合回路）。

块的运行属性具有默认设置，可针对每个块单独修改这些设置。

插入块时，会为每个块分配默认运行属性。通过在运行顺序中，将块安装到任务 (OB) 中
来实现。任务组成了 CPU 的操作系统与 S7 程序之间的接口。块也可安装在其本身安装在

任务 (OB) 中的运行组中。 

说明

创建新图表时，将会自动创建运行组，该图表的所有块都将集成在该运行组中。 

运行组

运行组用于构建或拆分任务 (OB)。块在运行组中按顺序安装。例如，可以通过使用运行

组，单独处理 CFC 的各个块。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 473



可使用运行组执行以下操作：

● 在 OB 中激活然后禁用所选的块

如果禁用某个运行组，将不再执行其包含的块。

使用“BOOL”数据类型的块输出激活或禁用运行组。

● 以特定缩小比率处理选定的块（在指定周期数后和/或使用相位偏移），以在 CPU 上实

现更好的负载分配。

● 如果 OB 包含大量已安装的块，可将它们分组到较小的单元中。

优点：编译每个 OB 时，将不会创建一个“庞大的”FC，而是根据运行组的数量创建若

干“较小的”FC。

如果以后修改了程序，将只为实际包含已修改块的运行组/FC 分配“已修改 ID”。

这表示可以在极短的时间内执行更改的后续编译和在线下载更改。

说明

出于以上所列原因，请确保未在一个 OB 或一个运行组中安装过多的块。只有做到这一

点，与编译和下载整个程序相比，编译或下载更改时的性能才会得到显著提升。 
还必须考虑启动 OB (OB 100)、错误 OB (OB 8x) 及可能会使用的任何特殊 OB。

插入点

插入块时，块在运行顺序中的插入点是固定的。

默认规则如下：在显示在 CFC 状态栏中的块之后插入块。

状态栏中显示以下块（替代）：

● 首次创建图表时，显示特定目标系统的默认设置

● 要插入的上一个新块（颜色标记：浅绿色背景，黑色文本）

● 由运行顺序指定的块

当前插入点显示在状态栏右侧。它显示任务名称 (OBx)、图表和块名称，在 CFC 中插入块

时，下一个块将在该块之后安装在运行顺序中。

显示运行属性 

可通过以下方式获取运行属性相关信息： 

● 针对个别块

● 针对整个 CPU
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各个块的运行属性

每个块的运行属性都显示在某个彩色背景的块标题区域中。

● 顶行：在其中安装块的任务的名称

● 底行（斜线左侧）：任务中块或运行组的位置

● 底行（斜线右侧）：如果块安装在运行组中，则为块在运行组中的位置；否则为“-”

如果块安装了多次，将只显示该块一个插入点的信息，即按字母顺序在任务中位列最前的

插入点。

块标题的左上部还可包括指示块处理状态的附加颜色符号： 

● 红色背景上的黄色感叹号 -> 未在处理中

例如，EN 输入为静态 0。

● 黑色背景上的黑色问号 -> 处理状态不明

例如，EN 输入被互连。

双击块标题中上方显示的域将启动块的处理顺序。在处理顺序中，可直接更改块的运行属

性。更多相关信息，请参见“如何修改运行顺序 (页 478)”部分。

CPU 所有块的运行属性

要获得运行顺序的完整概述，请在 CFC 编辑器中选择菜单命令“编辑 > 打开运行顺序”
(Edit > Open Run Sequence)（也可在此窗口中编辑运行顺序），或者在“运行顺序”(Run 
Sequence) 窗口中选择菜单命令“选项 > 图表引用数据”(Options > Chart Reference 
Data)。

更多信息

● CFC 在线帮助

9.15.3.7 设置 AS 范围的互连

概述

可以使用 CFC 编辑器建立与位于其它自动化系统中的伙伴的互连。这就是所谓的 AS 范围

的互连。     

这些互连伙伴通常是块 I/O 或层级图表的 I/O。 
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AS 范围的互连的要求： 

● 涉及的 PLC 位于同一个项目或多项目中。

● 已经组态了网络。

● 已在 CFC 编辑器中打开包含各互连伙伴的图表。

设置 AS 范围的互连

设置这种互连的方法与设置图表范围互连的方法相同。 

为此，请打开两个图表并在 CFC 中排列它们，以方便将源连接到目标。即先单击其中一个

图表中要连接的 I/O，然后再单击另一个图表中的 I/O 伙伴。

对于连接，有一条互连线绘到表单栏。在表单栏的小域中，AS 范围的互连被标记为绿色三

角形。项目/工作站/CPU 类型，或层级路径和图表名称/块/连接在大框中输入。

相关通信的组态步骤

为一个 AS 对创建了 AS 范围的互连后，可在 NetPro 中自动为其创建 S7 连接。

创建 AS 范围的互连后，需要编译和下载受影响的 S7 程序。

执行加载时，工程组态系统会提供数据传送所需的块，并加载这些块。 

这些块在图表中未实例化，因此在目录中不可见。 

可直接从 AS 的相应 OB（OB1 和 OB3x）中调用数据传送。处理指令位于由代码生成器

创建的特殊 DB 中，并从加载程序传送到 CPU。

更多信息

● CFC 在线帮助

9.15.3.8 如何优化运行顺序

    

说明

在 CFC 中插入块时，块会自动安装在运行顺序中。 
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步骤

1. 在运行编辑器中通过菜单命令“选项 > 优化运行顺序...”(Options > Optimize Run 
Sequence...) 启动优化；
对于所选任务或运行组，在快捷菜单中使用菜单命令“优化组/任务...”(Optimize Groups/
Tasks...)。

使用此功能，您可以基于数据流优化程序的运行顺序。当 CPU 进行顺序运行时，这可使

停滞时间保持最低。任务和运行组将分别进行优化。

选择单个元素

使元素成为要在运行编辑器中进行优化的对象，或将其排除在外。可以从对象属性中选择

所选的任务。一个额外的符号用于在运行编辑器中标识选定的元素（带斜线的蓝色圆

圈）。 

可执行下列优化：

● 优化整个任务，包括所有启用的运行组（设置：OB/执行级和运行组）。这是默认设置。

● 只优化任务的已启用运行组（设置：仅限运行组）。

● 从优化中排除整个任务，包括它所包含的运行组（设置：无）。

通过激活“优化运行顺序”(Optimize run sequence) 复选框（默认设置），可在每个运行组

的对象属性下设置要优化的单个运行组的发布。禁用此复选框后，将会从优化中排除单个

运行组。

规则

● 由驱动程序生成器（“生成模块驱动程序”(Generate Module Drivers) 功能）创建的运

行组内容将不进行优化，因为已在此处设置了正确的顺序。

● 如果优化是在创建模块驱动程序后执行的，则不能保证驱动程序块运行组的顺序就是驱

动程序生成器所指定的顺序。因此，下次编译时模块驱动程序将会重新启动（将选中

“创建模块驱动程序”(Create module driver) 复选框）。

优化期间发生了什么？

所有任务都分别优化。分别处理任务的运行组。不考虑运行组的减速比和相位偏移。 

数据流由互连数量决定。这些互连包括所有块间互连、块到 SFC 的互连及用来“启用”运

行组的块输出的互连。 
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下列互连将被忽略：

● 全局和文本互连

● 与位于其它任务中的块的互连

● 从 SFC 到位于其它任务中的块 I/O 的访问

● 将确定到图表接口的互连是否有实际互连源。如果不存在实际互连源，表示互连在某个

界面处结束，则该互连将被忽略。

指向或来自运行组的互连被视为运行组本身的互连。运行组在任务级形成一个虚拟块。运

行组内部块间的互连只用于运行组内的优化过程。这可确保正确地安排实际运行组，并确

保该运行组在任务中处于最佳位置。

在后续优化期间，仅当有必要时才会执行更改。因此，编译和下载更改时改变量将保持在

最低水平。

说明

如果通过 INOUT 参数将块互连，数据流可能会反向流动（从输入流动到输出）。优化运

行顺序时将不考虑这一点。

补救措施：这种情况下，必须手动优化运行顺序并从优化中移除相应运行组。

说明

在进行层叠互连及其它具有若干个返回跳转的连接时，请禁用运行组的运行组优化。

9.15.3.9 如何修改运行顺序

简介

块自动插入到其运行顺序中的图表中。插入点在“插入前导”中确定。视通过系统属性 
(S7_tasklist) 分配给块类型的任务列表中的条目而定，某些块也可能会在任务中安装多次。

例如，OB 100 中也实现了具有启动特征的块。 

在属性对话框“常规”(General) 选项卡的“安装在以下 OB/任务中”(To be installed in OBs/
tasks) 组下，也插入了该块的其它任务。

安装指针

安装指针决定运行顺序下一运行单元的安装位置。以下是不同的指针： 

● 图表安装指针

● 块安装指针
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步骤

1. 使用菜单命令“编辑 > 打开运行顺序”(Edit > Open Run Sequence)，在 CFC 编辑器中启动
运行顺序编辑器。
可在其中进行以下修改：

– 移动对象（SFC、运行组或块）

– 删除块

– 插入块

– 自定义安装指针

移动对象

移动对象的方法是：在右侧或左侧窗口中选择对象（SFC、运行组或块），然后将其拖放

到要在其安装完成后安装所选对象的对象之后。 

对象放置在运行组上之后将执行以下操作：

● 如果结构已展开 [-]，对象将安装在运行组内的第一个位置。

● 如果结构未展开 [+]，对象将安装在运行组之后。

● 如果运行组是空的，系统将询问是否要在运行组内安装块。如果回答“是”(yes)，将在

运行组内安装块；如果回答“否”(no)，将在运行组之后安装块。

将对象拖动到某一任务时，该对象将安装在已安装的对象之前。

说明

移动块时，请确保图表的所有块只位于相应的运行组中。将块移动到另一个组后，面向图

表的结构不再存在，在工程中以图表为单位进行工作将变得困难，甚至无法以这种方式工

作。

删除块

只能从任务中删除在运行顺序中多次安装的块。必须至少保留一个插入点。 

如果只安装了这一个块，将不会删除该块。否则，将删除该块并相应地调整下一个块的运

行顺序。

插入块

也可通过复制和粘贴多次安装块、运行组或 SFC。使用以下功能可达到此目的：

● 相应的菜单命令

● 工具栏图标
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● 按下 <Ctrl> 键的同时拖放

● 显示 CFC 时，从 CFC 将它们拖动到运行顺序中的所需位置。

说明

创建模块驱动程序时，会自动在运行顺序中安装带有系统标识符“@”的对象。要编辑

这些对象，只能在 SIMATIC Manager 中使用菜单命令“选项 > 图表 >“生成模块驱动程

序...”(Options > Charts > Generate Module Drivers...)。请不要手动删除或移动这些对

象。

自定义安装指针

可按以下方法修改安装指针：

● 图表安装指针（默认为 OB 35）
在运行顺序编辑器中，从 OB 级（不在运行组内）或 OB 内的运行组选择所需的 OB 或块。

在运行编辑器中选择“编辑 > 插入位置前导”(Edit > Predecessor for Insertion 
Position) 菜单命令。

● 块安装指针

无法在运行编辑器中设置块安装指针。

在 CFC 编辑器中，选择要在其后安装所有其它块的块。

在图表中选择“编辑 > 插入位置前导”(Edit > Predecessor for Insertion Position) 菜单命

令。

如果删除了指定为安装的原有对象的块，块安装指针将设置为安装在所删除块之前的块。

这同样适用于将块移动到其它图表的情况。目标图表中的块安装指针不会发生变化。移动

后的块将保留其在前一图表中的插入位置。

更多信息

● CFC 在线帮助

9.15.3.10 如何定义 CFC I/O

简介    

可将 I/O 添加到图表中以实现下列目的，例如：

● 插入到其它图表及与其它图表或块互连（图中图方法）。

● 将图表编译为块类型

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
480 配置手册, 12/2017, A5E39221328-AC



可通过两种不同的方法创建图表 I/O：

● 创建未分配的图表 I/O，然后进行互连

● 创建带互连的图表 I/O

创建未分配的图表 I/O，然后进行互连

在第一步中，为不引用任何参数的图表（例如，因为图表尚不包含块和/或嵌套图表）创

建 I/O。为图表 I/O 分配名称、属性及默认值。

在第二步中，在图表中放入块/图表，将它们互连，然后将图表中对象的 I/O 分配给图表 I/
O。

1. 选择菜单命令“视图 > 表 I/O”(View > Chart I/Os)。
用于编辑图表 I/O 的窗口将打开并“停驻”在图表窗口的上部。

2. 在左侧的层级窗口中，选择所需 I/O 类型（IN、OUT 或 INOUT）。

3. 在右侧的详细信息窗口中，编辑相应 I/O 类型的空声明行（名称、数据类型、初始值、注释）。
从下拉列表中选择数据类型。

说明

如果使用此方法，将不应用块 I/O 的属性（例如，S7_m_c）。随后必须手动为图表 I/
O 分配属性。

4. 通过拖放将块/图表 I/O 拖动到具有兼容数据类型的图表 I/O 中。

以下是用于现有图表 I/O 的替代方法：

可将图表和/或嵌套图表中放置的块 I/O 分配给现有图表 I/O，而无需打开图表 I/O 窗口。 

1. 标记 I/O，然后选择菜单命令“插入 > 图表 I/O 的互连...”(Insert > Interconnection to Chart 
I/O...)。
将打开一个对话框，其中包含相关 I/O 类型的所有可用 I/O 的列表。

2. 选择所需图表 I/O，然后单击“确定”(OK)。

说明

只能分配具有兼容数据类型的未连接 I/O。

创建带互连的图表 I/O 

首先，创建实际图表。为此，插入块/图表并将其互连。 

在第二步中，打开图表 I/O 的窗口，通过将图表 I/O 连接到放置在图表中的块/图表的 I/O 
来定义图表 I/O。将会创建一个新行，并将所连接 I/O 的所有属性应用于连接的 I/O（名称、
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属性和初始值）。如果发生命名冲突（例如，因为在不同块中使用了相同名称），则通过

递增名称中的数字可使名称在图表 I/O 中保持唯一性。

1. 选择菜单命令“视图 > 表 I/O”(View > Chart I/Os)。
用于编辑图表 I/O 的窗口将打开并“停驻”在图表窗口的上部。

2. 在左侧的层级窗口中，选择所需 I/O 类型（IN、OUT 或 INOUT）。
带有 I/O 的行显示在右侧的详细信息窗口中（如果仍必须创建新的图表 I/O，该窗口将仍为
空白）。

3. 在图表的工作区域中，选择所需的块/图表 I/O 并将此 I/O 拖动到图表 I/O 右侧窗口中的“名
称”(Name) 框中。
将会应用 I/O，包括其所有属性。
例外：互连的 I/O 将不会重新分配。

4. 对于图表中所有其它要与图表 I/O 进行互连的块/图表 I/O，请按照相同的步骤进行操作。

如果通过拖放将已存在于图表 I/O 中的 I/O 拖动回图表 I/O 窗口中的某个空行，将会自动

在 I/O 名称后添加一个数字，使 I/O 名称保持唯一性。

如果通过拖放将内部互连的 I/O（输入）拖动到一个新行上，将会创建一个副本，而不建立

到内部 I/O 的互连。

表单栏中的表示

表单栏显示应用于图表 I/O 的 I/O 名称和注释、I/O 类型及数据类型。互连的“接口 I/O”

类型由互连线上的小白色三角形来指示。

说明

如果与图表接口互连的 I/O 处于隐藏状态，将不会有表单栏条目。这些互连只能在块的对

象属性中识别（“I/O”选项卡的“互连”(Interconnection) 列）。

更改图表 I/O 名称

图表 I/O 名称不需要包括已分配块 I/O 的名称；可将它重命名。为此，请选择“名称”(Name) 
框中的名称，然后输入一个新名称。也可以双击右侧窗口中图表 I/O 行的开始部分，然后

在“属性”(Properties) 对话框中输入新名称。

分配系统属性

就像块 I/O 一样，也可为个别图表 I/O 分配系统属性。 

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
482 配置手册, 12/2017, A5E39221328-AC



以下内容适用：

● 如果通过拖动重新组态 I/O 以将其定义为图表 I/O，则它会应用块 I/O 的系统属性。

● 如果预定义的图表 I/O 与块 I/O 互连，则必须自己定义系统属性，将不会应用块 I/O 中
的这些属性。

带图表 I/O 的图表自身没有系统属性（I/O 的系统属性除外）。

已放置图表时分配 I/O

也可在以后通过添加更多图表 I/O 来扩展带图表 I/O 的图表。如果图表是嵌套图表，换句

话说，一个图表已置于另一图表中，则添加的 I/O 可能会导致定位冲突。在这种情况下，

嵌套图表将显示为重叠图表（就像重叠块一样）：浅灰色且不带 I/O。如果将图表放置在某

个空闲位置，便可使 I/O 和互连都显示出来。

如果已将图表放置在图表中并将其互连，接着更改了原始图表（例如，通过添加一个附加 
I/O），则将修改过的图表拖动到原始图表上。新图表将会替换旧图表。现有互连将得到保

留。

更多信息

● CFC 在线帮助

9.15.3.11 组态逻辑运算

在自动化系统中使用逻辑运算实现控制信号。逻辑运算最重要的应用是实现下列功能的逻

辑算子：

● Permit

● Protection

● Interlock

自 PCS 7 V8.2 起，可在对象中实现逻辑运算。这些对象是指下面的逻辑矩阵。PCS 7 中
的逻辑矩阵编辑器是用于创建和优化逻辑运算的工具。 

逻辑矩阵编辑器中的功能

● 创建逻辑矩阵

● 修改逻辑矩阵
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● 传送组态的逻辑矩阵（CFC、带逻辑矩阵块的 APL）

● 适合处理大量数据的导入/导出功能 

编译逻辑矩阵

通过编译逻辑矩阵在 CFC 中创建带特殊功能块的图表。

CFC 中的逻辑矩阵块

● LM_Cause

● LM_Matrix

● LM_Effect

处理大量数据的基本步骤 

1. 在 SIMATIC Manager 中，在 PCS 7 项目中插入逻辑矩阵。

2. 在逻辑矩阵编辑器中指定访问参数：

– 原因（输入变量）

– 结果（输出变量）

– 逻辑运算（交点）

– 连接（链接）

3. 导出逻辑矩阵

4. 编辑 .ods 文件（例如使用 EXCEL）

5. 输入逻辑矩阵

6. 通过矩阵生成带逻辑运算的 CFC

7. 编译并下载程序

操作并监视逻辑矩阵

● 逻辑矩阵的 OS 画面对象符合 APL 库的设计 

● 支持 PCS 7 OS 的报警和维护功能

● 支持 Web 客户端

更多信息

● 组态手册《过程控制系统 PCS 7；PCS 7 - 逻辑矩阵》(Process Control System PCS 
7; PCS 7 - Logic Matrix)

● “编辑大量数据 (页 563)”部分
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9.15.3.12 如何编译 CFC

简介

必须将 CFC 编译为 AS 的 CPU 能理解的代码。由于编译始终包括 S7 程序的所有图表，

因此只应在编译结束后启动程序。   

步骤

1. 在 CFC 编辑器中，选择菜单命令“选项 > 自定义 > 编译/下载...”(Options> Customize > 
Compile/Download...)。

2. 定义编译设置。 
有关此主题的更多信息，请参见“编译设置”部分。

3. 选择菜单命令图表 > 编译 > 图表作为程序... (Chart > Compile > Charts as Program...)。
将出现“编译程序”(Compile program) 对话框。

4. 必要时请选中以下复选框：

– 生成模块驱动程序 
（更多信息，请参见在线帮助）

– “生成 SCL 源”(Generating SCL source)

说明

如果不希望使用当前 PCS 7 库的块，则可以使用“模块驱动程序设置”(Module Driver 
Settings) 按钮打开一个对话框，您可以在其中选择所需的驱动程序库。

5. 单击“确定”(OK)。

“生成模块驱动程序”功能

在默认设置中，“生成模块驱动程序”(Generate module drivers) 复选框设置为激活状态，

这就意味着在执行每个编译步骤之前，还将调用驱动程序生成器。 

在特殊情况下（例如，硬件不完整），您可以禁用此复选框，以便不执行“生成模块驱动

程序”(Generate Module Drivers) 功能。此时编译总时间将会减少。

如果激活“生成模块驱动程序”(Generate Module Drivers) 功能，在执行编译过程前，驱动

程序生成器将为现有信号处理块创建模块驱动程序并与它们互连。

有关此主题的更多信息，请参见“如何生成模块驱动程序 (页 504)”部分。
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编译设置

使用菜单命令选项 > 自定义 > 编译/下载... (Options > Customize > Compile/Download...) 
打开一个对话框，其中包含有关编译图表时使用的资源的信息。可指定以下内容：

● 要使用的警告限制，以便在下载前检测到潜在的危险。

● 在编译当前图表文件夹的图表期间一直未使用的资源。这在某些情况下可能非常用。例

如，希望同时使用图表和编程（例如， STL、LAD 或 SCL 程序）完成一个自动化任

务，而且在用户程序中还存在来自其它源的函数 (FC) 或数据块 (DB) 时。

您也可以查看统计信息，其中显示在您的 CPU 中有多少资源（DB、FC）可用于编译图表

以及有多少资源已被占用。

说明

如果在程序中只处理 CFC 和 SFC，则可以使标准编译设置保持不变。

有关在编译期间生成的块的概述，可参见在线帮助。

集中功能“编译和下载对象”

说明

可在 SIMATIC Manager 中使用菜单命令 PLC > 编译和下载对象... (PLC > Compile and 
Download Objects...) 集中编译和下载所有对象。此对话框列出了可编译或下载的所有多项

目对象。

必须将硬件配置下载到 CPU 上，然后此功能才有效（自动化系统的初始调试）。

更多信息，请参见“如何下载到所有 CPU (页 660)”部分。

更多信息

● “如何将 CFC 下载到 CPU (页 488)”部分

● “下载到所有 CPU (页 660)”部分

● CFC 在线帮助

9.15.3.13 如何在下载前比较 CFC

简介

组态、测试及调试期间，在下载新的/更改后的 CFC 之前，通常需要将其与先前加载的版

本进行比较。
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要求

在 CFC 编辑器中使用菜单命令“选项 > 设置 > 编译/下载...”(Options > Settings > Compile/
Download...) 进行初始下载之前，激活“编译/下载设置”(Settings for Compiling/
Downloading) 对话框中的“生成用于比较的已下载程序的映像”(Generate image of 
downloaded program for comparison) 复选框。

步骤

1. 在 CFC 编辑器中，选择菜单命令“目标系统 > 下载...”(Target system > Download...)。

2. 单击“显示更改”(Show Changes)。
将打开版本交叉管理器，并将由先前下载所创建的映像（请参见“要求”部分）与要下载的
版本进行比较，并显示相应结果。

说明

只有安装了“版本交叉管理器”附加包并已生成加载程序的映像，才会启用“显示更

改”(Show Changes) 按钮。

3. 返回到“下载”(Download) 对话框。

4. 单击“确定”(OK) 或“取消”(Cancel)。

更多信息

● CFC 在线帮助

9.15.3.14 如何将各个已更改图表加载到 CPU 中

自 PCS 7 V8.1 起，对 AS 图表所做的更改可有选择地下载至 CPU。 

说明

准备多个更改

可使用“选择性下载”(Selective Download) 菜单命令将调整和少量图表更改选择性应用到 
AS。避免在各个图表之间进行大量更改并使用“选择性下载”(Selective Download) 菜单命

令将这些更改下载到 CPU。
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要求

● 启动更改前，组态须与 CPU 的下载状态必须一致。

● 以下程序段应保持不变：

– 故障安全程序段

– 硬件（无 CIR）

● 系统未阻止下载更改。

相关信息，请参见 SIMATIC Manager 图表文件夹下的图标说明。

步骤

1. 确定要加载的图表。可通过以下方式选择要加载的图表：

可以选择 第 3 步中预先选择的图表

在工厂视图中选择层级文件夹。 将显示层级文件夹中所有已修改的图表。

所有图表均预先选择。

在组件视图中，选择 AS 的图表文件夹。 将显示图表文件夹中所有已修改的图表。

没有预先选择的图表。

在组件视图中，标记 AS 的图表文件夹中

的多个已修改的图表。

将显示图表文件夹中所有已修改的图表。

所有标记的图表均预先选择。

在组件视图中，选择 AS 图表文件夹中的

一个已修改图表。

将显示图表文件夹中所有已修改的图表。

标记的图表将预先选择。

2. 选择菜单命令“选项 > 图表 > 选择性下载”(Options > Charts > Selective Download)。
“选择性下载”(Selective Download) 对话框随即打开。

3. 选中所需图表的复选框。

4. 为生成模块驱动程序和 SCL 源进行所需设置。
有关此内容的信息，请参见对话窗口帮助。

5. 单击“确定”(OK)。
图表已完成编译并下载。
处理完成后，日志对话框随即打开。有关信息，请参见与已执行操作相关的各个选项卡。

9.15.3.15 如何将 CFC 下载到 CPU

简介

编译图表后，将它们下载到 CPU，然后在测试模式下查看过程速率。 

程序将下载到分配给活动图表的 CPU。 
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要求

CPU 与您的编程设备/PC 之间必须存在连接。

步骤

1. 在 CFC 编辑器中，选择菜单命令“CPU > 下载...”(CPU > Download...)。
将打开“下载到 CPU”(Download to CPU) 对话框，您可以在其中确定下载类型。

2. 选择下载的范围。更多相关信息，请参见“用于编译和下载的选项 (页 664)”部分。

3. 单击“确定”(OK)。
如果在下载之前已经对用户程序进行了与下载有关的更改，一个消息对话框将会打开。该消
息会通知您必须对程序进行编译。消息对话框中提供“编译”(Compile) 功能以及下载功能。

说明

为了保持组态数据和 CPU 数据的一致性，必须将更改加载到 CPU。 
可选择以下方式执行更改的加载：

● 在 CFC 编辑器中：
菜单命令“CPU > 下载…”(CPU > Download…)。

● 从 SIMATIC Manager 中 
– 在组件视图中选择图表文件夹：

选择菜单命令“CPU > 下载”(CPU > Download)。
– 选择多项目、项目或 SIMATIC 站：

选择菜单命令“CPU > 编译和下载对象...”(CPU > Compile and Download Objects...)。

更多信息

● “如何编译 CFC (页 485)”部分

● “下载到所有 CPU (页 660)”部分

● “如何将各个已更改图表加载到 CPU 中 (页 487)”部分

● CFC 在线帮助

9.15.3.16 如何测试 CFC

测试模式    

CFC 编辑器提供了支持调试过程的测试功能。这些功能用于监视和改变 AS 中顺序控制系

统运行，并在必要时更改设定值。为此，请将 CFC 编辑器切换到测试模式。
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测试模式的运行模式

测试模式是指包含激活的图表的 CPU。可以选择在两种运行模式下进行测试：

运行模式 描述

过程模式 在过程模式下，CFC 和 CFC 实例在线动态显示的通信会受到限制，

这样只会略微增加 CP 和总线上的额外负载。 

如果过程模式中出现过载现象，将显示消息提示已达到总线负载限

制。在这种情况下，应停止并非绝对需要进行测试的 CFC 的测试模

式。

激活测试模式后，所有块的状态均为“关闭监视”。

实验室模式 实验室模式下的测试和调试更为方便和高效。和过程模式不同，在实

验室模式下用于 CFC 的在线动态显示的通信是不受限的。

激活测试模式后，所有块的状态均为“打开监视”。

要求

● CPU 与 PC 之间必须存在连接。

● 程序已下载。

激活/取消激活测试模式

1. 使用“测试”(Test) 菜单中的菜单命令，选择所需运行模式：

– “测试 > 过程模式”(Test > Process Mode)
– “测试 > 实验室模式”(Test > Laboratory Mode)
请注意，在测试模式下不可切换所使用的测试类型。 

2. 在 CFC 中选择菜单命令“测试 > 测试模式”(Test > Test Mode)。
测试模式被激活。

3. 在 CFC 中再次选择菜单命令“测试 > 测试模式”(Test > Test Mode) 停止测试模式。

故障诊断

在 CFC 内，可以打开与块实例关联的块类型。在 CFC 中，标记所需的块，然后选择菜单

命令“编辑 > 转到 > 类型”(Edit > Go To > Block Type)。 

如果项目中包括块的源文件，将打开用于创建它的工具（LAD/FBD/STL 或 SCL）且可以

编辑块类型。 

如果项目中不包括源文件，仍然会打开 LAD/FBD/STL。此时只能读取块信息（例外：仍可

编辑 I/O 的系统属性）。 

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
490 配置手册, 12/2017, A5E39221328-AC



如果在 CFC 中标记了 SFC 实例，将在 SFC 编辑器中打开该实例（相关的 SFC 类型可

在 SIMATIC Manager 或 SFC 编辑器中打开）。

更多信息

● CFC 在线帮助

● 手册《过程控制系统 PCS 7，入门指南 - 第 1 部分》(Process Control System PCS 7, 
Getting Started - Part 1)

● 手册《S7 的 CFC；连续功能图》(CFC for S7; Continuous Function Chart)

9.15.3.17 如何对块 I/O 使用“强制”功能

“强制”功能

调试期间，通过使用强制值永久覆盖互连值可以仿真若干互连值。  

强制期间，必须临时移除块之间的互连，并将强制值分配给这些互连的相应输入（IN 或 
IN_OUT）。

强制功能用“强制值”替换通常由互连提供的块输入处的值。可以随时在块实例的输入处

激活和禁用这种强制功能。

考虑到性能，不允许所有块输入从一开始就都支持强制功能。可在 CFC 的组态中或在过程

对象视图中指定可强制的输入。程序编译后，如果输入处的“添加强制”(Add forcing) 和
“强制激活”(Forcing active) 属性被更改，则需要重新编译并加载该程序。

最多可以强制 8192 个标准 I/O 和 8192 个 F I/O。

说明

如果已注册并下载最大数量的强制参数，则在对这些参数进行取消注册后必须下载更改内

容，以便同时在 CPU 中重新批准这些参数。只有下载更改内容后，新强制参数或其它强

制参数才可注册。

说明

如果在图表文件夹中激活了强制，则需要重新编译并下载程序（编译整个程序）。
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强制功能设置

强制功能由以下属性控制：

● “支持强制”(Support forcing)

● “添加强制”(Add forcing)

● “强制激活”(Forcing active)

● “强制值”(Force value)

步骤

可通过 SIMATIC Manager 和 CFC 中的相应复选框来启用这些属性。

在 SIMATIC Manager 中，在图表文件夹对象属性的“高级”(Advanced) 选项卡中： 

● “支持强制”(Support forcing) 复选框：此选项可启用强制功能以及 CFC 和过程对象视

图中的相应选项。

在 CFC 中，在块输入的对象属性中：

● “添加强制”(Add forcing) 复选框：此选项用于启用或禁用该输入的“强制功能”。每

次更改该选项都需要重新编译和加载程序。不能在测试模式下更改此选项。

● “强制激活”(Forcing active) 复选框：选中此复选框时，互连的值将始终由强制值代替。

禁用强制功能后，将重新激活互连的值。无需对测试模式下的更改进行重新编译。

● “强制值”(Force value) 文本框：如果启用了“添加强制”(Add forcing) 和“强制激活”
(Forcing active) 选项，则在此文本框中输入将应用到块输入的值。无需对测试模式下的

更改进行重新编译。在 INOUT 上，也会将强制值写入到互连块的输出中。

替代步骤

如果激活了图表文件夹的“支持强制”(Support forcing) 选项，则可以按以下说明操作：

1. 可以在 CFC 中对多个块输入进行设置。块对象属性的“I/O”选项卡中提供了设置强制功能
的相应列。

2. 在过程对象视图中，可以对项目中所有块的所需输入进行设置。“参数”(Parameters) 和“信
号”(Signals) 选项卡中提供了设置强制功能的相应列。
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表示法

在 CFC 中，强制输入的互连可通过块输入处的彩色矩形来标识： 

● 绿色矩形表示：“添加强制”(Add forcing) 已激活

● 红色矩形表示：   “添加强制”(Add forcing) 和“强制激活”(Forcing active) 已激活。

说明

由于只对互连的参数存在强制，因此仅对互连会显示彩色矩形。

在测试模式下，强制值通过不同的背景色区别于其它动态值。默认设置是“浅蓝”，可在

“颜色设置”(Color Settings) 中进行更改。（“选项 > 设置 > 颜色...”(Options > Settings 
> Colors...)）。只有结构中第一个元素将显示为彩色。其它元素均不可见。

强制值的背景色与图表中的显示颜色相同。

说明

如果强制激活时执行了 CPU 冷启动，则所有强制设置将丢失。但这些设置将保留在离线

程序中。要使离线程序和在线程序之间恢复一致，请在图表文件夹中禁用“支持强制”
(Support forcing)，编译并下载数据，在图表文件夹中重新启用“支持强制”(Support 
forcing)，然后再次编译并下载数据。

虽然可将带文本互连的连接注册为强制，但在测试模式下这种设置无效。

强制激活时发消息至 WinCC

强制情况下，在编译期间会自动将新系统图表 @FRC_CFC 与同名的运行组一起安装到 
OB1 中。消息块 FRC_CFC 将被添加到该图表中，同时也会添加到 OB100 中。如果在参

数中设置了“强制激活”(Forcing active)，则该块会触发一条给 WinCC 的进入消息。再次

禁用“强制激活”(Forcing active) 后，该块将触发相应的离开消息。@FRC_CFC 运行组

的“激活”(Active) 控制选项指定仅在更改了“强制激活”(Forcing active) 功能后才能执行该

块。

禁用强制后，块、系统图表和运行组将在下一次编译和下载时被再次从程序中删除。

数据类型

可强制以下数据类型：

BOOL、BYTE、INT、DINT、REAL、STRUCT、WORD、DWORD、DATE_AND_TIME
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对于 STRUCT 数据类型，只能强制该类型结构的第一层。而不能强制图表的输入/输出。

说明

如果将 EN 输入或者将 FC 或 BOP 的输入注册为强制，则可以在测试模式下设置此输入的

参数，使其具有操作员监控功能。

更多信息

● CFC 在线帮助

9.15.3.18 如何在测试模式下使用趋势显示

趋势显示        

趋势显示是 CFC 编辑器中的一个工具，通过它可定性跟踪 CPU 上一个或多个信号值随时

间的变化情况。趋势显示不间断地显示记录的信号随时间的变化情况。趋势显示可配合任

何支持常规在线操作的目标系统。 

趋势显示规则

● 在趋势显示窗口中，任一时刻只能有一个趋势显示处于激活状态。

● 最多可同时记录 12 个值。

● 对于每个 CPU，均可创建和管理任意数量的趋势显示数据记录。每个显示都指定了名

称，创建显示时必须指定该名称（可更改该名称）。

● 可使用简单数值数据类型（BYTE、INT、DINT、WORD、DWORD、REAL）和布尔

值。

● 在在线显示中，必须能够让值在图表中动态显示。

● 在每个显示中，图表文件夹中都将保存以下数据：

– 显示的名称

– 通道的分配

– 采集参数

– 显示参数

– 最后记录的曲线（如果存在）

● 采集周期可设置在 1 - 90 秒之间。
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要求

已为当前 CPU 在 CFC 编辑器中激活了测试模式。

步骤

1. 通过菜单命令“视图”(View) >“趋势显示”(Trend Display) 打开所需 CPU 的趋势显示窗口。

2. 在趋势显示组中，单击“重命名”(Rename) 按钮并为该趋势显示输入所需的名称。

3. 在“显示”(Display) 组中，输入时间轴上的测量点数。

4. 在“记录”(Recording) 组中，单击“更改”(Change) 按钮并输入趋势显示的当前操作模式和
中止条件。

5. 单击“应用”(Apply)。

6. 打开要显示其值的 CFC。

7. 在功能块级，选择要显示其值的 I/O 名称。

8. 单击菜单命令“调试 > 输入/输出 > 插入到趋势显示中”(Debug > Inputs/Outputs > Insert in 
Trend Display)。 
将打开趋势显示窗口。

9. 在“选择通道”(Select Channel) 对话框中选择所需的通道，然后单击“确定”(OK)。

10.打开“趋势显示”(Trend Display) 窗口。在此输入所需的上限和下限，然后单击“应用”
(Apply)。

11.连续重复执行步骤 6 到 10，直到将所有要显示的值都插入到趋势显示中。

12.在趋势显示中，单击“启动”(Start)。 
开始显示选定值。

导出趋势显示

1. 趋势显示打开时，选择菜单命令“选项”(Options) >“设置”(Settings) >“导出趋势数据...”(Export 
Trend Data...)。

2. 输入所需的导出格式。

3. 单击“确定”(OK)。
将导出当前趋势显示。

更多信息

● CFC 在线帮助
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9.15.3.19 如何组态 AS 运行时间测量

AS 运行时间测量

要避免新组态和修改过的组态中出现运行错误，建议监视 OB 的执行时间。在下述组态中，

可将警告限设置为任意值。可通过 PCS 7 OS 发送警告限信号。    

运行时间使用 TIME_BEG 和 TIME_END  块（下文中称为块对）进行测量。此外，可能需

要使用 MonAnL 块来设置警告限。

警告

请注意以下警告：

● 只有经过培训的维护人员才能执行针对过程控制系统的所有操作。

● 对系统进行更改时，请始终遵守工厂特定的规则和政府法规。

● 请遵守工厂特有限制条件并相应地对工作进行调整。

● 请始终记住，对系统的更改可能会影响系统的其它部分。

步骤

1. 在 CFC 中创建一个新图表（运行监视 ASNo x）。

2. 在此图表中放入一个块对 — 每个循环中断 OB 中放入一对。
要查看循环中断 OB，请选择菜单命令编辑 > 打开运行顺序 (Edit > Open Run Sequence)。

3. 连接块对的“TM”I/O。

将块分配给循环中断 OB

1. 选择 TIME_xxx 块。

2. 选择菜单命令编辑 > 打开运行顺序 (Edit > Open Run Sequence)。
将打开“运行顺序编辑器”(Run Sequence Editor) 对话框。
在树形视图中将突出显示所选块。也可以在此 OB 中找到其它块对。
将一对块分别移动到每个循环中断 OB 中。

3. 将 TIME_BEG 块作为循环中断 OB 中的第一个块。

4. 将 TIME_END 块作为循环中断 OB 中的最后一个块。

5. 如果需要警告限，请放置并互连 MonAnL 块。

6. 为 TIME_BEG 和 TIME_END 类型的所有块重复步骤 3 到 5。

为 TIME_BEG 和 TIME_END 块指定名称

在分配到各项目编辑器之前指定名称： 

1. 选择 TIME_xxx 块。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
将打开“块属性”(Block Properties) 对话框。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
496 配置手册, 12/2017, A5E39221328-AC



3. 在“名称”(Name) 域中输入块的符号名（例如，为 OB36 中用于测量周期时间的块对输入名
称 cyc36ob 和 cycob36）。

4. 单击“确定”(OK)。

5. 为 TIME_BEG 和 TIME_END 类型的所有块重复步骤 1 到 4。

显示周期时间

1. 编译步骤 1 中创建的图表并下载 AS。
若是处于 CFC 的在线模式下，您将会在 TIME_END 块的输出 TM_DIFF 处看到 OB 的运行
时间。

故障诊断注意事项

通过安装带缩小比率和相位偏移的运行组或启动其它 OB 中的块，可缩短 OB 的执行时

间。 

如果可增加循环监视时间，则可在 HW Config 中执行该操作（CPU 的属性，“周期/时钟

存储器”(Cycle/Clock Memory) 选项卡）。 

如果由于 I/O 组件故障导致 CPU 停止，使用 SUBNET 块可能会有帮助。出现错误 OB（例

如，OB 86，机架故障）时，SUBNET 块只允许发出错误信号提示的驱动程序块执行其例

程。这减少了必需的执行时间。

更多信息

● CFC 在线帮助

● 有关块的直接帮助：单击 CFC 中的“?”号，然后单击块头。

9.15.3.20 如何在过程模式下组态消息的自动显示和隐藏

简介

以下部分将介绍如何在过程模式下组态消息的自动显示和隐藏。       

要求

● 已完成 CFC 和 SFC 中工艺功能的组态。

● 指定了要隐藏其消息的工厂部件的块组。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 497



步骤

1. 将“STRep”块插入 PCS 7 高级过程库的 CFC 中。

2. 将预先创建的来自过程状态逻辑的控制信号连接到状态输入（从状态 1 到最高状态 32）。

3. 在 SIMATIC Manager 中打开工厂视图。

4. 双击“共享声明”(Shared Declaration) 文件夹。

5. 双击“列表”(Listings) 文件夹。

6. 选择“操作状态”(Operating State) 文件夹。

7. 选择快捷菜单命令插入新对象 > 值 (Insert New Object > Value)，输入对象名称来表示状
态。
对所有状态重复此步骤（状态 1 到最大状态 31）。

8. 选择对象名称。

9. 选择编辑 > 对象属性 (Edit > Object Properties) 菜单命令，然后将值从 1 开始分配给各个状
态（请不要使用 0）。

10.在 SIMATIC Manager 中打开过程对象视图。

11.选择“块”(Blocks) 选项卡。

12.在“块组”(Block group) 列中，输入“STRep”块的名称。

说明

在整个多项目中，块组的名称必须唯一。

块组的名称必须不同于作为 OS 区域标识符而分配的名称。

13.将此名称分配给将属于该组的所有块。

14.现在，选择“消息”(Messages) 选项卡。

15.从“按列过滤：”(Filter by column:) 下拉列表中选择“块组”(Block group) 条目。

16.在“显示”(Display) 输入框中输入块组的名称。

17.将状态（状态 1 到状态 32）分配给想要隐藏的显示块组的所有消息。相应的列名将由先前
定义的“操作状态”(Operating state) 所代替。

结果

分配给某个状态输入的信号将控制分配了该状态的所有消息的显示和隐藏。 
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9.15.4 PCS 7 许可证信息

简介 

在 SIMATIC Manager 中，可以调用一项标识所有需要 PCS 7 许可证的已组态对象的功

能。结果按许可证类型显示在“PCS 7 许可证信息”(PCS 7 License Information) 对话框中。

这样便可以检查购买的或打算购买的 PCS 7 许可证是否满足项目需要，或搞清楚可通过其

扩展项目的许可证所支持的对象数量。

左侧的框中显示了需要 PCS 7 许可证的所有已安装组件。

右侧框中显示了相应的已组态许可证对象。

PCS 7 组件

PCS 7 组件列表由安装情况确定。多项目、项目和站显示在“已组态的许可证对象”
(Configured license objects) 框中。 

以下对象显示在“选择所需许可证：”(Select the desired license:) 框中：

● 过程对象 
可计数的过程对象是指支持报告、操作员控制和监视的所有 SFC 和所有块实例。这些

是将传送到 OS 的对象，需要许可证。不能将驱动程序块视为过程对象。

仅当这些对象可以下载到 AS 时，才会将其纳入计数范围。不考虑未分配硬件的 S7 程
序（在项目级或在库中）的块实例。

● 诊断对象（维护 RT）
显示多项目或子项目。方括号 [...] 中包含项目许可证的数量。在下一层中，依次显示 
AS 对象（包含从属 AS）、PC 站、网络对象和用户对象。

● WinCC 中的过程对象

对于每个子项目或多项目，都会显示一个或多个 OS；已注册的许可证用方括号 [...] 表
示。可以显示 OS 服务器、OS 备用服务器和 OS 参考服务器。

● 归档变量

对于每个子项目或多项目，都会显示一个或多个 OS。如果有归档服务器，也会显示该

服务器。在下一层中，列出在此归档服务器上存储数据的那些 OS。归档变量数显示在

受影响对象旁的方括号 [...] 中，从而区分了短期归档和长期归档。 

● SIMATIC BATCH 单元

其视图与过程对象的相同

● SIMATIC Route Control
其视图与过程对象的相同
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更多信息

● 更多相关信息，请参见“计数和预定过程对象许可证 (页 500)”部分。

9.15.4.1 计数和预定过程对象许可证

简介 

可计数过程对象 (PO, Process Object) 可分类为支持操作员监控且具有“使用中断”(With 
interrupt) 属性的所有 SFC 和块实例。它们是编译和下载操作期间传送到 OS 并且需要许

可证的对象。 

驱动程序块不属于过程对象。      

可在 SIMATIC Manager 中启动一种功能，该功能可以识别已在自动化许可证管理器 (ALM) 
中组态和注册的所有过程对象。结果显示在“PCS 7 许可证信息”(PCS 7 License Information) 
对话框中。这样便可以检查购买的或打算购买的 PCS 7 许可证是否满足项目需要，或搞清

楚可用来扩展项目的许可证所支持的对象数量。

顺序

编译和下载操作涉及检测程序中的过程对象以及 CPU 和存储卡序列号。借助于这一号码，

将程序分配给 CPU。在 ES 数据管理中会为每个已下载的 CPU 创建一条过程对象信息，

以此来记录标识符和所用的过程对象许可证数。

在下载过程中，系统会确定当前 CPU 是否已使用了过程对象许可证以及多少过程对象许

可证。上次下载期间确定的过程对象数将从已保存到 ES 数据库的过程对象信息中读取。

此数量与当前确定的数量间的差异随后会与自动化许可证管理器 (ALM, Automation License 
Manager) 中可用的许可证数进行比较。如果此许可证仍能提供所需的过程对象数，则会

在 ALM 中注册这一相差的数量并执行下载。

如果当前程序包含的过程对象要少于之前下载的项目，则下载操作将自动增加可用过程对

象许可证数。如果可用许可证不够，则会因为许可证违规而相应生成一条消息要求用户必

须确认。此时可终止下载或忽略该消息继续下载。系统会将这些必需但未提供的许可证数

记录为缺少的许可证数。如果您已经购买了其它许可证，则在下次下载时这些缺少的许可

证将包含并记录到 ALM 中。
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涉及过程对象计数的情况

过程对象计数时考虑以下情况：  

● 第一次完全下载程序

● 将更改下载到同一 CPU 上的程序中

● 将程序移动到其它 CPU 中

● 停止使用 CPU

说明

拆卸 CPU 前，如果 ES 和 CPU 间此时存在连接，则首先需要取消注册 CPU 中的过程

对象。

● 在多个 CPU 中多次使用同一个程序

有关过程对象计数的信息

● 下载到 S7-PLCSIM 和测试 CPU：

不会包括过程对象计数。

● 删除项目：

删除项目时，不会通知 CFC。

说明

此种情况下不取消注册任何过程对象。因此，应在删除前取消注册过程对象。

● 删除图表文件夹或层级对象：

如果删除图表文件夹、S7 程序、CPU 或 SIMATIC 站，则此删除顺序将传递给 CFC。

在此情况下，将显示一条警告消息，允许您中止删除过程，以便可以在删除前取消注册

相关过程对象。
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● 故障 CPU：

如果过程对象信息中所存储的数据与 CPU 或存储卡的序列号相符，则替换故障 CPU 
的新 CPU 将重新被识别为之前的下载目标。对于不允许进行序列号查询的旧版 CPU，

会假定连接了“正确的”CPU。

● 取消注册过程对象

使用“选项 > 图表 > 取消注册过程对象”(Options > Charts > Book back process 
objects) 菜单命令，可以通过将不再需要在 CPU 上运行的程序的过程对象返还给自动

化许可证管理器来取消注册这些对象。 
该程序因此将从 CPU 中删除。   

说明

如果在不同位置执行工厂工程，但目标工厂需要过程对象许可证，则取消注册许可证就

尤为重要。

更多信息

● “在一个项目中可处理多少个对象？ (页 48)”部分

9.15.4.2 如何显示 PCS 7 许可证信息

简介     

仅当过程对象可以下载到 AS 时，才会将它们计入总数中。不考虑未分配硬件的 S7 程序

（在项目级或在库中）的块实例。

步骤

1. 在 SIMATIC Manager 中选择多项目或项目（任何视图）。

2. 选择菜单命令“选项 > PCS 7 许可证信息”(Options >PCS 7 license information)。
随即打开“PCS 7 许可证信息”(PCS 7 license information) 对话框。

更多信息

● “PCS 7 许可证信息”(PCS 7 license information) 对话框的在线帮助
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9.15.5 组态 I/O 的接口

9.15.5.1 信号处理的概念

简介

下文所述的 I/O 接口功能还确保了高性能。组态的执行既快又容易。

通道块的任务

在过程控制系统中，诊断/信号处理必须满足特定要求。其中包括监视模块、DP/PA 从站以

及 DP 主站系统是否出现故障。

PCS 7 的库中提供了必要的块。在这些块中，可实现包括测试功能在内的硬件接口。 

这些块执行两个基本任务： 

● 向 AS 提供过程发出的信号以便进一步处理。

● 监视模块、DP/PA 从站以及 DP 主站系统是否出现故障。

在读入过程信号时，这些块会访问过程输入映像（或过程映像区）(PII)，而在输出过程信

号时，它们会访问过程输出映像（或过程映像区）(PIQ)。 

概念

PCS 7 信号处理概念的特征可描述如下：

● 处理用户数据的块和处理诊断数据的块相互独立。

– 用户数据处理

CHANNEL 块 - 必须组态这些块。

–  诊断处理

MODULE 块 - 这些块会在生成代码时自动在组态中集成。

● I/O 信号的符号寻址

● 通过 CFC 自动生成 MODULE 块

借助这种块概念，可支持已发布模块列表中的所有模块。

还可以使用其它 PCS 7 库中的信号处理块（例如，自定义库中的自定义块）。可以在“生

成驱动程序块”(Generate Driver Blocks) 对话框中指定该附加库。在编译 AS 图表时，将首

先在指定库中搜索每个待导入块的相关数据。 
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时间优化处理 

为了能在运行时进行时间优化处理，用于处理错误的组织块（例如，OB85、OB86 等）将

自动划分成运行组，并且通道和诊断块将安装在相关的运行组中。 

例如，如果出现错误或故障，SUBNET 块会激活相关的运行组，而后，运行组中所含的 
RACK 块或模块将检测问题，对其进行评估并向 OS 输出控制系统消息。 

还会将模块的诊断信息传送到（输出 OMODE_xx）相应的 CHANNEL 块（输入模式）。

如有必要，通过可在 OS 上操作和监视的 PCS 7 块或通过用户块，可将此信息显示在过程

画面中（以颜色或闪烁显示来指示测量值变化）。

更多信息

● 相应块 (CFC) 的在线帮助

9.15.5.2 如何生成模块驱动程序

自动生成模块驱动程序

PCS 7 提供了一种信号处理功能，当使用 HW config 和 CFC 中的工艺函数组态硬件后，

系统将会自动生成所需的模块驱动程序、将它们互连并相应分配它们的参数。在信号处理

期间，需要使用这些模块驱动程序诊断和报告错误。 

如果选中了“生成模块驱动程序”(Generate module drivers) 复选框（默认设置），编译 
S7 程序时将调用此功能。如果已经生成项目的模块驱动程序，则将在处理期间进行检查以

确定是否需要更新模块驱动程序。如果在此期间硬件配置发生了变化，则必须进行更新。

手动生成模块驱动程序

也可以在 SIMATIC Manager 中手动调用“生成模块驱动程序”(Generate module drivers) 
功能。

步骤

1. 打开 SIMATIC Manager 以及要在其中生成驱动程序的项目。

2. 在组件视图中选择 S7 程序的图表文件夹。此图表文件夹中可能未选择任何图表。
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3. 选择菜单命令“选项 > 图表” > 生成模块驱动程序...”(Options > Charts > Generate Module 
Drivers...)。
或者，也可以在编译 CFC/SFC 时，在 CFC 的“将图表编译为程序...”(Charts as Program...) 
对话框中激活“生成模块驱动程序”(Generate module drivers) 复选框。
每次重新编译时，只会生成或更新所需的模块驱动程序。

4. 选择所需选项，然后单击“确定”(OK)。

说明

如果数字输入和输出模块的地址区域已在 HW Config 中进行压缩（“压缩地址”(Pack 
addresses) 功能），则驱动程序生成器无法将唯一的地址提供给相应的块。 
要确保每个模块都定义了槽分配，一定不能将地址压缩。

该功能的工作方式

“生成模块驱动程序”(Generate module drivers) 功能会生成新的系统图表（具有系统所分

配的名称“@...”），驱动程序生成器只会在其中插入依照硬件配置分配了参数且进行了互

连的驱动程序块。此外，给出相应的符号互连时，驱动程序生成器还会将用户图表中安装

的通道块与驱动程序块互连。每个系统图表包含的块数不应多于 50 个。 

用于一个 CPU 的 OB_BEGIN/OB_END 块、用于一个机架的 RACK 块以及 MODULE 块
都安装在运行组中。驱动程序生成器所创建的运行组分配有一个 ID，这样，当运行组不再

包含块时，便可再次自动将其删除。驱动程序生成器不会处理无此 ID 的运行组。如果用户

将 RACK/MODULE 块安装在另一不同的运行组中，则驱动程序生成器会将它们移动到具

有相关 ID 的运行组。

说明

由于涉及系统功能（以“@”表示），因此禁止更改系统图表。对 OB 或运行组中的安装内

容进行更改也是如此。

CFC 中的参数分配/互连

要求：已为硬件配置中模块的每个通道分配了符号名称。 

信号处理块（CHANNEL 块）会通过其符号名称分配给模块通道。 

信号处理块有一个标记为“VALUE”的块 I/O。指定此 I/O 上模块通道的符号名称（在 CFC 
中选择该 I/O，然后选择快捷菜单命令“互连到地址...”(Interconnection to Address...)）。

更多信息

● “如何组态分布式 I/O (页 369)”部分
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9.15.6 控制模块及类型概述

概述

PCS 7 中包含过程变量和控制模块以及其关联类型。       

过程变量类型或控制模块类型是一个 CFC，用于帮助过程工程工厂实现基本自动化方面的

特定过程控制功能。

过程变量

使用过程变量及其类型时存在以下属性： 

● 当从一个过程变量类型中创建并组态实例时，如果使用导入/导出助手再次导入过程变

量，实例特定的更改将丢失。

● 例如，使用不同输入块时，即使采用同一工艺功能（如“测量”），仍需要多个过程变

量类型。 不能从单个过程变量类型创建不同的过程变量版本。

控制模块

使用控制模块和控制模块类型时，上述属性不适用。 这就是为何控制模块与过程变量相比

具有以下优势：

● 对实例（即控制模块）进行的实例特定的更改在类型和实例同步期间不会丢失。

● 可从一个控制模块类型创建不同的实例。 控制模块类型还可包括可选块。 实例创建时，

可决定应向各个实例中插入哪些可选块。

处理选项

下图显示了过程变量类型或控制模型类型的创建过程、其处理方式，以及实例的创建过程。

其中还显示了过程变量类型到控制模块类型的移植方式。
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控制模块类型中的可选块

下表显示了带有可选块的控制模块类型的创建过程，以及可能的实例的创建过程。

更多信息

有关创建和处理控制模块及其类型的详细介绍，请参见手册《过程控制系统 PCS 7；
SIMATIC S7 的 CFC》(Process Control System PCS 7; CFC for SIMATIC S7)。
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9.15.7 通过过程变量类型创建过程变量（多项目）

简介

使用过程变量类型向导将过程变量类型从主数据库复制到指定的目标项目中。过程变量类

型在目标项目中作为过程变量插入。然后，将从导入文件导入关联的数据。     

根据导入文件中的条目数，可在一次导入操作中创建任意数量的过程变量。导入结果是，

根据指定的层级路径，在目标项目中为导入文件的每一行创建此过程变量类型的过程变量。

过程变量类型源

以下过程变量类型可存储在主数据库中：

● 控制系统库 PCS 7 高级过程库中的标准化过程变量类型，例如，电机、阀、PID 控制

器

● CFC 中用户创建的过程变量类型

概述

通过过程变量类型创建过程变量以及随后编辑这些变量时涉及以下主题：

● 如何从 CFC 创建过程变量类型 (页 510) 

● 如何更改过程变量类型 (页 511) 

● 如何将过程变量插入项目 (页 513) 

● 如何自动生成多个过程变量 (页 515) 

● 如何编辑过程变量 (页 516) 

● 如何采用过程变量 (页 517) 

● 如何将过程变量与过程变量类型同步 (页 519) 

● 如何恢复丢失的过程变量类型分配 (页 520) 
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9.15.7.1 如何从 CFC 创建过程变量类型

用于创建过程变量类型的选项

以下选项可用于创建过程变量类型：     

● 使用新的或现有 CFC 创建过程变量类型

● 更改现有过程变量类型：添加或删除连接/消息

由于 CFC 功能的变更（例如，互连或参数分配发生更改、添加或删除块等），可能必

须进行这些修改。可以从主数据库中的过程变量类型或已包含在项目中的过程变量开始

修改。

● 通过过程变量重新建立已删除的过程变量类型。

新过程变量类型将存储在主数据库中。

要求

在项目或主数据库中已创建 CFC，其中含有将要根据指定的过程变量描述实施的过程变量

的自动化功能、参数和消息。 

步骤

1. 在 SIMATIC Manager 中选择所需的 CFC（任意视图）。

2. 选择菜单命令“选项 > 过程变量 > 创建/修改过程变量类型...”(Options > Process Tags > 
Create/Modify Process Tag Type...)。
将启动向导，并显示“简介”(Introduction) 页面。显示当前主数据库。

3. 单击“继续”(Continue)。
向导将切换到“要将哪些 I/O 分配给过程变量类型？”(Which I/Os do you want to assign to 
the process tag type?) 页。

4. 在左侧的“过程变量类型图表中的 I/O”(I/Os in the chart of the process tag type) 窗口中，为
“参数”(Parameter) 和“信号”(Signal) 选择 I/O 点。（双击或通过选择并单击“箭头”按钮。）
I/O 点将被激活且加粗显示。

5. 在右侧的“参数/信号的 I/O 点”(I/O points for parameters/signals) 窗口中，编辑所选的 I/O 点。
可以编辑列“参数/信号”(Parameter/signal)（使用下拉列表）、
“过程变量 I/O”(Process tag I/O) 和“类别”(Category)（使用下拉列表）。
要打开下列列表，请单击相应的输入框。

6. 在左侧的“过程变量类型图表中的 I/O”(I/Os in the chart of the process tag type) 窗口中，
选择相应块的消息。
所有消息均显示在“消息的 I/O 点”(I/O points for messages) 窗口中。

7. 确认您的选择，然后单击“完成”(Finish)。
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结果

新过程变量类型存储在主数据库中。作为过程变量类型起源的 CFC 位于 S7 程序中。可在

该程序中重新使用或在不再需要时删除 CFC 图表。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.7.2 如何更改过程变量类型

简介

如果更改已用于创建过程变量的过程变量类型，则要决定是否应将这些更改应用于在更改

过程变量类型之前所创建的过程变量。     

要求 

CFC 存储在主数据库中。

步骤

1. 在 SIMATIC Manager 中选择所需的 CFC（工厂视图）。

2. 选择菜单命令“选项 > 过程变量 > 创建/修改过程变量类型...”(Options > Process Tags > 
Create/Modify Process Tag Type...)。
将启动向导，并显示“简介”(Introduction) 页面。显示当前主数据库。

3. 单击“继续”(Continue)。
向导将切换到“要将哪些 I/O 分配给过程变量类型？”(Which I/Os do you want to assign to 
the process tag type?) 页。

4. 在左侧的“过程变量类型图表中的 I/O”(I/Os in the chart of the process tag type) 窗口中，为
“参数”(Parameter) 和“信号”(Signal) 选择 I/O 点。（双击或通过选择并单击“箭头”按钮。）
I/O 点将被激活且加粗显示。

5. 在右侧的“参数/信号的 I/O 点”(I/O points for parameters/signals) 窗口中，编辑所选的 I/O 点。
可以编辑列“参数/信号”(Parameter/signal)（使用下拉列表）、“过程变量 I/O”(Process 
tag I/O) 和“类别”(Category)（使用下拉列表）。
要打开下列列表，请单击相应的输入框。

6. 在左侧的“过程变量类型图表中的 I/O”(I/Os in the chart of the process tag type) 窗口中，
选择相应块的消息。
所有消息均显示在“消息的 I/O 点”(I/O points for messages) 窗口中。

7. 如果在项目中找不到任何修改后的过程变量类型的过程变量，则单击“继续”(Continue)，然
后单击“完成”(Finish)。
向导将关闭。
否则：
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8. 单击“下一步”(Next)。
向导将切换到页面“是否要完成过程变量类型并将更改应用到现有过程变量？”(Do you want 
to finish the process tag type and apply changes to the existing process tags?)。

9. 单击“完成”(Finish)。
将显示更改日志。

10.单击“退出”(Exit)。

结果

完成对过程变量类型和过程变量所做的更改。向导将关闭。

过程变量类型 CFC 中的更改

说明

如果使用“创建/修改过程变量类型”(Create/Modify Process Tag Type) 向导直接在过程变

量类型的 CFC 中进行任何更改，则这些更改不会应用到现有的此类型过程变量！ 
其中包括以下更改： 
● 添加/删除块

● 互连更改

● 参数更改

此时，必须先删除受影响的 CFC，然后再使用导入/导出助手重新导入已更改的过程变量类

型。 
不能再对现有过程变量类型或者通过其派生的过程变量的块名称进行更改。否则，将不能

再进行导入/导出。 
确保多项目中的所有项目都可用，以便同步过程变量。

更多信息

● PH、IEA 和 PO 的在线帮助
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9.15.7.3 如何将过程变量插入项目

插入过程变量类型的概述

SIMATIC Manager 中可利用以下选项将过程变量添加到项目：    

● 使用菜单命令“插入”(Insert) >“过程变量（来自库）...”(Process Tag (from library)...)，
在过程对象视图中打开“过程变量类型”(Process Tag Types) 目录。

主数据库中的所有过程变量类型都在此目录中列出。

– 可将过程变量类型拖动到过程对象视图或工厂视图的层级文件夹中。此操作会在该

层级文件夹中创建过程变量。

– 另一选择是使用 <Ctrl> + <C> 键复制目录中的过程变量类型，然后使用 <Ctrl> + 
<V> 键将其粘贴至一个或多个层级文件夹中。

● 使用菜单命令“选项 > 过程变量 > 导入...”(Options > Process tags > Import...)（如果在

主数据库中选择了过程变量类型），可以执行导入操作并通过过程变量类型创建任意数

量的过程变量。更多相关信息，请参见“如何自动生成多个过程变量 (页 515)”部分。

● 将现有过程变量拖放到另一项目的层级文件夹中（或使用“复制”(Copy) 和“粘贴”(Paste) 
命令）。如果粘贴到同一项目中，系统会询问您是否要覆盖或重命名现有对象。请记

住，图表名称仅可出现一次。

说明

如果通过复制和粘贴创建过程变量，则仍需要分配参数并将这些参数互连。

如果使用导入文件，则与参数分配和互连相关的数据将取自导入文件。 

9.15.7.4 如何创建导入文件或将其分配给过程变量类型

简介

必须将导入文件分配给所需过程变量类型才能创建过程变量。通过“将导入文件分配给过

程变量类型”(Assign an import file to a process tag type) 向导可执行以下步骤：           

● 分配现有导入文件

● 打开并检查已分配的导入文件

● 创建和分配新导入文件
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步骤

1. 在主数据库中选择适用的过程变量类型。

2. 选择菜单命令“选项”(Options) >“过程变量”(Process Tags) >“分配/创建导入文件...”(Assign/
Create Import File...)。
将启动向导，并显示“简介”(Introduction) 页面。显示当前主数据库。

3. 单击“继续”(Continue)。
向导将切换到“要将哪些导入文件分配给过程变量类型？”(Which import file do you want to 
assign to the process tag type?) 页面。
“导入文件”(Import file) 下拉列表将显示文件，如果未进行任何分配，则会显示“未分配导
入文件”(No import file assigned) 文本。

4. 有以下几种选择：

– 若要检查已分配的导入文件的所有信息是否准确，可单击“打开文件”(Open File) 将
文件打开，并在必要时使用 IEA 文件编辑器进行编辑。

– 若要分配项目中已存在的导入文件，可单击“其它文件...”(Other File...) 并在对话框

字段中选择所需文件。

– 若要创建新的导入文件，可单击“创建模板文件...”(Create Template File...)，并在

对话域中选择所需的列/列组。然后，使用 IEA 文件编辑器编辑用“打开文件”(Open 
File) 打开的模板。

说明

如果在“导入文件”(Import file) 下拉列表中选择了“未分配导入文件”(No import file 
assigned) 文本，则可以编辑“列标题”(Column title) 列。可更改这些标题，然后生

成模板文件。 
在“导入”(Importing) 列中，有一个复选标记指示导入文件中存在哪些 I/O 点。如果

没有这个复选标记，则说明 I/O 点存在于过程变量类型中，但不在当前分配的导入文

件中。

5. 单击“完成”(Finish)。

结果

导入文件分配给过程变量类型。

更多信息

● “使用 IEA 文件编辑器创建/编辑导入文件 (页 639)”部分

● PH、IEA 和 PO 的在线帮助
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9.15.7.5 如何自动生成多个过程变量

要求

必须已将导入文件分配给过程变量类型。     

读者注意事项

有关导入文件创建的详细描述，可参考“导入/导出过程变量/模型”部分。以下是已经分配

了导入文件时所使用的基本步骤的描述。

步骤

1. 选择所需的层级文件夹、项目节点或过程变量库（主数据库中的层级文件夹），或过程变量
类型。

2. 选择“选项 > 过程变量 > 导入...”(Options > Process Tags > Import...) 菜单命令。
将打开“导入”(Import) 对话框。
向导会搜索过程变量类型及相应的导入文件（也会在所有层级子文件夹中搜索），并将其列
出。将对列出的所有导入文件执行导入操作。

3. 如果不想导入某些文件，可选择这些文件，然后使用“删除”(Remove) 按钮从列表中将其删除。
单击“其它文件”(Other File)，可以搜索不同的导入文件，然后选择该文件来代替其他文件。

4. 单击“继续”(Continue)，然后单击“完成”(Finish)。

结果

开始执行实际的导入过程。 

根据“在日志中仅显示错误和警告”(Only show errors and warnings in log) 复选框的设置，

在日志窗口中会显示活动及其各个步骤的完整列表或仅显示发生的错误。

日志保存在日志文件中。文件的名称和路径会出现在日志窗口的下面。可以使用“其它文

件”(Other File) 按钮修改此设置。

更多信息

● “如何导入过程变量类型和模型 (页 633)”部分。
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9.15.7.6 如何编辑过程变量

简介

在过程对象视图中，可编辑项目的各个过程变量，例如更改注释、值和互连（前提是这些

内容定义为“参数”或“信号”）。     

步骤

1. 使用菜单命令“视图”(View) >“过程对象视图”(Process Object View) 打开过程对象视图。

2. 在树形结构中选择所需过程变量（左侧窗口）。

3. 在右侧的表中，选择所需变量并在其中进行修改（在可编辑的单元中）。

示例：将一个 I/O 与其它 I/O 互连。

要求：块的 I/O 已定义为参数。

1. 选择过程变量。

2. 选择“参数”(Parameters) 选项卡。

3. 在“互连”(Interconnection) 列中选择所需 I/O 的单元。

4. 在快捷菜单中，选择菜单命令“插入互连...”(Insert Interconnection...)。
将打开“插入互连”(Insert Interconnections) 对话框。

5. 在树形结构中选择过程变量和含有要互连的 I/O 的块。

6. 单击“应用”(Apply)。
或者，也可以在过程对象中双击 I/O 或将 I/O 拖至所选单元。

结果

输入了互连；对话框仍然打开。选中了该列的下一格单元。

重命名过程变量

说明

重命名过程变量且随后编译了 OS 之后，会自动修改画面和归档中的所有互连以及脚本中

的变量。但是不会修改归档变量的名称；它们继续显示旧的过程变量名称。可相应地更改

归档变量名称。在这种情况下，确保同时修改关联的趋势控件。

只会为 OS 的本地单一控制单元更正互连。必须手动修改通过服务器-服务器通信进行的、

到其它 OS 的单一控制单元的所有互连。
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9.15.7.7 如何采用过程变量

简介

如果符合限制条件，则在导入期间可重新分配未分配给过程变量类型的 CFC。       

要求

CFC 块和 I/O 的名称对应于过程变量类型的名称。

这适用于：

● 识别为参数/信号的 I/O。

● 消息的识别块。

情况 1：将现有图表识别为过程变量

已经创建 CFC，例如，组态了电机控制，并已多次手动复制此图表。已更改或修改这些副

本，以应对不同需求。

以后要使用这些辅助功能，并通过导入创建更多过程变量。希望继续使用以前创建的图表

并要将其标识为过程变量。 

步骤 - 情况 1

1. 可以使用菜单命令“选项”(Options) >“过程变量”(Process Tags) >“创建/修改过程变量类型...”
(Create/Modify Process Tag Type...)，通过一个现有图表创建过程变量类型。
更多相关信息，请参见“如何从 CFC 创建过程变量类型 (页 510)”部分。

2. 使用菜单命令“选项”(Options) >“过程变量”(Process Tags) >“分配/创建导入文件...”(Assign/
Create Import File...) 将合适的导入文件分配给过程变量类型。

3. 使用菜单命令“选项”(Options) >“过程变量”(Process Tags) >“导入...”(Import...) 启动导入过
程，并使用“打开文件”(Open File) 按钮打开第 2(3) 页上的导入文件。

4. 将要采用的每个图表添加到文件的某一行中。继续操作直至完成导入。

说明

请注意以下事项：

● 确保采用的图表位于输入到导入文件“层级”(Hierarchy) 列中的文件夹内。

● 如果想要保留图表值并且不想要它们被过程变量类型值所覆盖，则删除导入文件中的相
应字段。
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结果 - 情况 1

如果满足采用过程变量的条件，则 CFC 会成为已导入的过程变量类型的过程变量，并应用

过程变量类型中的 I/O 名称和类别。将重置任何附加过程变量标识符（消息块或块 I/O）。

容许过程变量类型中没有的附加块和 I/O，但会予以忽略。

如果采用的过程变量是模型副本的一部分，则 IEA 标记将保持不变。若不是副本的一部

分，则必要时将重置预设的 IEA 标记。

情况 2：图表已丢失其到过程变量类型的分配。

对于已成为过程变量的 CFC，通过对象属性取消了对过程变量类型的分配（使用菜单命

令“对象属性 >”(Object Properties >)，“过程变量类型”(Process Tag Type) 选项卡，所

选图表，“取消”(Cancel) 按钮）。

要重新分配图表，请按情况 1 的第 3 项和第 4 项操作。

情况 3：手动复制了过程变量类型 

在项目或主数据库中已通过多次复制和粘贴插入过程变量类型。现在要将这些副本分配给

过程变量类型并创建或修改 IEA 文件。

步骤 - 情况 3

1. 在 PH 中选择过程变量类型。

2. 选择菜单命令“选项 > 过程变量 > 导出...”(Options > Process Tags > Export...)。
将打开“导入/导出助手：导出过程变量”(Import/Export Assistant:Export process tags) 对话
框。

3. 单击“继续”(Continue)，然后在下一个对话框中选择导出文件（“打开文件”(Open File) 或
“其它文件”(Other File) 按钮）。

4. 单击“继续”(Continue)。

5. 根据需要，选择日志文件的路径和名称，然后单击“完成”(Finish)。
将执行导出并创建导出文件。这些操作将记录在窗口内并存储在日志文件中。

6. 单击“上一步”(Back) 检查导出文件，然后打开刚刚创建的导出文件。

结果 - 情况 3

导出文件中包括过程变量类型的所有副本。 

现在，可使用这些文件进一步工作，即根据需要添加条目，然后将其用于导入过程。
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9.15.7.8 如何将过程变量与过程变量类型同步

简介

修改过程变量类型时，将自动同步多项目中存在的过程变量。如果过程变量类型和过程变

量之间存在不一致（例如：同步过程期间并非项目的所有过程变量都可访问），也可直接

执行同步。     

要求

● 在多项目中可使用过程变量。

● 修改后过程变量类型位于主数据库中。

步骤

1. 选择适用的过程变量类型（在主数据库中），然后选择菜单命令“选项 > 过程变量 > 同步...”
(Options > Process tags > Synchronize....)。
将启动“同步过程变量”(Synchronize process tags) 向导并显示当前主数据库。

2. 单击“继续”(Continue)。
向导转换到“是否要对比现有过程变量与过程变量类型？”(Do you wish to compare the 
existing process tags with the process tag type?) 页面。

3. 单击“完成”(Finish)。

随即出现同步过程日志。

过程变量类型修改

说明

同步过程变量时，不考虑过程变量类型图表中的更改。此时，必须重新导入已修改的过程

变量类型。 
在导入文件中，在“常规列组”(General column group) 的“Importmode”列中为要删除的

每个过程变量添加关键字“Delete”。要创建新过程变量，插入一个附加行，其中“导入模

式”(Import mode) 列字段为空。
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后续同步无法访问的过程变量

如果同时发生以下情况，则无法根据上述方法同步过程变量：

● 过程变量类型的名称已更改

● 执行同步时并不能访问此类型的所有过程变量（例如：将项目分配给工程工作分区后）

● 这些过程变量随后恢复到项目中。

后续同步过程变量

可在以后使用以下过程同步无法访问的过程变量：

1. 更改相关过程变量类型的名称。

2. 选择菜单命令“选项”(Options) >“过程变量”(Process Tags) >“同步...”(Synchronize...)。
所有过程变量将与已修改的过程变量类型同步。

3. 重命名具有原始名称的过程变量类型并重复同步。

现在将所有过程变量修改为符合相应的过程变量类型。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.7.9 如何恢复丢失的过程变量类型分配

简介

如果项目中存在过程变量，但相应的过程变量类型却不在主数据库中，则不能导入或导出

这些过程变量。导入/导出过程始终需要导入/导出文件结构。不过，只是过程变量类型有这

种结构。     

补救措施

可从项目的现有过程变量中创建过程变量类型，并重新建立分配。

步骤

1. 在项目中选择适用的过程变量。

2. 选择菜单命令“选项”(Options) >“过程变量”(Process Tags) >“创建/更改过程变量类型...”
(Create/Change Process Tag Type...)。
将启动向导，并显示当前主数据库。
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3. 单击“继续”(Continue)。
助手将显示一条错误消息，并提示是否要将所选图表创建为主数据库中的过程变量类型。

4. 单击“是”(Yes)。
助手转换到“要将哪些 I/O 分配给过程变量类型？”(Which I/Os do you want to assign to the 
process tag type?) 页面。

5. 单击“完成”(Finish)。

结果

创建过程变量类型并存储在主数据库中。从而重新建立了过程变量到过程变量类型的分配

关系。

现在仍必须分配导入文件或创建一个新文件。

规则

说明

在此步骤中，可根据需要修改过程变量类型。将自动修改现有过程变量。

说明

如果之前已针对某个具体工艺任务修改了过程变量，而过程变量类型与此过程变量无关或

甚至不允许存在，则必须在 CFC 图表中进行相应的更改（例如：互连、参数分配）。

9.15.8 创建顺序控制系统 (SFC)

SFC 和 SFC 编辑器

SFC 是一种顺序控制系统，在其中可以顺控程序的形式集成多达 8 个（SFC 类型可多达 
32 个）可单独启动的顺序。     

SFC 被唯一分配给一个 CPU，并在此 CPU 上完全执行。

SFC 编辑器是用于创建顺序控制系统的工具。

更多相关信息，可参见 SFC 在线帮助或手册《S7 的 SFC；顺序功能图》(SFC for S7; 
Sequential Function Chart)。
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顺序控制系统

顺序控制系统是一个逐步执行的控制器，可根据条件将控制从一个状态传递到下一个状

态。 

例如，顺序控制系统可用于将产品制造作为事件控制的过程（配方）来描述。 

使用顺序控制系统，可通过操作和状态更改控制基本自动化中的功能（通常用 CFC 创
建），且可以选择性的执行。

使用顺序控制系统

顺序控制系统通常应用于具有非连续特征的过程和工厂。但也可将其用于连续工作工厂。 

示例：

● 接近和撤回运动

● 运行点更改

● 干扰过程中的状态更改

可在工厂中的以下级别使用顺序控制系统：

● 工厂级（同步各单元和共用资源，例如工艺路线）

● 单元级（料罐、搅拌器、秤、反应釜等）

● 组控制级（配料、搅拌、加热、填充等）

● 设备控制级（开启阀、起动电机等）

工作原理

可以使用 SFC 编辑器中的图形工具创建顺序控制系统。图表中的 SFC 元素根据固定的规

则在顺控程序中进行放置。您无需关心算法或机器资源分配之类的细节问题。这使您可以

专注于组态的技术方面。

创建图表拓扑后，即可组态对象属性。此时您需要定义顺控程序的属性以及各个步和转移。

这样，您就可以组态操作和条件了。

组态之后，使用 SFC 编译可执行机器代码，将其下载到 PLC，并使用 SFC 测试功能对它

进行测试。
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更多信息

● SFC 在线帮助

● 手册《S7 的 SFC；顺序功能图》(SFC for S7; Sequential Function Chart)

● 手册《过程控制系统 PCS 7，入门指南 - 第 1 部分》(Process Control System PCS 7, 
Getting Started - Part 1)

9.15.8.1 SFC 类型/SFC 实例的优点和用例

类型/实例概念      

类型/实例概念可用于创建当放置在 CFC 中时可生成 SFC 实例的顺序控制系统。

通过类型/实例概念可实现以下优点：

● 集中组态

● 复用性

● 可下载更改

SFC 类型

除了“SFC”对象类型外，SFC 还包括“SFC 类型”对象类型。

SFC 类型允许定义顺序控制系统和可扩展接口。 

SFC 类型的顺序逻辑取决于 SFC 类型的接口 I/O。与 SFC 不同，SFC 类型不访问随机过

程信号。 

SFC 类型本身无法执行。与功能块类型类似，必须将 SFC 类型放入 CFC 中以获得运行系

统相关的对象（在此情况下为 SFC 实例）。要运行 SFC 实例，请将 SFC 类型和 SFC 实
例都下载到自动化系统上。

说明

SFC 类型也可位于库中（例如，SFC 库）。

为使用 SFC 类型，这些类型必须位于程序的图表文件夹中。这可通过如下方式得以实现：

● 将库中的 SFC 类型直接放置到 CFC 中时，此 SFC 类型将被复制到程序的图表文件夹中。
然后 SFC 类型将显示在“块”(Blocks) 选项卡的 CFC 目录中，并可从此处将其放入 CFC 
中。

● 将 SFC 类型从库的图表文件夹复制到程序的图表文件夹中。然后可在“块”(Blocks) 选项卡
的 CFC 目录中使用 SFC 类型，并可从此处将其放入图表中。
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SFC 实例

SFC 实例由 SFC 类型派生得出。为此，该 SFC 类型安装在 CFC 中，类似于 CFC 中的功

能块类型。SFC 实例始终分配给 CFC，并由该图表进行寻址。与 CFC 实例类似，SFC 实
例会表示为块：其接口显示在 CFC 中。 

SFC 实例不在 SIMATIC Manager 中显示，因为它们只能通过 CFC 进行寻址。将 CFC 分
配到工厂层级时，也会间接地将包含的 SFC 实例分配到工厂层级。

基本操作步骤

1. 在 SFC 编辑器中创建 SFC 类型。同时组态其顺控程序和 SFC 接口。
更多相关信息，请参见“如何创建 SFC 类型 (页 543)”部分。

2. 在 CFC 中创建 SFC 实例，然后设置参数并将它们互连。
更多相关信息，请参见“如何创建 SFC 实例 (页 546)”部分。

预组态顺控程序模板

预组态的顺控程序模板位于 SFC 库中。可复制并修改这些模板以供自己使用。

OS 上的 SFC 可视化

SFC 可视化附加软件包用于操作和监视 OS 上的 SFC。也可使用 SFC 可视化 进行操作和

监视 SFC 所需的组态工作。有关详细信息，请参考组态手册《过程控制系统 PCS 7；操

作员站》(Process Control System PCS 7; Operator Station)。

更多信息

● SFC 在线帮助

● 手册《S7 的 SFC 可视化》(SFC Visualization for S7)

9.15.8.2 组态步骤概述

简介         

以下是为 PLC 组态顺序控制系统 (SFC) 时所必须执行的一系列步骤：同一系列步骤也适

用于 SFC 类型的组态，但在这种情况下，仍必须定义 I/O 和特征。

要求

在 SIMATIC Manager 中创建可在其中组态 CFC/SFC 的项目结构。 
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组态任务概述

步骤 内容 描述

1 指定图表属性 指定图表属性时，可更改图表名称并添加注释。

2 创建顺序控制系统

的拓扑 
顺序控制系统随 SFC 一同组态。这通过为一个或多个顺控程

序插入步和转移（并在必要时添加结构元素）来实现。

3 组态顺控程序属

性 
针对每个顺控程序，组态启动条件及预处理和后处理操作。

4 组态步

（在“对象属性”
(Object 
Properties) 对话

框中）

制定步中的操作。操作包含更改块输入值和共享地址值的指

令，或激活和禁用运行组或其它 SFC 的指令。

5 组态转移

（在“对象属性”
(Object 
Properties) 对话

框中）

制定转移中的步启用条件。这些条件会读取块 I/O 和共享地

址的值，或读取运行组或其它 SFC 的状态（活动/非活动）。

如果指定逻辑运算后面的条件为真，则下一步变为活动状态

并执行其操作。

6 调整工作参数和运

行属性 
通过设置工作参数，可指定顺序控制系统的行为，例如模式

（手动、自动）、步控模式（T、C、T 和 C……）、CPU 重
新启动后的 SFC 启动以及其它图表执行选项（循环操作、时

间监视、自动启动等）。 

SFC 的运行属性决定了在 PLC 上执行整个结构时如何加入 
SFC（在 CFC 运行编辑器窗口中）。

7 编译 SFC 在编译过程中，活动图表文件夹中的 CFC 和 SFC 会转换为

一个可执行用户程序（编译：整个程序/仅更改内容）。

8 下载 SFC 程序 编译后，可将程序下载到目标系统 (CPU)（下载：整个程序/
仅更改内容）。

9 SFC 程序测试简

介 
编译和下载完成后，可在过程模式或实验室模式下测试 SFC 
程序。使用 SFC 测试功能，可以在不同运行模式和步控模式

下运行顺序控制系统，并监视和修改 CPU 上的地址值。还可

以改变 CPU 最重要的运行模式（STOP、清除/复位、RUN 
等）。
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说明

输入单元时，确保未使用以下特殊字符：[ ' ] [ $ ]。

更多信息

● 相关信息，请参见“CFC 及 SFC 版本控制 (页 701)”部分。

● 有关访问保护的信息，请参见“如何防止对工厂进行未经授权的访问？ (页 37)”部

分。 

9.15.8.3 如何创建新 SFC

简介

可在 SIMATIC Manager 中创建 SFC 和 SFC 类型。

要求

● 所需的项目结构已存在于 SIMATIC Manager 中。

● 必须将用于创建图表的层级文件夹分配给一个图表文件夹。

步骤

1. 在 SIMATIC Manager 的工厂视图中选择所需的层级文件夹。

2. 选择菜单命令“插入 > 工艺对象 > SFC”(Insert > Technological Objects > SFC)。
将 SFC 插入层级文件夹。将 SFC 自动分配到图表文件夹。
图表从系统收到一个标准名称（如 SFC(1)）。

3. 根据需要更改名称。该名称在 CPU 中必须唯一。系统会对此进行检查。

4. 在右侧窗口（层级文件夹的内容）中，双击新的 SFC。

结果

SFC 编辑器启动（如果其尚未启动），SFC 以其初始状态显示在 SFC 编辑器的窗口中。
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命名

说明

请注意以下几点：

● SFC 的名称最多可以包含 22 个字符。

● SFC 类型的名称最多可以包含 16 个字符。尽管可以在属性中输入 24 个字符，但创建实例
时只允许输入 16 个字符。

● 名称中不允许使用下列字符：\、.、/、" 和 %。

更多信息

● SFC 在线帮助

9.15.8.4 如何指定顺控器属性

简介

顺控程序属性用于确定顺控程序最初启动的方式或首先启动哪个顺序控制系统。新建 SFC
（类型）的顺控程序已具备一个启动条件 (RUN = 1)。因此，它会被连接到操作状态逻辑 
(OSL)。对于其它每个顺控程序，用户必须自己指定启动条件。启动条件和优先级决定了

启动哪个顺控程序。

步骤

1. 在 SFC 编辑器中选择菜单命令“编辑 > 顺控程序属性...”(Edit > Sequencer Properties...)。
将打开“属性”(Properties) 对话框。

2. 设置下表中列出的顺控程序属性。
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可选择的顺控程序属性

选项卡 属性 含义

“常规”
(General)

名称 当前顺控程序的名称

最多可键入 16 个字符。

注释 有关顺控程序的注释 

最多可键入 80 个字符。 

优先级 顺控程序的优先级（1 到 32） 

在 SFC 有几个顺控程序同时满足启动条件时，优先级决

定启动其中哪个顺控程序。

注：32 是最高优先级，1 是最低优先级。

“启动条件”
(Start condition)

 指定哪些条件为真才可启动顺控程序（例如，当 SFC 处
于“RUN”操作模式时，“SFC.RUN = Active”则会启动

顺控程序）。

要实现三阶段转移逻辑，可将各个条件进行逻辑组合以

创建布尔表达式。

“OS 注释”(OS 
Comment)

 指定顺控程序属性和转移属性

可为 SFC/SFC 类型中的每个条件输入一个最长 256 个
字符的 OS 注释。

“预处理”
(Preprocessing)

 定义每个周期中的顺控程序启动后，要在处理步和转移

之前执行的动作

“后处理”
(Postprocessing
)

 定义每个周期中的顺控程序启动后，要在处理步和转移

之后执行的动作

更多信息

● SFC 在线帮助

9.15.8.5 如何创建顺控程序的拓扑

SFC 编辑器中的图表描述

新建的 SFC（SFC 类型）最初包含 1 个顺控程序，该顺控程序最多可扩展为 8 个（SFC 
类型：多达 32 个）顺控器。每个顺控器都在一个单独的工作窗口中创建。可以使用窗口

底部的选项卡在各个顺控程序之间切换。
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初始状态下的顺控程序由启动步、转移和结束步组成。

图表拓扑由步和转移的序列构成。 

如果决定在顺控程序中插入或删除 SFC 元素，则这些元素会根据预定义的规则自动显示。

例如，以下因素由规则规定：

● 各图表元素间的距离

● 步和转移的范围

● 选择序列的组态

可使用“选项”(Options) >“自定义”(Customize) >“表示...”(Representation...) 菜单命令随时

修改显示/布局规则。

可在显示区域上将整个工厂拓扑居中。这样，各元素就可在图表上均匀分布。缩放功能可

按照由缩放因子决定的百分比来增大或减小显示的大小。

创建顺控程序

要创建顺控程序，请使用菜单命令“插入”(Insert) >“顺序”(Sequence) > ...。 

一个新的顺控程序即被插入到图表中预先选择的位置。通过窗口底部的选项卡展开窗口。

每个选项卡都包含 SFC 中某一顺控程序的名称（RUN、SEQ1…）。

可以使用菜单命令“插入”(Insert) > ... 将 SFC 元素插入顺控程序。 

语法规则

图表拓扑的基本规则如下：步 (S) 后面必须跟有转移 (T)，反之亦然（顺序：S-T-S 或 T-S-
T）。编辑器会自动遵守规则。

示例：

如果在顺控程序中某一转移之后、某一步之前插入一个并行分支，则会在此步前面自动创

建一个转移，因为语法规则要求在并行分支的前后都必须是转移。
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SFC 元素概述

SFC 元素 功能

顺控程序 通过顺控程序可在 SFC 中实现基于状态的事件控制处理。SFC 包含可

通过定义的不同启动条件进行控制的顺控程序。

顺控程序元素 SFC 包括 1 到 8 个顺控程序，SFC 类型包括 1 到 32 个顺控程序，每个

顺控程序都具有一个由以下顺控程序元素（基本元素）组成的顺序：

● 步

● 转移

顺序之外还存在以下元素：

● 文本

剩下的元素是由不同基本元素构成的结构：

● 顺序

● 并行分支

● 选择分支

● 循环

● 跳转

步 在 SFC 中，通过步可执行操作。存在以下步类型： 
● 初始步

● 标准步

● 结束步

初始步 每个 SFC 都只有一个初始步。创建新图表时会自动在 SFC 中安装以下

对象（初始状态）：

● 初始步

● 转移

● 结束步

不可以复制、剪切或删除初始步。但可以复制、剪切或删除初始步操作。

初始步操作的组态方式与其它任何步的操作完全相同。

结束步 每个 SFC 都只有一个结束步。最初创建图表时，就会创建一个初始步、

一个转移和一个结束步（初始状态）。 

不可以复制、剪切或删除结束步。但可以复制、剪切或删除结束步操作。

结束步操作的组态方式与其它任何步的操作完全相同。

转移 转移是 SFC 的一个基本元素，并包含顺序控制系统将控制从某一步传递

给下一步时所依据的条件。

文本 文本是可插入到图表中的一个元素。可使用该元素在图表中输入注释。

可对插入图表的文本进行编辑、移动、复制、剪切和删除。
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SFC 元素 功能

顺序 SFC 中包含步和转移顺序的结构元素。并行分支或选择分支至少由 2 个
并列排列且至少包含 1 个元素的顺序组成。

并行分支 在 SFC 中，并行分支允许数个顺序同时运行。所有顺序程序完成（同

步）后，并行分支随即完成。

选择分支 SFC 中的结构元素，至少包含两个顺控程序。AS 只处理其转移条件最

先被满足的顺控程序。

循环 在 SFC 中，循环允许回跳到所选的上一点。当 SFC 位于循环的起点且

循环转移完成时，则会执行返回跳转。在这种情况下，会将循环中的顺

序从头至尾再运行一次。

跳转 跳转是 SFC 的一个结构元素，通过跳转可根据转移条件在同一图表中的

另一步继续执行 SFC。

添加 SFC 元素

要将更多的图表元素添加到 SFC 中，请在元素栏中选择所需 SFC 元素的图标。

鼠标指针的外观会由箭头变为带有定位十字准线的所选图标。要插入图表元素，请将十字

准线定位到链接上的所需位置并单击鼠标左键。插入的图表元素即被选中并用颜色显示。

数据备份 

说明

在 SFC 编辑器中进行的所有更改都会立即保存，因此在 SFC 中没有额外的保存选项。请

记住，如果不保存就关闭编辑器，则不能撤消或取消在 SFC 编辑器中所进行的更改。

建议使用菜单命令“文件”(File) >“归档...”(Archive...) 将整个多项目或相关项目中包含的数

据归档。

9.15.8.6 如何组态步

步    

操作在步中定义。例如，这些操作包含可用于修改块输入的值或者激活或禁用其它 SFC 的
语句。
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步属性

可以在步的“属性”(Properties) 对话框中进行以下设置：

选项卡 含义

“常规”
(General)

在此选项卡中，可以编辑所选步的常规属性（如名称、注释）。

“初始化”
(Initialization)

“处理”
(Processing)

“终止”
(Termination)

处理阶段（动作）的“初始化”(Initialization)、“处理”(Processing) 和
“终止”(Termination) 选项卡全都采用相同的布局。可在此处组态用于

控制过程的语句。 

在这些选项卡中，可以定义步的以下操作：

● 激活步时应执行的操作（初始化）

● 在处理步的周期中应执行的操作（处理）

● 退出步时应执行的操作（终止）

已为其定义操作的每个步都以暗灰色显示。这意味着您一眼就可以看

出是否已为某步分配了参数。

步骤

1. 在 SFC 编辑器中选择要编辑的步。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
将打开步的“属性”(Properties) 对话框。

3. 在“常规”(General) 选项卡中输入所需属性。

说明

从理论上说，可通过相同方式编辑其它所有选项卡。

4. 选择所需选项卡（“初始化”(Initialization)、“处理”(Processing)、“终止”(Termination)），
将鼠标指针定位到所需语句行左侧地址（操作符）的文本框中。

5. 单击“浏览”(Browse)。
将打开“浏览”(Browse) 对话框。
在此对话框中，可以看到项目的各个 CFC，并在前三列中显示了 PH 分配、图表名称和注
释。在后三列中，可以看见属于在第一列中所选的图表的所有块。选择某个块后，最后一列
就会立即显示所有的相关 I/O。

6. 选择所需 CFC。
将显示该图表的所有块。

7. 选择所需块。
将显示该块的所有 I/O。

8. 选择所需 I/O，然后选择快捷菜单命令“应用 I/O”(Apply I/O)。
将输入所选块 I/O 及相应的完整路径。鼠标指针将自动定位到右侧地址的文本框中。
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9. 根据左侧地址，为右侧地址输入一个设定值，如 TRUE 或 FALSE 或输入一个到附加块 I/O 
上的互连（菜单命令“浏览”(Browse)）。
更多相关信息，请参考“块 I/O 互连的语法”部分。

10.单击“应用”(Apply) 应用设置。

11.单击“关闭”(Close)。

12.如果要编辑更多步，请执行相同步骤。

更多信息

● SFC 在线帮助

9.15.8.7 如何组态转移

转移            

转移包含顺序控制系统从一个步向下一个步传递控制时使用的条件。可以使用布尔操作符

将数个条件在逻辑上组合起来。逻辑操作的结果决定是否启用下一个步。从理论上说，转

移的组态方式与步的组态方式相同。

转移的属性

可以在转移的“属性”(Properties) 对话框中进行以下设置：

选项卡 含义

“常规”
(General)

在此选项卡中，可以编辑所选转移的常规属性（如名称、注释）。

“条件”
(Condition)

在此选项卡中，可为 SFC/SFC 类型定义可导致转移在顺控程序中启用

下一步的条件。

要实现三阶段转移逻辑，可将各个条件进行逻辑组合以创建布尔表达

式。

“OS 注释”(OS 
Comment)

在此选项卡中，可为 SFC/SFC 类型中的每个条件都输入一个 OS 注
释，其最大长度为 256 个字符。 

所制定的条件在“条件”(Conditions) 或“启动条件”(Start Condition) 
选项卡中作为默认值输入。
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条件

条件提供以下选项：

● 从块 I/O 或共享地址读取值

● 使用布尔操作符（=、>、<……）将读取值与某一常量或另一读取值进行逻辑组合

条件的结果是一个可与其它条件结果进行逻辑组合的布尔变量。

步骤

1. 在 SFC 编辑器中选择要编辑的转移。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
将打开转移的“属性”(Properties) 对话框。

3. 在“常规”(General) 选项卡中输入所需属性。

4. 选择“条件”(Condition) 选项卡，将鼠标指针定位到所需语句行左侧地址（操作符）的文本
框中。

5. 单击“浏览”(Browse)。
将打开“浏览”(Browse) 对话框。
在此对话框中，可以看到项目的各个 CFC，并在前三列中显示了 PH 分配、图表名称和注
释。在后三列中，可以看见属于在第一列中所选的图表的所有块。选择某个块后，最后一列
就会立即显示所有的相关 I/O。

6. 选择所需 CFC。
将显示该图表的所有块。

7. 选择所需块。
将显示该块的所有 I/O。

8. 选择所需 I/O，然后选择快捷菜单命令“应用 I/O”(Apply I/O)。
将输入所选块 I/O 及相应的完整路径。鼠标指针将自动定位到右侧地址的文本框中。

9. 选择将用于逻辑组合两个地址的所需操作符。

10.根据左侧地址，为右侧地址输入一个设定值，如 TRUE 或 FALSE 或输入一个到附加块 I/O 
上的互连（菜单命令“浏览”(Browse)）。

11.指定一个三级转移逻辑布尔运算符被设计成按钮形式。单击该运算符可将其从“AND (&)”切
换到“OR (≥1)”。单击地址输出可将“AND”更改为“NAND”并将“OR”更改为“NOR”。
通过输出线上的一个加粗圆点来显示“非”操作。

12.打开“OS 注释”(OS Comment) 选项卡。
在此选项卡中，可为 SFC/SFC 类型中的每个条件都输入一个 OS 注释，其最大长度为 256 
个字符。
所制定的条件在“条件”(Conditions) 或“启动条件”(Start Condition) 选项卡中作为默认值输
入。第一次打开“OS 注释”(OS Comment) 选项卡时，会将制定的条件应用为 OS 注释。可
随时对其进行更改。
如果 OS 注释就是所制定的条件（即默认值），则会在行的开头由“链接”符号表明这一
点。

13.单击“应用”(Apply) 应用设置。

14.单击“关闭”(Close)。
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块 I/O 互连的语法

在 SFC 中，操作符将两个地址组合在一个条件中。将两个地址互相比较。结果为 TRUE 
或 FALSE。

可以对地址进行下列操作： 

● <（小于）

● <=（小于或等于）

● =（等于）

● >=（大于或等于）

● >（大于）

● <>（不等于）

更多信息

● SFC 在线帮助

9.15.8.8 如何调整工作参数和运行属性

简介

可以显示并修改活动 SFC 的工作参数和运行属性。SFC 的初始状态用工作参数指定。 
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SFC 的可调整工作参数和运行属性

可以在 SFC 的“属性”(Properties) 对话框中进行以下设置：

选项卡 含义

“常规”(General) 可在此选项卡中输入或更改以下信息：

● 名称

● 作者

● 注释

● 写保护

“运行参数 AS”
(Operating 
parameters AS)

在此选项卡中，可以更改 AS 工作参数的默认设置以及 SFC 的开

始选项。 
● SFC 初始状态的默认设置：

– “步控模式”(Step Control Mode)
– “运行模式”(Operating Mode)
– “命令输出”(Command Output)
– “循环操作”(Cyclic operation)
– “时间监视”(Time monitoring)

● CPU 重启动后 SFC 启动的选项

– “初始化 SFC”(Initialize SFC)
– “保留 SFC 状态”(Retain SFC state)

● 启动 SFC 的选项：

– “自动启动”(Autostart)
– “SFC 启动时使用默认工作参数”(Use default operating 

parameters when SFC starts)
此选项的设置决定了顺序控制系统的运行特征。

OS 在此选项卡中，可以指定下次编译 OS 时是否应包含 SFC。

“版本”(Version) 在此选项卡中，可以更改 SFC 的版本号。
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SFC 的可调整工作参数和运行属性

可以在 SFC 类型的“属性”(Properties) 对话框中进行以下设置：

选项卡 含义

“常规”(General) 可在此选项卡中输入或更改以下信息：

● 名称

● 作者

● 注释

● 写保护

“运行参数 AS”
(Operating 
parameters AS)

在此选项卡中，可以更改 AS 工作参数的默认设置以及 SFC 类型

的开始选项。 
● SFC 类型初始状态的默认设置：

– “步控模式”(Step Control Mode)
– “运行模式”(Operating Mode)
– “命令输出”(Command Output)
– “循环操作”(Cyclic operation)
– “时间监视”(Time monitoring)

● CPU 重启动后 SFC 启动的选项

– “初始化 SFC”(Initialize SFC)
– “保留 SFC 状态”(Retain SFC state)

● 启动 SFC 的选项：

– “自动启动”(Autostart)
– “SFC 启动时使用默认工作参数”(Use default operating 

parameters when SFC starts)
此选项的设置决定了顺序控制系统的运行特征。

“选项”(Options) 可在此选项卡中为 SFC 类型设置 SIMATIC BATCH 选项。 
● “类别：”(Category:)

– “无”(None)
– “EOP”
– “EPH”

● 允许操作员指令

● SIMATIC IT
– “MES 相关性”(MES-relevant)

● 控制策略选择

“版本”(Version) 在此选项卡中，可以更改 SFC 类型的版本号。
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步骤 

1. 选择菜单命令“SFC > 属性...”(SFC > Properties...)。
将打开“SFC 图表属性”(SFC Chart Properties) 对话框。

2. 调整工作参数和运行属性。

3. 单击“确定”(OK)。

运行模式

在组合框中选择是由操作员控制该执行还是自动执行该执行。

● 自动（过程模式）：

自动控制该执行。应用程序默认设置。例如，在 CFC 的 SFC 外部视图中通过参数设置

和输入互连来确定这些默认设置。在“自动”模式下，步控模式可设置为“T”和“T/T 
和 C”。

● 手动（操作员模式）（默认）：

由操作员手动控制该执行（例如，在 SFC 测试模式下或在 SFC 的 OS 上）。允许使用

所有的步进控制模式。

步控模式

在组合框中选择步控模式，SFC/SFC 实例将在该模式下运行。 

不同的步进控制模式会影响待传输的操作或实际的传输操作。 

在所有操作模式下都能更改步进控制模式。各种步控模式互相排斥。

步控模式 含义

T
（默认）

通过转移进行控制

由过程控制顺序控制系统的运行（自动）。当满足转移条件时，通过禁用

前面的步和启用后继步来传递控制。

C 通过操作员确认进行控制

只通过操作员控制顺序控制系统的运行。无需满足转移条件。对于每个活

动步的每一后继转移，都会设置操作员提示，且只有操作员对提示进行确

认后，控制才会传递到下一步或下几步。

T 和 C
通过转移和操作员确认进行控制由过程和操作员控制顺序控制系统的运

行。如果满足活动步的后继转移条件，则会设置操作员提示，且只有操作

员对提示进行确认后，控制才会传递到下一步或下几步。
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步控模式 含义

T 或 C 通过转移或操作员确认进行控制

由过程和操作员控制顺序控制系统的运行。对于活动步的每一后继转移，

都会设置操作员提示，且在操作员对提示进行确认后，控制会传递到下一

步或下几步。如果在确认操作员提示前转移条件为真，则不进行操作员干

预就可将控制传递到下一步或下几步（自动）。

T/T 与 C 控制步特定操作员确认

顺序控制系统按以下方式执行：

● 步中不带“确认”标识符的过程控制

不带此标识符的步之后，当每个满足条件的传输传递控制时，无需操

作员干预（相当于 T）。

● 带“确认”标识符的步的操作员控制

带有此标识符的活动步后的转移完成后，将设置操作员提示，确认提

示后将控制传递到下一步或下几步（相当于 T 和 C）。

执行和启动选项

选项 含义

命令输出 默认设置：开

在安装和调试过程中，或出现错误时，与某些运行模式共同配合的块

命令输出可在不影响过程的前提下将顺序控制系统带入一个已定义状

态。

如果选中该复选框，则由激活的步处理操作，否则不处理操作。

循环操作 默认设置：关

顺序完成并且选中该复选框后，SFC 或按此类型创建的 SFC 实例会

从“已完成”切换到“正在启动”。SFC 或 SFC 实例将自动首先启

动处理。

时间监视 默认设置：关

如果选中该复选框（复选标记），则对在步的对象属性中作为参数设

置的监视时间（# 0 ms）进行评估。如果超过该时间，则生成一条消

息（步错误）。
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选项 含义

自动启动 默认设置：关

如果选中了该复选框，则在 CPU 彻底重启之后，将 SFC 或由此类

型生成的 SFC 实例设置为“正在启动”模式。SFC 或 SFC 实例将

自动首先启动处理。否则，SFC 或 SFC 实例处于“空闲”操作状态

下，等待启动命令。

SFC 启动时将使用

默认工作参数

默认设置：关

如果选中此选项，则在启动 SFC 或 SFC 实例后，在“默认值”组中

设置（并可以在测试模式下更改）的所有工作参数都将重新激活。

9.15.8.9 处理图表、类型和实例

简介

可对 SFC 和 SFC 类型执行以下操作：           

● 在 SIMATIC Manager 和 SFC 编辑器中：

– 新建

– 打开以进行编辑

– 更改属性

● 仅在 SIMATIC Manager 中：

– 复制和删除

● 在 CFC 中：

– 复制和删除 SFC 实例

打开 SFC、SFC 类型和 SFC 实例

使用开始菜单中的搜索框执行“SFC - 创建顺序控制系统”(SFC - Creating sequential control 
systems) 指令时，会打开不带图表窗口的 SFC 编辑器。未打开图表。

内容 步骤

在 SFC 编辑器中打

开 SFC
在 SFC 编辑器中，选择菜单命令 SFC >“打开...”(Open...)，然后选

择所需图表。 

在 SFC 编辑器中打

开 SFC 类型

在 SFC 编辑器中，选择菜单命令 SFC >“打开...”(Open...)。要打

开 SFC 类型，必须在“打开”(Open) 对话框“对象类型”(Object 
type) 字段的下拉列表中选择条目“SFC 类型”(SFC type)。
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内容 步骤

在 SIMATIC 
Manager 中打开 
SFC 

使用菜单命令“编辑 > 打开对象”(Edit > Open Object) 在组件视图

或工厂视图中选择所需 SFC 图表。

在 SIMATIC 
Manager 中打开 
SFC 类型 

使用菜单命令“编辑”(Edit) >“打开对象”(Open Object) 在组件视图

中选择所需 SFC 类型。

打开 SFC 实例 选择 CFC 中的 SFC 实例，然后在快捷菜单中选择菜单命令“打

开”(Open)。

复制、移动和删除 SFC、SFC 类型和 SFC 实例

内容 步骤和位置

复制 
SFC

复制整个图表使您可以复制已测试的结构或子结构，甚至复制到其

它 CPU 上。不仅可以复制单个图表，还可以复制整个图表文件夹

及其包含的所有图表。 

请注意，多项目中的图表文件夹名称必须唯一。

移动 SFC 移动整个图表使您可以移动已测试的结构或子结构，甚至移动到其

它 CPU 上。不仅可以移动单个图表，还可以移动整个图表文件夹

及其包含的所有图表。 

复制

SFC 类型

可在 SIMATIC Manager（组件视图）中复制 SFC 类型。同时还会

复制属于 SFC 类型的运行时对象。如果所生成的 SFC 类型的版本

不是最新版本（FB 的时间戳早于 SFC 类型的时间戳），则显示一

条消息。如果在复制 SFC 类型时在复制目的地中已有名称相同的 
SFC 类型，则在确认提示后将覆盖现有 SFC 类型，并将与现有类

型的所有差异传送到 SFC 实例中。

移动

SFC 类型

可在 SIMATIC Manager 中移动 SFC 类型。仅当复制源中不存在 
SFC 类型的任何 SFC 实例时，才能移动 SFC 类型。同时还会移动

属于 SFC 类型的运行时对象。如果在移动目的地中已有名称相同

的 SFC 类型，则在确认提示后将覆盖现有 SFC 类型，并将与现有

类型的所有差异传送到 SFC 实例中。

复制 
SFC 实例

如果在 CFC 内复制 SFC 实例，或在同一图表文件夹的各 CFC 之
间复制 SFC 实例，或在图表文件夹内复制 CFC，则会复制 SFC 实
例。同时还会复制属于 SFC 实例的运行对象。 

在属于不同图表文件夹的 CFC 之间复制 SFC 实例时，或将 CFC 
复制到另一个图表文件夹时，也将复制 SFC 类型。
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内容 步骤和位置

移动 
SFC 实例

在 CFC 内移动 SFC 实例时，将只更改 SFC 实例的位置。 

如果在同一图表文件夹的各 CFC 之间移动 SFC 实例，则移动 SFC 
实例。将保留属于 SFC 实例的运行时对象。 

将 CFC 移动到另一个图表文件夹时，也将复制 SFC 类型。

删除图表和 
SFC 类型

只能在 SIMATIC Manager 中删除 SFC 和 SFC 类型。 

删除 SFC 的方法与删除其它对象（层级文件夹、OS 画面等）的方

法相同；即，对其进行标记并选择菜单命令“编辑 > 删除”(Edit > 
Delete)。

仅当不存在 SFC 类型的 SFC 实例时，才能删除该 SFC 类型。

如果存在该 SFC 类型的 SFC 实例，将显示一条消息，指明这一

点。 

同时还会删除属于 SFC 类型的运行时对象。

删除 
SFC 实例

可以在 SIMATIC Manager 中删除 CFC 中的 SFC 实例，或通过删

除 CFC 间接删除 SFC 实例。同时还会删除属于 SFC 实例的运行

时对象。

更多信息

● SFC 在线帮助

9.15.8.10 如何在 SFC 中组态消息

简介

可以针对每个 SFC/SFC 类型组态特定的消息文本。可以在对话框中更改该消息文

本。      

步骤

1. 在 SFC 编辑器中选择菜单命令 SFC > 消息... (SFC > Message...)。
将打开“PCS 7 消息组态”(PCS 7 Message Configuration) 对话框。

2. 使用下表来组态与块相关的消息类型和消息以在 PCS 7 OS 上显示。
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消息的设置

列 含义

Message name（消息

名称）

此列显示消息组态中与块相关的消息的名称。

消息类别 在此域中选择所需消息类别。

优先级 (Priority) 在此域中选择用于确认单个消息的优先级。数值越高，则表示优先级越高。

事件 (Event) 在此域中输入消息文本。

单个确认 (Single 
acknowledgment)

如果消息应作为单个消息确认，则选中该复选框。

信息文本 (Info text) 在此域中输入信息文本。

需要确认 (With 
acknowledgment)

如果生成的消息需要确认，则选中此复选框。此复选框是否选中，决定了“消息

类别”(Message class) 列是显示可确认的那些类别还是不能确认的那些类别。

仅适用于 SFC 类型！

该列是否显示取决于您正在编辑消息类型还是消息。通过在此列中加上复选标记，

可以互锁在此列之前的列中输入的文本。 

说明

在编辑现有消息的情况下，“来源”、“OS 区域”和“批次 ID”的条目会不统一，如果它

们是在消息组态期间编辑，还会以红色斜体字显示。要使条目统一，请覆盖显示的文本。

如果尚未创建 PCS 7 OS，则会自动创建一个显示设备并为其指定一个内部名称。

9.15.8.11 如何创建 SFC 类型

简介

SFC 类型在 SIMATIC Manager 组件视图中进行管理。    

SFC 类型不具备任何运行属性，因为它与程序的执行无关。SFC 类型不能安装在运行顺序

中。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 543



创建 SFC 类型

有两种方法可用于创建和修改 SFC 类型：

● 在库中创建/修改

此方法的优点在于 SFC 类型的主体始终位于库中，并且在采用新版本的 SFC 类型之

前，测试项目始终保持可执行状态。

● 在项目中创建/修改

此方法的优点在于可直接处理 SFC 类型的主体，因此可立即检查对 SFC 类型的每处更

改。

要求

● 已创建 PCS 7 项目。

步骤

1. 在 SIMATIC Manager 的组件视图中选中一个图表文件夹后，选择菜单命令插入 > S7 软件 
> SFC 类型 (Insert > S7 Software > SFC Type)。
下一个空闲 FB 号将自动为要创建的 SFC 类型预留，并且具有该编号的类型模板将复制到
块文件夹中。以后可在“对象属性”(Object properties) 对话框中更改此 FB 编号。
最初创建 SFC 类型时，进行编译所需的块会被复制到当前程序中，然后在 ES 中进行管理。
这些块包含在所提供的 SFC 库中。

说明

不可将 SFC 类型分配到工厂视图中的层级文件夹，因为其本身与执行无关（从要自动

化的过程的角度来说）。

2. 在 SIMATIC Manager 中选择 SFC 类型，然后选择菜单命令编辑 > 对象属性... (Edit > Object 
Properties...)。
将打开“SFC 类型属性”(SFC Type Properties) 对话框。

3. 设置 SFC 类型属性及工作参数。 
有关详细信息，请参见在线帮助和“如何调整工作参数和运行属性 (页 535)”部分。

4. 在 SIMATIC Manager 中选择 SFC 类型，然后选择菜单命令编辑 > 打开对象... (Edit > Open 
Object...)。 
将打开 SFC 类型。

5. 选择 SFC 编辑器菜单命令视图 > 特征 (View > Characteristics) 并添加控制策略、设定值
（注：请勿忘记控制策略分配）、过程值和块触点等。

6. 添加并组态顺控程序。编辑启动条件。
更多信息，请参见“如何指定顺控程序属性 (页 527)”部分。
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7. 组态 SFC 类型的消息。
最多可以组态 7 条需要确认的消息和 5 条不需要确认的消息。SFC 类型自身需要余下的可
用消息（每个消息类型 1 条消息和用于 SIMATIC BATCH 的 10 条通知消息）。 
相关信息，请参见“如何在 SFC 中组态消息 (页 542)”部分。

8. 通过菜单命令 SFC > 文本框... (SFC > Text Boxes...) 在 SFC 编辑器中组态文本框。如同 
SFC 一样，也可以为 SFC 类型组态文本框。

有关更多组态选项，可参见 SFC 在线帮助和手册《S7 的 SFC；顺序功能图》(SFC for 
S7; Sequential Function Chart)。

SFC 类型模板

在库“SFC 库” 中可找到以下用作模板的 SFC 类型，路径是“SFC 库 > 块和模板 > 模板”
(SFC Library > Blocks+Templates > Templates)：

● “TypeStates”
该 SFC 类型已经包含了几个基于状态处理顺序控制系统的顺控程序。

● “TypeCtrlStrategy”
该 SFC 类型包含基于控制策略处理顺序控制系统的顺控程序。

可复制并修改这些模板以供自己使用。

SFC 类型的接口

SFC 类型具备一个类似于 SFC 的接口。此接口在生成 SFC 类型时创建。此接口已经包

含 SFC 类型标准接口，后者派生自 SFC 类型模板。在 SFC 类型接口上需要标准接口来

提供 SFC 系统功能（运行模式、操作状态和步控模式）。

● 不可移动或删除标准接口的元素。可以修改初始值、注释及属性。

● 可通过使用接口编辑器添加 I/O 来扩展接口；可使用特征对话框添加特征。以上操作同

样适用于标准接口的这些元素。

● 块触点的特性：接口通过块类型的预定义 I/O 来扩展。这可通过“S7_contact”属性（用

于与 SFC 类型互连的预定义 I/O）来实现。

● 如果要显示的接口连接的数量多于可在三个图表分区显示的数量，某些块 I/O 可设置为

不可见。

● 在组态过程中，只有接口 I/O 可用于公式化步分配或转移和启动条件。因此，分配或条

件中的地址始终是对接口 I/O 的引用。在此，还可以进行文本互连。因此 SFC 类型具

备自持性。没有任何源自 SFC 类型的外部访问会绕过接口。
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更多信息

● SFC 在线帮助

● 手册《S7 的 SFC；顺序功能图》(SFC for S7; Sequential Function Chart)

9.15.8.12 如何创建 SFC 实例

SFC 实例

通过将 SFC 类型从 CFC 块目录拖放到 CFC 中可生成 SFC 实例。     

AS 的图表文件夹中的 SFC 类型显示在 CFC 块目录中（如果将它们分配到某一系列，则

显示在“所有块”(All blocks) 文件夹和此系列的文件夹中，否则显示在“其它块”(Other 
blocks) 文件夹中）。

SFC 实例的显示方式类似于 CFC 实例块。如果没有足够的空闲空间来放置 SFC 实例并且

它与一个或多个已放置的对象重叠，则 SFC 实例将显示为重叠块（浅灰色且不带可见的 I/
O）。在将这些重叠块移到图表中的某一空闲位置后，它们将重新显示为正常块。

在测试模式下，可为 CFC 中的 SFC 实例分配参数并将其互连。

如果已定义了块触点，则在互连此块的某 I/O 时，其它 I/O 会自动互连（用于与 SFC 类型

互连的预定义 I/O（“S7_contact”属性））。最重要的 I/O 已在 PCS 7 高级过程库的工艺

块中预定义。

步骤

1. 打开要在其中将某 SFC 实例与基本控制的块互连的 CFC。

2. 在 CFC 的“其它块”(Other blocks) 块目录中选择 SFC 类型，然后将其放入 CFC。
这样会在 CFC 中创建 SFC 类型的实例。

3. 指定 SFC 实例的属性。
在 CFC 中，可更改 SFC 实例对象属性的常规属性（名称、注释）。

4. 调整实例的工作参数和选项：
使用快捷菜单命令“打开”(Open) 在 CFC 中打开 SFC 实例，然后在“属性”(Properties) 对
话框中调整工作参数。这些参数决定 AS 中的运行方式。
更多信息，请参见“如何调整工作参数和运行属性 (页 535)”部分。
也可以选择 SFC 实例将使用由 SFC 类型指定的控制策略。

5. 组态并互连 SFC 实例的接口：
在 CFC 中使用对象属性或在 SFC 中使用“I/O”接口编辑器为 SFC 实例的 I/O 分配参数。 
在 CFC 中，将 SFC 实例的 I/O 与 CFC 块的 I/O 或与共享地址互连，或创建文本互连。
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更多信息

● SFC 在线帮助

9.15.8.13 如何集中更改 SFC 类型

简介

SFC 类型也可以保留在主数据库中。要能够使用 SFC 类型，需要将 SFC 类型从主数据库

的图表文件夹复制到 AS 的 S7 程序的图表文件夹中。然后 SFC 类型将显示在“块”(Blocks) 
选项卡（其它块）的 CFC 目录中，并可从此处将其放入 CFC 中。相关信息，可参考“如

何创建 SFC 实例 (页 546)”部分。 

要运行 SFC 实例，请将 SFC 类型和 SFC 实例都下载到自动化系统上。

组态更改规则

● 一般而言，对 SFC 类型（此类型禁止或限制在 RUN 模式下下载更改）所做的更改只能

经操作员确认后执行。

● 对 SFC 类型接口的修改将立即传送到相应的 SFC 实例。这意味着如果禁用或在下载过

程中暂时禁用该 SFC 类型的所有 SFC 实例，则只能在 AS RUN 模式下下载该 SFC 类
型及其实例。

操作员确认后，下载期间将禁用实例，下载完成后，再经操作员确认，然后重新启动实

例。实例的执行情况取决于过程状态和实例组态（尤其是启动条件）。 

● 在下载更改期间，系统会禁止在 AS 中处理 SFC 实例并禁止在 CFC 中通过互连访问 
SFC 实例。

● 对拓扑（步/转移顺序、更改的跳转目标）或步/转移组态的更改仅在编译和下载后才应

用到 SFC 类型并在 SFC 实例中生效。

下载期间对拓扑进行更改后，可随时下载非活动顺控程序，而在下载活动顺控程序前必

须禁用 SFC 实例。

● 可随时下载对步和转移组态的更改，即使当前正在 AS 中处理 SFC 类型的 SFC 实例。

● 更改组态后，需要编译 OS 以确保当前数据在 OS 中可用。

步骤

1. 打开图表文件夹中的 SFC 类型。
在 SFC 编辑器中打开 SFC 类型。

2. 在 SFC 编辑器中进行所需的更改。
更改将应用于 SFC 类型和每个现有的 SFC 实例。
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3. 编译、下载并测试程序。

4. 将 SFC 类型复制到主数据库中，以便修改后的版本在 CFC 块目录中可用。

5. 如果所做的修改与分配参数或互连有关，则必须在所有 SFC 实例中进行这些修改。
要执行此操作，请打开相关 CFC 并完成相应更改。

更多信息

● “如何下载 SFC (页 551)”部分

● 手册《过程控制系统 PCS 7，入门指南 - 第 2 部分》(Process Control System PCS 7, 
Getting Started - Part 2)

9.15.8.14 如何编译图表和类型

编译    

编译期间（范围：整个程序），当前图表文件夹的所有图表（包括 SFC 类型）都会逐块传

送到 SCL 编译器，然后再进行编译。在更改 SFC（SFC 类型、SFC 实例）后，只需编译

更改部分（范围：更改内容）。

在编译过程中将自动检查一致性。也可以手动启动该检查。

编译后，将用户程序下载到 CPU，进行测试，然后将其投入运行。

编译设置

使用菜单命令选项 > 自定义 > 编译/下载... (Options > Customize > Compile/Download...) 
打开一个对话框，其中包含有关编译图表时使用的资源的信息。可指定以下内容：

● 要使用的警告限制，以便在下载前检测到潜在的危险。

● 在编译当前图表文件夹的图表期间一直未使用的资源。

这在某些情况下可能非常用。例如，希望同时使用图表和编程（例如， STL、LAD 或 
SCL 程序）完成一个自动化任务，而且在用户程序中还存在来自其它源的函数 (FC) 或
数据块 (DB) 时。

● 此外，您还可以查看统计信息，该信息会显示 CPU 中还有多少资源（DB、FC）可供

编译图表使用，以及已使用了多少资源。

说明

如果在程序中只处理 CFC 和 SFC，则可以使标准编译设置保持不变。

有关在编译期间生成的块的概述，可参见在线帮助。
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一致性检查

在进行实际编译前，系统会自动进行以下一致性检查：

● 用户程序中的块类型与导入 CFC 中的类型是否匹配。

● 是否在符号表中输入了对共享地址的符号引用。

● 在用户程序中是否实际存在具有互连关系的数据块 (DB)。

● 是否提供“ANY”、“STRING”、“DATE_AND_TIME”或“POINTER”类型的输入/输出

参数或块输出（已互连）。

● 所有被 SFC 条件或语句访问的块是否仍然存在。

说明

也可以在不编译的情况下检查一致性。为此，选择菜单命令 SFC > 检查一致性 (SFC > 
Check Consistency)。

步骤 

1. 选择菜单命令 SFC > 编译... (SFC > Compile...) 
将出现“编译程序”(Compile program) 对话框。

2. 在“范围”(Scope) 组中选择以下选项之一以指定编译范围：

– 整个程序 (Entire program)：编译所有图表。

– 更改：仅编译自上次编译后被更改的对象。

3. 必要时，选中“生成 SCL 源文件”(Generate SCL source) 复选框。

4. 单击“确定”(OK)。 
编译过程将开始。

结果

先检查当前程序（图表文件夹）中图表的一致性，然后进行编译。

保存设置而不进行编译

可以使用“编译程序”(Compile Program) 对话框中的“应用”(Apply) 按钮保存设置而不启

动编译过程。

显示日志

编译后将自动显示一致性检查的结果及编译期间出现的所有消息。 

也可在以后通过菜单命令选项 > 日志... (Options > Logs...) 显示日志并将其打印出来。
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更多信息

● SFC 在线帮助

9.15.8.15 如何在下载前比较 SFC

简介

组态、测试及调试期间，在下载新的/更改后的 SFC 之前，通常需要将其与先前加载的版

本进行比较。   

要求

在 SFC 编辑器中使用菜单命令“选项 > 设置 > 编译/下载”(Options > Settings > Compile/
Download) 进行初始下载之前，激活“编译/下载设置”(Settings for Compiling/Laden) 对话

框中的“生成用于比较的已下载程序的映像”(Generate image of downloaded program for 
comparison) 复选框。

步骤

1. 在 SFC 编辑器中选择菜单命令 PLC > 下载... (PLC > Download...)。

2. 单击“显示更改”(Show Changes) 按钮。
将打开 Version Cross Manager，用先前下载所创建的映像（请参见“要求”部分）与要下
载的版本进行比较，并显示相应结果。

说明

只有安装了“版本交叉管理器”附加包并已生成加载程序的映像，才会启用“显示更

改”(Show Changes) 按钮。

3. 返回到“下载”(Download) 对话框。

4. 单击“确定”(OK) 或“取消”(Cancel)。

更多信息

● SFC 在线帮助
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9.15.8.16 如何将 SFC 下载到 CPU

下载

必须先编译图形图表并将其下载到 CPU 上才能使其在 CPU 上生效。将图表下载到为其分

配了包含当前图表文件夹的用户程序的 CPU。

要求 

● CPU 与您的编程设备/PC 之间必须存在连接。

● 设置编辑模式（而非测试模式）。

● 如果下载整个程序，CPU 必须处于 STOP 模式。

如果只下载更改，CPU 可处于 RUN-P 模式。

步骤

1. 在 SFC 编辑器中，选择菜单命令“CPU > 下载...”(CPU > Download...)。
将打开“下载到 CPU”(Download to CPU) 对话框。

2. 在“下载模式”(Download mode) 组中选择以下选项之一以指定编译范围：

– 整个程序 (Entire program)
将下载“块”(Blocks) 文件夹的全部内容。

– 更改 (Changes)
CPU 可处在“RUN-P”模式下。仅下载自上次编译后所做的更改。

– “下载到测试 CPU”(Download to test CPU)
使用此下载类型，可以将修改后的程序下载到另一个 CPU 或 S7 PLCSIM 上，而不

会丧失原始 CPU 中的增量下载功能。

3. 单击“确定”(OK)。
编译过程将开始。

说明

对于在 SFC 中创建的程序，必须将其从 SFC（或 CFC）下载到 CPU 上，因为只有该

下载功能可保证组态数据与 CPU 数据之间的一致性。

在 SIMATIC Manager 中，使用下列菜单命令可实现相同的下载功能： 
● 菜单命令“CPU > 编译和下载对象...”(CPU > Compile and Download Objects...)，然后激

活要进行编译和下载的“图表”(Charts) 对象

● 在组件视图中：标记“图表”(Charts) 文件夹，然后选择菜单命令“CPU > 下载”(CPU > 
Download)
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结果

程序（或仅更改部分）被下载到 CPU。

说明

如果已在组态中进行了与下载有关的更改，并且在更改后未进行编译，则在下载前系统将

提示您进行编译。在进行无错误编译后，将自动执行下载。

完整下载

如果选择“下载：整个程序”(Download: the entire program)，在此下载模式下会将当前图

表文件夹中的所有图表都下载到 CPU。确认提示后，CPU 被设置为 STOP 模式，并且删

除 CPU 中的所有块。

说明

编译整个程序并不一定意味着一个完整的下载。如果在编译前程序已经在 CPU 中加载，

则可能仅下载更改。 
如果完全下载被中止，则只有在完成完全下载后，才能下载更改。原因：CPU 上的块在下

载前已被删除。

下载更改

如果选择在“RUN-P”CPU 模式下选择“下载: 仅更改”(Download: changes only)，则可以

将对组态的更改下载到 AS，而无需将 CPU 切换到 STOP 模式。使用这种下载类型，只需

下载上次下载后进行了更改的内容。请遵照以下原则：

● 如果已在 SFC 中更改了图表拓扑（添加、删除、复制、移动了步或转移，或更改了跳

转目标……），则下载更改时必须禁用这些图表。

● SFC 类型的接口更改会立即传送到 SFC 实例中。因此，下载期间必须禁用 SFC 实例

并停止在 CPU 上的执行。

● 如果已修改 SFC（图表属性、对象属性为步/转移）而未更改其结构，则在 CPU 处于 
RUN 模式时，可在编译图表后将其下载，而无需禁用修改的 SFC。
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● 如果未更改图表本身，只是更改了访问的对象（例如，符号表中的符号、运行组、块 I/
O），则在下载图表前无需将其禁用。

● 下载更改后，不会自动启动属性为“自动启动：开”(Autostart: on) 的已停止 SFC 图表，

而必须由操作员重新启动。

说明

请注意，在下载更改时，不能完全保证 CPU 不会切换到 STOP 模式。

参见

如何将各个已更改图表加载到 CPU 中 (页 487)

9.15.8.17 如何测试 SFC

测试模式

SFC 编辑器所提供的测试功能支持调试过程。这些功能用于监视 AS 顺序控制系统，以及

在必要时改变该系统并更改设定值。为此，可将 SFC 编辑器切换到测试模式。

测试模式的运行模式

测试模式是指包含激活的图表的 CPU。可以选择在两种运行模式下进行测试：

运行模式 描述

过程模式 在过程模式下，SFC 和 SFC 实例在线动态显示的通信会受到限制，

这样只会略微增加 CP 和总线上的额外负载。

如果过程模式中出现过载现象，将显示消息提示已达到总线负载限

制。在这种情况下，应停止并非绝对需要进行测试的 SFC 的测试模

式。

激活测试模式后，所有块的状态均为“关闭监视”。

实验室模式 实验室模式下的测试和调试更为方便和高效。和过程模式不同，在实

验室模式下用于 SFC 的在线动态显示的通信是不受限的。

激活测试模式后，所有块的状态均为“打开监视”。
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要求

● CPU 与您的编程设备/PC 之间必须存在连接。

● 程序已下载。

激活/取消激活测试模式

1. 使用“测试”(Test) 菜单中的菜单命令，选择所需运行模式：

– “测试 > 过程模式”(Test > Process Mode)
– “测试 > 实验室模式”(Test > Laboratory Mode)
请注意，在测试模式下不可切换所使用的测试类型。 

2. 选择 SFC 菜单命令“测试 > 测试模式”(Test > Test Mode)。
测试模式被激活。

3. 再次选择 CFC 菜单命令“测试 > 测试模式”(Test > Test Mode) 关闭测试模式。

测试

一旦启动了测试模式，便可测试 SFC 的功能。 

SFC 可在“手动”模式下启动。也可以改变用于执行 SFC 的工作参数（例如循环操

作）。 

如果 SFC 处于“RUN”运行模式，则显示以下信息： 

● 当前处于活动状态的步

● 在此步中执行的操作

● 处于活动状态的转移和针对此转移所必须满足的条件

说明

在测试模式下进行的任何操作员输入或分配的任何参数随后都将同时在 CPU 中和 SFC 
的数据中执行。 
如果将 S7 CPU 关闭后又打开，但没有备用电池，则 CPU 中的这些参数更改会丢失。

在这些情况下要恢复这些参数设置，必须重新编译图表文件夹，并将其再次从 PC/编程

设备下载到 CPU。

更多信息

● SFC 在线帮助

● 手册《过程控制系统 PCS 7，入门指南 - 第 1 部分》(Process Control System PCS 7, 
Getting Started - Part 1)

● 手册《S7 的 SFC；顺序功能图》(SFC for S7; Sequential Function Chart)
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9.15.9 创建模型（多项目）

9.15.9.1 如何创建和编辑模型

简介    

通常是通过将工厂划分成更小的可分类功能单元（例如，固定设定值控制或电机控制器）

来使其结构化。

可以在工程组态系统中创建一批称为模型的预制功能单元，而不用每次都对这些功能单元

进行规划。然后，只需根据新解决方案的要求复制和修改这些模型即可。

为确保在整个项目中仅使用一个模型版本，应将所有模型集中存储在主数据库中，而且应

在生成副本之前进行所有修改。

模型

说明

只能在多项目中创建或修改模型。

模型由包含以下元素的层级文件夹组成：

● CFC/SFC

● OS 画面

● OS 报表

● 附加文档

模型还包含与导入/导出文件（IEA 文件）的链接。 

使用导入/导出助手 (IEA)，可将块/图表 I/O 以及块消息链接到导入文件的列。 

副本

在以此种方式准备好模型并将其链接到导入文件后，可使用导入/导出助手将其导入。将会

为所生成的副本分配模型的参数、互连和消息。导入文件中的每一行均会在目标项目中创

建一个副本。

要求

已在自动化系统和操作员站上对要从中创建模型的功能单元进行了测试。
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创建模型

1. 选择包含主数据库中模型所需 CFC（或 CFC、SFC 等）的层级文件夹（或包含具有 CFC 
的嵌套层级文件夹的层级文件夹）。

2. 使用菜单命令选项 > 模型 > 创建/修改模型... (Options > Models > Create/Modify Model...) 
动向导，然后在接下来的几步中选择以下内容：

– 要将哪些 I/O 作为参数或信号导入？(Which I/Os do you want to import as parameters 
or signals?)

– 要为哪些块导入消息文本？(For which blocks do you want to import message texts?)
– 要将哪些导入数据分配给特定模型数据？(Which import data do you want to assign 

to specific model data?)

在“要将哪些导入数据分配到特定模型？”(Which import data do you want to assign to 
specific models?) 步骤中，“导入文件”(Import File) 文本框中最初输入的文本是“未分配

导入文件”(No import file assigned)。通过单击“其它文件...”(Other File...)，可以浏览并输

入导入文件。 

创建导入文件

倘若导入文件尚不存在或是没有合适的导入文件，可使用“创建模板文件...”(Create 
Template File...) 按钮从先前选择的模型数据创建导入文件。 

为此可以采用两种过程方法：

● 创建导入文件，同时编辑所需列标题。

– 在“导入文件”(Import file) 列表中，选择条目“未分配导入文件”(No import file 
assigned)。
在“模型数据”(Model Data) 列表的“列标题”(Column Title) 列中，编辑模式当前被

激活。

– 编辑所需列标题。

– 按第二个过程中所述继续操作。

● 由于暂且不想将文本最终定下来，因此可使用“虚设”(artificial) 列标题生成导入文件：

– 单击“创建文件模板...”(Create file template...)，然后指定文件名。

– 在下一个对话框中选择可选的列类型或取消选择不需要的列（例如 LID、FID）。

在文件结构中，将会判定 I/O 标记的属性，如果存在诸如文本 0、文本 1、单元、值和标识

符之类的条目，会自动为其输入值；互连、图表名称和层级也是自动输入的。此后，仅须

修改层级和图表名称。

如果选择第二种方法，可使用“打开文件”(Open File) 按钮打开已分配的文件，通过 IEA 
文件编辑器对其进行编辑。可在其中执行如下操作：

● 更改列标题

● 删除各个不需要的列
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● 添加行

● 编辑描述信息

保存文件后，导入/导出助手会显示随后必须分配的新列标题。 

完成模型

1. 将导入数据分配到模型数据后，单击“完成”(Finish)。

结果

此时便得到了一个模型，其中将所选的每个 I/O 和每个消息均分配到导入文件的某一列；

因此，导入文件的各列均已使用（1:1 分配）。

处理消息时，以下情况适用：并非所有模型数据行都必须从导入文件提供数据。因此，导

入文件中的消息数可能少于模型中的消息数（这种情况下，1:1 分配不适用）。

在 SIMATIC Manager 中，层级文件夹显示为模型。

修改模型

可随时修改没有副本的模型。 

1. 选择菜单命令选项 > 模型 > 创建/修改模型... (Options > Models > Create/Modify Model...)。

如果对已有副本的模型进行更改，则会显示一条消息，因为导入数据不再与模型数据相匹

配。

如果对已有副本的模型的 I/O 点（IEA 标记）进行修改，则会显示一条消息，并且对话框

会扩大以显示另外的步骤。已进行的所有修改均会记录在这个附加的对话框中。然后，将

对所有副本进行以下修改：

● 如果副本中缺少 IEA 标记，则会设置这些标记。

● 如果副本中设置的 IEA 标记多于模型中的标记，则会从副本中删除多余的标记。

说明

不可以再修改现有模型或模型副本中的块名称。否则，将不能再进行导入/导出。

使用 IEA，可向块 I/O 和图表 I/O 分配参数，然后将它们互连；也可重命名图表 I/O。

说明

请记住，可能还需要修改 IEA 文件。

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 557



更多信息

● “如何在 SIMATIC Manager 中处理模型 (页 560)”部分

● PH、IEA 和 PO 的在线帮助

9.15.9.2 文本互连和模型

简介

使用文本互连，可为导入互连块的输入和输出或嵌套图表。这可在某个图表内进行，也可

在各个图表之间进行。     

要求

● 互连伙伴在同一图表文件夹中。

语法

互连语法如下：

cfc\baustein.anschluss 

或 

cfc\chart.io

或 

sfc.I/O

如果名称中包含 PH 的文件夹，则名称前面可能还会有工厂层级的路径 (ph\ph\cfc
\chart.block)，但此路径将被忽略。

文本互连

只有定义为参数的 I/O 才能使用文本互连。

如果将输出和导入定义为参数，则文本互连既可始于输出，亦可始于导入。多互连只能在 
CFC 的输出上使用。在输入上只能使用单互连。 

创建 IEA 文件时，必须在“创建文件模板”(Create File Template) 对话框的“参数”
(Parameters) 选项卡上激活文本互连复选框。
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多个互连

多互连是从一个输出引到多个输入的互连。

● 在导入文件中，可为参数和信号输出输入多互连。I/O 名称在列中以引号 (") 分隔。

● 如果要保留现有的单互连并添加新的互连，请在互连文本之后输入分隔符 "（引号）。

若无此分隔符，旧互连便会被新互连替换。

● 如果已存在多互连，则除现有连接外，将始终在导入期间创建互连。无论是否存在分隔

符，都会执行该操作。

● 关键字“---”会删除输出上的所有互连。

在导出期间，也是用 " 分隔符来指示现有的多互连。

规则

在模型中使用文本互连时适用以下规则：

● 创建模型/过程变量时，“创建模板文件”(Create Template File) 功能会根据模型中的互

连为“TextRef”列中的文本互连输入互连伙伴。这会导致模型中的互连，从而会在导入

过程中更改模型。

因此，必须更正该列。为防止对模型的意外更改，在导入期间会引起错误的“TextRef”
列中，互连伙伴的前面会带有一个问号（“?”）。

● 作为更正过程的一部分，可通过 IEA 文件编辑器搜索“?”，然后相应地修改这些单元

格。 
只要可能，文本互连应当仅源于输入。因此，即使在选择对话框中激活了“文本互连”
(Textual Interconnection) 选项，生成文件模板时也不会为输出创建“TextRef”列。如果

需要，必须使用 IEA 编辑器的“扩展列组”(Expand Column Group) 功能另外进行创建。

● 在参数 I/O 点建立文本互连，在信号 I/O 点建立到共享地址的互连。

9.15.9.3 如何创建模型副本

简介

可使用模型助手导入模型数据。     

从主数据库中将模型作为副本复制到指定的目标项目。然后，导入数据。根据导入文件中

的条目，可创建任意数量的副本。 

导入时，可决定是否要在符号表中输入导入的信号（选项：“也在符号表中输入信号”(Also 
enter signals in the symbol table)）。对于 PCS 7，建议不要使用该选项，因为这些条目

是在使用 HW Config 配置硬件时完成的。
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要求

相应的导入文件可用。

读者注意事项

有关导入文件创建的详细描述，可参考“导入/导出过程变量/模型”部分。以下是已经分配

了导入文件时所使用的基本步骤的描述。

步骤

1. 在主数据库中选择所需的模型。

2. 选择菜单命令“选项 > 模型 > 导入...”(Options > Models > Import...)
向导会搜索单一控制单元类型及相应的导入文件（也会在所有层级子文件夹中搜索），并将
其列出。将对列出的所有导入文件执行导入操作。

3. 如果不想导入某些文件，可选择这些文件，然后使用“删除”(Remove) 按钮从列表中将其删除。
单击“其它文件”(Other File)，可以搜索不同的导入文件，然后选择该文件来代替其他文件。

4. 单击“继续”(Continue)，然后单击“完成”(Finish)。
开始执行实际的导入过程。

结果

根据“在日志中仅显示错误和警告”(Only show errors and warnings in log) 复选框的设置，

在日志窗口中会显示活动及其各个步骤的完整列表或仅显示发生的错误。

日志保存在日志文件中。文件的名称和路径会出现在日志窗口的下面。可以使用“其它文

件”(Other File) 按钮修改此设置。

更多信息

● “如何导入过程变量类型和模型 (页 633)”部分

● PH、IEA 和 PO 的在线帮助

9.15.9.4 如何在 SIMATIC Manager 中处理模型

复制模型           

说明

在多项目中，一个模型仅能存在一次，并且必须位于主数据库中。
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在 SIMATIC Manager 中复制模型时适用以下规则：

● 在同一多项目内或从一个多项目向另一多项目中复制模型时，将会为此拷贝创建内容相

同的副本。

● 将模型从主数据库复制到某个项目中时，会创建一个副本。

● 将模型从主数据库复制到另一不同的主数据库中时（不同的多项目），该模型仍为模

型。

● 将模型从主数据库复制到另一不同的库中时，该模型仍为模型。

这样可创建该模型的备份。导入期间将忽略备份。

复制模型的副本

在 SIMATIC Manager 中在同一多项目内复制模型的副本是，也会将这个新的层级文件夹

分配给原始模型。与使用 IEA 生成的其它所有副本类似，该副本不会被分配给导入文件。

该副本的响应方式与使用 IEA 通过导入生成的副本相同。

将副本复制到另一个多项目时，只有当主数据库中不存在相应模型的副本时，才会分配该

副本。将副本复制回其原始项目时（例如，当对项目数据进行分支和合并时），该副本会

再次收到对它的分配。

删除模型

如果不再想使模型可用于导入/导出，或者要使模型再次成为常规的层级文件夹，请按以下

步骤操作：

1. 选择该层级文件夹

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。

3. 打开“模型”(Models) 选项卡。

4. 单击“清除”(Clear)。

将删除已保存的对该导入文件的分配。这也意味着模型的所有现有副本都会转换为常规层

级文件夹。

删除副本

可采用与删除模型同样的方式删除模型副本。按以下步骤进行操作，将副本改回为“常规”

层级文件夹。

1. 选择其中一个副本。

2. 选择菜单命令“编辑 > 对象属性...”(Edit > Object Properties...)。
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3. 打开“模型”(Models) 选项卡。

4. 选择该副本，然后单击“清除”(Clear)。

删除具有副本的模型

所删除的模型已存在副本时，所有副本都将保持不变，但它们会失去了其对该模型的分配。

随后以相同类型的模型替换已删除的模型时（例如，通过分支和合并项目），将会重新建

立副本的分配。

如果不想使其保持为副本，而是想将它们重新转换为常规层级文件夹，则可按上述方式

（“删除副本”部分）操作。

9.15.9.5 如何在以后将副本分配给模型

用例

如果副本的结构与模型的结构完全一致，可以使用 IEA 将副本或含有不属于该模型的 CFC 
的常规层级文件夹转换成现有模型的副本。 

可以设想以下应用：

● 在将副本导入到项目中后，对其进行了本地修改。由于处理出错（例如，在分布式工程

中，在分支和合并后忘记了模型），副本存在，但对应的模型却丢了。

● 在创建了多个图表并对其进行了本地修改后，想要在项目中继续使用 IEA。而且，想要

将含有这些图表的层级文件夹作为副本分配给模型。

下面将对上述情况的操作过程进行说明。

步骤

如果副本不再有对应的模型，可按以下方式为其创建合适的模型：

1. 选择副本。

2. 选择菜单命令“选项 > 模型 > 创建/修改模型...”(Options > Models > Create/Modify 
Model...)。

3. 在随后出现的对话框步骤中选择先前的导入文件，并将该导入数据分配给模型数据。
更多相关信息，可参考“如何创建模型 (页 555)”部分。

4. 使用“选项 > 模型 > 导出...”(Options > Models > Export...) 菜单命令启动导出。
您会收到一个包含所有现有副本当前数据的 IEA 文件。
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9.15.10 编辑大量数据

简介

在过程对象视图 (页 239)中，项目范围内的所有基本自动化数据均可在基于过程控制的视

图中进行显示和编辑。项目范围内是指在一个多项目中包含来自所有项目的数据。     

使用过程对象视图

可在树形视图中创建、复制、移动和删除对象。也可在其中编辑批生产和连续式设备的层

级文件夹的属性。 

对象的所有基本方面都可直接在表（内容窗口）中记录和编辑，而无需访问用于编辑对象

的组态工具。

并非所有的属性都可直接编辑。不可编辑的信息会灰显。不过，访问必要的组态工具还有

些快捷键。

过程对象视图中的快捷键

如果对象的各个方面（过程变量、CFC、SFC 和画面）不能在过程对象视图中编辑，可使

用支持的组态工具来进行编辑。 

过程对象视图中有选定对象的快捷键，使用菜单命令编辑 > 打开对象 (Edit > Open Object) 
可对其进行调用。此方法对任何选定选项卡都有效。

下表提供了“常规”(General) 选项卡中该方面的示例：

对象 建立... 打开...

画面 在过程变量、CFC、或 SFC 之间的连接以

及它们的画面的互连。

由当前所选单元/行定义的画面（在 WinCC 图
形编辑器中）。

归档 在过程变量、CFC、或 SFC 之间的连接以

及它们的归档变量。

由当前所选单元/行定义的归档（在 WinCC 变
量记录中）。

图表 与 CFC/SFC 的连接。 由当前所选单元/行定义的相关图表（在 CFC/
SFC 编辑器中）。

模块 过程变量或 CFC 和相应的模块之间的连

接。

模块的对象属性（在 HW Config 中）。

消息 与块消息的连接。 由当前所选单元/行定义的块消息（在组态消息

的对话框中）。

符号表 与符号表的连接。 由当前所选单元/行定义的 S7 程序的符号表。
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概述

在过程对象视图中编辑大量数据涉及以下主题：

● 如何编辑常规数据 (页 567) 

● 如何编辑块 (页 571) 

● 如何编辑参数 (页 573) 

● 如何编辑信号 (页 577) 

● 如何编辑消息 (页 581) 

● 如何编辑画面对象 (页 584) 

● 如何编辑归档变量 (页 585) 

● 如何编辑层级文件夹 (页 588) 

● 如何编辑设备属性 (页 590) 

● 如何编辑共享声明 (页 591) 

● 如何在过程对象视图中测试 (页 592) 

更多信息

“组态逻辑运算 (页 483)”部分

9.15.10.1 在过程对象视图中工作

过滤

在过程对象视图中，可使用过滤器来限制所选显示对象的数量。默认设置为：<无过滤器

>。

在“按列过滤：”(Filter by column:) 组合框中，选择要在其中使用过滤器文本（“显示：”
(Display:) 文本框）来确定在表格中显示的对象的列。 
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示例： 

● 要在表中显示所有 CFC。

在“按列过滤：”(Filter by column:) 中选择类型并在“显示：”(Display:) 文本框中输入

“cf”。

将显示所有以字母“cf”开头的对象类型（例如，所有 CFC）。

● 要在表中显示某一范围内的所有对象。

在“按列过滤:”(Filter by column:) 中选择路径并在“显示：”(Display:) 文本框中输

入“*Boiler”。

将显示其路径中包含字符串“Boiler”的所有对象。

特殊过滤条目适用于“仿真输出”(Simulate outputs) 列。

说明

在“常规”(General) 选项卡中进行的过滤器设置适用于其它所有选项卡。这些选项卡上的

过滤器设置指定所做的选择。

排序

对过程对象视图中显示的数据可以按字母数字以升序和降序进行排序。为此，单击要对其

数据进行排序的列标题。小箭头将指示数据是按升序顺序还是降序顺序进行排序。

设置列宽

可在表中直接设置列宽（方法与在 Excel 中一样）。关闭过程对象视图或 SIMATIC 
Manager，然后将其重新打开时，这些设置会保留。 

拆分表格

可以将窗口拆分成两部分（左和右），这样，每一部分都有单独的滚动条。您可能在其它

应用程序中用过此功能，例如 Excel。

显示/隐藏列

使用菜单命令“选项 > 设置...”(Options > Settings...)，可在“列”(Columns) 选项卡上隐藏

列、显示先前隐藏的列以及改变列的顺序。
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定义自己的列

还可以使用菜单命令“查看 > 定义列...”(View > Define Columns...) 添加或移除自己的列。

可以在这些列中输入项目特定的数据，例如，有关维护间隔的具体信息。此信息保存在相

应的过程对象中，且与该对象一起被复制。

说明

在项目中，在“块”(Blocks) 选项卡上，可以将“OS 相关”(OS-relevant) 属性分配给新定义

的列，也可以使用相应的快捷菜单命令删除已经分配的属性。 

导入和导出

使用导入和导出功能，还可与其它工具交换此数据。

更多相关信息，请参见“有关工厂工程组态的数据交换 (页 621)”部分。

复制、移动和删除的限制 

在过程对象视图中，可以复制、移动和删除对象，其方法与在工厂视图中完全相同。但具

有以下限制：

● 只能在“常规”(General) 选项卡上执行从内容窗口（右侧窗口）向树形视图（左侧窗

口）或其它视图的复制和移动操作。

● 不能执行从树形视图或另一个视图到内容窗口的复制和移动操作。

● 只能在树形视图中或内容窗口的“常规”(General) 选项卡上删除对象。

单个块的执行步骤

可以为单个块选择和复制表格中的信息，然后将其粘贴到另一个位置。该功能不仅限于表

内而且还可应用于表和 Office 应用程序之间，例如，Excel 和 Access 等。 

这样就可以轻松快捷地将数据从指定列表复制到 PCS 7。如果在此过程中出现错误，则可

使用“撤消”(Undo) 功能（通过表格中的快捷菜单）对其进行更正。

查找和替换

可以在过程对象视图的选项卡上（通过表格中的快捷菜单）查找和替换文本。
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“查找”操作从所选单元格或光标所在单元格开始执行。视选定的搜索范围而定，按以下

方式对表格进行搜索：

● 整个表

● 从左到右逐行搜索

● 从上到下逐列搜索

“查找”操作循环执行：到达行或列的末尾后，将从头开始重新搜索，直到到达起始单元

格为止。 

找到第一个文本后，搜索即会停止。单击“查找”(Find) 时，将不替换文本而继续搜索。单

击“替换”(Replace) 时，只会替换此单元格中的文本。单击“全部替换”(Replace all) 时，

将继续搜索并替换找到的所有文本。 

说明

请注意以下几点：

● 无需输入要搜索的完整文本；只要保证能够唯一标识要搜索的文本，输入部分文本就足够
了。

● 单击“替换”(Replace)/“全部替换”(Replace all)，而没有在“替换为：”(Replace by:) 编辑框
中输入文本时，找到的文本将被删除。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.10.2 如何编辑常规数据

“常规”选项卡

在此选项卡中，对于在层级窗口中选择的工厂对应的所有基本的 ES 对象（PH 的对象），

都将与它们的常规信息一起显示。如所选内容改变了，则将重新读入相关对象。     

表中的列

如在层级窗口中选定了多项目图标，只有与此多项目的对象有关的列才会显示。 

说明

如果该块是故障安全程序的组件，在该行的开始处具有行号的域将显示黄色背景。
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列 含义

层级 (Hierarchy) 显示对象的工艺路径（或项目/库的储存位置）

名称 (Name of) 显示对象的图标和对象名称。可以更改对象名称。

注释 (Comment) 对象注释的输入字段。该注释可以更改。 

注：注释字段不接受空值。 

类型 (Type) 显示对象类型，例如，过程变量、CFC、SFC、OS 画面、OS 报表

或附加文档。

过程变量类型 显示派生出此过程变量的过程变量类型的名称。

FID 功能标识符的输入字段。如果在其中修改文本，则文本将输入到“描

述：”(Description:) 文本框“第 3 部分”(Part 3) 选项卡的 CFC/SFC 
中。

LID 位置标识符的输入字段。如果在其中修改文本，则文本将输入到“根

据位置的代码字段：”(Code field according to location:) 文本框“第 
3 部分”(Part 3) 选项卡的 CFC/SFC 中。

状态 (Status) 此列只能在在线视图中显示。如果在“监视”(Watch) 列上选中了该复

选框，则状态消息将在此显示。状态显示所显示的文本和颜色与 CFC 
中的相同。 

监视 (Monitoring) 此列只能在在线视图中显示。在此可为测试模式注册或取消注册过程

变量或图表。如果启用了监视功能，则会动态显示“已激活”
(Activated)、“仿真输入”(Simulate inputs) 和“仿真输出”(Simulate 
outputs) 列。然后以黄色背景显示这些列。

采样时间 
(Sampling time)

针对已为其创建了同名运行组的图表显示当前执行周期。可以更改执

行周期。 

下拉列表显示通过指定 OB 循环以及所有运行组缩小比率确定的周

期。

选中 (Selected) 用此选项可激活或禁用处于运行序列的图表。该复选框可设为离线和

在线状态。

仿真输入 
(Simulate inputs)

通过使用该选项，经过处理的传感器输入信号会转换为通道块的仿真

值。 

该复选框可设为离线和在线状态。例外：如果所有的 SIM_ON I/O 均
已互连，则会禁用该复选框。如果只互连了部分 SIM_ON I/O，则会

启用该复选框，但是设置仅应用于未互连的 SIM_ON I/O。
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列 含义

仿真输出 
(Simulate outputs)

使用此选项，自动系统中执行器的信号输出将从计算值变为通道块的

仿真值。 

该复选框可设为离线和在线状态。例外：如果所有的 SIM_ON I/O 均
已互连，则会禁用该复选框。如果只互连了部分 SIM_ON I/O，则会

启用该复选框，但是设置仅应用于未互连的 SIM_ON I/O。

AS 显示包含过程变量或者 CFC 或 SFC 的 S7 程序的组件路径。

单击此框会显示一个下拉列表。如果项目包含几个 S7 程序，它们将

显示在此下拉列表中。通过选择不同的 S7 程序，可以移动关联的图

表。 

OS 显示包含 OS 画面或 OS 报表的 OS 的组件路径。

单击此框会显示一个下拉列表。如果项目包含几个操作站，它们将显

示在此下拉列表中。通过选择不同的 OS，可以移动关联的对象。 

块图标 (Block 
icons)

在此列中，显示将在 PH 中或编译 OS 时自动为其生成块图标的画

面。可为每个收集的画面设置或重置属性“从工厂层级获得块图标”
(Derive block icons from the plant hierarchy)，而不必打开每个画面

的对象属性。

OCM 可行 (OCM 
possible)

使用此列确定是否应将 AS-OS 工程组态的 SFC 传送到 OS 进行显

示。 

作者 (Author) 作者名称的输入字段。如果在创建共享声明时激活了 SIMATIC Logon 
Service，则在此处输入当时登录的用户。

可以更改图表及附加文档的名称。

版本 (Version) 显示可于此处更改的 CFC 和 SFC 的版本号。 

大小 (Size) 在可行情况下以字节显示对象的大小。

上次修改日期 
(Last modified)

显示上次修改对象的日期。

更多信息

● PH、IEA 和 PO 的在线帮助
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9.15.10.3 如何编辑图表

“图表”(Charts) 选项卡

多项目中包含的所有图表，包括没有 PH 分配的图表和超出项目边界的图表在内，都显示

在此选项卡中。除 CFC 图表外，该列表还包含 SFC 图表和 SFC 类型。表格中不会显示 
SFC 类型的 PH 分配。当选择多项目、项目或 PH 文件夹时，可以选择此选项卡。

表中的列

列 含义

子项目 
(Subproject)

此列显示了到子项目的分配。

AS 层级 (AS 
hierarchy)

此列显示了到 AS 的分配。

工厂层级 (Plant 
hierarchy)

此列显示了对象（层级）的工厂路径。

对于没有工厂分配的对象，此路径为空，如 SFC 类型。

名称 (Name) 此列显示对象图标和名称。可在此处更改对象名称。

注释 (Comment) 此列显示对象注释。该注释可以更改。

类型 (Type) 此列显示对象类型，如 SFC 类型。

过程变量类型 
(Process tag 
type)

此列显示从中派生过程标签的过程标签类型的名称。

FID 功能标识符的输入字段。如果在其中修改文本，则文本将输入到“描

述：”(Description:) 下“第 3 部分”(Part 3) 选项卡的 CFC/SFC 图表页

脚中。

LID 位置标识符的输入字段。如果在其中修改文本，则文本将输入到 CFC/
SFC 图表页脚中“第 3 部分”(Part 3) 选项卡的“符合位置的代码字

段：”(Code field according to location:) 下。

采样时间 
(Sampling time)

此列显示图表的当前采样时间，已为相应图表创建了同名的运行组。可

以更改此采样时间。

在下拉列表中，会显示已通过所设置的 OB 周期和运行组的可能扫描速

率所确定的时间。
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列 含义

已激活 
(Activated)

用此选项可激活或禁用处于运行序列的图表。对于 CFC 图表，该设置

会影响同名的运行组。

对于 SFC 图表，该设置会影响图表 EN I/O。此复选框既可在离线状况

下选中，也可在在线状况下选中，但如果不存在与 CFC 图表同名的运

行组，则无法选中此复选框。

OCM 可行 
(OCM possible)

使用此列确定是否应将 AS-OS 工程的 SFC 图表传送到 OS 进行显示。

作者 (Author) 作者名称的输入字段。如果创建新对象时激活了 SIMATIC Logon 
Service，则在此处输入该登录用户。

可以更改图表及附加文档的名称。

版本 (Version) 此列显示 CFC 和 SFC 图表的版本号，可在此处进行更改。

上次修改日期 
(Last modified)

此列显示最后更改对象的日期。

9.15.10.4 如何编辑块

“块”选项卡

在此选项卡中，将为当前在层级窗口中选择的对象显示 CFC 中所有块的块属性。在此处，

SFC 实例也会被标识为块。     

表中的列 

说明

如果该块是故障安全程序的组件，在该行的开始处具有行号的域将显示黄色背景。

列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。

图注释 (Chart 
comment)

显示图表的注释（不可更改）。

块 显示块名。可以更改此名称。

最多可为块名输入 16 个字符。
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列 含义

块注释 (Block 
comment)

显示块注释。该注释可以更改。 

创建块图标 
(Create block 
icon)

此复选框用于指定是否应为此块生成一个块图标。 

选中“允许操作员监控”(Operator C and M possible) 复选框可启用

此选项。然后可编辑“块图标”(Block icon) 列中的单元。

块图标 (Block 
icon)

用于显示图标名称，块通过该名称在 OS 画面中显示。 

只有在激活“创建块图标”(Create block icon) 列中的复选框后，才可

编辑此单元。 

如果此块类型有多个块图标变体，可在此处输入该块实例的名称。如

未输入名称，则使用默认块图标。

OCM 可行 (OCM 
possible)

此复选框用于确定是否可对该块进行操作和监视（系统属性

“S7_m_c”）。

MES 相关性 
(MES-relevant)

此复选框决定在响应请求时此 I/O 的信息是否可传送到管理级 MIS/
MES。

只有选中“允许操作员监控”(Operator C and M possible) 复选框时，

才可设置此选项。

注：由于此信息在 PCS 7 中通常不用，因此默认情况下会隐藏该列。

要在过程对象视图中显示该列，请使用菜单命令“选项 > 设置...”
(Options > Settings...)，并选择“列”(Columns) 选项卡。

启用读回 
(Readback 
enabled)

指示出块是否已标记为已启用回读（块具有系统属性

“S7_read_back”）。可以修改此选项。

块组 (Block group) 指示属于特定消息组（基于操作状态的预定自动报警抑制）的块。如

果尚未将该块分配到组，可以更改或输入组的名称。可输入下拉列表

中现有的组名称。该名称最多可有 24 个字符。

使用中断 (With 
interrupt)

指示具有消息响应的块（不可更改）。

背景数据块 
(Instance DB)

显示相应背景数据块的对象名称（例如 DB86）（不可更改）。

系列 (Family) 显示块所属的块系列的名称（例如 CONTROL）（不可更改）。

作者 (Author) 显示特定库中 PCS 7 块的作者或成员的名称（例如 DRIVER70）（不

可更改）。

块类型 (Block 
type)

显示块来源的块类型的名称（不可更改）。
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列 含义

内部 ID (Internal 
ID)

显示内部 ID 的名称（例如 FC 262）（不可更改）。 

过程变量类型 
(Process tag type)

显示创建包含此块的过程变量（图表）时使用的过程变量类型的名称

（不可更改）。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.10.5 如何编辑参数

“参数”选项卡 

此选项卡为所有在“常规”(General) 选项卡中显示的过程变量和 CFC 显示 I/O 点，这些 I/
O 点已专门选定用于参数分配或在过程变量或 CFC 间互连。         

“参数”(Parameter) 选项卡的 I/O 可在以下位置选定：

● 在 SIMATIC Manager 中，使用菜单命令“选项 > 过程对象 > 选择 I/O...”(Options > 
Process Objects > Select I/Os...)。（显示在树形视图中选择的对象）

● CFC 中（块的）“属性 - I/O”(Properties – I/O) 对话框

● 在块类型中：系统属性 S7_edit = para

编辑

以下参数值可输入到在“参数”(Parameters) 选项卡下显示的 I/O 中。

● 数值

● 单位

● 标识符

● 二进制状态和注释的操作员文本。

如果不输入值，也可插入块互连。 

可使用快捷菜单打开相应的 CFC。块的相关 I/O 已被选中。

可使用过滤器来限制所选显示对象的数量。更多相关信息，请参考“使用过程对象视图 
(页 564)”部分。

在过程对象视图中，表格中每个有白色背景的单元均可直接编辑。
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表中的列

说明

如果该连接是故障安全程序的结构化连接，具有行号的域将在相关行开始处以黄色显示。

列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。

图注释 (Chart 
comment)

显示在图表属性中输入的注释（不可更改）。

块 (Block) 显示块名称（不可编辑）。

块注释 (Block 
comment)

显示块注释。该注释可以更改。

I/O 显示块 I/O 的名称（不可更改）。

I/O 注释 (I/O 
comment)

块 I/O 注释的输入字段。该注释可以更改。

过程变量 I/O (Process 
tag I/O)

显示 I/O 点的名称，此名称是为过程变量类型指定的（不可更

改）。

类别 (Category) 显示 I/O 点的类别，此类别是为过程变量类型指定的（不可更

改）。

状态 (Status) 此列只能在在线视图中显示。如果在“监视”(Watch) 列上选中了

该复选框，则状态消息将在此显示。就颜色和文本而言，此列类

似于 CFC。

监视 (Monitoring) 此列只能在在线视图中显示。在此视图中可为测试模式注册或取

消注册 I/O。如果开启“监视”(Watch)，则“状态”(Status) 和
“值”(Value) 列将动态显示。然后以黄色背景显示这些列。
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列 含义

值 (Value) I/O 值的输入字段，视数据类型和允许值范围而定。如果此值涉

及互连 I/O 类型 IN 或 IN_OUT，则不可编辑。

如果此 I/O 为 STRUCT 数据类型，将以基本数据类型显示第一个

结构元素的值。仅在可对结构进行组态的情况下，才可以更改此

值。

如果此值为枚举型值，可在下拉列表中选择枚举值的文本（如果

在共享声明的枚举中存在文本）。枚举型变量和值在 ES 上声明

和管理。

在测试模式中启用“监视”(Monitor) 时，此列将动态显示（在黄

色背景中）。要监视但不能编辑的已互连 I/O 的值以灰黄色背景

显示。红色背景表明在传输中出现了问题（取值无效）。

单位 (Unit) 值单位的输入字段。除输入文本以外，还可在下拉列表中选择标

准单位（kg、m、s、min 等）（I/O 具有系统属性“S7_unit”）。

注：单位列表从基本 CFC 设置生成。这个基本设置可在 ES 中管

理和更改。

互连 (Interconnection) 互连 I/O 的输入字段。

除输入文本外，还可用快捷菜单命令“插入互连...”(Insert 
interconnection...) 来打开互连对话框。写入的互连文本以黄色背

景显示。

注：

如果互连伙伴在过程对象视图中被标识为参数，当选择快捷菜单

命令“转到互连伙伴”(Go to Interconnection Partner) 后，可切换

到互连伙伴行。 

添加强制 (Add forcing) 指示是否为 I/O 添加了强制的复选框。 

如果选中此复选框，就会启用随后出现的“强制激活”(Forcing 
active) 和“强制值”(Forcing value) 这两列，以用于编辑。 

如果此选项无法使用，则该 I/O 不能用于强制。

强制激活 (Forcing 
active) 

指示是否为此 I/O 激活强制的复选框。 

必须激活“添加强制”(Add forcing) 才能使用此选项。

强制值 (Force value) 强制值的输入字段。 

该值取决于 I/O 的数据类型。要输入值，必须激活“添加强制”
(Add forcing)。

OCM 可行 (OCM 
possible)

使用该复选框可显示 I/O 是否可由操作员监控（I/O 对应的系统属

性为“S7_m_c”；属性不能更改）。
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列 含义

标识符 (Identifier) I/O 快捷键的输入字段（I/O 相应的系统属性为“S7_shortcut”）。

文本 0 (Text 0) 描述状态“0”的文本的输入字段。仅当 I/O 是“布尔”(BOOL) 型
数据类型而且其系统属性为“S7_string_0”时文本才显示并可编

辑。

例外：如果 I/O 还具有“S7_enum”系统属性，在“枚举”
(Enumeration) 列中将只有输入字段处于活动状态。

文本 1 (Text 1) 描述状态“1”的文本的输入字段。仅当 I/O 是“布尔”(BOOL) 型
数据类型而且其系统属性为“S7_string_1”时文本才显示并可编

辑。 

例外：如果 I/O 还具有“S7_enum”系统属性，在“枚举”
(Enumeration) 列中将只有输入字段处于活动状态。

受监视 (Watched) 决定 I/O 是否在测试模式下注册的复选框（I/O 对应的系统属性

为“S7_dynamic”）。可以修改此选项。

归档 (Archiving) 指示可由操作员控制和监控的 I/O 块是否要归档（I/O 对应的系统

属性为“S7_archive”）。可以更改此条目。单击此框会显示一个

下拉列表。可选择以下归档类型：

● 不归档 (No archiving)
● 归档 (Archiving)
● 长期归档 (Long-term archiving)

启用读回 (Readback 
enabled)

指示 I/O 是否标记为可读回（I/O 对应的系统属性为

“S7_read_back”）。此选项不可修改。

MES 相关性 (MES-
relevant)

此复选框决定在响应请求时此 I/O 的信息是否可传送到管理级 
MIS/MES。

只有选中“允许操作员监控”(Operator C and M possible) 复选框

时，才可设置此选项。

注：由于此信息在 PCS 7 中通常不用，因此默认情况下会隐藏该

列。要在过程对象视图中显示该列，请使用菜单命令“选项 > 设
置...”(Options > Settings...)，并选择“列”(Columns) 选项卡。

枚举 (Enumeration) 对于系统属性为“S7_enum”的 I/O，赋给 I/O 的枚举的对象名在

此列出。可以更改此名称。 

在此文本框中单击会打开一个下拉列表，从中可为此枚举选择所

需的名称。枚举型变量和值在 ES 上声明和管理。
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列 含义

操作权限级别 
(Operating rights 
level)

用于输入操作权限级别（介于 1 和 99 之间的值）的字段。 

只有在相应块类型具有“Op_Level”属性时，此字段才可用。

在 APL 面板的视图中，操作员可执行的控制取决于特定 APL 操
作员的权限：有关此主题的更多信息，请参见《过程控制系统 
PCS 7；高级过程库》(Process Control System PCS 7; 
Advanced Process Library) 手册中的“用户权限概览”小节和

《过程控制系统 PCS 7；操作站》(Process Control 
System PCS 7; Operator Station) 手册。 

OS 附加文本 (OS 
additional text)

用于输入面板按钮标签文本的字段。可使用此按钮跳转到互连块

的面板。该文本可编辑。

只有相应块在 WinCC 中具有画面跳转功能时，该输入字段才可

用。

数据类型 (Data type) 显示 I/O 的数据类型（不可更改）。

I/O 显示 I/O 类型（IN = input、OUT = output、IN_OUT = in/out 参
数），且不可更改。

块类型 (Block type) 显示块来源的块类型的名称（不可更改）。

图表类型 (Chart type) 显示已标记的 I/O 是属于 CFC 还是属于 SFC。

过程变量类型 
(Process tag type)

显示创建包含此块的过程变量（图表）时使用的过程变量类型的

名称（不可更改）。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.10.6 如何编辑信号

“信号”选项卡

此选项卡显示“常规”(General) 选项卡中显示的所有过程变量和 CFC 的 I/O 点，这些 I/O 
点已明确选定以进行信号互连。     
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“信号”(Signals) 选项卡 I/O 可在以下位置选定：

● 在 SIMATIC Manager 中，使用菜单命令“选项”(Options) >“过程对象”(Process Objects) 
>“选择 I/O...”(Select I/Os...)。

● 在 CFC 的“属性 - I/O”(Properties – I/O) 对话框中

● 在块类型中：系统属性 S7_edit = signal

编辑

可以为 I/O 设备的互连输入符号名、文本属性以及为在“信号”(Signals) 选项卡下的 I/O 输
入注释。 

作为以文本形式输入互连符号的替代方案，如信号已由硬件配置指定，也可在对话框中选

择这些信号。 

使用快捷菜单，可以打开相关的 CFC、硬件配置 (HW Config) 或符号表。

可使用过滤器来限制所选显示对象的数量。更多相关信息，请参见“在过程对象视图中工

作 (页 564)”部分。

在过程对象视图中，表格中每个有白色背景的单元均可直接编辑。

表中的列

说明

如果该连接是故障安全程序的结构化连接，具有行号的域将在相关行开始处以黄色显示。

列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。

图注释 (Chart comment) 显示对象注释（不可编辑）。

块 (Block) 显示块名称（不可编辑）。

块注释 (Block comment) 显示块注释。该注释可以更改。

I/O 显示块 I/O 的名称（不可更改）。

I/O 注释 (I/O comment) 块 I/O 注释的输入字段。该注释可以更改。

过程变量 I/O (Process 
tag I/O)

显示 I/O 点的名称，此名称是为过程变量类型指定的（不可更改）。
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列 含义

类别 (Category) 显示 I/O 点的类别，此类别是为过程变量类型指定的（不可更改）。

状态 (Status) 此列只能在在线视图中显示。如果在“监视”(Watch) 列上设置了该选项，则状态

消息将在此显示。就颜色和文本而言，此状态显示类似于 CFC。 

监视 (Monitoring) 此列只能在在线视图中显示。在此视图中可为测试模式注册或取消注册 I/O。如

果在测试模试中开启“监视”(Monitor)，则“状态”(Status) 和“值”(Value) 列将动

态显示。 

值 (Value) I/O 值的输入字段，视数据类型和允许值范围而定。如果此值涉及互连 I/O 类型 
IN 或 IN_OUT，则不可编辑。

如果此值为枚举型值，可在当前的下拉列表中选择枚举值的文本（如果有）。枚

举及其值在 ES 中声明和管理。

在测试模式中启用“监视”(Monitor) 时，此列将动态显示（在黄色背景中）。要

监视但不能编辑的已互连 I/O 的值以灰黄色背景显示。红色背景表明在传输中出

现了问题（取值无效）。

单位 (Unit) *) 值单位的输入字段。除输入文本以外，还可在下拉列表中选择标准单位（kg、m、

s、min 等）（I/O 具有系统属性“S7_unit”）。

注：单位列表从 CFC 的基本设置中生成。这个基本设置可在 ES 中管理和更改。

信号 (Signal) 互连信号名称的输入字段。可直接输入一个绝对地址。如果输入绝对地址已存在

符号，该符号会显示出来。否则，绝对地址将以“%”作为前缀进行显示。除输入

文本外，还可用快捷菜单命令“插入信号...”(Insert signal...) 来打开互连对话框。

信号注释 (Signal 
comment)

从符号表中读取的信号注释的输入字段（不可更改）。

添加强制 (Add forcing) 指示是否为 I/O 添加了强制的复选框。 

如果选中了此复选框，就会启用随后出现的“强制激活”(Forcing active) 和“强制

值”(Forcing value) 列，以用于编辑。 

如果此选项无法使用，则该 I/O 不能用于强制。

强制激活 (Forcing 
active) 

指示是否为此 I/O 激活强制的复选框。 

必须激活“添加强制”(Add forcing) 才能使用此选项。

强制值 (Force value) 强制值的输入字段。 

该值取决于 I/O 的数据类型。要输入值，必须激活“添加强制”(Add forcing)。

绝对地址 (Absolute 
address)

从符号表中读出的信号的绝对地址（例如 QW 12 或 I3.1），或者如果绝对地址

已在“信号”(Signal) 输入字段输入，则来自该输入字段（不可修改）。

硬件地址 (Hardware 
address)

信号的硬件地址。从 HW Config 中读出（不可更改）。
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列 含义

测量类型 (Measurement 
type)

输入模块的信号测量类型；输出模块的信号输出类型。从 HW Config 中读出（不

可更改）。

测量范围 (Measuring 
range)

输入模块的信号测量范围；输出模块的信号输出范围。从 HW Config 中读出（不

可更改）。

AS 显示到包含过程变量或 CFC 的 S7 程序的组件路径（不能修改）。

OCM 可行 (OCM 
possible)

使用该复选框可显示 I/O 是否可由操作员监控（I/O 对应的系统属性为“S7_m_c”；
属性不能更改）。

标识符 (Identifier) *) I/O 快捷键的输入字段（I/O 相应的系统属性为“S7_shortcut”）。

文本 0 (Text 0) *) 描述状态“0”的文本的输入字段。仅当 I/O 是“布尔”(BOOL) 型数据类型而且其

系统属性为“S7_string_0”时文本才显示并可编辑。

文本 1 (Text 1) *) 描述状态“1”的文本的输入字段。仅当 I/O 是“布尔”(BOOL) 型数据类型而且其

系统属性为“S7_string_1”时文本才显示并可编辑。

受监视 (Watched) 决定 I/O 是否在测试模式下注册的复选框（I/O 对应的系统属性为

“S7_dynamic”）。可以修改此选项。

归档 (Archiving) 指示将归档哪些支持 OCM 的块 I/O。可以更改此条目。在编辑框中单击将显示一

个下拉列表。可选择以下归档类型：

● 不归档 (No archiving)
● 归档 (Archiving)
● 长期归档 (Long-term archiving)
注：如果确定要将某个 I/O 归档，则只有在 OS 上执行完编译后，该 I/O 才会显

示在“归档变量”(Archive tags) 选项卡上。

启用读回 (Readback 
enabled)

指示 I/O 是否标记为可读回（I/O 对应的系统属性为“S7_read_back”）。此选项

不可修改。

MES 相关性 (MES-
relevant) *)

此复选框决定在响应请求时此 I/O 的信息是否可传送到管理级 MIS/MES。

只有选中“允许操作员监控”(Operator C and M possible) 复选框时，才可设置此

选项。

枚举 (Enumeration) *) 对于系统属性为“S7_enum”的 I/O，赋给 I/O 的枚举的对象名在此列出。可以更

改此名称。 

在此文本框中单击会打开一个下拉列表，从中可为此枚举选择所需的名称。枚举

型变量和值在 ES 上声明和管理。

也可在仍未定义枚举的输入字段中输入名称。

数据类型 显示 I/O 的数据类型（不可更改）。

I/O 显示 I/O 类型（IN = input、OUT = output、IN_OUT = in/out 参数），且不可更

改。
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列 含义

块类型 (Block type) 显示块来源的块类型的名称（不可更改）。

图表类型 (Chart type) 显示已标记的 I/O 是属于 CFC 还是属于 SFC。

过程变量类型 显示派生出此过程变量的过程变量类型的名称（不可更改）。

*) 注：由于此信息在 PCS 7 中通常不用，因此默认设置下会隐藏该列。要在过程对象视图

中显示该列，请选择菜单命令“选项 > 设置...”(Options > Settings...)，然后选择“列”
(Columns) 选项卡、“对象类型”(Object types) 组以及“过程对象视图”(Process object 
view) 文件夹。在此，选择期望条目，并在“可见列”(Visible columns) 组中激活所需的复

选框。

更多信息

● PH、IEA 和 PO 的在线帮助

9.15.10.7 如何编辑消息

“消息”选项卡

在使用“用户可组态消息类别”功能时，请参见“用户可组态消息类别”部分中的信息。

此选项卡显示了属于在“常规”(General) 选项卡中显示的过程变量及 CFC/SFC 的发送信

号块的消息文本。     

编辑

可使用快捷菜单打开相应的图表。

可使用过滤器来限制所选显示对象的数量。更多相关信息，请参考“使用过程对象视图 
(页 564)”部分。

在过程对象视图中，表格中每个有白色背景的单元均可直接编辑。

表中的列

说明

如果关于某块的消息来自故障安全程序，具有相应行号的字段将在相关行的开始处以黄色

显示。
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列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。

图注释 (Chart 
comment)

显示对象注释（不可编辑）。

块 (Block) 显示块名称（不可编辑）。

块注释 (Block 
comment)

显示块注释。该注释可以更改。

I/O 显示块 I/O 的名称（不可更改）。

I/O 注释 (I/O 
comment)

块 I/O 注释的输入字段。该注释可以更改。

子编号 (Sub 
number)

消息的子编号（不可更改）。

类别 (Class) 为块类型指定的消息类别。可使用下拉列表进行选择。 

如果消息类别在块类型消息中锁定，则该消息类别不可更改。

优先级 (Priority) 消息优先级。可使用下拉列表进行选择。 

在以下条件下不能更改优先级：

● 消息在块类型消息中锁定

● 消息已按先前的消息概念组态（“在整个项目中消息的编号是唯

一的”）

触发操作 (Trigger 
action)

启动“GMsgFunction”标准功能（可使用“全局脚本”PCS 7 编辑器

更改）

来源 (Origin) 块的来源。在 PCS 7 中使用关键字 $$HID$$。 

如该文本在块类型消息中锁定，则文本不可更改。

OS 区域 (OS area) OS 区域文本，可据此在线过滤消息列表。在 PCS 7 中使用关键字 
$$AREA$$。

如该文本在块类型消息中锁定，则文本不可更改。

事件 (Event) 事件文本的输入字段（例如“$$BlockComment$$ 太高”($
$BlockComment$$ too high)）。

如该文本在块类型消息中锁定，则文本不可更改。

单个确认 (Single 
acknowledgment)

如果消息应作为单个消息确认，则选中该复选框。
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列 含义

Batch  ID (Batch 
ID)

BATCH 消息文本。

如该文本在块类型消息中锁定，则文本不可更改。

信息文本（

操作员控制/
自由文本 1-5）

如该文本在块类型消息中锁定，则文本不可更改。

注：除了包含“信息文本”(Info text) 列，此选项卡中还包含“自由文

本 1”(Free Text 1) 到“自由文本 5”(Free Text 5) 列和“操作员控制”
(Operator Control)。由于这些文本在 PCS 7 中不常用，因而这些列

在默认设置中为隐藏状态 *)。 

响应时间 特定消息采取的响应时间。

说明 提供所选消息的详细信息。

原因 提供消息生成的原因。

操作员操作 提供操作员需要采取的操作。

结果 提供如果运营商不采取适当的措施，您可能面临的后果。

状态 1-10 (32) 
(Status 1-10 (32)) 
*)

在状态列中指定在哪些操作状态（状态 1 到状态 32）下于 OS 的过

程模式中隐藏消息。 

在默认设置下，不显示列 11 到列 32。

在满足以下先决条件的情况下，可对这些状态列进行修改：

● 在块组中包含属于该消息的块。

● 已在当前项目中设置 CPU 范围的消息概念。

如果当前选择中仅包含那些在其 SR 块（状态表示块，Status 
Representation block）上组态了相同列表类型的块组的消息，具体

的操作状态将替换默认的列标题。这些列表类型以列表形式包含可能

的操作状态。

块组 (Block group) 显示块组的名称，该块组中的块属于特定消息组，并且为该消息组指

定在特定操作状态下自动隐藏消息（不可更改）。

块类型 (Block 
type)

显示块来源的块类型的名称（不可更改）。

图表类型 (Chart 
type)

显示已标记的 I/O 是属于 CFC 还是属于 SFC。

过程变量类型 显示派生出此过程变量的过程变量类型的名称（不可更改）。

*) 注：由于此信息在 PCS 7 中通常不用，因此默认情况下会隐藏该列。要在过程对象视图

中显示该列，请选择 “选项 > 设置...”(Options > Settings...) >“列”(Columns) 选项卡 >“对
象类型”(Object types) 组 >“过程对象视图”(Process object view) 文件夹。在此，选择期望

条目，并在“可见列”(Visible columns) 组中激活所需的复选框。
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更多信息

● PH、IEA 和 PO 的在线帮助

9.15.10.8 如何编辑画面对象

“画面对象”选项卡

此选项卡显示了在“常规”(General) 选项卡中显示的过程变量和 CFC 中的具有 OCM 功能

的 CFC 块，以及任何画面互连和画面分配。所有 SFC 和它们的画面互连、画面分配也会

显示出来。     

对每个块，会显示使用它的位置（对每个 OS、每个 OS 画面和每个与其互连的画面对

象）。对于块图标，可以选择图标的外观。如紧靠块的行为空行，则表示任何项目 OS 都
没有操作或监视此块。 

编辑

所显示的互连和分配不可编辑。此选项卡实际上具有交叉引用功能，用于提供一个或多个

过程变量的现有或缺失画面互连及分配的快速总览。 

如想修改画面内容，使用此快捷菜单还可打开所选 OS 画面的 WinCC 图形（此快捷菜单

也可用于打开 CFC）。

可使用过滤器来限制所选显示对象的数量。更多相关信息，请参考“使用过程对象视图 
(页 564)”部分。

在过程对象视图中，表格中每个有白色背景的单元均可直接编辑。

表中的列

说明

如果可操作块是故障安全块或者可操作连接是故障安全程序的结构化连接，具有行号的域

将在相应行开始处以黄色突出显示。

列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。
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列 含义

图注释 (Chart 
comment)

显示对象注释（不可编辑）。

块 (Block) 显示块名称（不可编辑）。

块注释 (Block 
comment)

显示块注释。该注释可以更改。

I/O 显示块 I/O 或 SFC I/O 的名称（不可更改）。如画面对象作为整体分

配到块，则此单元格为空单元格。

I/O 注释 (I/O 
comment)

I/O 注释的输入字段。该注释可以更改。如画面对象作为整体分配到

块，则此单元格为空单元格。

过程变量 I/O 
(Process tag I/O)

显示 I/O 点的名称，此名称是为过程变量类型指定的（不可更改）。

如画面对象作为整体分配到块，则此单元格为空单元格。

OS 显示 OS 画面所在的 OS 的组件路径。在多项目中，项目名称还会显

示在不同项目的 OS 的路径中（不可修改）。

画面 (Picture) OS 画面的名称（不可修改）。

画面对象 (Picture 
object)

画面对象的名称，例如面板、用户对象（不可修改）。

属性 (Property) 画面对象的互连或分配属性的名称（不可修改）。

块类型 (Block 
type)

显示块来源的块类型的名称（不可更改）。

图表类型 (Chart 
type)

其中会显示 OS 画面是分配给 CFC 还是分配给 SFC。

过程变量类型 显示派生出此过程变量的过程变量类型的名称（不可更改）。

更多信息

● PH、IEA 和 PO 的在线帮助

● 组态手册《过程控制系统 PCS 7；操作站》

9.15.10.9 如何编辑归档变量

“归档变量”选项卡 

在“常规”(General) 选项卡下显示的所有过程变量、CFC、SFC 以及互连的 WinCC 归档

变量，将和它们的属性一起显示在该选项卡中。     

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 585



每个归档变量都占用一行显示。并非在 WinCC 变量记录中定义的所有属性都会显示，而

是只显示与 PCS 7 相关的子集。

编辑

归档变量必须首先在 WinCC 变量记录中创建。然后归档变量的属性可直接在表中编辑（不

必打开 WinCC 变量记录）。 

必要时，可从快捷菜单中打开 WinCC 变量记录。

可使用过滤器来限制所选显示对象的数量。更多相关信息，请参见“在过程对象视图中工

作 (页 564)”部分。

在过程对象视图中，表格中每个有白色背景的单元均可直接编辑。

表中的列

说明

如果该连接是故障安全程序的结构化连接，具有行号的域将在相关行开始处以黄色显示。

列 含义

层级 (Hierarchy) 显示过程变量或 CFC 的工艺路径（不可更改）。

图表 (Chart) 显示过程变量或 CFC 的名称（不可更改）。

图注释 (Chart 
comment)

显示对象的注释（不可更改）。

块 (Block) 显示块名称（不可编辑）。

块注释 (Block 
comment)

显示块注释。该注释可以更改。

I/O 显示块 I/O 或 SFC I/O 的名称（不可更改）。如画面对象作为整

体分配到块，则此单元格为空单元格。

I/O 注释 (I/O 
comment)

I/O 注释的输入字段。该注释可以更改。

过程变量 I/O (Process 
tag I/O)

显示 I/O 点的名称，此名称是为过程变量类型指定的（不可更

改）。

OS 显示包含 OS 画面或 OS 报表的 OS 的组件路径。

在多项目中，项目名称还会显示在不同项目的 OS 的路径中（不

可修改）。
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列 含义

归档名称 (Archive 
name)

测量值归档的名称（不可修改）。

变量名称 归档变量名的输入字段。

变量注释 (Tag 
comment)

归档变量注释的输入字段。

长期归档 (Long-term 
archiving)

指示归档变量是用于长期归档还是短期归档。在此列中进行的修

改会直接影响 WinCC 测量值归档，无需重新编译 OS。更改还会

影响 CFC 中的相关 I/O 块和“参数”(Parameters) 选项卡。

变量供应 (Tag supply) 变量供给的类型。从下拉列表中可进行选择（“系统”
(system)、“人工输入”(manual input)）。

归档 (Archiving) 指定是否在系统启动时立即开始归档。从下拉列表中可进行选择

（“已启用”(enabled)、“已禁用”(blocked)）。

采集周期 (Acquisition 
cycle)

采集数据的周期。可使用下拉列表进行选择。

归档周期因子 (Factor 
for archiving cycle)

从中可指定归档周期的因子。如采集类型是非周期性的，则此因

子不可修改。

归档/显示周期 
(Archiving/display 
cycle)

在此可输入用于归档和显示数据的周期。可使用下拉列表进行选

择。如采集类型是非周期性的，则此周期不可修改。

故障/错误时保存 
(Save on fault/error)

在此输入发生错误或故障时的更正类型。从下拉列表中可进行选

择（“上一个值”(last value)、“替代值”(substitute value)）。

在以下条件下归档 
(Archive if)

从中可指定逻辑信号的状态变化、更改的类型以及归档更改的时

间。可使用下拉列表进行选择。此条目仅对二进制变量有效。

单位 (Unit) ES 数据管理的单元。只在此显示，可在“参数”(Parameters) 选
项卡中修改。

数据类型 显示 I/O 的数据类型。

I/O 显示 I/O 类型（IN = input、OUT = output、IN_OUT = in/out 参
数）。

块类型 (Block type) 显示块来源的块类型的名称。

图表类型 (Chart type) 其中会显示归档变量属于 CFC 还是 SFC。

过程变量类型 
(Process tag type)

显示派生出此过程变量的过程变量类型的名称。
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列 含义

压缩 (Compression) 指定是否压缩归档变量（选中复选框时压缩，否则不压缩）。只

能压缩模拟值。

只有选中该复选框，以下各列才相关。

Tmin，ms 在此，可以指定两次保存归档变量之间的最短时间间隔。

Tmax，ms 在此，可以指定两次保存归档变量之间的最长时间间隔。

偏差 (Deviation) 在此，可以指定偏差的最大值。

绝对/相对 (abs/rel) 指定是按照百分比值还是按照绝对值来度量偏差的最大值。

下限 (Low limit) 指定要归档参数的下限。

上限 (High limit) 指定要归档参数的上限。

更多信息

● PH、IEA 和 PO 的在线帮助

● 组态手册《过程控制系统 PCS 7；操作站》

9.15.10.10 如何编辑层级文件夹

“层级文件夹”选项卡

在此选项卡中，将为当前在层级窗口中选择的对象显示 PH 的层级文件夹。每个现有层级

文件夹都占用一行显示。

表中的列

列 含义

层级 (Hierarchy) 显示层级文件夹的工艺路径（不可更改）。

名称 (Name) 显示层级文件夹的名称。可以重命名对象。 

对于当前项目，在“工厂层级 - 设置”(Plant Hierarchy - Settings) 对
话框（菜单命令“选项 > 工厂层级 > 设置...”(Options > Plant 
Hierarchy > Settings...)）中指定每个层级名称的最多字符数。 

不能更改作为逻辑操作列出的层级文件夹和系统生成的诊断文件夹的

名称。

注释 (Comment) 该注释可以更改。不能更改作为逻辑操作列出的层级文件夹的注释。
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列 含义

ISA-88 类型 
(ISA-88 type)

默认情况下隐藏此列。

显示可更改的默认 ISA-88 类型。在相应层级的下拉列表中，提供了

所有可能的 ISA-88 类型和“<中性>”(<neutral>) 类型。 

不能更改标记为逻辑操作的层级文件夹的 ISA-88 类型，也不能更改

系统生成的诊断文件夹的 ISA-88 类型。

AS 显示到包含层级文件夹的 S7 程序的组件路径。

在文本框中单击，将打开一个下拉列。如果项目包含几个 S7 程序，

它们将显示在此下拉列表中。通过选择另一个 S7 程序，可将层级文

件夹连同其所有从属层级一并移动到本程序，或使用“<没有分配>”
(<no assignment>) 删除对 AS 的分配。

OS 显示包含层级文件夹的 OS 的组件路径。

在文本框中单击，将打开一个下拉列。如果项目包含多个 OS，它们

将显示在此下拉列表中。选择另一个 OS，可将相关对象及其所有从

属层级一并移动到该 OS 中，或使用“<没有分配>”(<no assignment>) 
来重置对 OS 的分配。

在编译特定区域时，仅可在 OS 区域级别的层级文件夹更改 OS 分
配。

OS 区域标识符 
(OS area 
identifier)

可在此列中更改 OS 区域级别的层级文件夹的名称。

OS 画面名 
(Picture name for 
OS)

可在此列中更改 OS 区域级别以下的层级文件夹的名称。

画面顺序 (Picture 
order)

可在此列中更改 OS 上画面选择的画面顺序。下拉列表中的数字指示

画面以降序从左向右排列。

作者 (Author) 作者姓名的文本框。如果在创建层级文件夹时激活了 SIMATIC Logon 
Service，则在此处输入该登录用户。

修订日期 
(Revision date)

可在此列中查看最后更改的日期（不可更改）。

更多信息

● PH、IEA 和 PO 的在线帮助

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)
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9.15.10.11 如何编辑设备属性

“设备属性”选项卡

此选项卡显示选定项目中所含的设备属性。这些设备属性是由在共享声明中组态的设备属

性类型所创建的实例。每个现有设备属性都占用一行显示。如果对类型进行了更改，则无

法在此处编辑的属性会被传送到实例。

表中的列

列 含义

层级 (Hierarchy) 显示层级树中设备属性的路径（不可更改）。 

名称 (Name) 在此列中，您可以从下拉列表中为列出的其中一个实例选择所需的设

备属性类型名称。按 <F5> 更新数据之后，便会应用该类型的已组态

属性。

显示名称 (Display 
name)

显示名称使用多种语言，在 OS 编译期间会被传送到 WinCC（不可

更改）。只能在类型中更改显示名称（“共享声明”(Shared 
Declarations) 选项卡）。

注释 (Comment) 创建实例后，类型注释会显示在此列中。该注释可以更改。

值 (Value) 可在此列中为设备属性分配值。将根据数据类型检查语法。如果为类

型组态了枚举，则您可以在下拉列表中选择一个已组态的值。

单位 (Unit) 显示已组态的单位（不可更改）。只能在类型中更改单位（“共享声

明”(Shared Declarations) 选项卡）。

数据类型 (Data 
type)

此列显示已组态的数据类型（不可更改）。只能在类型中更改单位

（“共享声明”(Shared Declarations) 选项卡）。

枚举 
(Enumeration)

如果已在设备属性类型中组态了某个枚举，则它会在此处显示（不可

更改）。只能在类型中更改枚举（“共享声明”(Shared Declarations) 
选项卡）。

作者 (Author) 作者姓名的文本框。如果在创建设备属性时激活了 SIMATIC Logon 
Service，则在此处输入该登录用户。

更多信息

● PH、IEA 和 PO 的在线帮助

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)
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9.15.10.12 如何编辑共享声明

“共享声明”选项卡

在此选项卡中，可以编辑项目中枚举、单位和设备属性类型的属性。 

表中的列

列 含义

层级 (Hierarchy) 显示层级树中对象的路径（不可更改）。

名称 (Name) 显示“共享声明”(Shared Declarations) 文件夹中对象的名称。

显示名称 (Display 
name)

显示名称使用多种语言，在 OS 编译期间会被传送到 WinCC。只能

更改枚举和设备属性类型的显示名称。

注释 (Comment) 显示对象注释。该注释可以更改。

类型 (Type) 显示对象的类型名称。类型名称是：枚举、值、单位、设备属性（不

可更改）。

值 (Value) 显示枚举的已组态值。可以更改此值。对于单位和设备属性，这些字

段为空。

单位 (Unit) 此列显示设备属性的已组态单位。可从下拉列表中进行选择来更改单

位。对于枚举和单位，这些字段为空。

数据类型 (Data 
type)

显示已组态的设备属性数据类型。可从下拉列表中进行选择来更改数

据类型。对于枚举和单位，这些字段为空。

枚举 
(Enumeration)

显示设备属性的已组态枚举。对于数据类型 INT、DINT、SOURCE、
DEST 和 VIA，可以从下拉列表中进行选择来更改枚举。对于枚举和

单位，这些字段为空。

控制策略 (Control 
strategy)

显示枚举是否是控制策略（复选框选中）。可以更改此属性。

作者 (Author) 作者姓名的文本框。如果在创建共享声明时激活了 SIMATIC Logon 
Service，则在此处输入登录的用户。 

对于单位和设备属性，这些复选框为空。

版本 (Version) 显示已组态类型的当前版本：枚举、单位和设备属性。可以更改此版

本。

更多信息

● PH、IEA 和 PO 的在线帮助

实施 PCS 7 组态

9.15 组态 AS 功能

工程组态系统 (V9.0 SP1)
配置手册, 12/2017, A5E39221328-AC 591



9.15.10.13 如何在过程对象视图中测试

过程对象视图中的测试模式

过程对象视图提供一个测试模式，用此模式可在 CPU 上在线测试和调试过程变量和 
CFC。     

在测试模式下，以下列会动态显示在过程对象视图中：

选项卡 动态列 测试模式中的附加列

常规 
(General)

状态 (Status)

选中 (Selected)

仿真输入 (Simulate inputs)

仿真输出 (Simulate outputs)

监视 (Monitoring)

参数 
(Parameter)

状态 (Status)

值 (Value)

监视 (Monitoring)

信号 (Signals) 状态 (Status)

值 (Value)

监视 (Monitoring)

通过在“监视”(Watch) 列中放置复选标记，可以注册要进行测试 (页 675)的过程变量或图

表。

无法在测试模式下选择未在表格中列出的选项卡（消息、画面对象等）。

设置测试模式

类似于 CFC，测试模式可在过程和实验室模式下运行。可以在离线模式下使用菜单命令

“选项”(Options) >“过程对象（在线）”(Process Objects (Online)) >“过程模式”(Process 
Mode) 或 >“实验室模式”(Laboratory Mode) 进行设置。

使用菜单命令“选项”(Options) >“过程对象（在线）”(Process Objects (Online)) >“测试设

置...”(Test Settings...) 打开设置监视周期的对话框。监视周期会全局影响过程对象视图中

当前窗口的所有过程变量及 CFC（而非在 CFC 和 SFC 中时局限为 CPU 特定的）。 

这些设置的设定独立于 CFC/SFC 的设置。
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激活/禁用测试模式

在 SIMATIC Manager 中设置测试模式。激活/禁用测试模式会影响过程对象视图的活动窗

口。

● “激活/禁用测试模式”(Activating/deactivating test mode)
使用菜单命令“视图”(View) >“在线”(Online) 可激活测试模式。

使用菜单命令“视图”(View) >“离线”(Offline) 可禁用测试模式。

测试模式激活时，系统将切换到现有窗口而不是打开一个新窗口。

当向测试模式进行转换时，系统会执行测试来确保在线数据和离线数据彼此一致。此步骤

的执行方式与 CFC 和 SFC 中测试模式的方式相同。如果存在偏差，将为此显示一条消

息。

选项卡的解释

测试模式对选项卡产生以下影响：

选项卡 描述

常规 (General) 在此选项卡中不能删除、移动或复制对象。除“AS”列外，如果在离线模式下可修改，

则所有的列仍可编辑。

激活测试模式后，在“已激活”(Activated)、“仿真输入”(Simulate inputs) 以及“仿真

输出”(Simulate outputs) 列中的更改将保存在工程师站中并下载到 AS。过程变量或图

表未注册用于测试时同样有效。

“参数”
(Parameters) 和
“信号”(Signals)

在这两个选项卡下，“监视”（Watch）、“值”（Value）和“受监视”（Watched）
列均可编辑。

激活测试模式后，在“值”(Value) 和“监视”(Watches) 列中的更改将保存在工程师站中

并下载到 AS。I/O 未注册用于测试时，同样适用。

通过“####”显示错误或未定义的值。

动态值按照其状态如下显示在不同的背景上：

● 黄色（动态，可更改）

● 灰黄色（动态，不可更改）

● 红色（有故障）

当单击字段编辑其值时，字段的颜色由黄变成白色。然后离线值会显示出来。

在 ES 日志中记录更改

在测试模式下，所有在 CPU 中引起更改（值更改）的操作均记录在 ES 日志中。 
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要求：

● 安装了 SIMATIC Logon Service。

● 已为当前所选图表文件夹激活了 ES 日志。

如果有更改，ES 日志将打开，然后输入更改原因。如用户尚未登录 SIMATIC Manager，
SIMATIC Logon Service 对话框会在打开更改日志前打开。 

可通过“ES 日志”(ES Log) 选项卡中的菜单命令“选项 > 图表 > 日志...”(Options > Charts 
> logs...) 查看记录的更改。

打印选项卡显示

与离线模式下相同，可以使用快捷菜单“打印”(Print) >“当前选项卡”(Current Tab) 打印输

出当前选项卡中显示的值。 

与在离线模式下不同，只能使用菜单命令“文件”(File) >“打印”(Print) >“对象列表...”(Object 
List...) 打印当前选项卡。这已经在“打印过程对象视图设置”(Settings for printing the 
process object view) 中选择且不可更改。

更多信息

● PH、IEA 和 PO 的在线帮助
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9.16 将组态下载到 CPU

9.16.1 如何在 CPU-STOP 模式下下载组态

简介        

SIMATIC 站的硬件配置已完成。 

首先保存并编译已创建的硬件配置，然后将该信息传递给 CPU。 

规则

说明

在某些情况下，可以在操作期间下载硬件配置（CPU 处于 RUN 模式）。在“允许的组态

更改概述 (页 404)”部分中列出了可在 RUN 模式下进行的组态更改 (CiR)。
其它组态更改则意味着，仅当 CPU 处于 STOP 模式时才能下载硬件配置！ 

要求

● 从工程师站到自动化系统的数据链接必须正常工作。

● 要装载的自动化系统的硬件配置打开。

● SIMATIC 站处于 STOP 操作状态。

步骤

1. 在 HW Config 中选择菜单命令“站 > 保存并编译”(Station > Save and Compile)。
将发送信息指示现有的一致性错误。有关所发生错误的详细信息，请单击“详细信息”
(Details)。

2. 选择菜单命令 CPU >“下载到模块”(Download to Module)。
将打开“选择目标模块”(Select Target Modules) 对话框。

3. 选择目标模块，然后单击“确定”(OK)。
将打开“选择节点地址”(Select node address) 对话框。

4. 单击“刷新”(Refresh) 按钮。
在“可访问的节点”(Accessible Nodes) 组中列出所有可访问的节点。

5. 选择所需节点，然后单击“确定”(OK)。
该组态被加载到 PLC 中。
如果更改日志已激活，将打开该日志。在“原因”(Reason) 组中输入注释，然后单击“确
定”(OK)。
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6. 下载完成后，重新启动 CPU。

7. 选择菜单命令“站”(Station) >“退出”(Exit) 以关闭硬件配置。

结果

将会创建项目，例如采用组件视图中的以下结构。 

源文件和块

● 用户块的源文本以及由 CFC/SFC 生成的 SCL 源文件存储在“源”(Sources) 文件夹中。

● 标准块、用户块以及由 CFC/SFC 生成的块（如，实例）存储在“块”(Blocks) 文件夹

中。

● “图表”(Charts) 文件夹包含 CFC、嵌套图表（图表中的图表）和 SFC。

● 枚举、单位和设备属性保存在“共享声明”(Shared Declarations) 文件夹中。

H 系统上的运行中修改设备

有关在 H 系统上进行“运行中修改设备”的更详细信息，请参考手册《S7-400H 可编程控

制器；高可用性系统》(S7-400H Programmable Controller, High Availability Systems)
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9.16.2 如何在 CPU RUN 模式下下载组态更改 (CiR)

要求            

● 所更改的硬件组态必须已完成。

● 所更改的硬件组态必须已保存并进行了编译。

步骤

1. 使用菜单命令“站”(Station) >“检查 CiR 功能”(Check CiR Capability) 检查是否可以下载当
前的组态。

2. 在 HW Config 中选择菜单命令“站”(Station) >“保存并编译”(Save and Compile)。

3. 使用菜单命令 PLC >“下载到模块...”(Download to Module...) 将组态下载到 CPU。

说明

请注意以下事项：

● 如果无法下载组态更改，请关闭 HW Config 而不进行保存。这样可避免 CPU 中的组态
与 ES 上的组态之间的不一致。

● 在将组态下载到 CPU 时，INTF LED 亮起后又随即熄灭，而 EXTF LED 保持常亮。只
有 INTF LED 再次熄灭后才能开始添加真正的站或模块。EXTF LED 随即也会再次熄灭。

建议

无论 CPU 是何操作状态，每当从 HW Config 下载站组态时，都要备份当前组态。只有这

样才能确保在发生错误（数据丢失）时仍可继续工作而不会丧失 CiR 功能。 

更多信息

● HW Config 在线帮助

9.16.3 在 CPU RUN 模式下下载组态更改后 CPU 的响应 (CiR)

在 RUN 模式下下载组态后的 CPU 响应

下载已修改的组态后，CPU 一开始会检查是否允许所做的修改。如果允许，则对受影响的

系统数据进行分析。

此分析过程会影响许多重要的操作系统功能，如过程映像的更新和用户程序的编辑。将在

下面对这些影响进行详细说明。
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CPU 解释系统数据所花的时间（称为 CiR 同步时间）取决于受影响 DP 主站系统中的输入

及输出字节数。默认的同步时间最多为 1 秒。不能更改此值。

在系统数据评估开始时，CPU 在诊断缓冲区中输入事件 W#16#4318，在评估完成时输入

事件 W#16#4319。 

说明

如果在分析系统数据期间发生了“断电”或是 CPU 切换到 STOP 模式，则唯一可行的做

法是进行暖启动。

分析完系统数据后，CPU 便会伴随事件 W#16#350A 启动 OB 80，并在其启动信息中输入

分析持续时间。这样即可在周期性中断 OB 中针对控制算法考虑此时间。

说明

确保始终在 CPU 上加载 OB80。否则，当发生 OB 80 启动事件时，CPU 会切换到 STOP 
模式。

CPU 对所需组态更改的验证

CPU 首先会计算 DP 和 PA 主站系统的数目，您将在这些系统上添加或删除从站或模块，

或是希望更改现有的过程映像区分配。若受影响的主站系统最多为 4 个，CPU 会继续检

查，若超过 4 个，它将拒绝修改后的组态。 
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接着，CPU 将按如下所述计算 CiR 同步时间：

● 如果只更改现有模块的参数设置，则无论 CPU 为何种类型，以下计算都适用：

CPU 的 CiR 同步时间 = 100 ms

● 在其它所有情况下，则采用以下计算方法：

CPU 的 CiR 同步时间为各相关主站系统的 CiR 同步时间的总和。相关主站系统是指在

其中添加或删除从站或模块（或是更改现有部分过程映像分配）的系统。

相关主站系统的 CiR 同步时间 = 

主站系统的基本负载 + 以字节为单位的主站系统 I/O 总量 * 每字节的时间。

主站系统的 I/O 总量为此主站系统中 CiR 元素的实际现有输入及输出字节的总和。要针

对特定 CPU 类型计算主站系统的基本负载和每字节的时间，请参考 CPU 的技术规范。

说明

CiR 同步时间：

● 以此方式计算的 CiR 同步时间是基于最坏情况得出的。这意味着在 CiR 期间，实际的 
CiR 同步时间总是小于或等于计算得出的时间。

● 在 HW Config 中，主站系统的 CiR 同步时间显示在 CiR 对象的属性窗口中。

下图以 CPU 417-4 为例说明了主站系统的 CiR 同步时间与其全部 I/O 量之间的关系。
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由此图可以看出，如果只对一个 DP 主站系统进行更改，则很容易就能根据最大 CiR 同步

时间得出主站系统的最大大小。对此可参考“定义 DP 主站系统大小实例”部分的实例来

加以解释。 

CPU 现在会将计算得出的 CiR 同步时间与当前的 CiR 同步时间上限进行比较。在 PCS 7 
中为 CiR 同步时间设置的固定上限为 1 秒。 

如果计算值小于或等于当前上限，CPU 将接受更改后的组态，否则予以拒绝。

修改 CiR 同步时间 

从以上公式中可以清楚地看出，可对 CiR 同步时间进行如下修改：

减少 CiR 同步时间：

● 为主站系统选择了更少的输入及输出字节数

● 为将要更改的主站系统选择了更少的保证从站（保证从站数进而会直接影响输入及输出

字节数）

● 减少了要在一次 CiR 操作中更改的主站系统

这一点对于 F 系统尤为重要。在此，F 监视时间必须包括 CiR 同步时间。必须使用具有 
CiR 对象的所有 DP 主站系统的最高值（如果每次 CiR 操作只修改一个 DP 主站系统），

或使用要同时修改的主站系统的总和。

计算实例

下表中的实例针对的是有 6 个 DP 主站系统的 CPU 417-4。 

最大允许 CiR 同步时间为 550 ms。这样，只要这些主站系统的 CiR 同步时间总和不超过 
550 ms，即可对多个 DP 主站系统进行更改。最后一列显示了可以在一次 CiR 操作中修改

哪些 DP 主站系统。

DP 主站

系统

I/O 总量

（字节）

主站系统的 CiR 同步时间 DP 主站系统更改分布情况

1 1500 100 毫秒 + 1500 字节 * 0.12 毫秒/字节 = 280 毫秒 1（280 毫秒）或 

（1 和 2）（500 毫秒）

2 1000 100 毫秒 + 1000 字节 * 0.12 毫秒/字节 = 220 毫秒 2（220 毫秒）或 

（2 和 1）（500 毫秒）或 

（2 和 3）（500 毫秒）

3 1500 100 毫秒 + 1500 字节 * 0.12 毫秒/字节 = 280 毫秒 3（280 毫秒）或 

（3 和 2）（500 毫秒）
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DP 主站

系统

I/O 总量

（字节）

主站系统的 CiR 同步时间 DP 主站系统更改分布情况

4 2500 100 毫秒 + 2500 字节 * 0.12 毫秒/字节 = 400 毫秒 4（400 毫秒）

5 3000 100 毫秒 + 3000 字节 * 0.12 毫秒/字节 = 460 毫秒 5（460 毫秒）

6 7000 100 毫秒 + 7000 字节 * 0.12 毫秒/字节 = 940 毫秒 无法修改！

定义 DP 主站系统大小的实例 

此实例假定最大 CiR 同步时间为 400 ms。因此，图中给出的 DP 主站系统的最大完全组

态为 2500 个 I/O 字节（虚线）。如果打算将 CiR 对象中的 250 个输入字节和 250 个输出

字节留待以后使用，这样，可用于 DP 主站系统初始组态的字节数便为 2000 个字节。 

在实例中考虑了以下两组情况： 

● 如果对 ET 200M 站使用完全组态（128 个字节用于输入，128 字节用于输出，其中一

些可能在 CiR 模块中），则可以操作 2000/(128 + 128) 个（即，大约 8 个）ET 200M 
站。

● 如果每个 ET 200M 站通常需要 48 个字节（例如，6 个模拟模块，每个都有四个 2 字节

的通道，或是具有 CiR 模块的更小组态），因此可以操作 2000/48 个（即，大约 42 个）

ET 200M 站。

如果这样的组态满足不了要求，可按如下方法进行改进： 

● 使用更强大的 CPU（每字节处理时间更小的 CPU - 有关详细信息，可参考 CPU 的技

术规范）。

● 选择多个较小的主站系统，而不是一个大的主站系统。

● 选择一个或多个具有很大组态的主站系统和一个没有保证从站的 CiR 对象。在此类主站

系统中，只能在 CiR 框架内对现有模块的参数设置进行更改。选择在其中添加或删除从

站或模块（或是更改现有过程映像区分配）的其它小型主站系统。

错误显示

从验证开始直到 SDB 评估完成，INTF LED 会一直亮着。重新分配模块参数时，它也会亮

着。

完成 CiR 操作后，在预期的组态和实际的组态之间存在差异（由于将组态更改下载到 
CPU，所以更改了预期的组态）；因此 EXTF LED 亮起。如果更改组态时添加了从站，

则 BUS1F 或 BUS2F LED 也会闪烁。一旦完成相关的硬件更改，EXTF、BUS1F 和 BUS2F 
LED 便会再次熄灭。
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CiR 同步时间对操作系统功能的影响

在 CiR 同步时间期间，操作系统功能会作出如下响应：

操作系统功能 影响

过程映像更新 过程映像更新被禁用。过程输入及输出映像保持其当前值。

用户程序执行 所有优先级都被锁定，也就是说，不会对任何 OB 进行处理。所有输

出均保持其当前值。现有中断请求将被保留。只有在完成了 SDB 评
估之后，CPU 才会接受所发生的任何中断。

目标系统 定时器继续运行。日时钟、周期性中断和延迟中断的时钟继续运行，

但中断本身将被锁定。仅当 SDB 评估完成时才会接受这些中断。因

此，每个周期性中断 OB 最多可添加一个中断。

编程设备操作 在编程设备上只能使用 STOP 命令。不能进行数据记录作业。

外部 SSL 信息，

例如，通过 MPI。
信息功能将被延迟处理。
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9.17 组态 OS 功能

9.17.1 组态步骤概述

简介

PCS 7 操作站(OS)通过不同的子步骤进行组态。通过若干个 PCS 7 工具来执行组态：         

● 在 SIMATIC Manager 中

● 在 WinCC 项目管理器中

OS 的整个组态都是在工程系统中执行，这样便可集中管理所有组态数据。

根据项目的要求，组态中的某些步骤必须执行，而其它步骤为可选步骤。

有关 OS 功能组态的完整介绍，请参见《过程控制系统 PCS 7；操作站》手册。

在使用“用户可组态消息类别”功能时，请参见“用户可组态消息类别”部分中的信息。

下表初步概述了用户必须完成的各种组态任务。表中列示的顺序与建议的顺序一致。

SIMATIC Manager

组态任务 强制 可选

插入和组态 PCS 7 站  X；需要更多操作站时。PCS 7 向导会自动创

建 PCS 7 OS

组态 PCS 7 OS 的网络连接 X  

项目的访问保护  X

在工厂层级中插入画面 X  

AS-OS 分配 X  

创建块图标 X  

更改单元和操作员文本  X

定义归档变量 X  

在要将数据导出到 Process Historian 的 
OS 服务器上，启用“传送到外部归档服

务器”(Transfer to external archive server) 
选项 1)

 X；如果使用外部 Process Historian。

组态消息  X；如果要定义非标准消息
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组态任务 强制 可选

指定消息号范围 X  

定义消息优先级  X；对总览区消息行中的消息至关重要

通过“报警隐藏”指定隐藏消息  X；如果要在某个时间点隐藏单个消息

定义工厂代号 X  

定义 OS 区域 ID X2) X；OCM 属性

定义画面名称和画面层级  X；如果要定义非标准画面名称

设置更新例程：

● 更新 AS-OS 连接

● 更新 OS 区域标识符

 X

指定编译模式 X  

编译 OS X  

1) 还请将归档服务器分配给单工作站系统。

2) 工厂层级。

编译 OS

在 SIMATIC Manager 中完成了所有数据的 ES 组态后，必须先运行“编译 OS”功能，之

后再开始在 WinCC 项目管理器中组态 OS 数据。如果随后更改了 ES 组态，还必须编译 
OS。

OS “将可识别”所有来自 SIMATIC Manager 的数据（如变量、消息、文本以及硬件配置

和连接组态），以做进一步组态。

完成所有组态任务后

步骤 强制 可选

下载 OS 3) X  

3) 该功能不适用于 OS 单工作站系统。

WinCC 项目管理器

组态任务 强制 可选

设置对象属性  X

设置计算机属性  X
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组态任务 强制 可选

在 OS 项目编辑器中设置参数  X

如果要定义不同于默认值的设置

设置用户权限 X  

工厂可视化 – 初级：

● 插入动态对象

● 使用状态显示

● 使用扩展的状态显示

● 插入 I/O 字段

● 组态组显示

X

使用所需的对

象

 

工厂可视化 – 初级：

● 使用不是由 PCS 7 自动创建的面板和

块图标。

● 创建用户对象

● 创建用户对象模板

● 插入画面窗口

● 使用过程对象视图和交叉引用表

 X

在进行过程画面设置时，这些选项可提供有效支

持

计算组显示层级 X  

设置消息系统参数：

● 项目编辑器中的定义

● 报警记录中的设置

● 组态消息列表

● 组态声音信号生成器

 X

组态归档和日志 X  

设置

● 时间同步

● 设备状态监视

 

X

 

X

设置 PCS 7 维护工作站  X

在工程师站上激活 OS 过程模式

（“允许在 ES 上激活”(Allow activation on 
ES) 选项） 

 X
解锁项目在 ES 上激活后，对过程模式的本地激

活设置将无法撤消。

下载项目后直接在 OS 服务器/OS 客户端

上执行此任务：

● 激活项目

X  
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更多信息

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)。

9.17.2 设置 AS/OS 设备状态监视

简介

OS 的“设备状态监视”(Lifebeat Monitoring) 功能支持对连接到工厂总线的 AS 和 OS 进行

监视，使其在 PCS 7 中的正确运行。这意味着可随时了解工厂的最新概况。 

监视功能在声明为设备状态监视的操作员站中执行。

设备状态监视

设备状态监视用于监视所有 OS 服务器、OS 客户端和所有自动化系统。

要求：

所有要监视的组件均连接到集成网络，并分配给了设备状态监视。执行监视的周期可在组

态设备状态监视时指定。

设备状态监视在 WinCC 的“设备状态监视”编辑器中组态。

监视自动化系统

在自动化系统中，会在以下两种情况下生成过程控制消息：

● 设备状态监视从 AS 读取当前操作状态：检测到模式更改时（例如，从 RUN 更改为 
STOP），设备状态监视将生成控制系统消息。

● 设备状态监视将发送监视请求给 AS。只要电源中断、设备发生故障或连接中断，AS 便
无法再对此监视请求做出响应，此时将会生成过程控制消息。

过程模式下设备状态监视的显示

设备状态监视会为 OS 自动激活。对于 OS 是以 5 秒到 1 分钟的周期执行设备状态监视。
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错误消息将按如下方式显示：

● 设备状态监视一旦识别出组件发生故障，就会自动生成一条过程控制消息。

● 所有受监视组件的状态也会显示在一个单独的画面中，操作员可使用按钮组中的按钮显

示该画面。在此画面中，通过“划掉线”指示有故障的组件。此外，此画面中还会出现

文本形式的补充说明，例如：

– “有故障”(Failed)
– “服务器故障”(Server failed)
– “服务器已组态”(Server configured)

故障的消除也通过过程控制消息来指示。

更多信息

有关组态 AS/OS 设备状态监视的逐步操作说明，可参考组态手册《过程控制系统 PCS 7；
操作员站》(Process Control System PCS 7; Operator Station)。
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9.18 组态 BATCH 功能

简介

SIMATIC BATCH 是一个可用于规划、控制和记录不连续过程（也称为批生产过程）的 
PCS 7 软件包。   

具有可组态顺序控制系统的简单批生产过程通过 PCS 7 工程系统中包含的 CFC 和 SFC 工
具实现自动化。对于包含配方程序的要求更为苛刻的系统，使用 SIMATIC BATCH。 

采用 SIMATIC BATCH 时，将能以图形方式在操作站或单独 PC 上设计、修改和启动配方

结构。

组态任务涉及以下方面：

● 工程组态

● 权限管理

● 配方创建（离线）

● 过程模式

工程组态

批生产过程单元的组态与 S7-400 的基本工程组态一起进行，都是在工程师站中通过 
SIMATIC Manager 来完成（例如，阶段和操作类型、设备属性、用户数据类型、测量单

位）。

组态任务 强制 可选

工程系统 (ES) 中的批生产工厂组态 X  

编译批生产过程单元数据 X  

下载批生产过程单元数据到目标系统（BATCH 服务器、BATCH 
客户端） 

X  

在 BATCH 客户端读入批生产过程单元数据 X  

权限管理

SIMATIC BATCH 使用 PCS 7 集中用户管理功能。

组态任务 强制 可选

指定操作 SIMATIC BATCH 的用户权限 X  
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配方创建（离线）

通过使用 BatchCC 在所有 BATCH 客户端上读入批生产过程单元数据（工程组态数据）可

创建离线数据。使用 BatchCC 创建物料、公式类别和公式。可使用 BATCH 配方编辑器创

建库和主配方。通过发布主配方、库元素和公式，可随后在过程模式中加以使用。

组态任务 强制 可选

编辑原料 X  

创建和编辑主配方 X  

创建和编辑库操作  X
使用库时

验证配方 X  

批准配方以进行生产 X  

创建新的公式类别（仅限外部公式）  X

创建公式（仅限外部公式）  X

互连主配方和公式（仅限外部公式）之间的参数  X

过程模式

过程模式的第一阶段是批生产规划。产品订单即在此阶段创建。这些订单将分成可随后批

准和启动的批生产订单。实际批生产处理程序（设备阶段）是在自动化系统上运行，通过

批生产控制进行协调。 

批生产数据管理将使用单独的 WinCC 组件完成。批生产报告中所需测量值序列的数值从

测量值归档中获取，所有批生产相关消息都是从消息归档中过滤而得并显示在 BatchCC 
中。

组态任务 强制 可选

创建产品订单 X  

创建和编辑批生产 X  

批准批生产 X  

启动批生产 X  

编辑批生产时的操作员控制 X  

批生产报表 X  

归档批生产 X  
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更多信息

● SIMATIC BATCH 的在线帮助

● 手册《过程控制系统 PCS 7；SIMATIC BATCH》(Process Control System PCS 7; 
SIMATIC BATCH)
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9.19 组态 Route Control 功能

简介

SIMATIC 路径控制是 PCS 7 的一个软件包，用于实现工厂中原料的自动输送。

SIMATIC 路径控制搜索一条经过可用路径网络分段的路径并控制原料传输（例如，通过打

开阀和激活泵）。

SIMATIC 路径控制同时包括组态和运行系统，并提供了大量连接 PCS 7 基本系统及用户

程序的接口。

根据工厂设计，既可实现简单直接的输送过程，也可实现复杂的路径组合。

组态任务涉及以下方面：

● 工程

● 权限管理

工程

PCS 7 项目是包括数据存储的集中组态环境。

可组态以下内容：

组态任务 强制 可选

工厂层级（工厂、单元） X  

节点 X  

自动化系统 X  

交互项目 AS-AS 连接（工程工具：路径控制向导） X  

PC 站 X  

CFC X  

SFC X  

在 SIMATIC Manager 中启动以下 SIMATIC 路径控制工具：

● 路径控制向导

● 路径控制工程（组态接口）
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路径控制工程包括以下步骤：

组态任务 强制 可选

PCS7 项目中元件、路径、节点和自动化系统的传送 X  

组态功能目录和功能 ID X  

组态路径网络中的分段 X  

元素与各分段的互连以及功能等级的指定 X  

组态原料、原料组以及这二者之间允许的顺序关系 X  

权限管理

PCS 7 的集中用户管理功能用于 SIMATIC 路径控制。

组态任务 强制 可选

定义 SIMATIC 路径控制的用户权限（Windows 用户管理） X  

在安装 SIMATIC 路径控制之后，会创建 5 个用户组。将自动输入执行安装的用户。如果

需要更多用户，就必须将这些用户分配给用户组。

更多信息

● SIMATIC 路径控制的在线帮助

● 手册《过程控制系统 PCS 7；SIMATIC 路径控制》(Process Control System PCS 7; 
SIMATIC Route Control)
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9.20 组态与工厂管理级的连接 (OpenPCS 7)

9.20.1 如何组态 OpenPCS 站以访问 PCS 7 数据

简介

为了能够访问 PCS 7 数据，需要将 OS 服务器数据分配给 OpenPCS 7 站并下载组态数

据。       

要求

● 已创建 OpenPCS 7 站。

● 已输入 OpenPCS 7 站的目标路径。

步骤

1. 在 SIMATIC Manager 中打开项目，然后激活组件视图。

2. 在树形视图中选择 OpenPCS 7 站：
SIMATIC PC 站 > SPOSA 应用程序 > Open_PCS7_Station (SIMATIC PC-Station > SPOSA 
application > Open_PCS7_Station)

3. 选择菜单命令选项 > OS > 分配 OS 服务器... (Options > OS > Assign OS Server...)。
将打开“为 <OpenPCS 7 站的名称> 分配 OS 服务器”(Assignment of OS Server for <name 
of OpenPCS 7 station>) 对话框。

4. 选中 OS 服务器的复选框，以将其服务器数据分配给以上所选的 OpenPCS 7 站。

5. 单击“确定”(OK)。

6. 选择菜单命令“PLC > 下载”(PLC > Download)。

将组态并加载 OpenPCS 7 站。

组态数据通信

组态通过以下功能与 OPC 客户端应用程序进行数据交换：

● 通过 OPC（OPC 服务器的标准功能）进行数据交换。

● 通过 OLE DB（WinCC-OLE DB 提供程序的标准功能）进行数据交换。

更多相关信息，请访问以下链接：

服务和支持 (http://support.industry.siemens.com/cs) 
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OPC 基金会 (http://www.opcfoundation.org) 

说明

确保为 OPC 客户端应用程序设置了适当的访问保护。

更多信息

● “如何插入 OpenPCS 7 站 (页 281)”部分

● “通过 PCS 7 连接到 IT 世界 (页 108)”部分

● “OpenPCS 7 站的组态 (页 161)”部分

● 手册《SIMATIC NET；与 PG/PC 进行工业通信》(SIMATIC NET; Industrial 
Communication with PG/PC)

● 系统手册《SIMATIC HMI；OPC - 用于过程控制的 OLE》(SIMATIC HMI; OPC - OLE 
for Process Control)

● 手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 7; PCS 
7 - PC Configuration)

实施 PCS 7 组态

9.20 组态与工厂管理级的连接 (OpenPCS 7)

工程组态系统 (V9.0 SP1)
614 配置手册, 12/2017, A5E39221328-AC

http://www.opcfoundation.org


9.21 在分散编辑后合并项目（多项目工程）

概述

在分散编辑后合并多项目中的项目涉及以下主题：       

● 如何将分布式工作站上编辑过的项目移动到中央工程师站 (页 616) 

● 如何将不同项目的子网合并到多项目中 (页 617) 

● 如何合并交互项目连接 (页 618) 

● 如何在 AS 和 OS 之间组态新的交互项目连接 (页 619) 

使用 SIMATIC BATCH 进行多项目工程的规则

注意

在分布式工程师站上进行分布式工程组态的规则

对于使用 SIMATIC BATCH 的多项目工程，只有在满足了某些条件及采取了附加步骤的

情况下，才能在分布式工程师站上进行分布式工程组态（包括测试在内）。 
有关此主题的更多信息，可访问 Internet (https://support.industry.siemens.com/cs/cn/zh/
view/23785345)。 

多项目中外部归档服务器的规则

说明

在一个多项目中仅可组态一个外部归档服务器 (Process Historian)。  
在将一个多项目的多个分布式项目合并后，在该多项目中只能存在一个外部归档服务器。

当使用冗余归档服务器时，在多项目中只能有一个 PC 站充当归档服务器，另一个 PC 站
充当该归档服务器的冗余 PC 站。
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9.21.1 如何将分布式工作站上编辑过的项目移动到中央工程师站

要求

● 项目实际上位于分布式工程师站，且包含在多项目中。

● 可通过网络访问分布式工程师站。

步骤

1. 如有必要，请删除中央工程师站现有的同名（移动到分布式工程师站之前的版本）项目（备
份副本）。

2. 在 SIMATIC Manager 中使用菜单命令“文件 > 打开...”(File > Open...)，从中央工程师站打
开分布式工程师站上的项目。

3. 单击“浏览”(Browse) 按钮。

4. 转至“浏览”(Browse) 菜单，然后在“在目录中搜索”(Search in directory)字段中以 UNC 表
示法输入待移动项目的路径。

5. 单击“开始搜索”(Start search)。
项目将显示在“用户项目”(User projects) 选项卡中。

6. 在此选项卡中选择所需项目，然后单击“确定”(OK)。
项目随即打开。

7. 当工程师站上安装了 SIMATIC PDM 时：
在操作系统信息区域中的任务栏中停止 PdmAssetService。

8. 选择菜单命令“文件 >另存为...”(File > Save as ...)。

9. 进行以下设置：

– 清除“使用重组（慢）”(With Reorganization (slow))复选框。

– 选中“添加到多项目”(Add to multiproject) 复选框。

– 在相应的下拉列表中选择“当前多项目”(Current multiproject) 条目。

– 选中“替换当前项目”(Replace current project) 复选框。

10.单击“确定”(OK)。

结果

将会在中央工程师站上的多项目中创建与分布式工程师站项目完全相同的副本。原始项目

保留在分布式工程师站上，并且可能作为备份仍留在那里，或是被删除。
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在项目中应用 SIMATIC PDM

当工程师站上安装了 SIMATIC PDM 时：

可以再次启动 PdmAssetService。
建议：使用“允许自动启动/停止”(Allow automatic start/stop) 选项启动 SIMATIC PDM 
Asset 服务。

规则

说明

必须先删除或重命名中央工程师站上的该备份，才能将所复制的项目复制回其原来位置（同

一目录名称）。更多相关信息，请参见以下部分：“如何将项目移动到分布式工程师站 
(页 339)”

说明

如果已使用“删除以编辑...”(Remove to edit...) 功能将项目移除，且假定可通过删除项目

时使用的相同路径来访问该项目，则还可以将其移回到中央工程师站：

1. 在中央工程师站上选择标有“为进行编辑而删除的项目”(project removed for editing) 的项目
（呈灰色）。

2. 选择菜单命令“文件 > 多项目 > 编辑后重新应用...”(File > Multiproject > Reapply after 
Editing...)。
会将项目从分布式工程师站重新移回中央工程师站上的多项目中。

更多信息

● “如何将分布式工作站上编辑过的项目移动到中央工程师站 (页 339)”部分

9.21.2 如何将不同项目的子网合并到多项目中

简介

如果在多项目中使用交互项目网络，必须将项目中的网络合并回多项目中。 

要求

可以对参与项目及其子网进行写访问。 
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步骤

1. 在 SIMATIC Manager 中选择所需多项目

2. 选择菜单命令“文件 > 多项目 > 同步项目...”(File > Multiproject > Synchronize Projects...)。
将打开“同步多项目 <xxx> 中的项目”(Synchronize Projects in Multiproject <xxx>) 对话框。

3. 转至左侧窗口，选择要连接的以太网，然后单击“执行”(Execute)。
将打开用于合并/分隔子网的对话框。

4. 在左侧区域选择子网并单击“->”。
所选子网将合并到所选的综合网络中。

5. 按照项目要求更改交互项目网络的默认名称（双击该名称）。

6. 对要合并的所有子网执行相同的步骤。

7. 单击“应用”(Apply)，然后单击“关闭”(Close)以关闭对话框。

可在同一对话框中也可分隔开那些已经合并的网络。

在此对话框中，还可以创建新的交互项目子网（“新建”按钮）。

检查一致性

在合并子网之后及下载到 NetPro 之前，使用菜单命令“网络 > 交互项目一致性检查”
(Network > Check Cross-project Consistency) 检查整个多项目是否一致。

9.21.3 如何合并交互项目连接

步骤

可按如下所述合并交互项目连接：

● 在 SIMATIC Manager 中同步多项目中的项目时，使用菜单命令“文件 > 多项目 > 同步

项目...”(File > Multiproject > Synchronize Projects...)。

● 在 NetPro 中使用菜单命令编辑 > 合并连接...(Edit > Merge Connections...)。
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执行

执行中会发生以下变化： 

SIMATIC Manager NetPro
● 在 SIMATIC Manager 中，只有合并的

连接才会在项目中使用相同连接名称（引

用）组态为“其它项目中的连接伙伴”。

● 在 NetPro 中，还可以分配具有相似或不

同连接名称的连接。

● 在 SIMATIC Manager 中进行合并时，

无法预见哪个连接伙伴会保留连接属性、

哪个连接伙伴会修改其连接属性（例如，

建立活动连接）。

● 在 NetPro 中进行合并时，伙伴始终会使

其连接属性与本地模块的属性相适应。除

此之外，在 NetPro 中还可以在用于合并

连接的对话框中更改连接属性。

● 在 SIMATIC Manager 中，会忽略与未

指定伙伴的 S7 链接。

● 在 NetPro 中，可以将与未指定伙伴的 S7 
连接合并到交互项目 S7 连接。

更多信息

● STEP 7 的在线帮助

● “如何合并交互项目连接 (页 458)”部分。

9.21.4 如何在 AS 和 OS 之间组态新的交互项目连接

简介

在 AS 和 OS 组件之间组态交互项目连接的方式与在 AS 组件之间组态交互项目连接的方

式相同。

要求

● 已在多项目级合并了所涉及的网络。

相关信息，请参见“如何将不同项目的子网合并到多项目中 (页 617)”部分。

● 已指定 AS/OS 分配。

有关此主题的更多信息，请参见“如何指定 AS/OS 分配 (页 295)”部分。

步骤

在 AS 和 OS 组件之间创建交互项目连接时，与“多项目中的交互项目连接 (页 456)”部

分所述步骤相反，应在不同项目中选择连接伙伴。
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有关工厂工程组态的数据交换 10
10.1 数据交换概述

PCS 7 与 COMOS 之间的数据交换

借助数据交换接口（自动化接口），可以将工厂规划阶段在 COMOS 中生成的自动化相关

数据转换成 PCS 7 数据。PCS 7 硬件配置来源于电气样品规划 (EMSR) 中的电路图。将

基于功能图中的数据生成 PCS 7 过程变量，分配其参数并将其与信号互连。

同时会同步工厂层级、过程变量实例和硬件配置，包括符号表。 

与 PCS 7 进行数据交换允许 COMOS 中的规划状态与 PCS 7 的当前项目状态同步，从而

可确保 COMOS 中工厂文档的一致性。

更多相关信息请参见 COMOS 规划工具手册。

PCS 7 与 AdvES 之间的数据交换

高级工程组态系统 (AdvES) 可对信号列表或过程变量列表中的数据进行预处理，以适合

在 PCS 7 工程组态系统 (ES) 中使用。经过预处理的数据将直接传送到 PCS 7。此外，

AdvES 可以在表格视图中大量处理工程组态数据。       

在 PCS 7 中生成工厂层级、具有信号和参数设置的过程变量以及硬件配置。

以大量数据处理为例，控制模块的多个实例可通过组态的控制模块类型来创建。有关此主

题的更多信息，请参见“控制模块及类型概述 (页 506)”部分。

更多信息，请参见手册《过程控制系统 PCS 7；高级工程组态系统》(Process Control 
System PCS 7; Advanced Engineering System)。

PCS 7 与 Excel 之间的数据交换 

在 PCS 7 中的所有编辑器和过程对象视图中，可以将所选的内容复制、粘贴到 Excel 中，

经过编辑后再以同样方式送回。         

也可用同样的方式与 Access 交换数据。
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导入/导出功能 

所有的 PCS 7 工程组态系统的基本应用程序都有导入/导出接口。使用导入/导出接口具有

以下优势： 

● 工厂规划数据可以与控制系统工程组态数据同步。这就是控制系统工程组态和工厂工程

组态可以同时独立编辑的方法。

● 来自工程组态系统的数据可作为模板导出，在外部程序（例如 MS Excel）中有效地复

制和修改，然后导回工程组态系统中。这样可以优化重复或相似工厂信息的组态过程。

更多信息

有关导出和导入工厂信息的详细信息，请参见： 

● 导入及重用工厂数据 (页 208) 

● 可导入数据和数据格式 (页 143)。

● 使用过程变量和模型 (页 625) 

● 导入/导出硬件配置 (页 645) 
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10.2 确定重复功能

简介

大量数据处理的起始点是确定重复功能。     

工厂的功能单元

通常是通过将工厂划分成更小的可分类功能单元（例如，固定设定值控制或电机控制器）

来使其结构化。

您可以创建现成的功能单元库，然后根据新情况进行复制和修改，而不必每次在需要新功

能单元时再实现操作。 

如同工厂的功能单元一样，在 ES 中组态您熟悉的过程变量类型或模型对象，通过导入/导
出方式来创建任意数量的过程变量或副本。

指定过程变量类型和模型

为工厂定义过程变量类型和模型。 

请参见 PCS 7 高级过程库，以确定可在项目中使用哪些预编译的过程变量类型。或通过 
CFC 创建自己的过程变量类型和模型。

更多信息

● “如何从 CFC 创建过程变量类型 (页 510)”部分

● “如何创建和编辑模型 (页 555)”部分
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10.3 使用导入/导出助手（IEA）

说明

导入/导出助手 (IEA) 是 PCS 7 中的独立附加软件包，需要独立的许可证密钥。

IEA 随 PH 和过程对象视图一起在《过程控制系统；SIMATIC PCS 7》(Process Control 
System; SIMATIC PCS 7) DVD 中提供，并且也会随它们一起安装。 

什么时候使用 IEA？

在进行工厂规划期间，创建了各种各样的数据，但常常未规划明确的控制系统。通过使用

导入功能，可向控制系统工程组态提供此数据。             

如果需要在一个项目中多次使用多个模型或过程变量类型时（处理大量数据），并且希望

能够方便地修改各个块的参数描述，这时可使用 IEA。

使用 IEA

下图将以某个模型为例显示 IEA 的功能。
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10.4 使用过程变量和模型

概述

在导入/导出向导中使用过程变量类型和模型包括以下主题：         

● 组态中的要求和步骤 (页 625)

● 用于使用过程变量和模型的功能 (页 628)

● 如何创建导入文件或将其分配给过程变量类型 (页 513)

● 导入期间发生了什么？ (页 631)

● 如何导入过程变量类型和模型 (页 633)

● 导出期间发生了什么？ (页 635)

● 如何导出过程变量类型和模型 (页 636)

● 关于 IEA 的限制 (页 637)

10.4.1 组态中的要求和步骤

要求

已在主数据库中创建了过程变量类型和/或模型。           

组态任务概述

步骤 内容 在以下部分中描述

1 创建过程变量类型/模型 如何从 CFC 创建过程变量类型 
(页 510) 

如何创建和编辑模型 (页 555) 

2 将导入文件分配给过程变量类型/模型 - 
创建导入文件 

如何创建导入文件或将其分配给过程变

量类型 (页 513) 

如何创建和编辑模型 (页 555) 

3 使用 IEA 文件编辑器编辑导入文件 使用 IEA 文件编辑器创建/编辑导入文

件 (页 639) 
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步骤 内容 在以下部分中描述

4 导入过程变量类型/模型 如何导入过程变量类型和模型 (页 633) 

5 可选：将实际参数传送给过程变量和副

本

（仅限尚未使用 IEA 文件编辑器补充数

据时。）

 

IEA 如何运行

下图将通过“过程变量类型”的示例来说明助手的功能。

模型序列同样以灰色表示。
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启动 IEA

选择层级文件夹后，在 SIMATIC Manager 中的工厂视图或过程对象视图中启动导入/导出

助手。（也可选择过程变量类型中的个别过程变量。）

在“选项”(Options) 菜单中，选择命令“过程变量”(Process tags) 或“模型”(Models)，然

后在下一个子菜单中选择所需的功能。

更多信息

● PH、IEA 和 PO 的在线帮助

10.4.2 用于使用过程变量和模型的功能

简介

通过导入/导出助手 (IEA)，可以处理过程变量类型及其过程变量或模型以及它们所有实例。

IEA 提供了用于重用和修改过程变量类型/模型的功能。         

创建时使用的功能

助手 向导的功能

创建/更改过程变量类型 使用助手执行以下功能：

● 从现有 CFC 创建过程变量类型，然后将其存储在主数据库中。

● 在现有过程变量类型中添加/删除 I/O 消息。

● 检查现有过程变量是否偏离过程变量类型，如果偏离，则将它们同步。

创建/修改模型 使用助手执行以下功能：

● 使用先前通过 CFC/SFC、OS 画面、OS 报表等创建的 PH 对象，创建一个

用于在主数据库中存储的模型。

● 在现有模型中添加或删除 I/O 消息。

● 创建和分配导入文件。

● 检查模型与已分配的导入文件的一致性。

● 检查已更改 IEA 标记的副本。

所选 I/O 和消息都分配到导入文件的某列中。可在所有数据都输入导入文件后启

动导入。
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从工厂规划导入数据

工厂中的每个功能单元都与导入文件中的一行相对应。IEA 为每个功能单元复制相应的模

型（创建副本）或过程变量类型（创建过程变量）。它会根据导入文件中相应行的内容，

更改它们的互连/参数描述和消息文本。

导入时，可决定是否要在符号表中输入导入的信号（选项：“也在符号表中输入信号”(Also 
enter signals in the symbol table)）。对于 PCS 7，建议不要使用该选项，因为这些条目

是在使用 HW Config 配置硬件时完成的。

助手 向导的功能

导入过程变量 使用助手，可从过程变量类型创建过程变量，并将数据从导入文件导入到过程变

量。 

将过程变量类型从主数据库复制到相关的目标项目。然后，导入数据。 

结果是，将过变量作为过程变量类型的副本导入到导入文件的每一行。导入文件

的数据写入到相应的 I/O 或过程变量块。

导入模型 使用助手，可创建模型副本，并将数据从导入文件导入到副本中。 

在多项目中，将模型作为副本从主数据库复制到指定目标项目。然后，导入数

据。

结果是，将模型的副本导入到导入文件的每一行。导入文件的数据写入到相应

的 I/O 或副本块。

过程变量：分配/创建导入

文件

使用助手执行以下功能：

● 将导入文件分配到过程变量类型

● 检查导入文件到过程变量类型的分配

● 为过程变量的导入文件创建模板

为工厂规划导出数据

模型的副本或过程变量类型的过程变量已经过修改，例如，在测试和调试控制系统期间。

这也包括工厂规划期间使用其它工具组态并为控制系统工程组态导入的数据。 

以下应用程序选项用于导出此数据：

● 如果要将工厂文档与当前已组态状态同步，则将先前在导入过程中所创建模型的当前数

据以先前导入时的同样格式导出。

● 可将使用模型副本或过程变量组态的工厂数据导出。然后可以使用 IEA 文件编辑器或其

它工具（例如 MS Excel 或 Access）编辑并重新导入该数据。可以简单而快速地对项目

进行修改。
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助手 向导的功能

导出过程变量 可通过助手导出过程变量的数据。在多项目中，包含所有可用的项目。

这将为每个过程变量类型都生成一个导出文件，而且文件的每一行对应相应过程

变量类型的一个过程变量。

有效导入文件必须进行分配。单独列组以与导入文件中的列标题和名称的相同数

量组织结构。

导出模型 通过助手可导出模型副本的数据。在多项目中，包含所有可用的项目。

最终会生成一个模型导出文件，其中每一行都对应一个模型副本。

有效导入文件必须进行分配。单独列组以与导入文件中的列标题和名称的相同数

量组织结构。

规则

● 使用导入/导出助手的“导入/导出”功能时，在模型中可能包含更深层的层级文件夹。

● 如果画面层级来自 PH，则每个层级文件夹仅存在一个 OS 画面。

● 如果模型包含嵌套的层级文件夹，将无法对其重命名。

更多信息

助手 向导的功能

过程变量：同步 通过助手可以同步过程变量类型与过程变量。

修改过程变量类型时，项目中的过程变量将自动进行相应更改。

如果在自动同步期间，无法访问项目中的所有过程变量，则在过程变量类型和过

程变量之间将形成不一致。应通过显式同步消除不一致。 

提示

说明

为使图表更加简明，将不需要的模型块 I/O 切换到“不可见”(invisible)。
如果以后在 IEA 中编辑，将看到在过程对象视图的 CFC 中设置的选择，并可根据需要在

其中进行更正。以上内容同样适用于在模型中的选择。 
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参见

如何从 CFC 创建过程变量类型 (页 510)

如何创建和编辑模型 (页 555)

10.4.3 导入期间发生了什么？

导入步骤的说明 - 使用“模型”（Model）示例

过程变量和模型的导入方式相同。       

组态模型并向其分配导入文件后，可以启动导入步骤。将自动执行以下步骤：

1. 在导入文件的第一个数据行中的“层级”（Hierarchy）列中读取层级路径。检查路径的可
用性。根据测试结果进行附加操作：

– 如果层级文件夹已经作为模型的副本存在，则将对其应用导入文件的参数设置。

– 如果层级文件夹已经存在并适于成为副本，则将它与其 CFC 一起组成模型的副本，

并根据导入文件为其分配参数。

– 如果层级文件夹不存在，则创建一个。然后，创建模型副本并为其分配相应的参数。

2. 如果列可用，则以下元素将输入到图表文本字段：

– 功能标识符 (FID, Function identifier)
– 位置标识符 (LID, Location identifier)
– CFC 名称

– 图注释 (Chart comment)

3. 参数描述和互连描述（信号）的文本和值写入副本的相应块或图表 I/O 中。

说明

当信号名称（符号或文本互连）由代码字“---”（三个短划线）组成时，则删除一个互

连。

如果未指定互连名（符号或文本互连），则互连保持不变。
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4. 确定信号的 I/O 数据类型，并将其分配到互连。

说明

通过共享地址进行互连的规则如下：如果已设置“在符号表中包括信号”(Include signal 
in the symbol table) 选项，则可以在模型的资源符号表中找到名称。 
对于 PCS 7，建议不要使用该选项，因为这些条目是在使用 HW Config 配置硬件时完

成的。

请注意以下规则： 
– 符号名称存在于符号表中

数据类型必须相同；符号名称可能只存在一次。根据块/图表 I/O 向数据类型分配参

数。绝对地址被覆盖，并为符号输入符号注释（如在导入文件中可用）。仅覆盖更

改的信息，保留现有属性。

– 符号名称在符号表中尚不可用

创建互连并根据 I/O 向数据类型分配参数。为符号输入绝对地址和符号注释（如在导

入文件中可用）。

5. 导入每个消息的消息文本。

6. 为导入文件中的每一行执行第 1 步至第 5 步。

如果已经选择包含多个模型的层级文件夹，则输入文件将和模型一起出现在列表中。根据

需要，还可以编辑列表。随后，如上所述为列表中所有模型启动导入。

导入日志中的错误消息

在以下情况下会在导入日志中生成错误消息：

● 层级路径中包含不属于模型的副本，即，存在过多或过少的 I/O 点和/或块未被识别为或

错误地识别为信号发送块。

● 如果某个模型位于层级路径中

● 如果工厂层级中的设置与导入的层级路径不匹配

● 如果符号表中的信号不唯一或者将用错误的数据类型写入
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10.4.4 如何导入过程变量类型和模型

顺序

为过程变量或模型使用助手以导入以下数据：         

● 过程变量类型数据

从主数据库中将过程变量类型作为过程变量复制到指定目标项目中，随后导入数据。根

据导入文件中的条目数，可以创建任意数量的过程变量。

导入结果是，根据指定的层级路径，在目标项目中为导入文件的每一行创建此过程变量

类型的过程变量。

● 模型数据

从主数据库中将模型作为副本复制到指定目标项目中，随后导入数据。根据导入文件中

的条目，可创建任意数量的副本。

说明

导入过程变量或模型时，可以决定是否要在符号表中输入导入的信号（选项：“也在符

号表中输入信号”(Also enter signals in the symbol table)）。 
对于 PCS 7，建议不要使用该选项，因为这些条目是在使用 HW Config 配置硬件时完

成的。

说明

导入前，检查显示的语言设置。如果使用德语创建模型，而 SIMATIC Manager 中的当

前设置为“英语”(English)，则德语消息文本将写成英语文本文件。

步骤

1. 选择所需的层级文件夹、项目节点或过程变量库（主数据库中的层级文件夹），或过程变量
类型。

2. 选择菜单命令“选项”(Options) >“模型”(Models) >“导入...”(Import...) 
或“选项”(Options) >“过程变量”(Process Tags) >“导入...”(Import...)。
向导会搜索模型/过程变量类型及相应的导入文件（也会在所有层级子文件夹中搜索）并将
其列出。导入功能将对所有列出的导入文件执行导入。

3. 如果不想导入某些文件，可选择这些文件，然后使用“删除”(Remove) 按钮从列表中将其删除。
单击“其它文件...”(Other File...)，可搜索不同的导入文件，然后选择该文件，而非其它文
件。

4. 单击“继续”(Continue)，然后单击“完成”(Finish)。
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结果

开始执行实际的导入过程。根据“在日志中仅显示错误和警告”(Only show errors and 
warnings in log) 复选框的设置，在日志窗口中会显示导入活动的完整列表或仅显示出现的

错误。

日志保存在日志文件中。文件的名称和路径会出现在日志窗口的下面。可以使用“其它文

件”(Other File) 按钮修改此设置。 

在下图中，模型及其副本都将按照它们在 SIMATIC Manager 中的显示进行显示。

过程变量类型/模型的导入变形

● 第一次导入过程变量类型/模型

第一次导入过程变量类型或模型时，将根据导入文件中的条目在 PH 中创建过程变量/副
本并为其分配参数。

● 导入附加的过程变量类型/模型

如果再次导入过程变量类型或模型，将由在 IEA 文件中指定的参数、信号和消息覆盖首

次导入期间复制的 I/O（导入更改），并且创建那些尚未存在的内容。
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● 在导入期间删除副本/过程变量

可以决定在导入期间是否删除或覆盖模型的现有副本或过程变量类型的过程变量。使用

导入模式“删除”(delete)（在导入文件的“ImportMode”列中），可删除副本/过程变量。

随后会出现消息，指示删除是否成功。

说明

导入时，首先处理所有包含关键字“delete”的行，并删除主题。完成后才创建新对象。

如果已创建与副本的互连，这些互连都将丢失。

● 重新导入过程变量类型/模型

如果导入时未修改模型或过程变量类型，则将由在 IEA 文件中指定的参数、信号和消息

覆盖先前导入期间复制的 I/O（导入更改）。

将 CFC 重新分配到过程变量类型（采用）

如果在项目中包含不再作为或尚不作为过程变量（例如，因为对于过程变量类型的分配已

取消）但具备成为过程变量的条件的 CFC，则可将这些图表作为过程变量分配到过程变量

类型。

相关信息，请参见“如何采用过程变量 (页 517)”部分。

以上原则同样适用于采用模型。

10.4.5 导出期间发生了什么？

导出过程的说明 - 使用“模型”示例

过程变量和模型的导出方式相同。   

在 SIMATIC Manager 中通过导入或复制创建了模型副本后，例如，在测试和启动期间已

编辑了不同的参数值和信号值，即可以当前数据导入时的相同格式将其导出。如果直接为

某个模型或副本启动导出功能，将自动执行以下步骤：

1. 识别此模型的所有副本
在导出文件中，为找到的每个副本创建一个数据行。

2. 在导出文件中，输入标识符 LID、FID 和图表名称。

3. 参数描述和互连描述（对于找到的每个模型）将写入文件的相应单元中。
如果是与共享地址的互连，则将基于符号表中互连名（符号名称）标识互连描述并将其写入
文件的相应单元中。

4. 确定块消息并将其写入文件的相应单元中。
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如果已经选择包含多个模型的层级文件夹，则导出文件将和找到的模型一起出现在列表中。

根据需要，还可以编辑列表。最后，如上所述为列表中的所有模型启动导出。

导出日志中的错误消息

如果 I/O 点缺失或副本中的 I/O 点过多，则会在导出日志中看到错误消息。

10.4.6 如何导出过程变量类型和模型

选项

可使用助手导出模型数据或过程变量。可使用以下选项：             

● 单独选择一个模型/过程变量类型，以单独将其导出。

● 为导出所有较低级别的模型（副本）或过程变量，可选择较高级别的层级文件夹或项目

节点。

最终会生成一个导出文件，其中每个找到的模型副本或过程变量类型的每个过程变量都有

一行。

导出文件的结构与导入文件的结构相对应。

步骤

1. 选择所需的层级文件夹、项目节点和/或过程变量库（主数据库中的层级文件夹），或过程
变量类型。

说明

选择副本后，经提示转到主数据库中的相应模型。

2. 选择菜单命令“选项 > 模型 > 导出...”(Options > Models > Export...) 或
“选项 > 过程变量 > 导出...”(Options > Process Tags > Export...)。
向导将搜索模型/过程变量，并将其列出。

3. 下一步，将导出文件分配到显示的模型/过程变量或修改现有分配。
要更改已分配文件的名称，可以单击“其它文件...”(Other file...) 选择其它文件或输入新文件
名。

4. 在对话框中的最后一步，可选择日志文件或激活/禁用过滤器，以便仅记录错误消息和已完
成消息。

5. 单击“完成”(Finish)。
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结果

导出过程启动。在导出期间，将覆盖所有现有导出文件。

重复导出

通过多次导出模型/过程变量，可创建多个导出文件（副本）。导出期间，必须修改已分配

导出文件的名称。如未更改文件名称，将覆盖具有相同名称的导出文件。

10.4.7 关于 IEA 的限制

对于修改的限制

不能通过 IEA 属性在 CFC 中对图表/图表 I/O 进行以下修改，因为这些修改会阻止导入或

导出。     

● 重命名嵌套图表（在模型的图表中包括的具有图表 I/O 的图表）。

● 删除嵌套图表。

● 更改图表 I/O 的数据类型

● 修改带 IEA 标记的图表 I/O（或过程变量的 I/O 点）的相对顺序，例如，通过插入或删

除图表 I/O（不带 IEA 标记）来更改顺序。

● 如果模型中包含嵌套的层级文件夹，切勿修改嵌套文件夹的名称。

进行上述修改将在错误日志中生成错误。
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10.5 使用 IEA 文件编辑器创建/编辑导入文件

10.5.1 ES 中的 IEA 文件数据

简介

以下部分介绍了如何利用 IEA 文件编辑器创建和编辑导入/导出文件（IEA 数据）。该描述

包括以下主题：

● 使用 IEA 文件编辑器创建/编辑导入文件 (页 639)

● 与 MS Excel/Access 交换数据 (页 641)

● IEA 文件的结构 (页 642)

工程系统中的 IEA 文件 

下图显示项目对象和导入文件数据之间的关系。
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10.5.2 使用 IEA 文件编辑器创建/编辑导入文件

IEA 文件编辑器

导入/导出助手（IEA）以固定格式使用导入/导出文件。工厂规划工具如 SIGRAPH EMR 
支持此格式。导入/导出助手会安装 IEA 文件编辑器，使您能够很容易地创建和编辑导入文

件而不需求助于工厂规划工具。使用 IEA 文件编辑器编辑导出和导入文件，将确保符合组

态导出和导入文件的规则。     

IEA 编辑器“s7jieaEx.exe”是独立的应用程序，也可不依赖 PCS 7 安装来使用。可复制该

程序供工厂规划员使用。 

编辑器应用情形 - 使用示例“过程变量”/“模型”

IEA 文件编辑器用于以下情况：

● 已经创建过程变量类型/模型，并通过 IEA 创建了导入文件。您想要使用此导入文件来

创建模型或过程变量的副本。根据副本/过程变量的数量，导入文件中的行数必须相应增

加（例如，通过复制和编辑）。

● 已经创建过程变量类型/模型，并通过 IEA 创建了导入文件。要更改此模型，例如通过

包括更多的 I/O，因而需要通过添加这些列来扩展导入文件。

● 您没有可用来创建导入文件的工具，希望将 IEA 文件编辑器作为规划工具以创建导入文

件的列、列组和行以及相应的值。

● 要将导入文件与导出文件相比较（或将导出文件与导入文件相比较）。通过在 IEA 文件

编辑器的窗口中打开两个窗口并进行排列，将很容易进行所需比较。
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IEA 文件编辑器的外观

IEA 编辑器显示为一个具有列和列标题的表。某些列组合成列组，例如，具有以下列标题

的列组成图表的列组：“ChName”和“ChComment”。

列组的名称如果与导入文件的列标题重合，则可以进行更改。如果只想使用有限数量的导

入选项，则可以删除列组中的列。如果删除列组中的所有列，则此 I/O 点将丢失；即，IEA 
文件不再与该模型匹配。

行标题中包含行号。标记行标题时将选择整行（例如要进行复制）。

IEA 文件编辑器还提供了所有标准的编辑器功能（复制、粘贴、保存等）。 

为能够插入列组，所有的列组类型（常规、图表、参数、信号、消息）在子菜单中定义，

并且还在工具栏作为按钮提供。

也可向“常规”(General)、“图表”(Chart)、“参数”(Parameter)、“信号”(Signal) 和“消

息”(Messages) 列组中添加新列。在扩展对话框中，仅提供在该列组中未曾使用的列标题。

通过菜单栏中的菜单命令或工具栏中的按钮，可选择所有可能的功能。

否则，编辑器的结构与导入/导出文件（IEA 文件）的结构一致。

启动 IEA 文件编辑器 

1. 启动 IEA 文件编辑器
将打开 IEA 编辑器

2. 打开 IEA 文件。

在编辑器表中操作

使用 IEA 文件编辑器与使用其它 Windows 应用程序（例如 MS Excel）的方法一样。 

可使用以下功能：

● 使用箭头键和 <Tab> 键在文件中浏览。

● 使用 <Return> 键完成输入并移动到下一行。

● 可选择整列和整行。

● 可更改或优化列宽。
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● 使用剪切、复制和粘贴功能，可通过剪贴板从表中向所选单元一次或多次插入单元内

容。

● 可使用“查找/替换”功能。

更多信息

● PH、IEA、PO 和 IEA 文件编辑器 的在线帮助

10.5.3 如何使用 MS Excel/Access 交换数据

简介      

可将导入/导出数据（IEA 文件）用作 CSV 格式的文本文件。许多应用程序（MS Excel、
MS Access 等）都支持 CSV 格式，因此该格式适于用作工程工具和 ES 之间的常规数据

接口。在 IEA 中，这些文件应具有扩展名 *.iea。可能需要更改扩展名。 

CSV（Comma Separated Value，逗号分隔值）是用于存储以表的形式组态的数据的 ASCII 
文本格式。分隔单元的字符取决于操作系统的“区域和语言选项”（德语：分号）；通过

按 Enter 创建新行。 

可以使用电子表格程序（例如，MS Excel）创建和编辑 CSV 文件，或者如同来自数据库

（dBase、Access 等）中的导出文件那样进行创建和编辑。也可使用 IEA 文件编辑器很方

便地编辑文件（带扩展名 *.iea）。

使用 MS Excel 编辑文件

1. 将文件扩展名从 *.iea 更改为 *.csv。

2. 启动 MS Excel。

3. 选择“文件 > 打开...”(File > Open...) 菜单命令，并打开 CSV 文件。
该文件将打开；文件内容完全如它在 IEA 文件编辑器中显示的那样进行显示。

说明

通过双击方式打开 CSV 文件时，文件内容不以表格形式在 Excel 中显示。

所有单元都应设置为“文本”格式，否则信息将不会正确显示。示例：数字字符串

“1.23”可能显示为“23 Jan.”。

4. 编辑文件，然后保存。

5. 将文件扩展名从 *.csv 更改为 *.iea。

6. 根据需要，可在 IEA 文件编辑器中进行其它更改并/或通过 IEA 导入文件。
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与 MS Excel 交换数据

可以使用 IEA 文件编辑器很方便地编辑文件（带扩展名 *.iea）。编辑器也提供剪切、复制

和粘贴功能以及查找和替换功能。如果需要更高级的功能，则使用 Excel。 

请按以下步骤操作：

1. 启动 IEA 文件编辑器，然后打开所需文件。

2. 启动 Excel 并创建新文件。

3. 在 IEA 文件编辑器中选择表中所需区域并进行复制。

4. 将复制的区域粘贴到空 MS Excel 文件中。

5. 在 MS Excel 中编辑数据。

6. 在 MS Excel 中选择并复制数据。

7. 在 IEA 文件编辑器中，将已复制的数据粘贴到 IEA 文件。

10.5.4 IEA 文件的结构

导入/导出文件（IEA 文件） 

可以使用 IEA 文件编辑器很方便地编辑导入文件（带扩展名 *.iea）。导入文件是 CSV 文
件，可使用电子表格程序 (MS Excel) 创建和编辑，或者如同来自数据库（dBase、Access 
等）中的导出文件那样进行创建和编辑。     

要使用表或数据库程序进行编辑，必须熟悉下述的文件结构。

文件结构

对于每个 I/O 和消息，必须存在一个列组。

行 含义

 0 在第一个标题前面，会有一行注释（以“#”或“//”开头），其中包含版本号和创建日期。

 1 第一个标题行包含列组的标题。

 2 第二个标题行包含列标识符。此信息通知导入/导出助手如何解释列。在所有语言的版本中，这些

标识符相同。

 3 第三个标题行包含相关已标记 I/O 的关键字。用于确定将为此 I/O 导入哪些数据。并非必须输入全

部关键字，只有第一个关键字必须输入。

 4-x 接下来的行包含数据。每个副本或过程变量都对应一行。导入期间，每行在指定层级文件夹中生

成模型的一个副本。过程变量在层级文件夹中创建。
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示例：测量值采集

在以下实例中，为便于阅读，IEA 文件以表格的形式显示，三个标题行中的文本以“粗体”

显示。在每列条目的开始和结束位置，都缺少引号。 

仅可编辑包含数据的区域而不能编辑标题行。

由于这是纯 ASCII 文本，因此不能设置原始文件的格式（例如，插入空格、制表符或使用

粗体格式）。 

通过 IEA 文件编辑器，可将 IEA 文件以具有格式的表格进行显示及编辑。 

Projec
t;

Hierarchy; FID; LID; Chart; High limit; Measured value Alarm high

Prj; H\; F; O.; C|; P|; S|; M|

; ; ; ; ChName|
ChComment;

Value| 
ConComment
|
S7_shortcut|
S7_unit;

SymbolName|
SymbolComment|
ConComment|
S7_shortcut|
S7_unit;

Event|

Pro_A V12\RA1\P01
;

; ; P01|Internal 
pressure;

90|Com.| 
OG|mbar;

Tpress|ComS.| 
ComA.|PK|mbar;

Int. 
pressure 
too high

Pro_A V12\RA1\P02
;

; ; P02|External 
pressure;

8.5|Com.|
OG|bar;

Apress|ComS.|
ComA.|PK|bar;

Ext. 
pressure 
too high

Pro_A V12\RA2\T01
;

; ; T01|Temp contr 80|com.|
OG|degC;

Mtemp.|ComS.| 
ComA.|MT|degC;

Temperatu
re 
exceeded

Pro_B V12\RA2\T02
;

Delet
e
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列组的说明

● “项目”(Project)
“项目”(Project) 列组包含在其中存储副本或过程变量的多项目中目标项目的名称。

● “层级”(Hierarchy)
即使单个层级文件夹未使用该名称，“层级”(Hierarchy) 列组也包含完整的层级路径。

导入期间，如果层级文件夹尚未存在，则由此创建层级文件夹（模型的副本或过程变

量），并将模型内容/过程变量（图表等）的内容复制到新的层级文件夹中。导出期间，

会输入所有现有模型副本。

使用过程变量时，根据过程变量类型在层级文件夹中创建过程变量。一个层级文件夹可

能包含多个过程变量。

层级用“\”分隔，IEA 在第二行中得到此通知。此处，必须将“\”用作分隔符。

● FID 和 LID
“FID”和“LID”列组属于“常规列组”，并且为可选项。

在副本所有顶部图表的文本框中输入 FID 和 LID。

“FID”列组包含功能标识符。

“LID”列组包含位置标识符。

示例中缺少 FID 和 LID 的数据。但是，必须包含“;”，以使列组的数量保持不变。文本

在“第 3 部分”(Part 3) 选项卡，“描述：”(Description:) 或“根据位置的代码字段：”
(Code field according to location:) 文本框中输入。

● “图表”(Chart)
对于模型，“图表”(Chart) 列组为可选项，如果使用，将始终跟在“层级”(Hierarchy) 列
组或常规列组（如果存在）之后。该标题可使用任意名称。该列组中包含 CFC/SFC 的
名称和注释。模型副本中的图表名称通过关键字“ChName”进行更改。图表注释通过关

键字“ChComment”进行更改。

● 其它列组

后面的列组标识要导入的 I/O。使用文本字符串（括在引号中）描述各个连接，两个连

接之间用分隔符（由 Windows 区域设置指定的列表分隔符）分隔。文本字符串内的单

个数据用“|”（管道字符）分隔。

● 扩展列组

使用“扩展列组...”(Extend Column Groups...) 菜单命令可显示更多列，具体取决于所

选列。

更多信息

● PH、IEA 和 PO 的在线帮助
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10.6 导入/导出硬件配置

简介

不仅可以在整个项目内进行站组态（例如，保存或打开），而且可以独立于项目进行，方

法是：先将其导出为文本文件（ASCII 文件、CFG 文件），进行编辑，然后再将其导入。

采用这种方式还会导出或导入输入和输出的符号名称（只要未更改默认设置）。    

应用

可以使用导入/导出硬件配置执行下列操作：

● 导入硬件规划工具数据

● 使用电子介质（例如，电子邮件）分发数据

● 使用字处理程序打印导出文件，或出于文档记录目的继续处理导出文件

在工厂不同部分的组态相同或几乎相同的情况下，导入站组态在工厂中还有另外一个重要

的应用。使用导入功能，可以快速创建所需的工厂组态。

导出/导入什么？ 

配置硬件时，需要导出/导入组态所必需的数据以及模块的参数分配。 

不收集以下数据： 

● 其它应用程序所管理的数据（例如，程序、连接、共享数据）

● 所选的 CPU 密码

● 跨站数据（例如，智能 DP 从站链接或用于直接数据通信的组态）

说明

如果组态包含早期选件包中的模块，则使用“导出站”(Export Station) 功能可能并不会

导出模块的所有数据。这种情况下，请在导入后检查模块数据是否完整。
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10.6.1 如何导出站组态

步骤    

1. 在组件视图中选择所需的站。

2. 选择菜单命令“编辑 > 打开对象”(Edit > Open Object)。
站组态将在 HW Config 中打开。

3. 选择菜单命令“站 > 导出...”(Station > Export...)。
将打开“导出”(Export) 对话框。

4. 输入导出文件的路径、名称、格式和其它选项。
相关信息，可参考“导出设置”一节。

5. 单击“确定”(OK)。

结果

将会导出站组态并将其以 CFG 文件形式存储在所选路径中。 

导出设置

● 易读或紧凑格式

– 在易读格式中，参数标识符将作为字符串存储到导出文件中。

– 在紧凑格式中，这些标识符将以十六进制格式存储到导出文件中。

说明

导出站组态时，若要使用其它 PCS 7 版本将其读入，请选择“紧凑”（Compact）
选项。

● 文件（*.cfg）的名称（有选择余地）

● 含有或不含符号

可以确定导出文件中是否还应包括您为输入和输出所指定的符号。

● 含有或不含子网

可以决定是否导出子网。选择此选项时，还会导出站接口的网络数据（对子网的分配、

子网参数）。

● 可选择省略模块参数的默认值（PCS 7 知道这些默认值，并且会在导入时从内部提供它

们）。

注意

导出含有符号的站组态时，便不能再使用较早版本的 PCS 7 导入该文件。
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更多信息

● HW Config 在线帮助

10.6.2 CFG 文件的结构和内容

CFG 文件

“如何导出站组态 (页 646)”部分介绍的导出站组态的过程将生成一个 ASCII 文件，可以使

用“记事本”或“写字板”之类的文本编辑器查看和编辑该文件。

此文件（CFG 文件）包含所有硬件配置数据，其中包括来自 HW Config 用户界面对话框

的参数分配以及相应的符号（如果已导出）。 

根据各个字段中的介绍性文本，很容易识别各部分。 

以下示例包括可能的 CFG 文件结构的一部分。

示例

CFG 文件中的部分 信息/对象属性用于

FILEVERSION "3.2"

#STEP7_VERSION V5.6

#CREATED "Montag, 10.April 2017   13:02:49"

文件

STATION S7400 , "SIMATIC 400(1)"
BEGIN 

 ASSET_ID "B6BF...."
 USED_S7_VERSIONS "35 ....."
 REPORT_SYSTEM_ERRORS "0"
 OBJECT_REMOVEABLE "1"
 POS_X "0"
 POS_Y "0"
 SIZE_X "0"
 SIZE_Y "0"
 OBJECT_COPYABLE "1"
 CREATOR ""
 COMMENT ""
END

站
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CFG 文件中的部分 信息/对象属性用于

SUBNET INDUSTRIAL_ETHERNET , 
"Ethernet(1)"
BEGIN 
 COMMENT ""
 NET_ID_2 "00 31 00 00 00 13"
 NET_ID "003100000013"
END

子网（以太网）

SUBNET PROFIBUS , "PROFIBUS(1)"
BEGIN 
 PROFIBUS_HSA "126"
PROFIBUS_BAUDRATE "1.5_MBPS"
 PROFIBUS_RETRIES "1"
 PROFIBUS_GAP "10"
 PROFIBUS_READY "11"
 PROFILE_SELECTION "DP"
 NETCONFIG_ENABLE "0"
 NETCONFIG_AKTIV "1"
 NETCONFIG_PASSIV "2"
:

:

:

子网（PROFIBUS）

:  
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CFG 文件中的部分 信息/对象属性用于

RACK 0, SLOT 7, "6ES7 421-1BL01-0AA0", 
"DI32xDC 24V"

BEGIN 
 IPACTIVE "0"
 CPU_NO "1"
 ALARM_OB_NO "40"
 OBJECT_REMOVEABLE "1"
 POS_X "0"
 POS_Y "0"
 REDUNDANCY
 BEGIN
 END
 SIZE_X "0"
 MODULE_ADD_FLAGS "0"
 SIZE_Y "0"
 OBJECT_COPYABLE "1"
 CREATOR ""
 COMMENT ""
LOCAL_IN_ADDRESSES 
 ADDRESS 0, 0, 4, 0, 0, 0
SYMBOL I , 0, "I0.0", ""
SYMBOL I , 1, "I0.1", ""
SYMBOL I , 2, "I0.2", ""
SYMBOL I , 3, "I0.3", ""
:

:

:

SYMBOL I , 30, "E3.6", ""
SYMBOL I , 31, "E3.7", ""
END

包含符号的数字输入

:  

: 模块 
（PS、CPU、CP、DI、DO、AI、AO 
等）

:  
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CFG 文件中的部分 信息/对象属性用于

IOSUBSYSTEM 101, "Ethernet(1):PROFINET-
IO-System (101)"

BEGIN 

  PN_PHASE_RELATION "65536"

  PN_MIN_VERSION ""

  GUI_HIDE "0"

  OBJECT_REMOVEABLE "1"

  POS_X "459"

  POS_Y "232"

  SIZE_X "253"

  SIZE_Y "16"

  PN_USE_DEVICE_SPEC_UPD_TIME "1"

  SUBNET_NAME "Ethernet(1)"

  CAX_APP_ID ""

  DNS_CHECK "0"

  OBJECT_COPYABLE "1"

  PN_USER_DEF_UPD_TIME "0"

  CREATOR ""

  COMMENT ""

  IRT_GROUP_NR "1"

END 

子网 (PROFINET)

:  
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CFG 文件中的部分 信息/对象属性用于

IOSUBSYSTEM 101, IOADDRESS 5, SLOT 3, 
SUBSLOT 1, "Analog Input (AI)short", "148"

BEGIN   
ASSET_ID "7CC4EEC..."SLAVE_CFG_DATA 
"01 00 94"  OBJECT_REMOVEABLE "1"  
RETAIN_LAST_VALUE "0"  POS_X "0"  POS_Y 
"0"  SIZE_X "0"  MODULE_ADD_FLAGS "0"  
NORMMODULE_PARAM_DATA "00 00"  
SIZE_Y "0"  CAX_APP_ID ""  
OBJECT_COPYABLE "1"  
NORMMODULE_REFERENCE "2"  CREATOR 
""  COMMENT ""LOCAL_IN_ADDRESSES   
ADDRESS  10, 0, 5, 1, 8, 0

END

模块（DI、DO、AI、AO 等）

:  

更多信息

● HW Config 在线帮助

10.6.3 扩展 CFG 文件

扩展

始终都应基于现已导出的站组态来创建 CFG 文件。相关信息，可参考“如何导出站组态 
(页 646)”部分。

CFG 文件应该已包含站扩展所需的所有对象（文件段）。这样，只需通过复制和粘贴就能

进行所需的扩展。通过相应地修改复制的对象（例如，机架分配、地址、符号）保持组态

一致性。 

有关 CFG 文件结构和内容的说明，可参考“CFG 文件的结构和内容 (页 647)”部分。
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可以此为基础编辑文件的各个部分以适合具体用途（复制、粘贴、编辑）。

说明

由于系统不支持编辑，所以应在细节上熟悉 CFG 文件各部分的内容。只有在后续的导入

过程中才会检测错误。这会导致数据不一致，此时您将不得不在 HW Config 中重新进行编

辑。

步骤 － 实例

您想要向 ET 200M 添加另一个数字输入模块并更改现有的插槽分配。 

1. 确定要更改的区域。
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CFG 文件中的部分 信息/对象属性用于

DPSUBSYSTEM 1, DPADRESS 7, SLOT 6, 
"6ES7 321-FH00-0AA0", "DI16xAC120/230V"

BEGIN 
 PROFIBUSADDRESS "0"
 CPU_NO "1"
 ALARM_OB_NO "40"
 OBJECT_REMOVEABLE "1"
 POS_X "0"
 POS_Y "0"
 REDUNDANCY
 BEGIN
 END
 SIZE_X "0"
 SIZE_Y "0"
 OBJECT_COPYABLE "1"
 CREATOR ""
 COMMENT ""
LOCAL_IN_ADDRESSES 
 ADDRESS 0, 0, 2, 0, 1, 0
SYMBOL I , 0, "I0.0", ""
SYMBOL I , 1, "I0.1", ""
SYMBOL I , 2, "I0.2", ""
SYMBOL I , 3, "I0.3", ""
:

:

:

SYMBOL I , 30, "E3.6", ""
SYMBOL I , 31, "E3.7", ""
END

包含符号的数字输入

1. 选择并复制所需区域。

2. 在所需位置粘贴复制的区域。

3. 修改插入的区域（SLOT、SYMBOL 等）

4. 根据需要修改已组态的模块。

5. 如果要添加更多的组件，请按相同的步骤操作。

6. 保存文件。

有关工厂工程组态的数据交换
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7. 启动 HW Config。

8. 选择菜单命令“站 > 导入...”(Station > Import...)。

9. 选择相应的 CFG 文件，然后单击“打开”(Open)。
导入期间，可能会出现查询，询问用户是否应该覆盖现有数据。
更改后的站组态将被导入到打开的站中。系统将会创建日志并在必要时输出错误消息。

10.在用于显示错误消息的对话框中，单击“保存”(Save) 按钮，以便将错误消息保存在文本文
件中。为此，选择路径并输入文本文件的名称。

11.单击“关闭”(Close)。

更多信息

● HW Config 在线帮助

10.6.4 如何导入站组态（首次导入整个站）

步骤

建议：请勿导入先前从同一项目导出的站组态。这种情况下，PCS 7 无法处理网络分配。

请选择一个不同的项目或新项目进行导入。请按以下步骤操作：

1. 在已打开空的站组态时，选择 HW Config 菜单命令“站 > 导入...”(Station > Import...)。
如果未打开任何站组态，将会打开一个对话框，可在其中选择一个项目。在此情况下，浏览
到要导入站组态的项目。

2. 使用打开的对话框浏览到要导入的 CFG 文件。

3. 单击“确定”(OK)。
将会导入站组态。导入期间，将检查所导入的文件是否有错误和冲突，并显示消息。

说明

如果还想在导入期间导入 DP 主站系统，其名称必须与项目中已有的 DP 主站系统不

同。

更多信息

● HW Config 在线帮助
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10.6.5 如何执行已扩展的导入（添加远程 I/O、现场设备、模块）

导入到现有站

可将站导入到打开的站组态中。导入期间，PCS 7 会询问是否要覆盖已组态的模块/接口模

块。对于每个组件，可分别决定要保留还是覆盖。 

如果覆盖组件，则会应用导入文件中包含的所有设置（参数）。导入文件中不包含的设置

将保留在站组态中。 

 步骤 － 插入数字输入模块

想要添加另一个数字输入模块并更改现有的插槽分配。请按以下步骤操作：

1. 使用编辑器（例如写字板）打开所需的 CFG 文件。

2. 确定描述数字输入模块的区域，然后对其进行复制。

3. 紧接所复制的数字输入模块粘贴复制的段落。

4. 修改插槽号、地址、符号以及其它任何相关数据，然后保存文件。

5. 打开在 HW Config 中进行过更改的站。

6. 选择菜单命令“站 > 导入...”(Station > Import...)，导入所需的 CFG 文件。
将会打开一个对话框，可在其中选择是覆盖整个组态（“全部”(All) 按钮）还是仅覆盖更改
部分（“是”(Yes) 和“否”(No) 按钮）。
导入期间也会创建错误日志。

7. 保存导入的数据。

8. 使用菜单命令“站 > 检查一致性”(Station > Check Consistency) 检查数据一致性，并在必
要时消除不一致性。

更多信息

● HW Config 在线帮助

10.6.6 如何更新已导入的站组态（更改模块的属性、信号分配）

导入到现有站

如果已在 CFG 文件中对已组态的模块/接口模块进行了修改，可通过向站中导入的方法更

新现有的站组态。

导入期间，PCS 7 会询问是否要覆盖已组态的模块/接口模块。对于每个组件，可分别决定

要保留还是覆盖。 

有关工厂工程组态的数据交换
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如果覆盖组件，则会应用导入文件中包含的所有设置（参数）。导入文件中不包含的设置

将保留在站组态中。 

步骤 - 参数更改

您仅更改了现有站组态的设置（参数）。

1. 打开站组态后，选择菜单命令“站 > 导入...”(Station > Import...)，导入所需的 CFG 文件。
将会打开一个对话框，可在其中选择是覆盖整个组态（“全部”(All) 按钮）还是仅覆盖更改
部分（“是”(Yes) 和“否”(No) 按钮）。
导入期间也会创建错误日志。

说明

如果仅覆盖更改部分，导入过程将会快很多。

2. 如果生成了错误日志，则将其保存。随后可根据该日志消除所有错误。

3. 单击“是”(Yes) 保存导入的数据。
选择“否”(No) 将终止导入过程。在这种情况下，站组态将保持不变。

更多信息

● HW Config 在线帮助

10.6.7 导出以同步较高级别的工程工具

同步较高级别的工程工具

已根据工厂工程组态规划对站组态进行了组态，并在硬件详细组态过程中对其进行了添加

和/或更正。借助导出文件，可以再次将这些更改集成到到工厂工程组态数据中。

● 关于如何导出站组态的说明，请参见“如何导出站组态 (页 646)”部分。

● 有关 CFG 文件结构的说明，请参见“CFG 文件的结构和内容 (页 647)”部分。

按照导入到工程工具（工厂工程组态）的方法，准备 CFG 文件的内容，然后导出文件。

有关工厂工程组态的数据交换
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编译和下载 11
概述

可在以下编辑器中使用编译和下载功能：    

● HW Config
编译和下载硬件配置 
相关信息，请参见“配置硬件”部分。

● NetPro
编译并下载网络、连接组态以及硬件配置

更多信息，请参见“创建网络连接”部分。

● CFC
编译和下载 CFC 组态 
更多相关信息，请参见“创建 CFC”部分。

● SFC
编译和下载 SFC 组态 
更多相关信息，请参见“创建 SFC”部分。

● SIMATIC Manager
编译并下载多项目的单个或所有对象。

工程组态系统 (V9.0 SP1)
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合并分布式站上编辑过的项目之后的操作

合并分布式项目后，必须在多项目工程组态中执行以下任务：

● 编译带有分配的 AS 组件的 OS 服务器

● 仅当第一次下载时执行：将 OS 服务器数据包分配给 OS 客户端

● 下载到所有目标系统（例如 AS、OS 服务器、OS 客户端、BATCH 服务器、BATCH 
客户端、Route Control 服务器、Route Control 客户端）

说明

初次下载到 OS 客户端之后，必须只下载 OS 服务器数据一次。每次在过程模式下重

启 OS 客户端时或下载 OS 服务器的更改时，都会自动更新 OS 服务器数据。

关于确保 OS 服务器数据为最新数据的注意事项：服务器数据中包含最初从其中下载该

数据的工程师站的计算机名称。如果更改工程师站或更改工程师站上项目/多项目的存储

位置，请确保重新编译 OS，并记住必须从新的计算机（计算机名称）或存储位置下载

一次服务器数据。

有关编译和下载 OS 以及在 OS 客户端上更新 OS 服务器数据的详细信息，请参见组态

手册《过程控制系统 PCS 7；操作员站》(Process Control System PCS 7; Operator 
Station)，在此不作详细说明。

最初只需要编译和下载 AS 数据，以测试程序或 CFC 和 SFC 组态。 

概述

有关 PCS 7 的编译和下载部分讨论以下主题：

● 编译和下载的要求 (页 659)

● 下载到所有 PLC (页 660)

● 用于编译和下载的选项 (页 664)

● 如何在 ES 日志中记录更改 (页 669)

编译和下载
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11.1 编译和下载的要求

下载硬件组态和网络组态

要将“编译和下载对象...”(Compile and download objects...) 功能用于自动化系统，必须首

先下载每个 SIMATIC 400 站的硬件组态和网络组态。

OS 服务器数据的一次性下载

将 OS 服务器数据下载到 OS 服务器后，必须在 OS 客户端上仅更新一次该数据。每次在

过程模式下重启 OS 客户端时或下载 OS 服务器的更改时，都会自动更新 OS 服务器数据。

下载 OS 服务器数据

1. 在 SIMATIC Manager 中选择 OS 客户端。

2. 选择“选项 > OS > 分配 OS 服务器...”(Options > OS > Assign OS Server...) 菜单命令。
将 OS 服务器数据上传到 OS 客户端。这样 OS 客户端就会识别所分配的 OS 服务器。

更多信息

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

编译和下载
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11.2 如何下载到所有 CPU

简介

使用集中功能“编译和下载对象”(Compile and Download Objects) 可下载整个项目/多项

目。PCS 7 提供“编译和下载对象”(Compile and Download Objects) 对话框来完成该任

务。此对话框显示对象的方式与在 SIMATIC Manager 组件视图中的方式完全相同。会显

示在 SIMATIC Manager 中创建的所有自动化系统、操作员站和 SIMATIC PC 站。       

使用“编译和下载对象”(Compile and Download Objects) 对话框集中执行编译和下载所需

的所有设置。此外，还可在此处指定是要编译和下载整个项目，还是（例如）仅编译和下

载单个操作员站。 

说明

如果在 SIMATIC Manager 中选择 SIMATIC 400 站并选择菜单命令 PLC > 下载 (PLC > 
Download) 或 PLC > 编译和下载对象... (PLC > Compile and Download Objects...)（已激

活要编译和下载的“HW Config”对象），则会丧失下载更改内容的功能。

“编译和下载对象”(Compile and Download Objects) 对话框

此对话框的选择表中包含所有与下载相关的对象，包括其状态和操作状态。 

使用“编译和下载对象”(Compile and Download Objects) 对话框可准备所选要下载到目标

系统的项目或多项目对象，然后将其下载到目标系统。此对话框可应用于站、项目或多项

目中的对象。 

PCS 7 会对编译和下载进行协调，也就是说，您无需关注任务的顺序。 

编译和下载
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要求

● 已从 NetPro 组态并下载 PC 站和自动化系统（连接也已下载）

● 完成 CFC 和 SFC 组态。

● 已在 SIMATIC Manager 中选择以下对象之一：

– 多项目

– 项目

– 站

– 未进行站分配的 S7 程序

规则

● 只有当 CPU 处于 STOP 运行模式时，才能进行完整的自动化系统下载。

● 仅当关闭 OS 服务器（未处于过程模式下）时，才能将整个程序下载到 OS。

● 仅当 OS 处于过程模式下时，才能将更改部分下载到 OS。

● 如果在调试期间进行了更改，建议您在将多项目的项目下载到目标系统之前同步这些项

目。为此，选择菜单命令文件 > 多项目 > 同步项目... (File > Multiproject > Synchronize 
Projects...)。可使用集中功能“编译和下载对象”将更改发送到目标系统。

编译和下载
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步骤

说明

请阅读“用于编译和下载的选项 (页 664)”中的信息。

1. 在 SIMATIC Manager 中选择要编译或要编译并下载的对象。

2. 在 SIMATIC Manager 中，选择菜单命令 PLC > 编译和下载对象... (PLC > Compile and 
Download Objects...)。
“编译和下载对象”(Compile and Download Objects) 对话框随即打开。

3. 打开树形视图，对想要编译和/或下载的所有对象，在其“编译”(Compile) 或“下载”
(Download) 列中激活相应的复选框。
如果对一个对象勾选了这两个复选框，则会编译该对象然后将其下载。
如果要编译和下载连接，则选中“连接”(Connections) 对象上的相应复选框。

4. 使用“状态”(Status) 和“运行模式”(Operating Mode) 按钮检查对象的状态（已更改、已编
译、已下载等）和模式（RUN、已激活等），以便可以为编译和下载进行正确设置。

5. 选择要编译和/或下载的对象，然后单击“编辑”(Edit)。
输入进行编译和/或下载的设置（例如，编译和下载整个程序或仅更改内容）。

说明

完成操作员站的编译设置后，系统需要一些时间来保存编译设置和打开下载对话框。此

时应已输入 OS 的目标路径（但如果还没有输入，请输入）

6. 单击“测试”(Test)。
检查设置的有效性。如果设置无效，则不允许下载。

7. 对各个对象进行所需设置。
单击对话框中的“帮助”(Help) 可查看有关设置的详细信息。

8. 如果只想检查块而不将其下载到 CPU，选择“仅编译”(Compile only) 选项。

9. 为防止将损坏块下载到 CPU，可选择“检测到编译错误时不下载”(Do not load if compilation 
error is detected) 选项。

10.单击“启动”(Start)。
将开始编译/下载操作。

11.按画面上的说明操作。

12.如果要在编译/下载完成后查看日志，请在“打开日志”(Open log) 区域中单击以下按钮：

– “单个对象”(Single Object) - 显示所选 AS 的详细编译和下载日志，或所选 OS 的编

译日志。

– “所有”(All) - 显示所有编译和下载操作的结果（不显示详细信息）。

说明

切勿将“编译和下载对象”功能用于 S7 PLCSIM 下载。

编译和下载
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在调试期间进行更改后回读设置

将测试期间进行的操作员监控设置回读到项目中。   

离线程序 (CFC) 中的参数设置（如控制器参数）还必须具有调试期间设置的必需值。

CFC 支持回读 CFC。仅当工厂处于定义的安全状态下时，才应回读 CFC。

完成回读后，可以下载更改以便保持离线和在线程序之间的一致性。在“CPU 比较”(CPU 
Comparison) 对话框中，检查时间戳“上次下载相关更改”(Last download-relevant 
change)、“上次编译”(Last compilation) 和“加载程序的编译”(Compilation of the loaded 
program) 是否一致。

回读 AS 参数设置

说明

“版本跟踪”附加包

如果使用“版本跟踪”附加包，则可自动读回参数。有关此主题的更多信息，请参见“归

档、版本控制和文档编制简介 (页 694)”部分。

1. 在 SIMATIC Manager 中打开多项目并选择项目。

2. 双击已修改程序的 CFC。
将打开 CFC 编辑器。

3. 选择菜单命令图表 > 回读... (Chart > Read Back...)。

4. 在“读回”(Read Back) 对话框中，选中“CPU 上的程序”(Program on the CPU) 和“具有 
OCM 功能的参数”(OCM-capable parameters) 或“指定的参数”(Designated parameters) 复
选框。

说明

如果选中了“标记的参数”(Marked parameters) 复选框，则只回读带有“可以回读”属

性 (S7_read_back = true) 的块 I/O。必须先在块类型的 I/O 上输入此设置。不能在块实

例中修改该属性。

5. 单击“确定”(OK)。

更多信息

● “用于编译和下载的选项 (页 664)”部分

● “如何将各个已更改图表加载到 CPU 中 (页 487)”部分

● 有关“编译和下载对象”(Compile and Download Objects) 对话框的在线帮助
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11.3 用于编译和下载的选项

用于编译和下载的集中设置  

在“编译和下载对象”(Compile and Download Objects) 对话框中，分别为每个对象设定编

译和下载所需的设置。在“编译”(Compile) 和“下载”(Download) 列中，指定是要编译和

下载整个项目还是个别组件。

编译图表将生成可在 CPU 上运行的可执行程序。还会检查块和互连的一致性。

编译和下载
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“编译和下载对象”对话框中的选项

表格 11-1 编译/下载设置

设置 说明

“编辑...”
(Edit...) 按钮

打开对话框，可在其中更改在“对象”(Objects) 列中所选对象的编译和下载设置。

● 下载模式设置

– 整个程序 (Entire program)
 将下载“块”(Block) 文件夹的整个内容，出现提示后 CPU 将设置为 STOP。

– 更改 (Changes)
CPU 可处在“RUN-P”模式下。修改后的块的下载要尽可能安全（无扰动），以避

免 CPU 转入“STOP”模式。 
– 测试 CPU 中（整个程序）

使用这种下载类型，可以将修改的程序下载到另一个 CPU 或 S7 PLCSIM 中，而

不会丧失原始 CPU 中的增量下载功能。

注：

CPU 可能仍然会转入 STOP 模式。其原因包括加载程序无法检查到的暂时不一致

性（例如，对不包括引用列表的块的本地要求）。

● 包括用户数据块 (Include user data blocks)

此选项为默认设置，并且仅当下载更改时此选项才有意义（下载整个程序时，将会下

载所有块，包括用户数据块）。

● 使用版本跟踪自动归档

如果使用“版本跟踪”附加包，则在成功下载流程后可以自动创建项目版本。自动归

档可通过“下载版本化项目”(Download Versioned Project) 按钮进行设置。

“检查”(Check) 
按钮

检查在“对象”(Objects) 列中所选的要编译或下载对象的编译和下载属性。

对于块文件夹，此按钮处于非激活状态。只有对象支持此功能，该按钮才会激活。 

将检查“硬件”对象的以下方面：

● 模块是否处于 STOP 模式（不针对自动停止后可再次启动的模块，如 CP）？

● 是否组态了密码保护并已输入密码：对所选的块文件夹或 CPU 是通过“编辑”(Edit) 按
钮来输入密码的。
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表格 11-2 更新

设置 说明

“状态”(Status) 
按钮

更新选择表中对象的当前状态。

对于“硬件”(Hardware) 对象，如果站包含一个跨站的 PROFIBUS 子网，状态更新后将

显示“未定义”(undefined)。此时，如果对同样连接到此 PROFIBUS 子网的其它站进行

编辑，则可能影响当前显示的站。

“运行模式”
(Operating 
Mode) 按钮

更新显示画面中的修改后的运行模式。

“打开时的状态”
(Status on 
opening) 复选框

如果未选择此复选框（默认设置），则在选择菜单命令“CPU > 编译和下载对象...(CPU > 
Compile and Download Objects...) 后，“编译和下载对象”(Compile and Download 
Objects) 对话框会立即打开。但“状态”(Status) 列中均为“未定义”(Undefined)。要进行

第一次更新，请单击“状态”(Status) 按钮。 

如果选中此复选框，则无论有多少个对象，都要很长时间才能打开对话框。 

表格 11-3 查看日志

设置 说明

“单个对象”
(Single Object) 
按钮

显示有关“对象”(Objects) 列中所选对象的最新编译或下载过程的日志。

“全部...”(All...) 
按钮

打开“打开日志”(Open Log) 对话框，可在其中选择详细日志类型。 

这可能是有关最近的编译或下载过程的日志，或是上次按“测试”(Test) 按钮所生成的“编

译/下载设置”检查日志。 

详细日志会列出各个对象的所有消息。
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表格 11-4 选择对象

设置 说明

“全选”(Select 
All) 和
“取消全选”
(Deselect All) 按
钮

使用此按钮，可以选择或取消选择“编译”(Compile) 或“下载”(Download) 列中的所有对

象。 

如果选中“仅编译”(Compile only) 复选框，则该按钮将只影响“编译”(Compile) 列。如果

禁用“仅编译”(Compile only) 复选框，“全选”(Select All) 和“取消全选”(Deselect All) 
按钮将选择或取消选择这两个列中的所有对象。

“仅编译”
(Compile only) 
复选框

如果只想编译所选对象，请选中此复选框。对象不会下载到 CPU，并且“下载”(Download) 
列会被隐藏。

“检测到编译错

误时不装载”(Do 
not load if 
compilation 
error is 
detected) 复选框

选中此复选框时，如果出现编译错误（如时间戳冲突），将不下载任何对象。 

如果禁用此复选框，则会下载无编译错误的所有对象。不会下载编译时出错的对象。 

下载硬件对象的设置

说明

只有当 CPU 处于 STOP 模式时，才能下载硬件配置。

针对下载多个硬件对象进行以下设置后，下载过程将不会被确认提示中断。 

一个站中安装有多个 CPU 时，必须为每个 CPU 进行设置。

● CPU 密码

CPU 受密码保护时，在此处输入密码。如果未输入密码，后续提示要求输入密码时，

下载过程中断。

默认密码必须是： 
– 密码最短为 8 个字符

– 密码必须支持以下字符类型：

大写字母

小写字母，

数字

特殊字符 (ASCII 0x20 - 0x7E)
可选：产品可额外支持其他字符集

– 必须确保密码至少包含一个数字、大写字母和小写字母
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为高可用性 CPU 下载硬件对象时的特殊注意事项

● 下载前停止 H 系统

两个 CPU 在下载后具有相同的硬件配置。

● 下载到 S7-400H-CPU
开始下载前，必须确保所选 CPU（一个或多个）确实处于 STOP 模式。否则，将取消

下载并出现一条错误消息。这可防止意外停止整个 H 系统。

如果只有一个 CPU 已激活用于下载，并且只有该 CPU 处于 STOP 模式，则下载后可

使用“使用修改后的组态切换到 CPU”(Switch to CPU with Modified Configuration) 启
动该 CPU。这可避免停止 H 系统。

编译和下载连接的特殊注意事项

如果选择了模块的“连接”对象进行编译，将自动选择连接伙伴的相应“连接”对象。这

样，生成的组态数据（系统数据块）将始终保持一致。 

如果选择了模块的“连接”对象进行下载，将自动选中相应的“编译”(Compile) 复选框。

所有连接伙伴的“编译”(Compile) 和“下载”(Download) 复选框也会被选中。 

如果只选择了“连接”类型的对象，还可以在 CPU 处于 RUN-P 运行状态期间下载连

接。 

更多信息

● “编译和下载对象”(Compile and Download Objects) 对话框（站属性）的在线帮助

● “版本控制 (页 698)”部分

参见

SIMATIC 密码指令 (https://asrdwiki.siemens.com/swq/index.php/
Password_directives_for_Industry_Products_or_Solutions)
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11.4 如何在 ES 日志中记录更改

简介 

可使用 ES 日志按时间顺序记录操作。最近的动作出现在第一行中。 

每个操作的内容：

● 主行：日期和时间、用户、操作、对象

● 用户执行操作的原因 

● 操作日志（如下载日志）

若激活了选项“ES 日志激活”(ES log active)，则除了受保护的功能外，还将记录 CFC/SFC 
中的所有下载操作。

要求

● 安装了 SIMATIC Logon Service。

● 激活了更改日志。

规则

● 只有安装了 SIMATIC Logon Service 后，才可使用“对象属性”(Object Properties) 对话

框“高级”(Advanced) 选项卡中的“ES 日志激活”(ES log active) 复选框。

● 只能在安装了 SIMATIC Logon Service 的计算机上禁用激活的 ES 日志。

原因：必须在 ES 日志中记录禁用和激活任务本身。

● 如果将具有激活 ES 日志的程序或图表文件夹复制到未安装 SIMATIC Logon Service 的
计算机上，则无法选中“ES 日志激活”(ES log active) 复选框。

● 在 SIMATIC Manager 中使用“编译和下载对象”功能执行到各个 CPU 的下载前，如

果为当前所选图表文件夹激活了 ES 日志，则打开 ES 日志时会导致操作暂停。

激活 ES 日志

可按以下方式为当前所选图表文件夹激活 ES 日志。

1. 在 SIMATIC Manager 的组件视图中，选择要为其激活 ES 日志的图表文件夹。

2. 选择菜单命令：“编辑 > 对象属性...”(Edit > Object Properties...)
将打开“图表文件夹属性”(Chart Folder Properties) 对话框。

3. 切换到“高级”(Advanced) 选项卡。

编译和下载
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4. 选中“ES 日志激活”(ES log active) 复选框。

5. 单击“确定”(OK)。

禁用 ES 日志

如果受保护的功能不需要进行记录（例如，在初始组态的上下文中），可以禁用 ES 日
志。 

1. 在 SIMATIC Manager 的组件视图中，选择要为其激活 ES 日志的图表文件夹。

2. 选择菜单命令：“编辑 > 对象属性...”(Edit > Object Properties...)
将打开“图表文件夹属性”(Chart Folder Properties) 对话框。

3. 切换到“高级”(Advanced) 选项卡。

4. 清空“ES 日志激活”(ES log active) 复选框。

5. 单击“确定”(OK)。

调用 ES 日志

在打开将记入日志的受保护操作时会打开 ES 日志（选择图表文件夹并在“ES 日志”(ES 
Log) 选项卡中选择菜单命令“选项 > 图表 > 日志...”(Options > Charts > logs...)）。 

要记录的受保护操作包括：

● 下载到 CPU（整个程序）

● 下载到 CPU（仅更改内容）

● 测试模式

在 SIMATIC Logon Service 对话框中执行登录。 

如果用户已经执行全局登录，则在启动受保护操作时，此用户的 ES 日志会立即打开。对

于未决操作（并且只能对未决操作）可更改用户名。全局用户的设置保持不变。 

没有用户登录时，SIMATIC Logon Service 对话框会在 ES 日志打开之前打开。

编译和下载
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记录

在“日志”(Logs) 对话框中会记录以下内容：

● 对于“下载整个程序”操作，将从日志中删除 ES 日志，但同时将 ES 日志归档为带有

日期标识符的文件。在日志中会记录归档操作和所用文件名（包括路径）。

● 对于“启动测试模式”操作，会将在 CPU 中引起更改（值的更改）的所有后续操作记

入日志。记录包括值及其更改方式（地址、旧值和新值）。

特别是记录以下信息：

– 在 CFC 中
I/O 组态

启用/禁用强制功能和强制值更改

激活和取消激活运行组

– 在 SFC 中：

各步中的常量组态

转移中的常量组态

顺控程序属性中的常量组态

更多信息

● “ES 日志”(ES log) 和“高级”(Advanced) 对话框的在线帮助
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11.5 如何在更改日志中记录更改

简介

可使用更改日志记录用户、时间、所作更改、受影响的 CPU 及更改原因。     

要求 

● 安装了 SIMATIC Logon Service。

● 激活了访问保护。

激活更改日志

可按以下方式为当前所选文件夹激活更改日志。

1. 在 SIMATIC Manager 的组件视图中，选择要为其激活更改日志的文件夹。

2. 选择菜单命令：“选项 > 更改日志 > 激活”(Options > Change Log > Activate)。
将激活所选文件夹的更改日志。

禁用更改日志

可按以下方式为当前所选文件夹禁用更改日志。

1. 在 SIMATIC Manager 的组件视图中，选择要为其禁用更改日志的文件夹。

2. 选择菜单命令：“选项 > 更改日志 > 禁用”(Options > Change log > Deactivate)。
将禁用所选文件夹的更改日志。

规则

● 请注意，只能在安装了 SIMATIC 登录服务的计算机上禁用激活的更改日志。

原因：必须在更改日志中记录禁用和激活任务本身。

● 在 SIMATIC Manager 中使用“编译和下载对象”功能对各个 CPU 执行下载前，如果

为当前所选图表文件夹激活更改日志，则打开更改日志会导致操作暂停。

说明

如果将包含激活的更改日志的程序或图表文件夹复制到未安装 SIMATIC Logon Service 
的计算机上，当试图下载或切换到测试模式时，将出现一条错误消息，并且不会执行操

作。 
● 可以在 SIMATIC Manager 中启用/禁用更改日志（菜单命令“选项 > 更改日志 > ...”

(Options > Change log > ...)）。
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显示更改日志

可按以下方式显示更改日志：

1. 在 SIMATIC Manager 的组件视图中，选择要为其显示更改日志的文件夹。

2. 选择菜单命令：“选项 > 更改日志 > 显示...”(Options > Change log > Display...)。
将打开所选文件夹的更改日志。

在更改日志中会显示所有已记录的更改。可以为每个条目添加注释以及导出更改日志。

启用/禁用 ES 日志

可以在图表文件夹中启用/禁用“ES 日志”。 

1. 从快捷菜单中选择“对象属性”(Object Properties) 命令。

2. 单击“属性”(Properties)。

3. 在“图表文件夹属性”(Chart Folder Properties) 对话框中进行设置。

更多信息

● 更改日志的在线帮助

● ES 日志的在线帮助
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测试 12
测试选项 

过程对象视图提供了一种测试模式，用于帮助您在 CPU 上在线测试和调试过程变量和 
CFC。     

更多信息，请参见“如何在过程对象视图中进行测试 (页 592)”部分。

可以使用 ES 日志记录测试模式下进行的更改（用户、时间、CPU、所作更改等）。

要求：

● 安装了 SIMATIC Logon Service。

● 已为当前所选图表文件夹激活了 ES 日志。

更多信息，请参见“如何在 ES 日志中记录更改 (页 669)”部分。

在用于组态程序的编辑器中也提供有基本的测试功能。使用这些功能，可以对组态进行测

试。以下编辑器提供了测试功能：

● CFC
测试 CFC 组态 
更多信息，请参见“如何测试 CFC (页 489)”。

● SFC
测试 SFC 组态 
更多信息，请参见“如何测试 SFC (页 553)”。

概述

有如下不同的测试过程：

● 如何使用 S7 PLCSIM 进行测试 (页 676)

● 在正在运行设备中进行测试 (页 678)

● 如何测试现场设备 (页 679)

更多信息

● 手册《过程控制系 PCS 7；入门指南 - 第 1 部分和第 2 部分》(Process Control System 
PCS 7; Getting Started – Parts 1 and 2)
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12.1 如何使用 S7 PLCSIM 进行测试

简介

S7 PLCSIM 是一种用于仿真 AS 的可选性软件包。安装后，可在 SIMATIC Manager 中启

动它。         

可以使用 S7-PLCSIM 在仿真的自动化系统上编辑和测试程序。由于是在 S7 PLCSIM 中使

用 PCS 7 块执行仿真，所以不需要任何 S7 硬件（CPU 或信号模块）。可以使用仿真的自

动化系统测试 S7‑400 CPU 的程序。这样就可以对工程师站上仿真 AS（OS 过程模式）的

操作员监控进行测试。

S7-PLCSIM 提供了一个简单的用户界面，用于监视和修改程序中使用的各种参数（例如，

打开和关闭输入）。在仿真 CPU 处理程序期间，还可以使用 PCS 7 软件中的各种应用程

序。例如，在 S7-PLCSIM 中可以监控 I/O 值。

规则

说明

请注意以下事项：

● I/O 模块的仿真并不是使用 S7‑PLCSIM 来执行，而是由 CFC 内的 Pcs7AnIn、Pcs7DiIn 等
块来执行（另请参见手册《过程控制系统 PCS 7；高级过程库》(Process Control System 
PCS 7; Advanced Process Library)）。

● S7-PLCSIM 不适合在 PCS 7 环境下仿真大规模组态。

安装 S7 PLCSIM

S7-PLCSIM 不作为 PCS 7 安装例程的一部分自动安装，但如果选择相关选项，则会一同

进行安装。

在 DVD 过程控制系统；SIMATIC PCS 7 上可以找到后续安装的软件。

要运行该软件，则需要单独的许可证密钥。

使用 S7 PLCSIM 的要求

要使用 S7-PLCSIM，必须满足以下要求：

● 仿真期间不存在与当前自动化系统的连接。

测试

12.1 如何使用 S7 PLCSIM 进行测试

工程组态系统 (V9.0 SP1)
676 配置手册, 12/2017, A5E39221328-AC



步骤

当与实际自动化系统没有任何连接时，可从 SIMATIC Manager 启动仿真。以下序列适用

于使用 CPU 410 时的标准组态。

1. 启动 SIMATIC Manager。

2. 选择要仿真的 AS。

3. 选择菜单命令“选项 > 仿真模块”(Options > Simulate Modules)。S7-PLCSIM1 已启动。

4. 在 PLCSim 中，选择接口参数“PLCSim (TCP/IP)”。 

5. 在“HW Config”中，选择菜单命令“PLC >下载”(PLC > Download)。
硬件配置将下载到仿真的 AS 中。

6. 在 SIMATIC Manager 的树形视图中，选择“图表”(Charts) 对象。

7. 选择菜单命令“PLC > 下载”(PLC > Download)。
全部所需数据将下载到仿真的 AS 中。

8. 通过在 S7-PLCSIM 中添加输入/输出组态 S7-PLCSIM 以进行测试，以便可以仿真输入值和
监视输出值。还请检查是否可以执行程序。

9. 将仿真 CPU 切换到“RUN”模式。

10.打开 SFC 或 CFC 图表，选择菜单命令“调试 > 测试模式”(Debug > Test Mode)。

11.在 SIMATIC Manager 中选择“OS”对象，然后启动 OS 编译器。在编译器参数中，连接到
子网类型“工业以太网”(Ind. Eth.) 和 WinCC 单元“TCP/IP”。在“范围”(Scope) 下，激
活“更改”(Changes)。

12.打开 WinCC-Explorer ，然后打开“变量管理” (Tag Management)。选择通道“TCP/IP”，
然后在“上下文”(Context) 菜单中，选择“系统参数”(System parameter)。随即将打开一个
窗口。选择“单元”(Unit) 选项卡，将逻辑设备名称更改为“PLCSIM.TCPIP.1”。单击“确
定”(OK) 进行确认。

13.选择菜单命令“选项 > OS > 启动 OS 仿真”(Options > OS > Start OS simulation)。
OS 仿真即会启动。

14.测试程序。
有关块仿真的更多信息，请参见过程控制系统 PCS 7 和高级过程库文档。

说明

使用 PLCSIM (TCP/IP) 后，必须撤销 WinCC 中的更改。之后，需要通过实际连接重新

编译相应的 OS（仅更改内容）。

更多信息

● S7-PLCSIM 的在线帮助

● 如何将 S7 PLCSIM 与 SIMATIC PCS 7 配合使用？ (https://
support.industry.siemens.com/cs/cn/zh/view/16522013) 

测试

12.1 如何使用 S7 PLCSIM 进行测试
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12.2 在正在运行设备中进行测试

在正在运行设备中进行测试的简介

警告

在过程运行期间测试程序时，如果功能或程序出现错误，可能会导致严重的财产损失或人

身伤害。 
在执行此功能前，确保不会出现任何危险情况。

在运行设备上进行测试与“如何使用 S7 PLCSIM 进行测试 (页 676)”部分所述的过程（或

与使用 AS 的测试组态）的差别不大。然而，AS 和 OS 的可达到数量通常大于测试组态中

的数量。

测试中涉及的操作期间安全要求和人员安全要求更高。从上述警告中应明确这一点。 

此外，必须确保因测试导致的工厂运行中断控制在最低水平。通常应预先咨询工厂操作员。

测试

12.2 在正在运行设备中进行测试
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12.3 如何测试现场设备

读者注意事项

本手册没有对使用 SIMATIC PDM 进行参数组态和诊断的选项进行介绍。 

更多信息

● SIMATIC Manager 和 SIMATIC PDM 的在线帮助

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

测试

12.3 如何测试现场设备
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测试

12.3 如何测试现场设备
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使用 Version Cross Manager 比较项目版本 13
简介

Version Cross Manager (VXM) 是一个单独的应用程序，可作为选件订购。Version Cross 
Manager 使您能够快速而可靠地比较两个 PCS 7 项目的项目数据，以确定它们之间的差

异。利用此功能可识别是否进行过更改以及进行了哪些更改。   

要求

必须比较已归档的组态版本，以确定上次提供和接受之后的所有更改，例如交付客户之后

或经“技术监测组织”或 FDA 授权机构认证之后。

此信息很重要，例如在下列应用领域：

● 经过改动和添加扩展之后，以前接受的项目状态现为待批准。这样就要知道上次接受之

后的改动状态。

● 由于要求的后继改动，已签约并接受的项目状态已扩展，而扩展有待验证。

● 某工厂的项目处于调试状态时，工程组态部门同时对状态进行了扩展。扩展内容有待确

定，以将其添加到当前项目状态。

● 项目状态为已全部归档的文档需要更新。因改动需要修订哪个对象文档尚有待确定。

● 工厂的过程控制项目数据应与该工厂的规划数据同步。为此，请用与制造商无关的 XLM 
格式导出项目数据，然后将其导入 CAx 系统（CAD、CAE、E-CAD 或 E-CAE）。

工程组态系统 (V9.0 SP1)
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13.1 版本交叉管理器 (VXM) 的应用

简介

自动化解决方案在 PCS 7 工程系统中以 CFC 和 SFC 的形式使用块进行组态。项目版本编

译为程序并下载到 AS。此版本可通过归档项目进行保存（例如在客户、“技术监测组织”

或 FDA 代表验收项目后）。         

随着时间的延续，项目会有所改动，例如更正错误和添加内容。如果需要做更为详细的验

收测试，则版本交叉管理器 (VXM, Version Cross Manager) 可用于指明所做的全部更改。

功能

VXM 提供了下列主要功能：

● 比较项目和 XML 文件

● 导入和导出项目和规划数据

● 基于 CAx 功能图生成过程变量

比较哪些内容？

使用 VXM 时，选择一个对象作为“主对象”，选择另一个对象作为“比较对象”。打开

要比较的对象时，将自动开始比较。

支持下列对象：

● 项目

● 库

● HW 配置

● CFC/SFC 工程数据，例如图表、类型、图表文件夹、块文件夹。

● 共享声明

● S7 程序

● S7 块

● S7 符号

● 消息

使用 Version Cross Manager 比较项目版本

13.1 版本交叉管理器 (VXM) 的应用
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示例

显示更改的状态

使用菜单命令“选项”(Options) >“显示...”(Display...) 来访问“显示设置”(Display Settings) 
对话框，该对话框显示了更改状态的显示信息。 

在此对话框中，可以分别修改更改状态的显示信息。

使用 Version Cross Manager 比较项目版本

13.1 版本交叉管理器 (VXM) 的应用
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导入和导出

能够实现以某种独立的格式来交换项目数据正变得越来越重要。如今，在工业工厂的组态

阶段，工作流程中可能会用到来自不同制造商的多种软件工具。如果数据交换功能得以实

现，可显著改进各种软件工具间的整合。例如，在工厂的规划阶段，正越来越频繁地使用

相关的 CAx 系统。术语 CAx 代表 CAD、CAE、E-CAD 或 E-CAE。导出和导入可支持控

制系统项目数据与工厂规划数据之间的同步。

XML（可扩展标记语言，Extensible Markup Language）已成为许多领域的数据交换格式。

VXM 使用 SimaticML 格式。这是一种包含所有相关数据（例如硬件、CAx 功能图、工厂

描述等）的通用 XML 格式。

生成过程变量

在规划级生成的 CAx 功能图可用于生成或比较 PCS 7 项目中的过程变量。

更多信息

● VXM 的在线帮助

使用 Version Cross Manager 比较项目版本

13.1 版本交叉管理器 (VXM) 的应用
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13.2 如何比较项目版本

要求

已安装 Version Cross Manager。    

步骤

1. 启动 Version Cross Manager。

2. 选择菜单命令文件 > 打开/比较... (File > Open/Compare...)。
将打开“打开/比较”(Open/Compare) 对话框。

3. 对于 A，选择：

– 第一个对象

在“打开”(Open) 对话框中进行所需的选择和设置。

– 第一个 XML 文件

在“打开”(Open) 对话框中选择所需的 XML 文件。

4. 对于 B，选择：

– 与对象进行比较

在“选择比较对象”(Select comparison object) 对话框中进行所需的选择和设置。

– 与 XML 文件比较

在“选择比较文件”(Select comparison file) 对话框中选择所需的 XML 文件。

5. 如果只想查看某些对象，请单击图标：

进行所需的过滤器设置。

6. 单击图标：

将执行过滤。

7. 单击“确定”(OK)。
VXM 会读取所选的对象/文件（包括所有下层对象），同时执行比较。
两个对象在比较结果树中重叠。差异以颜色编码显示。

8. 在层级或详细信息窗口中导航到需要了解其详细改动信息的对象。

使用 Version Cross Manager 比较项目版本

13.2 如何比较项目版本
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过滤

可以使用过滤器将对象树的比较限定于特定对象和属性。

比较期间以及显示结果时过滤器设置都会对 VXM 产生影响。因此，仅显示进行比较时实

际使用的对象和属性。

可使用它们来指定是使用新过滤器设置还是不使用过滤器来打开文件；或者指定当文件出

现在“文件”(File) 菜单下的列表中，是否应使用该文件的默认设置打开它。

默认情况下，VXM 中已设置了一些过滤条件。

设置/激活/禁用过滤器

● 选择菜单命令选项) > 过滤器 (Options > Filters)，以激活/禁用所设置的过滤器。

● 选择菜单命令选项 > 设置过滤器... (Options > Set Filters...)，以更改默认过滤条件。

更新比较数据

如果项目数据与 PCS 7 应用程序同时发生改动，则可更新比较数据。为此，请按 <F5> 键
或选择菜单命令视图 > 更新 (View > Update)。

随后，VXM 会删除内部管理结构并再次读取两个对象（包括内含的所有对象），然后再次

对这两个对象进行完全比较。

保存比较数据

可以将差别保存到 CSV 文件，也可以打印差别数据。

● 选择菜单命令文件 > 保存差别... (File > Save Differences...) 可将比较发现的差别保存

到 CSV 文件。

更多信息

● VXM 的在线帮助

使用 Version Cross Manager 比较项目版本

13.2 如何比较项目版本
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维护和诊断 14
14.1 维护项目

简介 

应定期使用“重组”(Reorganization) 和/或“另存为”(Save As) 保存项目。以下几个部分将

说明这些功能的重要性及其为项目带来的好处。      

重组

如果在使用 STEP 7 时出现无法说明的问题，通常会促使对项目或库的数据管理进行重

组。 

选择菜单命令文件 > 重组 (File > Reorganize)。重组会消除由删除操作产生的空隙，也就

是说，可减少项目/库数据的存储器要求。 

此功能以类似整理硬盘碎片程序的方式优化项目或库的数据存储。

执行重组所花费的时间取决于所需的数据移动，可能需要很长时间。因此，不应自动执行

该功能（例如在关闭项目时）。

另存为

可以用新名称保存项目或库。这样便可以选择“使用重组（慢）”(With reorganization 
(slow)) 进行保存的选项。 

如果选择此选项，则会复制该项目并另存为一个不同的名称，从而可以查看和重组该项目。

如果无法复制和保存对象（例如，由于缺少附加包或对象数据损坏），则会显示相应的消

息。重组会消除由删除操作产生的空隙，从而减少项目数据的存储器要求。 

另存为 > 使用重组（慢） (Save As > With reorganization (slow)) 功能对项目结构的影响

比“重组”(Reorganization) 功能的影响大。例如，如果项目数据库在 PC 出现硬件故障后

工程组态系统 (V9.0 SP1)
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发生问题，则运行菜单命令另存为 > 使用重组（慢） (Save As > With reorganization 
(slow))。

说明

如果不通过重组保存项目，组态文件中存储位置的已组态路径将保持不变。结果是 NetPro 
的“保存和编译”(Save and Compile) 功能将覆盖已复制项目中原始项目的组态文件！

补救措施：使用选项“使用重组（慢）”(With reorganization (slow))！在这种情况下，将转

换所有路径。

当选择 “另存为 > 使用重组（慢）”(Save As > With reorganization (slow)) 选项时，会向

用户提供选择“向下兼容”(With downward compatibility) 的选项。

“另存为 > 新建项目”(Save As > Create new project) 选项对项目结构有影响。默认情况

下，不选择该选项。如果选择了该选项，则会为项目结构创建新 ID（对具有 Process 
Historian 的工厂很重要）。

更多信息

在线帮助“SIMATIC Manager 帮助”

维护和诊断

14.1 维护项目
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14.2 使用维护站诊断（资产管理）

概述

维护站可用于对 PCS 7 工厂进行完全诊断。维护站在按层级结构排列的诊断画面中提供有

关所有 PCS 7 组件状态的信息。在此过程中，使用关联工具的可用在线功能来分析组件的

数据。可通过诊断画面访问 ES 数据。可通过保护机制控制访问。     

会自动为整个 PCS 7 系统生成用于过程控制诊断的诊断画面。诊断画面的最顶层是整个系

统的总览。

组态和形式

维护站能以“基本 MS”和“标准 MS”的形式组态为单工作站系统或多工作站系统。

“SIMATIC PDM MS”版本将组态为一个 MS 单工作站系统。在工厂层级的设置中选择该

形式。 

特别推荐您在大中型 PCS 7 系统中使用维护站。

要求 

● 已成功进行项目间一致性检查（例如，在整个多项目中 S7 程序名是唯一的）。

● 在项目中使用从 V6.1 版本开始的 PCS 7 库的块。

● 在 CFC 中生成模块驱动程序并与信号处理块互连。

● 诊断块设置为“OCM 可行”(OCM possible)。

● 在 PH 设置中激活复选框“从工厂层级获得诊断画面”(Derive diagnostic pictures from 
the plant hierarchy)。

诊断选项

在维护工作站的特定诊断画面中，可以使用诊断功能来查看各个 PCS 7 组件的状态信息。

维护和诊断

14.2 使用维护站诊断（资产管理）
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下表列出了可监视的组件示例以及这些组件的显示区域。

诊断对象 区域 标准 MS 基本 MS SIMATIC
MS PDM

● 例如，Siemens 工业 PC
– 操作站

– BATCH 站
– Route Control 工作站

– Process Historian
– SIMATIC PCS 7 BOX

● 高级服务器

● 第三方 PC

PC 站 X X X

● 交换机，例如 SCALANCE X
● 其它支持 SNMP 服务的组件

– 例如，打印机、桥接器和路由器

网络对象 X X X

● CPU 和连接

● SIMATIC PCS 7 BOX
● 分布式 I/O，例如：

– ET 200iSP, ET 200M, ET 200S, 
ET 200SP, ET 200SP HA, 
ET 200pro

– 输入和输出模块

● 现场设备（HART、PROFIBUS PA、
……）

● 故障安全模块

● 接口模块 (IM, Interface Module)
● 具有诊断功能的非透明耦合器

● 链路模块

● 诊断中继器

AS 对象 X X  

维护和诊断

14.2 使用维护站诊断（资产管理）
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诊断对象 区域 标准 MS 基本 MS SIMATIC
MS PDM

● 可由 SIMATIC PDM 检测到的 EDD 对
象

● 分布式 I/O，例如：

– ET 200M, ET 200S, ET 200SP, 
ET 200iSP, ET 200pro

– 输入和输出模块

● 现场设备（HART、PROFIBUS PA、
……）

● 接口模块 (IM, Interface Module)
● 具有诊断功能的非透明耦合器

● 链路模块

现场对象   X

● 可由应用程序为其生成诊断的用户对象 用户诊断 X   

更多信息

有关维护站的组态和过程模式的说明，请参见手册《过程控制系统 PCS 7；维护站》

(Process Control System PCS 7; Maintenance Station)。 

维护和诊断

14.2 使用维护站诊断（资产管理）
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14.3 远程诊断功能

安全性要求

如果要在 PCS 7 工厂中执行远程诊断，则需要保护此工厂，使其免受未经授权的访问。

实现安全性概念需要采取几项措施。只有整体采用所有安全措施时，才能提供最佳的保护。

传输路径

可按以下方式发送数据：

● 通过电话线（调制解调器）

● 通过 TCP/IP 连接（内部工厂网络连接）

用于 PCS 7 工厂的远程诊断和远程管理的可能性

对于 PC 站，建议使用以下工具来对 PCS 7 工厂进行远程诊断和管理访问：   

● VNC
自 PCS 7 V8.0 起，认可将“RealVNC”Enterprise Edition 软件用于远程服务访问。

说明

访问 PC 站和应用程序 
通过 VNC 访问 PC 时，功能可能不可用或操作不被允许。请阅读要访问的应用程序或 
PC 站的文档中有关远程服务器访问的信息。

● RDP
远程桌面协议 (RDP, Remote Desktop Protocol) 仅允许用于远程维护 PCS 7 客户端。

此外，不允许在这些计算机上激活任何服务器服务（例如，Web 浏览器服务器、

DataMonitor 服务器、OPC 服务器）。

有关更多信息，请参见安装手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process 
Control System PCS 7; PCS 7 - PC Configuration)。

更多信息

● 安装手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 
7; PCS 7 - PC Configuration)

● 操作系统的在线帮助

● 白皮书《PCS 7 和 WinCC 的安全性概念》

维护和诊断
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14.4 附加服务支持和诊断

概述

有关 PCS 7 提供的更多诊断选项和进行维修时需执行的任务的详细说明，请参见手册《过

程控制系统 PCS 7；服务支持和诊断》(Process Control System PCS 7; Service Support 
and Diagnostics)。

本手册包含下列支持信息：

● 用于确保 PCS 7 工厂可用性的措施。

● 有效诊断 PCS 7 工厂所需要满足的要求。

● 理解 PCS 7 工厂的报警概念。

● 出现问题时，采用正确的步骤并为专业维修人员提供关于 PCS 7 工厂状态的详细信息。

● 选择正确的诊断工具，以便能够使用指定的辅助工具对 PCS 7 工厂执行诊断。

维护和诊断
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14.5 归档、版本控制和文档编制

14.5.1 归档、版本控制和文档编制简介

简介

SIMATIC PCS 7 提供归档、版本控制和文档编制功能。       

归档

PCS 7 提供多种归档功能：

● 归档过程值（例如测量值和消息）

操作站将测量值和消息保存在归档中，以便这些数据长期可用。

有关详细信息，请参考：

– 组态手册《过程控制系统 PCS 7，操作员站》(Process Control System PCS 7, 
Operator station)

– SIMATIC Process Historian 的文档

– “如何将项目和过程数据归档？ (页 42)”部分

● 归档 BATCH 数据

可以使用 SIMATIC Process Historian 归档 SIMATIC BATCH 数据。

有关详细信息，请参考： 
– “如何将项目和过程数据归档？ (页 42)”部分

– SIMATIC Process Historian 的文档

● 归档项目

归档多项目，包括所有项目和主数据库。

有关这方面的信息，请参见以下部分： 
– 如何将多项目和项目主数据归档 (页 695)  
– 如何重新获取多项目和项目主数据 (页 697)。

说明

尽量频繁地创建项目的备份副本。

应该至少保留五个旧数据版本。如果发生网络故障、网络或硬盘崩溃或者网络中断，

则可随时还原到项目的一个备份。

版本控制

在 PCS 7 中，版本控制是指在版本归档中以文档方式备份 PCS 7 工厂的数据。 

维护和诊断
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版本跟踪（附加件软件包）用于实现 PCS 7 中的版本控制功能。在版本归档中，可管理一

个对象（例如，项目或库）的多个备份（版本）。此后不能更改已归档的数据。 

版本跟踪负责全面管理版本历史。系统会根据特别组态的准则自动设置版本控制。例如，

能够以某个整数为增量来增加版本号。版本跟踪可确保在版本历史中具有同一代号的项目

仅有一个有效版本。

例如，使用版本跟踪将工厂的项目版本传递给其他人（传送版本），以及是否希望确定当

前项目版本中的更改。

版本跟踪提供了下列可能：

● 可根据需要随时归档对象（如库、多项目和单个项目）。已保存的对象是在将其输入版

本归档时，为其指定版本控制的。该版本控制是此对象的唯一 ID。

● 重新获取和重新使用版本化项目数据。

● 自动归档

● 自动回读

● 将某个归档的版本与现有项目或另一个归档版本进行比较。用户可启动 Version Cross 
Manager (VXM) 执行比较。

更多相关信息，请参见“如何保存版本化项目数据 (页 698)”部分。

文档

文档编制涉及到创建工厂文档。PCS 7 的 DOCPRO 附加件软件包可用来实现此目的。 

● 创建和管理设备文档

● 集中控制打印（项目段或整个项目）

● 自定义布局（例如，DIN 6771）

更多相关信息，请参见“创建项目文档 (页 701)”部分。 

14.5.2 归档/重新获取多项目和项目主数据

14.5.2.1 如何将多项目和项目主数据归档

简介

可将多项目以压缩形式保存在归档文件中，就像保存项目或库一样。压缩文件保存在硬盘

或移动式数据介质上。 

维护和诊断
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如果将多项目的几个部分存储在网络驱动器上，则可使用以下文件压缩工具为多项目数据

创建一个归档： 

● PKZIP for Windows（在《过程控制系统；SIMATIC PCS 7》(Process Control System; 
SIMATIC PCS 7) DVD 中提供；随 PCS 7 一同安装）

归档过程的要求

● 任何单一过程无法访问多项目中的某一项目（因为归档是一种交互项目功能）。

● 可在本地或网络中存储项目或库。 
如果要在网络中存储项目或库，需要在网络中为存储文件夹创建发布。 
在工程师站上，在 Windows 资源管理器中创建到网络驱动器的连接表示存储文件夹。 
输入存储文件夹在网络中的路径（采用 UNC 表示法）“\\计算机名称\共享名称”。

步骤

1. 在 SIMATIC Manager 中选择多项目。

2. 选择菜单命令“文件 > 归档...”(File > Archive...)。
将打开“归档”(Archive) 对话框。

3. 选择所需的多项目，然后单击“确定”(OK)。
将打开“归档 - 选择归档”(Archive - Select an Archive) 对话框。

4. 选择归档的名称和路径以及归档程序 (PKZip)。

5. 单击“保存”(Save) 按钮。

说明

使用 SIMATIC PDM 时：

1. 在操作系统工具栏的信息区域选择 SIMATIC PDM Asset Service。
2. 启动 SIMATIC PDM Asset Service。

更多信息

● SIMATIC Manager 在线帮助

● 手册《过程控制系统 PCS 7；服务支持和诊断》

● 操作手册《过程控制系统 PCS 7；SIMATIC PDM 帮助》(Process Control System PCS 
7; Help for SIMATIC PDM)

维护和诊断
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14.5.2.2 如何重新获取多项目和项目主数据

步骤

1. 在 SIMATIC Manager 中，选择菜单命令“文件 > 重新获取...”(File > Retrieve...)。
将打开“重新获取 - 选择归档”(Retrieve - Select Archive) 对话框。

2. 选择要重新获取的归档。

3. 单击“打开”(Open) 按钮。

4. 在所显示的“选择目标目录”(Select target directory) 对话框中，选择用于解压缩归档文件的
目标目录。

5. 单击“确定”(OK)。

说明

系统即会将多项目重新获取到目标目录中，同时建立一个附加子目录。系统会根据多项

目的名称来命名该子目录（以防止覆盖任何同名的多项目）。

重新获取后，必须生成服务器数据，将其分配给 OS 客户端并下载到所有的 OS 目标系

统中。

结果

在所选目录中会创建一个新目录，并且此时会在此所选目录下的同一级别中显示解压缩后

的多项目的所有项目目录。

更多信息 

● SIMATIC Manager 在线帮助

● 手册《过程控制系统 PCS 7；服务支持和诊断》(Process Control System PCS 7; 
Service Support and Diagnostics)

14.5.2.3 数据备份

建议

始终备份多项目版本。 

在以下情况下创建备份：

● 组态更改后

● 系统组件升级前后

● 组态软件软件更新前后

维护和诊断
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更多信息

有关如何备份 ES 和 OS 项目数据以及创建备份的详细分步说明，请参见手册《过程控制

系统 PCS 7；服务支持和诊断》(Process Control System PCS 7; Service Support and 
Diagnostics)。

14.5.3 版本控制

14.5.3.1 如何保存版本化项目数据

简介

可使用版本跟踪保存版本化的 PCS 7 项目数据。以此方式归档的数据不可再更改。可以重

新获取存储的版本化项目数据并再次使用它，或者将其与其它版本或当前项目进行比较。

例如，使用版本跟踪传送工厂的项目版本（传送版本），并在以后将其与当前工厂项目版

本进行比较（使用 VXM）。 

说明

可使用 SIMATIC 登录为已归档对象分配访问权限。

要求

要使用版本跟踪，请确保满足以下各项：

● 已安装 SIMATIC Logon。

● 用户必须已登录，并且所有相关操作必须记录在此用户名下。

● 尚未打开版本跟踪。

● 要进行版本化的对象（多项目、项目、库）尚未打开。

步骤

此处所述的步骤假定尚未在版本化项目中创建归档。

维护和诊断
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要保存版本化的多项目、单项目或库，请执行以下操作：

1. 选择菜单命令“文件 > 版本化项目 > 归档...”(File > Versioned Project > Archive...)
将打开“打开项目”(Open Project) 对话框。

2. 按照以下步骤来指定要为其创建版本化备份的对象（多项目、项目、库）：

– 选择对象。

– 使用“浏览”(Browse) 按钮搜索对象。

3. 单击“确定”(OK)。
将打开“在版本化项目中保存 SIMATIC 项目 <路径>”(Save SIMATIC Project <path> in 
Versioned Project) 对话框。

4. 单击“打开”(Open)。
将打开“打开版本化项目”(Open Versioned Project) 对话框。

5. 从列表中选择所需的版本化项目，然后单击“确定”(OK)。
将打开“在版本化项目中保存 SIMATIC 项目 <路径>”(Save SIMATIC Project <path> in 
Versioned Project) 对话框。

6. 在树形视图中选择版本化项目，然后选择上下文菜单命令“插入新对象 > 归档...”(Insert New 
Object > Archive...)。
将打开“打开项目”(Open Project) 对话框。

7. 如步骤 3 中所述来选择所需对象。
将打开“属性”(Properties) 对话框。

8. 输入名称和任意注释，然后单击“确定”(OK)。
将关闭“属性”(Properties) 对话框。

9. 在“版本代号”(Version designation) 组中，选中相应复选框以指示是否递增主要版本或次要
版本。
请注意，在首次归档期间，只有“递增主要版本”(Increment main version) 可用。
将打开“在版本化项目中保存 SIMATIC 项目 <路径>”(Save SIMATIC Project <path> in 
Versioned Project) 对话框。

10.输入版本的名称，并单击“归档...”(Archive...)。
即开始压缩，版本化对象的名称最终出现在详细信息窗口中。

结果

对象分配到了一个版本，并以压缩格式保存。

如果要在同一版本化项目中创建相同项目的新版本，可跳过某些中间步骤。

安全

版本跟踪受 SIMATIC Logon Service 保护。SIMATIC Logon Service 可检查用户是否在 
SIMATIC Manager 中登录。 

要进行用户登录，在 SIMATIC Manager 中选择菜单命令“选项”(Options) > SIMATIC 
Logon Service...。
没有用户登录时，“SIMATIC Logon Service”(SIMATIC Logon Service) 对话框会在每个受

维护和诊断
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保护操作被执行之前出现在版本跟踪中。

这也适用于创建新版本化项目。

更多信息

● SIMATIC Manager 在线帮助

● 版本跟踪的在线帮助

14.5.3.2 如何使用版本 ID 重新获取项目

步骤

要重新获取版本化的多项目、单项目或库，请执行以下操作：

1. 选择菜单命令“文件 > 版本化项目 > 重新获取...”(File > Versioned Project > Retrieve...)。
将打开“打开版本化项目”(Open Versioned Project) 对话框。

2. 从列表中选择所需版本化项目，然后单击“确定”(OK)。
将打开“从版本化项目中重新获取 SIMATIC 项目”(Retrieve SIMATIC Project from Versioned 
Project) 对话框。

3. 在树形视图中选择项目，在详细信息视图中选择要重新获取的版本。

4. 单击“重新获取”(Retrieve)。
将打开“选择目录”(Select Director) 对话框。

5. 选择目标目录并单击“确定”(OK)。
即开始解压缩。
如果在存储位置已经存在具有相同名称的文件夹，则会出现一个对话框，通知您此情况。
“取消”(Cancel) 按钮可以中止解压缩过程，“重命名”(Rename) 按钮可以用新名称保存解
压缩的数据。
系统将发出一条消息，通知您项目的名称和存储路径。

结果

现在，已对所需的项目版本进行解压缩和恢复。

更多信息

● 版本跟踪的在线帮助

维护和诊断
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14.5.3.3 CFC 及 SFC 版本控制

概述

可以在每个 CFC/SFC 的对象属性中分配一个版本号。创建 CFC/SFC 时，版本号自动设

置为“0.0001”，然后由用户对其进行管理。     

关闭 CFC/SFC 时，将打开“属性”(Properties) 对话框的“版本”(Version) 选项卡，用户可

在其中分配版本号（范围为 0.0001 到 255.4095）。 

说明

如果包含“版本”(Version) 选项卡的对话框自动出现，这说明在项目属性中激活了版本控

制并且在图表中做过更改。在这种情况下，预计将提高版本级别。

所设置的版本号不能低于之前保存的版本号。

CFC/SFC 的对象属性还包括上次编辑图表所用软件的版本 (PCS 7 Vx.y) 的信息。 

14.5.4 文档编制

14.5.4.1 创建项目文档

概述

创建设备后，需要将所有项目数据编制到清楚有条理的格式中。合适的文档结构使编辑和

维护项目更容易。

DOCPRO 是能够帮助您高效地创建和管理工厂文档的应用。该应用让您可以：

● 根据需要构建项目数据

● 以标准化技术文档的形式准备项目数据

● 以统一的打印映像打印项目数据

更多信息

● DOCPRO 在线帮助

● 手册《DOCPRO；创建符合标准的文档》 DOCPRO; Creating documentation in 
compliance with standards

维护和诊断
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14.5.4.2 如何将文档转换成 PDF 文件

简介

也可以将通过 DOCPRO 创建的文档转换为手册（PDF 格式）。自动转换不是 PCS 7 的
一部分。 

要求

有 Adobe Systems Incorporated 的 Adobe Acrobat 程序的完全许可证。

基本操作步骤

1. 在 DOCPRO 中生成项目文档，例如，借助 DOCPRO 向导。

2. 在 DOCPRO 中将文档打印输出为文件。为此，在 Windows 打印对话框内选中“打印到文
件”(Print to file) 复选框。

3. 打开 Acrobat Distiller，然后通过 DOCPRO 将所有文件从 Explorer 拖到 Distiller。
Distiller 为每个文件分别生成相关 PDF 文件。

说明

Siemens 不对 Adobe Systems Incorporated 提供的程序负责。使用 Acrobat Reader 的
详细说明，请参见 Acrobat 在线手册，您可以通过“帮助”(Help) 菜单进行访问。

更多信息

● DOCPRO 在线帮助

● 手册《DOCPRO；创建符合标准的文档》 DOCPRO; Creating documentation in 
compliance with standards

维护和诊断
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附录 15
15.1 PCS 7 安装指南

简介

为确保 PCS 7 控制系统的正确运行，必须遵循安装指南进行安装。本附录包含有关防雷、

接地以及符合 EMC 的安装的附加信息。对于基本的安装指南，可参考各组件的安装手册

（例如，安装手册《可编程控制器 S7-400，硬件和安装》(Programmable Controllers 
S7-400, Hardware and Installation)）。

组件

组态方法在很大程度上由 PCS 7 中所使用的组件决定：

● SIMATIC PC 站

● SIMATIC NET 

● S7-400/S7-400H/FH

● 分布式 I/O（包含模块的站；现场设备）

每个组件都有大量的组态变化，可对其进行修改以满足特定应用的需要。

还可以选择在机柜中安装可编程控制器和分布式 I/O 系统。

有关安装完整设备（防雷、接地等）的更详细信息，请参考下面的相关部分。在“I/O 安装”

部分对可用于将过程信号连接到 CPU 的选项进行了详细介绍。 

说明

在下面的文档中将以 ET 200M 作为分布式 I/O 的示例。有关安装其它 ET 模块的详细信

息，请参考相关的产品手册。

机架或壁式安装

如果系统运行环境的噪声水平很低且可维持允许的环境条件，则可将 PCS 7 控制系统安装

在机架中或安装在墙壁上。为了对大金属表面上耦合的电压进行放电，应在钢板制成的基

准电位表面上安装导轨、屏蔽物和避雷针。
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机柜安装

可将 S7-400 可编程控制器和 ET 200M 模块安装在 PCS 7 控制系统的机柜中。下图显示

了安装在机柜中的 S7-400 可编程控制器和分布式 I/O 系统 ET 200 M。例如，可根据需要

将不同的机架进行组合，从而将分布式 I/O 安装在单独的房间（电子室、布线室）内。

由系统相关模块（系统和 I/O 单元）和系统无关模块（基本机柜、电源装置和附加件软件

包）组成的机柜可针对以下因素提供充分的防护：

● 未经授权的访问

● 机械影响

● 污染和腐蚀

鉴于模块性及由此带来的可变性，机柜可以适应不同类型和不同尺寸的系统。

EMC 符合性

PCS 7 控制系统及其组件符合 EMC 欧洲标准要求。这些标准要求符合 EMC 的设备在安

装正确、维护适宜且在常规 EMC 环境中使用恰当的情况下，在运行期间具有足够的抗噪

性。为确保无线电及电信设备的正常运行，需要对噪声辐射进行限制。

由系统单元、I/O 单元、基本机柜、电源装置和附加件软件包组成的 PCS 7 控制系统的机

柜符合 CE 标准。这意味着机柜和 PCS 7 控制系统符合如下的 EMC 规定：

● 电磁兼容性（89/336/EEC；92/31/EEC）

● 低电压指令（73/23/EEC；93/68/EEC）

● 危险区指令（94/9/EEC）
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15.2 防雷

简介    

工业工厂和发电站必须配备防雷装置以防人员、建筑物和设备遭受雷击的损害。由于在相

距很远的两点之间会产生高电压，所以网络布线范围很广的过程控制系统常常会有风险。

由于雷电而对电子元件造成的破坏会导致设备故障，为此将会付出高昂的代价。

以下原因会导致遭受雷电损害的危险：

● 建筑物直接遭到雷击

● 工厂紧邻处发生雷击

● 远处的雷击（例如，在架空线路中）

● 云层间放电

源于闪道的雷电会产生圆柱形电磁波，它可以穿透建筑物并在此处的电缆环路中感生电压。

雷击距离越近，所产生的电场就越强。

云层之间或云地之间的雷电都会使架空线路（高电压、低电压和电信线路）中感生的电荷

发生变化。此时，这些变化的电荷会以行波形式沿着电缆流动。这些行波到达电缆端部的

装备时，它们也可能进入要保护的设备或系统。一般来说，通常只有变压器附近的信号和

总线电缆以及信号和电信线路会有危险。

过程控制系统的防雷措施可以大致分为外部防雷和内部防雷。 

外部防雷

外部防雷包括建筑物外面用于将雷电对地放电的所有装备。

内部防雷

内部防雷包括建筑物内部为了抵御雷电并抵消其电场和电磁场对金属装置及电气系统的影

响所采取的措施。

防雷区概念

防雷区的原则规定，应根据 EMC 注意事项将欲防止产生过压的设施（如工厂的某个区段）

划分成防雷区。 
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防雷区的划分是按照距离易受雷击地点的远近及由此产生的高能电磁场而做出的。防雷区

如下：

建筑物的外部防雷（现场方面） 防雷区 0

屏蔽 

－ 建筑物

－ 房间和/或

－ 设备

 

防雷区 1

防雷区 2

防雷区 3

更多信息

在安装手册《自动化系统 S7-400 硬件和安装》(Automation System S7-400 Hardware 
and Installation) 中，对防雷区与联网 SIMATIC 400 站的示例电路之间的接口桥接规则进

行了说明。
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15.3 电气安装

简介

PCS 7 组件能否正确运行在很大程度上取决于是否遵守了电气安装方面的某些规则。其中

包括以下方面：

● 等电位联结 (VDE 0100)

● 接地

● 过压保护

● 屏蔽

● 敷设电缆

等电位联结

依据 VDE 0100，必须互连系统中所有导电的金属部件（机柜面板、机架、端子块等）。

这样可确保将电位差降低到不会对人身或设备造成危险的程度。 

接地

低电阻接地连接可在短路或系统发生故障的情况下降低电气干扰的危险。通过对接地及屏

蔽电缆和设备使用低阻抗连接，可以减轻噪声对系统的影响并减少系统产生的噪声辐射。

SIMATIC S7-400 自动化系统和分布式 I/O 系统 ET 200M 在接地和未接地的情况下都可以

运行。

接地基准电位或未接地安装

S7-400 中使用的模块始终通过机架的背板总线接地。通常会在机器或工业设备中采用这种

策略，并且会将干扰电流释放到地面。 

在化工厂或发电站中，由于接地故障检测器的原因，可能需要以未接地基准电位来运行系

统。在此情况下，可拆除机架上的跳线，以便通过集成的 RC 网络将基准电位连接到地面。

过压保护

关闭感应器时，在模块输出端会产生过压（例如，在继电器上）。SIMATIC S7-400 的数

字模块已集成了过压保护装置。在某些情况下（例如，当模块输出端与感应器之间存在另

外一个触点时），必须在感应器上直接安装外部过压抑制器（例如，灭弧二极管）。
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平衡信号电路

在平衡信号电路中，所有信号路线都具有相同的阻抗。这意味着，如果存在干扰，则信号

电缆中的纵向感应电压大小相等，从而无干扰电流流过。平衡信号电路通常用于高灵敏度

的测量电路和高频率运行的系统。平衡测量电路具有高度的抗扰性，但这种电路极其复杂，

故而在过程控制系统中很少见。在过程控制系统中，首选方法是屏蔽电缆。

屏蔽电缆

屏蔽电缆可以降低磁干扰、电干扰和电磁干扰对电缆的影响。屏蔽层中感生的干扰电流将

通过低阻抗连接直接释放到地面。 

与箔屏蔽相比，编织屏蔽更为可取，因为箔屏蔽容易损坏，从而会降低屏蔽效果。采用长

而细的导线进行接地屏蔽也会使屏蔽无效。因为感应系数很高，使得干扰电流无法流到地

面。

如果电缆屏蔽的屏蔽效果不够理想，应将电缆放入到两端接地的金属导管中。

对于高频干扰，建议在电缆的两端（电缆始端与末端）均接触屏蔽；而对于低频干扰，只

需在电缆的始端或末端接触屏蔽。低频时的屏蔽效果由欧姆电阻（屏蔽横截面）决定，而

高频时的屏蔽效果则由感应系数，也即是护套结构（封闭导管要好于编织物等）来决定。

为防止磁场中发生耦合现象，请尽量将屏蔽的两端均连接到等电位联结系统。在室内条件

下，工频干扰电流可能会造成箔屏蔽上的电流荷载，由于担心违反与此相关的技术规定，

故经常不这样做。 

当存在很强的干扰磁场时（发电机、导线棒），禁止将屏蔽的两端都接地。连接屏蔽两端

会形成回路，其中可能会耦合工频干扰电压。

为避免磁场所引起的感生电压的影响，信号电缆为绞线形式。采用绞线后，在绞线的一半

中感生电压为正，而在另一半中感生电压为负。这些电压在绞线的全长上彼此抵消。

以下示意图说明了可能的屏蔽配置。 
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将电缆的电缆屏蔽连接到电子机柜的入口处

必须注意，沿着电缆屏蔽传送的干扰信号不得进入电子机柜。
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如果在机柜或外壳内部将电缆屏蔽接地，则屏蔽电流在屏蔽接地电缆中产生的电场不仅会

耦合到未屏蔽的信号电缆中，而且还会耦合到入口保护电路后面模块上的回路中，并产生

干扰电压。因此，如果将屏蔽的两端都接地，则应该直接在机柜开口处进行接地。

还要确保屏蔽接触接地导轨的区域足够大。屏蔽与接地棒之间长而细的导线具有较高的感

应系数，因此不适合对高频时的干扰电流放电。

请注意以下几点：

● 使用长度较短的导线（如果可能，可完全不用导线，而采取直接大面积接触的办法）

● 为屏蔽接地线选择合适的路径（勿使其接近敏感的电子设备）

● 在屏蔽棒和等电位联结系统之间使用短而粗的电缆

如果对控制系统进行屏蔽时包括机柜或外壳，请记住以下几点：

● 级联时，机柜面板（如侧板、背板、顶板和底板）的各个触点之间应保证足够的间距。

● 门应当有额外的触点以连接到机柜底盘。

● 从屏蔽机柜引出的电缆应进行屏蔽或经由专门用于 PCS 7 的滤波器按指定路线敷设。

● 如果机柜中存在较强的干扰源（变压器、与电机相连的电缆等），必须用隔板将其与敏

感的电子设备隔开。这些隔板应经由机柜以低阻抗形式连接到等电位联结系统。

应以尽可能短的路径将所有的外壳、机柜等连接到等电位联结系统。通常会建立一个独立

的等电位联结系统。此系统通过单根电缆连接到其余设备的等电位联结系统。

将 PCS 7 过程控制系统连接到设备外部接地点的做法是错误的。流入等电位联结系统的干

扰电流所产生的磁场会在等电位联结导体和接地连接之间的附加表面上感生电压。

铺设电缆

铺设电缆的目的是，通过将电缆直接铺设在传导干扰电流的导体上，从而最大限度地减弱

干扰源与信号电缆之间的干扰电流场。

信号及总线电缆应贴近直径较大的电缆进行铺设，因为与直径较小的电缆相比，此处的场

强较弱。 

如果带有干扰电流的导体是一块金属板（例如，它属于建筑结构），请将信号电缆铺设在

金属板的中部，因为此处的场强最弱。应将电缆固定到金属板噪声最小的一侧。这也适用

于托架和钢梁。
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信号或总线连接线应在一根电缆中，并以普通屏蔽层包裹。应将电缆铺设得尽可能靠近激

励电缆，以使绝缘应力保持最低。 

如果附近没有等电位联结系统的干扰传导部件，则应将现有电缆桥架装置（例如，电缆架）

连接到等电位联结系统。然后，可将电缆屏蔽的两端与电子设备的外壳接触，继而连接到

等电位联结系统。

更多信息

有关电气安装的更详细信息，请参考安装手册《自动化系统 S7-400 硬件和安装》

(Automation System S7-400 Hardware and Installation)。
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15.4 在易爆环境 2 区内使用模块

请参见产品信息“在 2 区易爆环境中使用模块 (https://support.industry.siemens.com/cs/
cn/zh/view/19692172)”。   
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15.5 PCS 7 符合 EMC 安装的基础

简介

虽然 PCS 7 控制系统及其组件被设计用于工业环境并且满足严格的 EMC 要求，但在安装

控制系统和确定可能的噪声源之前，仍应进行 EMC 评估。

可能的噪声源

不同电磁

干扰源可通过不同方式影响自动化系统：

● 电磁场可能直接影响系统。

● 干扰可能通过总线电缆传输。

● 干扰可能经由信号线路传送。

● 干扰可能经由电源或保护地线进入系统。

机制

由不同耦合机制产生的干扰可能会对 PCS 7 控制系统有影响。耦合机制的类型取决于干扰

源与 PCS 7 控制系统之间的距离及传输媒介。

耦合

机制

原因 干扰源

电导

耦合

发生于两个电路

共用一根电缆的情况下 
报时设备；启动

电机；静电释放

电容

耦合

发生在处于不同电位的两根电缆

之间

来自并行

电气信号电缆的干扰；接触器；来

自操作员的静电释放

电感

耦合

发生在两根带电电缆之间。电流

的磁场会感生干扰电压。

变压器；电机；

并行电源电缆；载有开关电流的电

缆；高频电气信号电缆

辐射

耦合

当电磁波与电缆相遇时发生。将

会感生电压和电流。 
邻近的发送器（步话机）；无线链

路
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确保电磁兼容性的规则

通常，只需遵守以下规则就足以保证电磁兼容性：

● 将可编程控制器安装在金属机柜或外壳中，使其免受外部噪声的干扰。将机柜或外壳加

入到底盘连接之中。

● 使用隔板（钢材、高磁导性材料）将可编程控制器与感应器（变压器、电机、接触器线

圈）产生的磁场屏蔽开。

● 对屏蔽信号电缆及总线电缆使用金属连接器外壳（而不是金属化的塑料）。

● 采用低阻抗和大面积接触的方式将所有无源金属部件连接在一起，另外还要在本地进行

接地。

● 在无源金属部件与接地之间建立中央连接。

● 应采用低阻抗和大面积接触的方式将屏蔽棒连接到底盘。

● 将电缆分成若干组，分别进行铺设。

● 务必分别将电源电缆、电气信号电缆和总线电缆铺设在不同的通道或线束中。

● 分别将危险区电缆和常规信号电缆铺设在不同的通道中。

● 仅将电缆从一侧送入机柜。

● 尽可能靠近底盘表面

（如支撑杆）铺设电气信号电缆及总线电缆。

● 使用绞线电缆。

● 连接电气信号电缆屏蔽的两端。

● 使用双屏蔽铺设模拟信号电缆。必须在单端连接内层屏蔽，而在双端连接外层屏蔽。

● 在电缆屏蔽进入机柜处，使用屏蔽棒以大面积直接接触电缆屏蔽，并将其用卡件固定。

● 不中断已连接的屏蔽层，将其延续到模块。

● 切勿在功能单元之间中断电缆屏蔽，并且必须双端连接。

● 不要将电缆屏蔽互连。

● 只能使用带有金属外壳且专门用于 PCS 7 的线路滤波器。

● 以大面积连接滤罩；换句话说，就是以低阻抗连接到机柜底盘。

● 切勿滤波器罩固定到涂漆表面

（这将刮掉油漆！）。

● 在电缆进入机柜之处安装滤波器。

● 不要将未经滤波的电缆铺设在机柜中。
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更多信息

有关设备安装的详细信息，请参考手册《自动化系统 S7-400 硬件和安装》(Automation 
System S7-400 Hardware and Installation)。
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15.6 保护等级（外壳保护）

IP 标准

欧洲标准 EN 60529 通过含有两位数字的 IP 代码 IPxx 来规定外壳保护。

下表对符合 EN 60529/IEC529 的 IP 标准进行了说明：

第一位数字 接触与固体保护 注释

0 无保护  

1 防止最大为 50 mm 的固体对象进入 例如，手无意中接触

2 防止最大为 12.5 mm 的固体对象进入 例如，手指

3 防止最大为 2.5 mm 的固体对象进入 例如，工具和细导线

4 防止超过 1 mm 的固体对象进入 例如，工具和细导线

5 防护灰尘，允许有限的渗透 无有害的沉积物

6 完全防尘  

第二位数字 防水保护等级 注释

0 无保护  

1 防护滴水 垂直落下的水滴

2 防护滴水 以 15°垂直角度直接倾斜落下

的水滴

3 防护喷雾水  

4 防护喷雾水 来自任何方向的喷雾应该都

不会造成损害

5 防护喷射水 来自任何方向的低压喷射水

应该都不会造成损害

6 防护高压喷射水 来自任何方向的喷射水应该

都不会造成损害

7 在规定时间内以规定压力间歇地浸入应该不

会造成损害

 

8 防护长时间在有压力的情况下浸没 由制造商和用户共同商定；

但是，条件必须要比第 7 号
更严格
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防护等级

大多数 SIMATIC 组件的外壳都有通风口。为了能够更有效地冷却电子组件，周围的空气可

以流过电柜。仅当空气可以不受限制地流过通风口时，技术规范中援引的最高操作温度才

适用。

视通风口大小不同，此类模块符合防护等级 IP 20、IP 30 到 IP 40。有关 SIMATIC 组件的

实际防护等级，可参考该组件的文档。

具有上述防护等级的组件不提供对灰尘和水的防护。如果安装场地需要此类保护，必须将

组件安装在具备更高防护等级（例如，IP 65/IP 67）的附加机柜（例如，开关柜）中。

在附加机柜中安装

将这些组件安装在附加机柜中时，请务必保持所需的操作条件。

说明

确保附加机柜内的温度不超过所安装组件允许的环境温度。选择尺寸足够大的机柜，或者

使用换热器。
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-
- 设置

使用 PCS 7 向导设置项目, 180

A
AS, 117, 362, 363

高可用性组件, 124
故障安全组件, 127
在 H 系统和 F 系统中可能的使用情况, 135
组件, 117
组态, 168
组态 SIMATIC 站, 270
组态高可用性系统, 362
组态故障安全系统, 363
组态运行时间测量, 496

AS 410
高可用性, 120
默认值, 119

AS 41x
默认值, 118
组件, 117

AS 41xH
高可用性, 119

AS 范围的互连
组态, 475

AS 功能
组态, 460
组态 AS 范围的互连, 475
组态项目间连接, 456

AS/OS 分配, 295
库, 295
指定, 295

AS-i, 64
AS-i 总线, 104

连接到 PROFIBUS DP, 104
ATR, 227, 368

B
BATCH

PC 组件, 112
基于 AS 运行, 158
基于 PC 运行, 158
站点的组态, 158
组态功能, 608

BATCH 归档, 42
BATCH 站

插入, 277
组态, 277

C
CFC, 468, 486, 488, 489

版本控制, 701
编译, 485
测试, 489
创建, 464, 468
下载到 CPU, 488
下载前比较, 486
组态概述, 466

CFC I/O, 480
定义, 480

CiR, 176, 401, 403, 404
CiR 对象, 401
CiR 元素, 401
简介, 403
建议, 404
模块, 401
原理, 401
组态规则, 176

CiR 的原理, 401
CiR 元素, 406, 410, 411

定义, 406
删除, 410
在 RUN 模式下使用, 411

COMOS, 621
CP 443, 439
CP 443-1, 351
CP 443-5 Extended, 351
CPU, 49, 363, 657

PCS 7 项目的默认参数, 122
PCS 7 项目的限制, 122
默认参数, 363
设置属性, 354
所需数量, 49
下载, 660

CPU 410-5H, 439

D
DP 从站, 369
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E
EMC 工程, 713
EMC 要求, 713
ES

PC 组件, 112
ES 日志

激活, 669
禁用, 669

ET 200iSP, 83, 131, 135, 136
ET 200M, 83, 124, 131, 135, 136, 363, 369
ET 200PA SMART, 131, 135
ET 200pro, 83, 131, 135, 136
ET 200S, 83, 131, 135, 136, 363
ET 200SP, 131, 135, 136, 381
ET 200SP HA, 131, 135, 381, 393, 395

属性, 136

F
F 系统, 363

组态, 363
FDA, 40
FOUNDATION Fieldbus, 64

H
H 系统, 362

组态, 362
HART, 64
HART 设备, 101, 430

连接到分布式 I/O, 101
使用 SIMATIC PDM 组态, 428

HW Config
HW Config 包括 CiR, 343
导入/导出, 645

I
I/O, 131, 503

分布式, 131
概述、分布式和中央, 136
集中式, 131
连接, 130
连接到通道块, 503

IE/PB Link, 426
IEA, 625

管理过程变量/模型, 625, 628

限制, 637
应用, 624

IEA 文件, 638
ES 中的数据, 638
使用 IEA, 624
在编辑器中工作, 639
组态, 642

IO 设备, 381
IO 设备名称, 387

参数, 387
IP 标准, 716
IT

PC 组件, 112

M
MIS/MES 连接, 106
Modbus

连接, 103

N
NAT

无效, 434

O
OPC, 109

连接 HMI 系统, 109
OpenPCS 7

PC 组件, 112
连接到 IT 世界, 108

OpenPCS 7 站
插入, 281
组态, 161, 281, 613

OS
PC 组件, 112

OS 单工作站系统
参考 OS, 276

OS 服务器数据, 659
一次性更新, 659

OS 功能, 603
组态, 603

OS 画面
创建/更新块图标, 321

OS 区域, 212
从 PH 获得, 212
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P
PA 设备, 426

组态, 426
PC 和 SIMATIC 400 站之间的连接, 450

组态, 450
PC 网络

更改传输率, 438
更改模式, 438

PC 站, 283
到以太网的连接, 75
下载, 283
组态, 270, 283

PC 组件
I/O, 113
用于 BATCH, 112
用于 ES, 112
用于 IT, 112
用于 OpenPCS 7, 112
用于 OS, 112
用于归档服务器, 112
用于路径控制, 112

PCS 7 Web 客户端, 109
PCS 7 包的预组态系统, 113
PCS 7 操作站, 156
PCS 7 的标准自动化系统, 118
PCS 7 工厂

安装帮助, 169
工厂结构, 147
系统和组件, 147

PCS 7 工厂安装帮助, 169
PCS 7 工程组态系统

组态, 155
PCS 7 向导, 180, 181
PCS 7 应用程序, 245
PCS 7 Web 服务器, 109
PCS 7 向导, 261
PDF 文件, 702

从文档创建, 702
PDM, 430
PH, 212, 292, 294, 297, 299, 302

创建, 286, 288
分配对象, 297
获得画面层级和 OS 区域, 212
检查一致性, 299
扩展, 292
命名约定, 292
取消分配, 297
设置, 290
有关复制和移动的注意事项, 294

组态, 287
组态步骤, 286

PROFIBUS, 68, 81, 84, 85, 425
电气传输介质, 81
光传输介质, 68
规划现场级, 80
将非冗余设备连接到冗余系统, 85
冗余网络的布局, 84
冗余系统上的非冗余 P 总线, 425

PROFIBUS DP, 64, 83, 87, 104, 130, 369
DP 从站, 369
从 PROFIBUS PA 连接, 87
连接到 AS-i 总线, 104
连接节点, 83
设备集成概述, 131

PROFIBUS DP/PA, 130
PROFIBUS PA, 64, 87, 100

连接到 PROFIBUS DP, 87
连接到 PROFINET IO, 100

PROFIBUS PA 网络, 90
冗余, 90

PROFIBUS 段, 81
PROFIBUS 诊断, 91

工厂, 91
PROFINET, 64, 130, 131

ET200M, 94
分布式现场设备, 93
规划现场总线, 94
现场总线集成, 93
最低要求, 93

PROFINET IO, 100, 381
IO 设备, 381
从 PROFIBUS PA 连接, 100

R
R1 冗余

激活, 135
Route Control

PC 组件, 112
Route Control 工作站

插入, 279
组态, 279

RS 485-iS 耦合器, 81

S
S7 PLCSIM, 676

测试方式, 676
S7 连接

跨网络, 434
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SCALANCE X, 72
SFC, 526, 531, 533, 553

版本控制, 701
编译, 548
测试程序, 553
创建顺序控制系统, 521
创建新, 526
复制和移动, 540
删除, 540
下载前比较, 550
组态步, 531
组态消息, 542
组态转移, 533

SFC 类型, 200, 523, 543, 547
编译, 548
创建, 543
更新, 315
几种更改, 547
使用, 200
用例, 523
优点, 523

SFC 实例, 523
生成, 546
用例, 523
优点, 523

SIMATIC BATCH, (另请参见 BATCH)
SIMATIC IT

连接到 IT 世界, 106
SIMATIC Manager, 231
SIMATIC NET, 62
SIMATIC PCS 7 AS RTX, 115
SIMATIC PCS 7 BOX, 115
SIMATIC Route Control

组态, 160
SIMATIC 过程设备管理器, 430
SIMATIC 站, 270, 346, 349

创建, 349
在多项目的项目中插入, 270
组态, 346

T
TIA, 147

V
Version Cross Manager, 682

比较项目版本, 681
使用, 682

W
WinCC 归档, 42

X
XML, 208

Y
Y Link, 425
Y 耦合器, 425

安

安全机制, 56
安装, 716

在附加外壳中, 716
安装 PCS 7 工厂的帮助, 169
安装程序, 376

冗余 I/O 模块, 376
安装说明, 175

特性，偏差, 175
安装指南, 703

PCS 7, 703
保护要求, 703
壁式安装, 703
机柜安装, 703
框式安装, 703
组件, 703

版

版本控制, 694, 698
CFC/SFC, 701
项目数据, 698

保

保存, 439
共享声明, 331
网络组态, 439
重组的项目, 687

保护, 182, 263, 483, 703
带有访问保护的项目/库, 182, 263
防机械影响, 703
防污染和腐蚀, 703
防止未经授权的访问, 703
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保护项目/库, 182, 263
保护要求, 703

报

报警器, 229

备

备份, 697

本

本地 ID, 450
本地 PC 站, 254

设置, 254
本文档的用途, 17

比

比较
项目版本, 685

比较项目版本
Version Cross Manager, 681

壁

壁式安装, 703

避

避免出现生产损失, 54

编

编辑, 341, 443, 573, 577, 588, 590, 591
参数 (Parameter), 573
测量值归档, 585
层级文件夹, 588
常规数据, 567
共享声明, 591
过程变量, 516
过程对象, 48
画面对象, 584
块, 571
设备属性, 590
网络组态, 443
消息, 581

信号, 577
在分布式工作站上继续编辑项目, 341

编译
CFC, 485
SFC, 548
SFC 类型, 548
与操作员相关的文本, 322

编译和下载, 659
AS 数据, 657
OS 服务器数据, 657
OS 要求, 659
选项, 664

编织屏蔽, 707

玻

玻璃光纤电缆, 68

布

布局, 84, 707
电气, 707
冗余 PROFIBUS PA 网络的, 84
未接地, 707

采

采用
过程变量, 517

参

参考 OS
交换文件范围, 276

参数, 63, 386, 387
编辑, 573
网络, 63
总线系统, 63

参数 (Parameter), 573

操

操作参数, 535
修改, 535

操作期间更换模块, 369, 381
操作员文本

编译和编辑与操作相关的文本, 322
生成, 214

操作站
OS 单工作站系统, 276
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插入, 274
用于多工作站系统的数量, 50
组态, 156

测

测量值归档
编辑, 585

测试, 489, 553, 676, 678, 679, (一致性)
CFC, 489
SFC 程序, 553
过程对象视图, 592
库对象, 333
使用 S7 PLCSIM, 676
现场设备, 679
在过程对象视图中, 675
在运行设备中, 678

测试模式, 494
趋势显示, 494

层

层级文件夹, 292, 293, 294, 297, 588
编辑, 588
插入, 292
插入对象, 293
复制, 294
删除, 294
属性, 302
同步, 302
移动, 294

插

插入, 270, 272, 273, 293, 349, 351, 369, 381, 469
BATCH 站, 277
OpenPCS 7 站, 281
Route Control 工作站, 279
SIMATIC 站到多项目的项目, 270
操作站, 274
层级文件夹中的对象, 293
工程师站, 273
将过程变量插入项目, 513
将项目插入多项目中, 259
块到 CFC 中, 469
模块, 369, 381
首次导入整个站, 654
通信处理器, 272, 351
外部归档服务器, 282
维护站, 274

硬件组件, 349
站, 349

常

常规数据
编辑, 567

撤

撤销, 415
已使用的 CiR 元素, 415

程

程序, 551
下载, 551

处

处理步骤, 337
多项目, 337

触

触发, 218
消息, 218

传

传感器
集成, 50

传输介质, 67, 70
电气, 67, 70
光, 67, 70

传输速率, 66
在 PC 网络中更改, 438

创

创建, 321, 349, 435, 436, 468, 504, 526, 528, 701
CFC, 464, 468
SFC 类型, 543
SFC 实例, 546
SIMATIC 站, 349
从 CFC 创建过程变量类型, 510
工厂层级, 286, 288
过程变量（根据过程变量类型）, 509
模块驱动程序, 504
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模型, 555
模型副本, 559
使用 PCS 7 向导创建多项目, 256
顺序控制系统, 521
顺序控制系统的拓扑, 528
顺序控制系统与 SFC, 521
网络连接, 434, 436
文档, 701
新 SFC, 526
新子网, 435
主数据库, 311
自动创建 OS 画面的块图标, 321
自己的块, 321

存

存储
多项目中的项目, 339

打

打开受访问保护的项目/库, 265

大

大量数据, 484
在过程对象视图中编辑, 563

单

单一控制单元类型, 624

当

当地时间转换, 218

导

导出, 345, 635, 646, 656
操作员文本, 322
过程变量类型, 636
来自工厂工程的数据, 621
模型, 636
硬件配置, 345
与工厂工程组态同步, 656
站组态, 646

导入, 345, 631
操作员文本, 322
工厂数据, 208

过程变量类型, 633
来自工厂工程的数据, 621
模型, 633
数据格式, 143
硬件配置, 345

导入/导出, 484
硬件配置, 645

导入文件, 513
创建, 513
分配过程变量类型, 513

等

等电位联结, 707

第

第三方系统
通信, 36

电

电磁兼容性, 713
确保, 713

电缆屏蔽, 707
引入触点, 707

电气安装, 707
电气传输介质, 67, 70, 81
电子签名, 37

定

定义, 406, 480, 565
CFC I/O, 480
CiR 元素, 406
列, 565
用于硬件配置的项目特定的目录配置文件, 344

对

对过程的影响, 597
对象, 293

插入层级文件夹中, 293
将库中的对象复制到主数据库, 313
主数据库的, 308
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多

多工作站系统
操作站的数量, 50

多项目, 188, 258, 270, 336, 337, 442, 617, 697, 698
PH 的其它功能, 300
SIMATIC BATCH 的规则, 190
保存版本化数据, 698
步骤概述, 337
插入 SIMATIC 站, 270
插入项目, 259
创建, 301
工作的规则, 336
归档, 695
合并交互项目网络, 442, 617
名称, 258
使用 PCS 7 向导创建, 256
使用归档服务器插入单个项目, 260
通过添加项目进行扩展, 258
外部归档服务器的规则, 190
项目的分散编辑, 334
重新获取, 697
组态, 189

多项目工程组态, 185, 334
多项目中的项目

存储, 339
多用户工程组态, 186, 195, 336
多语言

管理文本, 267

翻

翻译, 319
消息文本, 319

防

防护等级 － 外壳保护, 716
防雷, 705
防雷区, 705
防止未经授权的访问, 37

工厂, 37

访

访问 PCS 7 OS
通过 PCS 7 Web 客户端, 109

访问保护, 37, 182, 263, 265
打开项目/库, 265

分

分布
项目图表, 192

分布式 I/O, 101, 131, 369, 381
概述, 131
连接 HART 设备, 101
在危险区域中集成, 140
组件, 131
组态 ET 200M, 369
组态 ET 200SP HA, 381

分布式工程组态
分支与合并, 192
在网络中组态, 194

分配, 292, 297, 353, 562
PH 中的对象, 297
符号名, 369, 381
输入及输出地址的符号, 353
以后将副本分配给模型, 562
用于修复过程变量, 520

分配参数, 435, 470
块, 470
新子网, 435

分散编辑后的项目, 616
SIMATIC BATCH 组态规则, 615
合并, 615
外部归档服务器组态规则, 615
移动到中央工程师站：, 616

分散编辑项目, 334

敷

敷设电缆, 707

服

服务, 46
支持, 46

符

符号, 353
为输入和输出地址分配符号, 353

符号连接名, 450
符号名, 369, 381

分配, 369, 381
符合 EMC 的 PCS 7 安装, 713
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附

附加外壳, 716
附加组件

声卡, 114
信号模块, 114

复

复制, 294, 297, 560, 566
SFC, 540
对象到主数据库, 313
模型副本, 560
图表, 297
在 PH 中, 294

副

副本, 562
以后分配给模型, 562

概

概念, 346
地址分配, 346

概述, 117
AS 组件, 117
I/O、分布式和中央, 136
PCS 7 组态任务, 249
重复工艺功能, 145

高

高级工程组态系统, 621
高精度时间戳, 228
高可用性自动化系统, 124, 362

技术规范, 119
可能的使用情况, 135
组态, 362

高可用性总线, 77
高可用性组件, 54

建议采用, 59
高效工程组态

对象, 142
功能, 142

根

根据 ISA-88 在层级文件夹中定义类型, 302

更

更改, 176, 317, 419, 437, 443, 547, 597, 655
CiR 的组态规则, 176
ES 日志, 669
RUN 模式下的组态, 597
分布式 I/O 的组态, 138
过程变量类型, 511
集中更改 SFC 类型, 547
记入更改日志中, 672
节点地址, 437
块 I/O 属性, 317
模块的属性信号分配, 655
通道的参数分配, 419
网络组态, 443
与以前版本相比, 17
运行中 CiR, 176
中央, 197

更改参数设置, 416
参数设置, 416

更改日志, 672
更新, 655, 659

OS 服务器数据, 659
SFC 类型, 315
块类型, 315
已导入的站组态, 655
自动创建 OS 画面的块图标, 321

工

工厂, 71, 606
PROFIBUS 诊断, 91
防止未经授权的访问, 37
以太网管理级, 71
组态显示, 606

工厂保护
功能, 37
组件, 37

工厂层级, 212, 292, 294, 297, 299, 302
创建, 286, 288
分配对象, 297
获得画面层级和 OS 区域, 212
检查一致性, 299
扩展, 292
命名约定, 292
取消分配, 297
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设置, 290
有关复制和移动的注意事项, 294
组态, 287
组态步骤, 286

工厂规模, 48
工厂结构

PCS 7 工厂, 147
规划, 44

工厂视图
功能, 237
主数据库, 237
组态, 237

工厂数据
导入, 208
重复使用, 208

工厂总线
数据交换, 164

工程, 656
同步工程数据, 656

工程师站, 273
插入, 273
组态, 155, 273

工程组态
在网络中, 336
中央和工厂范围, 178

工程组态系统, 155
工业以太网, 64
工作原理, 376

冗余 I/O 模块, 376

功

功能, 40
导入/导出助手 (IEA), 628
归档过程数据, 42
验证, 40
用于访问保护, 37

功能标识符, 631
功能单元, 624

共

共享声明, 591
保存, 331
编辑, 591

故

故障安全自动化系统, 363
PCS 7 的运行安全性, 56
建议采用, 59

可能的使用情况, 135
类型, 121
应用, 127
组态, 363

管

管理级, 71
规划以太网, 71

管理文本
多语言, 267

光

光传输介质, 67, 68, 70
光链路模块, 68
光总线端子, 68

归

归档, 694
BATCH, 42
WinCC, 42
多项目, 695
功能, 42
过程数据, 42
换出, 42
批生产数据, 42
项目主数据, 695
组件, 42

归档服务器, 112, (另请参见外部归档服务器)
插入, 282
组态, 282

规

规划, 79
工厂结构, 44
开始之前, 26
使用 PROFIBUS 的现场级, 80
在以太网上诊断, 79

规划工厂结构, 44
源文件, 44

规则, 292, 336
PH 名称, 292
针对在多项目中工作, 336
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过

过程变量, 369, 381, 517
编辑, 516
采用, 517
插入到项目中, 513
使用, 625
使用 IEA, 625
通过过程变量类型创建, 509
同步, 519
与控制模块相比, 506
自动创建, 515

过程变量类型, 145, 513, 628
创建, 510
导出, 636
导入, 633
定义, 201
分配导入文件, 513
更改, 511
集中组态, 201
使用, 201, 327
修复分配, 520
移植到控制模块类型, 506

过程对象
编辑, 48
返还许可证, 500
计数, 500
显示统计信息, 502
注册, 500

过程对象视图, 566
编辑大量数据, 563
编辑过程变量, 516
测试, 592
测试模式, 675
查找, 566
对象, 239
功能, 239
替换, 566
组态, 239

过程对象统计信息, 502
过程控制, 40

验证, 40
过程类型

非连续, 34
连续, 34

过程数据
归档, 42

过程映像, 357
设置, 357

过滤, 564
显示的对象, 564

过压保护, 707

合

合并, 442, 617, 618
多项目中的交互项目网络, 442, 617
分散编辑后的项目, 615
交互项目连接, 618
项目间连接, 458
项目图表, 192

互

互连, 470
块, 470

互锁, 483

画

画面层级, 212
从 PH 获得, 212

画面对象
编辑, 584

换

换出
归档, 42

回

回读, 663

混

混合容量, 50

获

获得, 212
来自 PH 的 OS 区域, 212
来自 PH 的画面层级, 212

机

机柜结构, 703
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基

基本元素
用于重复使用, 197

基本组态, 271
在 PCS 7 工厂中, 153
组态硬件, 271

基准电位, 707

激

激活, 368
ES 日志, 669
确认触发报告, 368
系统冗余 R1, 135

集

集成
设备数量, 50
危险区域中的分布式 I/O, 140
执行器数量, 50

集中式 I/O, 131
集中组态, 201

记

记录, 333
库对象, 333

监

监视, 606
连接的 AS 和 OS, 606
设备状态, 606

检

检查, 299, 440
PH 的一致性, 299
网络一致性, 440

简

简介, 403
CiR, 403
在 RUN 模式下组态, 403
组态, 348

建

建议, 404
CiR, 404
使用故障安全和高可用性组件, 59

交

交互项目 S7 连接, 619
在 AS 和 OS 组件之间, 619
组态, 619

交互项目连接, 618
合并, 618

交互项目网络, 617
在多项目中合并, 617

交换, 641
数据与 MS Excel/Access, 641

交换技术
SCALANCE X, 72

接

接地, 707

节

节点地址, 437
更改, 437

介

介质冗余协议, 393

禁

禁用
ES 日志, 669

控

控制模块
与过程变量相比, 506

库

库, 306, 312
版本, 295
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测试对象, 333
存储位置, 255
使用, 312
使用主数据库, 204

库对象, 333
测试, 333
记录, 333

块

块, 320, 469, 470, 473
编辑, 571
插入到 CFC 中, 469
互连, 470
设置语言, 320
项目特定的修改, 316
运行属性, 473
组态, 470

块 I/O 属性, 317
更改, 317

块类型
更新, 315
使用, 198

块驱动程序, 503
块图标

大小, 301
更新, 301
生成, 214, 301
使用, 198
新建, 301
自动创建/更新 OS 画面, 321

框

框式安装, 703

扩

扩展, 258, 262
使用 PCS 7 向导设置项目, 181, 261
通过添加项目扩展多项目, 258
通过添加组件扩展项目, 262

扩展的导入, 655
扩展总线系统, 52

连

连接, 83, 87, 100, 101, 104, 106, 109, 503
HART 设备到分布式 I/O, 101
I/O 设备, 130

I/O 与通道块, 503
Modbus, 103
PROFIBUS DP 节点, 83
PROFIBUS PA 到 PROFIBUS DP, 87
PROFIBUS PA 到 PROFINET IO, 100
到 MIS/MES, 106
到工厂管理级, 613
连接到 PROFIBUS DP 的 AS-i 总线, 104
通过 OPC 连接 HMI 系统, 109
通过 OpenPCS 7 到 IT 世界, 108
通过 SIMATIC IT 到 IT 世界, 106
网络节点, 75
以太网, 75
组态, 445

连接 PC 组件, 113
连接表, 455
连接伙伴, 445
连接类型, 445
连接组态, 445

链

链接
逻辑, 483

列

列, 565
定义, 565
排序, 565
设置, 565
显示/隐藏, 565

列颜色
消息颜色, 224

路

路径控制功能, 611
组态, 611

逻

逻辑矩阵编辑器
逻辑运算, 483

逻辑运算, 483

面

面板
使用, 198
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名

名称
项目, 258

名称或 IO 设备
参数, 386

命

命名的连接, 450
命名约定

项目名称, 258

模

模板, 145
模块

插入, 369, 381
模块的属性信号分配, 655

更改, 655
模块驱动程序, 504

创建, 504
模型, 329, 558, 560, 562, 624, 628, 636

创建, 555
导出, 636
导入, 633
复制, 560
删除, 560
生成副本, 559
使用, 203, 329, 625
使用 IEA, 625
使用 SIMATIC Manager, 560
以后分配副本, 562
用于创建副本, 562

默

默认参数, 363
CPU 的, 363
PCS 7 项目 CPU 的, 122

默认值, 255
项目/库的存储位置, 255
在 SIMATIC Manager 中, 255

目

目录规约
硬件配置的项目特定的目录配置文件, 344
硬件组态的项目特定目录规约, 206

内

内部防雷, 705

耦

耦合, 87, 100, 104, 109, 713
Modbus, 103
PROFIBUS PA 到 PROFIBUS DP, 87
PROFIBUS PA 到 PROFINET IO, 100
连接到 PROFIBUS DP 的 AS-i 总线, 104
耦合机制, 713
通过 OPC 连接 HMI 系统, 109

排

排序, 564, 565
列, 565
显示的对象, 564

平

平衡信号电路, 707

屏

屏蔽, 707
屏蔽支持, 707

其

其它功能
多项目中 PH 的, 300

启

启动, 271
硬件的基本组态, 271

签

签名
电子, 37

强

强制, 491
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趋

趋势显示, 494
在测试模式下, 494

取

取消, 297
分配对象 - PH, 297

全

全集成自动化, 147

确

确保, 713
电磁兼容性, 713

确认触发报告 - ATR, 227, 368
确认概念, 218, 227

冗

冗余, 77, 84, 85, 393
IO 冗余, 396
PROFIBUS 网络布局, 84
将非冗余设备连接到冗余系统, 85
系统冗余, 395
以太网的结构, 77

冗余 IO, 396
冗余 PROFIBUS DP, 85

连接非冗余设备, 85
冗余概念, 54
冗余连接, 459

组态, 459
冗余总线, 77

删

删除, 260, 410, 560, 566
CiR 元素, 410
SFC, 540
多项目中的项目, 260
模型, 560

设

设备
集成, 50

设备属性, 590
编辑, 590

设备状态, 606
监视, 606
设备状态监视, 606

设备状态监视, 606
监视, 606

设置, 254, 320, 357, 366, 565
AS 上的时间同步, 366
CPU 的属性, 354
PH, 301
本地 PC 站, 254
工厂层级, 290
过程映像, 357
块的语言, 320
列, 565
默认值, 255
显示设备的语言, 320

设置项目
使用 PCS 7“新建项目”向导, 180

生

生成
操作员文本, 214
块图标, 214

声

声信令, 229

时

时间, 366
AS 上的同步, 366

时间戳, 367
时间戳 (10 ms), 367
时间同步, 364, 366

AS 上的设置, 366
原理, 364

识

识别
重复功能, 623
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使

使用, 131, 200, 312, 329, 682
IEA 文件, 639
SFC 类型, 200
Version Cross Manager, 682
分布式 I/O, 131
故障安全自动化系统, 121
过程变量, 625
集中式 I/O, 131
块类型, 198
块图标, 198
面板, 198
模型, 203
使用过程变量类型, 327
使用库, 312
使用模型, 329, 625
主数据库, 204

使用 PCS 7 应用程序, 245

视

视图, 243
工厂视图, 237
关系, 242
过程对象视图, 239
交叉视图功能, 243
组件视图, 234

视图间的关系, 242

输

输入/输出模块, 376
安装程序, 376
工作原理, 376
组态, 376

输入和输出地址, 353
分配符号, 353

属

属性
ET 200, 136
ET 200iSP, 136
ET 200M, 136
ET 200pro, 136
ET 200S, 136
ET 200SP, 136
ET 200SP HA, 136

数

数据, 638, 641
ES 中的 IEA 文件, 638
采用工厂工程组态中的, 621
与 MS Excel/Access 交换, 641

数据备份, 697
数据格式

导入, 143
数据交换, 641

PCS 7 COMOS, 621
PCS 7 和 AdvES, 621
通过终端总线和工厂总线, 164
有关工厂工程组态, 621
与 MS Excel/Access, 641

数据链接
到其它系统, 100

顺

顺控程序属性, 527
组态, 527

顺序控制系统
创建, 521
组态, 524

顺序控制系统的拓扑, 528
创建, 528

塑

塑料光纤电缆, 68

缩

缩放 PCS 7, 47

锁

锁定
锁定消息属性以免其在块实例中发生更改, 319

特

特性和偏差, 175
与产品的安装说明相比, 175
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通

通道的参数分配, 419
更改, 419

通道块, 503
通信, 165, 446

第三方系统, 36
对两个 SIMATIC 站之间的通信进行组态, 446
使用终端总线和系统总线, 165
通过终端总线和工厂总线, 164
通信伙伴, 445
网络, 62
总线系统, 62

通信处理器, 272, 351
插入, 272, 351

通信连接, 62
连接类型和连接伙伴, 445
使用 SIMATIC NET, 62

同

同步, 364, 366
AS 上的日时钟, 366
过程变量, 519

外

外部防雷, 705
外部归档服务器

Process Historian, 282
多项目, 282, 615

完

完整下载
更改后的 AS, 252
更改后的 OS, 252

网

网络, 63, 436, 442
创建和组态连接, 436
接口 AS 站, 75
接口 PC 站, 75
应用领域, 63
用于通信, 62
在多项目中合并, 442
组态冗余网络, 442
最大传输率, 66

网络连接
创建, 434

网络组态, 439, 443
保存, 439
更改, 443

维

维护站, 157
插入, 274
诊断, 689

位

位置代号, 631

文

文本
导出/导入, 322
相关文本, 322

文本互连, 461, 558
由几个用户组态, 461

文本列表, 322
文档, 694, 701, 702

访问选项, 18
项目, 701
用途, 17
用于规划和组态, 18
有效性, 17
转换成 PDF 文件, 702

系

系统
选择, 29
要使用, 29

系统规划, 26
系统冗余, 395

Typ R1 激活, 135

下

下载, 283, 488, 551, 595, 597
PC 站, 283
程序, 551
将 CFC 下载到 CPU, 488
所有 PLC, 660
在 CPU RUN 模式下的组态更改, 597
组态到 CPU, 595
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下载更改, 473, 488, 547, 551, 660
失去下载更改功能, 252

下载前比较, 486
CFC, 486
SFC, 550

显

显示
非联网站, 434
联网站, 434
消息，自动, 226, 304, 497

显示/隐藏, 565
列, 565

显示非联网站, 434
显示联网站, 434

现

现场设备, 679
测试, 679

现有模块, 416
更改参数设置, 416

限

限制
PCS 7 项目 CPU 的, 122
对于 IEA, 637

项

项目, 260, 262, 339, 341, 616
从多项目中删除, 260
存储位置和所需权限, 255
继续分散编辑, 341
将项目移动到分布式工程师站, 339
名称, 258
使用 PCS 7 向导进行扩展, 181, 261
使用重组保存, 687
通过添加组件进行扩展, 262
移动到中央工程师站：, 616

项目/库的存储位置
设置, 255
设置访问权限, 255

项目版本
比较, 685

项目间连接
合并, 458

项目库, 306

项目数据, 698, 700
保存版本化数据, 698
使用版本 ID 进行重新获取, 700

项目特定
为硬件组态定义目录规约, 206

项目特定的
为硬件组态定义目录规约, 344
修改块, 316

项目文档, 701
创建, 701

项目主数据, 697
归档, 695
重新获取, 697

消

消息, 218, 319
编辑, 581
触发, 218
翻译消息文本, 319
来自系统图表中具有消息功能的块, 304
消息缓冲区, 218
在 SFC 中组态, 542
自动显示/隐藏, 226, 304, 497
组态, 218

消息类别, 216, 221
用户组态的, 216

消息列表, 219
消息属性

锁定块实例的更改, 319
消息文本, 319

翻译, 319
消息系统

导入/导出组态, 224
基本概念, 216
消息类别, 216, 221
消息类别，用户组态的, 216
重要方面, 219
组态, 224

消息颜色
列颜色, 224

消息组态
重要方面, 219

信

信号, 577
信号 (Signals)

编辑, 577
信号电路, 707

平衡, 707
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信号模块, 218, 376
信令, 229

光, 229
声音, 229

修

修改, 478, 535
操作参数, 535
项目特定的块, 316
运行属性, 535
运行顺序, 478

许

许可证
过程对象计数, 501
取消注册过程对象, 502

许可证信息, 499, 502

选

选项
编译和下载, 664

选择
要使用的系统, 29
组件, 34

选择标准
自动化系统, 115

验

验证, 40
符合 21 CFR 第 11 部分, 40
功能, 40
过程控制, 40
组件, 40

要

要求, 376
组态冗余 I/O 模块, 376

要使用的系统
查找, 29
选择, 29

一

一致性, 299, 369, 381, 440, 687, (测试)
错误, 369, 381
检查 PH, 299
检查网络, 440

一致性检查, (一致性)

移

移动, 294, 339, 566, 616
SFC, 540
将分布式工作站上编辑过的项目移动到中央工程师
站, 616
将项目移动到分布式工程师站, 339
在 PH 中, 294

已

已导入的站组态, 655
更新, 655

已使用的 CiR 元素, 415
撤销, 415

以

以太网, 64, 71, 75, 77
冗余网络的组态, 77

易

易爆环境 Zone 2, 712

引

引入触点, 707
电缆屏蔽, 707

隐

隐藏
消息，自动, 226, 304, 497

应

应用
附加光学组件, 114
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附加声学组件, 114
自动化系统, 115

应用领域, 63
网络, 63

硬

硬件/软件
分配, 211

硬件配置, 208, 343, 345, 349
创建 SIMATIC 站, 349
导出/导入, 345, 645
高精度时间戳, 367
项目特定的目录规约, 206

硬件与软件之间的交互, 211
硬件组件, 349

插入, 349

用

用户可组态消息类别
导入/导出组态, 224
消息类别, 221

用户数据管理, 37

优

优化, 476
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在 PROFIBUS 上使用, 91
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执行器
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指
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中央、工厂范围的工程组态, 178
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重
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重复使用
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对象, 308
块, 313
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子
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创建和组态, 435

自
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自动化系统, 117
高可用性, 119
高可用性组件, 124
故障安全, 121
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组件, 117

自己的块, 321
创建, 321

自协商, 438

字
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总

总线系统, 63
参数, 63
应用领域, 52, 63
用于通信, 62
最大传输率, 66
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组

组件, 40, 117
避免生产损失, 54
高可用性, 54
高可用性自动化系统, 124
故障安全, 56
故障安全自动化系统, 127
归档过程数据, 42
属于自动化系统, 117
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验证, 40
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组件视图
AS 组态, 234
OS 组态, 234
Route Control 组态, 234
多项目工程组态, 234
功能, 234
硬件配置, 234

组态, 77, 90, 218, 271, 273, 283, 346, 349, 362, 363, 
369, 381, 403, 423, 425, 426, 436, 442, 446, 450, 459, 
461, 527, 531, 533, 595, 597, 603, 611, 619, 713

AS 范围的互连, 475
AS 功能, 460
AS 和 OS 之间的交互项目连接, 619
AS 和 PC 站的, 270
AS 运行时间测量, 496
BATCH 站, 277
CFC, 466
CFG 文件的结构和内容, 647
IE/PB Link, 426
IEA 文件, 642
OpenPCS 7 站, 161, 281
OS 功能, 603
PA 设备, 426
PC 和 SIMATIC 400 站之间的连接, 450
PC 站, 283
PCS 7 中的基本组态, 153
Route Control 工作站, 279
SFC 中的消息, 542
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SIMATIC BATCH 功能, 608
SIMATIC Route Control, 160
SIMATIC 站, 346
Y Link, 425
Y 耦合器, 425
步 - SFC, 524, 531
操作站, 156, 274
创建 SIMATIC 站, 349
地址分配的概念, 346
分布式 I/O, 369, 381
符合 EMC, 713
概述, 348
高精度时间戳的硬件, 367
高可用性系统, 362
更改分布式 I/O, 138
工厂层级, 287
工程师站, 155, 273
故障安全系统, 363
扩展 CFG 文件, 651
连接, 445
两个 SIMATIC 站之间的通信, 446
路径控制功能, 611
冗余 PROFIBUS PA 网络, 90

冗余连接, 459
冗余网络, 442
冗余以太网络, 77
使用 SIMATIC PDM 组态 HART 设备, 428
顺控程序属性, 527
顺序控制系统, 524
通过 OpenPCS 7 连接到工厂管理级, 613
外部归档服务器, 282
网络连接, 436
下载到 CPU, 595
项目间连接, 456
消息, 218
硬件, 343
由几个用户进行文本互连, 461
在 RUN 模式下 - CiR, 403
在 RUN 模式下下载更改, 597
在网络中, 194
诊断中继器, 423
转移 - SFC, 533
自动化系统, 168
组态手册, 21
组态硬件, 271

组态步骤
创建 SFC, 524

组态更改, 404
允许使用, 404

组态规则, 176
运行中更换设备 CiR, 176

组态任务, 255
PCS 7, 249
创建 PCS 7 项目, 255
设置 PCS 7 项目, 255
使用 I/E 助手, 625
用于创建 CFC, 466

组态手册
组态, 21
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